Защита RDP сервера от перебора паролей

Публикация № 462816

Администрирование - Информационная безопасность

rdp защита Mikrotik

Автоматически добавляет IP адрес атакующего, после определенного в настройках количества неудачных попыток входа в систему, в  фаервол Mikrotik или Брандмауэр Windows (2008 и более).

Консольное приложение, без интерфейса, написанное на Delphi. Программа на основании события вызванного АУДИТОМ ОТКАЗА windows добавляет в фаервол маршрутизатора Mikrotik адрес атакующего компьютера. Имеются настройки количества неудачных попыток входа до блокировки.

Механизм работы:

1) АУДИТ ОТКАЗА с кодом 4625 вызывает в планировщике программу с ключем - IP атакующего.

2) Программа сохраняет этот IP в файле и смотрит количество записей по этому IP

3) При достижении указанного в настройках количества записей IP по SSH отправляет на маршрутизатор Mikrotik/Брандмауэр Windows команду добавления IP в Адрес Лист.

 

Основано на //infostart.ru/public/238981/

Настройка:

1) Заполнить файл settings.ini информацией о маршрутизаторе и типу фаервола. Более подробная информация в файле Readme.txt

2) Создать в фаерволе Mikrotik правило блокировки с IP из группы указаной в п.1.

3) Создать вызываемую задачу для АУДИТА по руководству //infostart.ru/public/238981/

4) В задаче ОБЯЗАТЕЛЬНО указать "рабочую директорию" и параметр запуска программы $(IpAddress) (без кавычек и т.п.) и запуск с повышенными привилегиями.

5) В настройка Конфигурация узла Удаленных рабочих столов (настройки RDP) необходимо выбрать Безопастность - Уровень безопасности - "Уровень безопастности RDP"

 

 

2 недели работы приложениея показали 417 блокированных адресов и 129687 отраженных попыток ввода пароля (количество блокированных соединений в Mikrotik)

Скачать файлы

Наименование Файл Версия Размер
ban_ip.rar

.rar 402,18Kb
50
.rar 1.0.3.3 402,18Kb 50 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. kuzyara 1106 09.03.16 09:05 Сейчас в теме
Скажите ваш ip адрес? Проверю как работает защита;)
3. maters 10 09.03.16 12:33 Сейчас в теме
(1) kuzyara, 89.105.153.125 - можно насиловать :)
2. v_id 101 09.03.16 10:53 Сейчас в теме
Мне вполне достаточно перевесить порт RDP и http://nerderies.blogspot.ru/2012/12/automatically-banning-ips-with-windows.html для подстраховки
4. sergey_twin 29.10.16 10:21 Сейчас в теме
я только не понял откуда винда (в аудите отказа) возьмёт ip адрес атакующего, учитывая что rdp за NATom (за мироктиком), винда увидет только внутренний ip адрес роутера(НАТА) какой нибудь 192.168.0.1(пример). Можете пояснить?
7. dvsidelnikov 17 22.09.19 17:53 Сейчас в теме
как вариант:
http://www.admblog.ru/mikrotik-bruteforce-block/

/ip firewall filter
add action=reject chain=forward comment="Block RDP bruteforce" log=yes \
log-prefix="Blocked - " reject-with=icmp-network-unreachable \
src-address-list="Blocked bruteforcers"
add action=add-src-to-address-list address-list="Blocked bruteforcers" \
address-list-timeout=60m chain=forward comment="RDP bruteforce stage4" \
connection-state=new dst-port=3389 log=yes log-prefix=\
"RDP BRUTEFORCE - " protocol=tcp src-address-list=rdp_bruteforce3
add action=add-src-to-address-list address-list=rdp_bruteforce3 \
address-list-timeout=15m chain=forward comment="RDP bruteforce stage3" \
connection-state=new dst-port=3389 log=yes log-prefix=\
"RDP BRUTEFORCE - STAGE3 - " protocol=tcp src-address-list=rdp_bruteforce2
add action=add-src-to-address-list address-list=rdp_bruteforce2 \
address-list-timeout=15m chain=forward comment="RDP bruteforce stage2" \
connection-state=new dst-port=3389 log=yes log-prefix=\
"RDP BRUTEFORCE - STAGE2 - " protocol=tcp src-address-list=rdp_bruteforce1
add action=add-src-to-address-list address-list=rdp_bruteforce1 \
address-list-timeout=15m chain=forward comment="RDP bruteforce stage1" \
connection-state=new dst-port=3389 log=yes log-prefix=\
"RDP BRUTEFORCE - STAGE1 -" protocol=tcp
8. igriksoft 30.12.19 17:33 Сейчас в теме
9. user812970 08.07.20 04:46 Сейчас в теме
Всем привет! Столкнулся с такой проблемой - не определяется источник (IP адрес) запросов на перебор паролей для доступа по RDP и Ban_IP без определения источника не может внести изменения в сетку. Имеем - терминальный сервак Windows 2008 R2, Провайдер билайн, выделенный IP, в качестве шлюза Apple Time Capsule (проброшен измененный порт), стандартный порт сервера тоже изменен. Как заставить Ban_IP блокировать запросы на перебор?
P. S. Запросы, судя по логам идут с большой частотой...

Прошу вас, помогите пожалуйста.
Прикрепленные файлы:
Оставьте свое сообщение

См. также

Запуск 1С под любым пользователем (без необходимости указания пароля) Промо

Пароли v8 v8::Права 1cv8.cf Абонемент ($m)

Предназначается для запуска сеанса другого пользователя из своего сеанса 1С (если пароль вам неизвестен).

1 стартмани

02.07.2019    22813    240    sapervodichka    0    

Анализ ролей доступа

Роли и права v8 v8::Права ERP2 БП3.0 КА2 Абонемент ($m)

Быстрое определение, каких ролей доступа не хватает и на что влияет выбранная роль.

1 стартмани

06.01.2021    2510    48    yermak    9    

Групповое добавление и удаление ролей из списка профилей

Роли и права v8 v8::Права 1cv8.cf Абонемент ($m)

Подключаемая обработка. Помогает при конструировании профилей доступа пользователей (настройке прав пользователей), экономит время на добавлении/удалении одной и той же роли сразу в нескольких профилях.

1 стартмани

14.12.2020    3602    28    sapervodichka    8    

Подсистема прав доступа к объектам с гибкими отборами (расширение)

Роли и права v8 ERP2 БП3.0 УТ11 КА2 ЗУП3.x Абонемент ($m)

Возможность без доработок конкретизировать пользователям права Просмотра и Изменения объектов базы 1С, установив ограничения с помощью отборов системы компоновки данных.

2 стартмани

02.07.2020    11200    124    sapervodichka    56    

Анализ ролей и прав доступа Промо

Роли и права v8 v8::Права 1cv8.cf Абонемент ($m)

Отчет для анализа ролей и прав с использованием СКД. Формируется в разрезе объектов, ролей, пользователей и прав (чтение, просмотр и т.д.). Позволяет быстро узнать, какие пользователи или роли имеют конкретные права на объекты.

2 стартмани

09.01.2015    33467    2    kser87    7    

Настройка ограничений входа пользователей в базу (расширение)

Роли и права v8 v8::Права 1cv8.cf Абонемент ($m)

Настраиваем для пользователей 1С разрешенное количество открытых сеансов к текущей базе данных 1С в привязке к компьютерам. (У пользователя не будет возможности превысить допустимое количество сеансов или зайти с чужого компьютера).

2 стартмани

19.05.2020    9302    18    sapervodichka    14    

Обозреватель криптографии

Инструментарий разработчика Защита ПО v8 Абонемент ($m)

Отчет для просмотра доступных провайдеров и сертификатов криптографии на сервере и клиенте.

2 стартмани

21.10.2019    11650    14    YPermitin    10    

Завершение работы пользователей

Роли и права v8 1cv8.cf Россия Абонемент ($m)

Завершение работы пользователей с помощью подключения обработчика ожидания.

1 стартмани

02.10.2019    7355    15    user921814    6    

Просмотр прав пользователей Промо

Информационная безопасность v8 1cv8.cf Абонемент ($m)

Обработка наглядно показывает права доступа конкретного пользователя или роли к конкретному объекту метаданных.

1 стартмани

19.10.2012    33565    306    NILS2009    17    

Оптимизация прав ролей

Производительность и оптимизация (HighLoad) Роли и права v8::УФ v8::Права 1cv8.cf Россия Абонемент ($m)

Решение вопроса по неоптимальной настройке (избыточной) ролей, влияющей на производительность системы (потребление оперативной памяти). Алгоритм работы следующий: Выгрузка конфигурации в файлы - Обработка (изменение) файлов прав ролей - Загрузка измененных прав в конфигурацию. Проверено на платформе начиная с 8.3.12.

1 стартмани

09.09.2019    25538    10    toxilamer    11    

Автоматическая блокировка интерфейса 1С при простое в работе пользователя

Информационная безопасность v8::УФ 1cv8.cf Россия Абонемент ($m)

Простой способ реализации автоматической временной блокировки интерфейса программы при низкой активности пользователя некоторое время.

1 стартмани

28.08.2019    8441    8    shalex5    0    

PowerShell из 1С: создание пользователя Active Directory

Информационная безопасность v8 1cv8.cf Абонемент ($m)

Пример создания пользователя Active Directory с помощью PowerShell из 1С.

2 стартмани

27.08.2019    11080    16    wowik    13    

Отключение доступа уволенным пользователям Промо

Информационная безопасность Обработка справочников Администрирование данных 1С v8 v8::Права БП2.0 УПП1 Абонемент ($m)

Давно хотели навести порядок в пользователях? Надоело, что в списке мешаются давно уволенные сотрудники? Тогда эта обработка для Вас!

3 стартмани

15.10.2013    51753    109    VBod    17    

Вход в программу под нужным пользователем из карточки пользователя [Расширение]

Информационная безопасность v8::УФ v8::Права 1cv8.cf Абонемент ($m)

При проверке прав пользователей и тестировании требуется быстро войти в программу под пользователем (не меняя пароль пользователю). Для этого в карточку пользователя добавлена кнопка "Запустить сеанс".

1 стартмани

03.07.2019    4870    22    WinnerOnLine    3    

Сравнение доступа профилей, ролей, пользователей по всем объектам конфигурации 8.3, 8.2 (обычные формы "ОФ" и управляемые формы "УФ") (выборочно)(НАБОР УТИЛИТ)

Роли и права v8 v8::УФ v8::Права 1cv8.cf Абонемент ($m)

Сравнение профилей доступа по всем объектам конфигурации 8.3 (полноценно функционирует с версии 1С:Предприятия 8.1.10 - 8.3.X). Очень хотелось иметь обработку, которая бы показывала различия профилей доступа по каждому конкретному объекту конфигурации и по всем сразу. Желание было воплощено в данной обработке.

1 стартмани

23.06.2019    7552    28    AlexandrSmith    0    

Подсистема динамических прав

Информационная безопасность v8::Права 1cv8.cf Абонемент ($m)

Подсистема прав, позволяющая в реальном времени (без назначения ролей, перезапуска 1с, изменения конфигурации) менять права пользователя: Просмотр, Создание, Изменение, Проведение, Отмена проведения, Изменение проведенных, Неоперативное проведение. Существенно упрощает управление правами в базах с большим количеством пользователей. Версия платформы 8.3.12.1685.

2 стартмани

10.04.2019    9046    16    itmind    53    

Права доступа ролей Промо

Роли и права v8 v8::Права 1cv8.cf Абонемент ($m)

Отчет по правам доступа ролей, выводит в удобной краткой форме права доступа в разрезе ролей на интересующие нас объекты метаданных или объекты метаданных, к которым есть доступ у интересующей нас роли. Показывает наличие RLS и позволяет сравнить роли. Отображает использование роли в профилях групп доступа/группах доступа.

1 стартмани

05.02.2018    19534    130    Serge R    2    

Запуск 1С под другим пользователем без ввода пароля

Роли и права v8 v8::УФ v8::Права 1cv8.cf Абонемент ($m)

Для проверки настроек ролей и прав или для отладки можно использовать это решение.

1 стартмани

22.03.2019    8880    40    pridecom    0    

Наследование ролей в профилях групп доступа в конфигурациях на базе БСП

Практика программирования БСП (Библиотека стандартных подсистем) Роли и права v8 v8::Права 1cv8.cf Абонемент ($m)

С помощью данной доработки можно создать новый профиль групп доступа, с наследованием ролей от базового (поставляемого) профиля. В созданном профиле можно добавить или исключить какие-либо роли относительно базового профиля.

1 стартмани

15.03.2019    10816    14    ids79    1    

PasswordHashViewer - просмотр хэшей пользовательских паролей

Информационная безопасность v8 1cv8.cf Абонемент ($m)

Программа для просмотра хэшей паролей пользователей в файловых и клиент-серверных базах 1С. Зачем это нужно? Для их проверки на криптостойкость.

1 стартмани

25.02.2019    6978    12    GeraltSnow    5    

Регистры правил [Расширение] Промо

Инструментарий разработчика Информационная безопасность v8 v8::Права УТ11 Абонемент ($m)

Регистры правил - права доступа, запрет редактирования, автоподстановка реквизитов и т.д.

10 стартмани

15.03.2018    19220    28    33lab    3    

Обезличивание базы ЗУП 3.1.*

Информационная безопасность Зарплата Управление персоналом (HRM) v8 v8::СПР ЗУП3.x Абонемент ($m)

Обработка по перемешиванию/скрытию конфиденциальной информации в базе ЗУП.

1 стартмани

05.02.2019    11780    69    Skin123    11    

Наводим порядок в Active Directory с помощью ЗУП / ЗИКГУ 3.1 (идентификация, отключение и актуализация учетных записей пользователей)

Информационная безопасность Администрирование данных 1С v8 v8::СПР ЗКБУ ЗУП3.x Россия Абонемент ($m)

Продолжаем использовать ЗУП 3.1 совместно с LDAP во имя автоматизации работы системного администратора. В этот раз займемся аудитом учетных записей. Обработка производит сопоставление учетной записи с данными сотрудников из ЗУП, причем с учетом недавних событий (для перехода на ЗУП 3.1 чаще всего используется рекомендованный перенос, не включающий уволенных сотрудников) есть возможность использовать объединенные с помощью COM-соединения данные ЗУП 2.5 и ЗУП 3.1. Также в данной обработке есть возможность массовой корректировки, заполнения данных и отключения учетных записей. Перед использованием обработки для душевного спокойствия необходимо сделать резервную копию Active Directory любым удобным способом. Протестировано на ЗУП 3.1.6 - 3.1.8.

5 стартмани

01.02.2019    9917    44    Туки Туки    14    

Получение логина и пароля ИТС из базы 1С

Информационная безопасность v8 v8::УФ 1cv8.cf Абонемент ($m)

Обработка показывает пароль от сайта https://releases.1c.ru прямо из базы 1С.

1 стартмани

02.11.2018    28780    139    Timur.V    21    

Управление пользователями, редакция 3.0 Промо

Журнал регистрации Роли и права v8 1cv8.cf Абонемент ($m)

Программа создана для управления пользователями нескольких баз в одной программе. Управляемые формы, интерфейс такси.

10 стартмани

16.09.2015    26850    29    cyberintegration    13    

Особенность при создании своих ролей в конфигурациях на управляемых формах

Информационная безопасность v8 v8::УФ v8::Права 1cv8.cf Россия Абонемент ($m)

Столкнулся с небольшой проблемкой при создании "своих" ролей в конфигураторе и добавлении их пользователям. Пользователю не добавляются созданные в конфигураторе роли, 1С 8.3, Управляемые формы. Гуглил много, ответа толкового не нашёл, поэтому пришлось разбираться самому и как результат, решил поделиться опытом. Возможно, кому-то пригодится.

1 стартмани

29.10.2018    16737    11    d.saladin    15    

Программа для управления Bitlocker

Информационная безопасность Россия Абонемент ($m)

Управление Bitlocker Windows 7-10 (x32-x64), работает в WindowsPE.

1 стартмани

26.10.2018    5969    0    gortrex    0    

Запуск платформы под любым пользователем без смены пароля

Информационная безопасность v8::УФ 1cv8.cf Россия Абонемент ($m)

Обработка позволяет запускать 1С от любого пользователя без смены пароля.

1 стартмани

12.09.2018    8046    29    bmk74    9    

Включение и выключение регистрации отказа в доступе если "У пользователя не достаточно прав над операцией с базой данных". Промо

Информационная безопасность Журнал регистрации v8 1cv8.cf Абонемент ($m)

Включает (выключает) регистрацию событий отказа доступа в журнале регистрации.

1 стартмани

12.01.2011    36848    364    nexts    32    

Запрет на запуск более одного сеанса для одного пользователя в 1С: Предприятие 8.3 ЗУП, БП, КА, ERP, УАТ и т.д.

Информационная безопасность v8 1cv8.cf Россия Абонемент ($m)

Ограничение запуска 1С: Предприятие нескольких сеансов под одним пользователем. Функционал разработан через расширение, конфигурацию с поддержки снимать НЕ НУЖНО. Функционал работает в файловом и клиент-серверном варианте работы конфигурации. Платформа 8.3.12.1529 Конфигурации КА 2.4.5.71; ERP 2.4.5.54; БП 3.0.64.21; ЗУП 3.1.7.87 (это релизы на которых была произведена проверка, так же будет работать на всех стандартных конфигурациях 1С с режимом совместимости Версия 8.3.10)

1 стартмани

29.08.2018    18775    93    mityushov.vv    49    

[Расширения] Управление видимостью разделов для разных пользователей

Работа с интерфейсом Информационная безопасность v8 1cv8.cf Россия Абонемент ($m)

Как скрыть/показать раздел в управляемом приложении используя расширение, на примере БП 3.0

1 стартмани

05.07.2018    14212    14    Alex_E    10    

Анализ и редактирование прав пользователей (управляемые формы)

Информационная безопасность v8 v8::УФ v8::Права 1cv8.cf Россия Абонемент ($m)

В обработке реализовано два отчета - матрица ролей (пересечение ролей и пользователей), и анализ прав на объекты в разрезе пользователей / ролей. Также есть запуск под пользователем с временной подменой пароля и редактирование прав непосредственно в матрице.

2 стартмани

03.07.2018    11415    68    axelerleo    4    

Права пользователей Промо

Информационная безопасность v8 1cv8.cf Абонемент ($m)

Кросс-таблица прав пользователей (подсистема "Управление доступом")

1 стартмани

10.05.2016    29339    103    inspam    4    

Обновление профилей доступа. БСП 2.x

Информационная безопасность v8::Права БП3.0 Абонемент ($m)

Обработка, позволяющая синхронизировать роли обновляемого профиля по исходному профилю, после обновления релиза конфигурации (когда обновляемый профиль создан на основе исходного профиля).

1 стартмани

12.03.2018    9417    20    Darklight    0    

Запуск ИБ 1С под любым пользователем (только для разработчиков/администраторов)

Информационная безопасность v8 v8::Права 1cv8.cf Россия Абонемент ($m)

Когда ведете разработку нового функционала, то есть необходимость протестировать алгоритмы под разными правами. Тогда Вам нужна данная обработка, которая ускорит процесс входа в базу под нужным пользователем.

1 стартмани

28.11.2017    11283    40    Diagnostiks    7    

Перенос настроек пользователей между базами 1С 8.3 (УФ)

Роли и права v8 v8::УФ 1cv8.cf Абонемент ($m)

Задача была – скопировать одну базу в другую, причем перенести список пользователей и настройки пользователей. Потому что в настройках пользователей было очень много хитроумных разукрашиваний и отборов, следовательно, повторять это руками было бы долго. Была написана обработка, которая выгружает настройки пользователей из одной базы в файлы и потом позволяет их загрузить из файлов в другую базу. Можно использовать и для переноса настроек между одними пользователями, если типовое копирование не нравится.

1 стартмани

13.10.2017    25955    274    fixin    30    

Права по ролям Промо

Информационная безопасность v8 1cv8.cf Абонемент ($m)

Отчет выводит установленные права

2 стартмани

16.09.2015    25290    75    nad11    1    

Выгрузка и загрузка пользователей между различными конфигурациями 1С 8.3, включая пароли (Управляемое приложение, обычное приложение, БСП)

Роли и права v8 v8::УФ v8::Права 1cv8.cf Абонемент ($m)

Предназначена для переноса пользователей между различными конфигурациями 1С 8.3, включая пароли. Только для БСП (библиотека стандартных подсистем). Проверено на "Документооборот 2.0", "Управление торговлей 11", БСП 2.3.

4 стартмани

07.07.2017    21162    114    TuneSoft    5    

Как помочь сисадмину при большой текучке кадров

Информационная безопасность v8 v8::СПР v8::Права ЗУП2.5 Россия Абонемент ($m)

Хотелось бы поделиться своим опытом создания пользователей AD из 1С:ЗУП 2.5.

1 стартмани

06.07.2017    14384    7    PhoenixAOD    31    

Создание и удаление пользователей в конфигурациях с БСП

Информационная безопасность v8 1cv8.cf Абонемент ($m)

Быстрое создание пользователей с заранее известными правами в интерактивном режиме и из файла. По одному и списком. Быстрое удаление списком пользователей ИБ и пометка на удаление элементов справочника Пользователи.

1 стартмани

20.06.2017    10711    31    user768334    1    

Анализ ролей доступа (обычная и УФ) Промо

Информационная безопасность v8 v8::УФ 1cv8.cf Абонемент ($m)

Анализ ролей доступа. Определяет доступность к справочникам, документам, отчетам и т.д. Не нужно пересматривать кучу ролей, чтобы понять, что Вам нужно.

1 стартмани

25.08.2015    28362    190    fugu    9    

Просмотр ролей по объектам метаданных конфигурации на 1С 8.3

Роли и права v8 1cv8.cf Россия Абонемент ($m)

Универсальная обработка для просмотра ролей по любому из объектов конфигурации 1С 8.3.для настройки пользовательских интерфейсов по стандартным ролям в конфигурации ERP 2.4, ЗУП 3.1, БП 3.0 и т.д.

1 стартмани

13.04.2017    17840    122    mityushov.vv    11    

Загрузка пользователей в Документооборот 2.х из Active Directory

Документооборот и делопроизводство Информационная безопасность Документооборот и делопроизводство v8::УФ ДО УУ Абонемент ($m)

Обработка облегчит заведение новых пользователей в документооборот, в случае, если у вас есть доменный сервер (Active Directory).

2 стартмани

06.03.2017    15082    60    odineskin2    14    

"Защита от опасных действий" или как снять галочку у всех пользователей

Информационная безопасность v8::Права 1cv8.cf Абонемент ($m)

В новых версиях платформы 1С:Предприятие 8.3 (8.3.9.2033) появилась очень замечательная фишка. Реквизит у пользователя "Защита от опасных действий"

1 стартмани

17.01.2017    31413    120    Tatitutu    12    

Запуск 1С под пользователем без сброса пароля Промо

Информационная безопасность v8 Россия Абонемент ($m)

Обработка позволяет запустить пользовательский режим 1С, не сбрасывая полностью пароль пользователя. Что очень удобно при отладке прав и RLS. Также есть возможность быстро установить пароль 123, и вернуть старый пароль вручную.

1 стартмани

18.11.2013    47602    715    mylogin    38    

Ограничение доступа к 70 счету для БП 3.0

Зарплата Зарплата Роли и права v8::БУ БП3.0 Россия БУ Абонемент ($m)

Ограничение доступа к 70 счету для Бухгалтерии предприятия 3.0 через расширение.

1 стартмани

18.10.2016    18313    130    Evgenij1990    19    

Управление доступом к документам и справочникам

Информационная безопасность v8 БГУ ДО Абонемент ($m)

Расширение, позволяющее управлять доступом к справочникам и документам в Бухгалтерии 3.0 без изменения конфигурации информационной базы.

1 стартмани

16.09.2016    13231    66    sikvel2012    9    

Настройка прав пользователей

Информационная безопасность v8 1cv8.cf Россия Абонемент ($m)

Настройка прав пользователей в УТ 11.2

1 стартмани

26.08.2016    25930    32    shetill    3    

Отчет для анализа прав доступа в разрезах Право/Объект/Роль/Профиль/Пользователь Промо

Информационная безопасность v8 1cv8.cf Абонемент ($m)

Удобный анализ прав доступа в различных разрезах, с промежуточным кэшированием набора данных. Только для конфигураций на БСП.

1 стартмани

16.04.2015    29518    363    unichkin    13    

Просмотр информации о пользователе и его действий в документообороте 8 КОРП

Рабочее место Документооборот и делопроизводство Информационная безопасность Документооборот и делопроизводство v8 ДО Россия Абонемент ($m)

Просмотр информации о свойствах пользователя документооборота, его настройках, персональных данных; созданные им документы, задачи ему, от него, его процессы и т.д. в документообороте 8 КОРП

1 стартмани

03.07.2016    11622    29    diletant    7