Печать Чеков ККМ с помощью компоненты "DatecsECR.TECRFisc".

Публикация № 505160 24.03.16

Учет и отчетность - Кассовые операции

DatecsECR Чек ККМ фискальный регистратор

Обработка подходит для любой конфигурации где есть документы "Реализация товаров и Услуг" и "Чек ККМ". Для  фискальных регистраторов datecs.

Недавно столкнулся с проблемой печати чеков ККМ с помощью компоненты "DatecsECR". Может, кому будет полезна моя публикация. Собственно задача стояла реализовать печать копии чеков ККМ. Углубившись в задачу и в мануал по работе с компонентой DatecsECR, понял, что только по последнему созданному чеку можно напечатать копию. Задача же стоит - печатать копию любого чека.

Для реализации такой возможности нужно где-то хранить номер и дату чека фискального регистратора. Я выбрал самый легкий вариант, в реквизитах документа «Чек ККМ». Если конфигурацию стоит на поддержке, лучше создать отдельный регистр сведений для этих целей.

Если нужно печать только сами чеки из 1С на фискальный регистратор, то дорабатывать ничего не надо.

Обработка не претендует на эталон и выложена для примера печати чеков ККМ, поэтому перед скачиванием посмотрите код, может, такой вариант вам и не подойдет.

Вот код процедуры печати чека:

	
	ПолучитьТаблицуЧеков();
	
	флЕстьОшибка = 0;
	
	ECRFisc=Новый COMОбъект("DatecsECR.TECRFisc");
	

	Для каждого СтрокаДокументаЧекККМ из ТаблицаЧеков цикл 
		
		флЕстьОшибка = 0;
		
		Сообщить("Печать чека для РН "+СтрокаДокументаЧекККМ.Ссылка, СтатусСообщения.Информация);
		                    
		// 1. откроем порт
		Result = ECRFisc.SetComPort(1, 19200);
		ЗаписьЖурналаРегистрации("Печать Чеков КММ на ФР", УровеньЖурналаРегистрации.Информация, Метаданные.Документы.ЧекККМ, СтрокаДокументаЧекККМ.ЧекККМ,
				"Открыли COM порт. "+Строка(СтрокаДокументаЧекККМ.ЧекККМ));
				
		Если Result <> 1 Тогда
		//Если не Result тогда
			Сообщить("Проблем подключения по COM Порту. Код ошибки: "+Строка(Result)+" ! Проверьте подключение!", СтатусСообщения.ОченьВажное);
			Сообщить(" -1 - ошибка (неверный номер порта – меньше 1 или больше 8)" + Символы.ПС+
					 " -2 – неверно указана скорость" + Символы.ПС+
					 " -3 – порт занят" + Символы.ПС+
					 " -4 – невозможно создать блок управления устройством" + Символы.ПС+
					 " -5 – ошибка установки параметров порта" + Символы.ПС+
					 " -7 – проблемы с лицензированием");

			флЕстьОшибка = 1 ;
		Конецесли;
		
		// Находим номер последнего запрограммированного артикула
		Если флЕстьОшибка = 0  тогда 
			Код = ВернутьКодПоследнегоЗапрограммированногоАртикулаФР();
			
			Если Код = 0 Тогда
				// Свойство возвращает информацию о первом запрограммированном артикуле.
				ПервыйКод =  ECRFisc.firstart();
				ЗаписьЖурналаРегистрации("Печать Чеков КММ на ФР", УровеньЖурналаРегистрации.Информация, Метаданные.Документы.ЧекККМ, СтрокаДокументаЧекККМ.ЧекККМ,
					"Прочитали первый запрограммированный артикул. "+Строка(СтрокаДокументаЧекККМ.ЧекККМ));

				Если СтрДлина(ПервыйКод) = 0 тогда
					Код = 1;
				Иначе
					Для номерарт = 2 по 14800 цикл
						//свойство возвращает информацию о следующем запрограммированном артикуле.
						следкод = ECRFisc.nextart();
						Если стрдлина(следкод) = 0 тогда
							Код = номерарт;  прервать;
						Конецесли;
					Конеццикла;   
				Конецесли;
				
				ЗаписьЖурналаРегистрации("Печать Чеков КММ на ФР", УровеньЖурналаРегистрации.Информация, Метаданные.Документы.ЧекККМ, СтрокаДокументаЧекККМ.ЧекККМ,
					"Нашли номер последнего запрограммированного артикула. "+Строка(СтрокаДокументаЧекККМ.ЧекККМ));
					
				ЗаписатьКодПоследнегоДобавленногоАртикулаВФР(Код);
            КонецЕсли;
			
			// Если количество запрограммированных артикулов не привысило максимальное количество, то открываем фискальный чек 
			Если Код <= 14800 Тогда
				
				//откроем фискальный чек на ФР
				result = ECRFisc.OpenFiscReceipt(1,1,"0000");
				Если не Result тогда
					сообщить("Ошибка открытия чека продажи на ФР!");
					флЕстьОшибка = 1 ;
					//продолжить;
				Иначе
					// Объявляем переменные
					старртикул = 0;   ОбщаяСумма = 0; 				   
					
					// Перебираем все строки табличной части товары из Чека ККМ
					ОбъектЧекККМ = СтрокаДокументаЧекККМ.ЧекККМ.ПолучитьОбъект();
					Для Каждого СтрокаТЧ Из ОбъектЧекККМ.Товары Цикл
						//   код = код + 1; 
						Сумма 		= СтрокаТЧ.Сумма;
						Цена 		= Сумма / СтрокаТЧ.Количество;
						ОбщаяСумма 	= ОбщаяСумма + Сумма;
						НаименованиеТовара = Лев(СокрЛП(СтрокаТЧ.Номенклатура),24);
						
						// осуществим продажу по строке в чеке
						// Добавляем артикул
						res = ECRFisc.ProgramArt(192, Код, 1, Цена, "0000", НаименованиеТовара);
						
						ЗаписьЖурналаРегистрации("Печать Чеков КММ на ФР", УровеньЖурналаРегистрации.Информация, Метаданные.Документы.ЧекККМ, СтрокаДокументаЧекККМ.ЧекККМ,
							"Запрограммировали артикул "+Строка(НаименованиеТовара));
						
						// В случае удачного добавления артикула, выводим строку на печать
						Если res Тогда							
							Result = ECRFisc.SellArtCashDS(True, код, строкатч.количество, 0,0);
							
							ЗаписьЖурналаРегистрации("Печать Чеков КММ на ФР", УровеньЖурналаРегистрации.Информация, Метаданные.Документы.ЧекККМ, СтрокаДокументаЧекККМ.ЧекККМ,
								"Напечатали артикул "+Строка(НаименованиеТовара));

							
							Если не Result  тогда
								Сообщить("Ошибка при формировании продажи и выводе информации в строке фискального чека!" ,СтатусСообщения.ОченьВажное);
								флЕстьОшибка = 1;
								
								ЗаписатьКодПоследнегоДобавленногоАртикулаВФР(0);

								// Анулируем фискальный чек
								ECRFisc.ReceiptCancel();
								// Закрываем  com порт
								ECRFisc.CloseComPort(1);
								Прервать;
							Иначе 
								Код = Код +1;
								
								ЗаписатьКодПоследнегоДобавленногоАртикулаВФР(Код);

								Если Код > 14800 тогда
									
									ЗаписатьКодПоследнегоДобавленногоАртикулаВФР(0);
									
									Сообщить("Достигнуто максимальное количество программируемых артикулов = 14800!", СтатусСообщения.Важное);
									Сообщить("Сделайте z-отчет!", СтатусСообщения.Важное);
									// Анулируем фискальный чек
									ECRFisc.ReceiptCancel();
									// Закрываем  com порт
									ECRFisc.CloseComPort(1);
									Прервать;
									
								КонецЕсли;
							КонецЕсли;
						Иначе
							Сообщить("Ошибка при добавлении нового артикула в ФР!" + Символы.ПС + "Товар: "+НаименованиеТовара ,СтатусСообщения.ОченьВажное);
							флЕстьОшибка = 1; 
							
							ЗаписатьКодПоследнегоДобавленногоАртикулаВФР(0);
							
							// Анулируем фискальный чек
							ECRFisc.ReceiptCancel();
							// Закрываем  com порт
							ECRFisc.CloseComPort(1);
							Прервать;

						КонецЕсли;
						
						// Добавляем кодтовара из фискального регистратора в Строку Чека
						СтрокаТЧ.КодТовараФР = Код;
					КонецЦикла;
					
					// Пишем Номер, ИД чека из ФР
					Попытка
						ОбъектЧекККМ.НомерЧекаФР = Строка(ECRFisc.NumbRec());
					Исключение
					КонецПопытки;
                    						
					//регистрация продажи и закрытие чека
					ECRFisc.Payment(0, 0);
					
					ЗаписьЖурналаРегистрации("Печать Чеков КММ на ФР", УровеньЖурналаРегистрации.Информация, Метаданные.Документы.ЧекККМ, СтрокаДокументаЧекККМ.ЧекККМ,
							"Сделали продажу "+Строка(ОбъектЧекККМ));

					// Закрываем фискальный чек
					Result = ECRFisc.CloseFiscReceipt();
					
					ЗаписьЖурналаРегистрации("Печать Чеков КММ на ФР", УровеньЖурналаРегистрации.Информация, Метаданные.Документы.ЧекККМ, СтрокаДокументаЧекККМ.ЧекККМ,
							"Закрыли фискальный чек "+Строка(ОбъектЧекККМ));

					Если не Result Тогда
						Сообщить("Ошибка при закрытии фискального чека!");
						кодошибки = 1 ;
					Иначе
						// Пишем дату и время закрытия чека из ФР
						ПОПЫТКА
							ОбъектЧекККМ.ДатаЧекаФР  = ТекущаяДата();
						Исключение
						КонецПопытки;
					КонецЕсли;
					//закроем порт
					Result = ECRFisc.CloseComPort(1);
					
					ЗаписьЖурналаРегистрации("Печать Чеков КММ на ФР", УровеньЖурналаРегистрации.Информация, Метаданные.Документы.ЧекККМ, СтрокаДокументаЧекККМ.ЧекККМ,
							"Закрыли порт "+Строка(ОбъектЧекККМ));

					Если  не Result Тогда
						Сообщить("Ошибка закрытия порта!");
						кодошибки = 1 ;
					КонецЕсли;
					
					// Пишем Чек ККМ
					ОбъектЧекККМ.Записать(РежимЗаписиДокумента.Запись); 
				КонецЕсли;
			Иначе
				Сообщить("Достигнуто максимальное количество программируемых артикулов!");
				Сообщить("Сделайте z-отчет!");
				
				ЗаписатьКодПоследнегоДобавленногоАртикулаВФР(0);
				
				прервать;
			КонецЕсли;
		КонецЕсли;
		
	КонецЦикла;	
	
	Сообщить("Печать чеков закончена!");	
 

Главная проблема состоит в том, что при добавлении нового чека в фискальный регистратор, нужно хранить код товара на стороне 1С. Иначе нужно при печати каждого чека искать код последнего добавленного товара в фискальный регистратор, что занимает огромное количество времени. Поэтому пока открыта обработка мы храним код последнего добавленного товара в фискальный регистратор. Так же для каждого Чека ККМ записываем Номер и Дату чека из Фискального регистратора. Что касается даты чека из ФР, то у используемой компоненты нет метода для возврата Даты, поэтому в момент печати чека сохраняем ТекущуюДату.

Вот Код печати Копии Чека:

ПолучитьТаблицуЧеков();
	
	флЕстьОшибка = 0;
	
	ECRFisc=Новый COMОбъект("DatecsECR.TECRFisc");
	

	// Перебираем все строки и печатаем отмеченные чеки
	Для каждого СтрокаДокументаЧекККМ из ТаблицаЧеков цикл 

		флЕстьОшибка = 0;
		
		Сообщить("Печать копии чека для "+СтрокаДокументаЧекККМ.Ссылка, СтатусСообщения.Информация);
		
		// 1. откроем порт
		Result = ECRFisc.SetComPort(1, 19200);
		
		Если Result <> 1 Тогда
			Сообщить("Проблем подключения по COM Порту. Код ошибки: "+Строка(Result)+" ! Проверьте подключение!", СтатусСообщения.ОченьВажное);
			Сообщить(" -1 - ошибка (неверный номер порта – меньше 1 или больше 8)" + Символы.ПС+
					 " -2 – неверно указана скорость" + Символы.ПС+
					 " -3 – порт занят" + Символы.ПС+
					 " -4 – невозможно создать блок управления устройством" + Символы.ПС+
					 " -5 – ошибка установки параметров порта" + Символы.ПС+
					 " -7 – проблемы с лицензированием");

			флЕстьОшибка = 1 ;
		Конецесли;
		
		// Если подключили com порт, то открываем на печать не фискальный чек
		Если флЕстьОшибка = 0  тогда 
				
			//откроем нефискальный чек на ФР
			Result = ECRFisc.OpenNonFiscReceipt();
			Если не Result тогда
				Сообщить("Ошибка открытия нефискального чека на ФР!");
				флЕстьОшибка = 1 ;
			Иначе
				// Объявляем переменные
				ОбщаяСумма = 0;
				
				// Печатаем шапку чека
				Result = ECRFisc.PrntNonFiscal("Копия Чека № "+СокрЛП(СтрокаДокументаЧекККМ.ЧекККМ.НомерЧекаФР));
				Попытка
					ДатаЧекаФР = СтрокаДокументаЧекККМ.ЧекККМ.ДатаЧекаФР;
					Result = ECRFisc.PrntNonFiscal("от "+СокрЛП(ДатаЧекаФР));
				Исключение
				КонецПопытки;
				Result = ECRFisc.PrntNonFiscal("");
				
				// Перебираем все строки табличной части товары из Чека ККМ
				Для Каждого СтрокаТЧ Из СтрокаДокументаЧекККМ.ЧекККМ.Товары Цикл
					Сумма 		= СтрокаТЧ.Сумма;
					Цена 		= Сумма / СтрокаТЧ.Количество;
					ОбщаяСумма 	= ОбщаяСумма + Сумма;
					НаименованиеТовара1 = Лев(СтрокаТЧ.Номенклатура,24);
					НаименованиеТовара2 = Сред(СтрокаТЧ.Номенклатура,25, 24);
					
					// Выводим коментарий в нефискальный чек
					Result = ECRFisc.PrntNonFiscal(НаименованиеТовара1);
					Если НЕ ПустаяСтрока(НаименованиеТовара2) Тогда
						Result = ECRFisc.PrntNonFiscal(НаименованиеТовара2);	
					КонецЕсли;
					
					Result = ECRFisc.PrntNonFiscal(Формат(СтрокаТЧ.Количество,"ЧЦ=7; ЧДЦ=2")+ " " + 
							СокрЛП(СтрокаТЧ.ЕдиницаИзмерения) + "  х"+Формат(Цена,"ЧЦ=10; ЧДЦ=2")+
							" = "+Формат(Сумма,"ЧЦ=10; ЧДЦ=2"));

					Если не Result  тогда
						Сообщить("Ошибка при печати нефискального чека!" ,СтатусСообщения.ОченьВажное);
						флЕстьОшибка = 1; 
						// Закрываем нефискальный чек
						ECRFisc.CloseNonFiscReceipt();
						// Закрываем  com порт
						ECRFisc.CloseComPort(1);
						Прервать;
					КонецЕсли;
				КонецЦикла;
				
				// Выводим общую сумму по чеку
				Result = ECRFisc.PrntNonFiscal("------------------------");
				Result = ECRFisc.PrntNonFiscal("СУММА"+Прав("                        " +Формат(ОбщаяСумма,"ЧЦ=10; ЧДЦ=2"),19));
				Result = ECRFisc.PrntNonFiscal("ПДВ А  0,00%         0,00");
				Result = ECRFisc.PrntNonFiscal("Сумма ПДВ"+Прав("                        " +Формат(СтрокаДокументаЧекККМ.Ссылка.Товары.Итог("СуммаНДС"),"ЧЦ=10; ЧДЦ=2"),15));
				Result = ECRFisc.PrntNonFiscal("------------------------");
				Result = ECRFisc.PrntNonFiscal("     СЛУЖЕБНЫЙ ЧЕК     ");
				
				// Закрываем нефискальный чек
				Result = ECRFisc.CloseNonFiscReceipt();
				Если не Result Тогда
					Сообщить("Ошибка при закрытии нефискального чека!");
					кодошибки = 1 ;
				КонецЕсли;
				
				//закроем порт
				Result = ECRFisc.CloseComPort(1);
				Если  не Result Тогда
					Сообщить("Ошибка закрытия порта!");
					кодошибки = 1 ;
				КонецЕсли;
			КонецЕсли;
		КонецЕсли;
		
		Если кодошибки = 0 Тогда
			СтрокаДокументаЧекККМ.флНапечатать = ложь;
		КонецЕсли;
	КонецЦикла;	
	
	Сообщить("Печать копии чеков закончена!");
 

Так же буду очень признателен за продуктивную критику по работе с компонентой, может, есть какие-то методы, которые я не учел (не нашел)  и которые бы очень сильно облегчили разработку. К примеру, вытащить копию чека по номеру или вытащить дату чека.

Использование встроенных механизмов из типовых конфигураций специально не рассматривается ввиду автономности данной обработки, хотя и не универсальности.

Скачать файлы

Наименование Файл Версия Размер
Печать чеков ККМ (DatecsECR)

.epf 11,65Kb
6
.epf 11,65Kb 6 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. Иваныч 23 31.07.17 12:36 Сейчас в теме
2. hromovanton 6 09.08.17 11:37 Сейчас в теме
Нет, только по 1С 8. Я думаю переделать не составит особого труда.
Оставьте свое сообщение

См. также

Пакетное пробитие чеков на Онлайн-кассе при оплатах от физических лиц на расчетный счет Промо

Банковские операции Кассовые операции Обработка документов v8 v8::БУ БП3.0 Россия БУ Абонемент ($m)

Автоматизация процесса пробития чеков онлайн при поступлениях на расчетный счет от физических лиц. Помогает сократить трудозатраты таким организациям, как МФЦ, Управляющие компании и т.д. Подходит для 1С:Бухгалтерия 3.0 любой версии (базовая, ПРОФ, КОРП). Не изменяет конфигурацию. Конфигурация остается на поддержке (типовая).

2 стартмани

24.09.2019    22446    8    r.resh39    7    

Заполнение чека ККМ из Реализации или Заказа через штрихкод документа

Обработка документов Кассовые операции Розничная торговля Сканер штрих-кода v8 ERP2 УТ11 КА2 Абонемент ($m)

Заполняем Чек ККМ товарами из Реализации товаров или Заказа клиента - сканированием штрихкода Реализации или Заказа клиента.

2 стартмани

30.04.2021    4155    6    Rustig    3    

Сверка чеков платформы ОФД и 1С

Кассовые операции v8 v8::ОУ УТ10 Розничная и сетевая торговля (FMCG) Россия Абонемент ($m)

Обработка позволяет сверить данные ОФД с данными, хранящимися в системе 1С.

1 стартмани

13.02.2021    2775    8    dmt    0    

Возвращаем возможность печатать чеки на принтерах чеков и старых фискальниках в Рознице

Розничная торговля Кассовые операции v8 Розница БУ Абонемент ($m)

Если после очередного обновления вы обнаружили, что больше не можете печатать чеки на принтерах чеков, АСПД и старых фискальниках, то это расширение для вас.

2 стартмани

06.02.2021    3685    47    denmax    12    

Разделение чека по системам налогообложения (УСН+Патент)

Кассовые операции Розничная торговля v8 v8::ОУ УТ11 Россия БУ УУ УСН ПСН (патентная система налогообложения) Абонемент ($m)

Расширение для конфигурации Управление торговлей 11.4.13.99-103 при пробитии чека из РМК делит его по системам налогообложения.

3 стартмани

03.01.2021    9037    77    viktor_and_ko    93    

Чек ККМ на частичный возврат при оплате по карте в РМК для УТ 11.4 [РАСШИРЕНИЕ]

Розничная торговля Кассовые операции v8 v8::ОУ УТ11 Розничная и сетевая торговля (FMCG) Россия БУ УУ Абонемент ($m)

При оформлении возврата "день в день" из РМК при оплате наличными есть возможность удалять позиции из чека, если товар был оплачен банковской картой – такая возможность отсутствует. Данное расширение полностью решает эту проблему и дает возможность частичного возврата из РМК для Чеков ККМ оплаченных банковской картой.

1 стартмани

11.12.2020    5824    83    VCPro    12    

K-SOFT. Эмулятор ККТ с передачей данных. Управляемые формы. ФФД 1.1 (Ревизия 3002)

Фискальный регистратор v8 ЗКБУ Розница УНФ БГУ ЗКГУ3.0 БП3.0 БАУ УТ11 УХ КА2 ЗУП3.x 1С:CRM Россия Абонемент ($m)

Эмулятор ККТ с передачей данных позволяет печатать чеки, а также выводить их на экран в программе 1С без необходимости физического подключения фискальных регистраторов. Представляет из себя расширение, которое подключается к конфигурациям фирмы 1С, со встроенной библиотекой подключаемого оборудования (БПО). Вместо расширения, при желании, функционал можно включить и в конфигурацию. Поддерживает маркировку и печать чека коррекции с учетом проданной номенклатуры.

5 стартмани

23.11.2020    13595    204    karpik666    66    

Быстрая настройка ККМ из 1С с использованием драйвера от Атол без тест-драйвера Промо

Кассовые операции ККМ Кассовые операции v8 Розница Абонемент ($m)

В нашей компании на кассовых местах подключено несколько ККМ от Атола. При подключении к штатным разъемам USB на материнской плате все работает без проблем. Проблемы в тех магазинах, где кассы подключаются через USB-Hub. Данная обработка позволяет быстро, без запуска "Тест-драйвера" и "Управление драйверами", настроить кассовое оборудование. Протестировано на 32-х битной версии 1С и конфигурации 1С:Розница 2.2 с версиями драйверов от Атол 8.16.1.8701 и 9.12.1.6236

1 стартмани

27.08.2018    23405    16    valerasv    7    

Автоматическое создание ПКО на основании выемки ДС из кассы ККМ при закрытии смены Розница 2.3 (расширение)

Обработка документов Розничная торговля Кассовые операции v8 Розница Розничная и сетевая торговля (FMCG) БУ УУ Абонемент ($m)

При закрытии смены в Рознице 2.3 настраивается возможность "полной выемки", которая автоматически создает документ "Выемка денежных средств из кассы ККМ", но потому эти денежные средства надо принять в кассу предприятия, для этого надо создать документ ПКО "Поступление ДС из кассы ККМ".

2 стартмани

11.09.2020    3905    21    ClickUp    4    

Пакетная печать кассовых чеков

Пакетная печать Кассовые операции v8 v8::БУ БП3.0 БУ Абонемент ($m)

Внешняя обработка производит пакетную (групповую) печать кассовых чеков из любых видов документов по любым необходимым критериям - отборам.

2 стартмани

02.09.2020    4160    21    mirrr    15    

Эмулятор фискального регистратора для Бухгалтерии предприятия КОРП, редакция 3.0

Фискальный регистратор v8 БП3.0 Абонемент ($m)

Добавление эмулятора фискального регистратора в конфигурацию Бухгалтерия предприятия КОРП 3.0.

1 стартмани

26.08.2020    6768    35    DrZombi    28    

Пробитие чеков через ККМ в офисе (для курьеров) Промо

ККМ Фискальный регистратор Кассовые операции Розничная торговля Кассовые операции Розничная торговля v8 v8::ОУ Розница УТ11 Россия БУ Абонемент ($m)

Предлагается интеграция 1С с ККТ СтарРус. Поддерживается одновременная работа с разных рабочих мест. ККТ СтарРус работает как сервер, и принимает команды через API по http-протоколу, что позволяет пробивать чеки через центральную базу 1С для интернет-магазина и для курьеров.

1 стартмани

07.06.2018    39533    28    Kutuzov    12    

Загрузка чеков из файла выписки JSON для 1С:Деньги 8

Кассовые операции Розничная торговля v8 1cv8.cf Домашние учет и финансы Россия Абонемент ($m)

Обработка для загрузки чеков в 1С:Деньги 8 из файла выписки JSON, формируемого официальным мобильным приложением ФНС "Проверка чеков".

1 стартмани

20.08.2020    4250    5    teploukhov    8    

Нефискальный чек для УТ 11.4

Кассовые операции v8 УТ11 Абонемент ($m)

Расширение, которое позволит выбить нефискальный чек на Вашей ККТ по принципу конфигурации Розница 2. А также позволит пробить чек с последующем его проведением и выдачей псевдочека без отражения в ККТ (только с НАЛИЧНОЙ формой оплаты).

3 стартмани

17.08.2020    4926    47    zeibba    26    

Импорт документов "Поступления наличных" и "Операция по платёжной карте" в Бухгалтерию 3.0 из ОФД

Обработка документов Кассовые операции v8 БП3.0 БУ Абонемент ($m)

Обработка для импорта платёжных документов по данным оператора фискальных данных, которые представлены в формате XLS, XLSX. Не требует установки Microsoft Excell.

1 стартмани

04.08.2020    2205    4    inmortal203    0    

БП 2.0 онлайн-касса (ККТ с передачей данных) 54 ФЗ Промо

ККМ Фискальный регистратор Кассовые операции Розничная торговля Кассовые операции Розничная торговля v8 v8::БУ БП2.0 Россия БУ Абонемент ($m)

Изменения для объединения с конфигурацией "Бухгалтерия предприятия 2.0" с функционалом для работы с ККТ с передачей данных в ОФД (онлайн-касса), сделана согласно методическим указаниям.

2 стартмани

09.07.2017    52065    162    bob_    58    

[Расширение] Быстрое закрытие кассовой смены для 1С:Розница 2.3

Кассовые операции v8 Розница БУ Абонемент ($m)

Расширение позволяет в разы ускорить процесс закрытия кассовой смены.

1 стартмани

30.07.2020    5203    8    LamerSoft    0    

Подключение Sigma (7, 10 "150 Ф") к 1С: Розница 2.3, БП 3.0 и УТ 11.4, УНФ 1.6

ККМ Фискальный регистратор v8 Розница УНФ БП3.0 УТ11 Абонемент ($m)

Расширение, позволяющее использовать Sigma (7, 10 "150 Ф") как обычный ФР для пробития чеков из 1С: Розница напрямую.

1 стартмани

23.07.2020    12401    68    zeibba    52    

Автоматическое создание нового Чека ККМ после пробития в РМК для УТ 11.4 [РАСШИРЕНИЕ]

Кассовые операции Розничная торговля ККМ Рабочее место v8 УТ11 Розничная и сетевая торговля (FMCG) Россия БУ УУ Абонемент ($m)

Расширение для конфигурации 1С:Управление торговлей 11.4 реализовано с целью увеличения скорости обслуживания клиентов на рабочем месте кассира.

1 стартмани

18.06.2020    5865    33    VCPro    3    

Простая печать чеков в соответствии с 54-ФЗ. и поддержка маркировки Промо

Кассовые операции Фискальный регистратор Кассовые операции v8 v8::БУ БП3.0 Россия БУ Абонемент ($m)

Простая программа для печати чеков на фискальных регистраторах через драйвер компании Штрих-М. Соответствует 54-ФЗ. Подходит для интернет-магазинов.

3 стартмани

07.07.2017    34268    28    Rik30    19    

K-SOFT. Эмулятор ККТ с передачей данных. Обычные формы. ФФД 1.1 (Ревизия 3002)

Фискальный регистратор v8 УТ10 УПП1 БГУ Абонемент ($m)

Эмулятор работы с онлайн кассой, поддерживает современный стандарт работы 3.2, который включается в себя работу с маркировкой и печать чека коррекции с учетом проданной номенклатуры.

3 стартмани

16.06.2020    11872    105    karpik666    68    

Загрузка выручек касс по API с 1-ОФД (1-OFD.RU) и ОФД (OFD.RU)

Кассовые операции ККМ WEB v8 Розница ERP2 БП3.0 Розничная и сетевая торговля (FMCG) Россия БУ Абонемент ($m)

Обработка формирует отчет выручек Ваших касс средствами API с 1-ОФД (1-OFD.RU) и ОФД (OFD.RU) в разрезе каждого дня.

2 стартмани

26.05.2020    5506    20    slitov    4    

Кассовая программа "АрсКасса" на C# - без ограничений

Розничная торговля Кассовые операции Рабочее место v8 Розница Розничная и сетевая торговля (FMCG) Россия УУ Абонемент ($m)

Кассовая программа "АрсКасса" предназначена для автоматизации рабочего места кассира, без дополнительных затрат на покупку лицензий ПО.

1 стартмани

03.05.2020    10364    20    coolseo    9    

54-ФЗ: Онлайн-кассы для 1С 8.1 УТ 10.2. Поддержка Native драйверов Атол Промо

Кассовые операции Оптовая торговля Розничная торговля ККМ Кассовые операции Оптовая торговля Розничная торговля v8 v8::ОУ УТ10 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Россия УУ Абонемент ($m)

Доработан и адаптирован функционал работы ККТ по 54_ФЗ на УТ 10.2 платформы 8.1. Поддержка драйверов Атол версии 9 (native) и эмулятора ККТ. Код полностью открыт и внесены комментарии для самостоятельной доработки. Протестировано на Атол 11Ф. Распространяется как есть.

10 стартмани

18.04.2017    61649    128    Atom74    69    

Проведение чека из рабочего места кассира без пробития

Кассовые операции Рабочее место v8 Розница УУ Абонемент ($m)

Позволяет провести чек из РМК без его пробития (удаленная торговля, магазин доставки и т.д.).

1 стартмани

30.04.2020    9288    41    tatoshka0403    15    

Маркировка в УТ 10.3.59.2: ошибки в релизе

Кассовые операции Розничная торговля v8 УТ10 Россия Абонемент ($m)

Вышел релиз УТ 10.3.59.2, в котором реализована поддержка маркировки обуви. Релиз содержит некоторое количество ошибок, не позволяющих использовать его при продаже обуви.

1 стартмани

28.02.2020    31475    4    Sholl    75    

Выставление счета ссылкой на оплату через платежный шлюз Сбербанка из интерфейса 1С

Банковские операции Кассовые операции Оптовая торговля Розничная торговля v7.7 v8 1cv8.cf 1cv7.md Россия Абонемент ($m)

Внешняя обработка для выбора документа и формирования ссылки на оплату, которую можно скопировать в буфер обмена и отправить любыми средствами. Решение позволяет повысить автоматизацию процесса выставления счетов на оплату через интерфейс 1С8.х, 1С7.7. Совместимо с интернет-эквайрингом Сбербанк.

1 стартмани

14.01.2020    23677    120    etmarket    52    

Обработка "Все одной кнопкой" (групповое создание и печать документов) для УПП ред. 1.3 Промо

Обработка документов Пакетная печать Кассовые операции Оптовая торговля Производство готовой продукции (работ, услуг) Кассовые операции Оптовая торговля Производство готовой продукции (работ, услуг) v8 УПП1 БУ УУ Абонемент ($m)

Данная обработка предназначена для группового создания, редактирования и печати основных документов («Реализация товаров и услуг», «Счет-Фактура выданный», «Счет на оплату клиентом», «Доверенность» на получение продукции, "Приходного кассового ордера") на основании документа «Заказ клиента». Основная цель обработки – оптимизация работы менеджеров при формировании пакета документов клиентам.

3 стартмани

09.04.2016    31103    34    SEOAngels    0    

Создание документов выемки. 1С:Розница 2.2

Обработка документов Кассовые операции v8 v8::УФ Розница Розничная и сетевая торговля (FMCG) Россия БУ Абонемент ($m)

Создание, редактирование и удаление документа "Выемка ДС из Кассы ККМ" и "Приходно-кассовый ордер" в конфигурации 1С:Розница 2.2.

2 стартмани

30.11.2019    9647    57    ClickUp    18    

Слипы вышли, а чек - нет!

Розничная торговля Расширения Кассовые операции v8 v8::УФ Розница Розничная и сетевая торговля (FMCG) Россия Абонемент ($m)

Флаг устанавливающий Эквайринговый терминал как эмулятор для пробития чеков по карте.

1 стартмани

14.11.2019    31418    79    obmanOZ    47    

Фискальный регистратор из принтера чеков (COM и Windows принтеры) Промо

Фискальный регистратор Розничная торговля Розничная торговля Периферийные устройства v8 БП2.0 УТ10 Розница Россия Абонемент ($m)

Обработка - драйвер для подключения обыкновенных чековых принтеров в качестве фискальных регистраторов к стандартным конфигурациям 1С: УТ, БП, Розница в режиме обычного приложения. Поддерживаемые модели:Axiohm 794 (Wincor Nixdorf TH210) в "Native Mode", Advanpos WP-T800, STAR TSP-600, Epson Esc/P2, Star ESC/POS, ШТРИХ-700, Datecs EP-60, а также ВСЕ остальные COM принтеры в режиме "Custom", поддерживаются Windows принтеры.

1 стартмани

27.08.2009    282273    703    ZyZer    288    

1С:Деньги - Автоматическое заполнение расходов по QR-кодам чеков с помощью API ФНС

Обработка документов WEB Банковские операции Кассовые операции Банковские операции Кассовые операции v8 1cv8.cf Домашние учет и финансы Россия УУ Абонемент ($m)

UPDATE 2020.11 Учтено новое API взаимодействия с серверами проверки чеков ФНС. Реализована верификация по номеру телефона и кода из SMS. Обработка поможет сократить время на ввод данных о расходах в 1С:Деньги. Достаточно отсканировать QR-код чека смартфоном, с предустановленным официальным приложением проверки чеков от ФНС. Данные чека будут загружены в базу из данных электронного чека, которые хранятся на серверах ФНС. Обработка протестирована на последнем релизе 2.0.40.12.

1 стартмани

28.07.2019    13002    54    1sig    29    

Пример работы с OpenAPI ФНС проверки чеков ККМ

Внешние источники данных Кассовые операции Кассовые операции v8 УТ10 Россия Абонемент ($m)

Данную обработка можно использовать в своих разработках наподобие https://infostart.ru/public/732637/ Её отличие от остальных - она использует официальный API ФНС.

1 стартмани

23.07.2019    8644    28    StainDN    16    

Печать покупателя в чеке ККМ с 01.07.2019

ККМ Кассовые операции Печатные формы документов Кассовые операции v8 ERP2 БУ Абонемент ($m)

C 01.07.2019 если организация/ИП покупает у другой организации/ИП товары, работы или услуги, то в Чеке ККМ требуется указать: Покупателя (тег 1227) и ИНН (тег 1228). Если чек отправляется в ОФД без этих данных, то будет штраф . Но в 1С ERP вывод данных полей не предусмотрен. Предлагаемое расширение устраняет данную проблему.

1 стартмани

17.07.2019    35345    24    sapervodichka    14    

Восстановление нумерации кассовых ордеров (перенумерация) Промо

Обработка документов Кассовые операции Кассовые операции v8 БП2.0 БУ Абонемент ($m)

Обработка создана для узкой задачи восстановления нумерации расходных/приходных кассовых ордеров в конфигурации "Бухгалтерия Предприятия КОРП" 8.2 Ее плюс в простоте использования простым бухгалтером, при соблюдении правила "защиты от дурака". Учитывает префиксы организации и подразделений.

1 стартмани

27.06.2013    29943    127    Willforre    13    

Внешняя компонента для работы с драйвером "Атол v.10". 1С:8.3

Разработка внешних компонент Кассовые операции Кассовые операции v8 Абонемент ($m)

Внешняя компонента, для работы с драйвером «Атол v.10», посредством JSON-заданий.

1 стартмани

16.07.2019    16250    34    gortrex    5    

Анализ запущенных фоновых заданий для контроля ошибки при пробитии чека через РМК. Расширение для розницы 2.2

Администрирование данных 1С Кассовые операции Розничная торговля Кассовые операции Розничная торговля v8 Розница Россия БУ УУ Абонемент ($m)

Данное расширение решает проблему пробития чека в момент, когда выполняется обмен данными. Анализирует запущенные фоновые и не дает пробить чек, пока не завершится фоновое задание, выводит предупреждение пользователю. Дополнение актуально, если база файловая и настроен автоматический обмен данными с другими базами.

3 стартмани

08.06.2019    5841    7    Dadriel619960    0    

Данные по кассам из личного кабинета ТАКСКОМ

Внешние источники данных Кассовые операции Розничная торговля Кассовые операции Розничная торговля v8 Россия БУ Абонемент ($m)

Небольшая конфигурация, написанная на платформе 1С:Предприятие 8.3 версии 8.3.14.1694 для получения данных от ОФД Такском по ККТ, ФН, контроля над сроками замены ФН и получения информации по выручкам отправленным онлайн.

3 стартмани

14.05.2019    5555    18    akela2014    6    

iiko (Айко) 1с БП 8.2 Промо

Обработка документов Зарплата Кассовые операции Зарплата Кассовые операции v8 БП2.0 Россия БУ Абонемент ($m)

Обработка из экселевского файла выгрузки из Айко "Движение денежных средств" создает группы документов ПКО-Реализация товаров и услуг , РКО-Поступление товаров и услуг, РКО-Ведомость на выплату зарплаты. Подразумевается что работаем с ИП и в качестве номенклатуры используем всегда одну позицию ТОВАР без НДС.

1 стартмани

16.07.2013    34299    36    zavsom    4    

Печать картинки в чеке ККМ (для УТ 10.3 и АТОЛ Драйвер ККТ 10.4.5.0)

ККМ Кассовые операции Розничная торговля Кассовые операции Розничная торговля v8 КА1 УТ10 Розничная и сетевая торговля (FMCG) Россия Абонемент ($m)

Как я пытался на ККТ Атол 25Ф напечатать картинку в "Не фискальном чеке", а в дальнейшем уже печатать небольшую рекламу после основного чека.

1 стартмани

23.04.2019    12267    59    _Farsh_    3    

Обработка печати чеков на ККТ АТОЛ с использованием Web-сервера, поставляемого с драйвером контрольно-кассовой техники v.10

ККМ Кассовые операции Кассовые операции v8 1cv8.cf Россия Абонемент ($m)

Если хотите быстрой печати кассовых чеков, вам сюда! Web-сервер предназначен для обеспечения доступа к функциям ККТ одному и более Web-клиенту. Весь обмен ведется в кодировке UTF-8. Web-сервер хранит задания и их результаты в базе данных в течении месяца. Для работы Web-сервера требуется установленная Java версии 1.8 и выше. Платформа 1С должна поддерживать возможность работы с JSON. На данный момент обработка не поддерживает систему Маркировки! т.е. не передает коды маркировки в ККТ.

5 стартмани

11.04.2019    14325    30    user700705    14    

Автоматическое формирование листов кассовой книги (ERP 2.4)

Кассовые операции Обработка документов Кассовые операции v8 ERP2 Россия БУ Абонемент ($m)

Автоматическое и ручное формирование листов кассовой книги для ЕРП 2.4.

3 стартмани

09.04.2019    5505    17    tristarr1    2    

ЖКХ, ТСЖ: Ввод документа "Регистрация оплаты" на основании платежного документа бухгалтерии Промо

Обработка документов Банковские операции Дебиторская и кредиторская задолженность Кассовые операции Банковские операции Дебиторская и кредиторская задолженность Кассовые операции v8 БП2.0 Энергетика и ЖКХ Бытовые услуги, сервис Недвижимость, риэлторская деятельность Государственные, бюджетные структуры БУ УУ Абонемент ($m)

Вы загружаете выписки из банка или вводите их руками? А потом еще и мучаетесь с оплатами по лицевым счетам? Вы правильно зашли! Очень часто пользователи программы «ВДГБ:Учет в управляющих компаниях ЖКХ, ТСЖ и ЖСК» вынуждены сначала вводить поступления на расчетный счет (загрузка из банка) и приходные кассовые ордера, а затем выполнять двойную работу, вручную формируя в ЖКХ регистрации оплат. Обработка предназначена для облегчения этой задачи и позволяет быстро сформировать документ «Регистрация оплаты» на основании уже введенных бухгалтерских платежных документов. Подключается к платежным документам в виде простой кнопки "ЖКХ: Регистрация оплат" и не требует внесения изменений в конфигурацию программы. Если вы много времени тратите на создание документов "Регистрация оплат", то обработка это сделает за вас!

1 стартмани

08.03.2013    30089    34    free-lancer-2018    9    

Кассовый Менеджер 1.3 (Онлайн-кассы)

Внешние источники данных Кассовые операции Розничная торговля Кассовые операции Розничная торговля v8 Россия БУ Абонемент ($m)

Небольшая конфигурация, написанная на платформе 1С:Предприятие 8.3 версии 8.3.10.2252 для получения данных от ОФД (Такском) по ККМ, ФН, ОКС (отчетам кассовых смен), загрузке детализированных чеков, контроля за сроками замены ФН и получения информации по выручкам отправленным онлайн. Обновления конфигурации бесплатны.

10 стартмани

03.04.2019    8932    15    user597086_dir_box    21    

Печать чеков ФФД 1.05 (со списком товаров) УТ 11, ERP и КА 2 [Расширение]

ККМ Кассовые операции Розничная торговля Кассовые операции Розничная торговля v8 ERP2 УТ11 КА2 БУ Абонемент ($m)

Расширение позволяет выводить на чек товары из документа Заказ клиента.

10 стартмани

09.02.2019    9673    4    tigrandis    4    

Эмулятор ФР для обычного принтера чеков Windows Промо

Фискальный регистратор Розничная торговля Розничная торговля v8 Розница Розничная и сетевая торговля (FMCG) УУ Абонемент ($m)

Данная обработка предназначена для эмуляции фискального регистратора, что в последующем помогает запустить (РМК)! Также позволяет печатать чеки на обычный принтер windows!

1 стартмани

28.05.2012    40238    352    Antimyslitel    23    

Редактор чеков ККМ. УТ 11.4

Обработка документов Кассовые операции Кассовые операции v8 v8::ОУ УТ11 БУ Абонемент ($m)

Обработка чеков ККМ списком (редактирование, удаление, ...). Связь чеков с кассовой сменой (КС). Редактирование времени КС. Редактирование суммы и времени выемки.

1 стартмани

31.01.2019    10783    66    Dima_    14    

API Яндекс.Кассы v4 и 1С

WEB Кассовые операции Кассовые операции v8 v8::ОУ УТ11 Россия Абонемент ($m)

Работа с api яндекс кассы v4.

1 стартмани

29.01.2019    18136    27    kickout    2    

Касса дилерского центра - отключаем онлайн-кассу от Альфа-Авто

ККМ Кассовые операции Кассовые операции v8 Автомобили, автосервисы Россия Абонемент ($m)

Конфигурация основана на Библиотеке подключаемого оборудования 1С. Ориентирована на работу с Альфа-Авто 4.x -5.x и позволяет работать с онлайн-кассами в соответствии с 54-ФЗ.

8 стартмани

09.01.2019    10019    10    papami    3