Печать Чеков ККМ с помощью компоненты "DatecsECR.TECRFisc".

Публикация № 505160

Учет и отчетность - Кассовые операции

DatecsECR Чек ККМ фискальный регистратор

1
Обработка подходит для любой конфигурации где есть документы "Реализация товаров и Услуг" и "Чек ККМ". Для  фискальных регистраторов datecs.

Недавно столкнулся с проблемой печати чеков ККМ с помощью компоненты "DatecsECR". Может, кому будет полезна моя публикация. Собственно задача стояла реализовать печать копии чеков ККМ. Углубившись в задачу и в мануал по работе с компонентой DatecsECR, понял, что только по последнему созданному чеку можно напечатать копию. Задача же стоит - печатать копию любого чека.

Для реализации такой возможности нужно где-то хранить номер и дату чека фискального регистратора. Я выбрал самый легкий вариант, в реквизитах документа «Чек ККМ». Если конфигурацию стоит на поддержке, лучше создать отдельный регистр сведений для этих целей.

Если нужно печать только сами чеки из 1С на фискальный регистратор, то дорабатывать ничего не надо.

Обработка не претендует на эталон и выложена для примера печати чеков ККМ, поэтому перед скачиванием посмотрите код, может, такой вариант вам и не подойдет.

Вот код процедуры печати чека:

	
	ПолучитьТаблицуЧеков();
	
	флЕстьОшибка = 0;
	
	ECRFisc=Новый COMОбъект("DatecsECR.TECRFisc");
	

	Для каждого СтрокаДокументаЧекККМ из ТаблицаЧеков цикл 
		
		флЕстьОшибка = 0;
		
		Сообщить("Печать чека для РН "+СтрокаДокументаЧекККМ.Ссылка, СтатусСообщения.Информация);
		                    
		// 1. откроем порт
		Result = ECRFisc.SetComPort(1, 19200);
		ЗаписьЖурналаРегистрации("Печать Чеков КММ на ФР", УровеньЖурналаРегистрации.Информация, Метаданные.Документы.ЧекККМ, СтрокаДокументаЧекККМ.ЧекККМ,
				"Открыли COM порт. "+Строка(СтрокаДокументаЧекККМ.ЧекККМ));
				
		Если Result <> 1 Тогда
		//Если не Result тогда
			Сообщить("Проблем подключения по COM Порту. Код ошибки: "+Строка(Result)+" ! Проверьте подключение!", СтатусСообщения.ОченьВажное);
			Сообщить(" -1 - ошибка (неверный номер порта – меньше 1 или больше 8)" + Символы.ПС+
					 " -2 – неверно указана скорость" + Символы.ПС+
					 " -3 – порт занят" + Символы.ПС+
					 " -4 – невозможно создать блок управления устройством" + Символы.ПС+
					 " -5 – ошибка установки параметров порта" + Символы.ПС+
					 " -7 – проблемы с лицензированием");

			флЕстьОшибка = 1 ;
		Конецесли;
		
		// Находим номер последнего запрограммированного артикула
		Если флЕстьОшибка = 0  тогда 
			Код = ВернутьКодПоследнегоЗапрограммированногоАртикулаФР();
			
			Если Код = 0 Тогда
				// Свойство возвращает информацию о первом запрограммированном артикуле.
				ПервыйКод =  ECRFisc.firstart();
				ЗаписьЖурналаРегистрации("Печать Чеков КММ на ФР", УровеньЖурналаРегистрации.Информация, Метаданные.Документы.ЧекККМ, СтрокаДокументаЧекККМ.ЧекККМ,
					"Прочитали первый запрограммированный артикул. "+Строка(СтрокаДокументаЧекККМ.ЧекККМ));

				Если СтрДлина(ПервыйКод) = 0 тогда
					Код = 1;
				Иначе
					Для номерарт = 2 по 14800 цикл
						//свойство возвращает информацию о следующем запрограммированном артикуле.
						следкод = ECRFisc.nextart();
						Если стрдлина(следкод) = 0 тогда
							Код = номерарт;  прервать;
						Конецесли;
					Конеццикла;   
				Конецесли;
				
				ЗаписьЖурналаРегистрации("Печать Чеков КММ на ФР", УровеньЖурналаРегистрации.Информация, Метаданные.Документы.ЧекККМ, СтрокаДокументаЧекККМ.ЧекККМ,
					"Нашли номер последнего запрограммированного артикула. "+Строка(СтрокаДокументаЧекККМ.ЧекККМ));
					
				ЗаписатьКодПоследнегоДобавленногоАртикулаВФР(Код);
            КонецЕсли;
			
			// Если количество запрограммированных артикулов не привысило максимальное количество, то открываем фискальный чек 
			Если Код <= 14800 Тогда
				
				//откроем фискальный чек на ФР
				result = ECRFisc.OpenFiscReceipt(1,1,"0000");
				Если не Result тогда
					сообщить("Ошибка открытия чека продажи на ФР!");
					флЕстьОшибка = 1 ;
					//продолжить;
				Иначе
					// Объявляем переменные
					старртикул = 0;   ОбщаяСумма = 0; 				   
					
					// Перебираем все строки табличной части товары из Чека ККМ
					ОбъектЧекККМ = СтрокаДокументаЧекККМ.ЧекККМ.ПолучитьОбъект();
					Для Каждого СтрокаТЧ Из ОбъектЧекККМ.Товары Цикл
						//   код = код + 1; 
						Сумма 		= СтрокаТЧ.Сумма;
						Цена 		= Сумма / СтрокаТЧ.Количество;
						ОбщаяСумма 	= ОбщаяСумма + Сумма;
						НаименованиеТовара = Лев(СокрЛП(СтрокаТЧ.Номенклатура),24);
						
						// осуществим продажу по строке в чеке
						// Добавляем артикул
						res = ECRFisc.ProgramArt(192, Код, 1, Цена, "0000", НаименованиеТовара);
						
						ЗаписьЖурналаРегистрации("Печать Чеков КММ на ФР", УровеньЖурналаРегистрации.Информация, Метаданные.Документы.ЧекККМ, СтрокаДокументаЧекККМ.ЧекККМ,
							"Запрограммировали артикул "+Строка(НаименованиеТовара));
						
						// В случае удачного добавления артикула, выводим строку на печать
						Если res Тогда							
							Result = ECRFisc.SellArtCashDS(True, код, строкатч.количество, 0,0);
							
							ЗаписьЖурналаРегистрации("Печать Чеков КММ на ФР", УровеньЖурналаРегистрации.Информация, Метаданные.Документы.ЧекККМ, СтрокаДокументаЧекККМ.ЧекККМ,
								"Напечатали артикул "+Строка(НаименованиеТовара));

							
							Если не Result  тогда
								Сообщить("Ошибка при формировании продажи и выводе информации в строке фискального чека!" ,СтатусСообщения.ОченьВажное);
								флЕстьОшибка = 1;
								
								ЗаписатьКодПоследнегоДобавленногоАртикулаВФР(0);

								// Анулируем фискальный чек
								ECRFisc.ReceiptCancel();
								// Закрываем  com порт
								ECRFisc.CloseComPort(1);
								Прервать;
							Иначе 
								Код = Код +1;
								
								ЗаписатьКодПоследнегоДобавленногоАртикулаВФР(Код);

								Если Код > 14800 тогда
									
									ЗаписатьКодПоследнегоДобавленногоАртикулаВФР(0);
									
									Сообщить("Достигнуто максимальное количество программируемых артикулов = 14800!", СтатусСообщения.Важное);
									Сообщить("Сделайте z-отчет!", СтатусСообщения.Важное);
									// Анулируем фискальный чек
									ECRFisc.ReceiptCancel();
									// Закрываем  com порт
									ECRFisc.CloseComPort(1);
									Прервать;
									
								КонецЕсли;
							КонецЕсли;
						Иначе
							Сообщить("Ошибка при добавлении нового артикула в ФР!" + Символы.ПС + "Товар: "+НаименованиеТовара ,СтатусСообщения.ОченьВажное);
							флЕстьОшибка = 1; 
							
							ЗаписатьКодПоследнегоДобавленногоАртикулаВФР(0);
							
							// Анулируем фискальный чек
							ECRFisc.ReceiptCancel();
							// Закрываем  com порт
							ECRFisc.CloseComPort(1);
							Прервать;

						КонецЕсли;
						
						// Добавляем кодтовара из фискального регистратора в Строку Чека
						СтрокаТЧ.КодТовараФР = Код;
					КонецЦикла;
					
					// Пишем Номер, ИД чека из ФР
					Попытка
						ОбъектЧекККМ.НомерЧекаФР = Строка(ECRFisc.NumbRec());
					Исключение
					КонецПопытки;
                    						
					//регистрация продажи и закрытие чека
					ECRFisc.Payment(0, 0);
					
					ЗаписьЖурналаРегистрации("Печать Чеков КММ на ФР", УровеньЖурналаРегистрации.Информация, Метаданные.Документы.ЧекККМ, СтрокаДокументаЧекККМ.ЧекККМ,
							"Сделали продажу "+Строка(ОбъектЧекККМ));

					// Закрываем фискальный чек
					Result = ECRFisc.CloseFiscReceipt();
					
					ЗаписьЖурналаРегистрации("Печать Чеков КММ на ФР", УровеньЖурналаРегистрации.Информация, Метаданные.Документы.ЧекККМ, СтрокаДокументаЧекККМ.ЧекККМ,
							"Закрыли фискальный чек "+Строка(ОбъектЧекККМ));

					Если не Result Тогда
						Сообщить("Ошибка при закрытии фискального чека!");
						кодошибки = 1 ;
					Иначе
						// Пишем дату и время закрытия чека из ФР
						ПОПЫТКА
							ОбъектЧекККМ.ДатаЧекаФР  = ТекущаяДата();
						Исключение
						КонецПопытки;
					КонецЕсли;
					//закроем порт
					Result = ECRFisc.CloseComPort(1);
					
					ЗаписьЖурналаРегистрации("Печать Чеков КММ на ФР", УровеньЖурналаРегистрации.Информация, Метаданные.Документы.ЧекККМ, СтрокаДокументаЧекККМ.ЧекККМ,
							"Закрыли порт "+Строка(ОбъектЧекККМ));

					Если  не Result Тогда
						Сообщить("Ошибка закрытия порта!");
						кодошибки = 1 ;
					КонецЕсли;
					
					// Пишем Чек ККМ
					ОбъектЧекККМ.Записать(РежимЗаписиДокумента.Запись); 
				КонецЕсли;
			Иначе
				Сообщить("Достигнуто максимальное количество программируемых артикулов!");
				Сообщить("Сделайте z-отчет!");
				
				ЗаписатьКодПоследнегоДобавленногоАртикулаВФР(0);
				
				прервать;
			КонецЕсли;
		КонецЕсли;
		
	КонецЦикла;	
	
	Сообщить("Печать чеков закончена!");	
 

Главная проблема состоит в том, что при добавлении нового чека в фискальный регистратор, нужно хранить код товара на стороне 1С. Иначе нужно при печати каждого чека искать код последнего добавленного товара в фискальный регистратор, что занимает огромное количество времени. Поэтому пока открыта обработка мы храним код последнего добавленного товара в фискальный регистратор. Так же для каждого Чека ККМ записываем Номер и Дату чека из Фискального регистратора. Что касается даты чека из ФР, то у используемой компоненты нет метода для возврата Даты, поэтому в момент печати чека сохраняем ТекущуюДату.

Вот Код печати Копии Чека:

ПолучитьТаблицуЧеков();
	
	флЕстьОшибка = 0;
	
	ECRFisc=Новый COMОбъект("DatecsECR.TECRFisc");
	

	// Перебираем все строки и печатаем отмеченные чеки
	Для каждого СтрокаДокументаЧекККМ из ТаблицаЧеков цикл 

		флЕстьОшибка = 0;
		
		Сообщить("Печать копии чека для "+СтрокаДокументаЧекККМ.Ссылка, СтатусСообщения.Информация);
		
		// 1. откроем порт
		Result = ECRFisc.SetComPort(1, 19200);
		
		Если Result <> 1 Тогда
			Сообщить("Проблем подключения по COM Порту. Код ошибки: "+Строка(Result)+" ! Проверьте подключение!", СтатусСообщения.ОченьВажное);
			Сообщить(" -1 - ошибка (неверный номер порта – меньше 1 или больше 8)" + Символы.ПС+
					 " -2 – неверно указана скорость" + Символы.ПС+
					 " -3 – порт занят" + Символы.ПС+
					 " -4 – невозможно создать блок управления устройством" + Символы.ПС+
					 " -5 – ошибка установки параметров порта" + Символы.ПС+
					 " -7 – проблемы с лицензированием");

			флЕстьОшибка = 1 ;
		Конецесли;
		
		// Если подключили com порт, то открываем на печать не фискальный чек
		Если флЕстьОшибка = 0  тогда 
				
			//откроем нефискальный чек на ФР
			Result = ECRFisc.OpenNonFiscReceipt();
			Если не Result тогда
				Сообщить("Ошибка открытия нефискального чека на ФР!");
				флЕстьОшибка = 1 ;
			Иначе
				// Объявляем переменные
				ОбщаяСумма = 0;
				
				// Печатаем шапку чека
				Result = ECRFisc.PrntNonFiscal("Копия Чека № "+СокрЛП(СтрокаДокументаЧекККМ.ЧекККМ.НомерЧекаФР));
				Попытка
					ДатаЧекаФР = СтрокаДокументаЧекККМ.ЧекККМ.ДатаЧекаФР;
					Result = ECRFisc.PrntNonFiscal("от "+СокрЛП(ДатаЧекаФР));
				Исключение
				КонецПопытки;
				Result = ECRFisc.PrntNonFiscal("");
				
				// Перебираем все строки табличной части товары из Чека ККМ
				Для Каждого СтрокаТЧ Из СтрокаДокументаЧекККМ.ЧекККМ.Товары Цикл
					Сумма 		= СтрокаТЧ.Сумма;
					Цена 		= Сумма / СтрокаТЧ.Количество;
					ОбщаяСумма 	= ОбщаяСумма + Сумма;
					НаименованиеТовара1 = Лев(СтрокаТЧ.Номенклатура,24);
					НаименованиеТовара2 = Сред(СтрокаТЧ.Номенклатура,25, 24);
					
					// Выводим коментарий в нефискальный чек
					Result = ECRFisc.PrntNonFiscal(НаименованиеТовара1);
					Если НЕ ПустаяСтрока(НаименованиеТовара2) Тогда
						Result = ECRFisc.PrntNonFiscal(НаименованиеТовара2);	
					КонецЕсли;
					
					Result = ECRFisc.PrntNonFiscal(Формат(СтрокаТЧ.Количество,"ЧЦ=7; ЧДЦ=2")+ " " + 
							СокрЛП(СтрокаТЧ.ЕдиницаИзмерения) + "  х"+Формат(Цена,"ЧЦ=10; ЧДЦ=2")+
							" = "+Формат(Сумма,"ЧЦ=10; ЧДЦ=2"));

					Если не Result  тогда
						Сообщить("Ошибка при печати нефискального чека!" ,СтатусСообщения.ОченьВажное);
						флЕстьОшибка = 1; 
						// Закрываем нефискальный чек
						ECRFisc.CloseNonFiscReceipt();
						// Закрываем  com порт
						ECRFisc.CloseComPort(1);
						Прервать;
					КонецЕсли;
				КонецЦикла;
				
				// Выводим общую сумму по чеку
				Result = ECRFisc.PrntNonFiscal("------------------------");
				Result = ECRFisc.PrntNonFiscal("СУММА"+Прав("                        " +Формат(ОбщаяСумма,"ЧЦ=10; ЧДЦ=2"),19));
				Result = ECRFisc.PrntNonFiscal("ПДВ А  0,00%         0,00");
				Result = ECRFisc.PrntNonFiscal("Сумма ПДВ"+Прав("                        " +Формат(СтрокаДокументаЧекККМ.Ссылка.Товары.Итог("СуммаНДС"),"ЧЦ=10; ЧДЦ=2"),15));
				Result = ECRFisc.PrntNonFiscal("------------------------");
				Result = ECRFisc.PrntNonFiscal("     СЛУЖЕБНЫЙ ЧЕК     ");
				
				// Закрываем нефискальный чек
				Result = ECRFisc.CloseNonFiscReceipt();
				Если не Result Тогда
					Сообщить("Ошибка при закрытии нефискального чека!");
					кодошибки = 1 ;
				КонецЕсли;
				
				//закроем порт
				Result = ECRFisc.CloseComPort(1);
				Если  не Result Тогда
					Сообщить("Ошибка закрытия порта!");
					кодошибки = 1 ;
				КонецЕсли;
			КонецЕсли;
		КонецЕсли;
		
		Если кодошибки = 0 Тогда
			СтрокаДокументаЧекККМ.флНапечатать = ложь;
		КонецЕсли;
	КонецЦикла;	
	
	Сообщить("Печать копии чеков закончена!");
 

Так же буду очень признателен за продуктивную критику по работе с компонентой, может, есть какие-то методы, которые я не учел (не нашел)  и которые бы очень сильно облегчили разработку. К примеру, вытащить копию чека по номеру или вытащить дату чека.

Использование встроенных механизмов из типовых конфигураций специально не рассматривается ввиду автономности данной обработки, хотя и не универсальности.

1

Скачать файлы

Наименование Файл Версия Размер
Печать чеков ККМ (DatecsECR)
.epf 11,65Kb
24.03.16
5
.epf 11,65Kb 5 Скачать

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. Иваныч 23 31.07.17 12:36 Сейчас в теме
2. hromovanton 4 09.08.17 11:37 Сейчас в теме
Нет, только по 1С 8. Я думаю переделать не составит особого труда.
Оставьте свое сообщение

См. также

Печать покупателя в чеке ККМ с 01.07.2019 25

Отчеты и формы Программист Бухгалтер Пользователь Расширение (cfe) v8 ERP2 БУ Кассовые операции Абонемент ($m) ККМ Печатные формы документов

C 01.07.2019 если организация/ИП покупает у другой организации/ИП товары, работы или услуги, то в Чеке ККМ требуется указать: Покупателя (тег 1227) и ИНН (тег 1228). Если чек отправляется в ОФД без этих данных, то будет штраф . Но в 1С ERP вывод данных полей не предусмотрен. Предлагаемое расширение устраняет данную проблему.

1 стартмани

17.07.2019    6837    15    sapervodichka    10       

Эмулятор ККМ по стандарту ФФД 1.1 21

Инструменты и обработки Программист Архив с данными v8 Розница УТ11 Россия Windows Кассовые операции Абонемент ($m) Разработка внешних компонент ККМ

Эмулятор драйвера ККМ по стандарту ФФД 1.1 предназначен для использования всех возможностей программы, при отсутствии физической кассы. Подойдет как программистам при разработке интерфейса РМК, например, так и пользователям для тестирования возможностей программы.

1 стартмани

30.12.2018    8971    81    Matveymc    19       

ККТ Атол: настраиваем работу по новому порядку. 54ФЗ, ФФД 1.05, НДС 20%. + Работа ККТ по сети или как работать c ККТ из терминального сервера RDP + Работа в LINUX 22

Инструменты и обработки Системный администратор Архив с данными v8 УТ10 УПП1 ОС Кассовые операции Розничная торговля Абонемент ($m) ККМ

Настройка ККТ АТОЛ для работы по сети. Обработка обслуживания ККТ для конфигураций на обычных формах. Тестировал на УПП 1.3.106.2, УТ10.3.47.3. Платформа 8.3.10.2753

1 стартмани

14.12.2018    30255    49    Johny_v    42       

АТОЛ ВЕБ-СЕРВИС. Обработка для работы с ККТ 54 ФЗ + ИЗМЕНЕНИЯ С 01.07.2019 36

Инструменты и обработки Системный администратор Программист Бухгалтер Внешняя обработка (ert,epf) v8 КА1 УТ10 УПП1 БГУ БАУ 1С:CRM Россия Windows Кассовые операции Абонемент ($m) ККМ

Хотите ускорить печать чеков, или печатать с разных рабочих мест на один фискальный регистратор? В этом вам поможет, настроенный веб-сервис от фирмы АТОЛ, а данная разработка позволит интегрировать его с вашей программой 1С.

4 стартмани

03.12.2018    18920    150    karpik666    168       

Подключение онлайн касс (ФЗ-54) к старой 1С конфигурации УТ 10.2. Описание и реализация проекта 11

Статья Программист Конфигурация (md, cf) v8 Розничная и сетевая торговля (FMCG) Россия Windows Кассовые операции Розничная торговля Абонемент ($m) ККМ

Статья предназначена в первую очередь начинающим 1С программистам, а также будет полезна знакомым с ИТ-спецификой управленцам, пред которыми встанет вопрос об интеграции новой онлайн кассы, работающей по ФЗ-54 со старой информационной системой. В статье изложен ряд возможных подходов к решению задачи и показана реализация оптимального в данном случае варианта. Здесь нет готового тиражного решения, с одной стороны это пример реализации как иллюстрация к тексту, а с другой это рабочая программа для случая описанного ниже и если ваш случай похож, то решение с минимальными затратами может быть адаптировано. Также я слегка приоткрыл «фрилансерскую кухню».

1 стартмани

28.11.2018    5544    15    Petr54-ru    13       

Подключение нескольких касс к РМК (Розница 2.2). Расширение. Поддержка новой версии Розница 2.2.11 9

Инструменты и обработки Системный администратор Бухгалтер Пользователь Расширение (cfe) v8 Розница Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Кассовые операции Розничная торговля Абонемент ($m) ККМ Рабочее место

Работа с несколькими кассами в программе 1С:Розница 2.2, одновременное подключение ККТ с передачей данных, Фискального регистратора, Принтера чеков, Эмулятора и пр. Будет работать во всех версиях розницы с режимом совместимостью выше 8.3.10, изменения в конфигураций не требуется. Обязательное условие выключить безопасный режим в расширении.

10 стартмани

08.10.2018    4809    17    tigrandis    30       

Загрузка чека онлайн-касс (загрузка товаров из чека) 38

Инструменты и обработки Системный администратор Программист Бухгалтер Внешняя обработка (ert,epf) v8 1cv8.cf Кассовые операции Розничная торговля Абонемент ($m) Внешние источники данных WEB

Обработка-пример, позволяет любому и из любой конфигурации загрузить информацию о товарах из чека(и не только) с сервера ФНС proverkacheka.nalog.ru

2 стартмани

08.10.2018    7103    23    echo77    32       

Загрузка табличной части документов "Ведомость в банк" или "Ведомость в кассу". ЗУП 3.1 из xls файла. 8

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 v8::СПР ЗУП3.x БУ Банковские операции Зарплата Кассовые операции Абонемент ($m) Обработка документов Загрузка и выгрузка в Excel

Загрузка \ заполнение табличной части документов "Ведомость в банк" или "Ведомость в кассу" ЗУП 3.1 из xls файла. Для работы обработки Excel устанавливать не надо. Работает во всех клиентах и вариантах работы, клиент-серверном, файловом и web.

2 стартмани

14.09.2018    4857    58    kg2    15       

Быстрая настройка ККМ из 1С с использованием драйвера от Атол без тест-драйвера 8

Инструменты и обработки Системный администратор Внешняя обработка (ert,epf) v8 Розница Windows Кассовые операции Абонемент ($m) ККМ

В нашей компании на кассовых местах подключено несколько ККМ от Атола. При подключении к штатным разъемам USB на материнской плате все работает без проблем. Проблемы в тех магазинах, где кассы подключаются через USB-Hub. Данная обработка позволяет быстро, без запуска "Тест-драйвера" и "Управление драйверами", настроить кассовое оборудование. Протестировано на 32-х битной версии 1С и конфигурации 1С:Розница 2.2 с версиями драйверов от Атол 8.16.1.8701 и 9.12.1.6236

1 стартмани

27.08.2018    10241    14    valerasv    7       

Продажа с двух касс ККМ в 1С:Розница 2.2. Выбор, по какой кассе пробить чек 12

Инструменты и обработки Бухгалтер Пользователь Архив с данными v8 Розница Кассовые операции Розничная торговля Абонемент ($m) ККМ

Данное расширение конфигурации позволяет выбрать из списка кассу (ККМ), по которой необходимо пробить чек.

3 стартмани

09.08.2018    6472    22    pogroleg    39       

Эмулятор эквайрингового терминала 17

Инструменты и обработки Программист Архив с данными v8 Розница Россия УУ Windows Кассовые операции Абонемент ($m) ККМ

Эмулятор эквайрингового терминала для тестирования взаимодействий с разрабатываемыми или типовыми решениями.

1 стартмани

26.07.2018    9723    105    trigor    15       

Доработанное РМК. Розница 2.2 10

Отчеты и формы Руководитель проекта Расширение (cfe) v8 Розница Россия Кассовые операции Розничная торговля Абонемент ($m) Рабочее место

Расширение для конфигурации Розница 2.2. В режиме РМК добавляет на форму кнопки "Создать заказ", "Создать новую дисконтную карту".

3 стартмани

26.06.2018    5340    9    rounder    0       

Атол ККТ:Онлайн 54ФЗ для 1С 8.1 УТ 10.3 (без изменения конфигурации) 11

Инструменты и обработки Системный администратор Внешняя обработка (ert,epf) v8 v8::ОУ УТ10 Россия Кассовые операции Абонемент ($m) ККМ Фискальный регистратор

Обработка обслуживания драйвера "АТОЛ: Драйвер ККТ (54ФЗ) версия 8.16" для Управление торговлей 10.3 на платформе 1С:8.1. Не требует изменения конфигурации - подключение как "Фискальный регистратор".

4 стартмани

15.06.2018    31924    110    1st    61       

Пробитие чеков через ККМ в офисе (для курьеров) 11

Инструменты и обработки Пользователь Расширение (cfe) v8 v8::ОУ Розница УТ11 Россия БУ Кассовые операции Розничная торговля Абонемент ($m) ККМ Фискальный регистратор

Предлагается интеграция 1С с ККТ СтарРус. Поддерживается одновременная работа с разных рабочих мест. ККТ СтарРус работает как сервер, и принимает команды через API по http-протоколу, что позволяет пробивать чеки через центральную базу 1С для интернет-магазина и для курьеров.

1 стартмани

07.06.2018    17139    27    Kutuzov    12       

Печать на ККТ текстового документа из УТ 10.3 8

Инструменты и обработки Программист Архив с данными v8 v8::ОУ УТ10 Россия Кассовые операции Розничная торговля Абонемент ($m) ККМ

Показан способ печати нефискальных, произвольного текстового содержания документов на кассах-онлайн на примере 1С:Управление торговлей 10.3.

1 стартмани

25.05.2018    9258    21    ifal    0       

Выбор цены в РМК для УТ 11.3 и УТ 11.4 (расширение) 18

Отчеты и формы Бухгалтер Пользователь Расширение (cfe) v8 v8::ОУ УТ11 Россия УУ Кассовые операции Розничная торговля Абонемент ($m) Рабочее место

Расширение для УТ 11.3 и УТ 11.4, разрешает в рабочем месте кассира выбор вида цены или установку произвольной цены на каждую позицию.

1 стартмани

29.12.2017    19035    109    kassbar    76       

Загрузка ОФД (ofd.ru, ofd-ya.ru, taxcom.ru, platformaofd.ru, ofd.kontur.ru, online.sbis.ru, life-pay.ru, modulpos.ru, 1-ofd.ru, Экспресс касса, subtotal.ru, sberbank.ru/ofd, chekonline.ru, initpro.ru) 12

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 v8::БУ БП3.0 Россия БУ Кассовые операции Абонемент ($m) Внешние источники данных

Обработка по загрузке файлов из основных ОФД. Возвраты вычитаются из внесенных денег. Тестирование проводилось на Бухгалтерия предприятия, редакция 3.0 (3.0.54.15)

1 стартмани

28.12.2017    11402    63    ikbokov    6       

Загрузка кассовых чеков с сервера ФНС. Расширение для 1С: Деньги 22

Инструменты и обработки no Расширение (cfe) v8 1cv8.cf Домашние учет и финансы Россия УУ Кассовые операции Абонемент ($m) WEB

Для тех, кто ведет домашние финансы в 1С:Деньги. Расширение поможет сократить время на ввод данных о расходах, вместо набивания данных руками, данные чека (сумму и товары) можно загрузить из электронного чека, который хранится на сервере ФНС.

1 стартмани

17.11.2017    14768    62    Bazil    49       

Сравнение и синхронизация баз УТ-БП 10

Инструменты и обработки Системный администратор Программист Бухгалтер Внешняя обработка (ert,epf) v8 БП3.0 УТ11 БУ УУ Банковские операции Кассовые операции Оптовая торговля Розничная торговля Абонемент ($m) Обработка документов Анализ учета

Обработка позволяет быстро синхронизировать документы в базах УТ и БП. Будет полезна для бухгалтеров, специалистов поддержки, программистов, руководителей. Тестировалась на конфигурациях Бухгалтерия предприятия, редакция 3.0 (3.0.52.39) и Управление торговлей, редакция 11 (11.3.4.93), платформа 8.3.10.2299.

2 стартмани

08.11.2017    5513    30    leossb    4       

Загрузка в 1С:Бухгалтерию 3.0 данных из ОФД о денежных поступлениях (чеках) 20

Инструменты и обработки Бухгалтер Архив с данными v8 v8::БУ БП3.0 Россия БУ Кассовые операции Абонемент ($m) Обработка документов Загрузка и выгрузка в Excel

Если Ваша торговая точка (ККМ) отделена от 1С:Бухгалтерии, а вносить поступление наличных за день в 1С:Бухгалтерию надо, то автоматизировать процесс оформления наличных в 1С:Бухгалтерию можно!

5 стартмани

09.08.2017    32098    197    ah7777777    104       

Эмулятор ККТ с передачей данных для УПП 1.3.92+, КА 1.1.87+, УТ 10.3.43+ 18

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 КА1 УПП1 Кассовые операции Абонемент ($m) ККМ

Простейший эмулятор обработки обслуживания ККТ с передачей данных.

1 стартмани

28.07.2017    30973    246    Brawler    35       

Загрузка всех онлайн-чеков с сервиса проверки чеков ФНС – обработка для получения данных о покупках по чекам онлайн-касс с загрузкой в Авансовый отчет 13

Инструменты и обработки Системный администратор Программист Бухгалтер Пользователь Внешняя обработка (ert,epf) v8 1cv8.cf Россия Документооборот и делопроизводство Кассовые операции Розничная торговля Учет ТМЦ Абонемент ($m) Внешние источники данных WEB Бухгалтерия

В продолжение статьи «Свой кусочек информационного пирога по 54-ФЗ – обработка для получения данных о своих покупках по чекам ОФД» (на примере сети магазинов «Лента») (http://infostart.ru/public/647711/). Однако, в предыдущей публикации был показан пример получения данных с сервиса ОФД Такском по одному магазину, в новой публикации – показан пример загрузки всех чеков по всем ОФД непосредственно с сервиса проверки чеков ФНС. Опубликованы обработки, позволяющие работать по двум схемам: вносить данные по каждому чеку, получая данные с ФНС, или загружать чеки в мобильное приложение ФНС, выбирая в последующем для загрузки нужные чеки из списка.

3 стартмани

26.07.2017    16754    82    delta    10       

Печать чека ККМ в отчетах о розничных продажах 10

Отчеты и формы Бухгалтер Конфигурация (md, cf) v8 v8::БУ БП3.0 БУ Кассовые операции Абонемент ($m) ККМ

Возможность вывода на печать чека ККМ (Безналичная оплата) в отчетах о розничных продажах.

1 стартмани

24.07.2017    8285    1    maksa2005    2       

Свой кусочек информационного пирога по 54-ФЗ – обработка для получения данных о своих покупках по чекам ОФД (на примере сети магазинов «Лента») 11

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Россия БУ УУ Кассовые операции Розничная торговля Абонемент ($m) Внешние источники данных Мобильная разработка

Новшества по 54-ФЗ в области новой ККТ и все новые аббревиатуры из двух и трех букв (ОФД, ФН, ФД и т.д.) – одни из главных событий в торговой отрасли 2016-2017-2018 гг. Несмотря на всю сложность выполнения новых обязательных требований для магазинов, для рядовых пользователей появляется возможность автоматизировать получение данных о своих покупках от Операторов фискальных данных (ОФД). Вашему вниманию предлагается несколько вариантов использования данных со своих онлайн-чеков (на примере получения данных о покупках в магазинах «Лента»).

1 стартмани

11.07.2017    14275    6    delta    9       

Рабочее место кассира 1С:Розница 2.2 (РМК) как Фронт-офис с поиском по цене и только положительными остатками 30

Инструменты и обработки Бухгалтер Пользователь Внешняя обработка (ert,epf) v8 Розница Розничная и сетевая торговля (FMCG) Россия БУ УУ Кассовые операции Розничная торговля Абонемент ($m) Рабочее место

РМК Розница 2.2.9 с изменениями: 1) Только положительные остатки 2) Поиск по цене 3) Форма РМК с полем ввода (полем поиска) 4) Форма подбора товаров с окном характеристик 5) Внесение ден.средств без РКО и др.

1 стартмани

11.07.2017    31081    121    Vlx    79       

БП 2.0 онлайн-касса (ККТ с передачей данных) 54 ФЗ 20

Инструменты и обработки Системный администратор Программист Бухгалтер Конфигурация (md, cf) v8 v8::БУ БП2.0 Россия БУ Кассовые операции Розничная торговля Абонемент ($m) ККМ Фискальный регистратор

Изменения для объединения с конфигурацией "Бухгалтерия предприятия 2.0" с функционалом для работы с ККТ с передачей данных в ОФД (онлайн-касса), сделана согласно методическим указаниям.

3 стартмани

09.07.2017    30710    135    bob_    53       

Кассовая книга по подразделениям без доработки (Бухгалтерия 3.0 ПРОФ) 10

Отчеты и формы Бухгалтер Внешний отчет (ert,erf) v8 v8::БУ БП3.0 Россия БУ Кассовые операции Абонемент ($m) Бухгалтерские

Внешний отчет "Кассовая книга" для БП 3.0 ПРОФ формируется по каждому обособленному подразделению отдельно (требование законодательства). Доработка типовой конфигурации не требуется! Реализована нумерация документов ПКО и РКО отдельно для каждого подразделения (перенумерацией). Типовой функционал по нумерации листов Кассовой книги по головному подразделению не нарушен.

9 стартмани

08.07.2017    14689    185    SmArtist    31       

Простая печать чеков в соответствии с 54-ФЗ. 4

Инструменты и обработки Системный администратор Программист Бухгалтер Руководитель проекта Архив с данными v8 v8::БУ БП3.0 Россия БУ Windows Кассовые операции Абонемент ($m) Фискальный регистратор

Простая программа для печати чеков на фискальных регистраторах через драйвер компании Штрих-М. Соответствует 54-ФЗ. Подходит для интернет-магазинов.

3 стартмани

07.07.2017    22241    25    Rik30    14       

Эмулятор ККТ 14

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 1cv8.cf Россия Windows Кассовые операции Абонемент ($m) Фискальный регистратор

В связи с применением федерального закона 54 о кассах online появилось новое торговое оборудование ККТ. К сожалению, на просторах интернета я не нашёл Эмулятора под данный вид торгового оборудования. Обработка подойдёт для следующих конфигураций: УПП1.3, УТ10.3, КА1.1 и других, в которых применяется версия API 2.05 P.S. Версия API - это версия взаимодействия конфигурации 1С с обработкой обслуживания торгового оборудования.

1 стартмани

14.06.2017    35740    264    zaoproxy    26       

Обновление Бухгалтерии 2.0 для работы с 54-ФЗ Онлайн кассы 20

Инструменты и обработки Бухгалтер Конфигурация (md, cf) v8 v8::БУ БП2.0 Россия БУ Кассовые операции Абонемент ($m) ККМ SMS рассылки Email

Типовая конфигурация БП 2.0 не поддерживает работу с онлайн кассами. Это обновление конфигурации БП 2.0 позволяет подключить онлайн кассы, печатать чеки, отправлять их по email или SMS.

1 стартмани

08.06.2017    28480    276    Zorkon    120       

Опыт интеграции ФР Штрих-М с 1С 24

Статья Программист Архив с данными v8 1cv8.cf Россия БУ Кассовые операции Абонемент ($m) Фискальный регистратор

Надвигается 1 июля и всем срочно нужны ККМ-онлайн. Публикую свой опыт быстрого и простого решения на базе фискального регистратора Штрих-М для обычных форм.

1 стартмани

01.05.2017    40151    23    Yashazz    75       

Загрузка чеков в 1С:Деньги 15

Инструменты и обработки no Внешняя обработка (ert,epf) v8 1cv8.cf Домашние учет и финансы Россия УУ Кассовые операции Абонемент ($m) Обработка документов WEB

Загрузка чеков в 1С:Деньги с сайта налог.ру. Обработка загружает данные чека с сайта налоговой, сопоставляет наименования с сайта со статьями расхода, из ранее загруженных документов.

1 стартмани

29.04.2017    13117    36    a22011973    24       

54-ФЗ: Онлайн-кассы для 1С 8.1 УТ 10.2. Поддержка Native драйверов Атол 12

Инструменты и обработки Системный администратор Программист Архив с данными v8 v8::ОУ УТ10 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Россия УУ Кассовые операции Оптовая торговля Розничная торговля Абонемент ($m) ККМ

Доработан и адаптирован функционал работы ККТ по 54_ФЗ на УТ 10.2 платформы 8.1. Поддержка драйверов Атол версии 9 (native) и эмулятора ККТ. Код полностью открыт и внесены комментарии для самостоятельной доработки. Протестировано на Атол 11Ф. Распространяется как есть.

10 стартмани

18.04.2017    41416    127    Atom74    69       

FR_Atol_Shtrih.exe печать чеков для ККМ АТОЛ и ШТРИХ на основании текстового файла, где содержится описание товаров, цен, НДС (все требования 54ФЗ поддержка изменений от 01/07/19). Для 1С (7.7 и:8 УФ, Обычных Формы) есть готовые обработки 68

Инструменты и обработки Системный администратор Программист Архив с данными v7.7 v8 v8::УФ 1cv8.cf 1cv7.md Россия Windows Кассовые операции Оптовая торговля Розничная торговля Абонемент ($m) ККМ Фискальный регистратор

Это программа печати чеков, которая читает обычный текстовый файл, где перечислено, что надо распечатать на ФР - описание содержимого чека. Такой механизм позволяет использовать комплект для WEB сайтов, для не типовых или сильно измененных 1с7 или 1с8. Для любых программ которые умеют работать с текстовыми файлами (будь то CLIPPER,FOXPRO,JAVA, WSH, VBS итд). Внутри комплекта лежат готовые внешние печатные формы для печати из документов Реализация товаров и услуг 1с8 УТ10, БП2, БП2Базовая, БП2Корп, УТ11, БП3, БП3Базовая, БП3Корп, Для 1с:ТиС 7.7 Реализация ТМЦ, Бух4.5, Бух1.3 и Печать из ПКО Подключать ФР к 1С не надо! Не надо открывать смену. Подходит для любой конфигурации, для любого документа. Более 300 внедрений на ккм Штрих-Мини-ФР-К, Штрих ОнЛайн Атол 11Ф, 55Ф, 30. Возможна пробитие оплаты наличным или VISA  (Электронные деньги). Поддерживает передачу в ОФД имени кассира, телефон или email покупателя. Для каждого чека можно поменять ОСН (ЕНВД, Доходы-расходы итд). Возможна печать чека с выровненными колонками, Наименование,Количество Цена, Сумма, в этом случае фискализация будет одной строкой с общей суммой. Можно пробить не фискальный чек. (чек будет, но в налоговую не уйдет). Добавлена расшифровка длинных наименований, что актуально для Штрих (программа сама переносит длинные наименования на след строку). Есть внесение и выплата денег. 29.06.17 добавлено пробитие 2 видов оплат в одном чеке.

7 стартмани

11.04.2017    50844    173    ah7777777    473       

ФЗ-54. Печать кассового чека на основании «Реализация товаров и услуг» + автоматическое создание «Приходного кассового ордера». Для ККМ онлайн. УТ 10.3 и УТ 11.1(и выше) 19

Отчеты и формы Бухгалтер Руководитель проекта Внешняя обработка (ert,epf) v8 v8::ОУ УТ10 УТ11 Россия БУ Кассовые операции Розничная торговля Абонемент ($m) Печатные формы документов

Для организаций, принимающих от контрагентов оплату наличными, и перешедших на ККМ-онлайн, согласно ФЗ-54 необходимо печатать кассовый чек с детализацией. Обработка позволяет печатать чек ККМ непосредственно из документа «Реализация товаров и услуг».

5 стартмани

27.03.2017    39804    226    Vagner_Hate    219       

Дополнения для конфигурации 1С:Деньги 8

Инструменты и обработки no Расширение (cfe) v8 1cv8.cf Домашние учет и финансы УУ Банковские операции Финансовый учет и бюджетирование (FRP) Кассовые операции Абонемент ($m) Рабочее место

В процессе использования конфигураций, всем нам периодически хочется каких-то мелочей, которые упростили бы использование этих конфигураций. Здесь я хочу представить некоторые мелочи, которые, как мне кажется, не помешали бы конфигурации 1С:Деньги.

1 стартмани

13.03.2017    9303    6    lopatin    6       

ФЗ-54 Подключение фискальных регистраторов с ФН по TCP. Доработка Розницы 1.0. Обработка обслуживания Штрих-М для драйверов версии 4.13 30

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 КА1 УТ10 Розница Розничная и сетевая торговля (FMCG) УУ Розничная торговля Абонемент ($m) Фискальный регистратор

Обработка осуществляет обслуживание фискальных регистраторов, поддерживаемых драйвером "Штрих-М" версии 4.13 для конфигураций на обычных формах. Обработка позволяет подключать ФР как по TCP, так и через COM. Поддерживается работа двух компонент: "AddIn.SMDrvFR1C20" и "AddIn.SMDrvFR1C". Соответственно обе компоненты должны быть зарегистрированы в системе.

2 стартмани

26.01.2017    60905    171    sdv88    120       

Печать QR кода на слип чеке из 1С:УТ 10.3 для драйверов Штрих-М и АТОЛ 8

Инструменты и обработки no Внешняя обработка (ert,epf) v8 УТ10 Россия Кассовые операции Розничная торговля Абонемент ($m) Фискальный регистратор

Печать QR-кода на слип чеке, при продаже алкогольной продукции. Одна обработка для ФР работающие с драйверами Штрих-М и вторая обработка для ФР работающие с драйверами АТОЛ.

1 стартмани

08.08.2016    28537    105    delsoft    7       

Печать QR из УТ 10.3 Fprint ЕГАИС 21

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::ОУ УТ10 Розничная и сетевая торговля (FMCG) Windows Розничная торговля Абонемент ($m) Фискальный регистратор

На чековой ленте теперь необходимо печатать QR со ссылкой на чек в системе ЕГАИС. Стандартная обработка работы с фискальными регистраторами АТОЛ в УТ 10.3 этого делать не умеет. Не умеет - научим, не захочет - заставим. В статье приведен весь исходный код.

1 стартмани

19.06.2016    29562    60    erutan    26