Вывод информации на второй дисплей (дисплей покупателя)

Публикация № 538855

Разработка - Практика программирования

Второй дисплей второй экран второй монитор

7
Программа для обеспечения взаимодействия 1С со вторым дисплеем.

Столкнулся с необходимостью выводить информацию на второй дисплей для покупателей. Написал внешнюю программу для реализации данной задачи. Программа читает файл, находящийся в папке с программой 1.htm, и, если  дата записи файла была изменена с момента последнего отображения, то тогда отображает его на экране. При запуске программы она автоматически запускается на втором мониторе и через 10 секунд разворачивается во весь экран. Если второй монитор отключен, то запуск произойдет на основном мониторе. Тогда пользователь должен успеть включить второй и перетащить на него за десять секунд или закрыть программу и запустить ее после включение дополнительного монитора. Если не успели закрыть программу до ее разворачивания на весь экран, то закрыть можно через стандартную комбинацию клавишь Alt F4. Интервал проверки файла на изменения 1 секунда. Файл 1.htm созадется из табличного документа и это позволяет вывести любую информацию на дисплей стандартными средствами 1С, исключая, разве что видео(для этого уже нужно формировать файл вручную). Для работы программы необходим Net Frame Work (для XP версия 4.0, для Vista и выше 4.5.2), как правило, он в системе уже установлен при установке других прогрмм.

Пример вывода заказа покупателя для конфигурации 1С:УПП

Перем ВторойДисплей,МакетВторойДисплей,МакетРеклама;

Процедура ПриОткрытии()
	//проверяем нужно ли выводить информацию на второй дисплей
        //если есть папка с программой C:\secondmonitor, то значит второй дисплей используется
	КаталогНаДиске = Новый Файл("C:\secondmonitor");
	ВторойДисплей=Ложь;
	Если КаталогНаДиске.Существует() Тогда
		ВторойДисплей=Истина;
		МакетВторойДисплей=ПолучитьОбщийМакет("ВторойДисплей");
                МакетРекама=ПолучитьОбщийМакет("Реклама");
		ВывестиИнформациюНаВторойДисплей();
	КонецЕсли;	
КонецПроцедуры // ПриОткрытии()

Процедура ВывестиИнформациюНаВторойДисплей()
	Если Товары.Количество()+Услуги.Количество()=0 Тогда
		Возврат;
	КонецЕсли;	
	ТабДок=Новый ТабличныйДокумент;
	Область=МакетВторойДисплей.ПолучитьОбласть("Шапка");
	Область.Параметры.Ссылка=Ссылка;
	ТАбДок.Вывести(Область);
	Итого=0;
	НомерСтроки=1;
	Для каждого СтрокаТЧ из Товары Цикл
		Область=МакетВторойДисплей.ПолучитьОбласть("Строка");
		Область.Параметры.Заполнить(СтрокаТЧ);
		Область.Параметры.НомерСтроки=НомерСтроки;
		НомерСтроки=НомерСтроки+1;
		Итого=Итого+СтрокаТЧ.Сумма;
		ТабДок.Вывести(Область);
	КонецЦикла;
	Для каждого СтрокаТЧ из Услуги Цикл
		Область=МакетВторойДисплей.ПолучитьОбласть("Строка");
		Область.Параметры.Заполнить(СтрокаТЧ);
		Область.Параметры.НомерСтроки=НомерСтроки;
		НомерСтроки=НомерСтроки+1;
		Итого=Итого+СтрокаТЧ.Сумма;
		ТабДок.Вывести(Область);
	КонецЦикла;
	Область=МакетВторойДисплей.ПолучитьОбласть("Подвал");
	Область.Параметры.Итого=Итого;
	ТабДок.Вывести(Область);
        ТабДок.Вывести(МакетРеклама.ПолучитьОбласть("Реклама"));
	Попытка
		ТабДок.Записать("C:\secondmonitor\1.htm",ТипФайлаТабличногоДокумента.HTML);
	Исключение
		
	КонецПопытки;
КонецПроцедуры

Процедура ОбработкаВыбора(ЗначениеВыбора, Источник) Экспорт

	Если ВторойДисплей Тогда
		ВывестиИнформациюНаВторойДисплей();
	КонецЕсли;	
	
КонецПроцедуры // ОбработкаВыбора()

Процедура ПриЗакрытии()

	Если ВторойДисплей Тогда
		ТабДок=Новый ТабличныйДокумент;
                ТабДок.Вывести(МакетРеклама.ПолучитьОбласть("Реклама"));
		Попытка
			ТабДок.Записать("C:\secondmonitor\1.htm",ТипФайлаТабличногоДокумента.HTML);
		Исключение
			
		КонецПопытки;
	КонецЕсли;
	
КонецПроцедуры // ПриЗакрытии()

Процедура ТоварыПриОкончанииРедактирования(Элемент, НоваяСтрока, ОтменаРедактирования)
	
        Если ВторойДисплей Тогда
		ВывестиИнформациюНаВторойДисплей();
	КонецЕсли;	
		
КонецПроцедуры // ТоварыПриОкончанииРедактирования()

Процедура ТоварыПослеУдаления(Элемент)
	
        Если ВторойДисплей Тогда
		ВывестиИнформациюНаВторойДисплей();
	КонецЕсли;	

КонецПроцедуры // ТоварыПослеУдаления()

Процедура УслугиПриОкончанииРедактирования(Элемент, НоваяСтрока, ОтменаРедактирования)

	Если ВторойДисплей Тогда
		ВывестиИнформациюНаВторойДисплей();
	КонецЕсли;	

КонецПроцедуры // УслугиПриОкончанииРедактирования()

Процедура УслугиПослеУдаления(Элемент)

	Если ВторойДисплей Тогда
		ВывестиИнформациюНаВторойДисплей();
	КонецЕсли;	

КонецПроцедуры // УслугиПослеУдаления()




В 

7

Скачать файлы

Наименование Файл Версия Размер
SecondMonitor.exe
.exe 43,50Kb
25.07.16
21
.exe 43,50Kb 21 Скачать
SecondMonitorXP.exe
.exe 43,50Kb
25.07.16
6
.exe 43,50Kb 6 Скачать

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. zaliznyj 21.12.16 13:32 Сейчас в теме
Что бы вывести информацию на второй монитор достаточно скачать и установить файл SecondMonitor.exe ?
2. Bienko 177 21.12.16 21:14 Сейчас в теме
Добрый вечер! Не совсем! SecondMonitor.exe выводит html файл, который расположен в его папке. Сам же файл вам нужно формировать самостоятельно. Оптимальный вариант через табличный документ. В описании пример формирования такого файла для заказа конфигурации УПП.
3. zaliznyj 21.12.16 22:39 Сейчас в теме
(2)Если не подключон второй монитор то SecondMonitor.exe не запустится? Под рукой нету второго монитора не могу понять. все ли я правильно сделал
4. Bienko 177 22.12.16 07:15 Сейчас в теме
Она запуститься, но на основном дисплее. Через несколько секунд она развернется на весь экран. Крестика не будет (после развертывания). Закрыть можно через ATL-F4
5. zaliznyj 23.12.16 09:18 Сейчас в теме
(4)Доброе утро Максим! Спасибо за SecondMonitor.exe. Установил без особых проблем. Работает все супер. Дешево просто и еффективно. Очень хорошая получилась обработка для вывода на монитор покупателя. Очень доволен. Оправдала все мои надежды. Большое спасибо за решение мох проблем!!!!

При установке возникло две маленьких проблемы:
1. Я как чайник не сообразил что ( ПолучитьОбщийМакет("ВторойДисплей");) Макеты нужно создать самому.
2. В описании примера В строке кода МакетРекама=ПолучитьОбщийМакет("Реклама") в процедуре Процедура ПриОткрытии() пропущена буква Л. Долго не мог открыть Макет реклама. Говорю что ЧАЙНИК. Поэтому не удивляйтесь.

Есть еще одна проблемка при запуске SecondMonitor.exe
- ЗапуститьПриложение("C:\secondmonitor\secondmonitor.exe")
Приложение открывается но URL-Адрес указывается не правильно Берется из каких то предварительных настроек. Поэтому запустить его можно только вручную
Нельзя ли Исправить?

6. Bienko 177 23.12.16 14:02 Сейчас в теме
Добрый день! По поводу ЗапуститьПриложение("C:\secondmonitor\secondmonitor.exe"). У меня везде прописано в автозапуске операционной системы. Менеджеры приходят на работу и при включении компьютера программа сразу запускается и целый день работает. Так запускается нормально. Сам путь берется из пути запуска программы. В самой команде ЗапуститьПриложение(<СтрокаКоманды>, <ТекущийКаталог>, <ДождатьсяЗавершения>, <КодВозврата>) есть ТекущийКаталог. Попробуй его указать "C:\secondmonitor\". Самой простой вариант (кто его знает как 1с запускает, может и в темп копирует предварительно или еще чего) запускать не саму программу тогда, а bat файл, а уже из него запускать программу. Так должно работать, даже если 1с будет этот батник куда-то копировать.
7. Bienko 177 23.12.16 14:04 Сейчас в теме
Еще может быть на момент запуска файл в папке программы не существует (если вы его программно удаляете в каких-то случаях)
8. zaliznyj 23.12.16 15:09 Сейчас в теме
Спасибо. Открывается програмно без проблем.
9. hajiyevrr 23.02.17 14:37 Сейчас в теме
10. TODD22 18 09.08.17 09:18 Сейчас в теме
Здравствуйте.

Почему может не отображать содержимое?
В каталоге C:\secondmonitor\ есть файл 1.htm. Браузером открывается.
Но после запуска открывается окно в котором написано что не удалось отобразить страницу, не верный путь ли попробуйте обновить и тд.
В чём может быть проблема?
11. Bienko 177 09.08.17 13:36 Сейчас в теме
Добрый день! По вашему описанию все должно работать. Пришлите файл 1.htm, - я его у себя проверю.
12. TODD22 18 11.08.17 07:05 Сейчас в теме
Всё отлично заработало. Проблема была в том что файл secondmonitor лежал не в той же папке что и файл 1.htm.
13. TODD22 18 11.08.17 08:16 Сейчас в теме
А чем сделано отображение html файла?
У меня в браузере файл выглядит не так как в secondmonitor.
Между табличной частью и картинкой у меня есть отступ. В браузере(хром и IE) он меньше. А когда открываю монитором то отступ увеличивается в 2 раза....
14. maipochta 10.05.18 18:19 Сейчас в теме
видео пробовал кто-нибудь выводить? Попробовал несколько способов в hml файле, не сработало.
Оставьте свое сообщение

См. также

Вам нравятся запросы в 1С? 14

Инструменты и обработки Программист Конфигурация (md, cf) v8 v8::Запросы 1cv8.cf Абонемент ($m) Практика программирования Разработка

Речь не только о том, что простейший запрос с "легальным" оформлением растянется на пол-экрана, речь еще обо всем, что нужно написать "в нагрузку" к тексту запроса. Все эти "Новый Запрос", "УстановитьПараметр" и последующие пляски с обработкой результата... Пора с этим заканчивать!

1 стартмани

03.07.2019    11365    1    m-rv    79       

Перенос данных КА 1.1 / УПП 1.3 => БП 3.0 (перенос остатков, документов и справочников из "1С:Комплексная автоматизация 1.1" / УПП 1.3 в "1С:Бухгалтерия 3.0"). Обновлен до версий КА 1.1.115.х, УПП 1.3.127.х! Промо

Разработка позволяет перенести остатки по всем счетам бух.учета в программу "1С:Бухгалтерия предприятия 8", ред. 3.0 на выбранную дату начала ведения учета. Также переносятся документы за период и вся необходимая справочная информация. Правила оперативно обновляю при выходе новых релизов. Рассылка обновлений правил бесплатно в течение 12 месяцев. Есть видеодемонстрация проведения переноса данных. Конфигурации при использовании обмена остаются полностью типовыми. Перенос данных возможен в Бухгалтерию 3.0 версии ПРОФ, КОРП или базовую.

24700 руб.

1С:Ассемблер. Немного летнего веселья! 313

Статья Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Практика программирования Разработка

Все вы, наверное, слышали, что 1С-ники жалуются на свою систему, считая язык 1С недостаточно низкоуровневым, скучным и т.п. Все они с тоской поглядывают в сторону "настоящих" языков программирования. Так вот, господа, они неправы. В системе 1С есть места, где можно размять программерский мозг и получить удовольствие от низкоуровневой техники. Предлагаю вам погрузиться в недра виртуальной машины 1С и понять, как она работает. Там есть свой "ассемблер" и мы попробуем его в действии!

1 стартмани

21.06.2019    15966    49    Evil Beaver    116       

Простые примеры сложных отчетов на СКД 270

Статья Программист Архив с данными v8 v8::СКД 1cv8.cf Абонемент ($m) Практика программирования

Подписи в отчете. Особенности соединения наборов: как соединить несоединяемое. Остатки на дату и обороты по месяцам в одном отчете. Курс валюты на каждую дату без группировок и соединений в запросе. Отчет с произвольными колонками и с произвольной последовательностью. "Неадекватный отчет".

1 стартмани

12.06.2019    15722    11    Hatson    22       

Готовые переносы данных из различных конфигураций 1C Промо

Рекомендуем готовые решения для переноса данных из различных конфигураций 1C. C техподдержкой от разработчиков и гарантией от Инфостарт.

Безопасная работа с транзакциями во встроенном языке 190

Статья Программист Конфигурация (md, cf) v8 1cv8.cf Абонемент ($m) Практика программирования

Разбираемся с опасностями использования транзакций во встроенном языке 1С. Познаем ошибку "В данной транзакции уже происходили ошибки". Учимся защищаться от них.

1 стартмани

25.03.2019    17621    8    tormozit    44       

Коннектор: удобный HTTP-клиент для 1С:Предприятие 8 562

Инструменты и обработки Программист Конфигурация (md, cf) v8 1cv8.cf Абонемент ($m) Практика программирования Внешние источники данных WEB Универсальные функции Инструментарий разработчика Универсальные обработки

Коннектор - библиотека для работы с HTTP запросами. Библиотека берет на себя всю рутину работы с HTTP запросами. Буквально в одну строку можно получать данные, отправлять, не заботясь о необходимости конструирования URL, кодирования данных и т.п.

1 стартмани

31.01.2019    31191    281    bonv    117       

TurboConf 5 - расширение Конфигуратора 1С Промо

TurboConf повышает эффективность работы в Конфигураторе 1С и помогает автоматизировать рутинные задачи. Программа добавляет в Конфигуратор десятки возможностей, которые делают разработку в Конфигураторе намного удобнее и быстрее.

TextRadar - нечеткий поиск в тексте 10

Инструменты и обработки Программист Компонента, плагин (dll, vbs,..) v8 1cv8.cf Абонемент ($m) Разработка внешних компонент

В отличие от нечеткого сравнения строк, когда обе сравниваемых строки равнозначны, в задаче нечеткого поиска выделяются строка поиска и строка данных, а вычислить необходимо не степень похожести двух строк, а степень присутствия строки поиска в строке данных. Нормированный коэффициент, находящийся между 0 и 1 позволяет отсечь заведомо низкие результаты, организовать поиск по синонимам и т.д. Наглядное отображение результатов в кратком и детальном виде поможет быстро найти интересующий фрагмент.

5 стартмани

19.09.2018    8584    15    TSSV    14       

Работа с публикациями "Инфостарт" 14

Инструменты и обработки Программист Архив с данными v8 УУ Абонемент ($m) Практика программирования О сообществе WEB

Работа с рублевыми публикациями на сайте "Инфостарт": ведение клиентов, заказов, обновление файлов публикации, рассылка обновлений.

1 стартмани

13.09.2018    10739    10    RocKeR_13    16       

Базовый курс по разработке мобильных 1C-приложений для Android-устройств. Третий поток. Онлайн-интенсив с 11 февраля по 05 марта 2020 г. Промо

Данный онлайн-курс предусматривает изучение базовых принципов создания приложений для операционной системы Android, работающих на мобильной платформе “1С:Предприятие”. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие” при разработке прикладных решений для “обычных” компьютеров, но пока ещё не занимался разработкой 1С-приложений, предназначенных для работы на мобильных устройствах.

7500 рублей

Позиционирование в помещении с помощью нейросети по сигналу Wi-Fi. Интерактивная карта склада в 1С с показом позиции 65

Инструменты и обработки Программист Бизнес-аналитик Приложение (apk) v8 Windows Абонемент ($m) Инструментарий разработчика Практика программирования

Данная публикация содержит в себе редактор и интерактивную карту склада или иного помещения, на которой в реальном времени отображается позиция устройства, координаты которого вычисляются по уровням сигнала нескольких роутеров Wi-Fi. В статье и приложенным к ней разработкам предлагаются инструменты и методика для реализации вычисления точной геопозиции внутри помещений с помощью нейронной сети. Конфигурация написана на релизе 1С:Предприятие 8.3.12.1412, клиентское приложение имеет минимальный уровень совместимости SDK -16.

5 стартмани

09.08.2018    17365    23    informa1555    26       

Работа с данными выбора 41

Инструменты и обработки Программист Архив с данными v8 Россия Абонемент ($m) Практика программирования Работа с интерфейсом

В управляемом интерфейсе заложена мощная возможность описывать связи реквизитов формы через параметры. Установка параметров связей позволяет ограничить выбор данных так, чтобы целостность данных была обеспечена на этапе ввода. Однако без дополнительного программирования задать можно только самые простые связи. Такие условия связи, как зависимость от реквизита через точку или зависимость через дополнительное отношение, заданное в регистре сведений - уже задать без программирования не получится.

1 стартмани

17.07.2018    24316    14    kalyaka    15       

Подборка программ для взаимодействия с ЕГАИС Промо

ЕГАИС (Единая государственная автоматизированная информационная система) - автоматизированная система, предназначенная для государственного контроля за объёмом производства и оборота этилового спирта, алкогольной и спиртосодержащей продукции. Инфостарт рекомендует подборку проверенных решений для взаимодействия с системой.

HTTP Сервисы: Путь к своему сервису. Часть 1 287

Статья Системный администратор Программист Расширение (cfe) v8 1cv8.cf Абонемент ($m) Практика программирования WEB

Уже много было написано про http-сервисы, но то и дело всплывают «Новые» статьи по обмену между базами V8 по COM, что «Немножко» удивляет. Решил внести свои 5 копеек, поработаем с http-сервисом.

1 стартмани

15.07.2018    43067    17    dsdred    22       

ВСТАВИТЬ В Справочник.Номенклатура (Код, Наименование) ЗНАЧЕНИЯ ("001", "Новый товар") 105

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::Запросы 1cv8.cf Абонемент ($m) Практика программирования

Вас не обманывают ваши глаза, это запрос на изменение данных! И это работает без прямого доступа к БД, регистрации и смс.

1 стартмани

01.06.2018    20996    86    m-rv    57       

1C:Предприятие для программистов: Запросы и отчеты. Второй поток. Онлайн-интенсив с 17 марта по 16 апреля 2020 г. Промо

Данный онлайн-курс предусматривает углубленное изучение языка запросов и возможностей системы компоновки данных, которые понадобятся при разработке отчетов, работающих на платформе “1С:Предприятие” в рамках различных прикладных решений. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”, а также для опытных пользователей различных прикладных решений, которые используют в своей работе отчеты разного назначения.

6500 рублей

БСП: Дополнительная обработка (Регламенты), примеры от простого к сложному 242

Статья Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Практика программирования БСП (Библиотека стандартных подсистем)

Очень много попадается странных решений, которые можно решить через БСП:Дополнительные отчеты и обработки. Я бы вообще БСП из-за этой подсистемы переименовал в «Большое Спасибо Программистам». Поработаем с подсистемой в части написания регламентных заданий.

1 стартмани

10.05.2018    29525    28    dsdred    34       

Онлайн-курс "Технология выполнения проектов ERP-класса – процессный подход". Третий поток. Курс проходит с 21 января по 18 марта 2020 года. Промо

Курс разработан Внедренческим центром «Раздолье». Курс предназначен для подготовки аналитиков, архитекторов и руководителей проектов автоматизации процессов управления с использованием комплексных ИТ-систем (1С:ERP, 1С:УХ, 1С:КА, 1С:УТ). В основе курса лежит методика применения процессного подхода.

9000 рублей

Tool1CD Beta в деле 99

Инструменты и обработки Программист Компонента, плагин (dll, vbs,..) v8 Абонемент ($m) Разработка внешних компонент

Пс, парень! Не хочешь немного сырых байтов?

1 стартмани

09.05.2018    18619    29    baton_pk    26       

Как выполнить отчет на СКД через COM и получить данные отчета? 86

Статья Программист Архив с данными v8 УПП1 Россия Windows Абонемент ($m) Практика программирования

Для чего это нужно. Например, нужно в одной базе получить какой-либо показатель из другой базы. Этот показатель вычисляется в каком-либо сложном отчете, который написан на СКД. Можно, конечно, "скопипастить" текст запроса из другой базы, немного подправить его и выполнять в том же COM подключении. Но с этим теряется гибкость: если отчет изменился, то нужно помнить о том, что где-то есть его "немного модифицированная" копия. В статье будет рассмотрен пример получения данных из базы ЗУП.

2 стартмани

08.05.2018    19106    10    wowik    3       

Перенос документов и справочников ERP 2 / КА 2 / УТ 11 => БП 3.0 Промо

Перенос позволяет настроить собственный обмен данными между указанными программами, альтернативный предлагаемому фирмой 1С. Предоставляем техподдержку по всем вопросам данного обмена. Можем подключиться к вам удаленно для разбора ситуаций. Оперативно обновляем при выходе новых релизов 1С. Бесплатные обновления в течение полугода.

19700 руб.

Работа со схемой запроса 176

Статья Программист Конфигурация (md, cf) v8 v8::Запросы Абонемент ($m) Инструментарий разработчика Практика программирования

Стандартом взаимодействия с реляционной базой данных стал язык SQL. Приемником SQL в 1С является язык запросов. Язык запросов, также как и SQL, является структурированным. Составляющие структуры запроса отвечают на разные вопросы о том, какие данные требуется получить и какие манипуляции с множествами данных необходимо произвести при получении. В простых случаях текст запроса можно написать вручную, однако в сложных случаях, а также при программном формировании, - лучше воспользоваться объектной моделью запроса и использовать объект "Схема запроса". В статье дается описание объектной модели и особенностей работы с ней, а также приводится решение, упрощающее взаимодействие с объектом "Схема запроса".

1 стартмани

24.04.2018    30347    75    kalyaka    34       

Внешняя компонента для работы по Web-socket протоколу 22

Инструменты и обработки Программист Архив с данными v8 Windows Абонемент ($m) Разработка внешних компонент WEB

Кто когда-нибудь сталкивался с обменом данными по Web-Socket (wss) протоколу из 1С, тому известно, что в платформе отсутствуют данные механизмы (не путать с HTTP запросами и WebServices). Предлагается использовать внешнюю компоненту, написанную по технологии NativeAPI, для подключения и обмена с серверами из 1С-Предприятия, работающими по протоколу Web-Socket.

5 стартмани

30.03.2018    14972    9    Ditron    63       

Подборка решений для взаимодействия со ФГИС «Меркурий» Промо

С 1 июля 2019 года все компании, участвующие в обороте товаров животного происхождения, должны перейти на электронную ветеринарную сертификацию (ЭВС) через ФГИС «Меркурий». Инфостарт предлагает подборку программ, связанных с этим изменением.

Заполняем по шаблону (по умолчанию) 69

Инструменты и обработки Программист Архив с данными v8 v8::УФ 1cv8.cf Абонемент ($m) Практика программирования

Простой в подключении, универсальный и достаточно удобный механизм заполнения реквизитов произвольных документов/справочников значениями по умолчанию. Реализован в расширении, но может быть и непосредственно включен практически в любую конфигурацию на управляемых формах простым копированием одной формы и двух команд. Весь код в статье.

1 стартмани

08.02.2018    18863    20    mvxyz    17       

Бесплатная проверка контрагентов в ФНС (общий модуль с алгоритмом). На примере выводим статус в список справочника контрагентов 124

Статья Программист Конфигурация (md, cf) v8 1cv8.cf Абонемент ($m) Практика программирования

Если вам интересно проверить контрагенте в ФНС, вам поможет данная публикация. Весь алгоритм работы строится на основе данных, полученных с сервиса http://npchk.nalog.ru совершенно бесплатно.

1 стартмани

01.02.2018    26565    62    rpgshnik    46       

Базовый курс для начинающих 1С-программистов. Пятый поток. Онлайн-курс с 12 февраля по 15 апреля 2020 г. Промо

Данный онлайн-курс является начальной ступенью по изучению базовых принципов программирования в системе “1С:Предприятие” и предназначен для обучения 1С-программированию “с нуля”.

4500/9500 рублей

Расширение возможностей печати: Вывод произвольного нижнего и верхнего колонтитула 8

Отчеты и формы Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Печатные формы документов Практика программирования Универсальные функции

Расширяем функционал вывода нижнего / верхнего колонтитула. Стандартно 1С имеет достаточно ограничений по выводу и наполнению колонтитулов содержимым, взять хотя бы такие, как вывод только текста и отсутствие ограничения на номер конечной страницы. А при разработке кода сталкиваешься с тем, что свой блок с нижним колонтитулом нужно прижимать к низу страницы. Казалось бы быстро решаемый вопрос, но и в нем есть нюансы. Сейчас я расскажу о том, как решалась эта задача. UPD 15.02.2018. Добавлен вывод верхнего колонтитула; Вывод колонтитулов на первой и последней странице управляется параметрами; Научился считать страницы: Добавлено заполнение переменных аналогичных стандартным из колонтитулов; Задаются форматы даты и времени. Ограничения прежние: 1. Повторно сформировать табличный документ после смены параметров страницы интерактивно.; 2. Передавать данные для более плотной печати как можно более мелко нарезанными кусками.

1 стартмани

29.12.2017    24845    21    agent00mouse    0       

Практика доступа в базу 1С через протокол oData. Чтение данных 288

Статья Системный администратор Программист Бизнес-аналитик Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Сервисные утилиты Практика программирования Администрирование данных 1С

Для чего нужен доступ в базу 1С через REST-интерфейс по протокол oData? Как его организовать? Как не будучи гуру в JavaScript и .NET получить быстрый визуальный доступ к данным базы 1С? Попробую дать ответ на эти вопросы и прокомментирую некоторые нюансы, с которыми я столкнулся.

1 стартмани

11.12.2017    62769    260    Dementor    44       

Перенос данных КА 1.1 => ERP 2 (ЕРП) (обработка переноса документов, остатков и справочной информации из "1С:Комплексная автоматизация, ред. 1.1" в "1С:ERP Управление предприятием, ред 2"). Обновлен до КА 1.1.115.х и ERP 2.4.10.х Промо

Обработка позволяет переносить из КА 1.1 в ERP 2 документы за выбранный период и остатки. Типовая обработка от фирмы 1С документы не переносит. Также исправлены ошибки типовой обработки. При выходе новых релизов обновление высылается бесплатно в течение года. Разработка будет полезна фирмам-франчайзи, которые периодически выполняют такой перенос данных для заказчиков. Вы можете один раз приобрести обработку переноса, и потом бесплатно получать обновления в случае выхода новых релизов конфигураций 1С.

29700 руб.

Печатная форма, сделанная как расширение конфигурации для БП 3.0. Новые возможности БСП 26

Инструменты и обработки Программист Расширение (cfe) v8 БП3.0 Абонемент ($m) Практика программирования Универсальные печатные формы

Печатные формы на внешних обработках скоро канут в лету. На смену им приходят ПФ, реализованные в виде расширений конфигурации. Не нашел на сайте примеров таких расширений. Привожу пример подобного расширения для БП 3.0.

1 стартмани

06.12.2017    19525    52    kwazi    6       

Простой бесплатный DashBoard с помощью http сервиса 257

Статья Программист Конфигурация (md, cf) v8 Абонемент ($m) Практика программирования

Как создать свой DashBoard без дополнительных затрат и сложных технических доработок.

1 стартмани

25.11.2017    45639    59    dewersia    32       

Программы для исполнения 488-ФЗ: Маркировка товаров Промо

1 января 2019 года вступил в силу ФЗ от 25.12.2018 № 488-ФЗ о единой информационной системе маркировки товаров с использованием контрольных (идентификационных) знаков, который позволяет проследить движение товара от производителя до конечного потребителя. Инфостарт предлагает подборку программ, связанных с применением 488-ФЗ и маркировкой товаров.

Макеты СКД 292

Статья Программист Внешний отчет (ert,erf) v8 v8::СКД 1cv8.cf Абонемент ($m) Практика программирования

Рассмотрены некоторые типовые задачи, которые решаются с помощью предопределенных макетов, а также перечислены несколько случаев, для которых макеты не подходят

1 стартмани

25.07.2017    73687    111    json    25       

Расширения конфигураций 1С: учимся перехватывать методы 115

Инструменты и обработки Программист Расширение (cfe) v8 v8::УФ 1cv8.cf Абонемент ($m) Практика программирования

В этой статье я на примерах разберу некоторые механизмы расширений конфигураций 1С. А именно «перехваты» методов модуля объекта и «перехваты» событий формы и элементов формы. Данная статья написана с учебными целями, чтобы показать, как при помощи расширений конфигурации можно делать такие доработки, ради которых раньше приходилось снимать конфигурацию с поддержки.

1 стартмани

30.05.2017    88793    14    signum2009    45