"Защита от опасных действий" или как снять галочку у всех пользователей

Администрирование - Защита, права, пароли

Защита от опасных действий

12
В новых версиях платформы 1С:Предприятие 8.3 (8.3.9.2033) появилась очень замечательная фишка. Реквизит у пользователя "Защита от опасных действий"

Реквизит у пользователя "Защита от опасных действий " 

Очень полезное свойство. Но когда пользователей в базе около 100 , а баз 10 ки .

Данная обработка снимает галочку у все пользователей "Защита от опасных действий"

12

Скачать файлы

Наименование Файл Версия Размер
ПОЛЬЗОВАТЕЛИ.epf
.epf 5,67Kb
17.01.17
108
.epf 5,67Kb 108 Скачать

См. также

Лучшие комментарии
1. Tatitutu 3724 17.01.17 11:10 Сейчас в теме
Сразу предупреждаю тех - "у кого не работает"
Зайдите в конфигуратор и посмотрите, где нужно
Стоит "защита от дурака" - на всякий случай !
Остальные комментарии
Избранное Подписка Сортировка: Древо
1. Tatitutu 3724 17.01.17 11:10 Сейчас в теме
Сразу предупреждаю тех - "у кого не работает"
Зайдите в конфигуратор и посмотрите, где нужно
Стоит "защита от дурака" - на всякий случай !
2. Alex_E 1886 17.01.17 11:20 Сейчас в теме
Вопрос, а файле conf.cfg параметр DisableUnsafeActionProtection, не то же самое делает?
3. pumbaE 608 17.01.17 12:05 Сейчас в теме
(2) только не забывайте, что conf.cfg надо как на сервере, так и на клиентах прописывать.
6. Tatitutu 3724 17.01.17 15:35 Сейчас в теме
(2) Пробовал на практике ?

Результат видел ?

в базе от 100 пользователей

под админом запустил обработку - 2-5 секунд
и у всех пользователей эта галочка снята
7. Alex_E 1886 17.01.17 15:57 Сейчас в теме
4. Fragster 852 17.01.17 12:19 Сейчас в теме
Очень полезное свойство

вот тут готов не согласиться. если у пользователя есть права на добавление расширений или открытие внешних обработокчерез файл - открыть, то он и так должен быть ответственным и понимать, что делает. А если нет - то и предупреждение не нужно. А вот то, что из-за этой галочки сломалось создание расширений в конфигураторе, нужно переписывать регламентные задания, использующие ВК и т.п. - это плохо.

ИМХО добавление отдельной роли в БСП было правильным шагом для борьбы с вымогателями, а дополнительный диалог, в котором пользователь жахнет не глядя "подтвердить" при открытии внешней обработки, пришедшей по почте ни от чего не спасет.

Правильно не дать пользователю возможности запускать код, не прошедший аудит.
artbear; theshadowco; davdykin; Fox-trot; +4 Ответить
5. Tatitutu 3724 17.01.17 12:30 Сейчас в теме
(4) Антонио (Fragster) - ну прям , как маленький ))))
Если бы это было бы ОЧЕНЬ ПОЛЕЗНОЕ свойство - не было бы этой публикации и множества других подобных тем.
В кавычки не выделил по известной причине. А так это галочка - лично мое мнение,только для ГАЛОЧКИ - защиту поставили !
8. tank68 15 11.04.17 18:37 Сейчас в теме
Для массового изменения


Процедура КнопкаВыполнитьНажатие(Кнопка) 

Запрос = Новый Запрос; 
Запрос.Текст = 
"ВЫБРАТЬ 
|	Пользователи.Ссылка, 
|	Пользователи.ИдентификаторПользователяИБ 
|ИЗ 
|	Справочник.Пользователи КАК Пользователи"; 

РезультатЗапроса = Запрос.Выполнить(); 

Выборка = РезультатЗапроса.Выбрать(); 

#Если Клиент Тогда 
Процессор = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВКоллекциюЗначений; 
Процессор.ОтображатьПроцентВывода = Истина; 
Процессор.НачатьВывод(); 
Элемент = Новый ЭлементРезультатаКомпоновкиДанных; 
#КонецЕсли 

Колво = Выборка.Количество(); 
НомерПП = 0; 


Пока Выборка.Следующий() Цикл 

НомерПП = НомерПП+1; 
#Если Клиент Тогда 
Состояние(""+ТекущаяДата()+" Обрабатывается "+ НомерПП+" из "+Колво); 
Элемент.ПроцентВывода = НомерПП/Колво*100; 
Процессор.ВывестиЭлемент(Элемент); 
#КонецЕсли 

Попытка 

Пользователь1с = ПользователиИнформационнойБазы.НайтиПоУникальномуИдентификатору(Выборка.ИдентификаторПользователяИБ); 
Пользователь1с.ЗащитаОтОпасныхДействий.ПредупреждатьОбОпасныхДействиях = Ложь; 
Пользователь1с.Записать();	

Исключение 

Сообщить(""+ТекущаяДата()+" "+ОписаниеОшибки()); 

КонецПопытки; 

КонецЦикла; 

#Если Клиент Тогда 
Процессор.ЗакончитьВывод(); 
#КонецЕсли 

КонецПроцедуры
Показать
rii; Painted; +2 Ответить
9. Painted 20 23.05.17 13:49 Сейчас в теме
(8) Проверку на "ЭтоГруппа" у себя добавил.
10. Alex.O 12.06.17 10:37 Сейчас в теме
можно сделать проще:
	мПользователи = ПользователиИнформационнойБазы.ПолучитьПользователей();
	Для Каждого Пользователь из мПользователи Цикл
		Если Пользователь.ЗащитаОтОпасныхДействий.ПредупреждатьОбОпасныхДействиях Тогда
			Пользователь.ЗащитаОтОпасныхДействий.ПредупреждатьОбОпасныхДействиях = Ложь; 
			Попытка
				Пользователь.Записать();
				Сообщить("Обработан пользователь: "+Пользователь.Имя);
			Исключение
				Сообщить(""+Пользователь.Имя+" : "+ОписаниеОшибки());
			КонецПопытки;			
		КонецЕсли;
	КонецЦикла;
Показать
slitov; dynamicsystems; klinval; lDenisZl; Wrols; ice-net; Дмитрий74Чел; MICK77; Painted; +9 Ответить
11. Painted 20 19.06.17 16:40 Сейчас в теме
(10) Так даже лучше. Особенно, если нет справочника "Пользователи".
12. kite2 27 23.08.17 09:29 Сейчас в теме
Обновили платформу ночью в холдинге - очень утром помогло. Спасибо.
Оставьте свое сообщение