Управляемый Android Service перехвата сообщений Broadcast со сканера штрих-кодов в 1С (ver. 1.2.2)

Публикация № 587908

Разработка - Мобильная разработка

Внешнее событие Штрих-код сервис Broadcast Мобильное приложение Service

53
Service перехвата сообщений Broadcast со сканера штрих-кодов в мобильную платформу 1С (эмуляция внешнего события). Позволяет получать и обрабатывать Штрих-коды не в разрыв клавиатуры (определенное активное окно), а "под капотом". Поддержка запуска/остановки из программного кода 1С.

ВНИМАНИЕ! Компонента не имеет видимого интерфейса. При попытке запустить через иконку ничего происходить не будет!

Работает с мобильной платформой не выше 8.3.11

Предыстория создания //infostart.ru/public/586539/ (сначала ознакомиться)

На том этапе был создан сервис, который "жил сам по себе", запускался при старте системы, имел интерфейс и ручные настройки. Мне это показалось не достаточно удобным. Родилась идея отдельной компоненты. Она похожа на предыдущую, но управляется из 1С, не имеет интерфейса с настройками.

В модуль управляемого приложения прописываем:

Процедура ПриНачалеРаботыСистемы()
	
	ОбщегоНазначенияКлиент.ПодключитьГлобальноеСобытиеОповещения();
	ОбщегоНазначенияКлиент.ЗапуститьКомпонентуСканирования();
	
КонецПроцедуры

Процедура ПриЗавершенииРаботыСистемы()
	ОбщегоНазначенияКлиент.ОстановитьКомпонентуСканирования();
КонецПроцедуры

В модуль ОбщегоНазначенияКлиент

Процедура ПодключитьГлобальноеСобытиеОповещения() Экспорт
	#Если МобильноеПриложениеКлиент Тогда
		Оп = Новый ОписаниеОповещения("ОбработчикЛокальныхУведомлений", ЭтотОбъект);
		ДоставляемыеУведомления.ПодключитьОбработчикУведомлений(Оп);  
	#КонецЕсли
КонецПроцедуры

Процедура ГлобальноеСобытиеОповещения(Сообщение, ЧтоТоЕще = "") Экспорт

	Попытка
		Отправитель = Число(Сообщение.Отправитель);
	Исключение
		Возврат
	КонецПопытки;
	Если Отправитель = 1 Тогда
		Оповестить(Формат(Отправитель,"ЧГ="),Сообщение.Текст, "Сканирование ШК");
	Иначе 
		Возврат
	КонецЕсли;
КонецПроцедуры

Процедура ОбработчикЛокальныхУведомлений(Уведомление,Локальное,Показано, ЧтоТоЕще) Экспорт
	ГлобальноеСобытиеОповещения(Новый Структура("Отправитель,Текст",Уведомление.Текст,Уведомление.Данные));
КонецПроцедуры

&НаКлиенте
Процедура ЗапуститьКомпонентуСканирования() Экспорт
	#Если МобильноеПриложениеКлиент Тогда
		НовЗП = Новый ЗапускПриложенияМобильногоУстройства();
		НовЗП.Действие = "com.barcodeto1c.action";
		НовЗП.ДополнительныеДанные.Добавить("ServiceState","Start"); //что сделать: Старт/Стоп
		НовЗП.ДополнительныеДанные.Добавить("ServiceSCAN_MESSAGE","scan.rcv.message"); //чей бродкаст ловить
        НовЗП.ДополнительныеДанные.Добавить("ServiceBarCodeField","barocode"); //в каком поле сканер возвращает штрих-код (если не задавать - по умолчанию barocode, что в большинстве случаев оно так)
		НовЗП.ДополнительныеДанные.Добавить("ServiceEventID","1"); //категория сообщение для 1С
		НовЗП.ДополнительныеДанные.Добавить("ServiceToast","Service STARTED!");//(не обязательно) просто покажет Тост при успехе
		НовЗП.ДополнительныеДанные.Добавить("ServiceBase_Name",ОбщегоНазначенияСервер.ПолучитьИДБазы());//если одна база - можно поставить ""
		Результат = НовЗП.Запустить(Истина);
		
		Если НЕ Результат = 77 Тогда
             //тут можно отловить что что-то не так. Возможно апк не установлена или что-то не сработало
		КонецЕсли;
	#КонецЕсли
	
КонецПроцедуры

&НаКлиенте
Процедура ОстановитьКомпонентуСканирования() Экспорт
	#Если МобильноеПриложениеКлиент Тогда
		НовЗП = Новый ЗапускПриложенияМобильногоУстройства();
		НовЗП.Действие = "com.barcodeto1c.action";
		НовЗП.ДополнительныеДанные.Добавить("ServiceState","Stop");
		НовЗП.ДополнительныеДанные.Добавить("ServiceToast","Service STOPED!");
		Результат = НовЗП.Запустить(Истина);
	#КонецЕсли

КонецПроцедуры

ПолучитьИДБазы() можно разными способами. Я её прописал в константы.

Успешный результат всегда равен 77 (просто число, мне так захотелось)

У формы должно быть прописано ОбработкаОповещения приблизительно так:

&НаКлиенте
Процедура ОбработкаОповещения(ИмяСобытия, Параметр, Источник)
	Если ИмяСобытия = "1" И ВводДоступен() Тогда
		ПолученШтрихКод(Параметр); //процедура для обработки ШК
	КонецЕсли;
КонецПроцедуры

 

Теперь мы можем стартовать сервис только по необходимости. Если у нас несколько баз - то ловить события только той базой, что запущена.

Распространяется "как есть". Надеюсь будет полезным.

Добавлено в версии 1.1

1) сервис может работать с некоторыми bluetooth-сканерами (у которых для настройки используется утилита DataWedge со строкой "посылки" com.hht.emdk.datawedge.data_string)

2) добавлена возможность самостоятельно указывать поле, в котором возвращается набор байт со сканера. По-умолчанию это "barocode". Если сервису передать строку НовЗП.ДополнительныеДанные.Добавить("ServiceBarCodeField","svoe_pole") - то информация будет читаться из него

Оптимизация по размеру файла. А то жрала много памяти предыдущая ;)

Добавлено в версии 1.2.1

- Поддержка устройства CipherLab 9700A (ну и наверное его подобными)

28/03/18 Добавлены исходники

 

Добавлено в версии 1.2.2

- Поддержка устройств, которые возвращают штрих-код как строку, а не массив байт.

53

Скачать файлы

Наименование Файл Версия Размер
BarCodeComponent_ver_1_2_2.apk
.apk 49,75Kb
19.11.18
182
.apk 1.2.2 49,75Kb 182 Скачать
BC2OneC_sources.zip
.zip 47,62Kb
19.11.18
77
.zip 1.2.1 47,62Kb 77 Скачать

Специальные предложения

Вознаграждение за ответ
Показать полностью
Комментарии
Избранное Подписка Сортировка: Древо
1. ViperGSV 15.02.17 11:12 Сейчас в теме
Совместимость с какими версиями Android? Интересует работа на старых версиях 2.3.х
2. DMon 90 15.02.17 15:27 Сейчас в теме
(1) Я писал под 4.0.3. Если нужно - могу понизить версию.
3. DMon 90 15.02.17 18:53 Сейчас в теме


(1) добавил, можно попробовать. Но работу не гарантирую, так как девайса с 2.3 нету
4. Batman 150 15.02.17 23:08 Сейчас в теме
Небольшое замечание. Там в описании (жирным шрифтом) - опечатка - "Поддержка заКуска/"
5. aspirator23 401 18.02.17 16:23 Сейчас в теме
(4) Автор ушел за остальным к закуске. Вернется - исправит. :)
6. DMon 90 18.02.17 21:39 Сейчас в теме
(5)очень остроумно, спасибо)
7. ASK7 02.03.17 23:03 Сейчас в теме
Добрый день коллеги! В поисках решения своей проблемы наткнулся на вашу статью, за что автору огромное спасибо. Я правильно понимаю, чтобы работала данная утилита НЕ НУЖНО! "потрашить, допиливать" платформу как это делал dewersia http://infostart.blog-buh.ru/public/547851. Утилита работает на типовой мобильной платформе 1с?
9. DMon 90 03.03.17 08:10 Сейчас в теме
(7) Привет! правильно, в платформе ничего менять не нужно. Сервис живёт сам по себе, управляется из кода 1С. А можно Вашу проблему в ЛС? Может я подобное уже решал)
8. flyer 222 03.03.17 07:55 Сейчас в теме
я вот на еще один способ наткнулся можно сразу с dev0 читать т.е. с потока. щас работаю над этим если все получиться то выложу тут исходники глянете как сделал.
10. lion-killer 22 03.03.17 17:50 Сейчас в теме
Здравствуйте, коллеги. Можно ли подключить USB сканер к планшету на Android с помощью этого приложения. Если да, то какова последовательность действий. Объясните чайнику )))
11. DMon 90 04.03.17 12:04 Сейчас в теме
(10) С таким не сталкивался на практике, но думаю что реально. Нужно только знать какое сообщение бродкастом рассылается от подключенного сканера. Как узнать? Да много вариантов. Самый простой - анализ logcat к примеру.
12. lion-killer 22 09.03.17 18:03 Сейчас в теме
(11) Если переключить сканер в режим эмуляции клавиатуры - видна посылка штрих кода посимвольно (во вложении), в других режимах никаких событий нет ((
Прикрепленные файлы:
20. pri_hod 88 06.05.17 13:51 Сейчас в теме
(12) Удалось отловить событие?
22. Davidmad777 08.05.17 00:51 Сейчас в теме
Удалось отловить событие

(20)
Удалось отловить событие?
да
23. pri_hod 88 08.05.17 13:03 Сейчас в теме
(22) как ? Я уже все перепробывал...
51. andrey314 11 11.10.17 07:56 Сейчас в теме
(22) Присоединяюсь к вопросу
13. LiolickGG 13.04.17 06:22 Сейчас в теме
Спасибо очень помогло, ТСД зажил новой жизнью.
14. DMon 90 13.04.17 09:00 Сейчас в теме
(13) Рад за полезность :)
Какое именно у Вас устройство ТСД?
15. 1c-kt 24.04.17 02:00 Сейчас в теме
Спасибо, то что нужно. Возможно ли еще получать оповещения от нажатия клавиатурных клавиш?
18. DMon 90 24.04.17 14:53 Сейчас в теме
(15) Попробую реализовать и данный механизм когда будет посвободнее время. Спасибо за идею)
32. demONx7 29.06.17 04:18 Сейчас в теме
(18) Дмитрий, ну что, получилось реализовать? В данный момент занимаюсь аналогичной задачей. Думаю многим будет интересно посмотреть на реализацию данного действия. Информации в интернете по этому поводу - NULL.
33. DMon 90 30.06.17 07:25 Сейчас в теме
(32) нет, не занимался этим. Свободного времени нет пока. Да и практических задач тоже.
16. fr13 24.04.17 11:26 Сейчас в теме
Добрый день, скачал оба файла и ни один не запустился. Версия API 18. Ошибка следующего характера
There was a problem parsing the package

флажок на установку из неизвестных источник стоит, флажок Проверять приложения - снят. Устройство - ТСД Urovo sq42. Другие apk не из маркета ставятся без проблем
17. fr13 24.04.17 12:03 Сейчас в теме
(16) проблему решил, передал apk с пк на тсд, все установилось. До этого качал апк с почты. Странное поведение ОС )
19. fr13 24.04.17 15:57 Сейчас в теме
Поделюсь своим опытом работы с опубликованным выше сервисом и ТСД Urovo sq42:
1. обязательно нужно указывать верный источник броадкаста (как посмотреть автор написал)
2. сканер должен быть настроен не в разрыв клавиатуры, в моем случае в стандартных настройках были настройки сканера, там есть возможность указать режим.
После этого все взлетело, автору спасибо!
21. Davidmad777 08.05.17 00:50 Сейчас в теме
Поделюсь своим опытом работы с опубликованным выше сервисом наТСД Newland:
Все норм работает
Даже на других конфигурациях пробовал
34. user651504_anah0ret 07.07.17 16:50 Сейчас в теме
(21) А у Вас на Newland имя бродкаст сообщения какое, "scan.rcv.message"?
24. Davidmad777 08.05.17 16:12 Сейчас в теме
У тебя Есть Пример конфигурации с работы Acode?
25. pri_hod 88 08.05.17 23:25 Сейчас в теме
46. Dimitrij 26.09.17 11:11 Сейчас в теме
(26) Добрый день,

Не сталкивались с проблемой что при установки приложения на ТСД выскакивает "Cannot call synchronous methods on the client"?

Заранее спасибо!
27. Davidmad777 10.05.17 10:04 Сейчас в теме
Это пример Конфи там в макете есть и Acode tools apk и Примеры использования
28. Davidmad777 10.05.17 10:07 Сейчас в теме
29. pri_hod 88 13.05.17 00:32 Сейчас в теме
(28) Спасибо за конфигурацию, поставил, но так сканер и не получилось заставить работать. У меня сканер подключен к телефону через USB otg host, в блокнот сканирует без проблем, так вот заставить работать через уведомления так как в этой статье так и не получается, куда копать? как перевести "не в разрыв клавиатуры", нигде настроек нет никаких.
30. DMon 90 13.05.17 09:16 Сейчас в теме
(29) Боюсь что никак. Для телефона он просто OTG клавиатура.
По крайне мере мне не известны случаи успешного применения USB не в разрыв клавиатуры
31. Davidmad777 13.05.17 10:23 Сейчас в теме
35. Dream_kz 93 03.08.17 18:54 Сейчас в теме
А как узнать "ServiceBarCodeField" и "ServiceSCAN_MESSAGE"?
Попался на руки китайский ТСД qunsuo pda401, в родное демо приложение сканирует, а сюда не хочет. Декомпилировал приложение, но не могу найти какой броадкаст он ловит.
36. DMon 90 03.08.17 23:14 Сейчас в теме
(35) А чем декомпилировали? Может не всё разложилось?

Выложите где-то на шару это приложение и скиньте ссылку. Я посмотрю.
37. Dream_kz 93 04.08.17 11:15 Сейчас в теме
(36)Да вроде все. В манифесте посмотрел интент фильтр, попробовал по нему, и по другим событиям, но мне кажется я не то поле указал, в котором лежит штрихкод.

Здесь и само приложение, и исходники к нему (нашел на сайте производителя)

http://dropmefiles.com/JGlaf

Попробовал события:
ismart.intent.scandown
com.qs.scancode
com.zkc.scancode
с полем code, и barocode

Но безрезультатно.
38. as.kharlov 21.08.17 19:59 Сейчас в теме
У меня ТСД Motorola Symbol MC3200. Сканер штрихкода в разрыв клавиатуры. Acode не взлетели. Эта утилита может работать?
И как узнать какой бродкаст прописывать для моей модели? Гугл в ответе не помог.
Спасибо!
39. as.kharlov 21.08.17 20:03 Сейчас в теме
Прошу прощения, не заметил сразу сообщения про logcat. Завтра попробую
40. nkroshko 25.08.17 16:28 Сейчас в теме
Спасибо за программу! Удалось установить взаимодействие с 1С на ТСД Атол Smart Droid.
заработало с такими установками:
ServiceSCAN_MESSAGE = DATA_SCAN
что странно независимо от того, что указываешь в ServiceBarCodeField все равно вызывает событие в 1С :)
Shef_zeon; gorevg; perpleks; +3 Ответить
61. gorevg 8 06.11.17 22:19 Сейчас в теме
(40)
Спасибо!
Заработало.
Вот так нужно сделать:
НовЗП.ДополнительныеДанные.Добавить("ServiceSCAN_MESSAGE","DATA_SCAN");
41. /// ANTONIO 29.08.17 16:43 Сейчас в теме
Дмитрий, спасибо за компоненту! Шикарная вещь.
Успешно работает с линейными 1D сканерами Urovo i6200s.
Но вот на сканере 2D Urovo i6200s перестает работать сканирующее устройство через некоторое время использования.
Вместе со службой поддержки перепробовали различные варианты прошивки, ничего не помогает.
Луч сканера есть, но ничего не происходит, даже в родном приложении.
Помогает отключение сканирующего модуля и его включение в настройках Android.
Служба поддержки предполагает, что компонента вешает "камеру" сканера 2D и происходит Crash.
Строки Permission Denial повторяются постоянно, видимо, на каждое сканирование.

В логах при этом такой текст, повторяется
Лог с устройства

Дмитрий, есть мысли, в чем может быть проблема?
Был бы благодарен за помощь.
42. as.kharlov 30.08.17 12:21 Сейчас в теме
Dmitry Po.
Вопрос:
Пользуюсь ТСД Motorola Symbol MC9200
Настроил при сканировании штрих-кода отсылать его как эммуляцию ввода с клавиатуры и broadcast intent
подключил adb. Смотрю logcat чтоб понять какой бродкаст ловить. Вот изменения logcatа после сканирования штрихкода:
W/SoundPool(  730):   sample -1 not READY
E/ImagerAdapter(  730): Guard passed
E/NotificationService(  454): Not posting notification with icon==0: Notificatio
n(pri=0 contentView=com.symbol.datawedge/0x1090064 vibrate=null sound=null defau
lts=0x0 flags=0x11 kind=[null])
E/NotificationService(  454): WARNING: In a future release this will crash the a
pp: com.symbol.datawedge
E/TIAdapter(  730): ID-VIDIOC_SIZEDQBUF Acquistion Stopped mMaxFrameSkip = 0
D/dalvikvm(  730): GC_CONCURRENT freed 914K, 17% free 5774K/6884K, paused 6ms+5m
s, total 54ms
D/InputMethodService(  587): Params passed to SoftKeyboard android.util.MapColle
ctions$KeySet@bc86db18
D/InputMethodService(  587): keystroke_action_char -1
D/InputMethodService(  587): ime_output_enabled true
D/InputMethodService(  587): running Injector
D/InputMethodService(  587): Injector: doInject
E/NotificationService(  454): Not posting notification with icon==0: Notificatio
n(pri=0 contentView=com.symbol.datawedge/0x1090064 vibrate=null sound=null defau
lts=0x0 flags=0x11 kind=[null])
E/NotificationService(  454): WARNING: In a future release this will crash the a
pp: com.symbol.datawedge
I/wpa_supplicant(  572): signalpoll buffer: RSSI=-47
I/wpa_supplicant(  572): LINKSPEED=65
I/wpa_supplicant(  572): NOISE=-71
I/wpa_supplicant(  572): FREQUENCY=5220
E/NotificationService(  454): Not posting notification with icon==0: Notificatio
n(pri=0 contentView=com.symbol.datawedge/0x1090064 vibrate=null sound=null defau
lts=0x0 flags=0x11 kind=[null])
E/NotificationService(  454): WARNING: In a future release this will crash the a
pp: com.symbol.datawedge
I/wpa_supplicant(  572): signalpoll buffer: RSSI=-46
I/wpa_supplicant(  572): LINKSPEED=65
I/wpa_supplicant(  572): NOISE=-70
I/wpa_supplicant(  572): FREQUENCY=5220
Показать


Отсканированный штрихкод 120717109704 (EAN13)
Не вижу в логкате ни имени бродкаста, ни чего-либо похожего на отсканированный штрихкод.
Подскажите куда копать? Как определить имя бродкаста?
Заранее большое спасибо!
43. DMon 90 30.08.17 12:40 Сейчас в теме
(42) Это блютуз сканер? "com.hht.emdk.datawedge.data_string" не подходит?
Есть ли утилита внутренняя для настройки сканера? Я обычно разбираю её чтоб глянуть.
44. as.kharlov 30.08.17 14:19 Сейчас в теме
(43) Dmitry Po,
Спасибо за ответ!
сканер встроенный в терминал сбора данных
В настройках есть "Scanner selection". В этом меню есть пункт "Bluetooth Scanner disconnected". Если выбрать его, то при запуске 1С ругается что блютуз сканер не подключен.
у меня выбран пункт "Scanner selection" = "Auto (2D Barcode Imager)".
Из моего ответа можно понять блютуз сканер или нет?

прописал бродкаст "com.hht.emdk.datawedge.data_string"
ОбработкаОповещения не возникла.

Внутренняя утилита для настройки сканера есть. Называется DataWedge. В ней редактирую профили сканирования. Об этой утилите Вы спрашивали? Как ее можно разобрать?

Кстати, база 1с у меня не скомпилированный apk, а запускается как конфигурация из мобильной платформы, установленной на терминале. Это может влиять на результат?
Конфигурация у меня одна поэтому в параметре "ServiceBase_Name" оставил "".
45. as.kharlov 30.08.17 14:41 Сейчас в теме
Dmitry Po,
И еще:
НовЗП.ДополнительныеДанные.Добавить("ServiceBarCodeField","barocode")
у Вас написано: //в каком поле сканер возвращает штрих-код (если не задавать - по умолчанию barocode, что в большинстве случаев оно так)
"в большинстве случаев так, а в моем конкретном случае это не может отличаться?
47. andrey314 11 10.10.17 13:42 Сейчас в теме
Блютуз сканер Zebra DS6878-SR будет работать? В режиме HID ?
48. DMon 90 10.10.17 17:19 Сейчас в теме
(47) Если есть в устройстве утилита от сканера, которая генерит бродкас сообщения - теоретически возможно. На практике таким не занимался.
49. andrey314 11 10.10.17 17:53 Сейчас в теме
Подскажите, вы какие-нибудь другие блютус сканеры подключали? И в каком режиме?
50. DMon 90 10.10.17 21:34 Сейчас в теме
(49) Внизу публикации указано что добавлено в версию 1.1. Делал это вспелую для коллеги по инфостарту. По его словам всё заработало. Сканер должен быть НЕ в разрыв клавиатуры.
52. Lupeykin 16.10.17 06:51 Сейчас в теме
нет внешнего события, только зря потратил деньги, исходников APK автор не выложил неизвестно почему не работает.
53. DMon 90 16.10.17 10:59 Сейчас в теме
(52) и Вы думаете, что у всех кто скачал тоже нет внешнего события?... и даже те, кто выражал благодарность в комментариях - фейковые? А может нужно причину поискать у Вас на стороне, а не сразу жалеть потраченные копейки? И автор не обязан выкладывать исходники для утилиты за 1 стармани в статусе "как есть". Не нравится - сделайте свою и лучше, выложите на Инфостарт и вернете "зря потраченные деньги"! Хорошего дня!
55. user847620 24.10.17 11:38 Сейчас в теме
Добрый день!
Подскажите, пожалуйста, какое значение нужно задавать для ServiceSCAN_MESSAGE? Пробовал те, что указаны в настройках сканера (на фото), уведомление в 1с не приходит. Logcat тоже прикрепил. Нажатие кнопки сканера в строках 10117-10229 (первые строки тоже оставил, вдруг там какая-то нужная информация). Сканер DataLogic DL-Axist.
Прикрепленные файлы:
logcat.zip
1С-ИжТиСи; +1 Ответить
56. andrey314 11 25.10.17 10:27 Сейчас в теме
Подскажите по ПолучитьИДБазы(). Если например у меня в мобильном приложении несколько баз? Что я должен сюда передавать?
57. DMon 90 25.10.17 15:05 Сейчас в теме +10 $m
(56)
Не помню уже где это нашел, но писали очень хорошие люди, им спасибо!
Я получаю и записываю значение в константу.
На форме с константой, в НачалоВыбора пишем:

&НаКлиенте
Процедура ИдентификаторБазыНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
	
	СтандартнаяОбработка = Ложь;
	
	#Если МобильноеПриложениеКлиент Тогда
	СЗ = Новый СписокЗначений;
	
	Базы = Новый ЧтениеТекста ("/data/data/com.e1c.mobile/files/1C/1cem/ibases.v8i");
	Стр = Базы.ПрочитатьСтроку();
	_Имя = ""; _ИД = "";
	Пока Стр <> Неопределено Цикл 
		Если Лев(Стр, 1) = "[" Тогда
			_Имя = Стр;
		КонецЕсли;
		Если Лев(Стр, 3) = "ID=" Тогда
			_ИД = СтрЗаменить(Стр,"ID=","");
			СЗ.Добавить(_ИД,_Имя);
		КонецЕсли;
		Стр = Базы.ПрочитатьСтроку();	
	КонецЦикла;
	
	Эл = СЗ.ВыбратьЭлемент();
	НаборКонстант.ИдентификаторБазы = Эл.Значение;
	
	#КонецЕсли
КонецПроцедуры

Показать
savinsva; evgeny43; andrey314; +3 Ответить
58. andrey314 11 25.10.17 16:51 Сейчас в теме
59. gorevg 8 03.11.17 15:01 Сейчас в теме
А кто-нибудь на АТОЛ Smart.Droid смог запустить? Уже несколько дней вожусь. Функция ЗапуститьКомпонентуСканирования отрабатывает. Ошибок нет. Результат =77. Сканер пищит, что отсканировал, но до 1с не доходит...
60. DMon 90 03.11.17 17:05 Сейчас в теме
(59)
У формы
&НаКлиенте
Процедура ОбработкаОповещения(ИмяСобытия, Параметр, Источник)
	Если ИмяСобытия = "1" И ВводДоступен() И НЕ флВводСН Тогда
		ПолученШтрихКод(Параметр);
	КонецЕсли;
КонецПроцедуры

Показать

что-то подобное прописано?

И ПриНачалеРаботыСистемы всё ли правильно описано?
проверьте ещё раз
62. Igel 6 09.11.17 13:22 Сейчас в теме
День добрый.
Кто может подсказать, а какой Broadcast ServiceSCAN_MESSAGE у ТСД CipherLab RS30 / RS50?
63. DMon 90 10.11.17 11:05 Сейчас в теме
(62) Есть встроенная утилита для управления сканером?
Если да - то в ней должно быть какое-то поле для тестирования что сканер работает.
Если да - то эта утилита является слушателем бродкаста и соответственно в ней прописано какой именно слушается.
Остается только достать эту утилиту с устройства (apk-файл), разобрать его и посмотреть.

З.Ы. Как разобрать - это уже другая тема.
65. VladimirMelnychenko 20.11.17 19:35 Сейчас в теме
(63)
утилиту

Добрый день.
Подскажите пожалуйста, как можно определить параметры "ServiceSCAN_MESSAGE" И "scan.rcv.message".
Разобрал apk родной утилиты (http://dropmefiles.com/gnrhx) не могу разобраться что именно искать.
Терминал SunLux XL-868.
118. user667563_kostix911 01.08.18 14:44 Сейчас в теме
(63)А можно по подробнее об этой теме, есть какой то мануал?
119. DMon 90 01.08.18 18:41 Сейчас в теме
(118) У гугла спросить как разобрать apk )
120. user667563_kostix911 05.08.18 15:57 Сейчас в теме
(119)APK то разобрал, но как определить ServiceSCAN_MESSAGE в исходных файлах? Смотрел манифест, думал брать имя receiver . Но так и не получилось.
64. Igel 6 10.11.17 12:56 Сейчас в теме
66. evgeny43 6 18.12.17 20:24 Сейчас в теме
Добрый вечер коллеги .

Скачал данное ПО .
Возникло несколько вопросов :
1) мобильное приложение в апк файл конвертировать не обязательно?
2)ни кто не знает какой бродкаст и поле со штрих кодом у Honeywell ScanPal EDA50K ?
Прикрепленные файлы:
67. evgeny43 6 18.12.17 22:15 Сейчас в теме
(66) хотя с 1 вопросом чет не подумал, отпадает, в противном случае нафиг идентификатор базы)
68. evgeny43 6 19.12.17 11:51 Сейчас в теме
(66) По второму вопросы , нашел часть информации, однако по прежнему не получается отловить бродкаст при помощи ПО

API GUID :
package sample.honeywell.com.intentapisample;

import android.content.BroadcastReceiver;
import android.content.Context;
import android.content.Intent;
import android.content.IntentFilter;
import android.support.v7.app.AppCompatActivity;
import android.os.Bundle;
import android.support.v7.view.menu.ActionMenuItemView;
import android.util.Log;
import android.view.View;
import android.widget.Button;
import android.widget.TextView;

public class MainActivity extends AppCompatActivity {
    private static final String TAG = "IntentApiSample";
    private static final String ACTION_BARCODE_DATA = "com.honeywell.sample.action.BARCODE_DATA";
    /**
     * Honeywell DataCollection Intent API
     * Claim scanner
     * Package Permissions:
     * "com.honeywell.decode.permission.DECODE"
     */
    private static final String ACTION_CLAIM_SCANNER = "com.honeywell.aidc.action.ACTION_CLAIM_SCANNER";
    /**
     * Honeywell DataCollection Intent API
     * Release scanner claim
     * Permissions:
     * "com.honeywell.decode.permission.DECODE"
     */
    private static final String ACTION_RELEASE_SCANNER = "com.honeywell.aidc.action.ACTION_RELEASE_SCANNER";
    /**
     * Honeywell DataCollection Intent API
     * Optional. Sets the scanner to claim. If scanner is not available or if extra is not used,
     * DataCollection will choose an available scanner.
     * Values : String
     * "dcs.scanner.imager" : Uses the internal scanner
     * "dcs.scanner.ring" : Uses the external ring scanner
     */
    private static final String EXTRA_SCANNER = "com.honeywell.aidc.extra.EXTRA_SCANNER";
    /**
     * Honeywell DataCollection Intent API
     * Optional. Sets the profile to use. If profile is not available or if extra is not used,
     * the scanner will use factory default properties (not "DEFAULT" profile properties).
     * Values : String
     */
    private static final String EXTRA_PROFILE = "com.honeywell.aidc.extra.EXTRA_PROFILE";
    /**
     * Honeywell DataCollection Intent API
     * Optional. Overrides the profile properties (non-persistent) until the next scanner claim.
     * Values : Bundle
     */
    private static final String EXTRA_PROPERTIES = "com.honeywell.aidc.extra.EXTRA_PROPERTIES";

    private static final String EXTRA_CONTROL = "com.honeywell.aidc.action.ACTION_CONTROL_SCANNER";
    /*
        Extras
        "com.honeywell.aidc.extra.EXTRA_SCAN" (boolean): Set to true to start or continue scanning. Set to false to stop scanning. Most 

scenarios only need this extra, however the scanner can be put into other states by adding from the following extras.
        "com.honeywell.aidc.extra.EXTRA_AIM" (boolean): Specify whether to turn the scanner aimer on or off. This is optional; the default value 

is the value of EXTRA_SCAN.
        "com.honeywell.aidc.extra.EXTRA_LIGHT" (boolean): Specify whether to turn the scanner illumination on or off. This is optional; the 

default value is the value of EXTRA_SCAN.
        "com.honeywell.aidc.extra.EXTRA_DECODE" (boolean): Specify whether to turn the decoding operation on or off. This is optional; the 

default value is the value of EXTRA_SCAN
    */
    private static final String EXTRA_SCAN = "com.honeywell.aidc.extra.EXTRA_SCAN";

    private TextView textView;
    Button button;



    private BroadcastReceiver barcodeDataReceiver = new BroadcastReceiver() {
        @Override
        public void onReceive(Context context, Intent intent) {
            Log.d("IntentApiSample: ","onReceive");
            if (ACTION_BARCODE_DATA.equals(intent.getAction())) {
/*
These extras are available:
"version" (int) = Data Intent Api version
"aimId" (String) = The AIM Identifier
"charset" (String) = The charset used to convert "dataBytes" to "data" string
"codeId" (String) = The Honeywell Symbology Identifier
"data" (String) = The barcode data as a string
"dataBytes" (byte[]) = The barcode data as a byte array
"timestamp" (String) = The barcode timestamp
*/
                int version = intent.getIntExtra("version", 0);
                if (version >= 1) {
                    String aimId = intent.getStringExtra("aimId");
                    String charset = intent.getStringExtra("charset");
                    String codeId = intent.getStringExtra("codeId");
                    String data = intent.getStringExtra("data");
                    byte[] dataBytes = intent.getByteArrayExtra("dataBytes");
                    String dataBytesStr="";
                    if(dataBytes!=null && dataBytes.length>0)
                        dataBytesStr = bytesToHexString(dataBytes);
                    String timestamp = intent.getStringExtra("timestamp");
                    String text = String.format(
                            "Dat a:%s\n" +
                                    "Charset:%s\n" +
                                    "Bytes:%s\n" +
                                    "AimId:%s\n" +
                                    "CodeId:%s\n" +
                                    "Timestamp:%s\n",
                            data, charset, dataBytesStr, aimId, codeId, timestamp);
                    setText(text);
                }
            }
        }
    };
    @Override
    protected void onCreate(Bundle savedInstanceState) {
        super.onCreate(savedInstanceState);
        setContentView(R.layout.activity_main);
        textView = (TextView) findViewById(R.id.textView);
        button = (Button)findViewById(R.id.button);
        button.setText("Start Scan");
        button.setOnClickListener(new View.OnClickListener() {
            @Override
            public void onClick(View v) {
                sendBroadcast(new Intent(EXTRA_CONTROL)
                    .putExtra(EXTRA_SCAN, true)
                );
            }
        });
        Log.d("IntentApiSample: ", "onCreate");
    }
    @Override
    protected void onResume() {
        super.onResume();
//        IntentFilter intentFilter = new IntentFilter("hsm.RECVRBI");
        registerReceiver(barcodeDataReceiver, new IntentFilter(ACTION_BARCODE_DATA));
        claimScanner();
        Log.d("IntentApiSample: ", "onResume");
    }
    @Override
    protected void onPause() {
        super.onPause();
        unregisterReceiver(barcodeDataReceiver);
        releaseScanner();
        Log.d("IntentApiSample: ", "onPause");
    }
    private void claimScanner() {
        Log.d("IntentApiSample: ", "claimScanner");
        Bundle properties = new Bundle();
        properties.putBoolean("DPR_DATA_INTENT", true);
        properties.putString("DPR_DATA_INTENT_ACTION", ACTION_BARCODE_DATA);
        sendBroadcast(new Intent(ACTION_CLAIM_SCANNER)
                .putExtra(EXTRA_SCANNER, "dcs.scanner.imager")
                .putExtra(EXTRA_PROFILE, "DEFAULT")// "MyProfile1")
                .putExtra(EXTRA_PROPERTIES, properties)
        );
    }
    private void releaseScanner() {
        Log.d("IntentApiSample: ", "releaseScanner");
        sendBroadcast(new Intent(ACTION_RELEASE_SCANNER));
    }
    private void setText(final String text) {
        if (textView != null) {
            runOnUiThread(new Runnable() {
                @Override
                public void run() {
                    textView.setText(text);
                }
            });
        }
    }
    private String bytesToHexString(byte[] arr) {
        String s = "[]";
        if (arr != null) {
            s = "[";
            for (int i = 0; i < arr.length; i++) {
                s += "0x" + Integer.toHexString(arr[i]) + ", ";
            }
            s = s.substring(0, s.length() - 2) + "]";
        }
        return s;
    }
}

Код с сайта honeywell .

Информация по EDA50K
Yes, EDA50 supports broadcast mode and it need configure Settings->Scanning -> Internal Scanner -> Default Profile -> Data Processing Settings -> Data Editing Plugin->com.honeywell.sample.scanresultreceiver/.DataEditingPlugin, then customer application can receive scanned data via broadcast intent.


Общая информация по версиям андроид
How to use the Barcode Data Intent?
02.11.2017•HSM Article
ARTICLE NUMBER
000058703
QUESTION/PROBLEM
How to use the Barcode Data Intent?
APPLIES TO
Android 4.x, Android 6.x, Android 7.x
RESOLUTION
The Barcode Data Intent enables the reception and processing of barcode data without using an SDK or library.

The document DataCollectionIntentAPI_Guide.pdf has all the informations to use the Barcode Data Intent.

The attached sample code IntentApiSample shows the code usage for an Android application.

The lines
    ...
    private void claimScanner() {
        Log.d("IntentApiSample: ", "claimScanner");
        Bundle properties = new Bundle();
        properties.putBoolean("DPR_DATA_INTENT", true);
        properties.putString("DPR_DATA_INTENT_ACTION", ACTION_BARCODE_DATA);
        sendBroadcast(new Intent(ACTION_CLAIM_SCANNER)
                .putExtra(EXTRA_SCANNER, "dcs.scanner.imager")
                .putExtra(EXTRA_PROFILE, "DEFAULT")// "MyProfile1")
                .putExtra(EXTRA_PROPERTIES, properties)
        );
    }
...

will change the Internal Scanner settings to enable the Data Intent (properties.putBoolean("DPR_DATA_INTENT", true);) and set the Action to the registered Broadcast Receiver (properties.putString("DPR_DATA_INTENT_ACTION", ACTION_BARCODE_DATA);).
 
...
private static final String ACTION_BARCODE_DATA = "com.honeywell.sample.action.BARCODE_DATA";
...
    @Override
    protected void onResume() {
        super.onResume();
        registerReceiver(barcodeDataReceiver, new IntentFilter(ACTION_BARCODE_DATA));
        claimScanner();
        Log.d("IntentApiSample: ", "onResume");
    }

Depending on the device and CommonES installed, the Action value may have to be set manually. See "Settings" > "Scanning" > "Internal Scanner" > "Default profile" > "Data Processing Settings" > "Data Intent":
Показать
69. evgeny43 6 19.12.17 17:25 Сейчас в теме
(68) (66) наконец разобрался, что к чему , поле с байтовым значением кода "dataBytes" , а интент в данном случае, я задаю сам в настройках сканера,
и я указал scan.rcv.message, т.о сканер перестал сканировать в разрыв клавиатура и посылает сообщение по данному интенту , однако ПО по какой-то причине не перехватывает его.
 НовЗП = Новый ЗапускПриложенияМобильногоУстройства();
		НовЗП.Действие = "com.barcodeto1c.action";
		НовЗП.ДополнительныеДанные.Добавить("ServiceState","Start"); //что сделать: Старт/Стоп
		НовЗП.ДополнительныеДанные.Добавить("ServiceSCAN_MESSAGE","scan.rcv.message"); //чей бродкаст ловить
        НовЗП.ДополнительныеДанные.Добавить("ServiceBarCodeField","dataBytes"); //в каком поле сканер возвращает штрих-код (если не задавать - по умолчанию barocode, что в большинстве случаев оно так)
		НовЗП.ДополнительныеДанные.Добавить("ServiceEventID","1"); //категория сообщение для 1С
		НовЗП.ДополнительныеДанные.Добавить("ServiceToast","Service STARTED!");//(не обязательно) просто покажет Тост при успехе
		НовЗП.ДополнительныеДанные.Добавить("ServiceBase_Name","");//если одна база - можно поставить ""
		Результат = НовЗП.Запустить(Истина);
		
		Если НЕ Результат = 77 Тогда
             //тут можно отловить что что-то не так. Возможно апк не установлена или что-то не сработало
		КонецЕсли;
Показать

в чем может быть дело?

Версия мобильной платформы 8.3.9.74 ----- программа запускается через типовую мобильной платформу 1с(т.е не apk файл) .
Danil.Potapov; +1 Ответить
70. evgeny43 6 21.12.17 09:31 Сейчас в теме
Вопрос решился. данная модель , хотя и передает байтовое поле "dataBytes", но по какой то причине оно не преобразует его в строку для отправки в 1с.
Решался вопрос следующим образом: обработка была переписана на прием поле data в котором передается уже строковое представление штрих кода.
Для работы сканера данного устройства необходимы следующие настройки:
Меню Настройки->scanning->Internal Scanner-> тут либо в "default profile" делаете настройки, либо создаете новый профиль для 1с -> data processing settings-> тут нас интересуют следующие поля:
1)Scan to intent ставим галочку
2)Data intent ставим галочку , и проваливаемся в настройки данного поля.
настройки Data intent :
Action(поле отвечающие за наименование интента которое отправит сканер ) - тут я прописал scan.rcv.message .
остальные поля я не заполнял.



если кому интересно в коде андроид приложения я замел следующую строку :
public void onReceive(Context context, Intent intent) {
byte[] barcode = intent.getByteArrayExtra("barocode");-------->String barcode=intent.getStringExtra("data");
int lng = intent.getIntExtra("length", 0);
this.barcodeStr = new String(barcode, 0, lng);------> this.barcodeStr =barcode;
if (lng > 0) { /// данное условие в принципе должно работать, но у себя я его убрал, т.к сканер либо передает данные если считал все хорошо, либо нет.
Intent intentFor1C = new Intent("com.google.android.c2dm.intent.RECEIVE");
intentFor1C.putExtra("text", BCService.EventID);
intentFor1C.putExtra("title", "1C");
intentFor1C.putExtra("data", this.barcodeStr);
if (BCService.BaseName != null || BCService.BaseName != "") {
intentFor1C.putExtra("base", BCService.BaseName);
}
context.sendBroadcast(intentFor1C);
}
}
baracuda; temsan; Danil.Potapov; +3 Ответить
98. s.neumyvakin_2015 09.06.18 09:11 Сейчас в теме
(70) Добрый день!
Нам тоже привезли ТСД Honeywell. Не могли бы вы прислать переделанное андроид приложение?
99. evgeny43 6 09.06.18 18:02 Сейчас в теме
(98) Добрый вечер. оно есть в этой теме в 76 сообщении
102. Lupeykin 29.06.18 10:18 Сейчас в теме
8.3.10.51 это работало
на 8.3.12.67 больше не прокатывает
Intent intentFor1C = new Intent("com.google.android.c2dm.intent.RECEIVE");
intentFor1C.putExtra("text", BCService.EventID);
intentFor1C.putExtra("title", "1C");
intentFor1C.putExtra("data", this.barcodeStr);

изминили манифест разработчики, 1с, непонятно теперь как отдать платформе ШК
121. arcadics 6 21.08.18 01:22 Сейчас в теме
(70)
dataBytes


что если перебрать поля вот этим кодом:

Bundle extras = intent.getExtras();
Set<String> ks = extras.keySet();
Iterator<String> iterator = ks.iterator();
while (iterator.hasNext()) {
Log.d("MyActivity", iterator.next());
}

у меня результат:
dataBytes -- > необходимый массив
data --> штрих код в String
timestamp
aimId
version
charset
scanner

int lng = intent.getIntExtra("length", 0); //работать не будет т.к. поля нет
использовать int barocodelen = barocode.length;

если вычислить имя массива dataBytes останиться только указать в настройках имя интента "scan.rcv.message" и должно работать на всех ТСД
evgeny43; +1 Ответить
122. evgeny43 6 21.08.18 09:56 Сейчас в теме
(121)
dataBytes

Спасибо, полезная информация, когда то до этого сам доходил, но уже забыл.
Как раз собирался вспомнить как получить все поля интента )
71. Just_J 11.01.18 12:06 Сейчас в теме
Добрый день.

При запуске приложения перехвата из 1С оно возвращает 0, не подскажите что означает код возврата 0?
72. DMon 90 11.01.18 19:58 Сейчас в теме
(71) Значит не запустилось. Проверьте правильность запуска.
Корректный старт делает выход по инструкции

setResult(77);

иначе - всё что угодно, но не 77
73. Just_J 12.01.18 08:33 Сейчас в теме
(72) Это может быть связано с неправильными передаваемыми параметрами в сервис? или же это проблема моего устройства?
74. DMon 90 12.01.18 12:06 Сейчас в теме
(73) Напишите как вы передаете параметры, какое устройство, версия Android?
Поподробнее пожалуйста)
75. Just_J 15.01.18 08:43 Сейчас в теме
(74)ТСД:

zebra tc700h
android 4.4.3
На устройстве есть предустановленное приложение datawedge в нем можно настроить имя и категорию интента.

1С мобильная платформа 8.3.11.57.

Запускаю ваше приложение кодом взятым из этой темы. При запуске без ИД базы т.е. параметр ServiceBase_Name = "" приложение возвращает 0, если же указать ИД базы то оно запускается возвращает 77, но сообщения сканера не ловит.
76. evgeny43 6 15.01.18 10:40 Сейчас в теме
Попробуй для чипер лаба эту прогу.
просто для работы чип. лаба. мне пришлось вшивать в проект драйвер , который я нашел на самом тсд.
тролько она не работает как сервис после установки , как в этой теме , необходимо 1 раз зарегестрировать и все .
на код не обращай внимаения, просто писал под несколько разных тсд и решил все действия назвать com.HoneywellScan.action.

Процедура РегистрацияБазыВСканереHoneyWell()
	#Если МобильноеПриложениеКлиент  тогда
        НовЗП = Новый ЗапускПриложенияМобильногоУстройства();
		НовЗП.Действие="com.HoneywellScan.action";
		НовЗП.ДополнительныеДанные.Добавить("IdBase",ИдентификаторБазыНачалоВыбора()); //что сделать: Старт/Стоп
		Результат = НовЗП.Запустить(Истина);
	#КонецЕсли	
КонецПроцедуры

данная разработка так же подходит для тсд который я описал выше .









////////////////////////////////////////////////////////////­////
весь код с утановкой 
&НаКлиенте
Процедура УстановкаДрайверовШтрихКода()Экспорт 
	Если СлужебныеФункцииИПроцедурыКлиентСервер.КомпанентаСканированияУстановлена() тогда
		Возврат
	КонецЕсли;	
	
	МассивДрайверов=новый Массив;
	МассивДрайверов.Добавить("BarcodeHoneywell");
	

	 для Каждого ИмяМакета из  МассивДрайверов цикл
	//Если ДанныеДрайвера.ИнтеграционноеПриложение Тогда
	//	// Получение макета с сервера
	СсылкаНаФайл = СлужебныеФункцииИПроцедурыКлиентСервер.ПолучитьМакетДрайвера(ИмяМакета);
	ИмяФайлаВрем = ИмяМакета + ".apk";
	ВременныйКаталог = КаталогВременныхФайлов();
	Если ПолучитьФайл(СсылкаНаФайл, ВременныйКаталог + ИмяФайлаВрем, Ложь) Тогда
		ЗапуститьПриложение(ВременныйКаталог + ИмяФайлаВрем, , Истина);
		СлужебныеФункцииИПроцедурыКлиентСервер.ПодтвердитьУстановкуКомпаненты();
	Иначе
		ТекстОшибки = НСтр("ru='Ошибка установки драйвера.'");
		Сообщить(ТекстОшибки); 
	КонецЕсли;
	КонецЦикла;
////// до этого момента происходит установка
РегистрацияБазыВСканереHoneyWell();////// разовая регистрация (если база для которой используется драйвер меняется, то 
  ///регистрацию надо перезапускать от другой базы.
КонецПроцедуры
	
Функция ПолучитьМакетДрайвера(ИмяМакета) Экспорт
	
	Возврат ПоместитьВоВременноеХранилище(ПолучитьОбщийМакет(ИмяМакета));
	
КонецФункции

	
	
Процедура РегистрацияБазыВСканереHoneyWell()
	#Если МобильноеПриложениеКлиент  тогда
        НовЗП = Новый ЗапускПриложенияМобильногоУстройства();
		НовЗП.Действие="com.HoneywellScan.action";
		НовЗП.ДополнительныеДанные.Добавить("IdBase",ИдентификаторБазыНачалоВыбора()); //что сделать: Старт/Стоп
		Результат = НовЗП.Запустить(Истина);
	#КонецЕсли	
КонецПроцедуры
Показать



СлужебныеФункцииИПроцедурыКлиентСервер.КомпанентаСканированияУстановлена() и СлужебныеФункцииИПроцедурыКлиентСервер.ПодтвердитьУстановкуКомпаненты(); запись чтение константы в базе, о том что я уже установил драйвер и больше этого делать не надо.
Прикрепленные файлы:
BarcodeAndroid_1.3.apk
107. hobi 550 13.07.18 10:06 Сейчас в теме
(76)
Добрый день.
При запуске компоненты сканирования (BarcodeAndroid_1.3.apk)
отображается картинка с роботом и заголовком "BarcodeAndroid"
Как её убрать ?
108. evgeny43 6 13.07.18 14:05 Сейчас в теме
(107)
Нажать на клавиатуре андроид(Navigation bar) назад, или закрыть как обычное приложение, на работу повлиять не должно, т.к оно работает и в офф-лайн режиме .
в моем случае мне необходимо его установить 1 раз для 1 базы(иногда переключить на другую, но редко), поэтому я особо не заморачивался с серверной регистрацией в по (другими словами с регистрацией без вызова интерфейса ).
109. hobi 550 13.07.18 16:35 Сейчас в теме
(108)
Да, на работу не влияет.
Только на нервы действует )
110. evgeny43 6 13.07.18 17:55 Сейчас в теме
(109)
Ну если часто переключаться между базами, то да)) тут лучше подойдет решение DMon , если просто то в андроид студии , есть механизмы похожие на 1с в упр. приложении , где ты можешь поместить во временное хранилище данные под уникальный идентификатор формы - делаю приблизительно тоже самое , только данные не исчезают после закрытия формы . Влом было разбираться как сохранить по другому и так андроид программирование с 0 изучал под текущую задачу) мб, когда появится время или перейду на стадию модернизации приложения, которое пишу, улучшу и драйвер до более юзабильного вида)
77. evgeny43 6 15.01.18 11:12 Сейчас в теме
&НаКлиенте
Функция  ИдентификаторБазыНачалоВыбора()
	
	СтандартнаяОбработка = Ложь;
	
	#Если МобильноеПриложениеКлиент Тогда
		СЗ = Новый СписокЗначений;
		
		Базы = Новый ЧтениеТекста ("/data/data/com.e1c.mobile/files/1C/1cem/ibases.v8i");
		Стр = Базы.ПрочитатьСтроку();
		_Имя = ""; _ИД = "";
		Пока Стр <> Неопределено Цикл 
			Если Лев(Стр, 1) = "[" Тогда
				_Имя = Стр;
			КонецЕсли;
			Если Лев(Стр, 3) = "ID=" Тогда
				_ИД = СтрЗаменить(Стр,"ID=","");
				СЗ.Добавить(_ИД,_Имя);
			КонецЕсли;
			Стр = Базы.ПрочитатьСтроку();    
		КонецЦикла;
		Эл = СЗ.ВыбратьЭлемент();
		Возврат Эл.Значение;
		
	#КонецЕсли
КонецФункции 
Показать

это уже было описанно в данной теме Dmitry Po (DMon) ( за что ему спасибо)
78. Shef_zeon 7 15.01.18 14:55 Сейчас в теме
Подскажите что делать если сканер возвращает
(String)intent.getStringExtra("EXTRA_BARCODE_DECODED_DATA")
79. DMon 90 16.01.18 12:47 Сейчас в теме
(78) по идее это будет ServiceBarCodeField

НовЗП.ДополнительныеДанные.Добавить("ServiceBarCodeField","EXTRA_BARCODE_DECODED_DATA"); //в каком поле сканер возвращает штрих-код
80. evgeny43 6 18.01.18 13:59 Сейчас в теме
(78)
попробуй мою обработку
это у мобил байза такой интент и у хоновела похожий маунал, однако в итоге оказалось, что сам интент настраивается в настройках , а поле которое возвращается data типа srting

собери всю информацию что я писал выше и попробуй, или просто попробуй установить обработку в комментариях мою
81. Shef_zeon 7 22.01.18 14:50 Сейчас в теме
Спасибо
получилась такая модификация

if (BCService.TypeBarCodeField.equalsIgnoreCase("string"))
{
barcodeStr=paramIntent.getStringExtra(BCService.BarCodeField);
//"EXTRA_BARCODE_DECODED_DATA"
lng = paramIntent.getIntExtra("EXTRA_BARCODE_DECODED_SYMBOLE", -1)+1; }
else
{
byte[] barcode = paramIntent.getByteArrayExtra(BCService.BarCodeField);
lng = paramIntent.getIntExtra("length", 0);
barcodeStr = new String(barcode, 0, lng);
}
82. ludmirsky 23.01.18 17:17 Сейчас в теме
Дмитрий,

спасибо за проделанную работу, но мы пока так и не смогли заставить работать сканер.

Вот в документации от Zebra написано о параметрах в Intent: http://techdocs.zebra.com/datawedge/6-2/guide/setup/#decoderelateddata

Можно ли что-то сделать, чтобы сервис заработал?

Пробовали:
НовЗП.ДополнительныеДанные.Добавить("ServiceBarCodeField","data_string");
и
НовЗП.ДополнительныеДанные.Добавить("ServiceBarCodeField","com.symbol.datawedge.data_string");
83. Rokstedi 16 05.02.18 10:29 Сейчас в теме
Добрый день коллеги. Подскажите, все таки сканер должен работать в режиме эмуляции клавиатуры или в режиме эмуляции COM?
84. DMon 90 05.02.18 18:15 Сейчас в теме
(83) в режиме эмуляции COM
Rokstedi; +1 Ответить
85. Rokstedi 16 11.02.18 22:59 Сейчас в теме
(84)Сканер symbol ls2208. Подключаю к планшету через usb otg переходник. Сканер настроен в режиме cdc. Logcat молчит как партизан. Что делать?
86. DMon 90 15.02.18 12:54 Сейчас в теме
(85) Сложно сказать не имея оборудование под рукой. Компонента для ТСД, а не внешних сканеров.
Надо только экспериментировать.
87. hobi 550 06.03.18 15:51 Сейчас в теме
Добрый день.
При работе с ТСД Honeywall EDA50 (Android 7.1.1) сервис вылетает с ошибкой:
'В работе приложения BarCode_to_1C' by DMondi произошел сбой.

В настройках ТСД установлены флаги:
- Scan To Intent
- Data Intent
Для Data Intent в поле Action указано: scan.rcv.message , остальные поля не заполнены
88. DMon 90 06.03.18 20:32 Сейчас в теме
(87) Александр, на 7.1.1 не тестировалось приложение.
Чтоб отладить (или хотя бы просмотреть logcat), подходящего устройства нет, а эмулятор - совсем не вариант.

При всем желании ничем помочь не могу.
В будущем компания планирует закупить ТСД с андроид 7, но когда это будет пока не известно.
Оставьте свое сообщение

См. также

Мой помощник и бухгалтер 4

Отчеты и формы no Приложение (apk) v8::Mobile Домашние учет и финансы Россия УУ Android Абонемент ($m) Учет доходов и расходов Мобильная разработка

Домашняя бухгалтерия, записная книжка, контакты, напоминания, сканер штрих-кода, матрица Эйзенхауэра - все в твоём телефоне.

1 стартмани

26.09.2019    926    2    user-sergey    10       

Компонента аутентификации и шифрования с помощью биометрической информации для Андроид 7

Инструменты и обработки Программист Конфигурация (md, cf) v8::Mobile Android Абонемент ($m) Разработка внешних компонент Защита и шифрование Мобильная разработка

Компонента для мобильной платформы, позволяющая идентифицировать пользователя и шифровать данные с помощью биометрических сканеров.

5 стартмани

17.09.2019    729    1    IgorKissil    0       

Пример простого и приятного внешнего HTML интерфейса для мобильного приложения 8

Отчеты и формы Программист Конфигурация (md, cf) v8::Mobile Абонемент ($m) Работа с интерфейсом Мобильная разработка

Реализация простого и приятного внешнего HTML интерфейса для мобильного приложения. Делимся исходниками, чтобы разработчики мобильных приложений разрабатывали больше приятных интерфейсов для приложений.

5 стартмани

05.09.2019    1251    13    Baksheev-Nikita    10       

ERP 2.4 "Рабочее место работника склада" на ТСД + Android 7 5

Инструменты и обработки Программист Расширение (cfe) v8 ERP2 УУ Учет ТМЦ Абонемент ($m) Терминал сбора данных Рабочее место Мобильная разработка

Решение задачи использования терминала сбора данных в режиме онлайн при помощи типовой обработки ERP 2.4 "Рабочее место работника склада", запуском ERP на мобильном клиенте 1С. Для настройки использовался ТСД Urovo V5100 на ОС Андроид 7.

1 стартмани

07.08.2019    2133    2    chemezov    0       

Мобильное приложение 1С для помарочной инвентаризации маркируемой (алкогольной) продукции 11

Инструменты и обработки Программист Пользователь Архив с данными v8::Mobile Розничная и сетевая торговля (FMCG) Android Розничная торговля Абонемент ($m) Терминал сбора данных Мобильная разработка

Мобильное приложение 1С для помарочной инвентаризации маркируемой (алкогольной) продукции на ТСД под Android. Получение данных марок (штрихкодов), используя БПО для мобильного приложения. Разработка на платформе 8.3.13.1809. Мобильная платформа 8.3.13.64. Версия сборщика 2.0.8.19.

1 стартмани

18.07.2019    1555    7    savostin.alex    0       

Мобильное приложение "Сбор заказов" 6

Отчеты и формы Программист Пользователь Приложение (apk) v8 v8::Mobile 1cv8.cf Украина УУ Монитор заказов Абонемент ($m) Мобильная разработка

Приложение «Сбор заказов» разрабатывалось и разрабатывается для хранения и накопления данных от торговых представителей и автоматического обмена данными с программой учёта на базе платформы 1С:Предприятие. Мобильное приложение написано на технологии мобильной платформы 1С:Предприятие. Механизм обмена данных происходит посредством почтового сервера. В дальнейшем будет реализован механизм непосредственного доступа приложения к учётной системе через прямое интернет-соединение. FTP-соединение не работает как надо, так что будем довольствоваться тем, что есть... :)

4 стартмани

06.06.2019    1776    yarsort    9       

Мобильное приложение 1С: Список покупок и анализ расходов 31

Отчеты и формы Программист Пользователь Конфигурация (md, cf) v8 v8::Mobile Домашние учет и финансы Россия УУ Windows Финансовый учет и бюджетирование (FRP) Абонемент ($m) Мобильная разработка

В публикации рассмотрено небольшое домашнее мобильное приложение для составления списка покупок и анализа расходов. В приложении реализованы: работа с штрихкодами (сканирование встроенной камерой), поиск наименования товара по штрихкоду из интернета, загрузка чеков из ФНС по QR-коду, вывод QR-кода ранее загруженного чека и др.

1 стартмани

06.06.2019    2841    13    vasilievil    4       

Event Management - мобильное приложение для управления мероприятиями (Android) 2

Отчеты и формы no Приложение (apk) v8::Mobile Развлечения, искусство, спорт УУ Android Производство готовой продукции (работ, услуг) Абонемент ($m) Мобильная разработка

Event Management - мобильное приложение для управления мероприятиями. Отлично подойдет event-агентствам, свадебным организаторам, а также тем, кто проводит консультации, тренинги и т.д. Работает на Android (проверено на версии 5.1).

4 стартмани

31.05.2019    1502    1    yuriy_lokhonya    1       

[Расширение] для подключения мобильного устройства к УТ11.4/ КА 2/ERP 2 для работы с ордерным складом на базе Simple WMS. Для автоматизации склада нужен только телефон 18

Инструменты и обработки Программист Пользователь Расширение (cfe) v8 ERP2 УТ11 КА2 УУ Оптовая торговля Розничная торговля Учет ТМЦ Абонемент ($m) Сканер штрих-кода Терминал сбора данных Мобильная разработка Управление торговлей

Представляю готовое решение для работы с ордерами и проведения инвентаризаций в виде расширения на базе конструктора Simple WMS. Не требует доработки конфигурации, подключается как обычное расширение. Работать может с обычного телефона на Андроид либо с ТСД либо через RDP. Расширение содержит справочники, поэтому режим совместимости конфигурации должен быть не меньше 8.3.11. Расширение написано для конфигурации Управление торговлей 11.4.7 и тестировалось на Комплексная автоматизация 2.4.7.151.

5 стартмани

27.05.2019    2754    19    informa1555    20       

Мобильное приложение по учету личных финансов Android 7.0 7

Отчеты и формы no Архив с данными v8 Домашние учет и финансы УУ Android Финансовый учет и бюджетирование (FRP) Абонемент ($m) Мобильная разработка

Мобильное приложение по учету личных финансов, имеется возможность вести учет по банкам, по валюте сканировать чеки, вести учет по статьям движения денежных средств, реализована возможность резервного сохранения данных и синхронизации с приложением на ПК. Имеется демо-версия и собранный apk файл. Тестирование производилось Android 7.0 1С:Предприятие 8.3 (8.3.14.1694) Мобильная платформа 1С:Предприятия 8.3.14.53.

1 стартмани

26.05.2019    1507    3    o.kovalev    4       

Оффлайн телефонный справочник для IOS и Android 7

Инструменты и обработки Программист Пользователь Приложение (apk) v8 1cv8.cf Россия Абонемент ($m) Мобильная разработка

Как сделать телефонный справочник компании на мобильном телефоне для IOS, если у тебя android, бюджет в 100 долларов, несколько стартмани, а ты мастер программирования только в 1С? + БОНУС, как в компании бесплатно использовать телефонный справочник IOS и Android.

1 стартмани

20.05.2019    1847    2    rujiy_kot    2       

Шаблон http-сервиса для вашего проекта 65

Инструменты и обработки Программист Архив с данными v8 v8::Mobile 1cv8.cf Абонемент ($m) Внешние источники данных WEB Мобильная разработка

Http-сервис для обмена данными в формате JSON. Обработчики этого сервиса находятся во внешней обработке, что позволяет дорабатывать его без изменения конфигурации. Также прилагаю пример мобильного приложения для работы с данным сервисом (получает номенклатуру и остатки на складе). Сервис очень быстро разворачивается и масштабируется под ваши задачи.

2 стартмани

04.05.2019    5733    46    MarkoSokolov    47       

Управление задачами (мобильное приложение) 14

Отчеты и формы no Конфигурация (md, cf) v8 1cv8.cf Абонемент ($m) Мобильная разработка

Конфигурация "Управление задачами" для мобильного приложения.

2 стартмани

29.04.2019    1902    6    noprogrammer    0       

"Мобильный ТСД" - инвентаризация и сбор штрихкодов для iOS и Android 21

Инструменты и обработки Программист Пользователь Расширение (cfe) v8 v8::Mobile Розница УНФ ERP2 УТ11 КА2 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика УУ Монитор заказов Оптовая торговля Розничная торговля Ценообразование, анализ цен Абонемент ($m) Внешние источники данных Сканер штрих-кода Терминал сбора данных Работа с интерфейсом Мобильная разработка

Простой мобильный терминал сбора данных для iOS и Android, не требующий сложных настроек и установки дополнительных программ. Для выгрузки базы штрихкодов и загрузки собранных штрихкодов в документы учетной системы используется Яндекс Диск или облачный сервис и расширение конфигурации. Работает с конфигурациями Розница 2, УНФ 1.6, УТ 11, ERP, КА2.

3 стартмани

22.04.2019    9516    51    suepifanov    61       

EGAIS Scan - приложение для ТСД 4

Статья Системный администратор Программист Бухгалтер Пользователь Архив с данными v8 УТ10 УПП1 УТ11 КА2 Россия УУ Оптовая торговля Розничная торговля Учет ТМЦ Абонемент ($m) Терминал сбора данных Мобильная разработка

Каждый, кто занимается торговлей алкогольной продукцией, сталкивался с проблемами сканирования акцизных марок и трудностями при взаимодействии с учетной системой 1С. Приложение EGAIS Scan - простое и оптимальное решение для выполнения быстрой приемки и отгрузки алкогольной продукции.

1 стартмани

17.04.2019    1622    5    MrChe    0       

Управление ТСД Zebra с помощью внешней компоненты для мобильной платформы 5

Инструменты и обработки Программист Конфигурация (md, cf) v8::Mobile Android Абонемент ($m) Разработка внешних компонент Мобильная разработка

Представлена внешняя компонента для управления сканерами терминалов Zebra из мобильных приложений 1С.

2 стартмани

15.04.2019    2032    6    IgorKissil    1       

Андроид активити, разработанное для запуска и сбора информации из мобильного приложения 1С 8.3 3

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8::Mobile 1cv8.cf Автомобили, автосервисы Android Абонемент ($m) Мобильная разработка

Активити доступно из кода мобильного приложения 1С 8.3. Может использоваться как часть приложения при приемке автомобиля на предприятиях автосервиса. По сути является модальным диалогом, для внесения данных по осмотру автомобиля при приемке/передаче.

1 стартмани

10.04.2019    1524    hiEnergy    1       

Мобильный менеджер 4

Отчеты и формы Пользователь Архив с данными v8 1cv8.cf Россия УУ Android Оптовая торговля Розничная торговля Абонемент ($m) Мобильная разработка

Предлагаю вашему вниманию обновленную программу для менеджеров. Делюсь с надеждой, чтобы пользователи поделились своими наблюдениями, пожеланиями, или проблемами, с которыми они столкнулись.

1 стартмани

09.04.2019    1665    1    ziercool    1       

Подкасты сайта "Эхо Москвы" в мобильном приложении 1С 3

Инструменты и обработки no Архив с данными v8::Mobile Россия Android Абонемент ($m) Мобильная разработка

Данная разработка показывает возможности мобильного приложения от 1С на примере получения данных с сайта радиостанции "Эхо Москвы" и последующего проигрывания мультимедиа.

1 стартмани

09.03.2019    1813    2    NovPas    6       

Подписи для 1С 7

Инструменты и обработки Программист Приложение (apk) v8 Россия Документооборот и делопроизводство Абонемент ($m) Мобильная разработка

Получение подписей в Мобильной платформе 1С с помощью приложения.

1 стартмани

28.02.2019    2238    Grivba    7       

Альтернатива для "ПоказатьВыборИзСписка" и "ПоказатьВопрос" для приложений на Мобильной Платформе (УФ) 3

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8::УФ v8::Mobile 1cv8.cf Абонемент ($m) Мобильная разработка

Внешняя обработка, которая может быть интегрирована в вашу мобильную конфигурацию, если вы собираетесь уделить внимание интерфейсу программы в объеме отличном от нуля. Позволяет организовать выбор пользователем одного элемента из массива или спискаЗначений с возможностью управления цветом, размером и положением как текста вопроса, так и вариантов ответов.

1 стартмани

04.02.2019    2417    HorusTheOne    0       

Мобильное приложение "Деньги предприятия" + расширение для Бухгалтерии 3.0 3

Отчеты и формы Бухгалтер Пользователь Расширение (cfe) v8::БУ БП3.0 Россия БУ Android Банковские операции Кассовые операции Абонемент ($m) Мобильная разработка

Простое приложение для руководителя/собственника предприятия. Данный продукт является комплексом, состоящим из расширения типовой конфигурации "Бухгалтерия предприятия" ред. 3.0 и мобильного приложения. Программа позволяет смотреть на мобильном устройстве остатки наличных и безналичных денежных средств предприятия/индивидуального предпринимателя, а также оперативно проводить операции по выплате дивидендов. Обмен с базой осуществляется с помощью HTTP-сервисов.

1 стартмани

31.01.2019    3013    3    gufadmin    2       

Внешние компоненты мобильной платформы 1С для ОС Андроид 45

Статья Программист Нет файла v8::Mobile Android Абонемент ($m) Разработка внешних компонент Мобильная разработка

На трех простых примерах описана процедура разработки внешних компонент для Андроид. Статья написана по мотивам доклада на конференции INFOSTART 2018 EDUCATION.

31.01.2019    7388    81    IgorKissil    14       

Мобильное приложение для формирования заказов. Агент 6

Инструменты и обработки Системный администратор Программист Пользователь Архив с данными v7.7 v8 Оптовая торговля, дистрибуция, логистика УУ Android Управление взаимоотношениями с клиентами (СRM) Оптовая торговля Розничная торговля Абонемент ($m) Мобильная разработка Управление торговлей

Мобильное приложение на платформе Андроид для формирования заказов клиентов. Основное предназначение - работа торговых агентов, представителей, что включает в себя: список клиентов с адресами, телефонами, историей взаиморасчетов; список товаров с остатками, с несколькими типами цен; составление заявки; регистрация поступления оплаты; отслеживание координат. Приложение можно состыковать с 1С любой версии. Поддерживаемые протоколы передачи: файловый (FTP), Web-service, HTTP-service.

1 стартмани

30.01.2019    3118    4    ruslan_hut    2       

Инструкция по применению мобильного приложения 1С:Штрихкоды 3

Инструменты и обработки Программист Приложение (apk) v8::Mobile Android Абонемент ($m) Практика программирования Сканер штрих-кода Мобильная разработка

После выпуска обзора на настраиваемое мобильное приложение для сканирования штрихкодов у заинтересованных лиц появилось множество вопросов о том, как этим пользоваться.

1 стартмани

18.01.2019    3504    2    inord777    0       

Сканер штрих-кодов Сервер + Клиент 4

Инструменты и обработки Программист Пользователь Архив с данными v8::Mobile 1cv8.cf Россия Windows Розничная торговля Абонемент ($m) Мобильная разработка Сканер штрих-кода

Мобильное приложение для магазинов одежды, продавец сканирует товар, и ему мобилка выдает остаток +сумму+ склад+ цвет+ размер+ свойство товара.

1 стартмани

18.01.2019    2538    1    enot_tut    0       

Конструктор мобильного клиента Simple WMS Client: способ создать полноценный ТСД без мобильной разработки. Теперь полноценный оффлайн (обновление от 15.08.19)! 168

Инструменты и обработки Программист Архив с данными v8 v8::Mobile БУ УУ Android Оптовая торговля Производство готовой продукции (работ, услуг) Розничная торговля Учет ОС и НМА Учет ТМЦ Абонемент ($m) Инструментарий разработчика Сканер штрих-кода Терминал сбора данных Мобильная разработка

Simple WMS Client – это визуальный конструктор мобильного клиента для терминала сбора данных(ТСД) или обычного телефона на Android. Приложение работает в онлайн режиме через интернет или WI-FI, постоянно общаясь с базой посредством http-запросов (вариант для 1С-клиента общается с 1С напрямую как обычный клиент). Можно создавать любые конфигурации мобильного клиента с помощью конструктора и обработчиков на языке 1С (НЕ мобильная платформа). Вся логика приложения и интеграции содержится в обработчиках на стороне 1С. Это очень простой способ создать и развернуть клиентскую часть для WMS системы или для любой другой конфигурации 1С (УТ, УПП, ERP, самописной) с минимумом программирования. Например, можно добавить в учетную систему адресное хранение, учет оборудования и любые другие задачи. Приложение умеет работать не только со штрих-кодами, но и с распознаванием голоса от Google. Это бесплатная и открытая система, не требующая обучения, с возможностью быстро получить результат.

5 стартмани

09.01.2019    19487    207    informa1555    167       

Мобильное приложение для Android по учету выполненных работ/услуг и отслеживанию состояния расчетов с клиентами 1

Отчеты и формы Пользователь Архив с данными v8::Mobile УУ Производство готовой продукции (работ, услуг) Абонемент ($m) Мобильная разработка

Мобильное приложение для Android по учету выполненных работ/услуг. Позволяет вести почасовой учет выполненных работ/услуг, их закрытие, а так же отражение оплаты за выполненные работы и услуги. Позволяет сформировать отчеты о выполненных работах и услугах и о состоянии расчетов с клиентами, а так же отправлять результаты формирования отчетов в pdf формате на электронную почту.

1 стартмани

31.12.2018    2461    alevpe_1c    12       

Адаптация кода конфигурации для работы с мобильным клиентом 4

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) Практика программирования Мобильная разработка

С релиза 8.3.12 в платформе стал доступен мобильный клиент, но для его использования конфигурация подлежит адаптации.

1 стартмани

17.12.2018    3079    2    fr13    0       

Мобильное приложение: Терминал сбора данных (Автоматизация работы склада в режиме он-лайн) 24

Отчеты и формы no Расширение (cfe) v8::ОУ v8::Mobile ERP2 УТ11 КА2 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Россия УУ Оптовая торговля Розничная торговля Учет ТМЦ Абонемент ($m) Терминал сбора данных Мобильная разработка

Мобильное приложение предназначено для автоматизации работы склада в режиме он-лайн. Программа работает на ТСД (или на смартфоне) под управлением Android. Для работы необходим постоянный доступ к веб-публикации центральной базы данных через интернет.

1 стартмани

10.12.2018    6188    34    user1028927    18       

HTML-редактор для 1С (мобильное приложение) 9

Инструменты и обработки Программист Конфигурация (md, cf) v8 Android Абонемент ($m) Мобильная разработка

Простой, но полноценный HTML-редактор для мобильного приложения с поддержкой CSS и JavaScript Релиз платформы: 8.3.12 Релиз мобильной платформы: 8.3.13

1 стартмани

07.12.2018    2777    11    djvu    0       

Мобильное приложение "Вслух" 16

Отчеты и формы no Конфигурация (md, cf) v8 Обучение, бизнес-тренинг, курсы Россия Android Абонемент ($m) Мобильная разработка

Не с кем учить уроки? Говорящий репетитор в твоём мобильном! Обучающее мобильное приложение для детей и слабовидящих.

1 стартмани

16.11.2018    3339    4    RSConsulting    4       

Bluetooth сканер штрихкодов и мобильное приложение 1С (Android) 17

Инструменты и обработки Программист Архив с данными v8 1cv8.cf Android Абонемент ($m) Сервисные утилиты Сканер штрих-кода Мобильная разработка

Сервис для работы со сканером штрихкодов и передачи данных в мобильное приложение 1С.

1 стартмани

06.11.2018    6694    26    Isonic    8       

Самая простая конфигурация для сканирования штрихкодов из мобильного приложения 1С 7

Инструменты и обработки Программист Конфигурация (md, cf) v8 v8::УФ MobileOS Абонемент ($m) Сканер штрих-кода Мобильная разработка

Перед началом работы над этим приложением была поставлена задача в кратчайшие сроки разработать мобильное приложение - сканер штрихкода для нескольких конфигураций 1С, на управляемых формах и не только, причем нельзя было использовать драйвера торгового оборудования, что я и выполнил.

1 стартмани

01.11.2018    3607    11    Romyl01    2       

Применение цифровой подписи при организации учёта ТМЦ и ГСМ 10

Статья Программист Архив с данными v8::Mobile v8::Бизнес-процессы 1cv8.cf Абонемент ($m) Защита и шифрование Управление бизнес-процессами (BPM) Мобильная разработка

Статья о том, как внедрение мобильного приложения в бизнес-процессы компании сократило оборот бумажных документов, а простая электронная подпись - заменила аналоговую.

1 стартмани

25.10.2018    3930    2    ikekoval    2       

SmallSmarty Бухгалтерия - мобильное Android приложение для складских операций, интегрируемое с 1С Бухгалтерия 3.+ 6

Отчеты и формы Системный администратор Программист Бухгалтер Руководитель проекта Внешняя обработка (ert,epf) v8::БУ БП3.0 Россия БУ Android Учет ОС и НМА Учет ТМЦ Абонемент ($m) Мобильная разработка

SmallSmarty Бухгалтерия - мобильное решение для автоматизации учета на складах с использованием 1С Бухгалтерия и применением технологии штрих-кодирования и RFID. Мобильное приложение для инвентаризации в 1С Бухгалтерия может работать как онлайн, так и полностью автономно. Загрузка/выгрузка данных при автономной работе осуществляется через файл с помощью обработок. Онлайн обмен данными осуществляется через автоматически генерируемый REST интерфейс ODATA. При этом внесение каких-либо изменений в конфигурацию 1С не потребуется. SmallSmarty Бухгалтерия поддерживает сканирование штрихкодов с помощью терминалов сбора данных(ТСД) Caribe, Bluetooth сканера GS M100BT, любого ручного сканера подключаемого через OTG и камеры смартфона.

1 стартмани

24.10.2018    3009    7    ni032mas    0       

Интерфейсы мобильных приложений. Примеры 31

Отчеты и формы Программист Конфигурация (md, cf) v8::Mobile iOS Абонемент ($m) Работа с интерфейсом Мобильная разработка

Примеры реализаций одних из самых распространенных элементов навигации и пример реализации формы списка.

2 стартмани

17.10.2018    6120    87    Baksheev-Nikita    19       

Сканирование штрихкода медицинского полиса единого образца с помощью мобильного приложения 4

Инструменты и обработки Программист Конфигурация (md, cf) v8::Mobile 1cv8.cf Здравоохранение, медицина, стоматология Россия Абонемент ($m) Сканер штрих-кода Мобильная разработка

В данной публикации рассматривается демонстрация сканирования и распознавания штрихкода полиса ОМС единого образца с помощью мобильного приложения фирмы 1С.

5 стартмани

15.09.2018    5416    5    Agregadus    0       

Мобильное приложение для настольного тенниса 6

Инструменты и обработки no Приложение (apk) v8::Mobile Развлечения, искусство, спорт Россия Android Абонемент ($m) Мобильная разработка

Идея этого приложения появилась во время регулярных посещений детских соревнований по настольному теннису. Юные спортсмены результаты каждой встречи записывают в блокнот. В какой-то момент мне стало больно на это смотреть и я решил "оцифровать" этот процесс, а за одно поработать с мобильной платформой. Смартфон сейчас есть у многих с малых лет, поэтому логичным было бы перенести запись результатов игр на смартфон.

1 стартмани

23.08.2018    3294    2    gradi    0       

Приложение Android для идентификации/распознавания образов (с обучением с одного раза, One-Shot Learning) с возможностью работы с 1С через веб-сервис 13

Инструменты и обработки Программист Архив с данными v8 Абонемент ($m) Мобильная разработка

В данной статье описано приложение, алгоритм и методика распознавания изображений, предоставляющее посредством http-запросов информацию о распознанных объектах в 1С. В качестве примера интеграции прилагается конфигурация, реализующая веб-сервис для приема запросов от приложения.

1 стартмани

19.06.2018    8139    4    informa1555    15       

Учебное расписание (мобильное приложение) 7

Инструменты и обработки Программист Конфигурация (md, cf) v8::Mobile Android Абонемент ($m) Мобильная разработка

Мобильное приложение учебного расписания, которое принимает для загрузки файлы формата json

1 стартмани

18.06.2018    5104    10    onec.developer    1       

Внешняя компонента "Монитор активации мобильного приложения" 6

Инструменты и обработки Программист Архив с данными v8::Mobile Android Абонемент ($m) Разработка внешних компонент Мобильная разработка

Компонента позволяет определить, находится ли мобильное приложение на переднем плане.

2 стартмани

06.06.2018    4957    IgorKissil    3       

Электронные карты лояльности для магазина (мобильное приложение) 14

Инструменты и обработки Программист Пользователь Руководитель проекта Расширение (cfe) v8 v8::ОУ v8::Mobile УТ11 Розничная и сетевая торговля (FMCG) УУ Управление взаимоотношениями с клиентами (СRM) Розничная торговля Абонемент ($m) Мобильная разработка Управление торговлей WEB

Пластиковые дисконтные карты - уже прошлый век. Наступила эпоха мобильных приложений. С помощью мобильных приложений можно информировать ваших лояльных клиентов о новых акциях, начисленных бонусах, а также персональных предложениях, вместо рассылок по СМС и почте. Разработка индивидуального мобильного приложения для магазина - удовольствие не из дешевых. Но это и не обязательно, ведь для всех мобильных платформ уже есть встроенные приложения, в которых вы можете разместить карту лояльности вашего магазина. Например, с помощью системы CardPR. В данной публикации показано, как выгрузить клиентов из 1С в CardPR и настроить информирование клиентов о начисленных бонусах за покупки.

1 стартмани

28.05.2018    7951    25    Kutuzov    5       

Мобильный клиент + HTTP Сервис + Расширение конфигурации 96

Статья Программист Архив с данными v8 v8::Mobile 1cv8.cf Россия Абонемент ($m) Мобильная разработка

Пример использования Мобильного клиента, http сервиса и расширения. 10.04.2018 фирма 1С выпустила релиз 8.3.12.1412, с долгожданным мобильным клиентом. Платформа содержит еще ряд долгожданных функций, например возможность работы с расширением через хранилище, но разговор пойдет именно о Мобильном клиенте.

1 стартмани

16.04.2018    22541    36    dsdred    25       

Взаимодействие с NFC через мобильную платформу 1С 20

Инструменты и обработки Программист Архив с данными v8::Mobile 1cv8.cf Абонемент ($m) Мобильная разработка

Цель была научиться взаимодействовать с внешними приложениями из приложения на мобильной платформе 1С. Для данной цели выбрал тему чтение/запись NFC меток. Было разработано: 1) приложение в android studio, которое взаимодействует с NFC 2) приложение на мобильное платформе 1с, которое взаимодействует с разработанным приложением в android studio.

1 стартмани

15.04.2018    10316    12    leobrn    17       

Мобильное приложение: особенности разработки на примере «Тестирование: Отчеты» 43

Статья Программист Архив с данными v8::Mobile Абонемент ($m) Мобильная разработка

В данной статье мы расскажем, с какими проблемами столкнулись и как их решили при создании мобильного приложения «Тестирование: Отчеты» для платформы 1С. Приложение доступно в google play + есть возможность посмотреть работу в демонстрационном режиме.

1 стартмани

12.03.2018    14414    2    ivanov660    2       

Внешняя компонента для широковещательных сообщений (broadcasts) и буфера обмена (clipboard) в ОС Андроид 43

Инструменты и обработки Программист Конфигурация (md, cf) v8::Mobile Android Абонемент ($m) Разработка внешних компонент Мобильная разработка

Представлена компонента для получения широковещательных оповещений и управления буфером обмена в ОС Андроид.

2 стартмани

05.02.2018    13825    163    IgorKissil    155