INFOSTART EVENT 2018 EDUCATION

Второй тур голосования за доклады.
Окончание 5 сентября.

Бачаева Юлия | Руководитель проектов | ГК «Софт-сервис»

«Как не потерять контроль над управлением проектом»

Изменение первоначальных условий договоренностей в процессе проекта, как основные факторы риска. Удовлетворение потребностей заказчика в рамках проекта и избежание переработки участников проекта. Эффективность проектной документации, как средство коммуникации между участниками проекта. Убеждение заказчика в рациональности предложенного решения задач автоматизации. Распределение ресурсов проекта на этапе проектирования и во время внедрения. Защита проекта: ожидания от функционала системы и реальный результат.

Сканирование QR кодов через WEB-камеру

Программирование - Внешние компоненты

7
Программа для считывания QR кодов через вэб-камеру.

Программа не требует установки. Единственное условие - наличие установленного framework 4.0 и старше. Состоит из двух библиотек и выполняемого файла.

1. Запускаем программу. 

2. Подносим QR код.

3. Программа считывает и закрывается. 

В каталоге программы создается файл Output.txt с одной строкой формата: True|563067. Первый параметр  "True" или "False" - статус сканирования. Второй - штрих код или описание ошибки.

Пример процедуры чтения QR кода. Используется для чтения кодов UDS GAME со смартфонов покупателей. 

Процедура ОсновныеДействияФормыСканироватьКодUDS(Кнопка)
	
	КаталогИБ = КаталогИБ();
	Если КаталогИБ = КаталогВременныхФайлов() Тогда
		КаталогИБ = КаталогДокументов();
	КонецЕсли; 
	КаталогИБ = КаталогИБ+"QRreader\";
	
	МассивФайловРезультата = НайтиФайлы(КаталогИБ,"output.txt",Истина);
	Если НЕ МассивФайловРезультата.Количество() = 0 Тогда
		ФайлРезультата = МассивФайловРезультата[0];
		УдалитьФайлы(КаталогИБ+"output.txt");
	КонецеслИ;
	
	МассивФайлов = НайтиФайлы(КаталогИБ,"QRDecoder.exe",Истина);
	Если МассивФайлов.Количество() = 0 Тогда
		Предупреждение("Не установлена программа для чтения QR-кодов!", 60);
	Иначе
		ФайлQRreader = МассивФайлов[0].ПолноеИмя;
		ЗапуститьПриложение(ФайлQRreader, КаталогИБ, Истина,);
		
		МассивФайловРезультата = НайтиФайлы(КаталогИБ,"output.txt",Истина);
		Если НЕ МассивФайловРезультата.Количество() = 0 Тогда
			ФайлРезультата = МассивФайловРезультата[0];
	        ТД = Новый ТекстовыйДокумент;
			ТД.Прочитать(КаталогИБ+"output.txt");
			СтрокаОтвета = ТД.ПолучитьСтроку(1);
			Если СтрокаОтвета <> "" Тогда
				ПозицияРазделителя = Найти(СтрокаОтвета, "|");
				Если ПозицияРазделителя <> 0 Тогда
					ОтветПрограммы = Лев(СтрокаОтвета, ПозицияРазделителя-1); 
			        Если ОтветПрограммы = "True" Тогда
						КодСкидкиUDS = Сред(СтрокаОтвета, ПозицияРазделителя+1, СтрДлина(СтрокаОтвета)-ПозицияРазделителя);
						Если КодСкидкиUDS <> "" Тогда
							
							Отказ = Ложь;
							ИмяКлиента = "";
							СуммаСкидки = 0;
							ОтветСкидки = UDSGame.GET_Customer(КодСкидкиUDS); 
							ЧтениеJSON = Новый ЧтениеJSON;
							ЧтениеJSON.УстановитьСтроку(ОтветСкидки);
							
							СтруктураОтвета = ПрочитатьJSON(ЧтениеJSON, ,"dateCreated");
							
							Если СтруктураОтвета.Свойство("scores") Тогда 
								СуммаСкидкиUDS = СтруктураОтвета.scores; 
							КонецЕсли;
							
							Если СтруктураОтвета.Свойство("name") Тогда
								nameUDS = СтруктураОтвета.name;
							КонецЕсли;
							
							Если СтруктураОтвета.Свойство("surname") Тогда
								surnameUDS = СтруктураОтвета.surname;
							КонецЕсли;
							
							Если СтруктураОтвета.Свойство("errorCode") Тогда
								Предупреждение("Получена ошибка: " + СтруктураОтвета.errorCode, 60);
								Отказ = Истина;
							КонецЕсли;
							
							Если Не Отказ Тогда
								ЭтаФорма.Закрыть();
							КонецЕсли; 
							
						Иначе
							Предупреждение("Не удалось считать код. Попробуйте считать снова.",60);	
						КонецЕсли; 
					Иначе
						Предупреждение("Не удалось считать код. Попробуйте считать снова.",60);
					КонецЕсли; 
				Иначе
					Предупреждение("Не удалось считать код. Попробуйте считать снова.",60);	
				КонецЕсли; 
			КонецЕсли; 
		КонецЕсли; 
	КонецЕсли;
	
КонецПроцедуры

7

Скачать файлы

Наименование Файл Версия Размер
QRreader.zip
.zip 161,39Kb
09.03.17
15
.zip 161,39Kb 15 Скачать

См. также

Комментарии
Сортировка: Древо
2. Sergik_D 18 21.11.17 09:47 Сейчас в теме
(0) Здравствуйте. Не понял что Вам скинуть? Я код описал работы с программой. У меня не стандартная конфигурация, она Вам не подойдет. Если нужно интегрировать, напишите, обсудим.
3. Vladimir45 32 28.02.18 13:53 Сейчас в теме
А как указать что надо использовать не фронтальную, а заднюю камеру на планшете с виндой?
4. Crazy_Max 4 15.06.18 07:33 Сейчас в теме
А может быть исходный код библиотеки выложите, если вы его не распространяете в коммерческих целях? Хотелось бы сэкономить время и дополнить тот функционал, который хотелось бы лично мне...
Оставьте свое сообщение