Поздравление с Новым Годом 2010 для 1С 8.1 - свободный доступ для всех :)

Публикация № 63428

Сообщество - Поздравления

Поздравление с Новым Годом 2010 для 1С 8.1 - обновил до версии 1.2.1
Включил свободный доступ для всех :)

Поздравление с Новым Годом 2010 для 1С 8.1

Моя обработка основана на аналогичной обработке для 1С 77
//infostart.ru/public/61649

Версия 1.1

+ используются только новогодние анекдоты;

+ текст отображается не только в Агенте, но и на форме;

+ если Агента по разным причинам не удается загрузить, то обработка все равно работает, просто отображая текст на экране;

+ для каждой фоновой картинки используется свой цвет текста для лучшего восприятия.

Версия 1.2

- исправлен подсчет дней до НГ

* доработан показ дней (1 день, 2 дня, 5 дней и т.п.)

Версия 1.2.1

- исправлена ошибка при работе с поздравлениями.

Для новичков - для использования при начале работы пользователей

необходимо в модуле приложения конфигурации 8.1 выполнить следующее

1. в процедуре ПриНачалеРаботыСистемы добавить следующий код:

[code]
 ДатаПраздника = 31; МесяцПраздника = 12; //31.12
 РаботаемВСубботу = ЛОЖЬ;
 Если НужноВыводитьПоздравлениеСПраздниками(ДатаПраздника, МесяцПраздника, РаботаемВСубботу, лТекущаяДата) Тогда
  Попытка
  Открытка = ВнешниеОбработки.ПолучитьФорму("W:\артПоздравлениеСНовымГодом_2010.epf", "Форма"); 
  Открытка.Открыть();
  Исключение
  //ОписаниеОшибки()
  КонецПопытки;
 КонецЕсли;
[/code]

2. В модуль приложения добавить функцию
[code]
Функция НужноВыводитьПоздравлениеСПраздниками(ДатаПраздника, МесяцПраздника, РаботаемВСубботу, ТекущаяДатаДляОтладки = Неопределено)
 Если ЗначениеЗаполнено(ТекущаяДатаДляОтладки) Тогда
  лТекущаяДата = ТекущаяДатаДляОтладки;
 Иначе
  лТекущаяДата = ТекущаяДата();
 КонецЕсли;
 
 началоДняТекущейДаты = НачалоДня(лТекущаяДата);
 
 Если Месяц(лТекущаяДата) = МесяцПраздника Тогда
  ДеньНедели = ДеньНедели(Дата(Год(лТекущаяДата), МесяцПраздника, ДатаПраздника));
  Если ДеньНедели > 5 Тогда //Праздник попадает на Сб, Вс, открытку выводить нужно в Пт
  Если РаботаемВСубботу Тогда
  СмещениеДат = ДеньНедели - 6;
  Иначе
  СмещениеДат = ДеньНедели - 5;
  КонецЕсли;
  ИначеЕсли ДеньНедели < 3 Тогда //Праздник попадает на Пн, Вт, открытку выводить нужно в Пт, Сб
  Если РаботаемВСубботу Тогда
  СмещениеДат = 2;
  Иначе
  СмещениеДат = 3;
  КонецЕсли;
  Иначе
  СмещениеДат = 1;
  КонецЕсли;

  Если началоДняТекущейДаты = НачалоДня(Дата(Год(лТекущаяДата),МесяцПраздника,(ДатаПраздника - СмещениеДат))) Тогда
  ФизЛицо = глЗначениеПеременной("глТекущийПользователь").ФизЛицо;
  Если ЗначениеЗаполнено(ФизЛицо) Тогда
  Если ФизЛицо.Пол = Перечисления.ПолФизическихЛиц.Мужской Тогда
  Возврат ЛОЖЬ;
  КонецЕсли;
  КонецЕсли;
  Возврат Истина;
  КонецЕсли;
 КонецЕсли;
 Возврат ЛОЖЬ;
КонецФункции
[/code]

Жду предложений по развитию + анекдотов + идей по оформлению/использованию.

PS Мои женщины (менеджеры, бухгалтера) всегда по-детски радуются подобным поздравлениям на праздники.

PPS долго ждал, пока кто-нибудь сделает для 8.1, но народ не спешил, пришлось самому заняться :)

Скачать файлы

Наименование Файл Версия Размер
артПоздравлениеСНовымГодом_2010.epf
.epf 261,40Kb
25.02.13
460
.epf 261,40Kb 460 Скачать бесплатно

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо развёрнутое
Свернуть все
1. shaganel 28.12.09 17:07 Сейчас в теме
Мило. Завтра как раз еду любимых клиентов поздравлять.
3. dobraleks 136 28.12.09 18:10 Сейчас в теме
4. fikuz@mail.ru 29.12.09 05:46 Сейчас в теме
Все работает, отлично. Правда, считает странно :( . Пишет "Сегодня 29 декабря. До Нового года осталось 1 дней". Это по-нашему стопудово :D
O-Planet; artbear; +2 Ответить
5. artbear 1176 29.12.09 06:53 Сейчас в теме
Версия 1.2

- исправлен подсчет дней до НГ - Спасибо (4)

* доработан показ дней (1 день, 2 дня, 5 дней и т.п.)
6. oberonm 9 29.12.09 08:37 Сейчас в теме
7. e-katerina 125 29.12.09 10:29 Сейчас в теме
Отлично! :D

А что касается идей: кол-во дней до нового года можно сделать бегущей строкой, а при открытии волшебник выдает небольшое "предсказание" методом случайного выбора.
8. AKV77 245 29.12.09 11:17 Сейчас в теме
Спасибо, сделано со вкусом
9. kenshin 234 29.12.09 16:33 Сейчас в теме
Я б все таки тигра оставил на первой картинке, год тигра как ни как
10. kenshin 234 29.12.09 16:40 Сейчас в теме
13. artbear 1176 29.12.09 19:35 Сейчас в теме
(10) Не понял, ты про что написал?
11. kenshin 234 29.12.09 16:43 Сейчас в теме
{Форма.Форма(67)}: Ошибка при вызове метода контекста (Speak): Произошла исключительная ситуация (Agent.Control.2): Параметр задан неверно.

гПерсонажАгента.Speak(наименование);
по причине:
Произошла исключительная ситуация (Agent.Control.2): Параметр задан неверно.

при повторном нажатии на поздравления ошибка вылазить подправь и будет счастье
12. artbear 1176 29.12.09 19:34 Сейчас в теме
(11) Спасибо. Посмотрю
ЗЫ вроде все тестил :)
14. artbear 1176 29.12.09 20:43 Сейчас в теме
Выложена версия 1.2.1 - исправлена ошибка при работе с поздравлениями.

(11) Исправил
15. strange2007 142 30.12.09 04:26 Сейчас в теме
СУПЕР!!!!!!!!!!! Как я раньше не догадался?
16. elisabet 98 30.12.09 07:47 Сейчас в теме
все прикольно, но только у нас год будет 2010, а не 20010 как у автора в одной примете, а так "+"
17. KIT_VIA 30.12.09 08:38 Сейчас в теме
Большое спасибо, очень понравилось всем клиентам!!!
18. aipnnov 163 30.12.09 09:02 Сейчас в теме
Для новичков - для использования при начале работы пользователей необходимо в модуле приложения конфигурации 8.1 в процедуре ПриНачалеРаботыСистемы добавить следующий код:
Если НачалоДня(ТекущаяДата())= НачалоДня(Дата(2009,12,30)) ИЛИ НачалоДня(ТекущаяДата())= НачалоДня(Дата(2009,12,31)) Тогда 
  Попытка
  Открытка = ВнешниеОбработки.ПолучитьФорму("W:\артПоздравлениеСНовымГодом_2010.epf", "Форма");
  //Открытка = Обработки.артПоздравлениеСНовымГодом_2010.ПолучитьФорму("Форма");
  Открытка.Открыть();
  Исключение
  //ОписаниеОшибки()
  КонецПопытки;
 КонецЕсли
Показать


По моему лучше этот код добавить в модуль самой обработки, а обращение к ней добавить в любой общий модуль, который вызывается из модуля приложения ПриНачалеРаботыСистемы, например в ЗавершениеРаботыПользователей -> УстановитьКонтрольРежимаЗавершенияРаботыПользователей() и конечно же между операторами препроцессора #Если Клиент Тогда и #КонецЕсли.
Это гораздо лучше т.к. можно добавлять в обработку любой праздник.
19. artbear 1176 30.12.09 09:56 Сейчас в теме
Выложил обработку в свободный доступ для всех - качайте сколько хотите :)

(18) Я специально написал "для новичков".
Более опытные разработчики могут придумывать различные варианты :)
Например, у меня юзается спец.класс с вызовом разных вариантов для различных праздников.
20. DarkSign 30.12.09 12:14 Сейчас в теме
А что-то не стартует оно при загрузке. Модуль поправил, права есть, интерфейс соответствует. Работает только с пинка, т.е. вручную...
25. artbear 1176 31.12.09 10:48 Сейчас в теме
(20) Случайно хранилище не юзаешь? У меня лично была проблема, когда в конфу, подключенную к хранилищу, я пытался загрузить данный файл как обработку. Забыл флаг рекурсии поставить, и в итоге форма не грузилась.

Больше никаких проблем не было, как видишь, никто не жалуется, ищи у себя :(
Или пиши более подробно.
21. welik 3 30.12.09 13:01 Сейчас в теме
Спасибо, идея очень нужная. Пошлые анекдоты пришлось удалить. ))
22. TLS 30.12.09 13:49 Сейчас в теме
Спасибо большое, поставила, наших порадовала )))
23. DanilovaOlga 30.12.09 16:02 Сейчас в теме
Просто СУПЕЕЕР!!!! Пока всё работает! СПАСИИИБО!!!! От восторга прям распирает ))) :{}
24. artbear 1176 31.12.09 10:45 Сейчас в теме
(23) Всегда пожалуйста! :)
(21) Насчет пошлых - пока никто не жаловался, тем более, что самые пошлые я предпочитаю рассказывать лично уже самым достойным :)
26. DanilovaOlga 01.12.11 11:07 Сейчас в теме
До сих пор наши вспоминают этот подарок под Новый год )) никто не работал, все анекдоты читали ))
27. DanilovaOlga 01.12.11 11:30 Сейчас в теме
28. DanilovaOlga 01.12.11 11:30 Сейчас в теме
29. artbear 1176 01.12.11 11:44 Сейчас в теме
30. milkers 2391 19.12.18 11:24 Сейчас в теме
(0) Поздравление на управляемых формах https://infostart.ru/public/960899/
Оставьте свое сообщение

См. также

Онлайн-курс «Автоматизация процессов управления МТО: методика сбора и формализации требований» с 1 апреля по 13 мая 2020 года. Промо

Цель курса - повысить полноту и качество сбора и формализации требований к автоматизации процессов управления материально-техническим обеспечением. Курс основан на процессном подходе, позволяет в полном объеме выявить и учесть все факторы, влияющие на специфику процессов управления МТО. Участники курса получают теоретические знания в области организации процессов управления МТО и готовый инструментарий для сбора и формализации требований по автоматизации этих процессов (шаблоны, опросники, модели).

40000 рублей

Екатеринбург.Online: Голосование продолжается Промо

Продолжается голосование за доклады на INFOSTART MEETUP Екатеринбург.Online! Лучшие из них попадут в окончательную программу онлайн-митапа! Присоединяйтесь к голосованию и покупайте билеты - 3 000 рублей за 8 часов продуктивной пятницы!

3000

Подборка решений для взаимодействия со ФГИС «Меркурий» Промо

С 1 июля 2019 года все компании, участвующие в обороте товаров животного происхождения, должны перейти на электронную ветеринарную сертификацию (ЭВС) через ФГИС «Меркурий». Инфостарт предлагает подборку программ, связанных с этим изменением.

Поздравления с новым годом для бухгалтерии прямо в 1С

Отчеты и формы no Внешняя обработка (ert,epf) v8 1cv8.cf Россия Бесплатно (free) Поздравления

Думаю, после этого бухгалтерия начнет по другому к вам относиться)

04.12.2011    19756    130    mob51    18       

Поздравлялка с 8 марта

Отчеты и формы no Внешняя обработка (ert,epf) v8 1cv8.cf Россия Бесплатно (free) Поздравления

30 открыток и генератор случайных чисел, чтобы у 10 женщин не вылазила одна и та же картинка ;) Ну и для разнообразия кнопка "Еще!" - выдает случайную картинку из набора. Версии платформы 8.1 и 8.2 (обычное приложение).

04.03.2011    30024    313    v.l.    30       

Программы для исполнения 54-ФЗ Промо

С 01.02.2017 контрольно-кассовая техника должна отправлять электронные версии чеков оператору фискальных данных - правила установлены в 54-ФЗ ст.2 п.2. Инфостарт предлагает подборку программ, связанных с применением 54-ФЗ, ККТ и электронных чеков.

Несложная поздравлялка с Новым 2011 годом.

Отчеты и формы no Внешняя обработка (ert,epf) v8 1cv8.cf Россия Бесплатно (free) Поздравления

Обработка, которую Вы можете вставить в свою конфигурацию

23.12.2010    13137    158    Сисой    4       

Поздравления с 8 Марта! (4.2.0.1)

Отчеты и формы no Внешняя обработка (ert,epf) v8 1cv8.cf Россия Бесплатно (free) Поздравления

Поздравления с 8 Марта на рабочий стол 1С:Предприятия. Хотите больше поздравлений? Их здесь 30...

04.03.2010    29784    1003    alexk-is    58       

Новый раздел на Инфостарте - Electronic Software Distribution Промо

Инфостарт напоминает: на нашем сайте можно купить не только ПО, связанное с 1С. В нашем арсенале – ESD-лицензии на ПО от ведущих вендоров: Microsoft, Kaspersky, ESET, Dr.Web, Аскон и другие.

  • Низкие цены, без скрытых платежей и наценок
  • Оперативная отгрузка
  • Возможность оплаты с личного счета (кешбек, обмен стартмани на рубли и т.п.)
  • Покупки идут в накопления для получения скидочных карт лояльности Silver (5%) и Gold (10%)

С праздником 8 марта!

Отчеты и формы no Внешняя обработка (ert,epf) v8 1cv8.cf Россия Бесплатно (free) Поздравления

Обработка, поздравляющая женскую часть коллектива с праздником 8 марта.

05.03.2009    21061    499    azernot    26