Чичикин Арсен | Управляющий, собственник | 1С-Софт Райз

«Управление проектом в условиях неопределенности»

1. Требования Заказчика в тендерной документации и реальные требования к автоматизации диаметрально противовположны 2. Заказчик не готов к проекту автоматизации, а контракт уже подписан... 3. Заказчик "сам знает, как настроить автоматизированную систему"

Вставка снимка экрана (screenshot) в форматированный документ

Программирование - Практика программирования

Пример работы с буфером обмена и программной вставки скриншота в форматированный документ.

Возникла потребность создания документа в 1С для регистрации ошибок работы программ у пользователей.

 

На первый взгляд задача тривиальная, сделать документ, с красивым полем форматированного документа, ответственным, датой обращения, темой и все такое.

Камнем преткновения стала возможность работы с буфером обмена. Как оказалось, штатных способов работы с буфером и нет.

А ведь было бы прикольно, нажать ctrl+prtscr (alt+prtscr), и вставлять содержимое из буфера в нужную позицию документа, где находится курсор.

 

После изучения определенного количества неплохих, но достаточно старых публикаций, сделал вывод что штатная вставка ctrl+v для картинов не работает,

 

методы, типа

хОбъект = Новый COMОбъект(«htmlfile»);
Результат = хОбъект.ParentWindow.ClipboardData.Getdata(«Text»);

работают только с текстом,

 

варианты с подключением к эксель, копипастом в него, и сохранением в файл - ресурсоемки, да и не везде эксель доступен.

 

Остались варианты с внешними компонентами.

компонент тоже немного, давным давно (в 2009), пользователь gudun_ku выложил компоненту clipboard.dll для этой цели.

на основе которой, было сделано некоторое количество обработок к разным конфигурациям..

Но несмотря на все усилия, мне не удалось все это запустить уже на современной конфигурации, под win7. Все попытки подключения компоненты, приводят к исключению.

 

когда, уже почти опустились руки, - решил покопаться в типовых. И к радости обнаружил что фирма 1С уже позаботилась об этом, и в конфигурации Документооборот уже присутствует такая компонента, и данный функционал всего-лишь необходимо использовать.

Собственно этими знаниями и решил поделится, дабы облегчить жизнь тем, кто столкнется с подобной задачей.

 

Итак:

Сама компонента находится в общих макетах, макет называется - ОбщиеМакеты.КомпонентаПолученияКартинкиИзБуфера

 

Далее нам понадобится модуль

ОбщийМодуль.РаботаСКартинкамиКлиент

там всего несколько процедур и функций, по установке, и инициализации компоненты.

// Устанавливает компоненту сканирования
Процедура УстановитьКомпоненту(ОбработчикРезультата) Экспорт

// Продолжение установки компоненты
Процедура НачатьУстановкуВнешнейКомпонентыПродолжение(ПараметрыВыполнения) Экспорт// Продолжение установки компоненты
Процедура НачатьПодключениеВнешнейКомпонентыПродолжение(Подключена, ПараметрыВыполнения) Экспорт

// Проинициализировать компоненту сканирования
Функция ПроинициализироватьКомпоненту() Экспорт

// Вернет версию компоненты сканирования
Функция ВерсияКомпоненты() Экспорт

 

Также нужно не забыть про глобальную переменную

которая объявлена в модуле управляемого приложения

Перем КомпонентаПолученияКартинкиИзБуфера Экспорт; // компонента получения картинки из буфера обмена

Собственно, это и все что нам нужно для работы.

 

Далее рисуем наш документ, размещаем на форме форматированный документ, и не забываем про реквизит типа "ХранилищеЗначений", для того чтобы нам картинки в базе хранить.

 

Делаем команду, вставка из буфера, и прописываем код

 
&НаКлиенте 
Процедура ВставитьИзБуфера(Команда) 
     КомпонентаУстановлена = РаботаСКартинкамиКлиент.ПроинициализироватьКомпоненту(); 
     Если Не КомпонентаУстановлена Тогда 
          Обработчик = Новый ОписаниеОповещения("ВставитьКартинкуИзБуфераЗавершение", ЭтотОбъект); 
          РаботаСКартинкамиКлиент.УстановитьКомпоненту(Обработчик); 
     Возврат; 
     КонецЕсли; 
     ВставитьКартинкуИзБуфераЗавершение(Истина, Неопределено); 
КонецПроцедуры 

&НаКлиенте 
Процедура ВставитьКартинкуИзБуфераЗавершение(Результат, ПараметрыВыполнения) Экспорт 
     Если Результат = Истина Тогда 
          ПутьКФайлу = КомпонентаПолученияКартинкиИзБуфера.ПолучитьКартинкуИзБуфера(); 
          Если Не ПустаяСтрока(ПутьКФайлу) Тогда 
               Картинко = Новый Картинка(ПутьКФайлу); 
               УдалитьФайлы(ПутьКФайлу); 
               ПозицияНачала = 0; 
               ПозицияОкончания = 0; 
               Элементы.Описание.ПолучитьГраницыВыделения(ПозицияНачала,ПозицияОкончания); 
               Начало = ФорматированныйДокумент.ПолучитьПозициюПоЗакладке(ПозицияНачала); 
               ВставитьКартинкуВФорматированныйДокумент(Картинко,Начало); 
          Иначе 
               ПоказатьПредупреждение(,НСтр("ru = 'Буфер обмена не содержит картинки'")); 
          КонецЕсли; 
     КонецЕсли; 
КонецПроцедуры

 

Так как метод вставки картинки доступен только на сервере, то там и выполняем

 

&НаСервере 
Процедура ВставитьКартинкуВФорматированныйДокумент(Кар,Позиция) 
     Закладка = ФорматированныйДокумент.ПолучитьЗакладкуПоПозиции(Позиция); 
     ФорматированныйДокумент.Вставить(Закладка,Кар, Тип("КартинкаФорматированногоДокумента")); 
КонецПроцедуры

Результат достигнут, все работает.

Лишний раз убедился, что для успешной работы нет нужды каждый раз изобретать велосипед, а необходимо регулярно изучать имеющиеся подсистемы, и пользоваться по максимуму ими.

 

 

---

для ленивых прикладываю cf-файл с примером работы

---

 

При подготовке была использована информация из публикаций

//infostart.ru/public/19872/ - компонента

//infostart.ru/public/280022/ - через эксель

//infostart.ru/public/81133/ - труды Поручика

//infostart.ru/public/74958/ - про форматированный документ

//infostart.ru/public/601828/ - доп.информация

Скачать файлы

Наименование Файл Версия Размер
демонстрационный_пример
.cf 60,71Kb
29.08.17
13
.cf 60,71Kb 13 Скачать

См. также

Комментарии
Сортировка: Древо
1. gubanoff 45 30.08.17 17:29 Сейчас в теме
2. kraynev-navi 363 31.08.17 12:17 Сейчас в теме
Как человек, который не первый год использует эту типовую компоненту могу добавить следующее.
1. Она работает не всегда, не на всех платформах.
2. Если не работает на конкретной платформе, то можно покопаться в документообороте и найти другую версию компоненты. Вот только не факт, что заработает.
3. Не сталкивался, но подозреваю, что должны быть права на установку компоненты на клиентских компах, возможно также не на всех версиях винды это будет работать.
igormiro; Serj1C; +2 Ответить
3. Boneman 176 01.09.17 13:19 Сейчас в теме
Кстати, о форматированном документе. Все - таки, каким-то образом, штатная вставка картинки из буфера ctrl+v,работает, без всяких компонент. Но я не могу, понять причины.
Т.е. на одной и той же платформе, одна и та-же серверная база, оба сеанса на тонком клиенте.
На локальном компьютере с win7 - вставка не работает ни в какую.
На сервере, в сеансе через rdp - все работает.
Думал может из-за браузера, на сервере internet explorer по умолчанию. Сделал на локальном тоже его, настройки браузеров сравнивал. Но вставка так и не заработала.
Если кто-то, вычислит что именно влияет на работу форматированного документа, почему на одних компьютерах штатная вставка работает, на других нет, поделитесь информацией.

П.С. С компонентой, как я описал в статье, пока работает везде, но лишние познания в тайне работы форматированного документа - не помешают )))
4. DrAku1a 1280 11.09.17 07:03 Сейчас в теме
В "Управление ИТ-отделом" есть подобная компонента. И я реализовывал функцию вставки картинки в форматированный документ. Кстати, в 8.3 у меня PNG-картинки (скопированные из программы PicPick) - вставлялись и стандартно (через CTRL+V), но при этом они вставляются в "тело" документа как BASE64-строка, и такие картинки не отображаются встроенным же в 1С полем HTML-документа. Приходится перекодировать в обычные картинки.
kraynev-navi; +1 Ответить
5. VovkaBo 12.09.17 11:34 Сейчас в теме
Послушайте, у меня была задача вставки картинок, я тупо попробовал вставить из буфера обмена в поле форматированного документа, и картинка вставилась.
Также я пробовал тупо перетаскивать картинку мышкой в поле форматированного документа, и картинка вставилась.
Это на 8.3.10
6. Boneman 176 12.09.17 11:47 Сейчас в теме
(5) я в (3) сообщении об этом написал. Дело не в платформе, а в каких то настройках винды или каких-то программ. Но каких именно, я не смог найти. Показывал нашим админам, тоже потыркались - не поняли причины. на одном компе работает, на другом нет. Платформа одна и та же, база одна и та же, клиент одинаковый, тонкий.
7. SkyLink2012 240 15.03.18 14:15 Сейчас в теме
Надо в 1с вставить картинку из буфера обмена ? Работать с изображением из буфера обмена в 1с версий 8.1 , 8.2 , 8.3 из Windows XP- windows10?


Пока возможно скачать разработку 2010 года https://infostart.ru/public/19932/ без списания стартмони в 2018, 2019, 2012 году бесплатно. В макете обработки есть dll-ка clipboard.dll 511кб ( 523264б ), версия 1.0.0.5



Возникает ошибка 80004005 при регистрации ( c:\Program Files\1cv82>regsvr32 clipboard.dll ) в командной строке?

Попросту, надо запустить cmd "Командная строка (Администратор)" и зарегистрировать библиотеку

regsvr32 "c:\Program Files\1cv82\clipboard.dll"



Очень простой код
		ЗагрузитьВнешнююКомпоненту("clipboard.dll"); //и не надо вам никаких V8ADD.dll, если только фотки грузить, путем подгрузки через Base64
		Попытка
			КомпонентБО = Новый("AddIn.clipboard");
		Исключение
			Сообщить("Не удалось создать объект компоненты clipboard");
			Сообщить(ОписаниеОшибки());
		КонецПопытки;
Показать



Тип не определен (Addin.Clipboard) ? Понадобиться запустить cmd "Командная строка (Администратор)" и зарегистрировать библиотеку

regsvr32 "c:\Program Files\1cv82\clipboard.dll"


В итоге, в рунете появятся бОльше качественных и полезных фото))
В целом, для тех кто не в пожизненной теме - C# . Кто с уважением посматривает на кнопку "Заказать установку этой обработки". На дворе 2018год. Уже Python as an Excel scripting language Для 1с+Python from PIL import Image и subprocess.Popen в помощь! :)
Оставьте свое сообщение