Цвет индикатора в зависимости от значения

Программирование - Практика программирования

Функция, которая выдает значение цвета, в зависимости от передаваемого значения и максимально возможного значения.

Очень часто, для лучшего восприятия, необходимо окрасить индикатор в зависимости от значения.
Данная обработка является оберткой для демонстрации работы функции ПолучитьОттенок.
Фактически нужен градиент от красного(255,0,0) до зеленого(0,255,0) или от 0 до 120 H в HSV шкале.

Функция ПолучитьОттенок на входе получает текущее Значение и Максимальное значение, а на выход выдает цвет.
 

Функция ПолучитьОттенок(ТекущееЗначение,Максимум) экспорт // зеленый -максимальный, красный - минимальный
	
//Определяем часть
часть=ТекущееЗначение/максимум;
шаг=510/максимум; //сквозной шаг

//зеленый (0,255,0)
//желтый  (255,255,0)
//красный(255,0,0)
// фактически это движение в HSV, где меняется только Hue в пределах от 0 до 120
компонентR=0;
компонентG=0;
//определяем к какой половине спектра отностится наше число
Если часть > 0.5 тогда
	компонентR=цел(255-((ТекущееЗначение-0.5*максимум)*шаг));
	компонентG=255;
	
Иначе	
	компонентR=255;
	компонентG=цел(ТекущееЗначение*шаг);
		
КонецЕсли;	
	
возврат Новый Цвет(компонентR,компонентG,0);
	
КонецФункции

 

Скачать файлы

Наименование Файл Версия Размер
Цвет индикатора в зависимости от значения:
.epf 7,39Kb
29.08.17
3
.epf 1 7,39Kb 3 Скачать

См. также

Комментарии
1. Роман Ложкин (webester) 24 30.08.17 05:05 Сейчас в теме
Еще надо параметр "Инвертировать" в функцию, что бы она выдавала красный ближе к концу :)
2. Константин Чемисов (kc-ropa) 37 30.08.17 08:58 Сейчас в теме
Функция ПолучитьОттенок(ТекущееЗначение,Максимум,инвертировать=ложь) экспорт // зеленый -максимальный, красный - минимальный
	
//Определяем часть
часть=ТекущееЗначение/максимум;
шаг=510/максимум; //сквозной шаг

//зеленый (0,255,0)
//желтый  (255,255,0)
//красный(255,0,0)
// фактически это движение в HSV, где меняется только Hue в пределах от 0 до 120
компонентR=0;
компонентG=0;
//определяем к какой половине спектра отностится наше число
Если часть > 0.5 тогда
	компонентR=цел(255-((ТекущееЗначение-0.5*максимум)*шаг));
	компонентG=255;
	
Иначе	
	компонентR=255;
	компонентG=цел(ТекущееЗначение*шаг);
		
КонецЕсли;	
Если инвертировать тогда возврат Новый Цвет(компонентG,компонентR,0);	
				   иначе возврат Новый Цвет(компонентR,компонентG,0);
КонецЕсли;	
	
КонецФункции
Показать
itriot11; +1 Ответить
3. Артур Аюханов (artbear) 882 30.08.17 16:50 Сейчас в теме
7. Константин Чемисов (kc-ropa) 37 31.08.17 09:05 Сейчас в теме
4. Антон Грачев (Fragster) 721 30.08.17 19:34 Сейчас в теме
Не интересно. Например в https://infostart.ru/public/551431/ начальные и конечные цвета задаются, а далее получается плавный градиент между ними.
6. Константин Чемисов (kc-ropa) 37 31.08.17 09:04 Сейчас в теме
(4) Спасибо, я его не видел.
5. Андрей Акулов (DrAku1a) 1216 31.08.17 04:41 Сейчас в теме
Немножко математической магии:
компоненты = ТекущееЗначение / Максимум * 510;
компонентR = Мин(510 - компоненты, 255);
компонентG = Мин(компоненты, 255);
возврат Новый Цвет(компонентR,компонентG,0)

Для того, чтобы инвертировать - меняем местами R и G
8. Константин Чемисов (kc-ropa) 37 31.08.17 09:06 Сейчас в теме
(5) Красота! Так гораздо компактней и быстрее, но менее очевидно.
9. Андрей Акулов (DrAku1a) 1216 31.08.17 17:09 Сейчас в теме
(8) На самом деле - всё становится очевидно, если нарисовать графики изменения цвета.
Кстати, из этого графика становится примерно ясен алгоритм перехода из одного произвольного цвета в другой произвольный цвет.
Прикрепленные файлы:
10. Андрей Акулов (DrAku1a) 1216 01.09.17 08:33 Сейчас в теме
(9)
Функция ПолучитьКомпонентОттенка(КомпонентНач, КомпонентКон, Коэффициент)
	Если КомпонентКон=КомпонентНач Тогда
		Возврат КомпонентНач;
	ИначеЕсли КомпонентКон>КомпонентНач Тогда
		Возврат КомпонентНач + 2 * (КомпонентКон - КомпонентНач) * Коэффициент;
	Иначе
		Возврат КомпонентНач + 2 * (КомпонентНач - КомпонентКон) * (1-Коэффициент);
	КонецЕсли;
КонецФункции

Функция ПолучитьОттенокЦвета(ЦветНач, ЦветКон, ТекущееЗначение, МаксЗначение, МинЗначение=0)
	Если МаксЗначение<=МинЗначение или ТекущееЗначение<МинЗначение Тогда
		Возврат ЦветНач;
	ИначеЕсли ТекущееЗначение>МаксЗначение Тогда
		Возврат ЦветКон;
	КонецЕсли;
	Коэффициент = ТекущееЗначение / (МаксЗначение - МинЗначение);
	КомпонентКрасный = ПолучитьКомпонентОттенка(ЦветНач.Красный, ЦветКон.Красный, Коэффициент);
	КомпонентЗеленый = ПолучитьКомпонентОттенка(ЦветНач.Зеленый, ЦветКон.Зеленый, Коэффициент);
	КомпонентСиний = ПолучитьКомпонентОттенка(ЦветНач.Синий, ЦветКон.Синий, Коэффициент);
	Возврат Новый Цвет(КомпонентКрасный, КомпонентЗеленый, КомпонентСиний);
КонецФункции
Показать
Оставьте свое сообщение