Навигация по функциональным опциям типовых конфигураций

Управление - Пользователю системы

обработка функциональные опции настройки поиск

121
Из релиза в релиз разделы и функциональные опции меняют своё местоположение. Вкупе с многостраничными формами настроек поиск нужной настройки становится испытанием для терпеливых. Я нашел такое решение.

Обработка создана для удобной навигации по функциональным опциям конфигурации при подготовке к профу по УТ11.

Алгоритм работы основан на переборе форм всех обработок с основным реквизитом НаборКонстант.

ТаблицаНастроек = Новый ТаблицаЗначений;
Для Каждого Обработка из Метаданные.Обработки Цикл
	
	Для Каждого ФормаОбработки из Обработка.Формы Цикл
		
		Попытка
			Форма = ПолучитьФорму("Обработка." + Обработка.Имя + ".Форма."+ФормаОбработки.Имя);;
			ОсновнойРеквизит = Форма.НаборКонстант; 
		Исключение
			Продолжить; // если нет констант - пропускаем
		Конецпопытки;
	
		Для Каждого ЭлементФормы из Форма.Элементы Цикл
			НоваяСтрока = ТаблицаНастроек.Добавить();
			НоваяСтрока.ИмяЭлемента = ЭлементФормы.Имя;
			НоваяСтрока.ЗаголовокЭлемента = ЭлементФормы.Заголовок;
			НоваяСтрока.ИмяФормы = ФормаОбработки.ПолноеИмяФормы;
			НоваяСтрока.ЗаголовокФормы = ФормаОбработки.СинонимФормы;
		КонецЦикла;

	КонецЦикла;
	
КонецЦикла;

Реализован поиск по первым символам и по части подстроки. При выборе открывается форма и соответствующая настройка выделяется красным шрифтом.

Для удобства настройки выводятся как в форме таблицы, так и в форме иерархического дерева.

Тестировалось в 8.3:
- 1С:ERP Управление предприятием 2 (2.4.2.110)
- Управление торговлей, редакция 11 (11.3.1.109)
- Управление торговлей, редакция 11.1 (11.1.7.60)
- Бухгалтерия предприятия, редакция 3.0 (3.0.49.21)

На других тоже должно работать.

 
 ERP содержит более 600 настроек!

Вы можете поучаствовать в развитие разработки на github.

121

Скачать файлы

Наименование Файл Версия Размер
ОбработкаПоискНастроек.epf
.epf 12,82Kb
30.01.18
58
.epf 12,82Kb 58 Скачать

См. также

Комментарии
Избранное Подписка Сортировка: Древо
1. kuzyara 522 30.01.18 13:04 Сейчас в теме
ОбработкаПоискНастроек.epf
Прикрепленные файлы:
ОбработкаПоискНастроек.epf
windows98a; alex5550; ZhokhovM; 1vasia1; i_lo; independ; lmm; qwerty679; kuznecov_egor; AtPups000; leobrn; VladimirL; serg80; ice-net; aicom; angur; headMade; user595259_tta.bes; Bazil; igormiro; mevgenym; senshib; fomaOp; kadild; MarinaSk; user627712_1c; dvs691; AlX0id; shard; davlen; c1nil; ALFAcaRUS; NeviD; Snarl; user764938; &rew; yelloo; DreamcastMD; hornet_X; Дамир1; user774630; Demann; v_den_v; kernelio; Quasar; 9-pm; Ganjubas; rpgshnik; qbdp; creatermc; Новиков; Berckk; MaximStav; Aleskey_K; Lo1jke; cleaner_it; premier; Nelli_A86; the1; kaa79; ditp; jaroslav.h; fancy; akim2040; EliasShy; allga383; user747571; 27272; SP2000; zhenyat; nixel; Danil.Potapov; palsergeich; jif; pallid; MSK_Step; Wadus161; SkrAn; yukon; khabibullin.tu; genayo; klaus38; +82 Ответить
4. khabibullin.tu 75 30.01.18 14:30 Сейчас в теме
(1)
ОбработкаПоискНастроек.epf
Прикрепленные файлы:
ОбработкаПоискНастроек.epf


Протестировал на последней ERP, всё работает ШИ-КА-Р-НО !

Да и поиск после первого открытия сохраняется, супер !
2. Maxisussr 30.01.18 13:16 Сейчас в теме
Классная и простая обработка, спасибо автору! Пригодится даже в БУХ и ЗУП, когда забудешь что-нибудь.
3. khabibullin.tu 75 30.01.18 14:20 Сейчас в теме
Вот это да ! Николай, вы сделали то, о чем я мечтал каждый раз, когда пытался вспомнить где хранится та или иная настройка !

Однозначно, большой плюс вам в карму !
5. jif 30.01.18 16:57 Сейчас в теме
1С:ERP Управление предприятием 2 (2.4.1.206) +
6. petronas 7 31.01.18 10:31 Сейчас в теме
Николай, спасибо, крайне полезный функционал !
P.S. ERP + отраслевой модуль - 952 настройки ;)
7. MoksDm 31.01.18 10:48 Сейчас в теме
Автору спасибо, нужный инструмент.
8. jaroslav.h 01.02.18 18:09 Сейчас в теме
9. serega33 02.02.18 12:46 Сейчас в теме
11. 1vasia1 15 29.03.18 12:29 Сейчас в теме
Полезно, спс. Я добавил бы ещё группировку/разгруппировку дерева.
12. kuzyara 522 29.03.18 13:05 Сейчас в теме
Оставьте свое сообщение