IE2017

Шаблон внешней обработки УТ 11

Программирование - Инструментарий

Шаблон внешней обработки УТ 11
Функция СведенияОВнешнейОбработке() Экспорт

    Структура = Новый Структура;
    Структура.Вставить("Вид",             "ЗаполнениеОбъекта"); //Перечисления.ВидыДополнительныхОтчетовИОбработок.
    Структура.Вставить("Наименование",    "Шаблон внешней обработки");
    Структура.Вставить("Версия",          "1.01");
    Структура.Вставить("БезопасныйРежим", Истина);
    Структура.Вставить("Информация",      "");

    Команды = Новый ТаблицаЗначений;
    Команды.Колонки.Добавить("Идентификатор");
    Команды.Колонки.Добавить("Представление");
    Команды.Колонки.Добавить("Модификатор");
    Команды.Колонки.Добавить("ПоказыватьОповещение");
    Команды.Колонки.Добавить("Использование");

    НоваяСтрока = Команды.Добавить();
    НоваяСтрока.Идентификатор = "ОткрытьФорму";
    НоваяСтрока.Представление = "Открыть форму";
    НоваяСтрока.Модификатор   = "";
    НоваяСтрока.ПоказыватьОповещение = Ложь;
    НоваяСтрока.Использование = "ОткрытиеФормы";

    НоваяСтрока = Команды.Добавить();
    НоваяСтрока.Идентификатор = "ВызовКлиентскогоМетода";
    НоваяСтрока.Представление = "Вызов клиентского метода";
    НоваяСтрока.Модификатор   = "";
    НоваяСтрока.ПоказыватьОповещение = Ложь;
    НоваяСтрока.Использование = "ВызовКлиентскогоМетода";

    НоваяСтрока = Команды.Добавить();
    НоваяСтрока.Идентификатор = "ВызовСерверногоМетода";
    НоваяСтрока.Представление = "Вызов серверного метода";
    НоваяСтрока.Модификатор   = "";
    НоваяСтрока.ПоказыватьОповещение = Истина;
    НоваяСтрока.Использование = "ВызовСерверногоМетода";

    Структура.Вставить("Команды", Команды);

    Назначение = Новый Массив;
    Назначение.Добавить("Документ.ЗаказКлиента");

    Структура.Вставить("Назначение", Назначение);

    Возврат Структура;

КонецФункции

P.S. Обработки по заполнению табличных частей отчасти потеряли смысл, ибо работают не с объектом, а со ссылкой

Скачать файлы

Наименование Файл Версия Размер
ШаблонВнешнейОбработки.epf
.epf 6,30Kb
07.10.10
208
.epf 6,30Kb 208 Скачать

См. также

Комментарии
1. ПСВ (ПСВ) 113 07.10.10 12:46 Сейчас в теме
а пользовать серверный вызов видимо так:

Процедура ВыполнитьКоманду(ИдентификаторКоманды, ОбъектыНазначения) Экспорт
	
	ДокСсылка = ОбъектыНазначения.Получить(0);
	ДокОбъект = ДокСсылка.ПолучитьОбъект();
	// например меняем комментарий
	ДокОбъект.Комментарий =""+ ТипЗнч(ДокСсылка);
	ДокОбъект.Записать();
	
КонецПроцедуры
...Показать Скрыть
2. Анатолий Ситников (acsent) 1030 07.10.10 12:50 Сейчас в теме
лучше так
Процедура ВыполнитьКоманду(ИдентификаторКоманды, ОбъектыНазначения) Экспорт

   Для каждого ДокСсылка Из ОбъектыНазначения Цикл

       ДокОбъект = ДокСсылка.ПолучитьОбъект();
      // например меняем комментарий
      ДокОбъект.Комментарий =""+ ТипЗнч(ДокСсылка);
      ДокОбъект.Записать();

   КонецЦикла;

КонецПроцедуры
...Показать Скрыть
3. Роман Мусий (ph_1984) 17 07.10.10 13:31 Сейчас в теме
Шаблон для создания дополнительных отчетов и обработок уже есть - смотрите демонстрационные обработки в Библиотеке стандартных подсистем 8.2.
4. Сергей Ожерельев (Поручик) 3592 07.10.10 17:41 Сейчас в теме
Правильней было бы: Шаблон внешней обработки для конфигураций платформы 8.2 с использованием БСП.
5. Анатолий Ситников (acsent) 1030 07.10.10 17:43 Сейчас в теме
Нет под рукой БСП, поэтому про БСП ни слова и не сказал
6. kharitonov (kharitonov@gmail.com) 11.01.11 04:27 Сейчас в теме
что делать если он "не хочет" пользовать серверный вызов ВыполнитьКоманду ?
7. Сергей Матюшкин (wilduser) 63 10.04.11 21:37 Сейчас в теме
Уже 2 часа туплю. Первый раз столкнулся с УТ11. Не могу понять как тут добавить дополнительный внешний отчет или доп. печатную форму?
Вычитал что в пользовательском режиме нельзя, только через конфигуратор. Подскажите как правильно это сделать, если например у меня есть готовая внешняя печатная форма товарного чека?
8. Сергей Матюшкин (wilduser) 63 10.04.11 21:50 Сейчас в теме
Точно тупил, уже разобрался
9. isn Игнатьев (isn) 13 12.08.11 11:36 Сейчас в теме
ph_1984 пишет:
смотрите демонстрационные обработки в Библиотеке стандартных подсистем 8.2

не мог бы кинуть ссылку. не могу найти
10. ushan ushan (ushan) 13.10.11 11:49 Сейчас в теме
(9) Ищи библиотеку на диске ИТС
11. Игорь Богданов (avz_1C) 10 13.06.12 02:10 Сейчас в теме
Коллеги, я не смог разобраться, точнее не получается найти информацию, как в УИ (например УТ-11) заменить печатную форму (например М-4) так, чтобы она вызывалась по стандартной кнопке, а не из подпункта "Дополнительные ..." группы "Печать"? Ведь в обычном интерфейсе, при регистрации внешней печатной формы, можно было указать заменяемую!
Помогите разобраться.
12. Анатолий Ситников (acsent) 1030 13.06.12 10:28 Сейчас в теме
Оставьте свое сообщение