Поиск и замена значений с отбором объекта

Обработки - Универсальные обработки

обработка группировка по объектам отбор по периоду замена значений

7
Доработана универсальная обработка "Поиск и замена значений" с группировкой по объекту и отбору документов по периоду.

Доработана универсальная обработка "Поиск и замена значений". Предназначена для поиска и замены ссылочных значений в различных объектах информационной базы "1С:Предприятия". В обработку добавил группировку по объектам информационной базы, а также при выборе периода отбирает документы по дате. Дорабатывалась для замены кода экономической классификации (КЭК) по определенным документам и определенный период.

Инструкция:

  • Заполняем список пар значений "Что заменять", "На что заменять";
  • Нажимаем "Найти объекты";
  • Выбираем объект данных и период (используется только для документов) . Если выбраны все объекты и период не заполнен, то обработка будет искать во всех объектах;
  • Нажимаем "Найти ссылки". Пройдет отбор по объектам и периоду;
  • Далее выбираем нужные ссылки и нажимаем "Выполнить замену значений".

В архиве три обработки: для Бухгалтерия государственного учреждения, редакция 1.0, для Бухгалтерия государственного учреждения, редакция 2.0., плюс добавил для Бухгалтерия государственного учреждения, редакция 1.0 обработку по отбору КФО (часто просили выслать на электронную почту).

Тестировалась на Бухгалтерия государственного учреждения, редакция 2.0 (2.0.52.45), Бухгалтерия государственного учреждения, редакция 1.0 (1.0.50.7), платформа 1С:Предприятие 8.3 (8.3.10.2561).

7

Скачать файлы

Наименование Файл Версия Размер
Внешняя обработка "Поиск и замена значений" по отбору объекта
.zip 61,11Kb
27.09.18
94
.zip 61,11Kb 94 Скачать

См. также

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. Agema 23.03.18 12:14 Сейчас в теме
Добрый день!
А в документах по казначейсству, ПКО и РКО учитывается нюанс с 17,18, НД счетами?
2. dendzu 15 23.03.18 14:10 Сейчас в теме
Добрый день!
Доработана универсальная обработка "Поиск и замена значений", поэтому все алгоритмы по замене я не трогал. Сделано только удобство по отбору по объектам и по периоду (только по документам).
3. Agema 24.03.18 16:30 Сейчас в теме
(2) ясно, спасибо!
Буду советовать всем. Очень будет нужна.
9. Kaniman 28.03.18 22:16 Сейчас в теме
(2) Единственное, что плохо, отбор в списке метаданных не влияет на список отобранных объектов в самом нижнем окне. Хотя автор и пишет, что замена идет только по отобранным объектам. Но это ненаглядно, нет доверия...
4. adeich 204 26.03.18 13:08 Сейчас в теме
5. dendzu 15 26.03.18 14:15 Сейчас в теме
Сейчас опять дали задачу по поиску и замене значений только теперь по отбору нулевого ИФО в документах и определённого Кода финансового обеспечения. Видимо действительно актуально.
6. Agema 26.03.18 23:59 Сейчас в теме
(5)
по отбору нулевого ИФО в документах

а это что значит или пустой?
7. dendzu 15 27.03.18 06:57 Сейчас в теме
Добрый день! Да пустой, извините, неправильно выразился.
8. Kaniman 28.03.18 22:15 Сейчас в теме
10. Kaniman 28.03.18 22:55 Сейчас в теме
Разобрался))
Прикрепленные файлы:
27272; dendzu; +2 Ответить
12. dendzu 15 29.03.18 07:21 Сейчас в теме
Добрый день!
Действительно не учел такой инструкции. Спасибо Вам!. Так как статья первая на будущее буду писать руководство пользования.
13. dendzu 15 29.03.18 09:26 Сейчас в теме
...руководство пользования в картинках
11. Kaniman 28.03.18 22:59 Сейчас в теме
В БГУ 2.0 находит КЭК даже в объектах "Реквизиты типовых операций" и "Значения дополнительных реквизитов операций"
Спасибо!!
14. Dgimdim 13.04.18 16:56 Сейчас в теме
В связи с переходом на Новые КЭК , обработка актуальна!!!
15. dendzu 15 13.04.18 20:54 Сейчас в теме
(14)Здравствуйте! Вы правы, уже несколько видоизмененных обработок сделал для нескольких организаций, то по нулевому ИФО, то поиск по списку ИФО, то определённого Кода финансового обеспечения.
17. Eleet 19.04.18 09:25 Сейчас в теме
(15)Если не сложно,можно получить вариант с отбором по КФО ?
18. dendzu 15 19.04.18 09:53 Сейчас в теме
(17) Постараюсь в течение этого дня. Эл. почту напишите?
19. Eleet 19.04.18 10:02 Сейчас в теме
(18)eleet_murmansk@mail.ru Спасибо большое!
16. Dgimdim 15.04.18 16:33 Сейчас в теме
Тип документа, КПС, КФО, ИФО!!! Без этого никак!!
21. Kaniman 19.04.18 21:23 Сейчас в теме
(16) да, приходится вручную перевыбирать после обработки.
22. Kapitan911 338 02.07.18 11:33 Сейчас в теме
Можно тоже с отбором по КФО?
Kapitan_911@mail.ru
23. dendzu 15 04.07.18 10:39 Сейчас в теме
Здравствуйте! Извините что поздно, был в отпуске. Отправил на электронную почту.
24. Agema 04.07.18 11:19 Сейчас в теме
(23) можно и мне на почту agema2010@mail.ru
Спаисбо!
25. dendzu 15 04.07.18 15:03 Сейчас в теме
(24)Здравствуйте! Отправил на электронную почту.
27. Tatiana_orel 06.07.18 08:30 Сейчас в теме
(25) kaznacheeva.t@yandex.ru будьте добры и мне скиньте с отбором по КФО.....Спасибо
28. dendzu 15 06.07.18 21:57 Сейчас в теме
(27)Здравствуйте! Извините за позднее сообщение. Также отправил на электронную почту.
26. Tatiana_orel 06.07.18 08:28 Сейчас в теме
(0) огромное спасибо....выручает!!!!
29. fktrc171 17.07.18 11:58 Сейчас в теме
А если у нас в базе много- много организаций , по еще бы и отбор по ним , а для начала можно и нам с отбором по КФО zadoroz1@ya.ru ?
30. dendzu 15 17.07.18 13:34 Сейчас в теме
(29)Здравствуйте! Действительно про несколько организации я не рассматривал вариант, на заметку взял, постараюсь доработать. С отбором по КФО уже есть в скачиваемом архиве.
31. mart1120 26.09.18 15:30 Сейчас в теме
Здравствуйте! А у нас не работает обработка с учетом КФО. Не находит никаких объектов. В чем может быть проблема?
32. dendzu 15 26.09.18 15:43 Сейчас в теме
(31)Здравствуйте! посмотрите в коде вот это условие:
//Дзю 26.03.2018 добавил условие
Если ИмяКолонки = "Баланс" Тогда
Для Каждого СтрокаТаблицаНабора Из ТаблицаНабора Цикл
Если СтрокаТаблицаНабора.КВД = КВД И СтрокаТаблицаНабора.Баланс = Справочники.Баланс.ПустаяСсылка() Тогда
НадоЗаписывать = Истина;
СтрокаТаблицаНабора.Баланс = ПравильныйЭлемент;
КонецЕсли;
КонецЦикла;
Иначе
СтрокаТабЧасти = ТаблицаНабора.Найти(Ссылка, ИмяКолонки);
Пока СтрокаТабЧасти <> Неопределено Цикл
СтрокаТабЧасти[ИмяКолонки] = ПравильныйЭлемент;
НадоЗаписывать = Истина;
СтрокаТабЧасти = ТаблицаНабора.Найти(Ссылка, ИмяКолонки);
КонецЦикла;
КонецЕсли;
//Дзю 26.03.2018
может оно мешает
33. dendzu 15 26.09.18 15:45 Сейчас в теме
Кому отправлял, и они тоже что - то подправлял под себя, возможно убирали этот код (код в модуле формы)
34. Agema 26.09.18 19:48 Сейчас в теме
(33) не помогло. Проверил на БГУ 1.0, версия 1.0.53.3
35. mart1120 27.09.18 09:15 Сейчас в теме
Я просто не программист. Можете ли подправить и выслать на почту данную обработку?
36. dendzu 15 27.09.18 11:31 Сейчас в теме
Здравствуйте! Постараюсь посмотреть..... Сейчас вот уже смотрю, да нашел ошибки в обработке по отбору по КФО, исправляю...
37. dendzu 15 27.09.18 13:02 Сейчас в теме
Исправил, проверил, выложил исправления.
38. Agema 27.09.18 21:07 Сейчас в теме
Можете повторить на почту agema2010@mail.ru
Спасибо!
39. mart1120 28.09.18 11:13 Сейчас в теме
Оставьте свое сообщение