[БП 3.0] Оборотно-сальдовый калькулятор

Обработки - Универсальные обработки

калькулятор расчет вычисление оборотка ОСВ оборотно сальдовая ведомость

8
Простой инструмент бухгалтерского анализа, вычисляющий математические выражения с остатками и оборотами за указанный период. Предназначен для автоматизации повторяющихся бухгалтерских вычислений и ускорения работы бухгалтеров.

Инструкция по использованию:
1) Нажать кнопку "Добавить элемент" - из элементов будет состоять вычисляемое выражение.
2) Выбрать тип элемента: Данные регистра(сальдо/оборот за период), Знак(арифметический символ) или Произвольное число.
3) Определить данные элемента:
    3.1) Для данных регистра указать:
        3.1.1) Начальное ли это сальдо либо конечное, либо оборот.
        3.1.2) Дт или Кт
        3.1.3) Счет
    3.2) Для знака выбрать собственно сам знак(доступные значения: (, ), +, -, *, / ).
    3.3) Для произвольного числа записать само число.
4) Повторяя пункты 1-3 составить выражение, которое требуется вычислить.
5) Нажать кнопку "Рассчитать".

Строка расчета:
    Это альтернативный вариант записи выражения: немного более сложный и уязвимый к опечаткам, зато гораздо более быстрый. Выражение можно ввести вручную в строке расчета - при этом данные регистра нужно выделять восклицательными знаками и шифровать следующим образом: первая буква - "Н" если начальное сальдо, "К" если конечное и "О" если оборот. Вторая "Д" если дебет и "К" если кредит. Потом код счета. Так, Дт-сальдо на конец периода по счету 60.02 будет записано как !КД60.02!.
    Записи созданием элементов и редактированием строки расчета можно совмещать.

Примеры записи:
    Расчет налога на прибыль: (!ОК90.01!+!ОК91.01!-!ОД44!-!ОД90.02!-!ОД20!-!ОД91.02!)*0.2 поправьте если ошибаюсь.

Шаблоны:
    Часто используемые выражения можно сохранять в информационной базе - для этого нажмите кнопку "Шаблоны" и в открывшемся меню нажмите "Сохранить текущий", после чего запишите название шаблона в колонке "Имя". Список шаблонов хранится отдельно для каждого пользователя информационной базы.

Версия конфигурации:
    Обработка тестировалась на конфигурации БП 3.0.55.16, но должна работать и на более ранних и на более поздних релизах. Проблемы возникнут только если в конфигурации отличается состав измерений/ресурсов бух.регистра "Хозрасчетный" и/или процедуры "ХранилищеОбщихНастроекСохранить" и "ХранилищеОбщихНастроекЗагрузить" модуля "ОбщегоНазначения", что видится мне маловероятным.

upd(31.07.2018): Добавил кнопку "Рассчитать с расшифровкой", которая выдает последовательность вычислений с промежуточными результатами на каждом этапе.

8

Скачать файлы

Наименование Файл Версия Размер
Оборотно-сальдовый калькулятор:
.epf 17,82Kb
03.04.18
3
.epf 17,82Kb 3 Скачать

См. также

Комментарии
Избранное Подписка Сортировка: Древо
1. МимохожийОднако 120 04.04.18 07:41 Сейчас в теме
Напомнило язык выражений 1С: Бухгалтерии 6.0 и предыдущих DOS-версий
Например, такой фрагмент из отчета
[СКД50.1+СКД51+СКД52.1+СКД56]
fav@2ncom.ru; +1 Ответить
2. корум 311 04.04.18 10:39 Сейчас в теме
(1) Выражения 1с 6.0 сразу вызывают ассоциацию

Мы обращались в фирму 1С с предложением ввести в язык (речь идет о версии 6.0) следующие конструкции :
ПОЧЕМУ БЫ И НЕ — проверяет условие еще раз (самый частый глюк старой 1С)
НЕПРЕМЕННО — выполняет оператор без сбоев и зависаний
ОТНЫНЕ — присваивает значение переменной так, чтобы оно там действительно оказалось. (присвоить переменной вида, к примеру, «Справочник» значение в языке 1С — порой очень непростая задача, иногда требующая конструкции аж из 4-х операций)
ВО ЧТО БЫ ТО НИ СТАЛО — выводит текст отчета который без этого оператора выводится через раз.
НЕ СПАТЬ — отключает внутренний глюкогенератор
Я СКАЗАЛ — выполняет команду до тех пор, пока она не выполнится.
ИМЕТЬ СОВЕСТЬ — приостановить выполнение команды при её зависании.
Почему-то фирма не прислушалась к нашему мнению...
КонецЕсли; +1 Ответить
4. КонецЕсли 15 04.04.18 12:08 Сейчас в теме
(1) Я подумывал о квадратных скобках, но восклицательные знаки удобно вводить независимо от раскладки
5. fav@2ncom.ru 23.06.18 12:17 Сейчас в теме
Полезный бухгалтерский калькулятор! Скачал.
Думаю, практически все бухгалтеры именно так и оценивают (прикидывают) правильность сформированной квартальной отчетности.
Попробуем предложить нашим клиентам!
В 1С 6.0 это было удобно !
6. fav@2ncom.ru 01.07.18 21:10 Сейчас в теме
Не хватает расшифровки результата,
т.е. чтобы был виден результат каждого выражения (запроса) входящего в общую формулу.
Например, как в файле.
Прикрепленные файлы:
Таблица к оборотно-сальдовый калькулятору.xls
КонецЕсли; +1 Ответить
7. КонецЕсли 15 31.07.18 13:46 Сейчас в теме
(6) Пришлось немало повозиться с порядком вычислений(умножение, деление, выражения в скобках...), но все-таки добавил расшифровку; ссылку на обновленную версию скинул в личку.
Оставьте свое сообщение