INFOSTART EVENT 2018 EDUCATION

Второй тур голосования за доклады.
Окончание 5 сентября.

Александрович Андрей | Генеральный директор | ALEXROVICH

«Визуализация бизнес-показателей из 1С на TV-панели»

• Что может быть лучше отчетов и графиков 1С:Предприятие 8? • Какие бизнес-показатели нужно визуализировать и зачем? • Как за 30 минут сделать TV-панель с ключевыми цифрами из 1С для собственника компании? • Создание TV-панели на примере показателей отдела продаж. • Повышение выполнения планов продаж на +10% за счет контроля активности менеджеров используя TV-панель. • В чем отличие BI-систем (систем бизнес-аналитики) от дашбордов (панелей визуализации данных)? • TV-панель с показателями работы сотрудников как инструмент контроля и повышения эффективности компании.

Поиск по ИНН на сайте Федресурс

Обработки - Обработка справочников

0
Осуществляет поиск данных контрагента с помощью сайта fedresurs.ru. Обычные формы.

Еще один опус на тему загрузки данных контрагента в карточку по ИНН. Используются данные портала fedresurs.ru. 

Немного колхозно, но по сути тут представлен основной механизм, для встраивания в конфигурацию по своему желанию и по своей необходимости. 

У меня к конфигурации это "прибито гвоздями" вот таким способом:

В кнопке генерации кпп по инн добавлен код:

Если ЗначениеЗаполнено(ИНН) Тогда
        ОбработкаОбъект = Обработки.ПоискПоИнн.Создать();
        ОбработкаОбъект.ИНН = ИНН;
        ОбработкаОбъект.ПолучитьИнформациюПоИНН();
        ОбработкаОбъект.ПолучитьФорму("Форма", ЭтаФорма).Открыть();
КонецЕсли;

В конфигурацию, в дерево метаданных, добавлена обработка у которой есть самый главный метод ПолучитьИнформациюПоИНН();. Перед запуском метода в обработке этот самый ИНН надо заполнить.

Обратно в карточку контрагента это добро возвращается структурой через обработку оповещения.

Из обработки:

СтруктураВыбора = Новый Структура;
    СтруктураВыбора.Вставить("Команда",                 "ПоискПоИНН");
    СтруктураВыбора.Вставить("ИНН",                     ИНН);
    СтруктураВыбора.Вставить("КПП",                     КПП);
    СтруктураВыбора.Вставить("НаименованиеПолное",      НаименованиеПолное);
    СтруктураВыбора.Вставить("НаименованиеСокращенное", НаименованиеСокращенное);
    СтруктураВыбора.Вставить("ОГРН",                    ОГРН);
    СтруктураВыбора.Вставить("Отрасль",                 Отрасль);
    СтруктураВыбора.Вставить("Регион",                  Регион);
    СтруктураВыбора.Вставить("Статус",                  Статус);
    СтруктураВыбора.Вставить("ДолжностьДиректора",      ДолжностьДиректора);
    СтруктураВыбора.Вставить("ФИОДиректора",            ФИОДиректора);
    СтруктураВыбора.Вставить("ЮрАдрес",                 ЮрАдрес);
    СтруктураВыбора.Вставить("ФактАдрес",               ФактАдрес);
    
    ОповеститьОВыборе(СтруктураВыбора);


В форме элемента справочника "Контрагенты" :

Процедура ОбработкаВыбора(ЗначениеВыбора, Источник)

    //Типовой код .......

    ИначеЕсли ТипЗнч(ЗначениеВыбора) = Тип("Структура") Тогда
        Команда = "";
        Адрес = "";
        Если ЗначениеВыбора.Свойство("Команда", Команда) и Команда = "ПоискПоИНН" Тогда

          //Тут собственно ваш код загрузки в карточку

        КонецЕсли;

КонецЕсли;

КонецПроцедуры;

Поставляется в большей мере как механизм, из которого вы можете самостоятельно, с минимальными усилиями,  вылепить именно то, что вам требуется.

Тестировалось на УПП 1.3, но если нужно только показать форму с данными о контрагенте, тогда взлетит на любой конфигурации с обычными формами. Главное заполнить поле ИНН и нажать кнопку Обновить.

Часть кода взята отсюда, спасибо Автору

Премного благодарен автору

0

Скачать файлы

Наименование Файл Версия Размер
Поиск по ИНН Федресурс:
.epf 12,71Kb
15.05.18
12
.epf 1 12,71Kb 12 Скачать

См. также

Сортировка: Древо
В этой теме еще нет сообщений.
Оставьте свое сообщение