Поиск по ИНН, переработана под другой сайт

Обработки - Обработка справочников

Обработка Поиск по ИНН обычные формы ут10.3 упп1.3 БП2.0

0
Осуществляет поиск данных контрагента по инн, находит кпп, окпо, прочую информацию (смотри скриншот) Обычные формы. Для встройки требуется программист

Переделано, поправлено, опять работает. Минимальная интеграция.

Немного колхозно, но по сути тут представлен основной механизм, для встраивания в конфигурацию по своему желанию и по своей необходимости. 

У меня к конфигурации это "прибито гвоздями" вот таким способом:

В кнопке генерации кпп по инн добавлен код:

Если ЗначениеЗаполнено(ИНН) Тогда
        ОбработкаОбъект = Обработки.ПоискПоИнн.Создать();
        ОбработкаОбъект.ИНН = ИНН;
        ОбработкаОбъект.ПолучитьИнформациюПоИНН();
        ОбработкаОбъект.ПолучитьФорму("Форма", ЭтаФорма).Открыть();
КонецЕсли;

В конфигурацию, в дерево метаданных, добавлена обработка у которой есть самый главный метод ПолучитьИнформациюПоИНН();. Перед запуском метода в обработке этот самый ИНН надо заполнить.

Обратно в карточку контрагента это добро возвращается структурой через обработку оповещения.

Из обработки:

СтруктураВыбора = Новый Структура;
    СтруктураВыбора.Вставить("Команда",                 "ПоискПоИНН");
    СтруктураВыбора.Вставить("ИНН",                     ИНН);
    СтруктураВыбора.Вставить("КПП",                     КПП);
    СтруктураВыбора.Вставить("НаименованиеПолное",      НаименованиеПолное);
    СтруктураВыбора.Вставить("НаименованиеСокращенное", НаименованиеСокращенное);
    СтруктураВыбора.Вставить("ОГРН",                    ОГРН);
    СтруктураВыбора.Вставить("ОКВЭД",                   ОКВЭД);
    СтруктураВыбора.Вставить("Регион",                  Регион);
    СтруктураВыбора.Вставить("ЮрАдрес",                 ЮрАдрес);
    СтруктураВыбора.Вставить("ОКПО",                    ОКПО);
    
    ОповеститьОВыборе(СтруктураВыбора);


В форме элемента справочника "Контрагенты" :

Процедура ОбработкаВыбора(ЗначениеВыбора, Источник)

    //Типовой код .......

    ИначеЕсли ТипЗнч(ЗначениеВыбора) = Тип("Структура") Тогда
        Команда = "";
        Адрес = "";
        Если ЗначениеВыбора.Свойство("Команда", Команда) и Команда = "ПоискПоИНН" Тогда

          //Тут собственно ваш код загрузки в карточку

        КонецЕсли;

КонецЕсли;

КонецПроцедуры;

Поставляется в большей мере как механизм, из которого вы можете самостоятельно, с минимальными усилиями,  вылепить именно то, что вам требуется.

Тестировалось на УПП 1.3, для ут без изменений. Для бп 2.0 названия модулей немного другие, поэтому точное название модуля можно определить по имени метода. В остальном все осталось как прежде: главное заполнить поле ИНН и нажать кнопку Обновить.

Часть кода взята отсюда, спасибо Автору

И еще от кучи авторов с инфостарт, но за древностью лет уже не упомню кто это был. Спасибо добрые люди.

Премного благодарен автору

0

Скачать файлы

Наименование Файл Версия Размер
Поиск по ИНН
.epf 12,34Kb
05.10.18
0
.epf 1.3 12,34Kb Скачать

См. также

Комментарии
Избранное Подписка Сортировка: Древо
1. xraf 6 22.09.18 22:39 Сейчас в теме
Можно узнать, обработка еще работает?
2. vx_gas 18 27.09.18 03:53 Сейчас в теме
2 недели назад лавку прикрыли, не смотрю на сложности, ищу возможности...
3. vx_gas 18 27.09.18 03:54 Сейчас в теме
Когда решу задачу выложу обновления
4. vx_gas 18 05.10.18 04:52 Сейчас в теме
Оставьте свое сообщение