Обработка печати фискального регистратора MG N707TS по http (TCP/IP) протоколу JSON, +фильтры. Обычные формы

Публикация № 840642 01.06.18

Учет и отчетность - Кассовые операции

MG N707TS торговое оборудование фискальный регистратор

Пришлось подключать данный регистратор к точке с довольно интенсивным клиентопотоком. В стандартных обработках обнаружен ряд моментов, через которые регистратор мог отказать в печати чека, проигнорировать строку или просто зависнуть. Доработано: - Удаление перед отправкой по http всех неподдерживаемых символов протоколом JSON - Обязательная проверка результата успешной/неуспешной печати от РРО - Возможность печати Z Отчет По Товарам - Правильная печать чеков возврата - Код товара в памяти РРО соответсвует коду товара в 1С (избегаем ошибку продажи одного товара а печати другого)

Пришлось подключать данный регистратор к точке с довольно интенсивным клиентопотоком. В стандартных обработках обнаружен ряд моментов, через которые регистратор мог отказать в печати чека, проигнорировать строку или просто зависнуть.
В создании данной обработки благодарен ребятам из поста 376254

Работает на платформе 1С не ниже 8.3.7

Конфигурации: Розница 1.0, Управление торговлей для Украины 2.0 (обычные формы)

Основной функционал:

  • - Удаление перед отправкой по http всех неподдерживаемых символов протоколом JSON

  • - Обязательная проверка результата успешной/неуспешной печати от РРО

  • - Возможность печати Z Отчет По Товарам

  • - Правильная печать чеков возврата

  • - Код товара в памяти РРО соответсвует коду товара в 1С (избегаем ошибку продажи одного товара а печати другого)

  • - Через структуру "СтруктураДопРеквизитов" в параметр "ЭтоПодакцизныйТовар" можем передавать признак акцизного товара и соответсвенно печатать акцизную ставку налога.

  • -Закомментирована функция "Вывод" в процедуре "ПечататьСтроку", существенно ускоряет процесс печати чека, выводит на экран только итоговую информацию о чеке без построчного вывода.

Особенности установки:

Для того, чтобы передать в обработку параметры Кода товара, признак акциза необходимо доработать обработку конфигурации "ТОСервер".

Процедура "ПечатьЧека". У меня имеет следующий вид:

Функция ПечатьЧека(Идентификатор, НомерЧека, НомерСмены,
                   ОписаниеЧека, СуммаНал, СуммаБезнал, ПризнакВозврата) Экспорт

	Обработка = Неопределено;
	Объект    = Неопределено;
	Результат = ПолучитьОбъектДрайвера(Идентификатор, Обработка, Объект);
	
	/// +
	СтруктураДопРеквизитов = Новый Структура("ЭтоПодакцизныйТовар, Код");
	/// -
	
	// Проверим использование кода
	фИспользоватьКод = Объект.Параметры.Свойство("ИспользоватьКод");

	Если НЕ ЗначениеЗаполнено(Результат) Тогда
		Результат = Обработка.ОткрытьЧек(Объект, "", ПризнакВозврата, НомерЧека, НомерСмены, Истина);
		Если НЕ ЗначениеЗаполнено(Результат) Тогда
			Позиция = Неопределено;
			Для Каждого Позиция Из ОписаниеЧека Цикл
				ЗначениеСкидки = Позиция.Количество * Позиция.Цена * Позиция.Скидка * 0.01;
				СуммаСоСкидкой1С = Окр(Позиция.Количество * Позиция.Цена - ЗначениеСкидки, 2);
				СуммаСоСкидкойФР = Окр(Позиция.Количество * Позиция.Цена - Окр(ЗначениеСкидки, 2), 2);

				Объект.Параметры.Вставить("Весовой", Позиция.Весовой);
				/// +
				Объект.Параметры.Вставить("Код", Позиция.Код);
				СтруктураДопРеквизитов.ЭтоПодакцизныйТовар = Позиция.ЭтоПодакцизныйТовар;
				/// -
				
				СтруктураДопРеквизитов.СтавкаНДССтрокой = Позиция.СтавкаНДССтрокой;
					СтруктураДопРеквизитов.ЭтоПодакцизныйТовар = Позиция.ЭтоПодакцизныйТовар;
					СтруктураДопРеквизитов.Код = Позиция.Код;
				
				Если СуммаСоСкидкой1С = СуммаСоСкидкойФР Тогда
					 текКоличество = Позиция.Количество;
					 текЦена = Позиция.Цена;
					 текСкидка = Позиция.Скидка;
				Иначе
					 текКоличество = 1;
					 текЦена = СуммаСоСкидкой1С;
					 текСкидка = 0;
				КонецЕсли;

				Если фИспользоватьКод Тогда
					Результат = Обработка.ПечататьСтроку(Объект,
													 Позиция.Наименование,
													 текКоличество,
													 текЦена,
													 текСкидка,
													 Позиция.НомерСекции,
													 Позиция.СтавкаНДС, 
													 Позиция.Код);
				Иначе
					Результат = Обработка.ПечататьСтроку(Объект,
													 Позиция.Наименование,
													 Позиция.Количество,
													 Позиция.Цена,
													 Позиция.Скидка,
													 Позиция.НомерСекции,
													 Позиция.СтавкаНДС);
				КонецЕсли; 
				
				Если ЗначениеЗаполнено(Результат) Тогда
					Прервать;
				КонецЕсли;
			КонецЦикла;

			Если НЕ ЗначениеЗаполнено(Результат) Тогда
				Результат = Обработка.ЗакрытьЧек(Объект, СуммаНал, СуммаБезнал);
			КонецЕсли;
		КонецЕсли;
		
		мОписаниеОшибки = Объект.ОписаниеОшибки;
	Иначе
		мОписаниеОшибки = ПолучитьТекстОшибкиПодключенияТО("ФР");
	КонецЕсли;

	Возврат Результат;

КонецФункции // ПечатьЧека()

Передаете в обработку или в виде Объект.Параметры, или СтруктураДопРеквизитов код товара. Код товара должен содержать только цифры, без буквенных значений. Данный код будет записываться в качестве кода товара в память РРО.

С помощью параметра ЭтоПодакцизныйТовар, можно управлять формированием отдельной налоговой ставки для подакцизных товаров. Для этого сделайте X-отчет на РРО, проверьте на какой ставке Центр сервисного обслуживания установил налоговые ставки для подакцизных товаров и пропишите их в процедуре "ПечататьСтроку" самой обработки.

	// Расчет акциза
	Если СтруктураДопРеквизитов <> Неопределено Тогда
		Попытка
			Если СтруктураДопРеквизитов.ЭтоПодакцизныйТовар = Истина Тогда
			НалоговаяГруппа = 2; // ставка Б		
			КонецЕсли;	
		Исключение
		КонецПопытки;
	КонецЕсли;

 

Скачать файлы

Наименование Файл Версия Размер
Обработка печати фискального регистратора MG N707TS по http (TCP/IP) протоколу JSON, +фильтры. Обычные формы:

.epf 28,46Kb
0
.epf 28,46Kb Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. пользователь 02.06.18 06:16
Сообщение было скрыто модератором.
...
2. пользователь 02.06.18 17:32
Сообщение было скрыто модератором.
...
3. пользователь 02.06.18 17:59
Сообщение было скрыто модератором.
...
4. hadjieff 21.01.20 16:31 Сейчас в теме
5. vovkpro 29.02.20 22:23 Сейчас в теме
Добрый день. У меня на счету нет 2 стартмани. Мне нужна эта обработка, потому что по стандартной чек на возврат (при возврате с оплатой банк картой (эквайринг)) не выходит из ФР и в Х отчете нет возврата хотя в 1С он проводится и при открытии есть сообщение: Чек пробит. Как я могу получить эту обработку? Спасибо. 1С УТП для Украины.
6. otanais 02.03.20 13:05 Сейчас в теме
Добрый день! Аналогично предыдущему комментарию. Стартмани нет, а обработка нужна. Со стандартной обработкой (MG-http-v2.epf) другая проблема - при печати чека по какой-то причине некоторые цены пересчитываются и в чеке появляется скидка/наценка. В логах видно, что передается цена, отличная от переданной. Как я могу получить эту обработку? Спасибо. 1С УТП для Украины
7. vovkpro 02.03.20 17:35 Сейчас в теме
Добрый день. Кто нибудь тестировал данную обработку на Управление торговым предприятием для Украины?
8. vovkpro 02.03.20 18:28 Сейчас в теме
В Управление торговым предприятием для Украины при пробытии чека появляется ошибка в Функции Печататьстроку(.....) в строке Код = Объект.Параметры.НоменклатураСсылка.Код По причине нет реквизита (или параметра) НоменклатураСсылка. При проведении возврата при оплате банк картой(эквайринг) (не знаю как при других видах оплаты) ошибка возможны расхождения .... чек не выходит
9. michael2006 1 03.03.20 10:56 Сейчас в теме
(8) Сейчас уточню про ошибку в обработке. Возможно для контроля кодировки товаров в Сервере ТО доделан функционал передачи в обработку ссылки на Номенклатуру. Я ставил много таких РРО, Код товара желательно задавать из 1С в память РРО не не давать РРО самостоятельно нумеровать товары в рамках открытой смены. Иначе может возникнуть ситуация когда вы продаете один товар а в чеке печатается совершенно другой.
10. michael2006 1 03.03.20 13:00 Сейчас в теме
(8) Добавил коментарий в пост. Необходимо доработать ТОСервер для передачи в обработку печати кода товара. РРО должен получить код товара для записи в память.
11. vovkpro 03.03.20 16:09 Сейчас в теме
Вот Процедура ПечатьЧека из моей 1с УТП для Украины 1.2.56.2
как я понял мне надо добавить строки с комментариями /// + ..... /// -
Прикрепляю обработку СерверТО
надежда только на Вас.
Три дня как поставили ФР
Пробовал другие обработки.
Из Последних ошибок При пробытии чека с типом оплаты Эквайринг Ошибка точно не помню примерно Невозможно дать сдачу.... Хотя до этого 15 таких чеков пробилось без проблем...
Спасибо.

Функция ПечатьЧека(Идентификатор, Пароль, НомерЧека, НомерСмены,
                ОписаниеЧека, СуммаНал, СуммаБезнал, ПризнакВозврата) Экспорт

	Обработка = Неопределено;
	Объект    = Неопределено;
	СтруктураДопРеквизитов = Новый Структура("СтавкаНДССтрокой, ЭтоПодакцизныйТовар");
	Результат = ПолучитьОбъектДрайвера(Идентификатор, Обработка, Объект);
	
	Если Результат = мОшибкаНеизвестно Тогда
		Возврат Результат;
	КонецЕсли;	

	// Проверим использование кода
	фИспользоватьКод = Объект.Параметры.Свойство("ИспользоватьКод");
	
	Если НЕ ЗначениеЗаполнено(Результат) Тогда
		Результат = Обработка.ОткрытьЧек(Объект, Пароль, ПризнакВозврата, НомерЧека, НомерСмены, Истина);
		ЭтоНоваяВерсия = (ПолучитьВерсиюAPIОбработкиОбслуживания(Обработка) >= 2.9);
		Если НЕ ЗначениеЗаполнено(Результат) Тогда
			Позиция = Неопределено;
			Для Каждого Позиция Из ОписаниеЧека Цикл
				
				Если ЭтоНоваяВерсия Тогда
					
					СтруктураДопРеквизитов.СтавкаНДССтрокой = Позиция.СтавкаНДССтрокой;
					СтруктураДопРеквизитов.ЭтоПодакцизныйТовар = Позиция.ЭтоПодакцизныйТовар;
					
					Результат = Обработка.ПечататьСтроку(Объект,
													 Позиция.Наименование,
													 Позиция.Количество,
													 Позиция.Цена,
													 Позиция.Скидка,
													 Позиция.НомерСекции,
													 Позиция.СтавкаНДС,
													 СтруктураДопРеквизитов);
					
				Иначе
					ЗначениеСкидки = Позиция.Количество * Позиция.Цена * Позиция.Скидка * 0.01;
					СуммаСоСкидкой1С = Окр(Позиция.Количество * Позиция.Цена - ЗначениеСкидки, 2);
					СуммаСоСкидкойФР = Окр(Позиция.Количество * Позиция.Цена - Окр(ЗначениеСкидки, 2), 2);

					Если СуммаСоСкидкой1С = СуммаСоСкидкойФР Тогда
						Если фИспользоватьКод Тогда
							Результат = Обработка.ПечататьСтроку(Объект,
														 Позиция.Наименование,
														 Позиция.Количество,
														 Позиция.Цена,
														 Позиция.Скидка,
														 Позиция.НомерСекции,
														 Позиция.СтавкаНДС,
														 Позиция.Код);
						Иначе
							Результат = Обработка.ПечататьСтроку(Объект,
														 Позиция.Наименование,
														 Позиция.Количество,
														 Позиция.Цена,
														 Позиция.Скидка,
														 Позиция.НомерСекции,
														 Позиция.СтавкаНДС);
						КонецЕсли;
					Иначе
						Если фИспользоватьКод Тогда
							Результат = Обработка.ПечататьСтроку(Объект,
													   Позиция.Наименование,
													   1,
													   СуммаСоСкидкой1С,
													   0,
													   Позиция.НомерСекции,
													   Позиция.СтавкаНДС,
													   Позиция.Код);

						Иначе
							Результат = Обработка.ПечататьСтроку(Объект,
													   Позиция.Наименование,
													   1,
													   СуммаСоСкидкой1С,
													   0,
													   Позиция.НомерСекции,
													   Позиция.СтавкаНДС);
						КонецЕсли;
					КонецЕсли;
				
				КонецЕсли;

				Если ЗначениеЗаполнено(Результат) Тогда
					Прервать;
				КонецЕсли;
			КонецЦикла;

			Если НЕ ЗначениеЗаполнено(Результат) Тогда
				Результат = Обработка.ЗакрытьЧек(Объект, СуммаНал, СуммаБезнал);
			КонецЕсли;
		КонецЕсли;

		мОписаниеОшибки = Объект.ОписаниеОшибки;
	Иначе
		мОписаниеОшибки = ПолучитьТекстОшибкиПодключенияТО("ФР");
	КонецЕсли;

	Возврат Результат;

КонецФункции // ПечатьЧека()
Показать
Прикрепленные файлы:
ТОСервер.epf
12. michael2006 1 03.03.20 18:10 Сейчас в теме
(11)
ошибок

Разберемся, поможем. смотрю обработку вашу.
13. vovkpro 04.03.20 11:21 Сейчас в теме
У меня к этой 1с подключен еще 1 ФР Мини ФП 6. С ним проблем нет. Если исправим обработку ТОСервер на его работе это не скажется? Спасибо.
14. michael2006 1 04.03.20 14:56 Сейчас в теме
(13) Добрый день. Не скажется. Дописано так, что добавляются только доп параметры. У нас также к одной конфигурации подключен зоопарк разных РРО.
15. vovkpro 04.03.20 15:05 Сейчас в теме
Извините я не совсем понял. Что мне надо сейчас сделать чтобы ФР нормально заработал?
16. vovkpro 04.03.20 15:51 Сейчас в теме
Мне надо в своей конфигурации в обработке ТОСервер заменить функцию ПечатьЧека(....) на ту что выше в публикации? И на ФР поставить отправленную мне на почту обработку?
17. michael2006 1 04.03.20 17:13 Сейчас в теме
(16) Верно. Вам надо только добавить пару строчек в функцию сервера ТО. Те, которые обрамлены ///+ и ///-
18. vovkpro 04.03.20 18:22 Сейчас в теме
Наверное придется мне снимать конфигурацию с обслуживания.... Но я готов на это только чтобы нормально работал ФР. Функция ПечатьЧека, которую Вы выложили выше, где обрамили знаками ///+ и ///- нужные мне изменения существенно отличается от функции ПечатьЧека из обработки ТОСервер моей конфигурации . Свою функцию я тоже выложил выше. Я хотел попросить Вас чтобы Вы показали на моей функции ПечатьЧека куда мне вставить нужные строки. Спасибо. Извините.
19. vovkpro 04.03.20 18:28 Сейчас в теме
Ок я увидел сообщение перезвоню
Оставьте свое сообщение

См. также

Групповое штрихкодирование номенклатуры (ERP 2.4, ERP 2.5, КА 2.4, УТ 11.4)

Обработка справочников Оптовая торговля Розничная торговля Учет ТМЦ v8 ERP2 УТ11 КА2 Россия УУ Абонемент ($m)

Внешняя обработка "Групповое штрихкодирование номенклатуры" для ERP 2.4, 2.5, КА 2.4, УТ 11.4 для быстроты присвоения штрихкодов номенклатуры.

2 стартмани

08.06.2021    5307    4    SergAl    10    

Отправка счетов в PayKeeper

Розничная торговля Оптовая торговля WEB v8 v8::БУ БП3.0 Бытовые услуги, сервис Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Россия БУ Абонемент ($m)

Расширение предназначено для отправки счетов в платежный сервис PayKeeper из типовой Бухгалтерии предприятия 3.0 (создавалось и тестировалось на релизе 3.0.88.32)

4 стартмани

20.04.2021    5329    4    Krasnyj    0    

Пакетное пробитие чеков на Онлайн-кассе при оплатах от физических лиц на расчетный счет Промо

Банковские операции Кассовые операции Обработка документов v8 v8::БУ БП3.0 Россия БУ Абонемент ($m)

Автоматизация процесса пробития чеков онлайн при поступлениях на расчетный счет от физических лиц. Помогает сократить трудозатраты таким организациям, как МФЦ, Управляющие компании и т.д. Подходит для 1С:Бухгалтерия 3.0 любой версии (базовая, ПРОФ, КОРП). Не изменяет конфигурацию. Конфигурация остается на поддержке (типовая).

2 стартмани

24.09.2019    22463    8    r.resh39    7    

Декларации по формам 7 и 8 алкогольной продукции, перенос данных из Декларант-Алко, импорт данных из файлов XML форм 11,12,7,8

Розничная торговля Регламентированная отчетность Обмен через XML v8 v8::УФ Розничная и сетевая торговля (FMCG) Рестораны, кафе и фаст-фуд Россия БУ Акцизы Абонемент ($m)

Конфигурация на управляемых формах, платформа 1С 8.3.10.2667 и выше, с помощью которой можно сформировать Декларации по формам 7 и 8 алкогольной продукции, выполнить перенос данных из ПО Декларант-Алко версии 4.31.05 и выше, импорт и загрузку из файлов XML форм 11,12,7,8. Есть возможность автоматического подписания и шифрации файла выгрузки.

1 стартмани

15.04.2021    7350    42    independ    39    

[Расширение] Временное отключение онлайн-эквайринга в РМК (УТ 11.4, Розница 2.3)

Розничная торговля Рабочее место Эквайринг v8 v8::ОУ УТ11 Розничная и сетевая торговля (FMCG) УУ Абонемент ($m)

Расширение предназначено для исправления исключительных ситуаций, когда оплата по эквайринговому терминалу с подключением оборудования прошла успешно, но чек на ККТ не был фискализирован. Расширение позволит временно отключить онлайн-эквайринг непосредственно из формы РМК.

1 стартмани

14.12.2020    9583    42    RocKeR_13    13    

K-SOFT. Эмулятор ККТ с передачей данных. Управляемые формы. ФФД 1.1 (Ревизия 3002)

Фискальный регистратор v8 ЗКБУ Розница УНФ БГУ ЗКГУ3.0 БП3.0 БАУ УТ11 УХ КА2 ЗУП3.x 1С:CRM Россия Абонемент ($m)

Эмулятор ККТ с передачей данных позволяет печатать чеки, а также выводить их на экран в программе 1С без необходимости физического подключения фискальных регистраторов. Представляет из себя расширение, которое подключается к конфигурациям фирмы 1С, со встроенной библиотекой подключаемого оборудования (БПО). Вместо расширения, при желании, функционал можно включить и в конфигурацию. Поддерживает маркировку и печать чека коррекции с учетом проданной номенклатуры.

5 стартмани

23.11.2020    13618    204    karpik666    66    

Обмен данными между УТ 10.3 и Розницей 2.2 (правила обмена данными между "Управлением торговлей" ред. 10.3. и "Розницей" ред. 2.2) Промо

Обмен через XML Перенос данных из 1C8 в 1C8 Оптовая торговля Розничная торговля Оптовая торговля Розничная торговля v8 УТ10 Розница УУ Абонемент ($m)

Данные правила предназначены для обмена в формате XML данных из программы «Управление торговлей» ред. 10.3. и "Розница" ред. 2.2 по основным группам документов и основных справочников. Загрузка данных осуществляется через встроенную обработку «Универсальный обмен данными XML». Основная цель обработки – корректировка типовых правил на выявленные ошибки и расширение выгрузки для корректной выгрузки данных по ЕГАИС и продажам в целом. Протестировано до УТ 10.3.47.х и Розница 2.2.11.х

3 стартмани

16.09.2016    56961    6    SEOAngels    65    

Генератор маршрута по "документам отгрузки" в Google.Maps

Оптовая торговля Розничная торговля WEB v8 v8::ОУ УТ11 Россия УУ Абонемент ($m)

Данная обработка будет полезна для построения маршрута по документам реализаций за выбранный период.

7 стартмани

08.11.2020    9231    14    quazare    20    

Продажи со склада поставщика WildBerries. Взаимодействие с АПИ из 1С

WEB Розничная торговля v8 УТ11 УУ Абонемент ($m)

Взялся я тут делать интеграцию с АПИ нового проекта Диких Ягод - Продажи со склада поставщика (ПССП). Это было нелегко. Никто же не читает инструкцию (уже аж 7 версии!), а зря! Для начала сделал получение списка товаров и обмен остатками.

5 стартмани

06.11.2020    28001    177    kiv1c    136    

Клиент API ГИС МТ (ИС МП) "Честный знак". Чтение данных и отправка документов. Работа на стороне сервера.

Розничная торговля WEB v8 1cv8.cf Россия Абонемент ($m)

Обращаемся в личный кабинет системы "Честный знак", ГИС МТ (ИС МП) за информацией о маркировке, товарах, документах и т.д. используя предоставляемый API. Отправляем собственный исходящий документ. Разбираемся с электронной подписью на клиенте и на сервере.

1 стартмани

26.10.2020    9445    68    elian    23    

Загрузка весового товара в весы Масса-К ВПМ-Ф (1С Предприятие, УТ 11.2-11.4 управляемые формы) Промо

Весы Розничная торговля Розничная торговля v8 v8::ОУ v8::УФ УТ10 Розничная и сетевая торговля (FMCG) Россия Абонемент ($m)

Данная обработка загружает весовой товар из базы в весы. Данная обработка тестировалась только на версии УТ 11.2-11.4 (1С Предприятие 8.3) и весах ВПМ-Ф.

2 стартмани

21.07.2016    24250    55    user594264_e.sitnik    5    

Маркировка обуви. Получение информации о документах и товаре в Честном знаке

Розничная торговля WEB v8 v8::УФ 1cv8.cf Розничная и сетевая торговля (FMCG) Россия УУ Абонемент ($m)

Обработка позволяет подключаться к Честному знаку, и получать оттуда информацию по документам или кодам идентификации.

2 стартмани

21.09.2020    5672    45    SpiRUS    0    

Загрузка из XML файла ЭДО в документ поступления для конфигураций 1С: Розница 2.2/2.3, Управление торговлей 10.3/11.4

Розничная торговля Обработка документов Документооборот и делопроизводство Обмен через XML v8 УТ10 Розница Розничная и сетевая торговля (FMCG) Россия УУ Абонемент ($m)

Внешние обработки загрузки данных из XML файлов формата ON_NSCHFDOPPRMARK ЭДО в документы поступления 1С Розница версия 2.2.10.19 и выше, Управление торговлей 10.3.52.2 и выше, Управление торговлей 11.4.5.63 и выше

1 стартмани

04.06.2020    26955    291    independ    130    

Примеры работы с API в Честный знак (обувь)

WEB Розничная торговля v8 1cv8.cf Розничная и сетевая торговля (FMCG) Россия Абонемент ($m)

К сожалению, документация API честного знака полна пробелов и неточностей. В данной статье описан мой опыт отгрузки маркированных товаров с одного юр. лица на другое.

1 стартмани

15.05.2020    25933    41    stas8359    54    

Аналоги номенклатуры для УТ 11.4, КА 2.4, ERP 2.4, Розница 2.2, Розница 8. Магазин автозапчастей. Расширение Промо

Рабочее место Оптовая торговля Розничная торговля Управление торговлей Оптовая торговля Розничная торговля v8 Розница ERP2 УТ11 КА2 Автомобили, автосервисы Оптовая торговля, дистрибуция, логистика Россия УУ Абонемент ($m)

Расширение для работы с аналогами номенклатуры. Отлично подходит для работы с кроссами запчастей и товаров с аналогичными свойствами. Поддерживаемые конфигурации: УТ 11.4, КА 2.4, ERP 2.4, Розница 2.2, Розница 8. Магазин автозапчастей. Лёгкое подключение, без изменения конфигурации.

1 стартмани

30.08.2019    30347    60    AleSSandre    34    

Кассовая программа "АрсКасса" на C# - без ограничений

Розничная торговля Кассовые операции Рабочее место v8 Розница Розничная и сетевая торговля (FMCG) Россия УУ Абонемент ($m)

Кассовая программа "АрсКасса" предназначена для автоматизации рабочего места кассира, без дополнительных затрат на покупку лицензий ПО.

1 стартмани

03.05.2020    10379    20    coolseo    9    

Отображение цен и остатков в списке номенклатуры и подборах "как в УТ 10.3" в УТ 11, КА 2, ERP 2 (расширение, платформа 8.3.12+)

Оптовая торговля Розничная торговля Ценообразование, анализ цен v8 ERP2 УТ11 КА2 УУ Абонемент ($m)

(©Топчий Д.Ю.) Посвящается Всем, кто привык к удобному отображению цен и остатков в конфигурации "Управление торговлей 10.3" в списке номенклатуры! Не требует модификации конфигурации, устанавливается как расширение! Выбранные виды цен сохраняются в рамках пользователя. Отображение идет в виде дерева по характеристикам. Работа проверена на конфигурациях УТ 11.4, КА 2, ERP2. (Обновление от 17.04.2020)

3 стартмани

31.03.2020    11375    83    hakerxp    19    

Маркировка в УТ 10.3.59.2: ошибки в релизе

Кассовые операции Розничная торговля v8 УТ10 Россия Абонемент ($m)

Вышел релиз УТ 10.3.59.2, в котором реализована поддержка маркировки обуви. Релиз содержит некоторое количество ошибок, не позволяющих использовать его при продаже обуви.

1 стартмани

28.02.2020    31494    4    Sholl    75    

Автоматическая рассылка прайс-листов Промо

Ценообразование, прайсы Email Оптовая торговля Розничная торговля Оптовая торговля Розничная торговля v8 УТ10 Абонемент ($m)

Устали от утомительной рассылки прайс-листов своим клиентам? Тогда эта обработка как раз для вас, она сделает полностью все сама! Сформирует прайс с нужными настройками и отправит его по электронной почте, как, куда и когда надо.

1 стартмани

24.03.2014    47888    24    skyadmin    20    

Готовые решения для инвентаризации товаров и основных средств на мобильных устройствах для КА, УТ, ERP и БП 3.0 на базе Simple UI

Оптовая торговля Розничная торговля Учет ОС и НМА Мобильная разработка Учет ТМЦ v8 ERP2 БП3.0 УТ11 КА2 БУ УУ Абонемент ($m)

В расширениях для Бухгалтерия 3.0 и КА2.4/УТ11.4/ERP2.4 представлены готовые рабочие места для онлайн и оффлайн инвентаризации товаров (для БП 3.0 также инвентаризации основных средств) на базе бесплатного конструктора мобильного фронта Simple UI. При этом используется расширенная работа с идентификацией товаров и ОС с помощью различных подходов – сканирование штрих кода, распознавание артикулов и инвентарных номеров и различные поиски. Также используются различные возможности платформы Simple UI. Данная разработка может быть полезна как конечным пользователям, так и разработчикам в качестве заготовки, так как на базе этих блоков можно сделать ввод любого документа конфигурации , связанного с товаром или с ОС. Тестировалось на 1С 8.3.13.1865, КА 2.4.8.63 и БП 3.0.74.69

5 стартмани

28.02.2020    14605    72    informa1555    73    

Выставление счета ссылкой на оплату через платежный шлюз Сбербанка из интерфейса 1С

Банковские операции Кассовые операции Оптовая торговля Розничная торговля v7.7 v8 1cv8.cf 1cv7.md Россия Абонемент ($m)

Внешняя обработка для выбора документа и формирования ссылки на оплату, которую можно скопировать в буфер обмена и отправить любыми средствами. Решение позволяет повысить автоматизацию процесса выставления счетов на оплату через интерфейс 1С8.х, 1С7.7. Совместимо с интернет-эквайрингом Сбербанк.

1 стартмани

14.01.2020    23698    120    etmarket    52    

Печать, создание XML и сохранение в базу 1С кодов маркировки

Пакетная печать Розничная торговля v8 1cv8.cf Абонемент ($m)

Внешняя обработка для печати кодов марок, полученных из системы "Честный знак".

1 стартмани

14.01.2020    37650    417    user635667    328    

Маркировка. Формирование и печать марок с CSV-файла "Честный Знак" и подготовка файла ввода в оборот

Розничная торговля v8 Розница УНФ УТ11 Розничная и сетевая торговля (FMCG) Россия Абонемент ($m)

Внешняя обработка для формирования и печати марок с кодом DataMatrix, на основании полученных CSV-файлов с кодами из системы "Честный знак". Формирование файла о вводе марок в оборот для загрузке на сайт системы "Честный знак"

3 стартмани

09.01.2020    45630    297    Turbokey    177    

Слипы вышли, а чек - нет!

Розничная торговля Расширения Кассовые операции v8 v8::УФ Розница Розничная и сетевая торговля (FMCG) Россия Абонемент ($m)

Флаг устанавливающий Эквайринговый терминал как эмулятор для пробития чеков по карте.

1 стартмани

14.11.2019    31445    79    obmanOZ    47    

Несколько касс ККМ в РМК Розница 2.3 с выбором кассы для каждой строки

Розничная торговля ККМ Рабочее место v8 Розница Розничная и сетевая торговля (FMCG) Россия Абонемент ($m)

Расширение позволяет подключить несколько касс ККМ к одному рабочему месту, по одной организации. Выбор кассы осуществляется на каждую строку товара. При добавлении позиции товара, автоматически выбирается касса по умолчанию. Определение кассы по умолчанию осуществляется в настройках пользователя. Расширение можно подключить в Рознице 2.3 версии ПРОФ.

3 стартмани

13.11.2019    18445    72    SerGray    121    

Расширение "Интерфейс Плюс" Промо

Розничная торговля Рабочее место Розничная торговля v8 v8::ОУ Розница УТ11 Россия УУ Абонемент ($m)

Расширение для 1С:Розница 2.2/2.3 и 1С:Управление Торговлей 11, которое позволит повысить удобство работы!

1 стартмани

22.09.2018    35712    175    RocKeR_13    136    

Выгрузка - загрузка на WildBerries из УНФ 1.6, УТ 11.4, УТ 10.3

Розничная торговля WEB Обмен через XML v8 УНФ БУ УУ Абонемент ($m)

Обработка выгружает накладную ЭДО для отправки на wildberries.ru в формате xml и загружает данные, выгруженные с сайта в формате xlsx. + печатные формы "Заказ для wildberries" и "Спецификация для wildberries"

1 стартмани

27.09.2019    20086    214    KVIKS    85    

Рекомендательный сервис на основе коллаборативной фильтрации на 1С. Расширение формы подбора для УТ 11.4

Оптовая торговля Розничная торговля Практика программирования Математика и алгоритмы v8 ERP2 УТ11 КА2 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Россия УУ Абонемент ($m)

В данной разработке реализован механизм рекомендаций товаров по принципу схожести товаров в корзине на основе алгоритма Item-to-Item от Amazon. Разобран алгоритм с демо базой и сделано расширение для УТ11.4 которое добавляет в форму подбора таблицу рекомендаций. Протестировано на 8.3.13.1865 на Управление торговлей, редакция 11 (11.4.8.63)

3 стартмани

25.09.2019    16799    14    informa1555    24    

Выгрузка номенклатуры в социальную сеть Вконтакте

WEB Оптовая торговля Розничная торговля Оптовая торговля Розничная торговля v8 1cv8.cf Абонемент ($m)

Обработка для быстрой и легкой выгрузки товаров Вконтакт. Так просто еще не было)))

2 стартмани

14.08.2019    22970    61    kaliuzhnyi    48    

Конструктор мобильного клиента Simple WMS Client: способ создать полноценный ТСД без мобильной разработки. Теперь новая версия - Simple UI (обновлено 14.11.2019) Промо

Инструментарий разработчика Сканер штрих-кода Терминал сбора данных Мобильная разработка Оптовая торговля Производство готовой продукции (работ, услуг) Розничная торговля Учет ОС и НМА Учет ТМЦ Оптовая торговля Производство готовой продукции (работ, услуг) Розничная торговля Учет ОС и НМА Учет ТМЦ v8 v8::Mobile БУ УУ Абонемент ($m)

Simple WMS Client – это визуальный конструктор мобильного клиента для терминала сбора данных(ТСД) или обычного телефона на Android. Приложение работает в онлайн режиме через интернет или WI-FI, постоянно общаясь с базой посредством http-запросов (вариант для 1С-клиента общается с 1С напрямую как обычный клиент). Можно создавать любые конфигурации мобильного клиента с помощью конструктора и обработчиков на языке 1С (НЕ мобильная платформа). Вся логика приложения и интеграции содержится в обработчиках на стороне 1С. Это очень простой способ создать и развернуть клиентскую часть для WMS системы или для любой другой конфигурации 1С (УТ, УПП, ERP, самописной) с минимумом программирования. Например, можно добавить в учетную систему адресное хранение, учет оборудования и любые другие задачи. Приложение умеет работать не только со штрих-кодами, но и с распознаванием голоса от Google. Это бесплатная и открытая система, не требующая обучения, с возможностью быстро получить результат.

5 стартмани

09.01.2019    61572    266    informa1555    234    

1С REST API клиент. Обмен из 1С с сайтом/магазином WordPress/WooCommerce с помощью REST API

Универсальные обработки WEB Универсальные функции Оптовая торговля Розничная торговля Оптовая торговля Розничная торговля v8 1cv8.cf УУ Абонемент ($m)

Обмен 1С с сайтом на WordPress и магазином Woocommerce. Внешняя обработка сделана как REST API клиент сайта WordPress, позволяет разработчику публиковать/изменять/удалять/просматривать посты/страницы/товары/фотографии (в связке с товаром/страницей) на сайте/магазине WordPress/Woocommerce. Обработки сделаны с использованием обычных форм, демо-формы использования в комплекте.

10 стартмани

29.07.2019    13914    15    osivv    15    

1С:Деньги - Автоматическое заполнение расходов по QR-кодам чеков с помощью API ФНС

Обработка документов WEB Банковские операции Кассовые операции Банковские операции Кассовые операции v8 1cv8.cf Домашние учет и финансы Россия УУ Абонемент ($m)

UPDATE 2020.11 Учтено новое API взаимодействия с серверами проверки чеков ФНС. Реализована верификация по номеру телефона и кода из SMS. Обработка поможет сократить время на ввод данных о расходах в 1С:Деньги. Достаточно отсканировать QR-код чека смартфоном, с предустановленным официальным приложением проверки чеков от ФНС. Данные чека будут загружены в базу из данных электронного чека, которые хранятся на серверах ФНС. Обработка протестирована на последнем релизе 2.0.40.12.

1 стартмани

28.07.2019    13014    54    1sig    29    

Печать покупателя в чеке ККМ с 01.07.2019

ККМ Кассовые операции Печатные формы документов Кассовые операции v8 ERP2 БУ Абонемент ($m)

C 01.07.2019 если организация/ИП покупает у другой организации/ИП товары, работы или услуги, то в Чеке ККМ требуется указать: Покупателя (тег 1227) и ИНН (тег 1228). Если чек отправляется в ОФД без этих данных, то будет штраф . Но в 1С ERP вывод данных полей не предусмотрен. Предлагаемое расширение устраняет данную проблему.

1 стартмани

17.07.2019    35361    24    sapervodichka    14    

Корректировка остатков ЕГАИС, возврат из регистра 2, загрузка ТТН из файлов, другое для УТ10.3 Промо

Розничная торговля Обработка документов Розничная торговля v8 v8::ОУ УТ10 Россия БУ Абонемент ($m)

Набор обработок для автоматизации работы с ЕГАИС: Обработка корректировки остатков ЕГАИС для УТ 10.3, аналогичная имеющимся в УТ 11, Рознице 2.2. Автоматически формирует документы "Передача в торговый зал", "Акт постановки на баланс в торговом зале", "Акт списания в торговом зале". Обработка возврата из регистра 2 с подбором справок Б. Обработка формирования ТТН из файлов xml.

1 стартмани

24.01.2018    45882    20    biz-intel    6    

[Расширение] для подключения мобильного устройства к УТ11.4/ КА 2/ERP 2 для работы с ордерным складом на базе Simple WMS. UPD Устарело (см. Simple UI)

Сканер штрих-кода Терминал сбора данных Мобильная разработка Управление торговлей Оптовая торговля Розничная торговля Учет ТМЦ Оптовая торговля Розничная торговля Учет ТМЦ v8 ERP2 УТ11 КА2 УУ Абонемент ($m)

Представляю готовое решение для работы с ордерами и проведения инвентаризаций в виде расширения на базе конструктора Simple WMS. Не требует доработки конфигурации, подключается как обычное расширение. Работать может с обычного телефона на Андроид либо с ТСД либо через RDP. Расширение содержит справочники, поэтому режим совместимости конфигурации должен быть не меньше 8.3.11. Расширение написано для конфигурации Управление торговлей 11.4.7 и тестировалось на Комплексная автоматизация 2.4.7.151.

5 стартмани

27.05.2019    19539    44    informa1555    39    

Расширение для 1С: Розница 2.2 - 2.3. В подборе и списке товаров - колонки Остаток, Цены розничная и закупочная, Сальдо. В документах команда Остатки и цены - для просмотра по списку товаров из документа

Обработка справочников Розничная торговля Розничная торговля v8 Розница Розничная и сетевая торговля (FMCG) УУ Абонемент ($m)

Расширение для 1С Розница 2.2 / Розница 2.3. В Подборе товаров и списке товаров добавлен вывод колонок Остаток на складах, Цена розничная, Цена Закупочная, Сальдо цен. В документе Отчет о розничных продажах, Оприходование, Списание, Установка цен - добавлена команда "Остатки и цены". Служит для анализа остатков и цен товаров, указанных в документе.

1 стартмани

09.03.2019    12373    123    cmax    59    

Обработки для 1С: Розница по работе с ЕГАИС

Розничная торговля Обработка документов Обработка справочников Розничная торговля v8 Розница Розничная и сетевая торговля (FMCG) Россия БУ Абонемент ($m)

Несколько простых и нужных обработок для упрощения работы с ЕГАИС в 1С Розница версий 2.2.10.ХХХ и выше.

1 стартмани

25.02.2019    25678    55    independ    15    

Выполнение проверки поступившей алкопродукции в ТТН ЕГАИС одним нажатием. 1С: Розница

Розничная торговля Обработка документов Розничная торговля v8 v8::УФ Розница Розничная и сетевая торговля (FMCG) Россия БУ Абонемент ($m)

Расширение и код для 1С: Розница 2.2.9/2.2.10/2.2.11 для быстрой проверки поступившего алкоголя ЕГАИС.

1 стартмани

05.02.2019    17630    12    independ    8    

1С: Розница/УТ 10.3. ЕГАИС, загрузка акцизных марок в справочник Штрихкоды и Упаковки, регистр Акцизные марки из XML-сообщений входящих ТТН ЕГАИС + Печать акцизных марок

Розничная торговля Обработка справочников Обмен через XML Ценники Розничная торговля v8 Розница Розничная и сетевая торговля (FMCG) Россия Абонемент ($m)

Пакетная загрузка/обновление списка акцизных марок ЕГАИС из входящих ТТН ЕГАИС. Для 1С Розница 2.2.9.ХХХ/2.2.10.ХХХ//2.2.11.ХХХ/2.2.12.ХХХ/Управление торговлей 10.3.49.ХХХХ и выше с возможностью печати

1 стартмани

31.01.2019    33879    222    independ    140    

API Яндекс.Кассы v4 и 1С

WEB Кассовые операции Кассовые операции v8 v8::ОУ УТ11 Россия Абонемент ($m)

Работа с api яндекс кассы v4.

1 стартмани

29.01.2019    18169    27    kickout    2    

Эмулятор ККМ по стандарту ФФД 1.1

Разработка внешних компонент Кассовые операции ККМ Кассовые операции v8 Розница УТ11 Россия Абонемент ($m)

Эмулятор драйвера ККМ по стандарту ФФД 1.1 предназначен для использования всех возможностей программы, при отсутствии физической кассы. Подойдет как программистам при разработке интерфейса РМК, например, так и пользователям для тестирования возможностей программы.

1 стартмани

30.12.2018    29359    160    Matveymc    31    

ККТ Атол: настраиваем работу по новому порядку. 54ФЗ, ФФД 1.05, НДС 20%. + Работа ККТ по сети или как работать c ККТ из терминального сервера RDP + Работа в LINUX

ККМ Кассовые операции Розничная торговля Кассовые операции Розничная торговля v8 УТ10 УПП1 Абонемент ($m)

Настройка ККТ АТОЛ для работы по сети. Обработка обслуживания ККТ для конфигураций на обычных формах. Тестировал на УПП 1.3.106.2, УТ10.3.47.3. Платформа 8.3.10.2753

1 стартмани

14.12.2018    86320    88    Johny_v    51