Автоматизация проверки на плагиат в ИС "Курсовые работы"

Публикация № 878398

Управление - Управленческий учет (прочее)

Основное приложение мобильное приложение веб сервис API post запросы.

Разработка обеспечивает коммуникацию между студентом и преподавателем во время выполнения курсовой работы, хранение всех курсовых работ и данных о них в единой информационной базе, а также проверку текстов работ на уникальность. Платформа 8.3.10.2639

Мы постоянно используем почтовые сервисы для обмена сообщениями, документами, файлами. Выполнение курсовой работы чаще всего затрагивает использование таких сервисов, но их использование не несет упорядоченности. У каждого наверняка уже есть множество аккаунтов электронной почты, социальных сетей, которые переполнены разного рода информацией, в которых легко упустить что-то важное. В том числе, на кафедре осуществляется хранение работ до некоторого срока, но какой либо специальной информационной базы для этого, как правило, не существует, необходимые документы легко могут быть утеряны.

Все это говорит о том, что образовательный процесс нуждается в своих специализированных программных инструментах. Так наличие соответствующего прикладного решения могло бы не только решить данные проблемы, но также предоставить новые функциональные возможности, упрощающие деятельность преподавателей и студентов. Именно разработке такого программного средства посвящена данная работа.

Благодаря широкой структуре объекта документа «Курсовая работа» в созданном программном средстве доступна вся необходимая функциональность по учету и мониторингу работ, а также проверке и хранению данных о них.

В работе предусматривается свой собственный механизм обмена сообщениями в разрезе курсовых работ прямо из используемых программ, что упрощает коммуникацию между студентом и преподавателем в процессе выполнения работы.

В больших потоках информации возникает необходимость обеспечить хранение отдельной информации с удобным доступом к ней. Программное средство реализует хранение и обмен файлами различных форматов, которые связаны с курсовыми работами. Файлы могут открываться непосредственно из приложений. Для проверки на плагиат используются текстовые документы в формате Microsoft Word.

Если для реферата уникальность не имеет принципиального значения, то курсовой проект это уже работа с претензией на научную значимость, и она должна иметь определенный процент уникальности. В работе реализована автоматизация проверки курсовых работ прямо с используемого приложения. В соответствии с логикой программного средства работы на проверку отправляет преподаватель, а результаты проверки доступны как преподавателю, так и студенту.

Накопленная информация не редко должна быть обработана и проанализирована, поэтому в программе представлены некоторые механизмы отчетности. В программном средстве присутствуют отчеты, которые могут быть использованы в интересах кафедры, такие как: отчет по задолженностям, отчет по состоянию курсовых работ в заданном периоде на кафедре, отчет по группе.

В моей разработке подразумевается, что преподаватель использует приложение на персональном компьютере, имеющее расширенный функционал, заключающийся в том, что преподаватель может создать (как объект системы) и назначить курсовую работу любому студенту, а также имеет доступ ко всем справочникам и документам, может их редактировать. Студент, в свою очередь, имеет преднамеренно ограниченный функционал на своем мобильном устройстве. Студент может отвечать на сообщения, прикреплять и получать файлы, смотреть за статусом своей работы, получать уведомления.

 Основным объектом конфигураций данных приложений является документ «Курсовая работа», который использует справочники для заполнения своих реквизитов и предоставляет все необходимые команды с ним связанные. Именно в объекте конфигурации «Курсовая работа» реализована автоматизация проверки на плагиат.

 Форма объекта «Курсовая работа» имеет три вкладки, первая из них «Документ», содержащая основные реквизиты. Вторая вкладка «Файлы» содержит список файлов, прикрепленных к курсовой работе, в том числе сам текстовый файл, который подвергается проверке на плагиат. По кнопке «Антиплагиат» отправляем текст работы на проверку, а по кнопке «Результат проверки» получаем результаты проверки, на основании которых автоматически формируется содержимое вкладки «Уникальность».

 Для проверки на плагиат используется API сайта text.ru, который предоставляет услуги по созданию и соблюдению уникального контента. Взаимодействие с API происходит в два этапа. На первом этапе отправляем текст и пользовательский ключ посредством POST запроса на сервер сайта, на что в ответ получаем уникальный идентификатор проверки UID. В это время наш текст становится в очередь на проверку. Получение результатов проверки происходит на втором этапе: по запросу, который включает пользовательский ключ и уникальный идентификатор проверки UID получаем развернутый ответ. Ответ содержит процент уникальности работы, дату проверки на сервере сайта и массив ссылок в интернете с соответствующим процентом заимствований.

Так как текстовый файл хранится в сжатом виде двоичных данных, то чтобы его открыть в дальнейшем, мы записываем файл во временном хранилище операционной системы. Для работы с текстовым файлом формата Microsoft Word создаем COM-объект "Word.Application" с отключением отображения и открываем наш временный файл. Весь текст документа копируем по предложениям в отдельную переменную, после чего закрываем документ Microsoft Word и удаляем временный файл.

&НаСервере
Процедура АнтиплагиатНаСервере(Файл)
	
	ФайлСсылка = Файл;
	ИмяВременногоФайла = ПолучитьИмяВременногоФайла("docx");
	ДвоичныеДанные = ФайлСсылка.Файл.Получить();
	ДвоичныеДанные.Записать(ИмяВременногоФайла);
	
	Ворд = Новый COMОбъект("Word.Application");        
	Ворд.Visible = Ложь; 
	Ворд.Documents.Open(ИмяВременногоФайла);
	
	Документ = Ворд.ActiveDocument();  
	Для н = 1 по Документ.Sentences.Count Цикл 
		Текст = "" + Текст + Документ.Sentences(н).Text; 
	КонецЦикла;	
	
	Документ.Close();  
	Ворд.Quit();
	УдалитьФайлы(ИмяВременногоФайла);
	
	Попытка
		WinHttp = Новый COMОбъект("WinHttp.WinHttpRequest.5.1");
		WinHttp.Option(2,"utf-8");
		WinHttp.Open("POST","http://api.text.ru/post",0);
		WinHttp.SetRequestHeader("Accept-Language", "ru");
		WinHttp.SetRequestHeader("Accept-Charset","utf-8");
		WinHttp.setRequestHeader("Content-Language", "ru");
		WinHttp.setRequestHeader("Content-Charset", "utf-8");
		WinHttp.setRequestHeader("Content-type", "application/x-www-form-urlencoded; charset=utf-8");
		ПараметрыПОСТ = "text=" + Текст + "&userkey=" + Константы.userkey.Получить();
		WinHttp.Send(ПараметрыПОСТ);
		Если WinHttp.Status = 200 Тогда
			ТекстОтвета = WinHttp.ResponseText();
			ЧтениеJSON = Новый ЧтениеJSON;
			ЧтениеJSON.УстановитьСтроку(ТекстОтвета);
			СтруктураОтвета = ПрочитатьJSON(ЧтениеJSON, Ложь);
			Для Каждого Элемент Из СтруктураОтвета Цикл
				Если Элемент.Ключ = "error_code" Тогда
					Сообщить("Код ошибки: " + Элемент.Значение);
				КонецЕсли;
				Если Элемент.Ключ = "error_desc" Тогда
					Сообщить("Описание ошибки: " + Элемент.Значение);
				КонецЕсли;
				Если Элемент.Ключ = "text_uid" Тогда
					Объект.UID = Элемент.Значение;
					Сообщить("Работа успешно отправлена на проверку!");
				КонецЕсли;
			КонецЦикла;
		Иначе
			Сообщить("HTTP " + WinHttp.Status + " " + WinHttp.StatusText);
		КонецЕсли;
	Исключение
		Сообщить(ОписаниеОшибки());
	КонецПопытки;
	
КонецПроцедуры

&НаКлиенте
Процедура Антиплагиат(Команда)
	СтрокаТЧ = Элементы.СписокДокументов.ТекущиеДанные; 
	АнтиплагиатНаСервере(СтрокаТЧ.Файл);
КонецПроцедуры

Чтобы отправить POST запрос создаем COM-объект WinHttp, задаем заголовки запроса, указываем адрес, параметры, в том числе ранее скопированный текст и отправляем запрос на веб-сервер.

При успешном выполнении читаем ответ в формате JSON, сохраняем UID, в ином случае выводим текст ошибки.

После выполнения этих действий текст курсовой работы находится в очереди на проверку на веб-сервере. Чтобы получить результат нажимаем кнопку «Результат проверки». Процедура, соответствующая кнопке, создает аналогичный по структуре POST запрос, только в параметрах вместо текста указываем UID. Текст ответа читаем в формате JSON, в процессе чего заполняем реквизиты объекта «Курсовая работа»: дату проверки, процент уникальности и табличную часть, содержащую ссылки в интернете с соответствующим процентом заимствований.

&НаСервере
Процедура РезультатПроверкиНаСервере() 
	Попытка
		WinHttp = Новый COMОбъект("WinHttp.WinHttpRequest.5.1");
		WinHttp.Option(2,"utf-8");
		WinHttp.Open("POST","http://api.text.ru/post",0);
		WinHttp.SetRequestHeader("Accept-Language", "ru");
		WinHttp.SetRequestHeader("Accept-Charset","utf-8");
		WinHttp.setRequestHeader("Content-Language", "ru");
		WinHttp.setRequestHeader("Content-Charset", "utf-8");
		WinHttp.setRequestHeader("Content-type", "application/x-www-form-urlencoded; charset=utf-8");
		ПараметрыПОСТ = "uid=" + Объект.UID + "&userkey=" + Константы.userkey.Получить();
		WinHttp.Send(ПараметрыПОСТ);
		Если WinHttp.Status = 200 Тогда
			ТекстОтвета = WinHttp.ResponseText();
		Иначе
			Сообщить("HTTP " + WinHttp.Status + " " + WinHttp.StatusText);
		КонецЕсли;
	Исключение
		Сообщить(ОписаниеОшибки());
	КонецПопытки;
	
	ЧтениеJSON = Новый ЧтениеJSON;
	ЧтениеJSON.УстановитьСтроку(ТекстОтвета);
	СтруктураОтвета = ПрочитатьJSON(ЧтениеJSON, Ложь);
	Для Каждого Элемент Из СтруктураОтвета Цикл
		
		Если Элемент.Ключ = "error_code" Тогда
			Сообщить("Код ошибки: " + Элемент.Значение);
		КонецЕсли;
		Если Элемент.Ключ = "error_desc" Тогда
			Сообщить("Описание ошибки: " + Элемент.Значение);
		КонецЕсли;
		
		Если Элемент.Ключ = "text_unique" Тогда
			ЭтаФорма.Модифицированность = Истина;
			Объект.УникальностьТекста = Элемент.Значение;
			Сообщить("Уникальность работы: " + Элемент.Значение + "%");
			Сообщить("Проверьте страницу 'Уникальность'");
		КонецЕсли;
		 
		Если Элемент.Ключ = "result_json" Тогда
			ЧтениеResult = Новый ЧтениеJSON;
			ЧтениеResult.УстановитьСтроку(Элемент.Значение);
			СтруктураResult = ПрочитатьJSON(ЧтениеResult, Ложь);
			Для Каждого Значение Из СтруктураResult Цикл
				Если Значение.Ключ = "urls" Тогда
					ЭтаФорма.Объект.Ссылки.Очистить();
					Для Каждого ЭлементМассива Из Значение.Значение Цикл
						НоваяСтрока = Объект.Ссылки.Добавить();
						НоваяСтрока.Url = ЭлементМассива.url;
						НоваяСтрока.Процент = ЭлементМассива.plagiat;
					КонецЦикла;
					Продолжить;
				КонецЕсли;
				Если Значение.Ключ = "date_check" Тогда
					Объект.ДатаПроверки = Значение.Значение;
				КонецЕсли;
			КонецЦикла;
			Продолжить;
		КонецЕсли;	
	КонецЦикла;
КонецПроцедуры

&НаКлиенте
Процедура РезультатПроверки(Команда)
	РезультатПроверкиНаСервере();
КонецПроцедуры

Проверка работ через API привязана к определенной учетной записи. Под своей учетной записью на сайте text.ru можно получить пользовательский ключ, либо заменить его. По пользовательскому ключу выполняются все запросы по взаимодействию с API text.ru, а также в форме «Пользовательский ключ» можно не только задать ключ, но и проверить баланс остатка символов в учетной записи.

Проверка баланса осуществляется POST запросом с параметрами method = get_packages_info и пользовательским ключом. В ответе по значению ключа size сообщаем пользователю остаток символов в учетной записи.
Данное решение не является полностью завершенным и протестированным, а представляет наработки по теме. 

Скачать файлы

Наименование Файл Версия Размер
Рабочее место преподавателя

.cf 143,92Kb
0
.cf 143,92Kb Скачать
Рабочее место студента

.cf 2,70Mb
0
.cf 2,70Mb Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. serega_new 02.08.18 00:21 Сейчас в теме
2. Denis11K 2 02.08.18 02:05 Сейчас в теме
(1) Пожалуйста, но если скачаете хотя бы один файл, буду тоже благодарен, очень нужен 1 стартмани))
3. wowik 831 14.09.18 10:56 Сейчас в теме
4. user1344343 21.01.20 02:32 Сейчас в теме
не получается получить файл
Оставьте свое сообщение

См. также

Автоматизация отдела продаж - CRM конфигурация для небольшой компании Промо

Управление взаимоотношениями с клиентами (СRM) Оптовая торговля Управленческий учет (прочее) v8 Россия УУ Абонемент ($m)

Вам нужна несложная и многофункциональная автоматизированная система управления продажами для автоматизации отдела продаж? Наша CRM Система поможет Вам! Внедрение займет не более 15 минут. A-CRM - быстрая и безболезненная автоматизация отдела продаж. Без лишних затрат и сложностей. Интеграция с 1С Бухгалтерией 3 и 1С УТ 11.

1 стартмани

05.03.2018    27361    52    user718500    14    

Сравнительный анализ затрат предприятия по месяцам для 1С:Бухгалтерии 3.0

Финансовый учет и бюджетирование (FRP) Учет доходов и расходов Управленческий учет (прочее) Финансовые Управленческие v8 v8::БУ БП3.0 Россия БУ УУ Абонемент ($m)

Внешний отчет показывает затраты предприятия, сгруппированные по одинаковым месяцам за произвольный период с отбором по организации или по всем организациям сразу.

1 стартмани

07.01.2021    1635    6    accounting_cons    3    

Домашние деньги для Android

Управленческий учет (прочее) v8 1cv8.cf Домашние учет и финансы Россия УУ Абонемент ($m)

Домашние деньги Android. Программа написана на платформе 1С:Предприятие 8.3 (8.3.10.2299) для мобильных устройств на ОС Android. Предназначена для учета движения собственных средств на мобильных устройствах.

1 стартмани

16.01.2020    3520    2    shvalentin    20    

Конфигурация для анализа транзакций криптобиржи localbitcoins

Управленческий учет (прочее) v8 Финансовые услуги, инвестиции Абонемент ($m)

На криптобирже localbitcoins имеется возможность выгрузить в csv файл все осуществленные транзакции. Я сделал маленькую конфигурацию для анализа доходности ваших операций.

2 стартмани

14.08.2019    3251    2    Идальго    6    

Спланируй день! #0.9.6 Промо

Учет рабочего времени Управленческий учет (прочее) v8 Абонемент ($m)

Персональный планировщик дел.

1 стартмани

03.02.2016    32167    104    chuprina_as    69    

Конфигурация "Питание в детском доме"

Управленческий учет (прочее) v8 Государственные, бюджетные структуры Россия Госбюджет Абонемент ($m)

Конфигурация "Питание в детском доме" предназначена для планирования меню на основании установленных норм расхода продуктов на детей разных возрастных категорий.

1 стартмани

13.08.2019    3629    3    pasha_m    0    

Управление автохозяйством (Путевой лист)

Управленческий учет (прочее) v8 1cv8.cf Автомобили, автосервисы УУ Абонемент ($m)

Конфигурация для учета работы автотранспорта, расходу топлива и документообороту в автохозяйствах.

3 стартмани

06.06.2019    5391    16    Sintson    17    

Опросник

Управленческий учет (прочее) v8 Абонемент ($m)

Была задача анализа нескольких десятков ответов от нескольких десятков пользователей. Директор головного предприятия (назовем его так), предложил сделать Чек-Лист - разослать таблицы Эксель, затем обработать данные, собрав ответы в одну таблицу... Мы, 1Сники, не поддержали такое предложение. Наш ответ стал в виде конфигурации для web-клиента. Где, запустив в браузере опросник, можно добавлять вопросы, ответы и получать различные варианты отчетов с графическим представлением результатов.

9 стартмани

15.05.2019    5953    2    vitalbasl    7    

Регистрация и согласование договоров, редакция 2.0 Промо

Документооборот и делопроизводство Управленческий учет (прочее) v8 УУ Абонемент ($m)

Конфигурация "Регистрация и согласование договоров" является готовым решением для управления и учета договоров на предприятии. Позволяет организовать единую информационную систему регистрации и согласования. Включает CRM подсистему.

1000 руб.

26.05.2015    20024    18    5    

Конфигурация для программистов для повседневного использования

Управленческий учет (прочее) v8 Абонемент ($m)

Конфигурация полезна любым программистам для повседневного использования (постановка задач, отчетность по задачам, хранение обработок, каталог алгоритмов).

1 стартмани

15.05.2019    5996    23    Jen1978    11    

Учет обучения и адаптации сотрудников. ЗУП 3.1

Управление персоналом (HRM) Управленческий учет (прочее) v8 v8::СПР v8::УФ v8::СКД ЗУП3.x Россия УУ Абонемент ($m)

Данная доработка предназначена для учета обучения и адаптации сотрудников в ЗУП 3.1.

1 стартмани

15.04.2019    5785    4    hellf    0    

Управление задачами ИТ - ранжирование, планирование (самостоятельная конфигурация 1С:Предприятие 8.3)

Управленческий учет (прочее) v8 v8::УФ 1cv8.cf Абонемент ($m)

Как уже не раз писалось, каждый программист хоть раз в жизни, должен написать планировщик задач. Ключевое отличие от существующих в огромном количестве: задача это не справочник, а документ, со всеми вытекающими последствиями. Плюс "заточенность" не на ведение и распределение, а на расстановку приоритетов. Т.е. это скорее инструмент принятия решений, чем планировщик.

10 стартмани

18.03.2019    8217    4    capitan    3    

Конфигурация "Тестирование респондентов" Промо

Управленческий учет (прочее) v8 Россия Абонемент ($m)

Конфигурация для тестирования респондентов на управляемых формах

1 стартмани

08.06.2012    22485    121    Drak0n    21    

Бюджет семьи (конфигурация)

Финансовый учет и бюджетирование (FRP) Управленческий учет (прочее) v8 Домашние учет и финансы УУ Абонемент ($m)

Простая конфигурация на платформе 8.3, позволяющая вести учет семейного бюджета. Бюджет семьи у нас общий, ведется в разрезе "счетов" - например Кредитная карта, кошелек, шкатулка и т.д. Работает на платформе 8.3.13.1513

1 стартмани

19.11.2018    8457    2    vln    10    

Конфигурация "Дневник питания"

Управленческий учет (прочее) v8 v8::УФ Домашние учет и финансы Россия Абонемент ($m)

Учет ежедневного потребления калорий, изменений показателей веса и объемов тела.

1 стартмани

08.11.2018    31506    11    accounting_cons    27    

Анализ затрат по чекам онлайн

Финансовый учет и бюджетирование (FRP) Управленческий учет (прочее) v8 Домашние учет и финансы Россия УУ Абонемент ($m)

Представлена конфигурация, позволяющая загружать чеки онлайн и анализировать расходы в разрезе поставщиков, товаров (категорий товаров), статей затрат. Конфигурация будет полезна тем, кто думает, а стоит ли планировать свои затраты? Используя данную конфигурация можно с минимальной ручной работой проанализировать свои повседневные расходы.

1 стартмани

14.10.2018    8807    3    gzharkoj    2    

Подсистема "Выдача пропусков и система учета" Промо

Управленческий учет (прочее) v8 1cv8.cf Абонемент ($m)

Данная подсистема может использоваться и как отдельная конфигурация, и в качестве блока для основной конфигурации. Система позволяет производить регистрацию и выдачу пропусков.

1 стартмани

08.05.2015    25871    25    GATTUSO    8    

Конфигурация "Помощник системного администратора". Учет компьютеров и оргтехники на производстве

Учет рабочего времени Учет ТМЦ Управленческий учет (прочее) v8 УУ Абонемент ($m)

Простая конфигурация для ведения учета оборудования по инвентарным номерам, учета движения оборудования, учет по заправкам картриджей, ремонту оргтехники. Последнее обновление 23.09.2019г.

2 стартмани

03.10.2018    12177    73    user811626    24    

Автоматический расчет результатов теста Векслер

Управленческий учет (прочее) v8 1cv8.cf Здравоохранение, медицина, стоматология Обучение, бизнес-тренинг, курсы Абонемент ($m)

Чистая база данных для автоматического расчета результатов теста Векслер от 5 до 15 лет (для других возрастов, необходимо заполнить данные расчета).

1 стартмани

24.09.2018    6166    0    oleg-x    1    

Простая конфигурация для учета птичьего двора

Управленческий учет (прочее) v8 Домашние учет и финансы УУ Абонемент ($m)

Учет домашней птицы. Конфигурация для домашнего использования.

1 стартмани

05.09.2018    5139    3    asisdes    5    

Дневник Сновидений Промо

Управленческий учет (прочее) v8 Россия Абонемент ($m)

Конфигурация для ведения дневника сновидений с индивидуальной статистикой

1 стартмани

05.11.2014    19877    9    SeiOkami    7    

Каркас конфигурации для ведения учета фрилансером

Производство готовой продукции (работ, услуг) Учет рабочего времени Управленческий учет (прочее) v8 УУ Абонемент ($m)

Конфигурация предназначена для ведения учёта фрилансера. Скачав эту конфигурацию с открытым кодом, Вы сможете вести учёт своих взаиморасчётов. Получать напоминания о важных событиях. Добавлен необходимый функционал для автоматизации повседневной работы фрилансера. Конфигурация работает на платформе 1С: Предприятие 8.2, 8.3. Тестирование проводилось на платформе 1С:Предприятие 8.3 (8.3.10.2580).

5 стартмани

13.07.2018    8529    11    2757028    6    

Винотека 1.0

Управленческий учет (прочее) v8 Домашние учет и финансы Россия Абонемент ($m)

"Винотека 1.0" позволяет вести учет вина в личной винотеке.

1 стартмани

07.06.2018    5862    1    Andrew_Anatolich    8    

Простой учет материалов на складах

Учет ТМЦ Управленческий учет (прочее) v8 Россия УУ Абонемент ($m)

Конфигурация 1С "Простой учет движения материалов" с небольшим примером. Будет полезна при любом учете материалов на производстве, где материально-ответственные лица учитывают поступления и расход материалов, имущества, инструментов и рассчитывают расход по норме.

1 стартмани

07.01.2018    11509    20    user883442    1    

Учет времени разработчика Промо

Учет рабочего времени Управленческий учет (прочее) v8 Россия Абонемент ($m)

Конфигурация предназначена для учета времени фрилансера или любого программиста.

1 стартмани

12.03.2010    42081    2413    logarifm    137    

Прототип конфигурации для фундаментального анализа ценных бумаг и финансового анализа

Финансовый учет и бюджетирование (FRP) Управленческий учет (прочее) v8 Финансовые услуги, инвестиции УУ Абонемент ($m)

Прототип конфигурации для расчёта значений произвольных показателей по заданным формулам. Основное назначение - финансовый анализ и фундаментальный анализ ценных бумаг, но, теоретически, может быть использована и для других целей.

1 стартмани

06.01.2018    12006    5    q_i    8    

Конфигурация для учета личных финансов

Финансовый учет и бюджетирование (FRP) Управленческий учет (прочее) v8 Домашние учет и финансы Россия УУ Абонемент ($m)

Программа для учета личных финансов. Но кто знает может и подойдет для Малого бизнеса. Версия 1.0.1.10 Возможности: 1. Ведение счетов: наличка, карты. 1.1. Возможность в отчетности по остаткам не указывать счет для накоплений. 2. Статьи расходов 3. Статьи доходов. 4. Бюджеты расходов и доходов в разрезе месяцев. Учет финансовых целей.

3 стартмани

26.11.2017    11957    7    ra1ich    9    

Тренировка запоминания цепочек и пар ассоциаций, запоминание иностранных слов

Управленческий учет (прочее) v8 Россия Абонемент ($m)

Мини-конфигурация под 1С 8.2 создана для тренировки запоминания имен, цифр, иностранных слов и прочего. Содержит справочник "Карточки" с реквизитами: Наименование, Ассоциация, Картинка (по сути Вопрос, Ответ, Картинка), отчет по Запоминанию и проверке ответов, обработку по загрузке файлов TXT в формате Вопрос-Ответ.

1 стартмани

15.09.2017    10449    3    ak_register    0    

База знаний (вер. 1.3) Промо

Управленческий учет (прочее) v8 Россия Абонемент ($m)

Конфигурация (на базе БСП) для управления знаниями различного характера. Бесплатная открытая версия для свободного использования.

1 стартмани

11.10.2013    50263    836    vandalsvq    145    

Учет портфеля ценных бумаг частных инвесторов

Управленческий учет (прочее) v8 v8::ОУ Финансовые услуги, инвестиции Россия УУ Абонемент ($m)

Простая конфигурация для учета портфеля ценных бумаг частных инвесторов, основанная на БСП 2.4.3.40 и БИПП (Библиотека Интернет Поддержки Пользователей) 2.2.2.15.

1 стартмани

07.09.2017    13066    25    xan333    4    

2MS. Конфигурация для учёта данных о проектах и задачах

Управленческий учет (прочее) v8 Россия УУ Абонемент ($m)

2MS — это конфигурация, которая помогает мне работать над проектами и в жизни, так как я люблю фиксировать всё, что касается конкретной темы: ссылки, каталоги, различные заметки, сценарии пользователей и многое другое, — собираю это всё в одном месте. И потом, когда мне нужно, я могу быстро найти это среди структурированной информации.

1 стартмани

13.06.2017    11646    9    new1c    2    

Конфигурация "Идеальный рацион питания"

Управленческий учет (прочее) v8 Домашние учет и финансы Абонемент ($m)

С помощью данной конфигурации вы сможете создать сбалансированный рацион питания, учитывающий ваш возраст, физическую активность на работе. Опираясь на данные химического состава продуктов разных источников(Скурихин, USDA и др.), вы сможете снабжать свой организм всеми необходимыми нутриентами.

1 стартмани

17.05.2017    14718    9    Lem0n    1    

Простой расчет квартплаты. Расчет и начисление коммунальных услуг и платежей для квартиросъемщиков

Управленческий учет (прочее) v8 Энергетика и ЖКХ Домашние учет и финансы Россия УУ Абонемент ($m)

Конфигурация предназначена для учета показаний счетчиков в квартире и для учета оплаты за оказанные ЖКХ услуги для квартиросъемщиков.

1 стартмани

15.03.2017    18761    12    vik2006    1    

Accost Of Car (Учет затрат на автомобиль)

Учет ТМЦ Управленческий учет (прочее) v8 1cv8.cf Автомобили, автосервисы Россия УУ Абонемент ($m)

Конфигурация Учет затрат на автомобиль - помогает вести учет заправок и затрат на запчасти и ремонт.

3 стартмани

30.12.2016    12777    3    andrybar    2    

Учет компьютеров и оргтехники на предприятии

Учет ТМЦ Управленческий учет (прочее) v8 Россия УУ Абонемент ($m)

Бухгалтерский учет ТМЦ, инвентаря и основных средств это, конечно, очень хорошо. Но когда приходит время инвентаризации и данные бухгалтерского учета начинают не соответствовать фактическому наличию компьютера и оргтехники на рабочем месте сотрудника, то: - Бухгалтерия начинает "говорить" в свое оправдание, что ИТ- специалисты установили/ переместили/ изъяли оборудование с рабочего места МОЛа, не уведомив об этом бухгалтерию; - А ИТ- специалист начинает понимать поговорку, что без "бумажки" он букашка, а с "бумажкой" человек; Данная простейшая конфигурация призвана наладить учет у ИТ -специалистов, с передачей документов об изменении состава оборудования на рабочем месте МОЛа в бухгалтерию.

1 стартмани

14.10.2016    23295    85    Anson    8    

Конфигурация "Управление рисками" 0.2.2b Промо

Управленческий учет (прочее) v8 УУ Абонемент ($m)

Конфигурация "Управление рисками" 0.0.2.2b. В России управление рисками только начинает развиваться. Управление рисками является неотъемлемой части планирования любого проекта. По статистике только 50% проектов завершаются успешно и виной неудачных проектов всегда являются риски, будь то риск отсутствия финансирования или риск потери актуальности проекта. Грамотная оценка рисков поможет вам еще на этапе планирования понять вероятность завершения проекта неудачей и оценить трудоемкость устранения рисков. Первая версия является сжатой методикой управления рисками по PMBOK (Project Management Body of Knowledge), которую проект менеджеры зачастую рассчитывают в Excel. Введение по управлению рисками можно прочитать тут - http://infostart.ru/public/256641/

1 стартмани

23.01.2014    26549    65    bobreks    35    

Минусы при расчете себестоимости в УПП и особенности решения СЛАУ

Управленческий учет (прочее) Производство готовой продукции (работ, услуг) Учет ТМЦ Производство готовой продукции (работ, услуг) Учет ТМЦ v8 УПП1 Абонемент ($m)

В статье на примерах рассматривается, как в УПП при включенном РАУЗ решается система линейных алгебраических уравнений.

1 стартмани

21.09.2016    17026    1    Anashka    7    

Подсистема учёта дополнительных документов со внешним хранилищем присоединённых файлов

Документооборот и делопроизводство Управленческий учет (прочее) v8 1cv8.cf УУ Абонемент ($m)

Подсистема предназначена для учета в информационной базе дополнительных документов, и хранения их отсканированных копий (и других файлов) во внешнем файловом хранилище. Все операции копирования файлов в файловое хранилище и генерации имен (путей сохранения) производятся автоматически (по одному из шаблонов) сервером приложения "1С Предприятия 8" под именем пользователя, под которым запущена служба. При такой схеме работы всем пользователям домена (или рабочей группы) можно отключить право "Просмотра" файловой структуру хранилища, а все операции над файлами производить исключительно средствами приложения "1С Предприятия 8".

1 стартмани

22.08.2016    13376    9    Glebis    2    

Простая конфигурация склада

Учет ТМЦ Управленческий учет (прочее) v8 Россия УУ Абонемент ($m)

Простейший учёт оргтехники по подразделениям.

1 стартмани

10.08.2016    9947    18    shmax    0    

Программа "Контроль питания", редакция 1.2 Промо

Управленческий учет (прочее) v8 Россия Абонемент ($m)

Программа для тех кто пытается контролировать свое питание, будь вы спортсмен или желающим похудеть либо просто человеком ведущий здоровый образ жизни эта программа вам в помощь.

1 стартмани

10.07.2012    19308    17    TeoFrast    42    

Конфигурация учета ИТС

Управленческий учет (прочее) v8 v8::УФ Россия Абонемент ($m)

Бесплатная конфигурация: "Учет 1С:ИТС" на управляемых формах 8.3. Удобная конфигурация для оформления подписки ИТС прямо из платформы, реализована возможность сохранения заявки ИТС на диск в удобное для вас место и отправка заявки из программы. Нет необходимости хранить файлы Excel со множеством заявок в различных папках на компьютере, при оформлении подписки копировать все данные из формы в новую форму, теряя свое драгоценное время и нервы, все находится прямо в конфигурации. Формирование, сохранение заявки, анализ подписок и многое, многое другое и полезное в одной базе! Упрости свою жизнь в работе с подписками 1С:ИТС!

1 стартмани

27.07.2016    18828    67    nagaitseff    18    

Простая подсистема учета принятого на ремонт (в сервис) оборудования. БСП.

Учет ТМЦ Управленческий учет (прочее) v8 УТ10 УУ Абонемент ($m)

Простая подсистема учета принятого на ремонт оборудования. Подсистема основана на регистре сведений. Позволяет вести учет принятого в ремонт товара, учет переданного в сторонние сервисные центры. Основана на БСП.

1 стартмани

03.07.2016    10965    9    ddd_l    1    

Малая спецтехника

Управленческий учет (прочее) v8 Транспорт, автопарки, такси УУ Абонемент ($m)

Данная конфигурация предназначена для автоматизации управленческого учёта в небольших организациях, работающих со спецтехникой. Для них мало подходят типовые конфигурации.

1 стартмани

30.05.2016    12390    4    rossoxa    1    

Планирование и учет времени сотрудников (управляемое приложение) Промо

Учет рабочего времени Управленческий учет (прочее) v8 v8::УФ 1cv8.cf Россия УУ Абонемент ($m)

Давно искали программу, в которой можно без проблем поставить задачу своему сотруднику и проследить, какие решения он принимал, чтобы завершить задачу? Хотите, чтобы вновь созданные задачи становились в очередь, а сотрудник выполнял их по порядку? Хотите, чтобы Ваши сотрудники планировали свою деятельность? Хотите видеть загруженность сотрудников графически? Хотите видеть, как долго сотрудник обедает и обедает ли? Если у Вас есть такие потребности, ознакомьтесь с конфигурацией "Планирование и учет времени", здесь все это есть.

1 стартмани

26.03.2012    49656    1359    IRLes    103    

Технопарк - Учет компьютерной техники

Учет ТМЦ Управленческий учет (прочее) v8 УУ Абонемент ($m)

Конфигурация “Технопарк” предназначена для ведения учета различного оборудования - компьютерной техники, запчастей, расходных материалов, и т.д., управления обращениями и ремонтами (ITIL), анализа сетевой инфраструктуры организации - пинг, сканирование портов , опрос SNMP устройств, сканирование конфигурации ПК а также для накопления и использования базы решений возникающих проблем.

1 стартмани

20.05.2016    20726    129    tav_74    18    

Конфигурация учета задач

Управленческий учет (прочее) v8 Абонемент ($m)

Примитивная конфигурация по учету задач в разрезе авторов, исполнителей, проектов. Может отправлять уведомления о задаче на эл. почту.

1 стартмани

07.05.2016    16678    33    alexdarh    19    

Менеджер по персоналу

Управление персоналом (HRM) Управленческий учет (прочее) v8 УУ Абонемент ($m)

Конфигурация предназначена для автоматизации управленческих процессов в службе персонала. Я очень часто встречаюсь с претензиями от пользователей ЗУП Проф и базовой версии. В компаниях как минимум есть подбор, а часто обучение и мотивация. Нередко необходимо отслеживать допуски сотрудников к работам. В итоге это ведётся в журнале, или в лучшем случае - в экселе. С целью помочь я придумал эту конфигурацию.

1 стартмани

06.05.2016    9836    11    rossoxa    10    

Учет домашнего бюджета Промо

Производство готовой продукции (работ, услуг) Управленческий учет (прочее) v8 Домашние учет и финансы Россия Госбюджет Абонемент ($m)

Ведение домашнего учета постатейно, в разрезе кошельков. Отслеживание остатка средств.

1 стартмани

27.12.2011    18933    80    koderman    14    

Учет выезда и въезда автотранспорта

Управленческий учет (прочее) v8 Автомобили, автосервисы Транспорт, автопарки, такси УУ Абонемент ($m)

Конфигурация создана для фиксирования данных по выезду и въезду автотранспорта на территорию предприятия. Можно использовать автономно для регистрации въезда и выезда транспорта с территории.

1 стартмани

08.04.2016    17874    39    Arkadiy_B    12    

"Менеджмент безопасности". Редакция 1.0

Управленческий учет (прочее) v8 Россия УУ Абонемент ($m)

Менеджмент безопасности - конфигурация, позволяющая автоматизировать деятельность сотрудников, отвечающих за криптографическую защиту информации в организации. В первую очередь система предназначена для Лицензиатов ФСБ России по криптографии (в соответствии с Постановлением Правительства РФ № 313 от 16.04.2012), а также кредитно-финансовым организациям, государственным бюджетным организациям и другим организациям, ответственно подходящим к вопросам построения криптографической защиты информации.

1 стартмани

01.03.2016    12350    14    imbasoft    2    

Расширение для "1С:Деньги" (8.3)

Управленческий учет (прочее) v8 Домашние учет и финансы Россия Абонемент ($m)

Небольшое расширение, которое отображает текущий курс и конвертирует по нему валюту в кошельке.

1 стартмани

24.02.2016    15231    4    Dr.Morris    5