Автоматизация проверки на плагиат в ИС "Курсовые работы"

Публикация № 878398

Управление - Управленческий учет (прочее)

Основное приложение мобильное приложение веб сервис API post запросы.

2
Разработка обеспечивает коммуникацию между студентом и преподавателем во время выполнения курсовой работы, хранение всех курсовых работ и данных о них в единой информационной базе, а также проверку текстов работ на уникальность. Платформа 8.3.10.2639

Мы постоянно используем почтовые сервисы для обмена сообщениями, документами, файлами. Выполнение курсовой работы чаще всего затрагивает использование таких сервисов, но их использование не несет упорядоченности. У каждого наверняка уже есть множество аккаунтов электронной почты, социальных сетей, которые переполнены разного рода информацией, в которых легко упустить что-то важное. В том числе, на кафедре осуществляется хранение работ до некоторого срока, но какой либо специальной информационной базы для этого, как правило, не существует, необходимые документы легко могут быть утеряны.

Все это говорит о том, что образовательный процесс нуждается в своих специализированных программных инструментах. Так наличие соответствующего прикладного решения могло бы не только решить данные проблемы, но также предоставить новые функциональные возможности, упрощающие деятельность преподавателей и студентов. Именно разработке такого программного средства посвящена данная работа.

Благодаря широкой структуре объекта документа «Курсовая работа» в созданном программном средстве доступна вся необходимая функциональность по учету и мониторингу работ, а также проверке и хранению данных о них.

В работе предусматривается свой собственный механизм обмена сообщениями в разрезе курсовых работ прямо из используемых программ, что упрощает коммуникацию между студентом и преподавателем в процессе выполнения работы.

В больших потоках информации возникает необходимость обеспечить хранение отдельной информации с удобным доступом к ней. Программное средство реализует хранение и обмен файлами различных форматов, которые связаны с курсовыми работами. Файлы могут открываться непосредственно из приложений. Для проверки на плагиат используются текстовые документы в формате Microsoft Word.

Если для реферата уникальность не имеет принципиального значения, то курсовой проект это уже работа с претензией на научную значимость, и она должна иметь определенный процент уникальности. В работе реализована автоматизация проверки курсовых работ прямо с используемого приложения. В соответствии с логикой программного средства работы на проверку отправляет преподаватель, а результаты проверки доступны как преподавателю, так и студенту.

Накопленная информация не редко должна быть обработана и проанализирована, поэтому в программе представлены некоторые механизмы отчетности. В программном средстве присутствуют отчеты, которые могут быть использованы в интересах кафедры, такие как: отчет по задолженностям, отчет по состоянию курсовых работ в заданном периоде на кафедре, отчет по группе.

В моей разработке подразумевается, что преподаватель использует приложение на персональном компьютере, имеющее расширенный функционал, заключающийся в том, что преподаватель может создать (как объект системы) и назначить курсовую работу любому студенту, а также имеет доступ ко всем справочникам и документам, может их редактировать. Студент, в свою очередь, имеет преднамеренно ограниченный функционал на своем мобильном устройстве. Студент может отвечать на сообщения, прикреплять и получать файлы, смотреть за статусом своей работы, получать уведомления.

 Основным объектом конфигураций данных приложений является документ «Курсовая работа», который использует справочники для заполнения своих реквизитов и предоставляет все необходимые команды с ним связанные. Именно в объекте конфигурации «Курсовая работа» реализована автоматизация проверки на плагиат.

 Форма объекта «Курсовая работа» имеет три вкладки, первая из них «Документ», содержащая основные реквизиты. Вторая вкладка «Файлы» содержит список файлов, прикрепленных к курсовой работе, в том числе сам текстовый файл, который подвергается проверке на плагиат. По кнопке «Антиплагиат» отправляем текст работы на проверку, а по кнопке «Результат проверки» получаем результаты проверки, на основании которых автоматически формируется содержимое вкладки «Уникальность».

 Для проверки на плагиат используется API сайта text.ru, который предоставляет услуги по созданию и соблюдению уникального контента. Взаимодействие с API происходит в два этапа. На первом этапе отправляем текст и пользовательский ключ посредством POST запроса на сервер сайта, на что в ответ получаем уникальный идентификатор проверки UID. В это время наш текст становится в очередь на проверку. Получение результатов проверки происходит на втором этапе: по запросу, который включает пользовательский ключ и уникальный идентификатор проверки UID получаем развернутый ответ. Ответ содержит процент уникальности работы, дату проверки на сервере сайта и массив ссылок в интернете с соответствующим процентом заимствований.

Так как текстовый файл хранится в сжатом виде двоичных данных, то чтобы его открыть в дальнейшем, мы записываем файл во временном хранилище операционной системы. Для работы с текстовым файлом формата Microsoft Word создаем COM-объект "Word.Application" с отключением отображения и открываем наш временный файл. Весь текст документа копируем по предложениям в отдельную переменную, после чего закрываем документ Microsoft Word и удаляем временный файл.

&НаСервере
Процедура АнтиплагиатНаСервере(Файл)
	
	ФайлСсылка = Файл;
	ИмяВременногоФайла = ПолучитьИмяВременногоФайла("docx");
	ДвоичныеДанные = ФайлСсылка.Файл.Получить();
	ДвоичныеДанные.Записать(ИмяВременногоФайла);
	
	Ворд = Новый COMОбъект("Word.Application");        
	Ворд.Visible = Ложь; 
	Ворд.Documents.Open(ИмяВременногоФайла);
	
	Документ = Ворд.ActiveDocument();  
	Для н = 1 по Документ.Sentences.Count Цикл 
		Текст = "" + Текст + Документ.Sentences(н).Text; 
	КонецЦикла;	
	
	Документ.Close();  
	Ворд.Quit();
	УдалитьФайлы(ИмяВременногоФайла);
	
	Попытка
		WinHttp = Новый COMОбъект("WinHttp.WinHttpRequest.5.1");
		WinHttp.Option(2,"utf-8");
		WinHttp.Open("POST","http://api.text.ru/post",0);
		WinHttp.SetRequestHeader("Accept-Language", "ru");
		WinHttp.SetRequestHeader("Accept-Charset","utf-8");
		WinHttp.setRequestHeader("Content-Language", "ru");
		WinHttp.setRequestHeader("Content-Charset", "utf-8");
		WinHttp.setRequestHeader("Content-type", "application/x-www-form-urlencoded; charset=utf-8");
		ПараметрыПОСТ = "text=" + Текст + "&userkey=" + Константы.userkey.Получить();
		WinHttp.Send(ПараметрыПОСТ);
		Если WinHttp.Status = 200 Тогда
			ТекстОтвета = WinHttp.ResponseText();
			ЧтениеJSON = Новый ЧтениеJSON;
			ЧтениеJSON.УстановитьСтроку(ТекстОтвета);
			СтруктураОтвета = ПрочитатьJSON(ЧтениеJSON, Ложь);
			Для Каждого Элемент Из СтруктураОтвета Цикл
				Если Элемент.Ключ = "error_code" Тогда
					Сообщить("Код ошибки: " + Элемент.Значение);
				КонецЕсли;
				Если Элемент.Ключ = "error_desc" Тогда
					Сообщить("Описание ошибки: " + Элемент.Значение);
				КонецЕсли;
				Если Элемент.Ключ = "text_uid" Тогда
					Объект.UID = Элемент.Значение;
					Сообщить("Работа успешно отправлена на проверку!");
				КонецЕсли;
			КонецЦикла;
		Иначе
			Сообщить("HTTP " + WinHttp.Status + " " + WinHttp.StatusText);
		КонецЕсли;
	Исключение
		Сообщить(ОписаниеОшибки());
	КонецПопытки;
	
КонецПроцедуры

&НаКлиенте
Процедура Антиплагиат(Команда)
	СтрокаТЧ = Элементы.СписокДокументов.ТекущиеДанные; 
	АнтиплагиатНаСервере(СтрокаТЧ.Файл);
КонецПроцедуры

Чтобы отправить POST запрос создаем COM-объект WinHttp, задаем заголовки запроса, указываем адрес, параметры, в том числе ранее скопированный текст и отправляем запрос на веб-сервер.

При успешном выполнении читаем ответ в формате JSON, сохраняем UID, в ином случае выводим текст ошибки.

После выполнения этих действий текст курсовой работы находится в очереди на проверку на веб-сервере. Чтобы получить результат нажимаем кнопку «Результат проверки». Процедура, соответствующая кнопке, создает аналогичный по структуре POST запрос, только в параметрах вместо текста указываем UID. Текст ответа читаем в формате JSON, в процессе чего заполняем реквизиты объекта «Курсовая работа»: дату проверки, процент уникальности и табличную часть, содержащую ссылки в интернете с соответствующим процентом заимствований.

&НаСервере
Процедура РезультатПроверкиНаСервере() 
	Попытка
		WinHttp = Новый COMОбъект("WinHttp.WinHttpRequest.5.1");
		WinHttp.Option(2,"utf-8");
		WinHttp.Open("POST","http://api.text.ru/post",0);
		WinHttp.SetRequestHeader("Accept-Language", "ru");
		WinHttp.SetRequestHeader("Accept-Charset","utf-8");
		WinHttp.setRequestHeader("Content-Language", "ru");
		WinHttp.setRequestHeader("Content-Charset", "utf-8");
		WinHttp.setRequestHeader("Content-type", "application/x-www-form-urlencoded; charset=utf-8");
		ПараметрыПОСТ = "uid=" + Объект.UID + "&userkey=" + Константы.userkey.Получить();
		WinHttp.Send(ПараметрыПОСТ);
		Если WinHttp.Status = 200 Тогда
			ТекстОтвета = WinHttp.ResponseText();
		Иначе
			Сообщить("HTTP " + WinHttp.Status + " " + WinHttp.StatusText);
		КонецЕсли;
	Исключение
		Сообщить(ОписаниеОшибки());
	КонецПопытки;
	
	ЧтениеJSON = Новый ЧтениеJSON;
	ЧтениеJSON.УстановитьСтроку(ТекстОтвета);
	СтруктураОтвета = ПрочитатьJSON(ЧтениеJSON, Ложь);
	Для Каждого Элемент Из СтруктураОтвета Цикл
		
		Если Элемент.Ключ = "error_code" Тогда
			Сообщить("Код ошибки: " + Элемент.Значение);
		КонецЕсли;
		Если Элемент.Ключ = "error_desc" Тогда
			Сообщить("Описание ошибки: " + Элемент.Значение);
		КонецЕсли;
		
		Если Элемент.Ключ = "text_unique" Тогда
			ЭтаФорма.Модифицированность = Истина;
			Объект.УникальностьТекста = Элемент.Значение;
			Сообщить("Уникальность работы: " + Элемент.Значение + "%");
			Сообщить("Проверьте страницу 'Уникальность'");
		КонецЕсли;
		 
		Если Элемент.Ключ = "result_json" Тогда
			ЧтениеResult = Новый ЧтениеJSON;
			ЧтениеResult.УстановитьСтроку(Элемент.Значение);
			СтруктураResult = ПрочитатьJSON(ЧтениеResult, Ложь);
			Для Каждого Значение Из СтруктураResult Цикл
				Если Значение.Ключ = "urls" Тогда
					ЭтаФорма.Объект.Ссылки.Очистить();
					Для Каждого ЭлементМассива Из Значение.Значение Цикл
						НоваяСтрока = Объект.Ссылки.Добавить();
						НоваяСтрока.Url = ЭлементМассива.url;
						НоваяСтрока.Процент = ЭлементМассива.plagiat;
					КонецЦикла;
					Продолжить;
				КонецЕсли;
				Если Значение.Ключ = "date_check" Тогда
					Объект.ДатаПроверки = Значение.Значение;
				КонецЕсли;
			КонецЦикла;
			Продолжить;
		КонецЕсли;	
	КонецЦикла;
КонецПроцедуры

&НаКлиенте
Процедура РезультатПроверки(Команда)
	РезультатПроверкиНаСервере();
КонецПроцедуры

Проверка работ через API привязана к определенной учетной записи. Под своей учетной записью на сайте text.ru можно получить пользовательский ключ, либо заменить его. По пользовательскому ключу выполняются все запросы по взаимодействию с API text.ru, а также в форме «Пользовательский ключ» можно не только задать ключ, но и проверить баланс остатка символов в учетной записи.

Проверка баланса осуществляется POST запросом с параметрами method = get_packages_info и пользовательским ключом. В ответе по значению ключа size сообщаем пользователю остаток символов в учетной записи.
Данное решение не является полностью завершенным и протестированным, а представляет наработки по теме. 

2

Скачать файлы

Наименование Файл Версия Размер
Рабочее место преподавателя
.cf 143,92Kb
01.08.18
0
.cf 143,92Kb Скачать
Рабочее место студента
.cf 2,70Mb
01.08.18
1
.cf 2,70Mb 1 Скачать

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. serega_new 02.08.18 00:21 Сейчас в теме
2. Denis11K 2 02.08.18 02:05 Сейчас в теме
(1) Пожалуйста, но если скачаете хотя бы один файл, буду тоже благодарен, очень нужен 1 стартмани))
3. wowik 609 14.09.18 10:56 Сейчас в теме
Оставьте свое сообщение

См. также

Дневник давления 6

Отчеты и формы no Конфигурация (md, cf) v8 Здравоохранение, медицина, стоматология Windows Абонемент ($m) Управленческий учет (прочее)

Выполняем указания врача и набираем для него статистику показаний.

3 стартмани

05.09.2019    773    1    Infector    0       

Управление автохозяйством (Путевой лист) 5

Отчеты и формы Программист Бухгалтер Пользователь Архив с данными v8 1cv8.cf Автомобили, автосервисы УУ Абонемент ($m) Управленческий учет (прочее)

Конфигурация для учета работы автотранспорта, расходу топлива и документообороту в автохозяйствах.

3 стартмани

06.06.2019    1486    5    Sintson    7       

Опросник 4

Отчеты и формы Бизнес-аналитик Пользователь Руководитель проекта Конфигурация (md, cf) v8 Абонемент ($m) Управленческий учет (прочее)

Была задача анализа нескольких десятков ответов от нескольких десятков пользователей. Директор головного предприятия (назовем его так), предложил сделать Чек-Лист - разослать таблицы Эксель, затем обработать данные, собрав ответы в одну таблицу... Мы, 1Сники, не поддержали такое предложение. Наш ответ стал в виде конфигурации для web-клиента. Где, запустив в браузере опросник, можно добавлять вопросы, ответы и получать различные варианты отчетов с графическим представлением результатов.

9 стартмани

15.05.2019    1785    1    vitalbasl    7       

Конфигурация для программистов для повседневного использования 10

Отчеты и формы Программист Конфигурация (md, cf) v8 Windows Абонемент ($m) Управленческий учет (прочее)

Конфигурация полезна любым программистам для повседневного использования (постановка задач, отчетность по задачам, хранение обработок, каталог алгоритмов).

1 стартмани

15.05.2019    2013    13    Jen1978    9       

Управление задачами ИТ - ранжирование, планирование (самостоятельная конфигурация 1С:Предприятие 8.3) 8

Отчеты и формы no Архив с данными v8 v8::УФ 1cv8.cf Абонемент ($m) Управленческий учет (прочее)

Как уже не раз писалось, каждый программист хоть раз в жизни, должен написать планировщик задач. Ключевое отличие от существующих в огромном количестве: задача это не справочник, а документ, со всеми вытекающими последствиями. Плюс "заточенность" не на ведение и распределение, а на расстановку приоритетов. Т.е. это скорее инструмент принятия решений, чем планировщик.

10 стартмани

18.03.2019    3454    4    capitan    2       

Система взаимодействия [Расширение] для (УТ 11, УНФ) 11

Инструменты и обработки no Расширение (cfe) v8 УНФ УТ11 Россия Абонемент ($m) Управленческий учет (прочее)

Система взаимодействия пользователей в информационной базе.

3 стартмани

09.03.2019    2689    12    noprogrammer    2       

Бюджет семьи (конфигурация) 6

Отчеты и формы no Конфигурация (md, cf) v8 Домашние учет и финансы УУ Финансовый учет и бюджетирование (FRP) Абонемент ($m) Управленческий учет (прочее)

Простая конфигурация на платформе 8.3, позволяющая вести учет семейного бюджета. Бюджет семьи у нас общий, ведется в разрезе "счетов" - например Кредитная карта, кошелек, шкатулка и т.д. Работает на платформе 8.3.13.1513

1 стартмани

19.11.2018    3080    1    vln    10       

Конфигурация "Дневник питания" 17

Конфигурация no Конфигурация (md, cf) v8 v8::УФ Домашние учет и финансы Россия Windows Абонемент ($m) Управленческий учет (прочее)

Учет ежедневного потребления калорий, изменений показателей веса и объемов тела.

1 стартмани

08.11.2018    12200    12    accounting_cons    27       

Анализ затрат по чекам онлайн 4

Отчеты и формы no Конфигурация (md, cf) v8 Домашние учет и финансы Россия УУ Финансовый учет и бюджетирование (FRP) Абонемент ($m) Управленческий учет (прочее)

Представлена конфигурация, позволяющая загружать чеки онлайн и анализировать расходы в разрезе поставщиков, товаров (категорий товаров), статей затрат. Конфигурация будет полезна тем, кто думает, а стоит ли планировать свои затраты? Используя данную конфигурация можно с минимальной ручной работой проанализировать свои повседневные расходы.

1 стартмани

14.10.2018    3930    3    ifal    2       

Конфигурация "Помощник системного администратора". Учет компьютеров и оргтехники на производстве 6

Отчеты и формы Системный администратор Программист Конфигурация (md, cf) v8 УУ Учет рабочего времени Учет ТМЦ Абонемент ($m) Управленческий учет (прочее)

Простая конфигурация для ведения учета оборудования по инвентарным номерам, учета движения оборудования, учет по заправкам картриджей, ремонту оргтехники. Последнее обновление 23.09.2019г.

2 стартмани

03.10.2018    4772    38    user811626    7       

Загрузка файлов/картинок/изображений/фото номенклатуры PRO 16

Инструменты и обработки Программист Пользователь Внешняя обработка (ert,epf) v8 v8::УФ Розница УНФ УТ11 Россия Оптовая торговля Розничная торговля Абонемент ($m) Управленческий учет (прочее)

Пожалуй, самая многофункциональная обработка для пополнения каталога. Сопоставление изображений с номенклатурой по артикулу, коду и подстроке; обновление/замена, удаление фото; установка основного изображения по расширению или по любой части наименования файла. Информация о файлах и результаты сопоставления с номенклатурой отображается в таблице. Для каждого изображения есть возможность предпросмотра. Процесс загрузки картинок отображается через прогресс-бар.

1 стартмани

03.08.2018    7330    61    zannv    18       

Автоматизация отдела продаж - CRM конфигурация для небольшой компании 11

Отчеты и формы Руководитель проекта Конфигурация (md, cf) v8 Россия УУ Управление взаимоотношениями с клиентами (СRM) Оптовая торговля Абонемент ($m) Управленческий учет (прочее)

Вам нужна несложная и многофункциональная автоматизированная система управления продажами для автоматизации отдела продаж? Наша CRM Система поможет Вам! Внедрение займет не более 15 минут. CRM Система - быстрая и безболезненная автоматизация отдела продаж. Без лишних затрат и сложностей. Интеграция с 1С Бухгалтерией 3 и 1С УТ 11.

1 стартмани

05.03.2018    11177    32    user718500    8       

Простой учет материалов на складах 4

Отчеты и формы Бухгалтер Пользователь Архив с данными v8 Россия УУ Учет ТМЦ Абонемент ($m) Управленческий учет (прочее)

Конфигурация 1С "Простой учет движения материалов" с небольшим примером. Будет полезна при любом учете материалов на производстве, где материально-ответственные лица учитывают поступления и расход материалов, имущества, инструментов и рассчитывают расход по норме.

1 стартмани

07.01.2018    7977    18    user883442    1       

Конфигурация для учета личных финансов 5

Отчеты и формы no Конфигурация (md, cf) v8 Домашние учет и финансы Россия УУ Финансовый учет и бюджетирование (FRP) Абонемент ($m) Управленческий учет (прочее)

Программа для учета личных финансов. Но кто знает может и подойдет для Малого бизнеса. Версия 1.0.1.10 Возможности: 1. Ведение счетов: наличка, карты. 1.1. Возможность в отчетности по остаткам не указывать счет для накоплений. 2. Статьи расходов 3. Статьи доходов. 4. Бюджеты расходов и доходов в разрезе месяцев. Учет финансовых целей.

3 стартмани

26.11.2017    8001    6    ra1ich    9       

Учёт IT-отдела ред.1.0 (Shareware) 9

Инструменты и обработки Системный администратор Программист Конфигурация (md, cf) v8 ИТ-компания УУ Учет ТМЦ Абонемент ($m) Управленческий учет (прочее)

Учёт IT-отдела, конфигурация подойдет для IT-отделов любой организации, основным ее назначением является "навести порядок" IT-отдела: иметь под рукой учет компьютеров, принтеров, картриджей, паролей пользователей (если в организации запрещено пользователям менять системные пароли на свои), регистрационных данных программного обеспечения и т.д.

5 стартмани

12.11.2017    10345    25    espero    7       

Учет портфеля ценных бумаг частных инвесторов 5

Отчеты и формы no Конфигурация (md, cf) v8 v8::ОУ Финансовые услуги, инвестиции Россия УУ Абонемент ($m) Управленческий учет (прочее)

Простая конфигурация для учета портфеля ценных бумаг частных инвесторов, основанная на БСП 2.4.3.40 и БИПП (Библиотека Интернет Поддержки Пользователей) 2.2.2.15.

1 стартмани

07.09.2017    8630    14    xan333    4       

2MS. Конфигурация для учёта данных о проектах и задачах 8

Отчеты и формы no Архив с данными v8 Россия УУ Windows Абонемент ($m) Управленческий учет (прочее)

2MS — это конфигурация, которая помогает мне работать над проектами и в жизни, так как я люблю фиксировать всё, что касается конкретной темы: ссылки, каталоги, различные заметки, сценарии пользователей и многое другое, — собираю это всё в одном месте. И потом, когда мне нужно, я могу быстро найти это среди структурированной информации.

1 стартмани

13.06.2017    7914    11    new1c    2       

Конфигурация "Идеальный рацион питания" 13

Отчеты и формы no Конфигурация (md, cf) v8 Домашние учет и финансы Абонемент ($m) Управленческий учет (прочее)

С помощью данной конфигурации вы сможете создать сбалансированный рацион питания, учитывающий ваш возраст, физическую активность на работе. Опираясь на данные химического состава продуктов разных источников(Скурихин, USDA и др.), вы сможете снабжать свой организм всеми необходимыми нутриентами.

1 стартмани

17.05.2017    9791    8    Lem0n    1       

Тестируем алгоритмы для торговых роботов срочного рынка РТС 13

Инструменты и обработки Программист Бизнес-аналитик Архив с данными v8 Финансовые услуги, инвестиции Россия УУ Займы, кредит, лизинг Абонемент ($m) Управленческий учет (прочее)

1С может много чего. И ее возможности давно вышли за рамки изначально задуманного. В качестве такого примера решил выложить конфигурацию для тестирования простой стратегии торговли фьючерсом на пару Доллар-Рубль на срочном рынке РТС.

1 стартмани

29.04.2017    7858    9    rrider    2       

Видеокурс "Пример автоматизации учета и планирования в холдинге. 1С:Управление Холдингом 8" 15

Курс Программист Бизнес-аналитик Пользователь Руководитель проекта Архив с данными v8 УХ УУ Финансовый учет и бюджетирование (FRP) Управление холдингом (CPM) Абонемент ($m) Управленческий учет (прочее) Бухгалтерский учет

Мультимедийный обучающий курс по конфигурации "1С:Управление Холдингом 8". Описание конфигурации ведется на основе сквозного примера автоматизации вирутальной группы компаний. Автор курса руководитель проектов ВЦ "Раздолье" Андрей Мироненко.

5 стартмани

17.03.2017    19953    68    1СERP    8       

Простой расчет квартплаты. Расчет и начисление коммунальных услуг и платежей для квартиросъемщиков 7

Отчеты и формы no Архив с данными v8 Энергетика и ЖКХ Домашние учет и финансы Россия УУ Windows Абонемент ($m) Управленческий учет (прочее)

Конфигурация предназначена для учета показаний счетчиков в квартире и для учета оплаты за оказанные ЖКХ услуги для квартиросъемщиков.

1 стартмани

15.03.2017    12597    11    vik2006    1       

Accost Of Car (Учет затрат на автомобиль) 4

Отчеты и формы no Архив с данными v8 1cv8.cf Автомобили, автосервисы Россия УУ Учет ТМЦ Абонемент ($m) Управленческий учет (прочее)

Конфигурация Учет затрат на автомобиль - помогает вести учет заправок и затрат на запчасти и ремонт.

3 стартмани

30.12.2016    9978    2    andrybar    2       

Учет компьютеров и оргтехники на предприятии 11

Отчеты и формы no Конфигурация (md, cf) v8 Россия УУ Windows Учет ТМЦ Абонемент ($m) Управленческий учет (прочее)

Бухгалтерский учет ТМЦ, инвентаря и основных средств это, конечно, очень хорошо. Но когда приходит время инвентаризации и данные бухгалтерского учета начинают не соответствовать фактическому наличию компьютера и оргтехники на рабочем месте сотрудника, то: - Бухгалтерия начинает "говорить" в свое оправдание, что ИТ- специалисты установили/ переместили/ изъяли оборудование с рабочего места МОЛа, не уведомив об этом бухгалтерию; - А ИТ- специалист начинает понимать поговорку, что без "бумажки" он букашка, а с "бумажкой" человек; Данная простейшая конфигурация призвана наладить учет у ИТ -специалистов, с передачей документов об изменении состава оборудования на рабочем месте МОЛа в бухгалтерию.

1 стартмани

14.10.2016    16071    72    Anson    3       

Минусы при расчете себестоимости в УПП и особенности решения СЛАУ 14

Отчеты и формы Программист Архив с данными v8 УПП1 Производство готовой продукции (работ, услуг) Учет ТМЦ Абонемент ($m) Управленческий учет (прочее)

В статье на примерах рассматривается, как в УПП при включенном РАУЗ решается система линейных алгебраических уравнений.

1 стартмани

21.09.2016    11887    1    Anashka    7       

Подсистема учёта дополнительных документов со внешним хранилищем присоединённых файлов 8

Отчеты и формы Бухгалтер Руководитель проекта Конфигурация (md, cf) v8 1cv8.cf УУ Документооборот и делопроизводство Абонемент ($m) Управленческий учет (прочее)

Подсистема предназначена для учета в информационной базе дополнительных документов, и хранения их отсканированных копий (и других файлов) во внешнем файловом хранилище. Все операции копирования файлов в файловое хранилище и генерации имен (путей сохранения) производятся автоматически (по одному из шаблонов) сервером приложения "1С Предприятия 8" под именем пользователя, под которым запущена служба. При такой схеме работы всем пользователям домена (или рабочей группы) можно отключить право "Просмотра" файловой структуру хранилища, а все операции над файлами производить исключительно средствами приложения "1С Предприятия 8".

1 стартмани

22.08.2016    9667    10    Glebis    2       

Простая конфигурация склада 4

Отчеты и формы no Конфигурация (md, cf) v8 Россия УУ Учет ТМЦ Абонемент ($m) Управленческий учет (прочее)

Простейший учёт оргтехники по подразделениям.

1 стартмани

10.08.2016    7161    17    shmax    1       

Учет и расчет выплат работникам за время прохождения медосмотров в программе «1С:ЗУП» редакции 2.5 9

Статья Программист Бухгалтер Архив с данными v8 ЗУП2.5 Россия БУ Зарплата Управление персоналом (HRM) Учет рабочего времени Абонемент ($m) Управленческий учет (прочее) Бухгалтерский учет

Основная идея публикации - собрать в одном месте методические указания по учету и расчету выплат работникам за время прохождения медосмотров в программе «1С:Зарплата и управление персоналом» редакции 2.5. После прочтения статьи вы узнаете: 1) варианты условных обозначений медосмотра в табеле учета рабочего времени; 2) как и зачем вести Журнал учета прохождения медосмотров; 3) как производить расчет медосмотра сотруднику, тонкости настройки видов расчета; 4) как массово рассчитать медосмотры сразу всем сотрудникам выбранного подразделения или всей организации; 5) влияние расходов на медосмотры на бюджет ФОТ; 6) как должны взаимодействовать заинтересованные подразделения при организации медосмотров. В статье описываются как типовой функционал, так и нетиповые возможности "1С: ЗУП" редакции 2.5.

1 стартмани

09.08.2016    30936    3    RailMen    9       

Резервирование ТМЦ в "1С:Управление небольшой фирмой" 36

Статья Бизнес-аналитик Руководитель проекта Нет файла v8 УНФ Россия УУ Производство готовой продукции (работ, услуг) Учет ТМЦ Абонемент ($m) Управленческий учет (прочее) Бухгалтерский учет

В статье рассматривается механизм резервирования ТМЦ в программе 1С: Управление небольшой фирмой 1.6. Описываются способы формирования резервов с использованием основных документов позаказного производства. На сквозном примере рассматривается движение резервов от заказа покупателя до итоговой отгрузки продукции.

1 стартмани

01.08.2016    35262    45    Artem-B    22       

Конфигурация учета ИТС 12

Отчеты и формы Программист Руководитель проекта Конфигурация (md, cf) v8 v8::УФ Россия Windows Абонемент ($m) Управленческий учет (прочее)

Бесплатная конфигурация: "Учет 1С:ИТС" на управляемых формах 8.3. Удобная конфигурация для оформления подписки ИТС прямо из платформы, реализована возможность сохранения заявки ИТС на диск в удобное для вас место и отправка заявки из программы. Нет необходимости хранить файлы Excel со множеством заявок в различных папках на компьютере, при оформлении подписки копировать все данные из формы в новую форму, теряя свое драгоценное время и нервы, все находится прямо в конфигурации. Формирование, сохранение заявки, анализ подписок и многое, многое другое и полезное в одной базе! Упрости свою жизнь в работе с подписками 1С:ИТС!

1 стартмани

27.07.2016    14385    66    nagaitseff    17       

Технопарк - Учет компьютерной техники 12

Отчеты и формы no Архив с данными v8 УУ Windows Учет ТМЦ Абонемент ($m) Управленческий учет (прочее)

Конфигурация “Технопарк” предназначена для ведения учета различного оборудования - компьютерной техники, запчастей, расходных материалов, и т.д., управления обращениями и ремонтами (ITIL), анализа сетевой инфраструктуры организации - пинг, сканирование портов , опрос SNMP устройств, сканирование конфигурации ПК а также для накопления и использования базы решений возникающих проблем.

1 стартмани

20.05.2016    14446    105    tav_74    5       

Конфигурация учета задач 10

Отчеты и формы no Конфигурация (md, cf) v8 Windows Абонемент ($m) Управленческий учет (прочее)

Примитивная конфигурация по учету задач в разрезе авторов, исполнителей, проектов. Может отправлять уведомления о задаче на эл. почту.

1 стартмани

07.05.2016    12161    34    alexdarh    19       

Учет выезда и въезда автотранспорта 17

Отчеты и формы no Архив с данными v8 Автомобили, автосервисы Транспорт, автопарки, такси УУ Windows Абонемент ($m) Управленческий учет (прочее)

Конфигурация создана для фиксирования данных по выезду и въезду автотранспорта на территорию предприятия. Можно использовать автономно для регистрации въезда и выезда транспорта с территории.

1 стартмани

08.04.2016    13164    28    Arkadiy_B    12       

Расширение для "1С:Деньги" (8.3) 7

Отчеты и формы no Расширение (cfe) v8 Домашние учет и финансы Россия Windows Абонемент ($m) Управленческий учет (прочее)

Небольшое расширение, которое отображает текущий курс и конвертирует по нему валюту в кошельке.

1 стартмани

24.02.2016    11332    5    Dr.Morris    5       

Торговля глазами ветврача. Оформление ветеринарно-сопроводительных документов в системе Меркурий (Часть 3) 10

Статья Бизнес-аналитик Бухгалтер Пользователь Архив с данными v8 Сельское хозяйство и рыболовство Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Пищевая промышленность Беларусь Россия Казахстан УУ Windows Учет ТМЦ Абонемент ($m) Управление бизнес-процессами (BPM) Управленческий учет (прочее)

Для торговой компании объясняется, как выполнять типовые операции в системе Меркурий. Зачем нужен Меркурий? C его помощью можно оформлять ветсвидетельства бесплатно. Уточните у руководства, сколько денег платите ветеринарам. Например, сеть Перекресток платит 400 млн. руб. в год.

5 стартмани

22.01.2016    48252    10    axxell    5       

Производство глазами ветврача. Оформление ветеринарно-сопроводительных документов в системе Меркурий (Часть 2) 22

Статья Программист Бухгалтер Архив с данными v7.7 v8 1С7:Комплекс УПП1 1С7:ПУБ Сельское хозяйство и рыболовство Пищевая промышленность Беларусь Россия Казахстан УУ Производство готовой продукции (работ, услуг) Учет ТМЦ Абонемент ($m) Управление бизнес-процессами (BPM) Управленческий учет (прочее) Бухгалтерский учет

Для предприятия по производству пищевых продуктов объясняется, как выполнять типовые операции в системе Меркурий. Зачем нужен Меркурий? C его помощью можно оформлять ветсвидетельства бесплатно. Уточните у руководства, сколько денег платите ветеринарам. Например, сеть Перекресток платит 400 млн. руб. в год.

5 стартмани

19.01.2016    71148    10    axxell    9       

Методическое пособие для микрофинансовых организаций "Учет займов с использованием системы 1С: Бухгалтерия 8 редакция 3.0" 4

Отчеты и формы Бухгалтер Курс v8 БП2.0 Финансовые услуги, инвестиции Россия БУ Windows Займы, кредит, лизинг Абонемент ($m) Управленческий учет (прочее) Бухгалтерский учет

Подробное иллюстрированное практическое руководство по учету привлеченных и выданных займов в микрофинансовых организациях в программе 1С:Бухгалтерия 8.

5 стартмани

06.01.2016    13101    8    irinik51    1       

Конфигурация для спортивных состязаний (8.3 управляемые формы) 3

Отчеты и формы no Конфигурация (md, cf) v8 Развлечения, искусство, спорт Windows Абонемент ($m) Управленческий учет (прочее)

Простая конфигурация, разработанная для соревнований по маунтин-байку. Может использоваться и для других циклических видов спорта, где основное - не время участника, а порядок прохождения финиша. Есть возможность учитывать кубковые очки. Программа не предназначена для официальных соревнований.

1 стартмани

14.09.2015    6642    6    Vlan    7       

Учет питания и нагрузок (Smooth & Simple Sport Food Edition) 4

Отчеты и формы no Конфигурация (md, cf) v8 Развлечения, искусство, спорт Абонемент ($m) Управленческий учет (прочее)

Данная разработка - улучшение существующей конфигурации Smooth&Simple Sport, ред. 1.1 http://infostart.ru/public/196533/ от fuxic, которую он любезно разрешил опубликовать. Доработка касается подробного учета содержания БЖУ (белки-жиры-углеводы), витаминов, микроэлементов и калорий в потребляемых продуктах.

1 стартмани

17.08.2015    10548    7    Synoecium    3       

Семейный бюджет (Такси) v1.1.1 9

Отчеты и формы no Конфигурация (md, cf) v8 Домашние учет и финансы Россия Windows Абонемент ($m) Управленческий учет (прочее)

Конфигурация "Семейный бюджет". Интерфейс Такси.

1 стартмани

21.07.2015    10797    20    Poyarkov696    9       

Притча о желтой коробке и «большой красной кнопке». Статья №1: Организация справочника «Статьи движения денежных средств». 27

Отчеты и формы Бизнес-аналитик Бухгалтер Пользователь Внешняя обработка (ert,epf) v8 УПП1 УУ Учетная политика Абонемент ($m) Управленческий учет (прочее)

Выполнение проекта автоматизации на любом предприятии неизбежно меняет почти все управленческие процессы, в том числе, разумеется, и процесс, который называется «управленческий учет». После появления первых релизов типовых конфигураций на платформе «1С: Предприятие 8» в них стали явно заметны объекты, предназначенные для организации управленческого учета. Вместе с ними появились и дискуссии о том, что такое управленческий учет в условиях функционирования на предприятии автоматизированной системы и как именно нужно этот самый учет автоматизировать. Что такое управленческий учет до автоматизации? Он выглядит, как несколько таблиц, к которым «прилагаются» специалисты, в функции которых входит собирание данных из разных источников (информационные базы систем бухгалтерского учета, ручные записи, другие таблицы), интерпретация этих данных c точки зрения целей управленческого учета, сведение их в таблицы и предоставление руководству для принятия решений. Я пишу об этом так подробно чтобы продемонстрировать следующий тезис – как правило, методология управленческого учета не существует в форме написанных документов, а существует в форме знаний и навыков конкретных людей. Проще говоря, есть данные в первичном состоянии, есть уже обработанные и сведенные в таблицу (конечный результат), и есть человек, который знает, как из первого сделать второе. Человек есть, а правил нет. Во всяком случае, их нет в виде достаточном для автоматизации. Это стартовая точка, с которой, обычно приходится начинать консультантам по автоматизации управленческого учета. Эта серия статей - попытка осмысления коллективного практического опыта специалистов ООО «ПРОКОМ» полученного в ходе проектов автоматизации.

1 стартмани

30.06.2015    25226    26    cso_procom    9       

Конфигурация, позволяющая вести учет личных доходов и расходов. 5

Отчеты и формы no Конфигурация (md, cf) v8 1cv8.cf Домашние учет и финансы Абонемент ($m) Управленческий учет (прочее)

В своей книге "Думай как миллионер" Харв Экер обращает внимание читателей на то, как мы обращаемся со своими деньгами. Основой служит идея о том, что каждый доллар (рубль) должен быть правильно распределен. Для себя он вывел список "счетов" между которыми, в соответствии с установленными процентами, распределяется любая сумма, которая есть в данный момент в распоряжении. Да, согласен, иногда бывает ощущение, что и распределять особо нечего, но поверьте мне это не так. Автор книги утверждает, и я с ним полностью согласен, когда у вас есть хотя бы одни доллар (рубль) - распределите его, часть отложите на виртуальный "счет долгосрочных сбережений", часть на "счет ежедневных расходов", часть на "счет благотворительности" и так далее. Конфигурация позволит Вам создать любое количество подобных счетов, указать процент распределения для этих счетов. Конфигурация позволит Вам в реальном времени видеть остатки этих счетов, что позволит Вам планировать свой бюджет, свои долгосрочные покупки, и в итоге, на что я очень надеюсь, позволит Вам стать миллионерами. Удачи!

1 стартмани

25.06.2015    4879    8    TOKAPEB    5       

Регистрация и согласование договоров, редакция 2.0 6

Отчеты и формы Пользователь Архив с данными v8 УУ Windows Документооборот и делопроизводство Абонемент ($m) Управленческий учет (прочее)

Конфигурация "Регистрация и согласование договоров" является готовым решением для управления и учета договоров на предприятии. Позволяет организовать единую информационную систему регистрации и согласования. Включает CRM подсистему.

1000 руб.

26.05.2015    13761    18    5       

Приемная руководителя, редакция 1.1 23

Инструменты и обработки Пользователь Конфигурация (md, cf) v8 Windows Документооборот и делопроизводство Абонемент ($m) Управленческий учет (прочее)

Приемная руководителя, редакция 1.1. Конфигурация на управляемых формах (интерфейс - Такси) с открытым кодом, создана для секретарей.

1500 руб.

19.05.2015    22764    21    6       

CRM "Управление контактами" 4

Отчеты и формы Пользователь Архив с данными v8 Windows Управление взаимоотношениями с клиентами (СRM) Абонемент ($m) Управленческий учет (прочее)

Иногда в компании приходит момент, когда информации о клиентах становится много, и сложность её запоминания заставляет искать средства для хранения списка клиентов (контактов). Для этого как нельзя лучше подходит 1С. Я понимаю, что многие из пользователей уже сталкивались с большими конфигурациями для учета клиентских данных, но для меня они не подходили из-за своих размеров. При обучении клиентов у меня просто сложилось впечатление, что пора сделать свою, пусть и небольшую, но конфигурацию для управления контактами клиентов. И именно это я и решил сделать. Обновление: 2.0!

2 стартмани

11.05.2015    11748    19    yarsort    5       

Подсистема "Выдача пропусков и система учета" 13

Отчеты и формы no Конфигурация (md, cf) v8 1cv8.cf Windows Абонемент ($m) Управленческий учет (прочее)

Данная подсистема может использоваться и как отдельная конфигурация, и в качестве блока для основной конфигурации. Система позволяет производить регистрацию и выдачу пропусков.

1 стартмани

08.05.2015    20568    24    GATTUSO    8       

Управление заявками пользователей (Service Desk). Платформа 8.3.12.1595. Управляемый интерфейс 45

Отчеты и формы Пользователь Руководитель проекта Конфигурация (md, cf) v8 v8::УФ УУ Windows Управление взаимоотношениями с клиентами (СRM) Абонемент ($m) Управленческий учет (прочее)

Управление заявками пользователей (Service Desk). Конфигурация разработана на управляемых формах с использованием бизнес-процесса.

1 стартмани

07.05.2015    15379    181    MaxCreator    6