Универсальные формы ввода даты, числа, строки, Виртуальная клавиатура, форма выбора из списка (для сенсорных экранов). Управляемые и обычные формы.

Публикация № 918580 20.11.18

Разработка - Работа с интерфейсом

Сенсорный экран Универсальная форма ввода Редактирование чисел дат. Виртуальная клавиатура. Форма выбора из списка программное создание кнопок

Универсальные формы ввода даты, числа, строки, Виртуальная клавиатура, форма выбора из списка. Данные формы используется на сенсорных экранах или когда обычный ввод даты неудобен.

Любая форма используется как общая, для скачивания помещена в обработку. Форму из обработки необходимо поместить в общие формы, для удобства создать в общем модуле процедуру, аналогичную указанной в примере.

Работает на любой конфигурации, формы и обычные и управляемые, мы тестировали на УПП 1.3 (обычные) и на ERP 2.5 (управляемые).

Как пользоваться: вы хотите выбирать значение через эту форму, подменяете процедуру выбора этого значения на процедуру общего модуля (пример ниже), при необходимости передаете туда значение для редактирования (если это не ввод нового значения), после работы с формой нужно обработать результат - вам вернется выбранное значение, если пользователь отказался, то вернется "Неопределено".


///////////// УПРАВЛЯЕМЫЕ ФОРМЫ /////////////
 
// Ввод числа
&НаКлиенте
Процедура ВесБруттоНачалоВыбора
	ОписаниеЗакрытия = Новый ОписаниеОповещения("ОповещениеВводВесБрутто",ЭтаФорма);
	МК_КалькуляторыКлиент.КалкВвестиЧисло(ЭтаФорма, ОписаниеЗакрытия, НашеЧисло);
КонецПроцедуры

// Вводит число через обработку для сенсорного экрана
//
// Параметры:
//  ФормаВладелец  		- Форма - Форма источник
//  ОповещениеЗакрытия  	- ОписаниеОповещения - Описание оповещения при закрытии формы
//  НачальноеЗначение  		- Число - Исходное число для редактирования
//
Процедура КалкВвестиЧисло(ФормаВладелец, ОповещениеЗакрытия, НачальноеЗначение = 0, Заголовок = "") Экспорт
	
	ОткрытьФорму("ОбщаяФорма.МК_ВводЧисла", 
	Новый Структура("НачальноеЗначениеВводаЧисла, Заголовок", НачальноеЗначение, Заголовок),
	ФормаВладелец,
	,
	ВариантОткрытияОкна.ОтдельноеОкно,
	,
	ОповещениеЗакрытия,
	РежимОткрытияОкнаФормы.БлокироватьВесьИнтерфейс);	
	
КонецПроцедуры // КалкВвестиЧисло()

// Ввод даты
&НаКлиенте
Процедура ВыбратьДату(Команда)	
	ОписаниеЗакрытия = Новый ОписаниеОповещения("ОповещениеВыбораДаты",ЭтаФорма);
	МК_КалькуляторыКлиент.КалкВвестиДату(ЭтаФорма, ОписаниеЗакрытия, Объект.ДатаВыработки);	
КонецПроцедуры

// Вводит дату через обработку для сенсорного экрана
//
// Параметры:
//  ФормаВладелец  		- Форма - Форма источник
//  ОповещениеЗакрытия  	- ОписаниеОповещения - Описание оповещения при закрытии формы
//  НачальноеЗначение  		- Дата - Исходная дата для редактирования
//
Процедура КалкВвестиДату(ФормаВладелец, ОповещениеЗакрытия, НачальноеЗначение = 0) Экспорт
	
	ОткрытьФорму("ОбщаяФорма.МК_ВводДаты", 
	Новый Структура("ДатаОтсчета", НачальноеЗначение),
	ФормаВладелец,
	,
	ВариантОткрытияОкна.ОтдельноеОкно,
	,
	ОповещениеЗакрытия,
	РежимОткрытияОкнаФормы.БлокироватьВесьИнтерфейс);	
	
КонецПроцедуры // КалкВвестиЧисло()


///////////// ОБЫЧНЫЕ ФОРМЫ ///////////// 

// Ввод строки
Процедура Пример

СтрокаДляРедактирования = "Тест";

СтрокаДляРедактирования = НастройкиФорм.ВводСтроки(СтрокаДляРедактирования);

КонецПроцедуры


// Открывает форму интерактивного ввода строки
//
// Параметры:
//  Строка - Строка
//              строка для редактирования
Функция ВводСтроки(Строка = Неопределено) Экспорт
        
    Если Строка = Неопределено Тогда
        Строка = "";
    КонецЕсли;
    
    ФормаСтрока = ПолучитьФорму("ОбщаяФорма.МК_ФормаВводаСтроки");
    ФормаСтрока.Строка = Строка;
    Строка = ФормаСтрока.ОткрытьМодально();
    
        Возврат Строка;
    
КонецФункции

// Ввод числа
Процедура Пример

ЧислоДляРедактирования = 124;

ЧислоДляРедактирования = НастройкиФорм.ВводЧисла(ЧислоДляРедактирования );

КонецПроцедуры


// Открывает форму интерактивного ввода числа
//
// Параметры:
//  Число - Число
//             число для редактирования
Функция ВводЧисла(Число = Неопределено) Экспорт

    Если Число = Неопределено Тогда
        Число = 0;
    КонецЕсли;
    
    ФормаЧисла = ПолучитьФорму("ОбщаяФорма.МК_ФормаВводаЧисла");
    ФормаЧисла.Число = Число;
    Число = ФормаЧисла.ОткрытьМодально();
    
    Возврат Число;
    
КонецФункции


// Ввод даты
Процедура Пример

ДатаДляРедактирования = ТекущаяДатаСеанса();

ДатаДляРедактирования = НастройкиФорм.ВводДаты(ДатаДляРедактирования);

КонецПроцедуры

// Открывает форму интерактивного ввода даты
//
// Параметры:
//  Дата - Дата
//             дата для редактирования
Функция ВводДаты(Дата = Неопределено) Экспорт
        
    Если Дата = Неопределено ИЛИ НЕ ЗначениеЗаполнено(Дата) Тогда
        Дата = ТекущаяДатаСеанса();
    КонецЕсли;
    
    ФормаДаты = ПолучитьФорму("ОбщаяФорма.ФормаВводаДаты");
    ФормаДаты.ТекущаяДата = Дата;
    Дата = ФормаДаты.ОткрытьМодально();
    
    Возврат Дата;
        
КонецФункции

// Выбор из списка
Процедура Пример

СписокВозврата = Новый СписокЗначений;

Запрос = Новый Запрос;
Запрос.Текст =
        "ВЫБРАТЬ
        |    Склады.Ссылка КАК Ссылка,
        |    Склады.Наименование КАК Наименование
        |ИЗ
        |    Справочник.Склады КАК Склады
        |ГДЕ
        |    НЕ Склады.ПометкаУдаления
        |
        |УПОРЯДОЧИТЬ ПО
        |    Наименование";
   
РезультатЗапроса = Запрос.Выполнить();   
ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
    
Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
    СписокСкладов.Добавить(ВыборкаДетальныеЗаписи.Ссылка, СокрЛП(ВыборкаДетальныеЗаписи.Наименование));
КонецЦикла;

ПеремещениеТекущийСклад = НастройкиФорм.ВыбратьИзСписка(СписокСкладов, 2);

КонецПроцедуры

// Открывает форму интерактивного выбора из списка
//
// Параметры:
//  СписокВыбора - СписокЗначений - Список из которого нужно выбрать
//  РежимРаботы - Число - Вариант отображения: 1 - в один столбец, 2 - в два столбца
//
Функция ВыбратьИзСписка(СписокВыбора, РежимРаботы) Экспорт
        
    ФормаВыбораИзСписка = ПолучитьФорму("ОбщаяФорма.ФормаВыбораИзСписка");
    ФормаВыбораИзСписка.СписокВыбора     = СписокВыбора;
    ФормаВыбораИзСписка.РежимРаботы     = РежимРаботы;
    ВыбранноеЗначение = ФормаВыбораИзСписка.ОткрытьМодально();
    
    Возврат ВыбранноеЗначение;
    
КонецФункции

 

Скачать файлы

Наименование Файл Версия Размер
Универсальная форма ввода даты (для сенсорных экранов):

.epf 269,02Kb
2
.epf 269,02Kb 2 Скачать
Универсальная форма ввода числа (для сенсорных экранов):

.epf 27,18Kb
7
.epf 27,18Kb 7 Скачать
Виртуальная клавиатура.Универсальная форма ввода строки (для сенсорных экранов):

.epf 29,82Kb
4
.epf 29,82Kb 4 Скачать
Универсальная форма выбора из списка (для сенсорных экранов):

.epf 213,00Kb
3
.epf 213,00Kb 3 Скачать
Управляемая Форма. Универсальная форма ввода числа (для сенсорных экранов):

.epf 9,85Kb
1
.epf 9,85Kb 1 Скачать
Управляемая Форма. Универсальная форма ввода даты (для сенсорных экранов):

.epf 25,06Kb
0
.epf 25,06Kb Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. yarsort 21.11.18 15:22 Сейчас в теме
В окне выбора значения надо заголовок подправить: "Выберите значение".
2. Izumov 7 21.05.19 09:03 Сейчас в теме
(1)
В окне выбора значения надо заголовок подправить: "Выберите значение".

С грамматикой проблема, извиняюсь :)
3. vlad636 3 17.03.21 10:44 Сейчас в теме
Приветствую. Проблемы с вводом числа. Попробуйте ввести например 0,708. Второй ноль не вводится, т.к. там явное преобразование строки в число, соответственно 0,70 преобразуется в 0,7, как обойти?
4. Izumov 7 18.03.21 10:45 Сейчас в теме
(3) Исправил. Обработку обновил.

Или сами поправьте у себя:
Процедура "ЦифраНажатие(Элемент)"
Меняем Число = Число(Строка(Число) + Строка(Добавить));
на Число = Строка(Число) + Строка(Добавить);
5. vlad636 3 18.03.21 10:52 Сейчас в теме
6. vlad636 3 15.04.21 11:15 Сейчас в теме
Приветствую еще раз. Теперь проблемы с выбором из списка.
Ошибка при вызове метода контекста (ЗаполнитьЗначенияСвойств)
		ЗаполнитьЗначенияСвойств(НоваяКнопка, ШаблоннаяКнопка, , "Данные, ИсточникДействий, Видимость");
по причине:
Ошибка установки значения свойства 'Имя'
по причине:
Не уникальное имя!
7. Izumov 7 19.05.21 16:38 Сейчас в теме
(6) Вы одинаковые значения передали в выбор? Они должны быть уникальны, там кнопки создаются.
8. vlad636 3 20.05.21 03:14 Сейчас в теме
(7) Решил вопрос, даже не помню уже что там было
Оставьте свое сообщение

См. также

Альтернативный способ добавления элементов и реквизитов на формы Промо

Работа с интерфейсом v8 ERP2 УТ11 Россия Абонемент ($m)

Предлагаю альтернативный вариант добавления динамически создаваемых элементов и реквизитов на форму.

1 стартмани

09.09.2019    15634    30    bmk74    6    

Интерактивная справка по объектам 1С (подключаемое расширение)

Практика программирования Работа с интерфейсом v8 ERP2 Абонемент ($m)

База знаний, подключаемая к объектам основной базы. Пополняется интерактивно, формируется в виде статей прямо в 1С (текст, картинки, таблицы, ссылки). Есть возможность прикрепления файлов, привязки к объектам 1С, возможности рейтинга и комментирования пользователями.

3 стартмани

29.09.2020    12945    73    sapervodichka    43    

Визуальный html WYSIWYG редактор без сторонних библиотек на управляемых формах

Прочие инструменты разработчика Работа с интерфейсом v8 v8::УФ 1cv8.cf Абонемент ($m)

Простой и удобный html редактор без сторонних библиотек.

1 стартмани

31.08.2020    6602    10    ivanov660    12    

Открыть форму внутри другой формы - наконец-то возможно!

Работа с интерфейсом v8::УФ Абонемент ($m)

Я давно мечтал о возможности открытия форм 1С внутри других форм, мне время от времени попадаются задачи, где это бы пригодилось. И вот в версии 8.3.16 наконец-то это можно реализовать! Конечно, это не совсем то, что я ожидал, но получилось все равно интересно. Давайте посмотрим.

1 стартмани

15.04.2020    18043    24    CyberCerber    65    

Менеджер открытых форм Промо

Работа с интерфейсом v8::УФ 1cv8.cf Абонемент ($m)

Обработка получает информацию об открытых формах и позволяет ими манипулировать.

1 стартмани

13.04.2017    23908    39    SeiOkami    19    

Делаем из СКД Excel (ну, почти)

Работа с интерфейсом v8 Абонемент ($m)

Несложный в использовании способ внедрить в обычный отчет СКД возможность редактировать значения ресурсов отчета (а-ля Excel) и получать отредактированные значения для дальнейшей обработки.

1 стартмани

26.01.2020    13196    21    herfis    16    

Индикация прогресса выполнения фонового задания на управляемой форме внешней обработки

БСП (Библиотека стандартных подсистем) Работа с интерфейсом v8 v8::УФ 1cv8.cf Абонемент ($m)

Внешняя обработка с фоновым выполнением и индикацией процесса для любой конфигурации на основе БСП >= 2.3 без изменения конфигурации и встраивания обработки в "Дополнительные отчеты и обработки".

1 стартмани

27.12.2019    16665    31    1sig    14    

Декомпиляция условного оформления

Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Обработка автоматически генерирует полный код создания условного оформления формы любой сложности. Достаточно настроить для формы в конфигураторе условное оформление, а затем выбрать данную форму в обработке. В результате будет сгенерирован программный код создания условного оформления.

2 стартмани

23.12.2019    10251    48    XilDen    7    

Расширенная настройка динамического списка УФ Промо

Работа с интерфейсом v8 v8::УФ 1cv8.cf Абонемент ($m)

Открывая управляемую форму выбора и не увидев там видимых в форме списка элементов, часто хочется узнать причину их отсутствия там, т. е. какой наложен отбор. Но стандартная настройка списка управляемой формы показывает только пользовательские настройки, скрывая от пользователя фиксированный отбор. Предлагаю вам расширение конфигурации с расширенной настройкой динамического списка, отображающей пользователю кроме пользовательских настроек еще фиксированные.

1 стартмани

31.05.2017    37129    161    tormozit    25    

Многоуровневые списки выбора с оформлением элементов

Практика программирования Работа с интерфейсом v8 v8::УФ 1cv8.cf Абонемент ($m)

Данная статья - попытка решить один маленький кусочек большой проблемы платформы 1С, а именно - бедные и невыразительные пользовательские интерфейсы. Поскольку 1С в режиме управляемого приложения позволяет задействовать веб-клиент, то хочется реализовывать интерфейсы как у взрослых веб-приложений - красивые, дружелюбные для пользователя и, желательно, с положительным UX. Возможно, кто-то со мной не согласится и скажет, что учетные системы должны быть строгие и линейные. Но мы все знаем, что 1С - это уже не только про бухгалтерию. Небольшое отступление для разработчиков, работающих с типовыми конфигурациями. Я не знаю, использует ли фирма 1С что-то похожее в своих разработках. Если да, то данная статья навряд ли будет вам полезна.

1 стартмани

17.12.2019    11292    2    azhilichev    5    

[Взрыв шаблона!] Новый способ программной настройки условного оформления

Работа с интерфейсом v8::УФ 1cv8.cf Абонемент ($m)

Условное оформление форм и списков это великолепная возможность их настройки по заданным условиям. Но существенным недостатком является трудоемкость написания и сопровождения программного кода. В публикации предлагается новый способ программной настройки условного оформления.

1 стартмани

01.12.2019    16433    48    mszsuz    12    

Удобный выбор из таблицы/дерева в УФ

Практика программирования Работа с интерфейсом Разработка v8 v8::УФ 1cv8.cf Абонемент ($m)

Выбор из таблицы значений или дерева значений в выпадающем списке рядом с полем ввода - УФ, быстро и просто!

1 стартмани

12.08.2019    16730    8    Yashazz    18    

Открывашка ячеек таблиц Промо

Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Глобальное сочетание клавиш для открытия объекта по ссылке из текущей ячейки любой таблицы в большинстве управляемых форм

1 стартмани

27.10.2018    20632    12    tormozit    31    

[Механизм интерфейса] Свой флажок (чекбокс)

Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Создадим свой флажок для интерфейса, используем простой универсальный алгоритм.

1 стартмани

09.08.2019    20139    20    rpgshnik    43    

Отбор на управляемой форме из списка значений

Практика программирования Работа с интерфейсом Разработка v8 v8::УФ 1cv8.cf Абонемент ($m)

Пример простого удобного отбора любых данных ссылочного типа на управляемой форме. Работа обработки проверена на релизе: 1С:Предприятие 8.3.13.1513.

1 стартмани

09.08.2019    27625    28    nagaitseff    6    

Программное добавление элементов на управляемую форму

Работа с интерфейсом v8::УФ 1cv8.cf Россия Абонемент ($m)

Пример добавления Команд, Полей ввода, Групп, Страниц, Реквизитов, Обработчиков событий.

1 стартмани

13.02.2019    66563    38    spec8s    22    

Расширение: Темы для 1С 8.3 Промо

Работа с интерфейсом v8::УФ 1cv8.cf Абонемент ($m)

Расширение позволяет сменить цвет оформления для интерфейса Такси.

1 стартмани

10.02.2019    21089    123    spec8s    19    

Виртуальная (экранная) клавиатура для управляемых форм

Инструментарий разработчика Работа с интерфейсом v8 v8::УФ 1cv8.cf Абонемент ($m)

Предлагаю свой вариант виртуальной клавиатуры для использования в разработках, предполагающих использование сенсорного ввода.

1 стартмани

14.12.2018    16395    74    asdfgcom    16    

Рисуем и распознаем нарисованное при помощи нейросети

Практика программирования Работа с интерфейсом v8 v8::УФ 1cv8.cf Абонемент ($m)

Используем нейронную сеть для распознавания нарисованных объектов.

1 стартмани

03.10.2018    17133    45    DO_WHILE_LOOP    28    

Рисуем диаграммы в metadata.js

Инструментарий разработчика Работа с интерфейсом v8 v8::СКД 1cv8.cf Абонемент ($m)

Не одной же литературой заниматься?

1 стартмани

20.09.2018    20320    4    1c-intelligence    77    

Лучший подарок для бухгалтера - счёты 8.2 (со звуком) Промо

Работа с интерфейсом v8 1cv8.cf Россия Абонемент ($m)

(Толстый клиент) Подарите бухгалтеру счеты, и он(а) Вас никогда не забудет.

1 стартмани

13.05.2011    43375    923    Tatitutu    45    

Продвинутое рисование в табличном документе (стрелок и не только)

Практика программирования Работа с интерфейсом v8 Абонемент ($m)

Вспоминаем геометрию и основы компьютерной графики. Матрицы и аффинные преобразования на плоскости.

1 стартмани

24.07.2018    19145    20    WalterMort    30    

Работа с данными выбора

Практика программирования Работа с интерфейсом v8 Россия Абонемент ($m)

В управляемом интерфейсе заложена мощная возможность описывать связи реквизитов формы через параметры. Установка параметров связей позволяет ограничить выбор данных так, чтобы целостность данных была обеспечена на этапе ввода. Однако без дополнительного программирования задать можно только самые простые связи. Такие условия связи, как зависимость от реквизита через точку или зависимость через дополнительное отношение, заданное в регистре сведений - уже задать без программирования не получится.

1 стартмани

17.07.2018    61962    24    kalyaka    17    

Иерархическая диаграмма

Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Концепция диаграммы по иерархической структуре данных, например по номенклатуре (продажи или остатки на складах).

2 стартмани

17.06.2018    17224    19    DrAku1a    6    

Визуализация событий на временной шкале средствами "Поле HTML документа" Промо

Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Интересный способ наглядно отобразить события на временной шкале. Например, может быть применен для красивого вывода документов по клиенту. Тестировалось на платформе 8.3.12.1469

1 стартмани

31.07.2018    27382    145    Plotks2017    27    

Рисуем стрелки в табличном документе

Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Рисуем стрелки средствами 1С .

1 стартмани

01.06.2018    18077    9    pm74    9    

Программная работа с графическими схемами. Готовое решение

Инструментарий разработчика Универсальные обработки Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Работоспособное, проверенное на практике, простое и удобное программное управление графическими схемами.

1 стартмани

18.02.2018    21900    24    Yashazz    13    

Тестирование интерфейса в обычном приложении 8.2 при помощи SikuliX

Инструментарий разработчика Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Как же не хватает клиента тестирования на платформе 8.2. Не кликнешь на кнопку, не выберешь из списка, не проверишь видит ли надпись пользователь. Воспользуемся внешним инструментом SikuliX, который позволит нам протестировать функционал форм. Данный инструмент легко встраивается в линию сборки и может "дружить" с уже известным многим Open-source продуктами.

1 стартмани

03.01.2018    33946    5    kraynev-navi    42    

Интерактивный интерфейс Промо

Рабочее место Работа с интерфейсом v8 1cv8.cf Россия Абонемент ($m)

Обработка (отдельная панель меню), позволяющая настраивать интерфейс пользователя интерактивно (права не настраивает). Мне очень пригодилось, так как приходится прописывать индивидуальный интерфейс, каждому пользователю (а их уже сотни). Выложил 2 версии одна в виде таблицы, вторая в виде выпадающего меню

1 стартмани

29.10.2011    20565    65    Vin_Tik    9    

Программное формирование форматированной строки в стиле html+inline CSS

Работа с интерфейсом Инструментарий разработчика v8 1cv8.cf Абонемент ($m)

Если вам приходилось работать с форматированными строками программно, то вы знаете, какая это боль. Данное решение облегчает программное формирование таких строк.

1 стартмани

18.11.2017    39505    44    bonv    11    

Программное создание элементов графической схемы (через XSLT)

Практика программирования Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Встала как-то передо мной задача визуализировать определенный прикладной процесс, лучше всего для этого подходит графическая схема. Так уж вышло, что 1С по не понятным мне причинам не предоставила возможность программно работать с элементами графической схемы. Пришлось импровизировать.....

1 стартмани

20.07.2017    24238    68    lazarenko    19    

Управляемые формы. Итоги в динамических списках

Универсальные обработки Работа с интерфейсом v8::УФ 1cv8.cf Россия Абонемент ($m)

Многие задаются вопросами расчета итогов динамических списков в управляемых формах. Здесь мы не будем претендовать на академичность, оставим споры, что мол это не нужно, что это все равно что считать бородатых мужиков на движущемся эскалаторе, что это дополнительная нагрузка. Все это понимают, Кто не понимает - поймет на практике. Поэтому основываемся на... "снегопад, снегопад, если женщина просит..." или "..а мня плевать - мне очень хочется.." Я попытался решить практические проблемы при расчете и выводе итогов. В приложении примеры расчета итогов в иерархическом справочнике и журнале документов.

1 стартмани

15.12.2016    44401    13    argut    16    

Цветовые схемы для конфигуратора 1С (Популярные цветовые схемы для C# - теперь и для 1С) (Теперь 8.2 - 8.3) Промо

Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Тёмные цветовые схемы кода. То, что было доступно всем передовым средствам разработки, теперь доступно и на 1С. 13.12.17 UPD: Теперь работает с платформой 8.3

3 стартмани

07.10.2013    41544    178    Chernov_Dmitriy    82    

Простой редактор плана помещения JavaScript

Практика программирования Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

На ресурсе сейчас очень много решений, которые позволяют редактировать карты, используя географические схемы. Так же много решений, которые позволяют редактировать объекты онлайн веб-карт. Мне же нужно было простое решение, для того чтобы расставить квадратные объекты на плане, показать их пользователю. Ну и распечатать, опять же. Я решил написать простенький редактор на JavaScript с использованием библиотеки Raphael.

1 стартмани

23.11.2016    25357    103    igel9780    22    

Настройка начальной страницы (Рабочего стола)

Работа с интерфейсом Рабочее место Универсальные обработки v8 1cv8.cf Абонемент ($m)

Альтернатива стандартной настройке начальной страницы. В типовой доступны лишь те формы, что явно "разрешены" разработчиком в режиме конфигуратора. Эта обработка позволяет собрать "Рабочий стол" из любых подходящих форм в пользовательском режиме. Без программирования. БСП не используется. Не расширение. Универсальна, т.е. подойдет для любой конфигурации (в т.ч. самописной).

2 стартмани

19.10.2016    42897    242    Erne100    30    

[Расширение] Стартовые страницы. Автозапуск форм при старте 1С. (8.3.9+, без доработки конфигурации)

Инструментарий разработчика Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Уверен, что в большинстве случаев список справочников, отчетов, обработок (объектов 1С в целом), к которому обращаются пользователи после запуска конфигурации 1С, раз от раза меняется не сильно. Так почему бы немного не упростить процесс открытия часто используемых форм? Данное расширение позволяет настроить автоматическое открытие различных форм объектов сразу после запуска 1С. Список форм настраивается индивидуально для каждого пользователя. Работает на платформе 8.3.9, без доработки конфигурации.

1 стартмани

03.10.2016    24214    91    Artem-B    20    

NativeDraw: Компонента рисования для 1С [V2.6.2] Промо

Разработка внешних компонент Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Рисуйте в формах 1С, также предлагается небольшое количество нерисовальных функций

1 стартмани

13.07.2015    51421    469    ПерваяСистема    147    

Конструктор условного оформления

Инструментарий разработчика Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Иногда требуется сделать отчет, который бы содержал в себе множество показателей. В таком случае в получившейся "портянке" показатели сливаются. Как один из вариантов решения (ну, кроме упрощения отчета) можно рассматривать раскраску показателей в индивидуальные цвета. После нескольких подобных случаев (особенно, когда в уже готовый отчет добавляются или убираются поля) сделал обработку, которая позволяет в режиме предприятия быстро подготовить болванку условного оформления для подобных отчетов.

1 стартмани

27.09.2016    19452    16    Fragster    7    

HTTP-сервис: отчеты [Расширение]

Практика программирования Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Это HTTP-сервис, который возвращает почти любой отчет в HTML, XLSX или в JSON. Сохраните вариант отчета, получите на него ссылку и можно получить данные без захода в 1С. Работает в конфигурациях на основе БСП 2.3.3+, для отчетов на СКД и в 1С 8.3.8+

2 стартмани

30.08.2016    31876    147    Stepa86    15    

Механизм доп. реквизитов и сведений

Практика программирования Работа с интерфейсом v8 БП2.0 Абонемент ($m)

Как к новому справочнику подключить механизм дополнительных реквизитов и сведений

2 стартмани

23.06.2016    32292    36    piffoff    19    

Подборка иконок для подсистем 1С:8.2, 8.3 (740 шт.) PNG 48х48 Промо

Практика программирования Работа с интерфейсом v8 1cv8.cf Россия Абонемент ($m)

Подборка иконок для подсистем 1С: Предприятие 8.2, 8.3 (УП) в формате PNG 48*48 с сохранением прозрачности.

5 стартмани

19.12.2011    114393    1240    Lesha1C    74    

Блокировка баннеров при помощи расширения

Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Примеры использования расширений

1 стартмани

09.06.2016    16260    12    oslokot    16    

Простые радости жизни программиста 1С: выбор типа значения

Работа с интерфейсом Практика программирования v8 1cv8.cf Абонемент ($m)

Предлагаемая в работе обработка включает обычную и управляемую формы, которые максимально точно реализуют функциональность системного диалога выбора типа в толстом клиенте обычное приложение (включая оформление диалога). Эти формы имеют дополнительные интерфейсные удобства и могут быть использованы в качестве альтернативных диалогов выбора типа.

1 стартмани

17.02.2016    56824    56    yuraos    18    

Визуальный редактор цветовых схем подсветки синтаксиса 1С + импорт схем Visual Studio

Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Данная обработка призвана облегчить настройку рабочего места программиста 1С, а именно улучшить визуальное восприятие кода, уменьшить утомляемость, и, как следствие, увеличить общую производительность труда!

1 стартмани

29.01.2016    18140    82    ram3    27    

Возможности перетаскивания, примеры использования, помощь в понимании и отладке механизма работы (8.3, управляемые формы)

Практика программирования Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Механизм перетаскивания используется редко, а ведь его использование может помочь в реализации интуитивно понятных функций, которые могут весьма ускорить работу пользователя, и получить в итоге более дружественный интерфейс. Данная обработка не содержит копированного из Синтакс-Помощника текста (его вы сможете прочитать и сами). Она показывает примеры использования перетаскивания; позволяет прямо в режиме Предприятия протестировать, проверить и отладить основные приёмы работы; понять принцип вызова событий и увидеть состав их параметров.

1 стартмани

17.11.2015    40134    105    Alias    17