IE2017

Виртуальная клавиатура поиска по таблице 1Сv8.2

Программирование - Практика программирования

Для тонкого клиента. Обработка сделана для сенсорного экрана. Осуществляет ввод строки и поиск по строке в исходной таблице для последующего выделения нужной строки. Легко может быть переделана под конкретную задачу!

Для работы необходимо добавить её в конфигурацию и сделать вызов:

&НаКлиенте

Процедура НайтиПоТаблицеТовары(Команда)

ФормаПоиска = ПолучитьФорму("Обработка.ВиртуальнаяКлавиатура.Форма.Форма",,ЭтаФорма);//Элементы.ТаблицаТовары);

ФормаПоиска.Открыть();

КонецПроцедуры

 

И в обработке оповещения добавить:

Если ИсточникВыбора.ИмяФормы = "Обработка.ВиртуальнаяКлавиатура.Форма.Форма" Тогда

Если ТипЗнч(ВыбранноеЗначение) = Тип("СправочникСсылка.Номенклатура") Тогда

ПараметрыОтбора = Новый Структура;

ПараметрыОтбора.Вставить("Номенклатура", ВыбранноеЗначение);

НайденныеСтроки = ТаблицаТовары.НайтиСтроки(ПараметрыОтбора);

Если НайденныеСтроки.Количество()>0 Тогда

Элементы.ТаблицаТовары.ТекущаяСтрока = НайденныеСтроки[0].ПолучитьИдентификатор();

КонецЕсли;

КонецЕсли;

КонецЕсли;

Скачать файлы

Наименование Файл Версия Размер
ВиртуальнаяКлавиатура
.epf 7,84Kb
19.10.11
24
.epf 7,84Kb 24 Скачать
ВиртуальнаяКлавиатура v2
.epf 9,60Kb
19.10.11
41
.epf 9,60Kb 41 Скачать

См. также

Комментарии
1. Алексей Константинов (alexk-is) 6155 16.10.11 21:54 Сейчас в теме
(0) Тексты модулей в публикации можно раскрасить
2. Сергей Троицкий (tsd) 147 16.10.11 23:34 Сейчас в теме
Мелкий недочет. У кнопки удаления последнего символа не видна картинка. Наверно Вы используете нестандартную картинку. Для универсальности лучше ее заменить на стандартную из библиотеки 1С (напр. Назад или Переместит влево).

Не узрел цифр и английской раскладки.

Зачем делаете высоту поля ввода 2, если текст печатается всегда в 1 строку?
3. Дмитрий Михеев (Dmi|MiX) 47 17.10.11 18:02 Сейчас в теме
(2) tsd, Странно но у меня это была стандартная картинка типа назад как раз, может разные версии, английская раскладка мне не нужна в базе нет ни одного английского слова, поле ввода шириной 2 потому что весовщицы вечно жалуются что им мелко) Типа заботы о людях)
4. Сергей Троицкий (tsd) 147 17.10.11 19:07 Сейчас в теме
(3) зарекался поп молитвы не читать :)
чую, отечественный производитель :)
а ну как завтра появятся, или цифирь какую в наименование придумают?
5. Дандронтий Крузенштерн (dandrontiy) 18.10.11 07:39 Сейчас в теме
Может добавить кнопку РУС/ИНГЛ/СИМВОЛЫ ?
Цифры тоже не помешало бы добавить.
А еще хорошо бы хранить N последних набранных и уметь их из списка выбирать
6. Иван Плющев (its) 164 21.11.11 00:14 Сейчас в теме
Хорошая, полезная вещь в хозяйстве.
7. Фёдор Собачкин (sobbaka) 09.01.12 14:50 Сейчас в теме
Очень помогло при допиливании стандартной УТ под клиента,спасибо!
8. Евгений Сущенков (Jonny_wk) 20.06.12 19:48 Сейчас в теме
Отличная вещь, автру респект! Обязательно где-нить использую!
Оставьте свое сообщение