Поздравление с новым годом!

Публикация № 965279

Сообщество - Поздравления

Поздравление

Простая обработочка на простых формах для поздравления пользователей с праздниками (новый год, рождество, 8 марта, 23 февраля, день рождения и т.д.).

Простая обработочка на простых формах для поздравления пользователей с праздниками (новый год, рождество, 8 марта, 23 февраля, день рождения и т.д.).
Несколько картинок, рандомно выбирается одна из них, чтоб не так скучно было, правда все на обычных формах, никак руки не дойдут переделать на УФ.

В публикации прикреплена "С новым годом!"
При начале работы системы проверяется дата и в зависимости от ее значения запускается та или иная обработка, можно наворотить, но это если нечем заняться), это было для поднятия настроения пользователей в праздники))))

Примерно так.

Если ДеньГода(ТекущаяДата()) = 366
        или ДеньГода(ТекущаяДата()) = 365
        или ДеньГода(ТекущаяДата()) = 364
        или ДеньГода(ТекущаяДата()) = 363
        или ДеньГода(ТекущаяДата()) = 1
        тогда
        //Запускаем обработку С новым годом!
КонецЕсли;

Если ДеньГода(ТекущаяДата()) = 6
        или ДеньГода(ТекущаяДата()) = 7
        или ДеньГода(ТекущаяДата()) = 8
        тогда
        //Запускаем обработку С рождеством!
КонецЕсли;

Если (Месяц(ТекущаяДата()) = 3 и День(ТекущаяДата()) = 7)
        или (Месяц(ТекущаяДата()) = 3 и День(ТекущаяДата()) = 8)
        или (Месяц(ТекущаяДата()) = 3 и День(ТекущаяДата()) = 9)
        тогда
        Если Пользователь.Пол = Перечисления.ПолФизическогоЛица.Женский тогда
            //Запускаем обработку с 8 марта!
        КонецЕсли;
КонецЕсли;

Если (Месяц(ТекущаяДата()) = 2 и День(ТекущаяДата()) = 22)
        или (Месяц(ТекущаяДата()) = 2 и День(ТекущаяДата()) = 23)
        или (Месяц(ТекущаяДата()) = 2 и День(ТекущаяДата()) = 24)
        тогда
        Если Пользователь.Пол = Перечисления.ПолФизическогоЛица.Мужской тогда
            //Запускаем обработку с 23 февраля!
        КонецЕсли;
КонецЕсли;


Если Месяц(ТекущаяДата()) = Месяц(Пользователь.ДатаРождения) и День(ТекущаяДата()) = День(Пользователь.ДатаРождения) тогда
        //Прописываем в заголовок ФИО и запускаем обработку с ДР!
 КонецЕсли;

Тестировалось на 1С:Предприятие 8.3 (8.3.12.1685)

Скачать файлы

Наименование Файл Версия Размер
Поздравление с новым годом!:

.epf 1,48Mb
17.12.18
8
.epf 1,48Mb 8 Скачать

Специальные предложения

Оставьте свое сообщение

См. также

Новогоднее поздравление с анимацией Промо

Поздравления v8 1cv8.cf Россия Абонемент ($m)

Новогоднее поздравление с анимацией от всем знакомого Волшебника для платформ 8.1 и 8.2!

1 стартмани

23.12.2011    18906    10    RuslanZ    37    

[Расширение] Поздравление с 8 Марта для типовых конфигураций

Поздравления v8 1cv8.cf Абонемент ($m)

Оригинальное поздравление с 8 марта: падающие сердца, цветочки, летающие птички, открытки random, поздравления в стихах random, печатающиеся на экране.

1 стартмани

28.02.2020    1554    6    77dream77    1    

Поздравление с 8 марта! (Управляемые формы)

Поздравления v8 v8::УФ ДО БП3.0 УТ11 ЗУП3.x Абонемент ($m)

Открытие окна поздравления при старте программы. Можно менять открытку и текст поздравления.

1 стартмани

05.03.2019    4964    30    milkers    10    

Редактирование, добавление своей новости для встроенного справочника новостей 1С (БСП, управляемые формы).

Поздравления v8 v8::УФ 1cv8.cf Абонемент ($m)

Пригодится для оповещения пользователей 1С, поздравлений и т.п.. Праздники все впереди.

2 стартмани

29.12.2018    5619    8    capitan    2    

Поздравление с Новым Годом! (Управляемые формы, авто год)

Поздравления v8 v8::УФ ДО ERP2 БП3.0 УТ11 ЗУП3.x Абонемент ($m)

Открытие окна поздравления при старте программы. Можно менять открытку и текст поздравления.

1 стартмани

10.12.2018    10668    71    milkers    23    

Оригинальное поздравление с 8 марта

Поздравления v8 v8::УФ Абонемент ($m)

Оригинальное поздравление с 8 марта: падающие сердца, цветочки, летающие птички, открытки random, поздравления в стихах random, печатающиеся на экране, рисование мышкой в paint поздравления.

1 стартмани

22.02.2018    10997    16    77dream77    5    

Поздравление с Новым Годом

Поздравления v8 1cv8.cf Абонемент ($m)

Открытка для поздравления с Новым Годом. Обработка выводит поздравление с НГ.

1 стартмани

30.12.2015    10402    10    dedicated    1    

Поздравительная открытка при запуске 1С 8.3

Поздравления v8 1cv8.cf Абонемент ($m)

Использование параметра запуска /Execute и Функции ЗапуститьПриложение() для поздравления с праздником при запуске 1С.

1 стартмани

27.08.2015    14787    12    niko11s    1    

Поздравление с Новым Годом 2015

Поздравления v8 1cv8.cf Абонемент ($m)

Поздравление с Новым 2015 Годом.

1 стартмани

28.12.2014    12322    3    ev-pak    7    

Обработка "С новым годом!"

Поздравления v8 1cv8.cf Абонемент ($m)

Обработка, показывающая случайную картинку из определенного каталога и отсчитывающая, сколько дней осталось до Нового года. Обычные формы.

1 стартмани

04.12.2014    11781    3    Dmitrith    7    

Поздравление с 8 Марта

Поздравления v8 1cv8.cf Абонемент ($m)

Внешняя обработка “8 Марта” предназначена для любых конфигураций платформы 1С:Предприятие 8.2.

1 стартмани

05.03.2014    16259    8    y19671212    5    

Новогоднее поздравление 2014

Поздравления v8 Казахстан Абонемент ($m)

Новогоднее поздравление 2014

1 стартмани

26.12.2013    14480    4    Vadimok    2    

Поздравление с Новым годом Обычные формы (НЕ управляемые)

Поздравления v8 1cv8.cf Абонемент ($m)

Радость для бухгалтера! Поздравление с Новым годом!

1 стартмани

19.12.2013    17864    2    mamba    4    

"Сканер отпечатка пальца" для доступа в программу 1с 8 обычное приложение.

Поздравления v8 1cv8.cf Россия Абонемент ($m)

Розыгрыш своих сотрудников, установим в общем модуле запуск данной обработки, и в конце вывести сообщение, что отпечаток не совпадает с закрытием программы.

1 стартмани

07.05.2013    15290    3    demart-omsk    4    

Сканер отпечатка пальца

Поздравления v8 1cv8.cf Абонемент ($m)

Скоро праздник! Возникла необходимость проверить всех пользователей на наличие доступа к базе.

1 стартмани

27.03.2013    15549    2    Muxomop    19    

Поздравление с Новым Годом 2013

Поздравления v8 1cv8.cf Абонемент ($m)

Порадуйте коллег веселым поздравлением с Новым Годом 2013

1 стартмани

27.12.2012    14004    1    Prompak    3    

Новогоднее поздравление 2013

Поздравления v8 1cv8.cf Абонемент ($m)

Новогоднее поздравление 2013 (обычная и управляемая форма)

1 стартмани

04.12.2012    18910    2    Vadimok    40    

Поздравление к Дню Защитника Отечества (23 февраля)

Поздравления v8 1cv8.cf Россия Абонемент ($m)

Поздравление к Дню защитника Отечества: анимированная открытка + игра

1 стартмани

20.02.2012    15107    4    margo2007    7    

Сброс Сохраненных Значений Настроек

Универсальные обработки Поздравления v8 УПП1 Россия БУ Абонемент ($m)

Внешняя обработка, два в одном: Поздравление с Новым 2012 годом и Рождеством и Сброса сохраненных значений в оборотно-сальдовой ведомости Бухгалтерского и Налогового учета (ОСВ) в УПП

1 стартмани

30.12.2011    12824    1    Zots    2    

Внешняя обработка "С Новым Годом"

Поздравления v8 1cv8.cf Россия Абонемент ($m)

Внешняя обработка-поздравление бухгалтерии с новым годом. Предназначена для 1С 8.2.

1 стартмани

27.12.2011    12584    3    AXonline    11    

С наступающим Новым Годом (Елочка, зажгись)

Поздравления v8 1cv8.cf Россия Абонемент ($m)

Подборка новогодних анимированных елочек на рабочий стол (26)

1 стартмани

26.12.2011    13130    2    dmsoft    8    

Новогоднее поздравление

Поздравления v8 1cv8.cf Россия Абонемент ($m)

Новогоднее поздравление с 2012 годом

1 стартмани

26.12.2011    14290    0    Vadimok    9    

Поздравлялка с новым годом 2012

Поздравления v8 1cv8.cf Россия Абонемент ($m)

Обработка - поздравлялка с новым годом 2012.

1 стартмани

14.12.2011    15266    0    Severwolf    28    

Пример оригинального поздравления пользователей с Новым Годом.

Поздравления v8 1cv8.cf Россия Абонемент ($m)

31 декабря все приходят на работу в почти рабочий день, запускают 1С а тут на экран вылазит дед мороз (санта клаус на самом деле), приветственно машет рукой и поздравляет с наступающим от всех сотрудников ИТ.

1 стартмани

30.11.2011    20095    7    comol    36    

Поздравление с 8 марта [2011]

Поздравления v8 1cv8.cf Россия Абонемент ($m)

Обработка-поздравлялка пользователей базы с 8 марта. Используется персонаж Merlin (читает текст вслух). Используется внешнее приложение "цветы", при вызове которого экран заполняется цветами.

1 стартмани

02.03.2011    18925    3    execombat    32    

C Новым Годом 2011! (слайд шоу)

Поздравления v8 1cv8.cf Россия Абонемент ($m)

Очередное поздравление с Новым Годом! Отличие лишь в оформлении в виде слайд-шоу с эффектами=) Если кому-то будет полезно, буду рад.

1 стартмани

29.12.2010    12799    2    iceflash    6    

Поздравление с новым годом 2011

Поздравления v8 1cv8.cf Россия Абонемент ($m)

Поздравление с Новым Годом 2011 для 1С предприятие 8 порадуйте бухгалтеров под редакцией artbear Артур http://infostart.ru/profile/9621/ Авторство исходной версии artbear Артур Спасибо Всем кто Поставит +

1 стартмани

10.12.2010    18653    0    kenshin    25    

Оригинальное поздравление с Новым годом!

Игры Поздравления v8 1cv8.cf Россия Абонемент ($m)

Позитивная игрушка "Memory" позволит немного отвлечься от работы и поднапрячь свою память. В конце игры ждет новогодний сюрприз. :)

1 стартмани

13.12.2009    13880    2    Cifer    12    

МОЗГОДЕР 3 - универсальное решение для пользователей 8.2

Поздравления v8 1cv8.cf Абонемент ($m)

Тупая, никому не нужная обработка под 8.2, написанная для тренировки

1 стартмани

03.07.2009    13604    1    fishca    31    

МОЗГОДЕР 2 - универсальное решение для пользователей

Поздравления v8 1cv8.cf Абонемент ($m)

"Теперь и для снеговиков"... Наконец-то найдено универсальное решение всех проблем в 1С Решение практически любого вопроса и проблемы Более 1000 ! любых отчетов все на Ваш вкус. Стоит только сильно захотеть. Теперь пользователь не будет отвлекать Вас от важных дел. Он решит проблему сам. Достали пользователи с "глупыми" вопросами? Научите их работать автономно. Присутствует зачатки Искуственного Интелекта - чем больше пользуешся, тем результат выше. Программа бесплатная и для всех. Получи максимум от 1С.

1 стартмани

23.06.2009    16957    0    fishca    34    

Поздравление пользователя с официальными праздниками

Поздравления v8 Россия Абонемент ($m)

Ни к чему не обязывающая обработка, скорее просто процедура, которая при входе в 1С поздравляет с кануном праздника или праздником. Праздники можно добавлять с указанием текста поздравления и количеством дней, на протяжении которых выводится сообщение. Проверить работу можно через несколько дней (9 мая).

04.05.2009    9791    1    WWW123    10