Рассылка событий журнала регистрации

Публикация № 998159

Администрирование - Администрирование данных 1С - Журнал регистрации

оповещение журнал регистрации

Отправка событий журнала регистрации на почту с возможностью группировки и фильтрации.

Попалась на глаза публикация об отправке ошибок из журнала регистрации на почту. Делал в свое время похожее решение, но для удобства сделал возможность создавать отдельные настройки, в соответствии с которыми выполнялась фильтрация событий и их рассылка.

События фильтруются по принципу: (Условие1 ИЛИ Условие2 ИЛИ ....) И НЕ (Условие3 ИЛИ Условие4 ИЛИ ...).

Возможно создание нескольких настроек и расписания обработки для каждой по отдельности.

Во вложении файл конфигурации с подсистемой. Конфигурация писалась на платформе версии 8.3.6..

Кому не хочется скачивать файл, кратко опишу реализацию и приведу основную процедуру, в которой выполняется сбор и рассылка данных.

Основные объекты подсистемы:
1. Справочник Настройки оповещения
2. Регистр сведений ДатаПоследнегоОповещения
3. Регламентное задание ОтправкаОповещений

В справочнике "НастройкиОповещения" задаются Получатель оповещения и фильтр событий. В списке "Фильтр событий" вводятся строки - фрагмент сообщения об ошибке. В этом же списке отдельные события можно "Исключить".

Регистр сведений ДатаПоследнегоОповещения содержит дату и время последней обработки в разрезе НастройкиОповещения.

Регламентное задание ОтправкаОповещений запускается по своему расписанию для каждой НастройкиОповещения.

В текущей реализации анализ журнала регистрации выполняется только по "Ошибкам". При желании, список событий можно расширить.

Текст процедуры ниже.

Процедура ELN_ОтправкаОповещений(НастройкаОповещения) Экспорт
	
	Запрос = Новый Запрос;
	Запрос.Текст = Новый Запрос;
	Запрос.УстановитьПараметр("НастройкаОповещения", НастройкаОповещения);
	Запрос.Текст = 
	"ВЫБРАТЬ
	|	ELN_НастройкиОповещения.АдресЭП,
	|	ELN_НастройкиОповещения.АдресЭПКопия,
	|	ELN_НастройкиОповещения.УчетнаяЗаписьЭлектроннойПочты,
	|	ELN_НастройкиОповещения.ФильтрСообщений.(
	|		Ссылка,
	|		НомерСтроки,
	|		Текст,
	|		Исключить
	|	),
	|	ЕСТЬNULL(ELN_ДатаПоследнегоОповещения.Дата, ДАТАВРЕМЯ(1, 1, 1)) КАК ДатаПоследнегоОповещения
	|ИЗ
	|	Справочник.ELN_НастройкиОповещения КАК ELN_НастройкиОповещения
	|		ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.ELN_ДатаПоследнегоОповещения КАК ELN_ДатаПоследнегоОповещения
	|		ПО (ELN_ДатаПоследнегоОповещения.НастройкаОповещения = ELN_НастройкиОповещения.Ссылка)
	|ГДЕ
	|	ELN_НастройкиОповещения.Ссылка = &НастройкаОповещения
	|	И ELN_НастройкиОповещения.Активная";
	
	Выборка = Запрос.Выполнить().Выбрать();
	Если НЕ Выборка.Следующий() Тогда
		Возврат;
	КонецЕсли;
	
	Отбор = Новый Структура;
	
	ДатаНачала = Выборка.ДатаПоследнегоОповещения;
	ДатаОкончания = ТекущаяДата();
	Если ДатаНачала = '00010101' Тогда
		ДатаНачала = НачалоДня(ТекущаяДата()); // первый раз с начала дня
	КонецЕсли; 
	Отбор.Вставить("ДатаНачала", ДатаНачала);
	Отбор.Вставить("ДатаОкончания", ДатаОкончания); 
	
	Уровень = Новый Массив;
	Уровень.Добавить(УровеньЖурналаРегистрации.Ошибка);
	Отбор.Вставить("Уровень", Уровень);

	тзДанныеЖР = Новый ТаблицаЗначений;
	ВыгрузитьЖурналРегистрации(тзДанныеЖР,Отбор,,,);
	
	тзВрем = Новый ТаблицаЗначений;
	тзВрем.Колонки.Добавить("Дата", Новый ОписаниеТипов("Дата",,,Новый КвалификаторыДаты(ЧастиДаты.ДатаВремя)));
	тзВрем.Колонки.Добавить("Комментарий", Новый ОписаниеТипов("Строка",,Новый КвалификаторыСтроки(1000),));
	
	Для Каждого СтрокаЖР из тзДанныеЖР Цикл
		НоваяСтрока = тзВрем.Добавить();
		НоваяСтрока.Дата = СтрокаЖР.Дата;
		Если ПустаяСтрока(СтрокаЖР.Комментарий) Тогда
			НоваяСтрока.Комментарий = "" + СтрокаЖР.Данные;
		Иначе
			НоваяСтрока.Комментарий = СтрокаЖР.Комментарий;
		КонецЕсли;
	КонецЦикла;
	тзДанныеЖР = Неопределено;
	
	Запрос = Новый Запрос;
	Запрос.УстановитьПараметр("тзДанныеЖР", тзВрем);
	Запрос.Текст = 
	"ВЫБРАТЬ
	|	тзДанныеЖР.Дата,
	|	тзДанныеЖР.Комментарий
	|ПОМЕСТИТЬ втДанныеЖР
	|ИЗ
	|	&тзДанныеЖР КАК тзДанныеЖР
	|;
	|
	|////////////////////////////////////////////////////////////////////////////////
	|ВЫБРАТЬ
	|	втДанныеЖР.Дата КАК Дата,
	|	втДанныеЖР.Комментарий,
	|	ПОДСТРОКА(втДанныеЖР.Комментарий, 1, 300) КАК Комментарий0
	|ИЗ
	|	втДанныеЖР КАК втДанныеЖР
	|ГДЕ
	|	втДанныеЖР.Комментарий ПОДОБНО &Комментарий
	|ИТОГИ
	|	КОЛИЧЕСТВО(Дата)
	|ПО
	|	Комментарий0";
	
	ФильтрСообщений = Выборка.ФильтрСообщений.Выбрать();
	Если ФильтрСообщений.Количество() = 0 Тогда
		Запрос.Текст = СтрЗаменить(Запрос.Текст,"втДанныеЖР.Комментарий ПОДОБНО &Комментарий", "ИСТИНА");
	Иначе
		ТекстУсловия = "";
		ТекстУсловияНЕ = "";
		Пока ФильтрСообщений.Следующий() Цикл
			Если НЕ ФильтрСообщений.Исключить Тогда
				ТекстУсловия = ТекстУсловия + ?(ПустаяСтрока(ТекстУсловия),"", Символы.ПС + "ИЛИ ");
				ТекстУсловия = ТекстУсловия + "втДанныеЖР.Комментарий ПОДОБНО " + """%" + ФильтрСообщений.Текст + "%""";
			Иначе
				ТекстУсловияНЕ = ТекстУсловияНЕ + ?(ПустаяСтрока(ТекстУсловияНЕ),"", Символы.ПС + "ИЛИ ");
				ТекстУсловияНЕ = ТекстУсловияНЕ + "втДанныеЖР.Комментарий ПОДОБНО " + """%" + ФильтрСообщений.Текст + "%""";				
			КонецЕсли;
		КонецЦикла;
		
		Если ПустаяСтрока(ТекстУсловия) Тогда 
			ТекстУсловия = "НЕ " + "(" + ТекстУсловияНЕ + ")";
		ИначеЕсли НЕ ПустаяСтрока(ТекстУсловияНЕ) Тогда
			ТекстУсловия = "(" + ТекстУсловия + ")"+ " И НЕ " + "(" + ТекстУсловияНЕ + ")";
		КонецЕсли;
		Запрос.Текст = СтрЗаменить(Запрос.Текст,"втДанныеЖР.Комментарий ПОДОБНО &Комментарий", ТекстУсловия);		
	КонецЕсли;
	
	ТекстОповещения = "";
	КоличествоОшибокВсего = 0;
	
	ВыборкаОшибки = Запрос.Выполнить().Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
	Пока ВыборкаОшибки.Следующий() Цикл
		
		ТекстОповещения = ТекстОповещения + ?(ПустаяСтрока(ТекстОповещения), "", Символы.ПС + Символы.ПС + Символы.ПС);
		ТекстОповещения = ТекстОповещения + "Текст ошибки:" + Символы.ПС;
		
		ВывестиОшибку = Истина;
		КоличествоОшибок = ВыборкаОшибки.Дата;
		КоличествоОшибокВсего = КоличествоОшибокВсего + КоличествоОшибок;
		
		ВыборкаДетальные = ВыборкаОшибки.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
		Пока ВыборкаДетальные.Следующий() Цикл
			
			Если ВывестиОшибку Тогда
				ТекстОповещения = ТекстОповещения + ВыборкаДетальные.Комментарий;
				ТекстОповещения = ТекстОповещения + Символы.ПС + Символы.ПС + "Количество ошибок: " + КоличествоОшибок;
				
				ВывестиОшибку = Ложь;
			КонецЕсли;
						
		КонецЦикла;
		
	КонецЦикла;
	
	Если НЕ ПустаяСтрока(ТекстОповещения) Тогда
		
		ПочтовыйПрофиль = ПолучитьПрофильИнтернетПочтовоеПодключения(Выборка.УчетнаяЗаписьЭлектроннойПочты);
		
		ТемаПисьма = "Оповещение об ошибках в ЖР за период " 
			+ Формат(ДатаНачала,"ДФ='dd.MM.yyyy hh:mm:ss'")
			+ " по "
			+ Формат(ДатаОкончания,"ДФ='dd.MM.yyyy hh:mm:ss'")
			+ ". Ошибок: " 
			+ КоличествоОшибокВсего;
		
		Получатель = Выборка.АдресЭП;
		Копии = Выборка.АдресЭПКопия;
		
		Если НЕ ОтправитьЭлектронноеПисьмо(ПочтовыйПрофиль, "" + Выборка.УчетнаяЗаписьЭлектроннойПочты, ТемаПисьма,ТекстОповещения,Получатель,Копии,) Тогда
			ДатаОкончания = '00010101'; // последнюю дату менять не будем
		КонецЕсли;
		
	КонецЕсли;
	
	Если ЗначениеЗаполнено(ДатаОкончания) Тогда 
		
		НаборЗаписей = РегистрыСведений.ELN_ДатаПоследнегоОповещения.СоздатьНаборЗаписей();
		НаборЗаписей.Отбор.НастройкаОповещения.Установить(НастройкаОповещения);
		НоваяЗапись = НаборЗаписей.Добавить();
		НоваяЗапись.НастройкаОповещения = НастройкаОповещения;
		НоваяЗапись.Дата = ДатаОкончания;
		НаборЗаписей.Записать();
		
	КонецЕсли;
	
КонецПроцедуры

 

Спасибо за внимание.

Скачать файлы

Наименование Файл Версия Размер
Рассылка событий журнала регистрации:

.cf 29,81Kb
06.02.19
2
.cf 29,81Kb 2 Скачать

Специальные предложения

Оставьте свое сообщение

См. также

История формирования отчётов. (Используем новые возможности расширений в 8.3.11) Промо

Журнал регистрации v8::УФ v8::СКД УНФ ДО БП3.0 УТ11 ЗУП3.x Абонемент ($m)

Подсистема ведёт историю формирования отчётов и позволяет быстро подгрузить используемые настройки в отчёт.

1 стартмани

28.11.2017    15211    20    SeiOkami    1    

Активность пользователей на основании журнала регистрации

Журнал регистрации v8 v8::УФ 1cv8.cf Абонемент ($m)

Активность пользователей информационной базы за период в разрезе пользователей, видов документов, самих документов и количества строк в них. Отчет выводит данные о созданных документах за период и количестве строк в них.

1 стартмани

22.11.2020    473    2    chagbig    2    

История данных (Версионирование данных). Обычные и управляемые формы. Механизм платформы 1С

Журнал регистрации Структура метаданных Расширения v8 v8::УФ 1cv8.cf Абонемент ($m)

История данных - специальный механизм платформы 1С, который позволяет хранить в базе данных данные объектов конфигурации.

1 стартмани

30.09.2020    1560    10    yuryshestakov    0    

История изменения реквизитов для любых конфигураций

Администрирование данных 1С Журнал регистрации v8 1cv8.cf Россия Абонемент ($m)

Просмотр истории изменения документов и справочников одним кликом. Дополнение к любой конфигурации на платформе 1С 8x. Позволяет отслеживать историю изменения реквизитов справочников и документов, в том числе и их табличных частей. Для управляемых и не управляемых форм.

5 стартмани

14.08.2020    1673    6    alvabul    1    

Включение и выключение регистрации отказа в доступе если "У пользователя не достаточно прав над операцией с базой данных". Промо

Информационная безопасность Журнал регистрации v8 1cv8.cf Абонемент ($m)

Включает (выключает) регистрацию событий отказа доступа в журнале регистрации.

1 стартмани

12.01.2011    35878    68    nexts    32    

Список пользователей за период

Журнал регистрации v8 УНФ ДО Абонемент ($m)

Анализируя Журнал регистрации выводит список всех пользователей, которые заходили в текущую базу в выбранном периоде

1 стартмани

12.08.2020    1241    2    Gvozdod    0    

Объединение (слияние) журналов регистрации через СкопироватьЖурналРегистрации

Журнал регистрации v8 1cv8.cf Россия Абонемент ($m)

В основном это для тех, кто накосячил с журналом, а он оказался нужен.

1 стартмани

20.07.2020    2109    3    tech1c    2    

Отправка сообщений о действиях в конфигураторе из журнала регистрации на почту письмом

Журнал регистрации v8 БП3.0 Россия Абонемент ($m)

Бывает, нужно знать, кто, кроме вас, открывал конфигуратор 1С и вносил ли изменения в саму конфигурацию. Представленная внешняя обработка добавляется в регламентные задания и по расписанию отправляет письмо по указанным адресам с отбором журнала регистрации за предыдущие сутки по действиям с конфигуратором за исключением указанных в ней пользователей (и пользователей операционной системы). Тестировалось на платформе 1С:Предприятие 8.3 (8.3.15.1830), в конфигурациях 1С ЗУП Проф 3.1.13.151 и 1С Бухгалтерия КОРП 3.0.75.93.

1 стартмани

13.05.2020    2070    0    Svetlanka_sv    0    

Статистика работы пользователя Промо

Журнал регистрации Управленческие Статистика базы данных Учет рабочего времени Учет рабочего времени v8 1cv8.cf Абонемент ($m)

Анализ работы сотрудников - важные составляющие функционирования компании. Безусловно, руководитель может самостоятельно оценивать труд работников, деятельность которых как на ладони, стоит лишь взглянуть на поступление денег на банковский счет фирмы. Сложнее оценить работу сотрудников, которые не имеют прямого влияния на бизнес-результат: это бухгалтеры, кадровые работники, менеджеры.

3 стартмани

17.07.2011    47259    346    imozg    63    

Отслеживание ошибок в журнале регистрации

Журнал регистрации v8 1cv8.cf Россия Абонемент ($m)

Как узнать об ошибках из журнала регистрации, когда вы не на рабочем месте? Легко!

1 стартмани

25.04.2020    2796    3    maslyann    0    

Журнал регистрации в эластике с использованием службы без использования 1С (.net + elastic)

Журнал регистрации v8 Абонемент ($m)

При большом количестве записей в ЖР типовыми средствами он просматривается тяжело либо при просмотре зависает намертво. Для просмотра ЖР есть различные обработки, которые надо запускать под 1С. В этой публикации предлагается отдельная служба фоново и незаметно работающая на сервере, не требующая использования 1С.

1 стартмани

09.03.2020    2932    7    pashamak    0    

Версионирование (история изменений) объектов в 1С:Предприятие 8

Журнал регистрации v8 1cv8.cf Россия Абонемент ($m)

Версионирование представляет собой опцию, с помощью которой пользователь может легко установить, кто и когда изменил находящийся в базе документ, а также какие именно изменения имели место.  Платформа 1С:Предприятие 8 имеет сходную опцию – журнал регистрации, однако эта опция не позволяет выяснить характер изменений, журнал регистраций позволяет только узнать, когда был изменен документ и какой пользователь внес изменения. В платформе 8.3.11 данный механизм встроен "ИсторияДанных" и позволяет работать с версионированием через встроенные механизмы платформы, что является несомненным плюсом. Данная конфигурация предназначена для более ранних версий.

1 стартмани

15.01.2020    8933    24    ClickUp    0    

Просмотр документов, измененных задним числом Промо

Журнал регистрации v8 УТ10 Россия Абонемент ($m)

Редактирование документов в 1С, проведенных задним числом, бывает необходимо для исправления ошибок в учете, но также является распространенным способом воровства в магазине. Поэтому важно максимально ограничить работу задним числом.

2 стартмани

12.08.2015    28499    58    ПерваяСистема    17    

Журнал регистрации SQLite, кластер, метаданные

Журнал регистрации v8 Абонемент ($m)

О журнале регистрации, его форматах и парсинге написано много статей. Но я не нашёл информации, что бы кто-то агрегировал журнал регистрации в кластере или архивные части. Суть проблемы - если у вас несколько серверов 1С (кластер), то ЖР в конкретный момент пишется только на один из узлов (как правило, назначенный функциональной опцией). Стоит перезагрузить или выключить этот узел кластера, то ЖР регистрации начинает писаться на доступный. Соответственно при просмотре ЖР записи отображаются только с активного в данный момент узла кластера.

1 стартмани

22.12.2019    4135    2    AlexSTAL    2    

Универсальная обработка (УФ) для работы с журналом регистрации в формате SQLite через ODBC

Универсальные обработки Журнал регистрации v8 v8::УФ 1cv8.cf Абонемент ($m)

Обработка позволяет подключиться к журналу регистрации в формате SQLite (.lgd) через ODBC и прочитать его события в привычном виде, как в стандартном журнале.

1 стартмани

27.11.2019    4110    8    Spartacus    5    

Управление историей изменения данных

Журнал регистрации v8 1cv8.cf Россия Абонемент ($m)

Данная обработка позволяет включить версионирование объектов истории изменения данных.

10 стартмани

09.11.2019    6586    4    D_E_S131    3    

Получение запросом данных журнала регистрации хранящегося в SQLite Промо

Практика программирования Журнал регистрации v8 1cv8.cf Абонемент ($m)

В статье показано как, используя новый функционал платформы, получать данные из журнала регистрации привычным запросом.

1 стартмани

17.09.2014    67026    173    rtnm    38    

Версионирование объеков УТ 10 с возможностью перехода к сохраненной версии

Журнал регистрации Универсальные функции v8 УТ10 Абонемент ($m)

Версионирование объектов УТ 10.3 с возможностью перехода к сохраненной версии. Взята стандартная система версионирования УПП, добавлена возможность восстановления ранее сохраненной версии.

1 стартмани

28.10.2019    7559    32    art.prm    8    

Быстрый поиск в журналe регистрации 1С *.lgd

Журнал регистрации v8 1cv8.cf Абонемент ($m)

Обработка для быстрого поиска данных в журнале регистрации 1С SQLite (.lgd). 8.3.15.

1 стартмани

10.10.2019    7203    18    andboss    3    

Сложнейшая загрузка журнала регистрации в ElasticSearch (или делаем настоящий ETL)

Журнал регистрации v8 Россия Абонемент ($m)

Году в 2017ом возникло (наверное странное на тот момент) желание перегрузить журнал регистраций 1С в ELK. Чтобы журналы место на диске не съедали, 1С программисты забыв поставить фильтр сервер не подвешивали, все журналы лежали в одном месте да и можно было безопасно туда ответственных пользователей пускать, чтобы сами смотрели кто какой документ поправил.На предложение написать выгрузку сразу из 1С программисты благополучно забили ("ой на это минимум месяц", "у нас срочные бизнес-фичи" и т.д. и т.п.). Зато попалась статья от Aleksey.Bochkov (https://infostart.ru/public/182820/). Ну и решили мы все это запилить без 1С программистов. Во что влезаем я тогда еще не понимал. А вылилось почти в год допилок (хорошо хоть в фоновом режиме) в цельный ETL с использованием C#, T-SQL и прочими делами.

1 стартмани

27.09.2019    11201    6    DonAlPatino    33    

Монитор журнала регистрации Промо

Журнал регистрации Администрирование данных 1С WEB v8 1cv8.cf Абонемент ($m)

Позволяет в режиме реального времени отслеживать активность пользователей, накапливать и оповещать о возникновении ошибок, которые попадают в журнал регистрации

2 стартмани

29.06.2015    41335    106    andy23    49    

Удаление журнала регистрации с отбором

Журнал регистрации v8 1cv8.cf Россия Абонемент ($m)

Обработка очистки журнала регистрации с отбором по пользователю и периоду для обычного приложения.

2 стартмани

05.09.2019    5594    15    doctorov_s    5    

Журнали2Ст: сверхбыстрый журнал регистрации 1С

Журнал регистрации v8 Абонемент ($m)

Строит внешний индекс по журналам регистрации любого формата и делает поиск в них фантастически быстрым. Дополнительно ничего не нужно настраивать! Журналы Регистрации остаются на своём месте и не занимают дополнительного, а сервис Журнали2Ста обеспечивает их постоянную индексацию.

1 стартмани

22.08.2019    12465    86    MrWonder    66    

Отправление событий журнала регистрации в приватный / публичный канал Telegram в виде сообщений и файлов

WEB Журнал регистрации v8 v8::УФ Абонемент ($m)

Данная конфигурация позволяет получать события журнала регистрации в телеграм в виде сообщений и файлов.

1 стартмани

29.07.2019    5508    7    serg-lom89    0    

Автоматизация анализа файлов технологического журнала Промо

Журнал регистрации v8 Россия Абонемент ($m)

В арсенале каждого уважающего себя 1С-ника, занимающегося оптимизацией быстродействия, всегда есть ряд собственных методик и инструментов, которые позволяют на основе наблюдений за системой понять, что именно происходит и в каком направлении работать над улучшением. В этой публикации я хотел бы поделится собственным инструментом для разбора файлов технологического журнала 1С и показать несколько примеров получения наиболее ценной информации.

1 стартмани

14.02.2012    31387    35    Aleksey.Bochkov    16    

Как отправить ошибки из журнала регистрации на почту? Продолжение. Отдельная база

Журнал регистрации v8 Абонемент ($m)

Добавлена отдельная база: возможность указания списка баз, из которых нужно собирать ошибки, возможность указания почтового профиля для каждой базы.

1 стартмани

27.05.2019    5172    3    wowik    0    

Запуск встроенного в платформу механизма История данных для ленивых

Журнал регистрации v8 1cv8.cf Абонемент ($m)

В последних версиях платформы 1С появился замечательный механизм Истории данных. Если кратко, механизм позволяет сохранять историю, просматривать, сверять и самое приятное, это восстанавливать любую версию объекта. А самое главное, чтобы это заработало, не нужно продумывать, писать и поддерживать тонны кода, все уже сделано за нас... Возникает вопрос: Как запустить встроенный в платформу механизм Истории данных ничего не кодируя?

1 стартмани

24.05.2019    7964    8    _root    13    

Подсистема для выгрузки, быстрого поиска и анализа журнала регистрации 1С в Elasticsearch

Журнал регистрации Поиск данных v8 1cv8.cf Абонемент ($m)

Elasticsearch - это opensource решение для очень быстрого поиска данных в больших массивах информации. Использование этого решения позволит решить проблемы с поиском и анализом больших объемов информации журнала регистрации. Протестировано на платформах начиная с 8.3.10.2580.

5 стартмани

15.05.2019    10624    25    Nikolo17    12    

Подсистема: История изменений реквизитов объекта, в том числе табличных частей. 1с 8.2. Промо

Журнал регистрации Практика программирования v8 1cv8.cf Абонемент ($m)

Данная подсистема предназначена для хранения истории изменений реквизитов шапок и табличных частей документов и справочников. подсистема основана на записях изменений реквизитов в регистр сведений? с указанием автора и времени изменения.

1 стартмани

12.11.2012    40664    77    allert73    16    

Журнал Регистрации ➜ Телеграмм

Журнал регистрации v8::УФ 1cv8.cf Россия Абонемент ($m)

Подключаемая обработка для рассылки ошибок журнала регистрации в телеграмм.

1 стартмани

14.05.2019    10039    22    🅵🅾️🆇    9    

История данных [Расширение] УТ11

Журнал регистрации v8 УТ11 Абонемент ($m)

Расширение позволяет хранить (восстанавливать) историю данных прикладных объектов (справочников, документов, движений регистров по документам).

10 стартмани

06.05.2019    5668    3    noprogrammer    6    

Журнал регистрации по навигационной ссылке

Журнал регистрации v8 v8::УФ 1cv8.cf Абонемент ($m)

Обработка получает записи журнала регистрации только по указанной навигационной ссылке (либо просто по ссылке).

1 стартмани

13.03.2019    5652    2    Смешной 1С    0    

Журнал регистрации на СКД (полностью программная реализация) Промо

Журнал регистрации v8 1cv8.cf Абонемент ($m)

Очередная вариация на тему отчет по журналу регистрации на СКД

1 стартмани

22.08.2013    24186    69    Жолтокнижниг    6    

Сообщение об ошибках журнала регистрации по электронной почте

Журнал регистрации Email v8 1cv8.cf ЗКГУ3.0 БП3.0 ЗУП3.x Россия Абонемент ($m)

Универсальная внешняя обработка по выгрузки ошибок журнала регистрации по электронной почте. Может работать как отдельно по команде, так и быть загруженной в справочник Дополнительные отчеты и обработки и запускаться по настраиваемому расписанию.

2 стартмани

04.03.2019    4651    5    ig-efrem    2    

История версий объектов

Журнал регистрации v8 1cv8.cf Россия Абонемент ($m)

Подсистема для записи и хранения изменений любых объектов ссылочного типа. Формирует хронологию работы пользователей с базой данных. Позволяет произвести быстрый поиск версии объекта БД по указанным параметрам и восстановить данные выбранной версии. Протестирована в конфигурации ЗУП, редакция 2.5 на платформе 1С:Предприятие 8.2 (8.2.19.130). Обычные формы. В поставке выгрузка тестовой демонстрационной базы и файл CF c объектами подсистемы.

1 стартмани

22.02.2019    7011    12    dmitrydemenew    7    

Монитор активных пользователей по журналу регистрации

Журнал регистрации v8 1cv8.cf Россия Абонемент ($m)

Монитор активности пользовательских сеансов с возможностью завершить сеансы и соединения. Платформа 1С: 8.3.12.1685. БСП не используется

1 стартмани

01.02.2019    5086    5    mefalcon    2    

Анализ транзакций по журналу регистрации 1С 8 Промо

Журнал регистрации v8 КА1 БП2.0 ЗУП2.5 УТ10 УПП1 УНФ Россия Абонемент ($m)

Из журнала регистрации (ЖР) можно почерпнуть немного информации о производительности. 28.08.2012 Новая версия с графическим представлением

1 стартмани

28.12.2011    25409    32    mrWatson    30    

Ошибки, предупреждения и прочее из журнала регистрации на почту и в Telegram автоматически (БП 3, ЗУП 3.1, УТ 11.4, ERP 2.4, Розница 2.2)

Журнал регистрации Поиск данных Тестирование и исправление Email v8 Розница УНФ ERP2 ЗКГУ3.0 БП3.0 УТ11 ЗУП3.x Абонемент ($m)

Данная обработка позволяет анализировать журнал регистрации с пользовательским отбором (4 критерия отбора) и высылать отчет пользователю с заданной периодичностью на электронную почту или в Телеграм. Возможно использовать как регламентное задание (автоматическая отправка отчетов по времени), непосредственно запускать из клиента, а также выгружать в форму обработки отфильтрованные данные из журнала регистрации без отправки.

2 стартмани

28.01.2019    10734    39    Redinternational    3    

Удаление одинаковых версий в журнале регистрации, очистка записей по неверсионированным объектам

Чистка базы Журнал регистрации v8 1cv8.cf Украина Абонемент ($m)

Обработка также позволяет очищать лишние записи версий объектов, которые все-таки остаются для регистрации в журнале регистрации. Также возможна очистка по неверсионированным в журнале регистрации объектам.

2 стартмани

09.01.2019    4591    1    t_yuri    0    

Архивирование и удаление файлов журнала регистрации на Linux-сервере

Журнал регистрации v8 Абонемент ($m)

Bash-скрипт для архивации и удаления файлов Журнала регистрации в старом формате на Linux-сервере 1С Предприятия.

1 стартмани

29.11.2018    6565    0    Sloth    4    

Версионирование объектов Промо

Журнал регистрации v8 КА1 БП2.0 ЗУП2.5 УТ10 УПП1 Россия Абонемент ($m)

Немного измененный механизм версионирования объектов. Может использоваться с любой конфигурацией (возможно с небольшими доработками). Тестировался на УТ 10.3. Основное отличие - контроль уже записанных версий объектов.

1 стартмани

25.05.2012    38330    130    kolos    22    

Загрузка журнала регистрации 1С v8 в базу SQLServer

Журнал регистрации v8 Россия Абонемент ($m)

Загрузка журнала регистрации 1С v8 в базу SQLServer, для хранения архивной информации по журналам, быстрого поиска и/или переноса данных из журнала и его усечения.

10 стартмани

26.10.2018    8058    13    user1054014    12    

Мониторинг активности пользователя

Журнал регистрации v8 БП3.0 Россия Абонемент ($m)

Расширение предназначено для мониторинга активности пользователей, фиксирует какие окна открывал и когда пользователь в программе. Автоматически завершает работу не активных пользователей, что позволяет экономить системные ресурсы. Есть отчет об Активности пользователей по часам с возможностью отбора по конкретному пользователю. Расширение для типовых конфигураций 1С на управляемых формах в режиме совместимости 8.3.12.

1 стартмани

26.10.2018    7661    61    xan333    7    

Python-скрипт для массового переключения формата журнала регистрации

Журнал регистрации v8 1cv8.cf Абонемент ($m)

Python-скрипт для массового переключения формата журнала регистрации. В первую очередь из SQL в файл. python.exe 1c_format_log_chenger.py Analyze, clearing and change journal format for 1C journal system Use -a or --analyze for analyzing Use -c or --clear for delete all log files Use --sql2file for change logfiles format 2 File Use --file2sql for change logfiles format 2 SQL

1 стартмани

12.10.2018    5872    0    DonAlPatino    8    

Отчет об изменениях в объектах Промо

Журнал регистрации v8 1cv8.cf Россия Абонемент ($m)

Обработка подписывается на событие записи выбранных объетов, и по команде, показывает таблицу изменений реквизитов в объекте. Обработка универсальная - не требует вносить изменения в конфигурацию. Eсть пример подключения к обмену ковертации данных через XML.

1 стартмани

21.11.2011    23200    13    i132    6    

Обработка журнала регистрации в формате SQLLite

Журнал регистрации v8 1cv8.cf Россия Абонемент ($m)

Обработка предназначена для работы с файлом "1Cv8.lgd" журнала регистрации 1С в формате "SQLLite". Выборка и удаление записей.

1 стартмани

14.09.2018    7885    50    VslavKup    6    

R2-D2: журнал регистрации, монитор обменов, аварийные уведомления

Сервисные утилиты Распределенная БД (УРИБ, УРБД) Администрирование данных 1С Журнал регистрации v8 Россия Абонемент ($m)

Обслуживание Журналов регистрации нескольких баз 1С. Сбор и обработка сведений о статусах обменов баз 1С, рассылка аварийных уведомлений.

2 стартмани

14.06.2018    14686    19    pbabincev    8    

Установка параметров журнала регистрации (УФ)

Журнал регистрации v8 v8::УФ 1cv8.cf Россия Абонемент ($m)

Обработка позволяет установить регистрацию по событиям.

1 стартмани

06.05.2018    7382    15    lisenenkov    6    

Анализ времени проведения документов Промо

Журнал регистрации Статистика базы данных v8 1cv8.cf Абонемент ($m)

Данный отчет показывает сколько времени тратится на проведение документов определенного вида.

1 стартмани

06.05.2011    21936    17    anderson    20    

Журнал регистрации из формы документа или справочника

Журнал регистрации v8 Розница УНФ БП3.0 УТ11 КА2 Абонемент ($m)

Данная обработка позволяет просматривать журнал регистрации (кто из пользователей последний вносил изменения) по справочнику или документу прямо из формы. Не требуется изменение конфигурации.

2 стартмани

23.04.2018    11720    47    Kutuzov    7    

Версии объекта (просмотр версий текущего объекта)

Журнал регистрации v8 КА1 УПП1 Абонемент ($m)

Печатная форма, вызывающая отчет подобный встроенному История изменений объектов.

2 стартмани

12.03.2018    10555    5    SITR-utyos    2    

История изменений объектов

Журнал регистрации v8 1cv8.cf Украина Абонемент ($m)

Обработка "История изменений объектов" представляет собой типовой отчет истории изменений объектов, с функцией подключения в виде внешней печатной формы, и возможностью формирования макета "Параметры авторегистрации".

1 стартмани

07.03.2018    9994    10    sakila    0    

Как нам защитить журнал

Информационная безопасность Журнал регистрации v8 1cv8.cf Абонемент ($m)

Первая и важнейшая функция бухгалтерского учета - функция защиты, охраны. В ее основе лежит идея сколь простая, столь же эффективная. Вы должны построить такую систему, в которой любое неправомерное действие будет оставлять следы. Другими словами: никто не будет делать ничего плохого, если это плохое тут же вскроется. Кстати, верно и обратное. Если в вашей системе можно сделать что-то плохое так, что никто никогда не узнает, тогда это плохое рано или поздно сделают. Для обеспечения защитной функции, в 1С уже давно существует т.н. журнал регистрации. Но, к сожалению, есть две причины, по которым этот журнал не может считаться средством защиты...

1 стартмани

23.01.2018    11771    7    mkalimulin    51