Рассылка событий журнала регистрации

Публикация № 998159

Администрирование - Администрирование данных 1С - Журнал регистрации

оповещение журнал регистрации

4
Отправка событий журнала регистрации на почту с возможностью группировки и фильтрации.

Попалась на глаза публикация об отправке ошибок из журнала регистрации на почту. Делал в свое время похожее решение, но для удобства сделал возможность создавать отдельные настройки, в соответствии с которыми выполнялась фильтрация событий и их рассылка.

События фильтруются по принципу: (Условие1 ИЛИ Условие2 ИЛИ ....) И НЕ (Условие3 ИЛИ Условие4 ИЛИ ...).

Возможно создание нескольких настроек и расписания обработки для каждой по отдельности.

Во вложении файл конфигурации с подсистемой. Конфигурация писалась на платформе версии 8.3.6..

Кому не хочется скачивать файл, кратко опишу реализацию и приведу основную процедуру, в которой выполняется сбор и рассылка данных.

Основные объекты подсистемы:
1. Справочник Настройки оповещения
2. Регистр сведений ДатаПоследнегоОповещения
3. Регламентное задание ОтправкаОповещений

В справочнике "НастройкиОповещения" задаются Получатель оповещения и фильтр событий. В списке "Фильтр событий" вводятся строки - фрагмент сообщения об ошибке. В этом же списке отдельные события можно "Исключить".

Регистр сведений ДатаПоследнегоОповещения содержит дату и время последней обработки в разрезе НастройкиОповещения.

Регламентное задание ОтправкаОповещений запускается по своему расписанию для каждой НастройкиОповещения.

В текущей реализации анализ журнала регистрации выполняется только по "Ошибкам". При желании, список событий можно расширить.

Текст процедуры ниже.

Процедура ELN_ОтправкаОповещений(НастройкаОповещения) Экспорт
	
	Запрос = Новый Запрос;
	Запрос.Текст = Новый Запрос;
	Запрос.УстановитьПараметр("НастройкаОповещения", НастройкаОповещения);
	Запрос.Текст = 
	"ВЫБРАТЬ
	|	ELN_НастройкиОповещения.АдресЭП,
	|	ELN_НастройкиОповещения.АдресЭПКопия,
	|	ELN_НастройкиОповещения.УчетнаяЗаписьЭлектроннойПочты,
	|	ELN_НастройкиОповещения.ФильтрСообщений.(
	|		Ссылка,
	|		НомерСтроки,
	|		Текст,
	|		Исключить
	|	),
	|	ЕСТЬNULL(ELN_ДатаПоследнегоОповещения.Дата, ДАТАВРЕМЯ(1, 1, 1)) КАК ДатаПоследнегоОповещения
	|ИЗ
	|	Справочник.ELN_НастройкиОповещения КАК ELN_НастройкиОповещения
	|		ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.ELN_ДатаПоследнегоОповещения КАК ELN_ДатаПоследнегоОповещения
	|		ПО (ELN_ДатаПоследнегоОповещения.НастройкаОповещения = ELN_НастройкиОповещения.Ссылка)
	|ГДЕ
	|	ELN_НастройкиОповещения.Ссылка = &НастройкаОповещения
	|	И ELN_НастройкиОповещения.Активная";
	
	Выборка = Запрос.Выполнить().Выбрать();
	Если НЕ Выборка.Следующий() Тогда
		Возврат;
	КонецЕсли;
	
	Отбор = Новый Структура;
	
	ДатаНачала = Выборка.ДатаПоследнегоОповещения;
	ДатаОкончания = ТекущаяДата();
	Если ДатаНачала = '00010101' Тогда
		ДатаНачала = НачалоДня(ТекущаяДата()); // первый раз с начала дня
	КонецЕсли; 
	Отбор.Вставить("ДатаНачала", ДатаНачала);
	Отбор.Вставить("ДатаОкончания", ДатаОкончания); 
	
	Уровень = Новый Массив;
	Уровень.Добавить(УровеньЖурналаРегистрации.Ошибка);
	Отбор.Вставить("Уровень", Уровень);

	тзДанныеЖР = Новый ТаблицаЗначений;
	ВыгрузитьЖурналРегистрации(тзДанныеЖР,Отбор,,,);
	
	тзВрем = Новый ТаблицаЗначений;
	тзВрем.Колонки.Добавить("Дата", Новый ОписаниеТипов("Дата",,,Новый КвалификаторыДаты(ЧастиДаты.ДатаВремя)));
	тзВрем.Колонки.Добавить("Комментарий", Новый ОписаниеТипов("Строка",,Новый КвалификаторыСтроки(1000),));
	
	Для Каждого СтрокаЖР из тзДанныеЖР Цикл
		НоваяСтрока = тзВрем.Добавить();
		НоваяСтрока.Дата = СтрокаЖР.Дата;
		Если ПустаяСтрока(СтрокаЖР.Комментарий) Тогда
			НоваяСтрока.Комментарий = "" + СтрокаЖР.Данные;
		Иначе
			НоваяСтрока.Комментарий = СтрокаЖР.Комментарий;
		КонецЕсли;
	КонецЦикла;
	тзДанныеЖР = Неопределено;
	
	Запрос = Новый Запрос;
	Запрос.УстановитьПараметр("тзДанныеЖР", тзВрем);
	Запрос.Текст = 
	"ВЫБРАТЬ
	|	тзДанныеЖР.Дата,
	|	тзДанныеЖР.Комментарий
	|ПОМЕСТИТЬ втДанныеЖР
	|ИЗ
	|	&тзДанныеЖР КАК тзДанныеЖР
	|;
	|
	|////////////////////////////////////////////////////////////////////////////////
	|ВЫБРАТЬ
	|	втДанныеЖР.Дата КАК Дата,
	|	втДанныеЖР.Комментарий,
	|	ПОДСТРОКА(втДанныеЖР.Комментарий, 1, 300) КАК Комментарий0
	|ИЗ
	|	втДанныеЖР КАК втДанныеЖР
	|ГДЕ
	|	втДанныеЖР.Комментарий ПОДОБНО &Комментарий
	|ИТОГИ
	|	КОЛИЧЕСТВО(Дата)
	|ПО
	|	Комментарий0";
	
	ФильтрСообщений = Выборка.ФильтрСообщений.Выбрать();
	Если ФильтрСообщений.Количество() = 0 Тогда
		Запрос.Текст = СтрЗаменить(Запрос.Текст,"втДанныеЖР.Комментарий ПОДОБНО &Комментарий", "ИСТИНА");
	Иначе
		ТекстУсловия = "";
		ТекстУсловияНЕ = "";
		Пока ФильтрСообщений.Следующий() Цикл
			Если НЕ ФильтрСообщений.Исключить Тогда
				ТекстУсловия = ТекстУсловия + ?(ПустаяСтрока(ТекстУсловия),"", Символы.ПС + "ИЛИ ");
				ТекстУсловия = ТекстУсловия + "втДанныеЖР.Комментарий ПОДОБНО " + """%" + ФильтрСообщений.Текст + "%""";
			Иначе
				ТекстУсловияНЕ = ТекстУсловияНЕ + ?(ПустаяСтрока(ТекстУсловияНЕ),"", Символы.ПС + "ИЛИ ");
				ТекстУсловияНЕ = ТекстУсловияНЕ + "втДанныеЖР.Комментарий ПОДОБНО " + """%" + ФильтрСообщений.Текст + "%""";				
			КонецЕсли;
		КонецЦикла;
		
		Если ПустаяСтрока(ТекстУсловия) Тогда 
			ТекстУсловия = "НЕ " + "(" + ТекстУсловияНЕ + ")";
		ИначеЕсли НЕ ПустаяСтрока(ТекстУсловияНЕ) Тогда
			ТекстУсловия = "(" + ТекстУсловия + ")"+ " И НЕ " + "(" + ТекстУсловияНЕ + ")";
		КонецЕсли;
		Запрос.Текст = СтрЗаменить(Запрос.Текст,"втДанныеЖР.Комментарий ПОДОБНО &Комментарий", ТекстУсловия);		
	КонецЕсли;
	
	ТекстОповещения = "";
	КоличествоОшибокВсего = 0;
	
	ВыборкаОшибки = Запрос.Выполнить().Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
	Пока ВыборкаОшибки.Следующий() Цикл
		
		ТекстОповещения = ТекстОповещения + ?(ПустаяСтрока(ТекстОповещения), "", Символы.ПС + Символы.ПС + Символы.ПС);
		ТекстОповещения = ТекстОповещения + "Текст ошибки:" + Символы.ПС;
		
		ВывестиОшибку = Истина;
		КоличествоОшибок = ВыборкаОшибки.Дата;
		КоличествоОшибокВсего = КоличествоОшибокВсего + КоличествоОшибок;
		
		ВыборкаДетальные = ВыборкаОшибки.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
		Пока ВыборкаДетальные.Следующий() Цикл
			
			Если ВывестиОшибку Тогда
				ТекстОповещения = ТекстОповещения + ВыборкаДетальные.Комментарий;
				ТекстОповещения = ТекстОповещения + Символы.ПС + Символы.ПС + "Количество ошибок: " + КоличествоОшибок;
				
				ВывестиОшибку = Ложь;
			КонецЕсли;
						
		КонецЦикла;
		
	КонецЦикла;
	
	Если НЕ ПустаяСтрока(ТекстОповещения) Тогда
		
		ПочтовыйПрофиль = ПолучитьПрофильИнтернетПочтовоеПодключения(Выборка.УчетнаяЗаписьЭлектроннойПочты);
		
		ТемаПисьма = "Оповещение об ошибках в ЖР за период " 
			+ Формат(ДатаНачала,"ДФ='dd.MM.yyyy hh:mm:ss'")
			+ " по "
			+ Формат(ДатаОкончания,"ДФ='dd.MM.yyyy hh:mm:ss'")
			+ ". Ошибок: " 
			+ КоличествоОшибокВсего;
		
		Получатель = Выборка.АдресЭП;
		Копии = Выборка.АдресЭПКопия;
		
		Если НЕ ОтправитьЭлектронноеПисьмо(ПочтовыйПрофиль, "" + Выборка.УчетнаяЗаписьЭлектроннойПочты, ТемаПисьма,ТекстОповещения,Получатель,Копии,) Тогда
			ДатаОкончания = '00010101'; // последнюю дату менять не будем
		КонецЕсли;
		
	КонецЕсли;
	
	Если ЗначениеЗаполнено(ДатаОкончания) Тогда 
		
		НаборЗаписей = РегистрыСведений.ELN_ДатаПоследнегоОповещения.СоздатьНаборЗаписей();
		НаборЗаписей.Отбор.НастройкаОповещения.Установить(НастройкаОповещения);
		НоваяЗапись = НаборЗаписей.Добавить();
		НоваяЗапись.НастройкаОповещения = НастройкаОповещения;
		НоваяЗапись.Дата = ДатаОкончания;
		НаборЗаписей.Записать();
		
	КонецЕсли;
	
КонецПроцедуры

 

Спасибо за внимание.

4

Скачать файлы

Наименование Файл Версия Размер
Рассылка событий журнала регистрации:
.cf 29,81Kb
06.02.19
2
.cf 29,81Kb 2 Скачать

Специальные предложения

Избранное Подписка Сортировка: Древо
В этой теме еще нет сообщений.
Оставьте свое сообщение

См. также

Быстрый поиск в журналe регистрации 1С *.lgd 7

Инструменты и обработки Системный администратор Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Журнал регистрации

Обработка для быстрого поиска данных в журнале регистрации 1С SQLite (.lgd). 8.3.15.

1 стартмани

10.10.2019    1762    2    andboss    0       

Сложнейшая загрузка журнала регистрации в ElasticSearch (или делаем настоящий ETL) 36

Инструменты и обработки Системный администратор Архив с данными v8 Россия Windows Абонемент ($m) Журнал регистрации

Году в 2017ом возникло (наверное странное на тот момент) желание перегрузить журнал регистраций 1С в ELK. Чтобы журналы место на диске не съедали, 1С программисты забыв поставить фильтр сервер не подвешивали, все журналы лежали в одном месте да и можно было безопасно туда ответственных пользователей пускать, чтобы сами смотрели кто какой документ поправил.На предложение написать выгрузку сразу из 1С программисты благополучно забили ("ой на это минимум месяц", "у нас срочные бизнес-фичи" и т.д. и т.п.). Зато попалась статья от Aleksey.Bochkov (https://infostart.ru/public/182820/). Ну и решили мы все это запилить без 1С программистов. Во что влезаем я тогда еще не понимал. А вылилось почти в год допилок (хорошо хоть в фоновом режиме) в цельный ETL с использованием C#, T-SQL и прочими делами.

1 стартмани

27.09.2019    2798    3    DonAlPatino    32       

Удаление журнала регистрации с отбором 4

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 1cv8.cf Россия Абонемент ($m) Журнал регистрации

Обработка очистки журнала регистрации с отбором по пользователю и периоду для обычного приложения.

2 стартмани

05.09.2019    667    4    doctorov_s    4       

Журнали2Ст: сверхбыстрый журнал регистрации 1С 86

Инструменты и обработки Системный администратор Программист Приложение (exe) v8 Windows Абонемент ($m) Журнал регистрации

Строит внешний индекс по журналам регистрации любого формата и делает поиск в них фантастически быстрым. Дополнительно ничего не нужно настраивать! Журналы Регистрации остаются на своём месте и не занимают дополнительного, а сервис Журнали2Ста обеспечивает их постоянную индексацию.

1 стартмани

22.08.2019    4593    44    MrWonder    44       

Отчет по изменению документа 7

Отчеты и формы Пользователь Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Журнал регистрации

Данная обработка покажет, кто изменил определенный документ.

1 стартмани

30.07.2019    987    6    ranis888    6       

Отправление событий журнала регистрации в приватный / публичный канал Telegram в виде сообщений и файлов 5

Инструменты и обработки Программист Конфигурация (md, cf) v8 v8::УФ Абонемент ($m) WEB Журнал регистрации

Данная конфигурация позволяет получать события журнала регистрации в телеграм в виде сообщений и файлов.

1 стартмани

29.07.2019    1039    3    serg-lom89    0       

Простейшее использование Elasticsearch для работы с журналом регистрации 15

Инструменты и обработки Системный администратор Программист Архив с данными v8 1cv8.cf Абонемент ($m) Журнал регистрации

Простейшая настройка выгрузки журнала регистрации в Elasticsearch для ускорения поиска.

1 стартмани

20.06.2019    1834    2    milut    7       

Как отправить ошибки из журнала регистрации на почту? Продолжение. Отдельная база 4

Инструменты и обработки no Конфигурация (md, cf) v8 Windows Абонемент ($m) Журнал регистрации

Добавлена отдельная база: возможность указания списка баз, из которых нужно собирать ошибки, возможность указания почтового профиля для каждой базы.

1 стартмани

27.05.2019    1498    2    wowik    0       

Запуск встроенного в платформу механизма История данных для ленивых 17

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Журнал регистрации

В последних версиях платформы 1С появился замечательный механизм Истории данных. Если кратко, механизм позволяет сохранять историю, просматривать, сверять и самое приятное, это восстанавливать любую версию объекта. А самое главное, чтобы это заработало, не нужно продумывать, писать и поддерживать тонны кода, все уже сделано за нас... Возникает вопрос: Как запустить встроенный в платформу механизм Истории данных ничего не кодируя?

1 стартмани

24.05.2019    2861    3    _root    12       

Отчет для просмотра отчетов, которые запускали пользователи 12

Отчеты и формы Системный администратор Пользователь Внешний отчет (ert,erf) v8 1cv8.cf Абонемент ($m) Журнал регистрации

Отчет отвечает на вопрос: кто, и как часто формирует отчеты. Было протестировано на Управлении торговлей, конфигурация 11.4.1.273.

1 стартмани

18.05.2019    1696    8    Mari_Kuznetzova    3       

Подсистема для выгрузки, быстрого поиска и анализа журнала регистрации 1С в Elasticsearch 26

Инструменты и обработки Системный администратор Программист Конфигурация (md, cf) v8 1cv8.cf Абонемент ($m) Журнал регистрации Поиск данных

Elasticsearch - это opensource решение для очень быстрого поиска данных в больших массивах информации. Использование этого решения позволит решить проблемы с поиском и анализом больших объемов информации журнала регистрации. Протестировано на платформах начиная с 8.3.10.2580.

5 стартмани

15.05.2019    3173    13    Nikolo17    12       

Журнал Регистрации ➜ Телеграмм 109

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8::УФ 1cv8.cf Россия Абонемент ($m) Журнал регистрации

Подключаемая обработка для рассылки ошибок журнала регистрации в телеграмм.

1 стартмани

14.05.2019    5595    15    🅵🅾️🆇    9       

История данных [Расширение] УТ11 7

Инструменты и обработки Программист Расширение (cfe) v8 УТ11 Абонемент ($m) Журнал регистрации

Расширение позволяет хранить (восстанавливать) историю данных прикладных объектов (справочников, документов, движений регистров по документам).

3 стартмани

06.05.2019    1620    2    noprogrammer    6       

История выполнения фоновых заданий в виде диаграмм (версия 6.4.17) 20

Отчеты и формы Системный администратор Программист Внешний отчет (ert,erf) v8 1cv8.cf Абонемент ($m) Журнал регистрации

Отчет предназначен для получения из журнала регистрации данных об истории выполнения фоновых заданий и отображения их в виде диаграмм.

1 стартмани

26.04.2019    2348    19    sertak    21       

Журнал регистрации по навигационной ссылке 7

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Абонемент ($m) Журнал регистрации

Обработка получает записи журнала регистрации только по указанной навигационной ссылке (либо просто по ссылке).

1 стартмани

13.03.2019    2030    2    Смешной 1С    0       

Сообщение об ошибках журнала регистрации по электронной почте 2

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 1cv8.cf ЗКГУ3.0 БП3.0 ЗУП3.x Россия Абонемент ($m) Журнал регистрации Email

Универсальная внешняя обработка по выгрузки ошибок журнала регистрации по электронной почте. Может работать как отдельно по команде, так и быть загруженной в справочник Дополнительные отчеты и обработки и запускаться по настраиваемому расписанию.

2 стартмани

04.03.2019    1391    3    ig-efrem    2       

Запрос к Журналу регистрации 2

Отчеты и формы Системный администратор Программист Внешний отчет (ert,erf) v8 ЗКГУ3.0 Россия Windows Абонемент ($m) Журнал регистрации

Краткая форма получения сведений из Журнала регистрации - с детализацией событий до минут

1 стартмани

03.03.2019    1713    9    mnb-next    2       

История версий объектов 2

Инструменты и обработки Системный администратор Программист Архив с данными v8 1cv8.cf Россия Абонемент ($m) Журнал регистрации

Подсистема для записи и хранения изменений любых объектов ссылочного типа. Формирует хронологию работы пользователей с базой данных. Позволяет произвести быстрый поиск версии объекта БД по указанным параметрам и восстановить данные выбранной версии. Протестирована в конфигурации ЗУП, редакция 2.5 на платформе 1С:Предприятие 8.2 (8.2.19.130). Обычные формы. В поставке выгрузка тестовой демонстрационной базы и файл CF c объектами подсистемы.

1 стартмани

22.02.2019    2332    7    dmitrydemenew    3       

Как отправить ошибки из журнала регистрации на почту? 34

Статья Программист Нет файла v8 УПП1 Абонемент ($m) Журнал регистрации

Процедуры отправки ошибок из журнала регистрации на почту. Журнал регистрации выгружается в файл Excel, далее прикрепляется к письму. Для отправки писем создано регламентное задание.

1 стартмани

06.02.2019    4056    wowik    0       

Монитор активных пользователей по журналу регистрации 1

Инструменты и обработки Системный администратор Внешняя обработка (ert,epf) v8 1cv8.cf Россия Windows Абонемент ($m) Журнал регистрации

Монитор активности пользовательских сеансов с возможностью завершить сеансы и соединения. Платформа 1С: 8.3.12.1685. БСП не используется

1 стартмани

01.02.2019    1950    3    mefalcon    2       

Ошибки, предупреждения и прочее из журнала регистрации на почту и в Telegram автоматически (БП 3, ЗУП 3.1, УТ 11.4, ERP 2.4, Розница 2.2) 22

Инструменты и обработки Системный администратор Программист Пользователь Внешняя обработка (ert,epf) v8 Розница УНФ ERP2 ЗКГУ3.0 БП3.0 УТ11 ЗУП3.x Абонемент ($m) Журнал регистрации Поиск данных Тестирование и исправление Email

Данная обработка позволяет анализировать журнал регистрации с пользовательским отбором (4 критерия отбора) и высылать отчет пользователю с заданной периодичностью на электронную почту или в Телеграм. Возможно использовать как регламентное задание (автоматическая отправка отчетов по времени), непосредственно запускать из клиента, а также выгружать в форму обработки отфильтрованные данные из журнала регистрации без отправки.

2 стартмани

28.01.2019    3830    23    Redinternational    3       

Удаление одинаковых версий в журнале регистрации, очистка записей по неверсионированным объектам 1

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 1cv8.cf Украина Абонемент ($m) Чистка базы Журнал регистрации

Обработка также позволяет очищать лишние записи версий объектов, которые все-таки остаются для регистрации в журнале регистрации. Также возможна очистка по неверсионированным в журнале регистрации объектам.

2 стартмани

09.01.2019    1871    t_yuri    0       

Архивирование и удаление файлов журнала регистрации на Linux-сервере 3

Инструменты и обработки Системный администратор Архив с данными v8 Linux Абонемент ($m) Журнал регистрации

Bash-скрипт для архивации и удаления файлов Журнала регистрации в старом формате на Linux-сервере 1С Предприятия.

1 стартмани

29.11.2018    2260    Sloth    4       

Загрузка журнала регистрации 1С v8 в базу SQLServer 6

Инструменты и обработки Системный администратор Программист Архив с данными v8 Россия Windows Абонемент ($m) Журнал регистрации

Загрузка журнала регистрации 1С v8 в базу SQLServer, для хранения архивной информации по журналам, быстрого поиска и/или переноса данных из журнала и его усечения.

10 стартмани

26.10.2018    3394    7    user1054014    12       

Мониторинг активности пользователя 26

Инструменты и обработки Системный администратор Расширение (cfe) v8 БП3.0 Россия Абонемент ($m) Журнал регистрации

Расширение предназначено для мониторинга активности пользователей, фиксирует какие окна открывал и когда пользователь в программе. Автоматически завершает работу не активных пользователей, что позволяет экономить системные ресурсы. Есть отчет об Активности пользователей по часам с возможностью отбора по конкретному пользователю. Расширение для типовых конфигураций 1С на управляемых формах в режиме совместимости 8.3.12.

1 стартмани

26.10.2018    3783    47    xan333    2       

Python-скрипт для массового переключения формата журнала регистрации 3

Инструменты и обработки Системный администратор Архив с данными v8 1cv8.cf Абонемент ($m) Журнал регистрации

Python-скрипт для массового переключения формата журнала регистрации. В первую очередь из SQL в файл. python.exe 1c_format_log_chenger.py Analyze, clearing and change journal format for 1C journal system Use -a or --analyze for analyzing Use -c or --clear for delete all log files Use --sql2file for change logfiles format 2 File Use --file2sql for change logfiles format 2 SQL

1 стартмани

12.10.2018    3066    DonAlPatino    8       

История изменений с ОТКАТОМ (на основе типового решения) 4

Отчеты и формы Системный администратор Бухгалтер Внешняя обработка (ert,epf) v8 УТ11 Россия Абонемент ($m) Журнал регистрации

История изменений документов и справочников с откатом на версию и с отбором по измененным реквизитам для УТ.

1 стартмани

11.10.2018    2956    6    strelec13    2       

Отчет "История изменения объектов" на СКД для БП 3.0, УТ 11, КА 2, ERP 2 (версии объектов) с использованием версионирования объектов 9

Отчеты и формы Системный администратор Бухгалтер Внешний отчет (ert,erf) v8 v8::УФ v8::СКД ERP2 БП3.0 УТ11 КА2 Россия Windows Абонемент ($m) Журнал регистрации

Отчет "История изменения объектов" предназначен для отслеживания изменений справочников и документов в базах 1С. Позволяет выводить сводную таблицу изменений одновременно по всем отобранным объектам. Работает в конфигурациях БП 3.0, УТ 11, КА 2.0, ERP 2.

5 стартмани

03.10.2018    5106    49    mrm1212    35       

Обработка журнала регистрации в формате SQLLite 6

Инструменты и обработки Системный администратор Внешняя обработка (ert,epf) v8 1cv8.cf Россия Windows Абонемент ($m) Журнал регистрации

Обработка предназначена для работы с файлом "1Cv8.lgd" журнала регистрации 1С в формате "SQLLite". Выборка и удаление записей.

1 стартмани

14.09.2018    4125    33    VslavKup    6       

Активные сеансы пользователей на СКД по журналу регистрации для анализа пиков активности и количества одновременно запущенных сеансов 1

Отчеты и формы Системный администратор Внешний отчет (ert,erf) v8 v8::СКД 1cv8.cf Абонемент ($m) Журнал регистрации

Отчет на СКД по журналу регистрации исключительно по событиям сеансов - начало и завершение. Отчет можно использовать для анализа количества работающих пользователей по часам рабочего дня и поиска пиков активности.

1 стартмани

24.08.2018    3420    17    cmax    0       

Мой велосипед для журнала регистрации. Внешний отчёт 4

Отчеты и формы Системный администратор Внешний отчет (ert,erf) v8 УПП1 Абонемент ($m) Журнал регистрации

Отчет по журналу регистрации с отбором по виду метаданных и типу операции.

1 стартмани

31.07.2018    4354    16    alexlx    6       

Мониторинг журнала регистрации при помощи Powershell 28

Статья Системный администратор Программист Архив с данными v8 Windows Абонемент ($m) Сервисные утилиты Журнал регистрации

Работа с журналом регистрации в формате SQLite внешними средствами на примере мониторинга изменений в конфигурации базы данных.

1 стартмани

12.07.2018    7390    3    user768334    7       

Журнал регистрации 1С (sql lite) в web app 13

Статья Программист Архив с данными v8 1cv8.cf Абонемент ($m) Журнал регистрации

Данная публикация рассматривает построение компонентного решения работы журнала регистрации в стороннем приложении(web app). Встала задача миграции sql lite жр во внешнюю базу. Данное решение было создано: 1. для хранения жр за весь период 2. для ускорения работы с жр 3. для ускорения сервера предприятия, так как именно он (а точнее рагент) пытается записать данные в жр sql lite(фактически файл на диске), после увеличения размера файла более 10 гб, поступали жалобы по вопросу быстродействия 1с (и не только ради этого) Данная публикация может быть полезной администраторам, программистам, оптимизаторам.

1 стартмани

09.07.2018    5877    5    dmarenin    4       

R2-D2: журнал регистрации, монитор обменов, аварийные уведомления 14

Инструменты и обработки Системный администратор Программист Архив с данными v8 Россия Абонемент ($m) Сервисные утилиты Журнал регистрации Распределенная БД (УРИБ, УРБД) Администрирование данных 1С

Обслуживание Журналов регистрации нескольких баз 1С. Сбор и обработка сведений о статусах обменов баз 1С, рассылка аварийных уведомлений.

2 стартмани

14.06.2018    7911    16    pbabincev    7       

Отчет "История изменения объектов" на СКД для УПП и КА (версии объектов) с использованием версионирования объектов 13

Отчеты и формы Системный администратор Внешний отчет (ert,erf) v8 v8::СКД КА1 УПП1 Абонемент ($m) Журнал регистрации

Отчет "История изменения объектов" предназначен для отображения изменений объектов (справочники и документы) за указанный период и с учетом отбора по заданным параметрам объектов. Работает в конфигурациях УПП 1.3 и КА 1.1

5 стартмани

22.05.2018    6321    39    mrm1212    11       

Анализ активности пользователей 5

Отчеты и формы Системный администратор Внешний отчет (ert,erf) v8 1cv8.cf Россия Windows Абонемент ($m) Журнал регистрации

Анализ журнала регистрации произвольной конфигурации формата LGD. Платформа 1С:Предприятие 8.3 (8.3.11.2954).

1 стартмани

11.05.2018    5422    18    forusing    0       

Журнал регистрации из формы документа или справочника 7

Инструменты и обработки no Внешняя обработка (ert,epf) v8 Розница УНФ БП3.0 УТ11 КА2 Абонемент ($m) Журнал регистрации

Данная обработка позволяет просматривать журнал регистрации (кто из пользователей последний вносил изменения) по справочнику или документу прямо из формы. Не требуется изменение конфигурации.

2 стартмани

23.04.2018    7660    34    Kutuzov    7       

Протокол действий с документом. Внешняя печатная форма 6

Отчеты и формы Системный администратор Программист Бухгалтер Внешняя обработка (ert,epf) v8 1cv8.cf Россия Абонемент ($m) Журнал регистрации Печатные формы документов

В больших коллективах пользователям (бухгалтерам) нужно быстро узнать, кто, когда и какие действия производил с документом. Представляю универсальную внешнюю печатную форму к любой конфигурации на 1С 8.3 (уф). Обработка сама регистрируется ко всем документам конфигурации. Обработка делает отбор по журналу регистраций и выводит краткую печатную форму. Выводит реальную дату и время создания документа из GUID.

1 стартмани

21.03.2018    5113    14    DEG156    1       

Версии объекта (просмотр версий текущего объекта) 10

Инструменты и обработки Системный администратор Архив с данными v8 КА1 УПП1 Абонемент ($m) Журнал регистрации

Печатная форма, вызывающая отчет подобный встроенному История изменений объектов.

2 стартмани

12.03.2018    7139    3    SITR-utyos    2       

Повышение качества разработок и онлайн контроль ошибок 163

Статья no Расширение (cfe) v8 Абонемент ($m) Журнал регистрации

Анализ ошибок и сбор ошибок журнала регистраций из десятков и сотен баз в одном месте.

09.03.2018    19088    136    DitriX    47       

История изменений объектов 2

Инструменты и обработки Системный администратор Внешняя обработка (ert,epf) v8 1cv8.cf Украина Абонемент ($m) Журнал регистрации

Обработка "История изменений объектов" представляет собой типовой отчет истории изменений объектов, с функцией подключения в виде внешней печатной формы, и возможностью формирования макета "Параметры авторегистрации".

1 стартмани

07.03.2018    6831    4    sakila    0       

История изменений объектов 3

Отчеты и формы Системный администратор Программист Внешний отчет (ert,erf) v8 УПП1 Россия Абонемент ($m) Журнал регистрации

Отчет позволяет получить все изменения по выбранному типу объектов. Может оказаться полезным для администраторов в случае, когда необходимо посмотреть историю изменения различных объектов конкретным пользователем. Протестировано на платформе 8.2.19.130, конфигурации 1С:УПП 1.3.88.2

3 стартмани

02.02.2018    8303    18    s000632    7       

Как нам защитить журнал 4

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Информационная безопасность Журнал регистрации

Первая и важнейшая функция бухгалтерского учета - функция защиты, охраны. В ее основе лежит идея сколь простая, столь же эффективная. Вы должны построить такую систему, в которой любое неправомерное действие будет оставлять следы. Другими словами: никто не будет делать ничего плохого, если это плохое тут же вскроется. Кстати, верно и обратное. Если в вашей системе можно сделать что-то плохое так, что никто никогда не узнает, тогда это плохое рано или поздно сделают. Для обеспечения защитной функции, в 1С уже давно существует т.н. журнал регистрации. Но, к сожалению, есть две причины, по которым этот журнал не может считаться средством защиты...

1 стартмани

23.01.2018    8542    5    mkalimulin    51       

Интерфейс для истории данных (платформенное версионирование) в режиме обычных форм 16

Отчеты и формы Системный администратор Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Россия Абонемент ($m) Журнал регистрации

Как известно, в версии платформы 8.3.11 появился встроенный в платформу механизм версионирования "История данных", однако штатных средств работы с ним в платформе при работе в режиме обычных форм не предусмотрено. Данная обработка предоставляет интерфейс для взаимодействия с механизмом истории данных, функционально сходный с интерфейсом, встроенным в платформу при работе в режиме управляемого приложения.

1 стартмани

12.01.2018    12340    46    Prometeus2011    8       

Анализ времени работы пользователей по журналу регистрации 1

Отчеты и формы Пользователь Руководитель проекта Внешний отчет (ert,erf) v8 v8::СКД 1cv8.cf УУ Учет рабочего времени Абонемент ($m) Журнал регистрации

Отчет анализирует время начала и окончания сеанса в 1С и представляет эти данные в одной таблице.

1 стартмани

08.12.2017    7266    19    belmaxim    0       

Поиск пользователя, блокирующего объект (документооборот 2.1) 1

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 ДО Россия Windows Абонемент ($m) Журнал регистрации

Небольшая обработка помогает найти пользователя, который блокирует объект: внутренний документ, задачу и т.д.

1 стартмани

04.12.2017    6429    9    YuraMatasov    3       

История формирования отчётов. (Используем новые возможности расширений в 8.3.11) 22

Инструменты и обработки Системный администратор Программист Расширение (cfe) v8::УФ v8::СКД УНФ ДО БП3.0 УТ11 ЗУП3.x Абонемент ($m) Журнал регистрации

Подсистема ведёт историю формирования отчётов и позволяет быстро подгрузить используется настройки в отчёт.

1 стартмани

28.11.2017    10382    16    SeiOkami    1       

Сокращение журнала регистрации (Пакетный запуск и в режиме предприятия) 7

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 1cv8.cf Россия Абонемент ($m) Журнал регистрации

Обработка сокращения журнала регистрации. Работает в режимах пакетного запуска (конфигуратор) и в режиме предприятия. Есть возможность подключения как регламентного задания.

1 стартмани

24.11.2017    5981    14    Zedd4D    6