ADO. Работа с БД SQL. Внешние источники данных

07.04.2020 13:37:50   Вася Котов (ayv73@bk.ru)    999

1. Подключение к БД SQL через ADO
2. Выборка полученных данных
3. Использование прямого запроса для создания внешнего источника данных

Сервер SQL имеет отличный от 1С формат даты, поэтому используем это:
format(dateadd(YYYY, -2000, place._Period), 'dd.MM.yyyy hh:mm:ss') AS  _Period

Обратное преобразование даты, для передачи параметра в запрос:
DECLARE @datetime datetime2(0) = dateadd(YYYY, 2000, '31.12.2018 12:32:03');

Шаблон: https://bitbucket.org/snippets/ayvas/8np994/sql-ado

Функция ДанныеADO() Экспорт

strConnect = "DRIVER={SQL Server Native Client 11.0};SERVER=;UID=;PWD=;DATABASE=;Trusted_Connection=yes;LANGUAGE=русский";

Connect = Новый COMОбъект("ADODB.Connection");
Попытка
  Connect.Open(strConnect);
Исключение
  ОписаниеОшибки = "ошибка подключения "+ОписаниеОшибки();
  Возврат ОписаниеОшибки;
КонецПопытки;

ТекстЗапроса = "";
                                
Попытка
  RS = Connect.Execute(ТекстЗапроса);
Исключение
  Возврат "Ошибка запроса : "+ОписаниеОшибки();
КонецПопытки;

Данные = ТЗ();

Пока НЕ RS.EOF Цикл
  
  СтрокаДанных = Данные.Добавить();
  Для каждого Колонка Из Данные.Колонки Цикл
    СтрокаДанных[Колонка.Имя] = СокрЛП(RS.Fields(Колонка.Имя).value)
  КонецЦикла;
  
  RS.MoveNext();
  
КонецЦикла;
    
    Возврат Данные;
  
КонецФункции // ()

Функция ТЗ()

ТЗ = Новый ТаблицаЗначений;
ТЗ.Колонки.Добавить("_Period", Новый ОписаниеТипов("Дата", , ,
           Новый КвалификаторыДаты(ЧастиДаты.ДатаВремя)));
ТЗ.Колонки.Добавить("os", Новый ОписаниеТипов("Строка", ,
           Новый КвалификаторыСтроки(100, ДопустимаяДлина.Переменная)));

Возврат ТЗ;

КонецФункции;

Категории:
 Программирование

Избранное Подписка Сортировка: Древо развёрнутое
Свернуть все
В этой теме еще нет сообщений.
Оставьте свое сообщение
HTTP протокол в 1С для начинающих. Restful api. Postman. Fiddler. БЛОК 1
Иван Козлов. Как поставить качество кода на поток и при этом не разориться? Какие шаги стоит сделать уже завтра, чтобы повысить планку качества?
Мобильная 1С. GUIDELINES
AmoCRM 1С. Аутентификация OAUTH 2 0
Дмитрий Маренин. Как построить микросервисную инфраструктуру
Смотрим внутренности таблиц базы данных 1С
Александр Капралов. Unit-тесты с помощью 1C:Enterprise Development Tools
Дмитрий Жичкин. 1C# – 1С моей мечты
Решитко Дмитрий. Молчание "best practices": тестовые и эталонные данные, структура и связность, падения и новая функциональность, и другие неудобные вопросы к сценарному тестированию
Дмитрий Мишнов. Применение математических достижений в решении сложных задач бизнеса