ADO. Работа с БД SQL. Внешние источники данных

07.04.2020 13:37:50   Вася Котов (ayv73@bk.ru)    2577

1. Подключение к БД SQL через ADO
2. Выборка полученных данных
3. Использование прямого запроса для создания внешнего источника данных

Сервер SQL имеет отличный от 1С формат даты, поэтому используем это:
format(dateadd(YYYY, -2000, place._Period), 'dd.MM.yyyy hh:mm:ss') AS  _Period

Обратное преобразование даты, для передачи параметра в запрос:
DECLARE @datetime datetime2(0) = dateadd(YYYY, 2000, '31.12.2018 12:32:03');

Шаблон: https://bitbucket.org/snippets/ayvas/8np994/sql-ado

Функция ДанныеADO() Экспорт

strConnect = "DRIVER={SQL Server Native Client 11.0};SERVER=;UID=;PWD=;DATABASE=;Trusted_Connection=yes;LANGUAGE=русский";

Connect = Новый COMОбъект("ADODB.Connection");
Попытка
  Connect.Open(strConnect);
Исключение
  ОписаниеОшибки = "ошибка подключения "+ОписаниеОшибки();
  Возврат ОписаниеОшибки;
КонецПопытки;

ТекстЗапроса = "";
                                
Попытка
  RS = Connect.Execute(ТекстЗапроса);
Исключение
  Возврат "Ошибка запроса : "+ОписаниеОшибки();
КонецПопытки;

Данные = ТЗ();

Пока НЕ RS.EOF Цикл
  
  СтрокаДанных = Данные.Добавить();
  Для каждого Колонка Из Данные.Колонки Цикл
    СтрокаДанных[Колонка.Имя] = СокрЛП(RS.Fields(Колонка.Имя).value)
  КонецЦикла;
  
  RS.MoveNext();
  
КонецЦикла;
    
    Возврат Данные;
  
КонецФункции // ()

Функция ТЗ()

ТЗ = Новый ТаблицаЗначений;
ТЗ.Колонки.Добавить("_Period", Новый ОписаниеТипов("Дата", , ,
           Новый КвалификаторыДаты(ЧастиДаты.ДатаВремя)));
ТЗ.Колонки.Добавить("os", Новый ОписаниеТипов("Строка", ,
           Новый КвалификаторыСтроки(100, ДопустимаяДлина.Переменная)));

Возврат ТЗ;

КонецФункции;

Категории:
 Программирование

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. ToryKittony 04.02.21 17:23 Сейчас в теме
Спасибо, коротко, понятно, по теме
Оставьте свое сообщение
Сергей Харламов. Уникальный дизайн в 1С на примере разработки реального продукта
Матвей Серегин. Когда интерфейсам 1С нужны веб-технологии
Анна Гнатюк. Из арт-директора веб-студии в команду разработки продукта на платформе 1С
VanessaRunner. Проверяем доработки после обновления с помощью внешней обработки
Эльдар Мингалиев. Разработка гибридного web-приложения на 1С, возможности и ограничения
VanessaADD. Дымовые тесты для 1С и вывод результата в отчет Allure. Проверяем доработки в расширение
Антон Шаганов. WEB-интерфейсы как механизм сбора данных в розничной сети. Инструменты и наработки.
Юрий Лазаренко. Гарри Поттер и подкапотное пространство веб-клиента
Вадим Фоминых. Адекватный параллелизм в 1С
Николай Крылов. Backend силами 1С. 4 кейса внедрений