Ошибка в 1С:Бух77 ред.533 Начисление ФФОМС при ЕНВД

10.02.12

Задачи пользователя - Адаптация типовых решений

При начислении налогов с ФОТ (док.ЗакрытиеМесяца) не расчитываются налоги ФФОМС, если начисление зарплаты проводится как "облагаемые ЕНВД".

Ошибка возникает по причине того, что расчет ставки налога ФФОМС и ТФОМС идут следом друг за другом и вычисленная ставка налога для ФФОМС затирается затем ставкой налога для ТФОМС (которая в этом году равна 0%)

Для исправления этой ситуации было добавлено пару строк в модуль документа "ЗакрытиеМесяца". 

со строки № 7254

было:

Если РезультатФФОМС <> 0 Тогда
ТаблицаРаспределения = РаспределитьВзносыПоНачислениям(РезультатФФОМС, НачисленияФОМС, СтавкаТарифа, СтавкаТарифаИнвалид, Инвалид, ИмяШкалыВзносов, МатПомощьЕдиновременная, МатПомощьПриРождении);
ТаблицаРаспределения.ВыбратьСтроки();
Пока ТаблицаРаспределения.ПолучитьСтроку() = 1 Цикл
СформироватьПроводку("ФФОМС", Сотрудник, ТаблицаРаспределения, ТаблицаРаспределения.Сумма + ТаблицаРаспределения.СуммаЕНВД);
СформироватьПроводкуСВЗ("ФФОМС", Сотрудник, ТаблицаРаспределения.Сумма + ТаблицаРаспределения.СуммаЕНВД, 0, ТаблицаРаспределения);
КонецЦикла;
КонецЕсли;

стало:

Если РезультатФФОМС <> 0 Тогда
ИмяШкалыВзносов = "ФФОМС"; //добавлено LB2012
СтавкаТарифа = глПолучитьСтавкуВзноса(ВидТарифа,ИмяШкалыВзносов,ДатаКон) / 100; //добавлено LB2012

ТаблицаРаспределения = РаспределитьВзносыПоНачислениям(РезультатФФОМС, НачисленияФОМС, СтавкаТарифа, СтавкаТарифаИнвалид, Инвалид, ИмяШкалыВзносов, МатПомощьЕдиновременная, МатПомощьПриРождении);
ТаблицаРаспределения.ВыбратьСтроки();
Пока ТаблицаРаспределения.ПолучитьСтроку() = 1 Цикл
СформироватьПроводку("ФФОМС", Сотрудник, ТаблицаРаспределения, ТаблицаРаспределения.Сумма + ТаблицаРаспределения.СуммаЕНВД);
СформироватьПроводкуСВЗ("ФФОМС", Сотрудник, ТаблицаРаспределения.Сумма + ТаблицаРаспределения.СуммаЕНВД, 0, ТаблицаРаспределения);
КонецЦикла;
КонецЕсли;

------

и со  строки №7263

было:

Если РезультатТФОМС <> 0 Тогда 

ТаблицаРаспределения = РаспределитьВзносыПоНачислениям(РезультатТФОМС, НачисленияФОМС, СтавкаТарифа, СтавкаТарифаИнвалид, Инвалид, ИмяШкалыВзносов, МатПомощьЕдиновременная, МатПомощьПриРождении);

ТаблицаРаспределения.ВыбратьСтроки();

Пока ТаблицаРаспределения.ПолучитьСтроку() = 1 Цикл

СформироватьПроводку("ТФОМС", Сотрудник, ТаблицаРаспределения, ТаблицаРаспределения.Сумма + ТаблицаРаспределения.СуммаЕНВД);

СформироватьПроводкуСВЗ("ТФОМС", Сотрудник, ТаблицаРаспределения.Сумма + ТаблицаРаспределения.СуммаЕНВД, 0, ТаблицаРаспределения);

КонецЦикла;

КонецЕсли;


стало:

Если РезультатТФОМС <> 0 Тогда 

ИмяШкалыВзносов = "ТФОМС";//добавлено LB2012

СтавкаТарифа = глПолучитьСтавкуВзноса(ВидТарифа,ИмяШкалыВзносов,ДатаКон) / 100;//добавлено LB2012

ТаблицаРаспределения = РаспределитьВзносыПоНачислениям(РезультатТФОМС, НачисленияФОМС, СтавкаТарифа, СтавкаТарифаИнвалид, Инвалид, ИмяШкалыВзносов, МатПомощьЕдиновременная, МатПомощьПриРождении);

ТаблицаРаспределения.ВыбратьСтроки();

Пока ТаблицаРаспределения.ПолучитьСтроку() = 1 Цикл

СформироватьПроводку("ТФОМС", Сотрудник, ТаблицаРаспределения, ТаблицаРаспределения.Сумма + ТаблицаРаспределения.СуммаЕНВД);

СформироватьПроводкуСВЗ("ТФОМС", Сотрудник, ТаблицаРаспределения.Сумма + ТаблицаРаспределения.СуммаЕНВД, 0, ТаблицаРаспределения);

КонецЦикла;

КонецЕсли;

См. также

Улучшенная обработка "Внешние печатные формы" для типовых конфигураций на базе 1С 7.7

Печатные формы Адаптация типовых решений Платформа 1С v7.7 Конфигурации 1cv7 Абонемент ($m)

Приятное улучшение обработки "Внешние печатные формы" для типовых конфигураций на базе 1С 7.7 для более комфортной работы с "любимой семерочкой".

1 стартмани

04.02.2022    3232    1    igor7777    0    

3

Расчет страховых взносов в 1С 7.7 "Учет и отчетность предпринимателя, ред. 1.2" с апреля 2020

Адаптация типовых решений Платформа 1С v7.7 Конфигурации 1cv7 Россия Бухгалтерский учет ФОМС, ЕФС Бесплатно (free)

В этой статье описано, какие небольшие изменения можно внести в модуль документа Начисление налогов с ФОТ, чтобы правильно рассчитывались страховые взносы с 1 апреля 2020 г.

09.04.2020    19990    Юджин58    39    

5

Дистрибьюция 7.7. Часть 1. Жизненный цикл заявки покупателя. Одна заявка покупателя, много адресов доставки.

Адаптация типовых решений Платформа 1С v7.7 1С:Комплексная 7.7 1С:Торговля и склад 7.7 Управленческий учет Бесплатно (free)

Описан способ работы с учетом расписания с приоритетными покупателями - торговыми сетями (основными покупателями) в торговой или комплексной учетной системе на 1С 7.7. Множественная заявка покупателя на несколько торговых точек.

14.10.2019    6088    ksnik    14    

3

Как в торговле 7.7 печатать код ТНВЭД в счет-фактуре

Операции по ВЭД Адаптация типовых решений Оперативный учет 7.7 1С:Торговля и склад 7.7 Россия Бухгалтерский учет НДС Бесплатно (free)

В данной статье хотел поделиться опытом, как в Торговле 7.7 ( релиз 994) сделать возможность выводить код ТНВЭД в печатную форму счета-фактуры. Сразу скажу, что нужно это только тем, кто осуществляет экспорт в страны таможенного союза. Остальные могут не волноваться.

15.11.2017    11863    AndKovalchuk    0    

1

Предельные базы взносов в ПФР, ФСС, ФФОМС 2015 в 1С: Бухгалтерия 7.7

Зарплата Адаптация типовых решений Бухгалтерский учет 7.7 1С:Бухгалтерия 7.7 Россия Бухгалтерский учет Абонемент ($m)

Реализация Постановления Правительства РФ 1316 от 04.12.14 для типовой конфигурации "Бухгалтерский учет 7.7" рел. 7.70.590

1 стартмани

31.12.2014    23973    9    Sergey1CSpb    2    

0
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
0. lelbraun 188 09.02.12 16:46 Сейчас в теме
При начислении налогов с ФОТ (док.ЗакрытиеМесяца) не расчитываются налоги ФФОМС, если начисление зарплаты проводится как "облагаемые ЕНВД".


Перейти к публикации

1. 1801 09.02.12 16:46 Сейчас в теме
Спасибо, полтора часа убил на поиск так и не нашел ошибки! А тут готовое решение.
Еще исправьте ошибку в тексте публикации, а то при копировании в модуль ругается на синтаксис.
Пока ТаблицаРаспределения.ПолучитьСтроку() = 1 ЦиклСформироватьПроводку("ТФОМС", Сотрудник, ТаблицаРаспределения,
Оставьте свое сообщение