Запись/Чтение XML, пример обмена по COM соединению

Публикация № 1119287

Разработка - Системная интеграция - Обмен через XML

XML ЗаписьXML ЧтениеXML COMСоединение ОбменXML

Пример работы с XML, запись и чтение, обмен по COM между одинаковыми конфигурациями.

Приветствую вас, друзья. Хочу поделиться опытом работы с файлами XML, возможно, пригодится начинающим в этом деле )

1 пример - запись\чтение XML, выгрузим документ в xml файл и загрузим его обратно

2 пример, выгрузка номенклатуры в идентичную конфигурацию по COM Соединению.

Для выгрузки документа в базу с другой конфигурацией будем объявлять элементы и пространства имен вручную. 

&НаКлиенте
Функция ПолучитьПутьКФайлу(Режим)
	ЗаписьXML = Новый ЗаписьXML;
	///1 ВАРИАНТ, Прописываем путь к фалу, при записи - файл будет перезаписываться 
	ПутьКФайлу = "d:\Temp\Test.XML";
		
	///2 ВАРИАНТ, Указываем путь при сохранении/открытии 
	Диалог = Новый ДиалогВыбораФайла(Режим);
	Диалог.Заголовок = "Выбрать"; 
	Диалог.Фильтр = "XML (*.xml)|*.xml"; 
    Диалог.МножественныйВыбор = Ложь;
	Диалог.Каталог = "F:\";  	//При желании, (Открывается этот диск по умолчанию)
	Если Диалог.Выбрать() Тогда
		ПутьКФайлу = Диалог.ПолноеИмяФайла;
	Иначе 
		возврат Неопределено;
	КонецЕсли;
	
	Возврат ПутьКФайлу ;
КонецФункции

&НаКлиенте
Процедура ЗаписьВРучную_XML()
	
	ПутьКФайлу =  ПолучитьПутьКФайлу(РежимДиалогаВыбораФайла.Сохранение);
	Если ПутьКФайлу = Неопределено Тогда ///Если не выбран путь к фалу прерываем операцию
		возврат;
	КонецЕсли;
	
	Документ = СсылкаНаДокумент;  /// СсылкаНаДокумент - реквизит со ссылкой на документ "ПоступлениеТоваров"
	
	ЗаписьXML.ОткрытьФайл(ПутьКФайлу, "UTF-8"); //Открываем файл для записи, указываем кодировку
	
	ЗаписьXML.ЗаписатьОбъявлениеXML();  // Записываем объявление XML
	ЗаписьXML.ЗаписатьНачалоЭлемента("ПоступлениеТоваров"); // Начало элемента Документа "ПоступлениеТоваров"
	
	ЗаписьXML.ЗаписатьАтрибут("Код",Строка(Документ.Код));   
	ЗаписьXML.ЗаписатьАтрибут("Дата",Строка(Документ.Дата)); 
	ЗаписьXML.ЗаписатьАтрибут("Номер",Строка(Документ.Номер));
	ЗаписьXML.ЗаписатьАтрибут("Ответственный",Строка(Документ.Ответственный));
	ЗаписьXML.ЗаписатьАтрибут("Комментарии",Строка(Документ.Комментарии));
	ЗаписьXML.ЗаписатьАтрибут("Склад",Строка(Документ.Склад));
	
	///Запись табличной части "Товары"
	Для Каждого выборка из Документ.Товары Цикл  // Начинаем выгружать табличную часть "Товары"
		ЗаписьXML.ЗаписатьНачалоЭлемента("ТаблицаТовары"); // Начало элемента "ТаблицаТовары"
		
		ЗаписьXML.ЗаписатьАтрибут("Номенклатура",Строка(Выборка.Номенклатура));
		//ЗаписьXML.ЗаписатьАтрибут("КодНоменклатуры",Строка(Выборка.Номенклатура.Код)); ///ЕСЛИ СОВПАДАЮТ КОДЫ В БАЗАХ, МОЖНО ПРОИЗВОДИТЬ ПОИСК ПО КОДУ ПРИ ЧТЕНИИ
		ЗаписьXML.ЗаписатьАтрибут("Количество",Строка(Выборка.Количество));
		ЗаписьXML.ЗаписатьАтрибут("Цена",Строка(Выборка.Цена));
		ЗаписьXML.ЗаписатьАтрибут("Сумма",Строка(Выборка.Сумма));
		ЗаписьXML.ЗаписатьАтрибут("ЕД",Строка(Выборка.Номенклатура.ЕдиницаИзмерения));
		
		ЗаписьXML.ЗаписатьКонецЭлемента(); // Конец элемента "ТаблицаТовары"
	КонецЦикла;
	ЗаписьXML.ЗаписатьКонецЭлемента(); // Конец элемента "ПоступлениеТоваров"
	Сообщить("Файл успешно записан!");

КонецПроцедуры

Чтение файла:

&НаКлиенте
Процедура ЧтениеВРучную_XML()
	ПутьКФайлу =  ПолучитьПутьКФайлу(РежимДиалогаВыбораФайла.Открытие);
	Если ПутьКФайлу = Неопределено Тогда ///Если не выбран путь к фалу прерываем операцию
		возврат;
	КонецЕсли;
			
	ЧтениеXML = Новый ЧтениеXML;	
	ЧтениеXML.ОткрытьФайл(ПутьКФайлу);  //Открываем файл
	
	///Запись документа должна быть на сервере
	ЧтениеXMLНаСервере(ЧтениеXML);
	ПоказатьОповещениеПользователя("Уведомление",,"Документ записан!",БиблиотекаКартинок.Успешно32);
КонецПроцедуры

&НаСервере
Процедура ЧтениеXMLНаСервере(ЧтениеXML)
	
	Документ = Документы.ПоступлениеТоваров.СоздатьДокумент();  ///НОВЫЙ ДОКУМЕНТ
	Товары =  Документ.Товары; 									///ТАБЛИЧНАЯ ЧАСТЬ "Товары"
	
	Пока ЧтениеXML.Прочитать() Цикл  //Цикл по структуре
		Если ЧтениеXML.ТипУзла = ТипУзлаXML.НачалоЭлемента Тогда  //Определяем начало элемента
			Если ЧтениеXML.Имя = "ПоступлениеТоваров" Тогда
				Документ.Код 			= ЧтениеXML.ЗначениеАтрибута("Код");
				Документ.Дата 			= Дата(ЧтениеXML.ЗначениеАтрибута("Дата")); ///Преобразовываем обратно в дату
				Документ.Номер 			= ЧтениеXML.ЗначениеАтрибута("Номер");
				Документ.Ответственный 	= Справочники.Пользователи.НайтиПоНаименованию(ЧтениеXML.ЗначениеАтрибута("Ответственный"));
				Документ.Комментарии 	= ЧтениеXML.ЗначениеАтрибута("Комментарии");
				Документ.Склад 			= Справочники.Склады.НайтиПоНаименованию(ЧтениеXML.ЗначениеАтрибута("Склад"));
			КонецЕсли;
			Если ЧтениеXML.Имя = "ТаблицаТовары" Тогда   ///Чтение элемента  "ТаблицаТовары"
				НоваяСтрока = Товары.Добавить();
				НоваяСтрока.Номенклатура       = Справочники.Пользователи.НайтиПоНаименованию(ЧтениеXML.ЗначениеАтрибута("Номенклатура"));
				//НоваяСтрока.КодНоменклатуры  = Справочники.Пользователи.НайтиПоКоду(ЧтениеXML.ЗначениеАтрибута("КодНоменклатуры"));
				НоваяСтрока.Количество         = Число(ЧтениеXML.ЗначениеАтрибута("Количество"));
				НоваяСтрока.Цена               = Число(ЧтениеXML.ЗначениеАтрибута("Цена"));
				НоваяСтрока.Сумма              = Число(ЧтениеXML.ЗначениеАтрибута("Сумма"));
				НоваяСтрока.ЕД                 = НоваяСтрока.Номенклатура.ЕденицаИзмерения;
			КонецЕсли;
		КонецЕсли ;
	КонецЦикла;
	
	Документ.Записать(РежимЗаписиДокумента.Проведение);	

КонецПроцедуры

Такой метод не всегда эффективен, так как наименования реквизитов могут отличаться, и запись осуществится с ошибками (Например с пустыми реквизитами), вполне подойдет для выгрузки и загрузки определенных элементов между не типовыми конфигурациями. Для более сложных задач (Выгрузка\Загрузка документов и справочников со структурой подчиненности) между не типовыми конфигурациями рекомендуется использовать Конвертацию данных и универсальный обмен данными в формате XML .

Пример Выгрузки и загрузки данных между одинаковыми базами средствами XDTO.

&НаКлиенте
Процедура ЗаписьСредствамиXDTO_XML()
	
	ПутьКФайлу =  ПолучитьПутьКФайлу(РежимДиалогаВыбораФайла.Сохранение);
	Если ПутьКФайлу = Неопределено Тогда ///Если не выбран путь к фалу прерываем операцию
		возврат;
	КонецЕсли;
	
	Документ = СсылкаНаДокумент;  /// СсылкаНаДокумент - реквизит со ссылкой на документ "ПоступлениеТоваров"
	
    /////////////////////////////////////////////////////////////////////////
    //Выгрузка
    
    Запись = Новый ЗаписьXML;
    ЗаписьXML.ОткрытьФайл(ПутьКФайлу, "UTF-8"); //Открываем файл для записи, указываем кодировку
    
    //записываем объявление xml файла: <?xml version="1.0"?>
    Запись.ЗаписатьОбъявлениеXML();
    
    //записываем корневой элемент, по спецификации xml он может быть только один, назовем его "Данные"
    Запись.ЗаписатьНачалоЭлемента("ПоступлениеТоваров");
    
    //для того чтобы пространства имен не объявлялись сериализатором в кажом элементе, пишем их в корневой элемент
    //они будут работать на все вложеные элементы
    //пространство имен по-умолчанию
    Запись.ЗаписатьСоответствиеПространстваИмен("", "http://v8.1c.ru/8.1/data/enterprise/current-config");
    
    //пространства имен остальные префиксы
    Запись.ЗаписатьСоответствиеПространстваИмен("xsd", "http://www.w3.org/2001/XMLSchema");
    Запись.ЗаписатьСоответствиеПространстваИмен("xsi", "http://www.w3.org/2001/XMLSchema-instance");
    
       
     //вместо этого кода в боевой реализации выгрузки будет создание ОбъектаXDTO и его сериализация
     //через ФабрикуXDTO и загруженные в нее схемы конфигурации приемника
     СериализаторXDTO.ЗаписатьXML(Запись, Документ.ПолучитьОбъект());
	
	/////ПРИМЕР ЗАПИСИ НЕСКОЛЬКИХ ДОКУМЕНТОВ 
	//Выборка = Справочники.ПоступлениеТоваров.Выбрать();
	//Пока Выборка.Следующий() Цикл        
	//    СериализаторXDTO.ЗаписатьXML(Запись, Выборка.ПолучитьОбъект());
	//КонецЦикла;

    
    //записываем конец корневого элемента
    Запись.ЗаписатьКонецЭлемента();
    Сообщить("Файл успешно записан!");

	//// посмотреть содержимое xml
	//Текст = Запись.Закрыть();
	//Сообщить("Содержимое файла:");
	//Сообщить(Текст);
    
КонецПроцедуры


/////////////////////////////////ЗАГРУЗИМ ОБРАТНО 
////////////////////////////////////////////////////

&НаКлиенте
Процедура  ЧтениеСредствамиXDTO_XML()
	
	ПутьКФайлу =  ПолучитьПутьКФайлу(РежимДиалогаВыбораФайла.Открытие);
	Если ПутьКФайлу = Неопределено Тогда ///Если не выбран путь к фалу прерываем операцию
		возврат;
	КонецЕсли;

	/////////////////////////////////////////////////////////////////////////
    //Загрузка
    
    Чтение = Новый ЧтениеXML;	
	Чтение.ОткрытьФайл(ПутьКФайлу);  //Открываем файл
	
	///Запись документа должна быть на сервере
	ЧтениеXMLНаСервереЧасть2(Чтение);
	
КонецПроцедуры

&НаСервере
Процедура ЧтениеXMLНаСервереЧасть2(Чтение)
	
	//прочитаем начало xml файла
    Чтение.ПерейтиКСодержимому();
    
    //прочитаем начало корневого элемента
    Чтение.Прочитать();
    
    //читаем содержимое пока текущим не станет конец корневого элемента, т.к. мы писали туда только целые элементы справочника,
    //а сериализатор читает каждый из их полностью, то мы упремся именно в конец корневого
    Пока Чтение.ТипУзла<>ТипУзлаXML.КонецЭлемента Цикл
        
        //читаем очередной элемент справочника
        Объект = СериализаторXDTO.ПрочитатьXML(Чтение);
        //покажем что прочитали, осталось только записать объект
        Сообщить(""+ТипЗнч(Объект)+" - "+Объект);
		Объект.Записать(РежимЗаписиДокумента.Проведение);
    КонецЦикла;
    
    Чтение.Закрыть();

КонецПроцедуры

 

Пример выгрузки номенклатуры в одинаковую базу, без сохранения файла XML на диске: 

&НаСервере
Функция ПодключениеПоCOM()
	//КаталогБазыДанных="C:\ЗУП3";     ///ФАЙЛОВАЯ БАЗА
	
	БазаДанных		="ZUP3";          ///СЕРВЕР
	Сервер			="Server1";
	Пользователь	="Admin";
	Пароль			="Admin";

	V8 = Новый COMОбъект("V83.ComConnector"); 
	//Открытие = "file='" + КаталогБазыДанных + "'; usr='" + Пользователь + "'; pwd='" + Пароль + "';";        			/// ФАЙЛОВОЕ
	Открытие= "srvr='" + Сервер + "'; ref='" + БазаДанных + "'; usr='" + Пользователь + "'; pwd='" + Пароль + "';";     /// СЕРВЕРНОЕ
		
	Соединение = V8.Connect(Открытие);
	Возврат Соединение;	
КонецФункции

&НаСервере
Процедура ПодключитьсяИЗаписать()

	Соединение = ПодключениеПоCOM();
    /////////////////////////////////////////////////////////////////////////
    //Выгрузка
    
    Запись = Новый ЗаписьXML;
    Запись.УстановитьСтроку();
    
    //записываем объявление xml файла: <?xml version="1.0"?>
    Запись.ЗаписатьОбъявлениеXML();
    
    //записываем корневой элемент, по спецификации xml он может быть только один, назовем его "Данные"
    Запись.ЗаписатьНачалоЭлемента("Данные");
    
    //для того чтобы пространства имен не объявлялись сериализатором в кажом элементе, пишем их в корневой элемент
    //они будут работать на все вложеные элементы
    //пространство имен по-умолчанию
    Запись.ЗаписатьСоответствиеПространстваИмен("", "http://v8.1c.ru/8.1/data/enterprise/current-config");
    
    //пространства имен остальные префиксы
    Запись.ЗаписатьСоответствиеПространстваИмен("xsd", "http://www.w3.org/2001/XMLSchema");
    Запись.ЗаписатьСоответствиеПространстваИмен("xsi", "http://www.w3.org/2001/XMLSchema-instance");
    
    //ограничение количества выгружаемых элементов для примера
    Кол = 4;
    Выборка = Справочники.Номенклатура.Выбрать();
    Пока Выборка.Следующий() Цикл
        
        //вместо этого кода в боевой реализации выгрузки будет создание ОбъектаXDTO и его сериализация
        //через ФабрикуXDTO и загруженные в нее схемы конфигурации приемника
        СериализаторXDTO.ЗаписатьXML(Запись, Выборка.ПолучитьОбъект());
        //
        
        Кол = Кол - 1;
        Если Кол=0 Тогда
            Прервать;
        КонецЕсли;
    КонецЦикла;
    
    //записываем конец корневого элемента
    Запись.ЗаписатьКонецЭлемента();
    Текст = Запись.Закрыть();
    
    //а теперь загрузим это  в новую базу 
    
    /////////////////////////////////////////////////////////////////////////
    //Загрузка
    
    Чтение = Соединение.NewObject("ЧтениеXML");
    Чтение.УстановитьСтроку(Текст);
    
    //прочитаем начало xml файла
    Чтение.ПерейтиКСодержимому();
    
    //прочитаем начало корневого элемента
    Чтение.Прочитать();
    
    //читаем содержимое пока текущим не станет конец корневого элемента, т.к. мы писали туда только целые элементы справочника,
    //а сериализатор читает каждый из их полностью, то мы упремся именно в конец корневого
    Пока Чтение.ТипУзла<>ТипУзлаXML.КонецЭлемента Цикл
        
        //читаем очередной элемент справочника
        Объект = Соединение.СериализаторXDTO.ПрочитатьXML(Чтение);
        
        //покажем что прочитали, осталось только записать объект
       // Сообщить(""+ТипЗнч(Объект)+" - "+Объект);
	   
	   //Запишем..
		Объект.Записать();
    КонецЦикла;
    
    Чтение.Закрыть();
	Сообщить("Операция завершена!");
	
КонецПроцедуры

Кстати, можно использовать данный метод между не типовыми конфигурациями,  без использования "СериализаторXDTO" как в первом примере )

Спасибо за внимания! Прошу строго не судить ) возможно данный пример поможет именно для решение вашей задачи !) Удачи (=

Буду рад услышать более эффективные решения для подобных задач ! Спасибо !)

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. gospodenkods 09.09.19 08:29 Сейчас в теме
Интересно. А какой смысл гонять xml через COM ? Имея COM можно и напрямую общаться не используя XML
artfa; fomix; altu71; nomad_irk; A_Max; +5 Ответить
5. cool99 09.09.19 11:50 Сейчас в теме
(1)
(4)
Можно банально гонять XML/JSON через WS предварительно зазиповав в хранилище значения
6. gospodenkods 09.09.19 13:32 Сейчас в теме
(5)
Можно конечно .

Но XML через COM уж больно броско в глаза .

По мне так COM если есть , то через него напрямую и работать .

XML / JSON особенно over HTTP тогда , когда или нет вариантов COM или клиенты разные.
2. dsdred 1491 09.09.19 09:42 Сейчас в теме
И опять COM, xml...
У Вас же была предыдущая статья с web-сервисами, зачем тут то опять "назад в прошлое"?
3. user5300 545 09.09.19 09:53 Сейчас в теме
(2) Не все хотят заморачиваться с Web - Сервисами, а здесь обзор простого примера,
и (1) Сериализатор поможет избавится от большого программного кода (=
4. dsdred 1491 09.09.19 09:59 Сейчас в теме
(3)
Не все хотят заморачиваться с Web - Сервисами

Согласен, можно менее геморойно использовать http-сервисы и OData

Сериализатор поможет избавится от большого программного кода

Согласен, при этом 1C работает с форматом JSON
7. ovasiliev 5 09.10.19 16:14 Сейчас в теме
Что вы напали на человека? Если у вас две базы на одном серваке крутятся, вы для риал-тайм обмена между ними будете веб-сервер поднимать и с веб-сервисами заморачиваться?..
А XML - стандартный формат обмена данными даже в клиент-серверном взаимодействии. Всё через сериализацию..
Drivingblind; user5300; +2 Ответить
Оставьте свое сообщение

См. также

Регулярные выражения без внешних компонент? Легко! Промо

Практика программирования Обмен через XML v8 Бесплатно (free)

Сложный способ организовать проверку строки с помощью регулярного выражения в 1С. При этом ни одна внешняя компонента не пострадала. Ну и от платформы (Linux, MustDie) - не зависит.

04.03.2016    63036    starik-2005    103    

Конвертация данных 2. Использование подключаемых обработок в правилах обмена. Конвертация дерева значений

Обмен данными 1С Обмен через XML Перенос данных из 1C8 в 1C8 v8 КД Бесплатно (free)

Разработка правил обмена с использованием подключаемых обработок. В качестве примера рассмотрена реальная задача конвертации дерева значений.

15.06.2020    3512    Drivingblind    8    

[БСП] Обмен через Конвертацию данных 2.1

Обмен через XML v8 1cv8.cf Бесплатно (free)

Добавим новый план обмена и настроим в БСП типовой обмен через правила конвертации данных (КД 2.1)

03.02.2020    7940    John_d    16    

Обмен через Конвертацию данных 2.1 во внешней обработке + Запуск внешней обработки по расписанию (БСП)

Обмен через XML v8 1cv8.cf Бесплатно (free)

Сделаем ежедневную выгрузку и загрузку данных через конвертацию данных 2.1 из одной базы в другую. Но весь код и правила конвертации будут располагаться во внешней обработке.

22.01.2020    5994    John_d    30    

Загрузка из EXCEL в 1С. Чтение файла XLSX средствами 1С. ПостроительDOM Промо

Универсальные обработки Загрузка и выгрузка в Excel Обмен через XML v8 1cv8.cf Бесплатно (free)

ПРАКТИЧЕСКОЕ ПОСОБИЕ РАЗРАБОТЧИКА: Метод "NativeXLSX" (ПостроительDOM). Обрабатываются данные EXCEL типов: "Строка", "Число", "Дата" ("Время"), "Булево", "Процент", а также изображения.

11.09.2014    73539    StepByStep    27    

Как сделать обмен данными через универсальный формат быстрее? Реализация многопоточного обмена данными

Обмен данными 1С Обмен через XML v8 1cv8.cf Бесплатно (free)

Предлагаю Вашему вниманию интересный кейс по реализации обмена данными через универсальный формат между современными типовыми конфигурациями в режиме многопоточности. Учитывая все тонкости механизмов обмена данными и сложности типовых правил конвертации, сделать это оказалось совсем не так просто.

31.12.2019    8268    ids79    17    

Использование XML-схемы из макета внешней обработки

Обмен через XML Универсальные функции v8 1cv8.cf Бесплатно (free)

Простой способ использования XML-схем из макета внешней обработки.

28.10.2019    10985    Olesia_Matusevich    10    

Преобразование XML в таблицу значений или иной объект 1С методом XSL преобразования

Универсальные функции Обмен через XML v8 1cv8.cf Бесплатно (free)

Сразу открою интригу, напрямую прочитать XML, не содержащий объект 1С, не удастся. Статья раскрывает способы привести XML к формату, который возможно прочитать средствами платформы.

24.10.2019    11532    kraspila    30    

Отладка правил обмена 7.7, 8 Промо

Перенос данных из 1С7.7 в 1C8.X Обмен через XML Перенос данных из 1C8 в 1C8 v8 КД Бесплатно (free)

Отладка правил обмена всегда была для меня больной темой, пока наконец-то не разобрался. В интернете мало тем, посвященных этому, поэтому решил написать небольшую инструкцию по этому поводу. Очень надеюсь, что она будет кому-то полезна. С радостью выслушаю недочеты.

29.10.2013    51567    pyrkin_vanya    70    

Доработка конвертации данных КД2 (версии 2.1). Расширенная диагностическая информация при выгрузке по правилам из 1С 7.7 и при загрузке в 1С 7.7

Обмен данными 1С Перенос данных из 1С7.7 в 1C8.X Обмен через XML v7.7 v8 КД Бесплатно (free)

Есть очень неприятная особенность при настройке обмена по правилам КД2 в момент отладки на стороне 1С 7.7, как при выгрузке из 1С 7.7, так и при загрузке в 1С 7.7. Непонятно, в каком конкретно месте формирования или разбора данных XML файла в какой именно момент споткнулась программа (произошел сбой). Я нашел способ вывода дополнительной диагностики, теперь точно известно, на каком элементе данных XML споткнулся модуль выгрузки V77Exp.ert (модуль загрузки V77Imp.ert). Теперь отладка правил обмена на стороне 1С 7.7 стала простой, выполняется на порядок проще.

18.10.2019    5705    ksnik    0    

Практика XDTO. Нюансы

Практика программирования Обмен через XML v8 Бесплатно (free)

Некоторые практические моменты работы с XDTO. Дополнения к очевидному.

23.09.2019    13788    Yashazz    30    

Конвертация данных 2.0. Перенос справочника с иерархией групп и элементов

Обмен через XML v8 1cv8.cf Россия Бесплатно (free)

Детективная история о том, как при переносе элементы справочника становились не "видимыми".

09.08.2019    5437    chagbig    6    

Обмен по расписанию типовыми средствами. Промо

Распределенная БД (УРИБ, УРБД) Обмен через XML Перенос данных из 1C8 в 1C8 v8 1cv8.cf Россия Бесплатно (free)

Часто перед интеграторами стоит задача организовать автообмен (по расписанию или при наступлении какого-либо события) данными между различными конфигурациями. В этой статье я попробую изложить простую инструкцию, как это можно сделать средствами, заложенными в типовые конфигурации 1С (ЗУП, БП, УПП и т.д.). Для обмена используется подсистема "Обмен данными" из БСП

20.06.2012    103070    kser87    52    

Загрузка данных в БП 3.0 (Универсальный обмен данными XML)

Обмен через XML v8::БУ БП3.0 БУ Бесплатно (free)

Решение задачи по загрузке данных из имеющегося файла в формате xml в БП 3.0 (в том числе на 1cfresh.com) без доработок

26.05.2019    5338    rutadmeen    0    

Конвертация 3.0. Пример доработки: два справочника в один

Обмен через XML v8 КД ERP2 БП3.0 Россия Бесплатно (free)

Доработка правил конвертации путем расширения конфигурации: номенклатура и характеристика (ERP) в номенклатуру (БП).

15.05.2019    7712    forusing    4    

Обмен данными между УПП 1.3.64.х и БП 3.0 по расписанию через Универсальный обмен данными + План обмена

Обмен через XML Перенос данных из 1C8 в 1C8 v8 УПП1 Россия Бесплатно (free)

Описание доработки конфигурации УПП 1.3.64.х для выполнения обмена данными по расписанию в БП 3.0. через обработку Универсальный Обмен Данными XML и План Обмена.

09.04.2019    7402    mrcamomile    15    

Альтернативные способы работы с XML. Часть 2: Введение в xPath или запросы к XML Промо

Обмен через XML Математика и алгоритмы v8 1cv8.cf Бесплатно (free)

В предыдущей статье "Введение в DOM или объектная модель документа" было описано понятие объектной модели документа (DOM), раскрыты плюсы и минусы использования модели при разборе файлов XML, приведено сравнение с построчным последовательным разбором. Были представлены варианты выборки данных с помощью объекта 1С ДокументDOM. Теперь настало время познакомить читателей с самым, на мой взгляд, интересным способом извлечения данных из XML - при помощи языка запросов xPath.

09.08.2012    42291    1cspecialist    13    

RabbitMQ + Конвертация Данных 3.0

Внешние источники данных Обмен через XML Интеграция Перенос данных из 1C8 в 1C8 v8 КД Бесплатно (free)

Предлагаем ознакомиться с хронологией проекта, проследить ход мыслей от снятия потребностей до реализации, и решить, удалось ли проектной команде найти оптимальное архитектурное решение под конкретный кейс заказчика путем совмещения двух известных, но до сих пор не пересекавшихся технологий, и получилось ли сложить плюсы и устранить минусы каждой из них.

21.03.2019    26754    barelpro    82    

EnterpriseData – часть 2. Процесс выгрузки данных

Практика программирования Обмен через XML v8 v8::УФ Россия Бесплатно (free)

Основные этапы выгрузки данных через ED, обработчики событий выгрузки, правила обработки данных, правила конвертации объектов, конвертация свойств первого и второго этапов, процедуры БСП, используемые при выгрузке данных, структура «КомпонентыОбмена».

26.12.2018    27263    ids79    31    

Неполадки в работе функционала конфигурации "Бухгалтерия предприятия 3.0" после переноса данных из одной конфигурации в другую через XML

Обмен через XML v8 БП3.0 Россия Бесплатно (free)

«Подводные камни» в работе конфигурации «Бухгалтерия предприятия 3.0» после переноса данных из одной конфигурации в другую средствами XML.

18.12.2018    5177    faust0923    1    

Новый подход к обмену данными EnterpriseData

Практика программирования Обмен через XML v8 v8::УФ Россия Бесплатно (free)

Хочу предложить Вашему вниманию цикл статей, посвященных обмену данными через универсальный формат (EnterpriseData или ED).

14.12.2018    42203    ids79    72    

MDM система для централизованного управления справочниками предприятия типовыми средствами

Обмен через XML Обработка справочников v8 1cv8.cf Бесплатно (free)

Поставили мне пару недель назад задачу настроить единые справочники номенклатуры во всех базах холдинга. Учитывая количество 1С бухгалтерий, которых в процессе выполнения задачи оказалось 32, и учитывая, что они все разных версий (2.0, 3.0, отраслевые), задача казалась из ряда чистой воды подстава. Но решение с технической точки зрения оказалось простейшим.

27.11.2018    6488    lopatin    6    

EnterpriseData - пример доработки правил конвертации без использования КД 3.0 в расширении конфигурации

Практика программирования Обмен через XML v8 v8::УФ БП3.0 УТ11 Россия Бесплатно (free)

В статье подробно описан реальный пример доработки обмена данными через EnterpriseData (универсальный формат обмена) между конфигурациями УТ 11.4 и Бухгалтерия 3.0

16.11.2018    37750    ids79    42    

Свертка номенклатуры при выгрузке из Управления Торговлей 11 в Бухгалтерию 3.0

Обмен через XML v8 БП3.0 УТ11 БУ УУ Бесплатно (free)

Свертка номенклатуры при выгрузке из УТ 11 в Бухгалтерию 3. Используется типовой обмен на базе EnterpriseData

20.07.2018    10358    Kutuzov    3    

Обмен через универсальный формат. Пример нестандартной конвертации данных

Обмен через XML Перенос данных из 1C8 в 1C8 v8 УТ11 Россия Бесплатно (free)

В статье описан небольшой пример обмена данными через EnterpriseData без снятия конфигурации с поддержки. Тестовая площадка: Управление торговлей, редакция 11 (11.4.3.126), версия платформы 8.3.11

18.06.2018    36289    artkor    14    

Создание множественного дополнительного реквизита. Управление торговлей 11

Обмен через XML Практика программирования v8 УТ11 Россия Бесплатно (free)

Создание механизма множественного дополнительного реквизита для выгрузки в битрикс.

20.03.2018    15919    bad_wag    19    

Конвертация данных. Выгрузка контактной информации из регистра сведений в табличную часть

Обмен через XML v8 КД Бесплатно (free)

Довольно часто встречается задача выгрузить при помощи «Конвертация данных, редакция 2.1» контактной информации контрагента из «Управление торговлей", редакция 10.3» в «Бухгалтерия предприятия, редакция 3.0». Сложность заключается в том, что в УТ контактная информация хранится в регистре сведений, а в БП - в табличной части справочника «Контрагенты». Предлагаю мое, достаточно простое, решение данной задачи.

11.12.2017    22368    Nicholas    10    

1С: Конвертация данных 3. Инструкции и примеры. EnterpriseData (универсальный формат обмена)

Перенос данных из 1C8 в 1C8 Практика программирования Обмен через XML v8 КД Бесплатно (free)

Что такое КД3? Как начать использовать? Полезные дополнения к документации. Что нужно исправить в типовых обработках и конфигурации. Как изменить правила обмена не снимая конфигурацию с поддержки. Как отлаживать правила обмена?

19.11.2017    196181    MaxS    299    

Что такое конвертация данных 1С (статья написана исключительно для новичков)

Обмен через XML Перенос данных из 1C8 в 1C8 v8 КД Бесплатно (free)

О том, что "Конвертация данных" - мощный инструмент и прочую терминологию, вы прочтёте в любом источнике. Я хочу поделиться кратким пояснением как пользоваться данной конфигурацией. Речь пойдет о версии 2.1.

07.08.2017    37896    perepetulichka    40    

Перенос данных из базы с поврежденными таблицами

Тестирование и исправление Обмен через XML Перенос данных из 1C8 в 1C8 v8 БП2.0 Казахстан БУ УУ Бесплатно (free)

У клиента что-то произошло с жестким диском, что потребовало восстановления данных на нем. Базу 1С вроде бы сохранили, и она даже открылась. Однако при попытке доступа к документу "Платежный ордер, списание денежных средств" база вылетает с ошибкой. Также при получении оборотов за период в целом и по декадам выводились разные цифры. Обработка переноса данных в идентичную конфигурацию не подошла, из-за того, что так же вылетала с ошибкой БД. Ниже опишу мои действия по созданию новой конфигурации.

06.06.2017    16326    ermek6    14    

Работа со схемой XML в модуле обмена от Битрикс

Обмен через XML v8 1cv8.cf Бесплатно (free)

Пошаговое руководство «Как добавить поле для выгрузки в модуль обмена для битрикс» Анамнез: УПП 1.3 (Полиграфия, но не суть важно); модуль обмена 1С-Битрикс 5.0.0.5. Допустим, нам нужно добавить в структуру XML-файла поле «Основной менеджер». Поверхностный анализ модуля обмена дает нам информацию о том, что используется пространство имен «urn:1C.ru:commerceml_2».

28.12.2016    14241    ogroup    6    

XDTO на службе у лентяев. Самый простой способ чтения xml

Обмен через XML Практика программирования v8 Бесплатно (free)

Это статья для лентяев. Никаких описаний свойств и методов xdto здесь нет. Тем более здесь нет описания формата xml. Здесь лишь простой и удобный метод чтения xml для тех, кому нужно получить быстрый результат без углубления в теоретические дебри.

03.11.2015    33440    Ks_83    29    

Отладка конвертации данных 2.1 в конфигурациях, построенных на БСП 2.1 (БП 3.0, УТ 11 etc.)

Практика программирования Распределенная БД (УРИБ, УРБД) Обмен через XML БСП (Библиотека стандартных подсистем) v8 1cv8.cf Бесплатно (free)

Отладка процесса выгрузки/загрузки данных при проведении синхронизации в новых конфигурациях 1С может вызвать (у меня вызвала) некоторые затруднения. О них и пойдёт речь.

29.10.2015    40134    NittenRenegade    23    

Оптимизация новой типовой схемы обмена через синхронизацию

Практика программирования Обмен через XML v8 1cv8.cf Бесплатно (free)

В новых типовых конфигурациях УТ11 и БП3 вместо прошлой схемы обмена данными используется синхронизация данных. Однако у неё есть свои недостатки. В статье - краткое описание некоторых нюансов новой схемы и приемы для оптимизации работы с ней.

26.09.2015    23688    fixin    13    

Обмен данными между информационной базой и мобильным клиентом

Обмен через XML WEB v8 1cv8.cf Бесплатно (free)

В каком формате передавать данные между информационной базой на сервере и мобильным клиентом.

04.08.2014    23479    spezc    11    

О встроенных моделях XDTO платформы 1С

Обмен через XML v8 Бесплатно (free)

Иногда в пакетах, предоставленных самой платформой, можно найти интересное. Служебные объекты, системные перечисления, устройство универсальных коллекций.

13.02.2014    29794    Yashazz    10    

Загрузка из EXCEL в 1С. Чтение файла XLSX средствами 1С. ЧтениеXML

Загрузка и выгрузка в Excel Обмен через XML Практика программирования v8 1cv8.cf Бесплатно (free)

ПРАКТИЧЕСКОЕ ПОСОБИЕ РАЗРАБОТЧИКА: Метод "NativeXLSX" (ЧтениеXML). Обрабатываются данные EXCEL типов: "Строка", "Число", "Дата" ("Время"), "Булево", "Процент".

01.11.2013    112045    StepByStep    76    

Универсальный обмен данными XML через web-сервисы

Обмен через XML WEB Перенос данных из 1C8 в 1C8 v8 Бесплатно (free)

Организация онлайн-обмена данными в формате "Конвертации данных" через web-сервисы

08.10.2013    108172    Mleg    55    

Организация обмена с прочими программами через XML. Имитация двухстороннего обмена без именения конфигурации

Внешние источники данных Обмен через XML v8 Бесплатно (free)

Настраиваем обмен типовой конфигурации со сторонними базами данных, с функционалом двустороннего обмена

24.04.2013    15324    Stim213    6    

Загрузка из EXCEL в 1С. Список листов EXCEL

Универсальные обработки Загрузка и выгрузка в Excel Обмен через XML v8 1cv8.cf Бесплатно (free)

ПРАКТИЧЕСКОЕ ПОСОБИЕ РАЗРАБОТЧИКА: Методы получения списка листов файлов типа EXCEL. Поддерживаемые типы: *.xls,*.xlsx,*.ods,*.sxc.

30.11.2012    52858    StepByStep    5