Автоматизация процесса формирования документов реализации в лизинговой компании

Публикация № 1156410

Учет и отчетность - Оптовая торговля

Лизинговым компаниям каждый месяц приходится формировать большое количество документов реализации в соответствии с графиком платежей, указанным в договоре. Ввиду того, что имеются все необходимые данные, процесс может быть автоматизирован.

Постановка задачи:

При заключении договора лизинга в обязательном порядке подписывается утверждённый график платежей в соответствии с которым лизингополучатель осуществляет оплату. Соответственно, лизингодатель каждый месяц должен формировать документы реализации и отправлять их лизингополучателю. Так как все необходимые данные для формирования документов имеются, то можно автоматизировать этот процесс.

Решение:

Необходимо где-то хранить информацию о графике платежа (дата платежа и сумма платежа). В конфигурацию "Бухгалтерия предприятия, редакция 3.0" был добавлен новый справочник "ГрафикПлатежей" (можно добавить в расширение). 

Реквизиты: Контрагент, Договор, ВидДоговора

Табличная часть: Платежи (ДатаПлатежа, СуммаПлатежа)

 

В форму элемента справочника выведены реквизиты: Наименование, Контрагент, Договор, Вид договора и Табличная часть "Оплата" с реквизитами ДатаПлатежа и СуммаПлатежа.

 

В модуле формы прописываем код для формирования документов

&НаСервере
Функция СформироватьРТиУНаСервере()
	РТУ = Документы.РеализацияТоваровУслуг.СоздатьДокумент();
	Сегодня = ТекущаяДата();
	РТУ.Дата = КонецМесяца(Сегодня);
	РТУ.Организация = Справочники.Организации.НайтиПоНаименованию("ООО ""Наша фирма""");
	РТУ.ВидОперации = Перечисления.ВидыОперацийРеализацияТоваров.Услуги;
	РТУ.ДоговорКонтрагента = Объект.Договор;
	РТУ.ВалютаДокумента = Объект.Договор.ВалютаВзаиморасчетов;
	РТУ.Контрагент = Объект.Договор.Владелец;
	РТУ.СчетУчетаРасчетовСКонтрагентом = ПланыСчетов.Хозрасчетный.НайтиПоКоду("62.01");
	РТУ.СчетУчетаРасчетовПоАвансам = ПланыСчетов.Хозрасчетный.НайтиПоКоду("62.02");
	РТУ.СпособЗачетаАвансов = Перечисления.СпособыЗачетаАвансов.Автоматически;
	РТУ.СуммаВключаетНДС = Истина;
	РТУ.ТипЦен = Справочники.ТипыЦенНоменклатуры.НайтиПоНаименованию("Основная цена продажи");
	ТекущийМесяц = Месяц(ТекущаяДата());
	ТекущийГод = Год(ТекущаяДата());
	НоваяСтрока = РТУ.Услуги.Добавить();
	Если Объект.ВидДоговора.Наименование = "Аренда" Тогда
		НоваяСтрока.Номенклатура = Справочники.Номенклатура.НайтиПоКоду("00000000333");
		НоваяСтрока.Субконто = Справочники.НоменклатурныеГруппы.НайтиПоНаименованию("Аренда");
	ИначеЕсли
		Объект.ВидДоговора.Наименование = "Лизинговый платеж"
		Тогда
		НоваяСтрока.Номенклатура = Справочники.Номенклатура.НайтиПоКоду("00000000025");
		НоваяСтрока.Субконто = Справочники.НоменклатурныеГруппы.НайтиПоНаименованию("Лизинговый платеж");
	КонецЕсли;
	НоваяСтрока.Содержание = Строка(НоваяСтрока.Номенклатура)+" по договору "+Строка(Объект.Договор);
	НоваяСтрока.СтавкаНДС = Перечисления.СтавкиНДС.НДС20;
	НоваяСтрока.СчетДоходов = ПланыСчетов.Хозрасчетный.НайтиПоКоду("90.01.1");
	НоваяСтрока.СчетРасходов = ПланыСчетов.Хозрасчетный.НайтиПоКоду("90.02.1");
	НоваяСтрока.СчетУчетаНДСПоРеализации = ПланыСчетов.Хозрасчетный.НайтиПоКоду("90.03");
	
	Для Каждого Элемент из Объект.Платежи Цикл
		Если ТекущийМесяц = Месяц(Элемент.ДатаПлатежа) И ТекущийГод = Год(Элемент.ДатаПлатежа) Тогда
			НоваяСтрока.Цена = Элемент.СуммаПлатежа;
			НоваяСтрока.Сумма = Элемент.СуммаПлатежа;
			НоваяСтрока.СуммаНДС = Элемент.СуммаПлатежа*(1-1/1.2);
		КонецЕсли;
	КонецЦикла;
	
	РТУ.Записать(РежимЗаписиДокумента.Запись);
	Возврат РТУ.Ссылка;
КонецФункции

&НаКлиенте
Процедура СформироватьРТиУ(Команда)
	ОткрытьЗначение(СформироватьРТиУНаСервере());
КонецПроцедуры

Таким образом, при нажатии на кнопку "Сформировать РТиУ" формируется документ реализации, заполняется шапка документа, табличная часть "Услуги" и документ записывается с датой последнего дня текущего месяца. 

Табличная часть заполняется в соответствии со значениями справочника "График платежей"

Так можно сформировать документ для каждого конкретного договора.

 

Для того, чтобы сформировать документы по нескольким договорам была написана внешняя обработка "Формирование РТиУ"

 

В модуле формы обработки при нажатии на кнопку "Заполнить" сначала заполняем таблицу из справочника "График платежей"

&НаСервере
Процедура ЗаполнитьНаСервере()
	Запрос = Новый Запрос;	
	Запрос.Текст =
	"ВЫБРАТЬ
	|	ГрафикПлатежей.Ссылка КАК График,
	|	ГрафикПлатежей.Контрагент КАК Контрагент
	|ИЗ
	|	Справочник.ГрафикПлатежей КАК ГрафикПлатежей";
	
	Таблица.Загрузить(Запрос.Выполнить().Выгрузить());
	
	Для Каждого Строка Из Таблица Цикл
		Строка.Выбор = Истина;
	КонецЦикла;		
	
КонецПроцедуры

&НаКлиенте
Процедура Заполнить(Команда)
	ЗаполнитьНаСервере();
КонецПроцедуры

 

Затем, при нажатии на кнопку "Сформировать РТиУ" формируем документы, которые отмечены крыжиком

&НаСервере
Процедура СформироватьРТУНаСервере()
	
	Для каждого Строка Из Таблица Цикл
		Если Строка.Выбор Тогда
			Выборка = Строка.График;		
			РТУ = Документы.РеализацияТоваровУслуг.СоздатьДокумент();
			Сегодня = ТекущаяДата();
			//РТУ.Дата = Дата(Год(Сегодня),Месяц(Сегодня),20);
			РТУ.Дата = КонецМесяца(Сегодня);
			РТУ.Организация = Справочники.Организации.НайтиПоНаименованию("ООО ""Наша фирма""");
			РТУ.ВидОперации = Перечисления.ВидыОперацийРеализацияТоваров.Услуги;
			РТУ.ДоговорКонтрагента = Выборка.Договор;
			РТУ.ВалютаДокумента = Выборка.Договор.ВалютаВзаиморасчетов;
			РТУ.Контрагент = Выборка.Договор.Владелец;
			РТУ.СчетУчетаРасчетовСКонтрагентом = ПланыСчетов.Хозрасчетный.НайтиПоКоду("62.01");
			РТУ.СчетУчетаРасчетовПоАвансам = ПланыСчетов.Хозрасчетный.НайтиПоКоду("62.02");
			РТУ.СпособЗачетаАвансов = Перечисления.СпособыЗачетаАвансов.Автоматически;
			РТУ.СуммаВключаетНДС = Истина;
			РТУ.ТипЦен = Справочники.ТипыЦенНоменклатуры.НайтиПоНаименованию("Основная цена продажи");
			ТекущийМесяц = Месяц(ТекущаяДата());
			ТекущийГод = Год(ТекущаяДата());
			НоваяСтрока = РТУ.Услуги.Добавить();
			Если Выборка.ВидДоговора.Наименование = "Аренда" Тогда
				НоваяСтрока.Номенклатура = Справочники.Номенклатура.НайтиПоКоду("00000000333");
				НоваяСтрока.Субконто = Справочники.НоменклатурныеГруппы.НайтиПоНаименованию("Аренда");
			ИначеЕсли
				Выборка.ВидДоговора.Наименование = "Лизинговый платеж"
				Тогда
				НоваяСтрока.Номенклатура = Справочники.Номенклатура.НайтиПоКоду("00000000025");
				НоваяСтрока.Субконто = Справочники.НоменклатурныеГруппы.НайтиПоНаименованию("Лизинговый платеж");
			КонецЕсли;
			НоваяСтрока.Содержание = Строка(НоваяСтрока.Номенклатура)+" по договору "+Строка(Выборка.Договор);
			НоваяСтрока.СтавкаНДС = Перечисления.СтавкиНДС.НДС20;
			НоваяСтрока.СчетДоходов = ПланыСчетов.Хозрасчетный.НайтиПоКоду("90.01.1");
			НоваяСтрока.СчетРасходов = ПланыСчетов.Хозрасчетный.НайтиПоКоду("90.02.1");
			НоваяСтрока.СчетУчетаНДСПоРеализации = ПланыСчетов.Хозрасчетный.НайтиПоКоду("90.03");
			
			Для Каждого Элемент из Выборка.Платежи Цикл
				Если ТекущийМесяц = Месяц(Элемент.ДатаПлатежа) И ТекущийГод = Год(Элемент.ДатаПлатежа) Тогда
					НоваяСтрока.Цена = Элемент.СуммаПлатежа;
					НоваяСтрока.Сумма = Элемент.СуммаПлатежа;
					НоваяСтрока.СуммаНДС = Элемент.СуммаПлатежа*(1-1/1.2);
				КонецЕсли;
				
				
			КонецЦикла;
		
		РТУ.Записать(РежимЗаписиДокумента.Запись);	
		КонецЕсли;
	КонецЦикла;
КонецПроцедуры

&НаКлиенте
Процедура СформироватьРТУ(Команда)
	СформироватьРТУНаСервере();
КонецПроцедуры

Код формирования документов, фактически, повторяет код в справочнике, только добавлен цикл по строкам таблицы

 

Обработка в режиме предприятия

 

Помимо формирования документов, добавление в базу информации о графиках платежей, позволяет с помощью простенького отчета проводить план-фактный анализ  поступления платежей

Запрос

ВЫБРАТЬ
	ГрафикПлатежейПлатежи.Ссылка.Наименование КАК Наименование,
	ГрафикПлатежейПлатежи.Ссылка.Контрагент КАК Контрагент,
	ГрафикПлатежейПлатежи.Ссылка.Договор КАК Договор,
	ГрафикПлатежейПлатежи.НомерСтроки КАК НомерСтроки,
	ГрафикПлатежейПлатежи.ДатаПлатежа КАК ДатаПлатежа,
	ГрафикПлатежейПлатежи.СуммаПлатежа КАК СуммаПлатежа,
	ПоступлениеНаРасчетныйСчет.Контрагент КАК Контрагент1,
	ПоступлениеНаРасчетныйСчет.Дата КАК Дата,
	ПоступлениеНаРасчетныйСчет.ДоговорКонтрагента КАК ДоговорКонтрагента,
	ПоступлениеНаРасчетныйСчет.СуммаДокумента КАК СуммаДокумента,
	ПоступлениеНаРасчетныйСчет.Ссылка КАК Ссылка
ИЗ
	Справочник.ГрафикПлатежей.Платежи КАК ГрафикПлатежейПлатежи
		ЛЕВОЕ СОЕДИНЕНИЕ Документ.ПоступлениеНаРасчетныйСчет КАК ПоступлениеНаРасчетныйСчет
		ПО ГрафикПлатежейПлатежи.Ссылка.Договор = ПоступлениеНаРасчетныйСчет.ДоговорКонтрагента
			И (НАЧАЛОПЕРИОДА(ГрафикПлатежейПлатежи.ДатаПлатежа, МЕСЯЦ) = НАЧАЛОПЕРИОДА(ПоступлениеНаРасчетныйСчет.Дата, МЕСЯЦ))

 

Сам отчет

 

В табличную часть справочника "График платежей" информация загружалась с использованием стандартной обработки "ЗагрузкаДанныхИзТабличногоДокумента.epf"

Скачать файлы

Наименование Файл Версия Размер
Формирование РТиУ

.epf 7,74Kb
1
.epf 7,74Kb 1 Скачать
Сравнение фактически поступивших платежей с графиком платежей

.erf 8,25Kb
0
.erf 8,25Kb Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. roman3333 14.01.20 13:44 Сейчас в теме
добрый день! есть опыт автоматизации платежей..Т.е. клиент имеем неск-ко догворов. Оплачивает он общей суммой
Возможно ли как-то распределить автоматом общую сумму на все договры (от первого догвора до последнего)?
2. yurikmellon 5 14.01.20 14:35 Сейчас в теме
(1) добрый. А как Вы это себе представляете? Приходит выписка из банка по контрагенту (документ "Поступление на расчетный счет") на конкретную сумму и конкретный договор.
Потом что должно происходить? Эта сумма должна пропорционально распределиться на все договора данного контрагента?
3. roman3333 14.01.20 18:02 Сейчас в теме
допустим у клиента есть 7 договоров. К каждому договру привязан график ежемесячных платежей (дата/сумма). Соотв-но общая сумма распредел-ся согласно каждого договора и суммы из графика по порядку возрастания номеров договоров. Если общей суммы на все договоры не хватит,то на те договоры что не хватило суммы должны зафиксироваться как долг клиента по конкретному договору.
При следующем поступлении средств от клиента (выписка) вначале погашается долги по этим договорам,а затем плановые суммы из гарфика вновь распределяются.
4. yurikmellon 5 15.01.20 08:31 Сейчас в теме
(3) я бы в этом случае написал обработку, которая из одного документа "Поступление на расчетный счет" делает семь и сумму в этом документе распределяет по этим семи договорам в соответствии с графиком платежей начиная с первого по номеру. Нужно где то хранить информацию по долгам (регистр какой нибудь сделать), чтобы следующее поступление сначала закрывало эти долги. Как то так.
Оставьте свое сообщение

См. также

Проблема сопоставления товара при приемке маркированной продукции на примере обуви в конфигурации 1С:Розница

Оптовая торговля Розничная торговля v8 Розница Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Россия УУ Абонемент ($m)

В статье описывается проблема сопоставления товара при приемке товаров маркированной продукции применительно к типовым конфигурациям на примере 1С:Розница.

1 стартмани

16.11.2020    3032    gzharkoj    3    

Работа с табачной продукцией в УТ 11.4

Оптовая торговля Розничная торговля v8::ОУ УТ11 Розничная и сетевая торговля (FMCG) Россия УУ Абонемент ($m)

Практическая работа с маркированным товаром - табачной продукцией (с изюминкой).

1 стартмани

28.09.2020    2601    zemskov    22    

Обмен с интернет-магазином на платформе DOCPART

WEB Оптовая торговля Розничная торговля Оптовая торговля Розничная торговля v8 1cv8.cf Абонемент ($m)

В настоящее время существует множество платформ для создания интернет-магазинов. Удобные и не очень, платные или бесплатные. У каждого решения найдутся свои сторонники, но наличие оперативного обмена с учётной системой важно для любой платформы. В этой публикации мы рассмотрим одну из популярных платформ для создания интернет-магазина по продаже автозапчастей Docpart и организацию обмена данными с ней.

10 стартмани

04.07.2019    5685    Johny_v    24    

Печать чеков на Меркурии 119Ф USB по сети

Фискальный регистратор Кассовые операции Оптовая торговля Розничная торговля Кассовые операции Оптовая торговля Розничная торговля v8 1cv8.cf Россия НУ Абонемент ($m)

Стандартный драйвер Меркурия 119Ф usb не позволяет осуществлять печать на фискальный регистратор с другого компьютера, поэтому был сделан простейший http сервер, который транслирует post запросы в вызовы методов com-объекта.

1 стартмани

06.06.2019    6042    philya    6    

EGAIS Scan - приложение для ТСД

Терминал сбора данных Мобильная разработка Оптовая торговля Розничная торговля Учет ТМЦ Оптовая торговля Розничная торговля Учет ТМЦ v8 УТ10 УПП1 УТ11 КА2 Россия УУ Абонемент ($m)

Каждый, кто занимается торговлей алкогольной продукцией, сталкивался с проблемами сканирования акцизных марок и трудностями при взаимодействии с учетной системой 1С. Приложение EGAIS Scan - простое и оптимальное решение для выполнения быстрой приемки и отгрузки алкогольной продукции.

1 стартмани

17.04.2019    5565    MrChe    3    

Автоматическое уведомление клиентов по электронной почте в программе 1С: УВС

Email Документооборот и делопроизводство Оптовая торговля Документооборот и делопроизводство Оптовая торговля v8 1С:УВС Россия Абонемент ($m)

В данной статье предлагается внешняя обработка для конфигурации 1С: Управление ветеринарными сертификатами, выполняющая автоматическую рассылку писем по электронной почте клиентам компании, с целью уведомления о сформированных ветеринарно-сопроводительных документах.

1 стартмани

12.04.2019    4446    Астиг    0    

Раскрашенный log-файл без HTML и СМС (используем Форматированный документ в личных целях)

Практика программирования Оптовая торговля Оптовая торговля Разработка v8::ОУ УТ11 КА2 Россия УУ Абонемент ($m)

Иногда пользователям отдается на откуп загрузка каких то данных, результат загрузки которых желательно раскрасить если и не всеми цветами радуги, то хотя бы светофором. Один из вариантов – это использовать Форматированную строку. Следите за руками:

1 стартмани

08.02.2019    3281    kembrik    2    

Вывод веса и объема номенклатуры в УТ 11

Оптовая торговля Практика программирования Оптовая торговля v8 УТ11 Оптовая торговля, дистрибуция, логистика Россия УУ Абонемент ($m)

Статья ориентирована на программиста и содержит пример реализации вывода веса и объема номенклатуры В ТЧ "Товары" документа "ЗаказКлиента" в УТ 11.4.

1 стартмани

03.12.2018    6746    triviumfan    10    

Альтернативный пересчет упаковок товаров в типовых конфигурациях

Практика программирования Оптовая торговля Учет ТМЦ Оптовая торговля Учет ТМЦ v8 v8::ОУ УТ11 КА2 Оптовая торговля, дистрибуция, логистика Россия УУ Абонемент ($m)

Рассмотрен вариант пересчета упаковок, при котором исходное количество товара не изменяется, а происходит пересчет упаковок друг относительно друга.

1 стартмани

24.11.2018    11502    gzharkoj    10    

Yep Cart. Пишем интернет-магазин на http-сервисах OneScript

Оптовая торговля Розничная торговля OneScript v8 УУ Абонемент ($m)

В статье описана демонстрационная конфигурация, реализующая простейший интернет магазин на http-сервисах OneScript, интегрированный с 1С:Предприятие.

1 стартмани

16.04.2018    16964    blackhole321    33    

Опыт интеграции 1С с системой Меркурий (Часть 5)

Внешние источники данных Интеграция Оптовая торговля Оптовая торговля v8::ОУ 1cv8.cf Сельское хозяйство и рыболовство Транспорт, автопарки, такси Оптовая торговля, дистрибуция, логистика Пищевая промышленность Россия БУ УУ Абонемент ($m)

Описывается опыт внедрения в 1С системы работы с ветеринарно-сопроводительными документами Меркурий. Интеграция еще в процессе и приветствуется обмен опытом.

1 стартмани

10.07.2017    61045    axxell    33    

Практика создания заказной внешней печатной формы для УТ 11.3

Печатные формы документов Оптовая торговля Оптовая торговля v8 v8::ОУ УТ11 Оптовая торговля, дистрибуция, логистика Россия УУ Абонемент ($m)

Внешняя печатная форма "Счёт на оплату" для конфигурации Управление торговлей, редакция 11.3

1 стартмани

09.05.2017    26190    zemskov    11    

Адресная система хранения на складе

Практика программирования Оптовая торговля Учет ТМЦ Оптовая торговля Учет ТМЦ v8 УУ Абонемент ($m)

Решение тестового задания. Разбор ошибок.

1 стартмани

22.10.2016    11481    vasvl123    6    

Руководство пользователя. УТ 10.3 Рабочее место кассира.

Пользователю системы Оптовая торговля Розничная торговля Оптовая торговля Розничная торговля v8 КА1 УТ10 Россия УУ Абонемент ($m)

Развернутая инструкция для работы пользователя в типовом интерфейсе кассира конфигурации 1С: Управление торговлей 10.3. Подробно с иллюстрациями описаны основные действия кассира.

1 стартмани

22.06.2016    38267    zhuravlev_as    5    

Сложные отчеты для управляемых форм с использованием СКД: просто. На примере отчета ABC анализ номенклатуры, клиентов для УТ11

Практика программирования Оптовая торговля Оптовая торговля v8::СКД УТ11 УУ Абонемент ($m)

Не очень часто, но все же, иногда приходится сталкиваться с необходимостью создания отчета, который очень сложно скомпоновать на "чистом" СКД, в этом случае альтернативой может являться следующая последовательность действий для получения итогового отчета: 1. при помощи одной схемы компоновки данных получить необходимую выборку данных; 2. запрограммировать (на языке 1С) некое преобразование этих данных; 3. при помощи другой схемы компоновки данных - произвести вывод необходимой информации в табличный документ. Как оказалось эта процедура не слишком сложная, хотя и немного запутанная.

1 стартмани

12.08.2013    61990    mxm2    21