Интеграция с Трелло. Готовый код

Публикация № 1280701

Разработка - Обмен данными 1С

Трелло Trello Atlassian канбан-доска интеграция

Код основных действий, интеграция с API Трелло.

Канбан-доска Трелло (Trello) достаточно проста, удобна и популярна, и обладает простым API, позволяющим создать интеграцию с 1С. Также, на 1С уже создано несколько интерфейсов, реализующих канбан-доски. Их объединение позволяет расширить и сделать удобнее возможности постановки, контроля и решения задач, а также статистику по ним, с помощью механизмов Трелло.

Интеграция выполнена в виде отдельных функций на каждое действие, по возможности атомарных, т.е. без взаимных и пакетных вызовов (исключение составляет только работа с досками и чек-листами). Использованы синхронные http-запросы согласно описанию rest-методов и объектов (на сайте Atlassian: документация по методам и описание основных объектов). К сожалению, подробного описания всех объектов схемы данных я не нашёл, поэтому свойства объектов представлены ниже по результатам просмотра при отладке.

Данные передаются в json, всё только средствами платформы. Никакие особенности, связанные с защищённым соединением, сертификацией, SSL и прочим, в явном виде не использовались (всё по умолчанию).

 
 Авторизация

 

Я применял для http-обмена собственную разработку, ранее уже опубликованную на ИС. Можно использовать свои или БСП-шные механизмы, не суть. Все они лишь обёртка вызовов API и обработка возвращённых json-объектов и, при наличии документации, можно легко "наштамповать" недостающие методы, используя имеющееся как образец. Поэтому, собственно, все-все методы API я реализовывать и не стал.

 
 Общие действия

Механизмы реализации рест-обмена 


// При ошибке возвращает Неопределено
Функция ПрочестьJSONизСтроки(рСтрока,рВСоответствие=Ложь) Экспорт
Попытка
	Если ПустаяСтрока(рСтрока) Тогда
		Сообщить("ПрочестьJSONизСтроки, строка на чтение пуста!");
		Возврат Неопределено;
	КонецЕсли;
	
	рЧтение=Новый ЧтениеJSON;
	рЧтение.УстановитьСтроку(рСтрока);
	//
	рДанные=ПрочитатьJSON(рЧтение,рВСоответствие);
	
	Если ТипЗнч(рДанные)<>Тип("Структура") и ТипЗнч(рДанные)<>Тип("Соответствие") и ТипЗнч(рДанные)<>Тип("Массив") Тогда
		Сообщить("ПрочестьJSONизСтроки, получены данные неверного формата!");		
		Возврат Неопределено;
	Иначе
		Возврат рДанные;
	КонецЕсли;
	
Исключение
	Сообщить("ПрочестьJSONизСтроки, общая ошибка: "+ОписаниеОшибки());
	Возврат Неопределено;
КонецПопытки;
КонецФункции

// Вспомогательная
Процедура СообщитьИВнестиВПротокол(инфо,рПротокол) Экспорт
	Если Прав(инфо,3)="!!!" Тогда
		рСтатус=СтатусСообщения.ОченьВажное;
	ИначеЕсли Прав(инфо,2)="!!" Тогда
		рСтатус=СтатусСообщения.Важное;
	ИначеЕсли Прав(инфо,1)="!" Тогда
		рСтатус=СтатусСообщения.Внимание;
	Иначе
		рСтатус=СтатусСообщения.Информация;
	КонецЕсли;
	Сообщить(инфо,рСтатус);
	//
	Если ТипЗнч(рПротокол)=Тип("ТекстовыйДокумент") Тогда
		рПротокол.ДобавитьСтроку(инфо);
	КонецЕсли;
КонецПроцедуры

// Выполняет любой запрос к соединению, при необходимости создаёт соединение, заносит в параметры ответ сервиса.
// Возвращает успешность, при ошибке возвращает Ложь.
//
// Параметры:
//    рПараметры - структура:
//
//        Соединение - HTTP-соединение; заносится в этот ключ, если не было передано (создаётся в функции), и используется из этого ключа без изменений, если было передано;
//        если значение ключа Соединение не указано или имеет иной тип, то соединение создаётся согласно значениям указанных ключей:
//            Сервер -строка, обязательный (если пусто или не указано, то возвращает ошибку), если начинается с http://, то приводится к правильному виду автоматически;
//            Порт - число, обязательный (по умолчанию для незащищённых 80, для защищённых 443);
//            Пользователь - строка, необязательный;
//            Пароль - строка, необязательный;
//            Таймаут - число, необязательный (по умолчанию 0);
//            ПроксиПользователь - строка, необязательный (по умолчанию пуста); если не пуста, то это признак использования прокси, в этом случае требуется передача свойств:
//                ПроксиПароль - строка, необязательный;
//                ПроксиСервер - строка,
//                ПроксиПорт - число, необязательный (по умолчанию 0);
//        Если Соединение не было указано, то по завершении функции в ключ Соединение вносится созданное в ней;
//
//        HTTPЗапрос - запрос с уже установленными свойствами; необязательный, если не указан, то инициализируется в функции согласно значениям указанных ключей:
//            АдресРесурса или АдресСкрипта (равнозначны оба ключа) - строка, необязательный; по умолчанию "/";
//            ЗаголовкиЗапроса - соответствие или фикс.соответствие;
//            ПараметрыЗапроса - структура, соответствие, фикс.соответствие или список значений (где имя ключа - Представление, а значение ключа - Значение),
//                список значений используется в случае, когда важен порядок следования параметров, вносит в ком.строку строго по порядку вхождения данных в список;
//            ТелоЗапроса - строка или двоичные данные, необязательный;
//            ИмяФайлаТелаЗапроса - строка; необязательный;
//                указание тела запроса более приоритетно, чем указание имени файла тела запроса;
//        Если HTTPЗапрос был указан, то по завершении функции из рПараметры значение с ключом HTTPЗапрос удаляется, во избежание кэширования;
//
//        МетодHTTP - строка, необязательный (по умолчанию GET), допустимы все значения, поддерживаемые методами объекта "HTTPСоединение" 1С.
//        
//        Протокол - текстовый документ, необязательный (по умолчанию пуст и не используется).
//
//    По итогам работы функции при её успешном завершении в рПараметры вставляется значение с ключом HTTPОтвет. При ошибке вставляет Неопределено.
//
// Возвращает успешность (булево).
//
Функция HTTPВыполнитьЗапрос(рПараметры) Экспорт
Попытка	
	рПротокол=?(рПараметры.Свойство("Протокол"),рПараметры.Протокол,Неопределено);
	
	рПояснять=?(рПараметры.Свойство("Пояснять"),рПараметры.Пояснять,Ложь);
	
	// сразу по умолчанию
	//рОтвет=Новый HTTPСервисОтвет(0,"Запрос не выполнялся"); // в релизах ниже 8.3.7 не отрабатывает
	рОтвет=Неопределено;
	рПараметры.Вставить("HTTPОтвет",рОтвет);
	
	#Область Соединение
	рКраткийФормат=?(рПараметры.Свойство("КраткийФорматВызова"),рПараметры.КраткийФорматВызова,Ложь);
	рЗащищённое=?(рПараметры.Свойство("ЗащищенноеСоединение"),рПараметры.ЗащищенноеСоединение,Ложь);
	//
	рСоединение=?(рПараметры.Свойство("Соединение"),рПараметры.Соединение,Неопределено);
	Если ТипЗнч(рСоединение)<>Тип("HTTPСоединение") Тогда // надо его установить
		#Область УстановкаСоединения
		Если не рПараметры.Свойство("Сервер") Тогда Возврат Ложь КонецЕсли;
		рСервер=СокрЛП(рПараметры.Сервер);
		Если ПустаяСтрока(рСервер) Тогда Возврат Ложь КонецЕсли;
		рПорт=?(рПараметры.Свойство("Порт"),рПараметры.Порт,0);
		рТаймаут=?(рПараметры.Свойство("Таймаут"),рПараметры.Таймаут,0);
		рПроксиПользователь=?(рПараметры.Свойство("ПроксиПользователь"),рПараметры.ПроксиПользователь,""); // признак применения прокси именно в этом
		//Если рКраткийФормат Тогда рЗащищённое=Ложь; рПроксиПользователь="" КонецЕсли;
		//
		рПрокси=Неопределено;
		Если не ПустаяСтрока(рПроксиПользователь) Тогда
			рПрокси=Новый ИнтернетПрокси;
			рПрокси.Пользователь=рПроксиПользователь;
			рПрокси.Пароль=рПараметры.ПроксиПароль;
			Если рПараметры.ПроксиПорт=0 Тогда
				рПрокси.Установить("HTTP",рПараметры.ПроксиСервер);
			Иначе	
				рПрокси.Установить("HTTP",рПараметры.ПроксиСервер,рПараметры.ПроксиПорт);
			КонецЕсли;	
		КонецЕсли;
		//
		Если СтрНачинаетсяС(НРег(рСервер),"http://") Тогда
			рСервер=Сред(рСервер,8);
		КонецЕсли;		
		Если рПорт=0 Тогда
			рПорт=?(рЗащищённое,443,80);
		КонецЕсли;
		//
		Если рЗащищённое Тогда
			рSSL=Новый ЗащищенноеСоединениеOpenSSL(,Новый СертификатыУдостоверяющихЦентровWindows);		
		//	//рSSL=Новый ЗащищенноеСоединениеOpenSSL(Новый СертификатКлиентаWindows(СпособВыбораСертификатаWindows.Выбирать),Новый СертификатыУдостоверяющихЦентровWindows());
		//	рСпособВыбора=СпособВыбораСертификатаWindows.Авто;
		//	рСертификатОС=Новый СертификатКлиентаWindows(рСпособВыбора);
		//	рSSL=Новый ЗащищенноеСоединениеOpenSSL(рСертификатОС);
		Иначе
			рSSL=Неопределено;
		КонецЕсли;
		//
		Если рКраткийФормат Тогда
			рСоединение=Новый HTTPСоединение(рСервер);
		Иначе
			Если рПрокси=Неопределено Тогда
				рСоединение=Новый HTTPСоединение(рСервер,рПорт,рПараметры.Пользователь,рПараметры.Пароль,,рТаймаут,рSSL);
			Иначе
				рСоединение=Новый HTTPСоединение(рСервер,рПорт,рПараметры.Пользователь,рПараметры.Пароль,рПрокси,рТаймаут,рSSL);
			КонецЕсли;
		КонецЕсли;
		//
		Если ТипЗнч(рСоединение)<>Тип("HTTPСоединение") Тогда			
			СообщитьИВнестиВПротокол("Не удалось создать объект HTTP-соединения!",рПротокол);
		КонецЕсли;
		//
		// вставим на будущее (это иногда имеет смысл кэшировать)
		рПараметры.Вставить("Соединение",рСоединение);
		#КонецОбласти
	Иначе
		рСервер=рСоединение.Сервер;
		рПорт=рСоединение.Порт;
		рТаймаут=рСоединение.Таймаут;
		рПроксиПользователь=рСоединение.Прокси.Пользователь;
	КонецЕсли;
	// а эти всегда берём по итогам установленного соединения
	рПроксиСервер=рСоединение.Прокси.Сервер();
	рПроксиПорт=рСоединение.Прокси.Порт();
	//
	// выводим настройки соединения
	Если рПояснять Тогда
		инфо="Соединение:
		|Сервер: "+СокрЛП(рСервер)+", порт: "+Строка(рПорт)+", пользователь: "+СокрЛП(рПараметры.Пользователь)+", таймаут: "+рТаймаут+"
		|краткий формат: "+Строка(рКраткийФормат)+", защищённое: "+Строка(рЗащищённое)+Символы.ПС;
		Если не ПустаяСтрока(рПроксиПользователь) Тогда
			инфо=инфо+"прокси: сервер "+СокрЛП(рПроксиСервер)+", порт "+Строка(рПроксиПорт)+", пользователь "+СокрЛП(рПроксиПользователь);
		Иначе
			инфо=инфо+"прокси не используется";
		КонецЕсли;
		СообщитьИВнестиВПротокол(инфо,рПротокол);
	КонецЕсли;	
	//
	Если ТипЗнч(рСоединение)<>Тип("HTTPСоединение") Тогда // уже без сообщения, именно выход по ошибке
		Возврат Ложь;
	КонецЕсли;
	#КонецОбласти
	
	#Область Запрос
	рЗапрос=?(рПараметры.Свойство("HTTPЗапрос"),рПараметры.HTTPЗапрос,Неопределено);
	
	Если ТипЗнч(рЗапрос)<>Тип("HTTPЗапрос") Тогда
		Если рПараметры.Свойство("АдресРесурса") и не ПустаяСтрока(рПараметры.АдресРесурса) Тогда
			рАдресРесурса=рПараметры.АдресРесурса;
		ИначеЕсли рПараметры.Свойство("АдресСкрипта") и не ПустаяСтрока(рПараметры.АдресСкрипта) Тогда
			рАдресРесурса=рПараметры.АдресСкрипта;
		Иначе
			рАдресРесурса="/";
			СообщитьИВнестиВПротокол("Используется пустой адрес ресурса для запроса.",рПротокол);
		КонецЕсли;
		
		#Область ЗаголовкиЗапроса
		рЗаголовкиЗапроса=Новый Соответствие;
		Если рПараметры.Свойство("ЗаголовкиЗапроса") Тогда
			Если ТипЗнч(рПараметры.ЗаголовкиЗапроса)=Тип("Соответствие") или ТипЗнч(рПараметры.ЗаголовкиЗапроса)=Тип("ФиксированноеСоответствие") Тогда
				рЗаголовкиЗапроса=рПараметры.ЗаголовкиЗапроса;				
			КонецЕсли;
		КонецЕсли;
		Если рПояснять Тогда
			Если рЗаголовкиЗапроса.Количество()=0 Тогда
				инфо="Заголовки запроса не указаны.";
			Иначе
				инфо="Заголовки запроса:";
				Для каждого киз Из рЗаголовкиЗапроса Цикл
					инфо=инфо+Символы.ПС+"    "+киз.Ключ+" = "+киз.Значение;
				КонецЦикла;
			КонецЕсли;
			СообщитьИВнестиВПротокол(инфо,рПротокол);
		КонецЕсли;
		#КонецОбласти
		
		#Область ПараметрыЗапроса
		рПараметрыЗапроса=Новый Соответствие;
		Если рПараметры.Свойство("ПараметрыЗапроса") и рАдресРесурса<>"/" Тогда
			Если ТипЗнч(рПараметры.ПараметрыЗапроса)=Тип("Структура")
			или ТипЗнч(рПараметры.ПараметрыЗапроса)=Тип("Соответствие") 
			или ТипЗнч(рПараметры.ПараметрыЗапроса)=Тип("ФиксированноеСоответствие") 
			Тогда
				Для каждого киз Из рПараметры.ПараметрыЗапроса Цикл
					рПараметрыЗапроса.Вставить(киз.Ключ,киз.Значение);
				КонецЦикла;
			ИначеЕсли ТипЗнч(рПараметры.ПараметрыЗапроса)=Тип("СписокЗначений") Тогда
				// случай, когда был очень важен порядок параметров, и их разместили осознанно именно так; не сортировать!
				Для каждого знч Из рПараметры.ПараметрыЗапроса Цикл
					рПараметрыЗапроса.Вставить(СокрЛП(знч.Представление),знч.Значение);						
				КонецЦикла;
			КонецЕсли;
		КонецЕсли;
		
		Если рПараметрыЗапроса.Количество()=0 Тогда
			инфо="Параметры запроса не указаны.";
		Иначе
			инфо="Параметры запроса:";
			разд="?";
			Для каждого киз Из рПараметрыЗапроса Цикл
				Если ТипЗнч(киз.Значение)=Тип("Массив") Тогда // раскрываем в последовательность, повторяя ключ
					Для каждого знч Из киз.Значение Цикл
						рАдресРесурса=рАдресРесурса+разд+киз.Ключ+"="+СокрЛП(Строка(знч)); разд="&";
					КонецЦикла;
				Иначе
					рАдресРесурса=рАдресРесурса+разд+киз.Ключ+"="+СокрЛП(Строка(киз.Значение)); разд="&";
				КонецЕсли;				
				инфо=инфо+Символы.ПС+"    "+киз.Ключ+" = "+киз.Значение;
			КонецЦикла;
		КонецЕсли;
		Если рПояснять Тогда
			СообщитьИВнестиВПротокол(инфо,рПротокол);
		КонецЕсли;
		#КонецОбласти
		
		рЗапрос=Новый HTTPЗапрос(рАдресРесурса,рЗаголовкиЗапроса);
		//
		Если рПараметры.Свойство("ТелоЗапроса") Тогда
			Если ТипЗнч(рПараметры.ТелоЗапроса)=Тип("Строка") Тогда				
				рЗапрос.УстановитьТелоИзСтроки(рПараметры.ТелоЗапроса);
			ИначеЕсли ТипЗнч(рПараметры.ТелоЗапроса)=Тип("ДвоичныеДанные") Тогда
				рЗапрос.УстановитьТелоИзДвоичныхДанных(рПараметры.ТелоЗапроса);
			КонецЕсли;
		ИначеЕсли рПараметры.Свойство("ИмяФайлаТелаЗапроса") Тогда
			// наличие файла не проверяем, считаем, что он есть априорно
			рЗапрос.УстановитьИмяФайлаТела(рПараметры.ИмяФайлаТелаЗапроса);
		КонецЕсли;
	КонецЕсли;
	Если рПараметры.Свойство("HTTPЗапрос") Тогда
		// удаляем из параметров, чтобы не повторялось в будущем (кэшировать его нам не надо)
		рПараметры.Удалить("HTTPЗапрос");
	КонецЕсли;
	//
	Если рПояснять Тогда // выводим настройки запроса
		инфо="Запрос:
		|Адрес ресурса: "+рЗапрос.АдресРесурса;
		Если рПараметры.Свойство("ТелоЗапроса") и ТипЗнч(рПараметры.ТелоЗапроса)=Тип("Строка") Тогда
			инфо=инфо+"
			|Тело запроса:"+Символы.ПС+рПараметры.ТелоЗапроса;
		КонецЕсли;
		СообщитьИВнестиВПротокол(инфо,рПротокол);
	КонецЕсли;
	#КонецОбласти
	
	рМетодHTTP=?(рПараметры.Свойство("МетодHTTP"),ВРег(рПараметры.МетодHTTP),"");
	Если ПустаяСтрока(рМетодHTTP) Тогда рМетодHTTP="GET" КонецЕсли;
	Если рПояснять Тогда
		СообщитьИВнестиВПротокол("Метод запроса: "+рМетодHTTP,рПротокол);
	КонецЕсли;	
	
	Если рМетодHTTP="GET" Тогда
		рОтвет=рСоединение.Получить(рЗапрос);
	ИначеЕсли рМетодHTTP="POST" Тогда
		рОтвет=рСоединение.ОтправитьДляОбработки(рЗапрос);
	ИначеЕсли рМетодHTTP="PUT" Тогда
		рОтвет=рСоединение.Записать(рЗапрос);
	ИначеЕсли рМетодHTTP="PATCH" Тогда
		рОтвет=рСоединение.Изменить(рЗапрос);
	ИначеЕсли рМетодHTTP="DELETE" Тогда
		рОтвет=рСоединение.Удалить(рЗапрос);
	Иначе
		СообщитьИВнестиВПротокол("Указан не поддерживаемый метод: "+рМетодHTTP+", никакое действие не выполняется!!",рПротокол);
		Возврат Ложь;
	КонецЕсли;
	рПараметры.Вставить("HTTPОтвет",рОтвет);
	
	Возврат Истина;
	
Исключение
	инфо="HTTPВыполнитьЗапрос, общая ошибка: "+ОписаниеОшибки();
	Сообщить(инфо,СтатусСообщения.Важное);
	ЗаписьЖурналаРегистрации("ОбменСайт",УровеньЖурналаРегистрации.Ошибка,,,инфо);
	Возврат Ложь;
КонецПопытки;
КонецФункции

// Выполняет анализ ответа rest-сервиса как объекта HTTPОтвет, заносит в параметры результаты разбора.
//
// Параметры:
//    HTTPОтвет - объект типа "HTTPСервисОтвет", обязательный; собственно разбираемый ответ;
//    КодСостояния - число, вносимый;
//    Причина - строка, вносимый; если КодСостояния 200, то пуста;
//    ЗаголовкиОтвета - соответствие, вносимый;
//    ТелоКакСтрока - булево; если указан и Истина, то читается тело ответа как строка, для уточнения кодировки используется ключ:
//        КодировкаТелаОтвета - строка или КодировкаТекста, по умолчанию UTF8;
//    ТелоКакДвоичныеДанные - булево; если указан и Истина, то читается тело ответа как двоичные данные;
//    ТелоКакИмяФайла - булево; если указан и Истина, то возвращается имя файла, куда прочитано тело ответа;
//    ТелоОтвета - результат чтения тела ответа, вносимый, если способ чтения тела не указан, то Неопределено.
//    Протокол - текстовый документ, необязательный (по умолчанию пуст и не используется).
//
// Возвращает успешность (булево).
//
Функция HTTPРазобратьОтвет(рПараметры) Экспорт
Попытка
	рПротокол=?(рПараметры.Свойство("Протокол"),рПараметры.Протокол,Неопределено);
	
	Если Не (рПараметры.Свойство("HTTPОтвет") и ТипЗнч(рПараметры.HTTPОтвет)=Тип("HTTPОтвет")) Тогда
		СообщитьИВнестиВПротокол("В структуре параметров не найден ответ сервиса!!",рПротокол);
		Возврат Ложь;
	КонецЕсли;
	рОтвет=рПараметры.HTTPОтвет;
	//
	рПараметры.Вставить("КодСостояния",рОтвет.КодСостояния);
	Если рОтвет.КодСостояния=200 Тогда
		рПараметры.Вставить("Причина","");
	Иначе
		Попытка рПараметры.Вставить("Причина",рОтвет.Причина) Исключение рПараметры.Вставить("Причина","") КонецПопытки;
	КонецЕсли;	
	рПараметры.Вставить("ЗаголовкиОтвета",рОтвет.Заголовки);
	Если рПараметры.Свойство("ТелоКакСтрока") и ТипЗнч(рПараметры.ТелоКакСтрока)=Тип("Булево") и рПараметры.ТелоКакСтрока=Истина Тогда
		рКодировка=КодировкаТекста.UTF8;
		Если рПараметры.Свойство("КодировкаТелаОтвета") и ЗначениеЗаполнено(рПараметры.КодировкаТелаОтвета) Тогда
			Если ТипЗнч(рПараметры.КодировкаТелаОтвета)=Тип("Строка") или ТипЗнч(рПараметры.КодировкаТелаОтвета)=Тип("КодировкаТекста") Тогда
				рКодировка=рПараметры.КодировкаТелаОтвета;
			КонецЕсли;
		КонецЕсли;		
		рПараметры.Вставить("ТелоОтвета",рОтвет.ПолучитьТелоКакСтроку(рКодировка));
	ИначеЕсли рПараметры.Свойство("ТелоКакДвоичныеДанные") и ТипЗнч(рПараметры.ТелоКакДвоичныеДанные)=Тип("Булево") и рПараметры.ТелоКакДвоичныеДанные=Истина Тогда
		рПараметры.Вставить("ТелоОтвета",рОтвет.ПолучитьТелоКакДвоичныеДанные());
	ИначеЕсли рПараметры.Свойство("ТелоКакИмяФайла") и ТипЗнч(рПараметры.ТелоКакИмяФайла)=Тип("Булево") и рПараметры.ТелоКакИмяФайла=Истина Тогда		
		рПараметры.Вставить("ТелоОтвета",рОтвет.ПолучитьИмяФайлаТела());
	Иначе
		СообщитьИВнестиВПротокол("Тело ответа игнорируется, т.к. его тип и способ обработки не указаны!",рПротокол);
		рПараметры.Вставить("ТелоОтвета",Неопределено);
	КонецЕсли;
	//
	Возврат Истина;
Исключение
	инфо="HTTPРазобратьОтвет, общая ошибка: "+ОписаниеОшибки();
	Сообщить(инфо,СтатусСообщения.Важное);
	ЗаписьЖурналаРегистрации("ОбменСайт",УровеньЖурналаРегистрации.Ошибка,,,инфо);
	Возврат Ложь;
КонецПопытки;
КонецФункции

 

 

 
 Выполнение запросов

 

 
 Преобразование json-объектов в коллекции 1С

 

 
 Получение данных

 

 
 Изменение данных

 

Отмечу, что веб-интерфейс реагирует на вызов методов, изменяющих данные, мгновенно, без обновления страницы (но, возможно, в других браузерах при других настройках кэширования это не так). При конкурентном доступе из кода или интерфейса результат соответствует действию, последнему по времени вызова.

 

Также могут представлять интерес следующие действия
* Отметить как прочитанные, т.е. сбросить все оповещения: POST /1/cards/{id}/markAssociatedNotificationsRead
* Архивировать все задачи на листе: POST /1/lists/{id}/archiveAllCards
* Перенести все задачи листа на другой лист: POST /1/lists/{id}/moveAllCards
* Получение ответной реакции на действие (комментарий) в задаче: GET /1/actions/{idAction}/reactions/{id}
 

Приведённая на скриншоте публичная доска также небезынтересна, кроме того, там можно пообщаться с разработчиками.

Примечания:
1. При отправке дат, как устанавливаемых значений свойств, не забывайте про правильный формат - должен быть ISO 8601-2001 (т.е. вида "ГГГГ-ММ-ДДTЧЧ:ММ:ССZ", вариант записи "УниверсальнаяДата").
2. В ряде случаев, особенно для кириллицы, может потребоваться url-перекодировка, используйте глобальные "КодироватьСтроку" и "РаскодироватьСтроку".

 

Есть публикация //infostart.ru/public/1195416/, но там конфигурация, а я выкладываю исходник. Желающие также могут найти по ключевому слову "Trello" множество канбанообразных обработок и проектов. Тема не нова, но авось кому пригодится.

Тестировалось на 8.3.16.1063, но должно работать на всех релизах не ниже 8.3.10.

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. DrZombi 183 19.08.20 08:37 Сейчас в теме
Приветствую вас. "КолЛлега"

Позвольте спросить, где именно использовалась ваша интеграция?
И для какой именно сферы деятельности компании?
user1166203; +1 Ответить
2. Yashazz 3638 19.08.20 09:20 Сейчас в теме
(1) Скажем так, в сфере торговли. Более подробно вам знать незачем.
Подобные решения достаточно универсальны, чтобы конкретика не имела значения.
3. Rustig 1669 19.08.20 09:21 Сейчас в теме
ссылка на " документация по методам" бита
4. Yashazz 3638 19.08.20 09:22 Сейчас в теме
(3) а вроде просто копипастил... Тогда так: https://developer.atlassian.com/cloud/trello/rest/api-group-actions (с первого пункта оглавления)
5. Rustig 1669 19.08.20 09:29 Сейчас в теме
Есть публикация //infostart.ru/public/1195416/, но там конфигурация, а я выкладываю исходник.

Добавлю прямую ссылку https://infostart.ru/public/1195416/
6. Yashazz 3638 19.08.20 09:52 Сейчас в теме
(5) Спасибо. Я вечером и в публикации поправлю.
7. malikov_pro 644 20.08.20 00:27 Сейчас в теме
по
рПорт=?(рПараметры.Свойство("Порт"),рПараметры.Порт,0);
попробуйте применить паттерн "конструктор" и после через "ЗаполнитьЗначенияСвойств" перезаполняйте из входящих.

по "&НаСервереБезКонтекста" - почему не перенести в общий модуль?

По оформлению
То что используете спойлеры - отлично
"Авторизация" - по идее заголовок "Получение токена", тест из спойлера можно вынести, принцип "читаем повествование, при необходимости разворачиваем код или картинки".

Если код открыт- попробуйте опубликовать в github.
Так же тем кто будет разбираться в теме отталкиваясь вашей статьи будет полезна коллекция postman, экспортируется в JSON.

Пробовали использовать https://github.com/vbondarevsky/Connector?
10. Yashazz 3638 20.08.20 09:17 Сейчас в теме
(7)
по "&НаСервереБезКонтекста" - почему не перенести в общий модуль?

Некоторые, конечно, будут делать это в общем модуле, а некоторые - прямо на форме. Ну я на всякий случай и обозначил. Наличие директивы компиляции ничему не мешает)
Если код открыт- попробуйте опубликовать в github

Опять же, подозреваю, не до того мне будет.
8. gradi 5 20.08.20 06:11 Сейчас в теме
Было бы не плохо написать все это на HTTPКоннектор. Код стал бы более читаемым.
За публикацию однозначно +1.
malikov_pro; +1 Ответить
9. Yashazz 3638 20.08.20 09:15 Сейчас в теме
(8) Согласен, но, подозреваю, руки не дойдут.
11. malikov_pro 644 20.08.20 13:14 Сейчас в теме
(9) В результате получаем очередную наработку, которую мало кто будет использовать. Рабочий вариант "посмотреть как реализовано и написать свое". Пример https://infostart.ru/1c/articles/993225/, наработка вроде есть, но переписываю для возможности переиспользования.
12. Yashazz 3638 20.08.20 19:10 Сейчас в теме
(11) Я ж позиционирую это не как наработку, а как атомарный инструментарий. Это даже на проект не тянет, просто набор функций.
13. PLAstic 270 02.09.20 14:33 Сейчас в теме
бОльшую часть колхоза из кода можно убрать, если описать схему XDTO для этого обмена. Тогда будем сразу получать ответы в объектной модели. Да и запросы тоже отправлять объектом удобнее.
14. Yashazz 3638 02.09.20 15:02 Сейчас в теме
(13) Принципиально - да, соглашусь. Это было бы круто, но... если б оно где-то у них на сайте было выложено полностью - а так описаны лишь самые важные объекты, остальное же чисто в процессе выясняется. Схему из этого лепить было муторно (ну неудобный в конфигураторе редактор xsd, блин), посему и не стал.
Оставьте свое сообщение

См. также

Копирование числовых ячеек из 1С в Excel Промо

Загрузка и выгрузка в Excel Администрирование данных 1С v8 1cv8.cf Бесплатно (free)

Решение проблемы, когда значения скопированных ячеек из табличных документов 1С в Excel воспринимаются последним как текст, т.е. без дополнительного форматирования значений невозможно применить арифметические операции. Поводом для публикации послужило понимание того, что целое предприятие с более сотней активных пользователей уже на протяжении года мучилось с такой, казалось бы на первый взгляд, тривиальной проблемой. Варианты решения, предложенные специалистами helpdesk, обслуживающими данное предприятие, а так же многочисленные обсуждения на форумах, только подтвердили убеждение в необходимости описания способа, который позволил мне качественно и быстро справиться с ситуацией.

15.01.2019    28814    itriot11    27    

R.I.P. РИБ

Обмен через XML Распределенная БД (УРИБ, УРБД) v8 1cv8.cf Бесплатно (free)

РИБ, спасибо и до свидания.

19.02.2021    6098    1c-intelligence    131    

Перенос данных из ЗУП 2.5 в ЗУП 3.1

Зарплата Перенос данных из 1C8 в 1C8 v8 v8::СПР ЗУП2.5 ЗУП3.x Россия БУ Бесплатно (free)

Довольно часто сталкиваюсь с тем, что у коллег возникает вопрос, как правильно выполнить перенос данных из ЗУП 2.5 в ЗУП 3.1. (Неужели еще кто-то до сих пор работает в ЗУП 2.5? Да, и очень много людей)

25.01.2021    3212    VAAngelov    48    

HTML редактор/editor (Wysiwyg) для WebKit 1С (CMS, B2B), альтернатива TinyMCE и стандартному ФорматированныйДокумент

WEB Интеграция v8 v8::УФ 1cv8.cf Бесплатно (free)

Suneditor - отличная замена HTML редактору TinyMCE (бесплатному), в публикации с открытым кодом подключим его в 1С с WebKit, скачать HTMLeditor обработку можно бесплатно.

28.12.2020    1801    SizovE    23    

Обмен данными. Консистентность vs Многопоточность Промо

Интеграция v8 1cv8.cf Бесплатно (free)

Рассмотрим теоретические основы обмена данными. Какие бывают обмены, какие гарантии при этом даются, зачем идти на компромиссы и что при этом может пойти не так. Есть ли идеальная схема?

03.09.2019    13559    m-rv    1    

Сказ о том, как в одной крупной компании документооборот внедряли, или проблемы типовых обменов между КА и ДО

Интеграция Документоборот 2 Перенос данных из 1C8 в 1C8 v8 ДО КА2 Бесплатно (free)

Приветствую всех. Сегодня пойдет речь о том, как на одной крупной компании внедряли 1С:Документооборот 2.1 в связке с КА 2.4. Вроде бы системы типовые, мы практически не добавляли ничего в них, но проблем было столько, что я решил изложить их в статье. Может, кому-то пригодится это в дальнейшем, и не придется тратить кучу времени на поиск решений.

10.11.2020    4837    maks_20    22    

Простой пример разработки регулярного обмена с использованием БСП на примере ERP 2.4 и УПП 1.3

БСП (Библиотека стандартных подсистем) Перенос данных из 1C8 в 1C8 v8 1cv8.cf УПП1 КД ERP2 Россия Бесплатно (free)

Данный вариант подойдет тем, кто хочет настроить "свой" регулярный обмен с добавлением "своих" планов обмена с использованием правил обмена на КД 2.1.

27.10.2020    4031    байт    8    

Управление соляриями из 1С через Arduino

Интеграция v8 1cv8.cf Здравоохранение, медицина, стоматология УУ Бесплатно (free)

Мой опыт автоматизации сети соляриев с интеграцией 1С и оборудования соляриев с помощью платформы Arduino.

01.10.2020    2129    impextr    31    

Excel vs 1С: битва с неожиданным исходом Промо

Анализ учета Универсальные обработки Загрузка и выгрузка в Excel Финансовые Управленческие v8 1cv8.cf Россия Бесплатно (free)

Что лучше 1С или Excel? Разберемся, в казалось бы, очевидном, чтобы получить невероятное!

11.04.2019    38324    bolefirenko    120    

Лайфхаки конвертации данных 2.1 (часть 2)

Обмен данными 1С v8 1cv8.cf Бесплатно (free)

В данной статье будут рассмотрены десять приемов работы с конвертацией данных 2.1. Указанные приемы явно не описываются в документации (справке), но их полезно знать и применять. Для наглядности приёмы работы сопровождаются описанием реализации и практическими примерами.

14.09.2020    4946    Alexsandr_Retunskiy    11    

Маркировка лекарственных препаратов. Часть первая "Быстрая интеграция"

Интеграция Розничная торговля v8 1cv8.cf Фармацевтика, аптеки Россия УУ Бесплатно (free)

Данный цикл будет посвящен маркировке лекарственных препаратов (далее ЛП), нюансам работы с "1С: Библиотека интеграции с МДЛП", доступной для скачивания на сайте ИТС, методиками работы с регистраторами выбытия, и проблемам, с которыми пришлось столкнуться при интеграции. Эта статья будет представлять из себя краткую инструкцию, что делать, когда маркировка уже близко и необходимо быстро внедрить ее. Надеюсь, она станет подспорьем в данной задаче. Будут приведены рекомендации, как в короткие сроки с минимально необходимой функциональностью и минимумом чтения документации произвести интеграцию библиотеки МДЛП и выполнить начальные настройки. Также будут даны рекомендации по быстрым, но важным, на мой взгляд, доработкам.

23.06.2020    6857    IssakN    32    

Диадок. Подключаемый модуль. Отладка

Интеграция Внешние источники данных v8 1cv8.cf Бесплатно (free)

Небольшой пример, как работать с подключаемым модулем Диадок (для изменения УПД перед выгрузкой на сайт Диадок.). Отладка подключаемого модуля, если не смогли подключить стандартную отладку.

17.06.2020    6645    John_d    10    

Как прикрутить ГУИД к регистру сведений Промо

Практика программирования Перенос данных из 1C8 в 1C8 Разработка v8 Бесплатно (free)

... и немного теории обмена данными. В частности, разберем боль всех, кто пишет небанальные обмены данными: как набору записей регистра сведений назначить гуид и далее использовать его в обмене для идентификации этого набора.

16.04.2019    20979    m-rv    17    

Конвертация данных 2. Использование подключаемых обработок в правилах обмена. Конвертация дерева значений

Обмен данными 1С Обмен через XML Перенос данных из 1C8 в 1C8 v8 КД Бесплатно (free)

Разработка правил обмена с использованием подключаемых обработок. В качестве примера рассмотрена реальная задача конвертации дерева значений.

15.06.2020    4330    Drivingblind    8    

Конвертация данных 2.1. Методика переноса остатков

Перенос данных из 1C8 в 1C8 v8 1cv8.cf УУ Бесплатно (free)

В данной статье я приведу пример использования базовой методики конвертации данных для переноса остатков из одной информационной базы в другую.

12.06.2020    9811    aximo    17    

Лайфхаки конвертации данных 2.1

Обмен данными 1С v8 КД Россия Бесплатно (free)

В данной статье будут рассмотрены десять приемов работы с конвертацией данных 2.1. Указанные приемы явно не описываются в документации (справке), но их полезно знать и применять. Для наглядности приёмы работы сопровождаются описанием реализации и практическими примерами.

07.06.2020    10355    Alexsandr_Retunskiy    9    

Из Excel в 1С запросом Промо

Загрузка и выгрузка в Excel v8 1cv8.cf Бесплатно (free)

... ну, конечно, не прям так типовым языком запросов, а расширенным языком запросов. Речь пойдет о том, как "залить" данные в таблицы 1С и не пилить при этом бесконечного количества наколеночных обработок.

14.08.2018    20694    m-rv    5    

1C# – 1С моей мечты

Интеграция v8 Бесплатно (free)

Встроенных в платформу 1С возможностей не всегда хватает для построения сложных интеграционных схем между различными 1С и не-1С-решениями на базе MS SQL Server. Как сделать интеграцию между SQL-базами более гибкой с помощью платформы 1С# на конференции Infostart Event 2019 Inception рассказал Дмитрий Жичкин.

01.06.2020    11892    zhichkin    36    

Как мы РИБ на веб-сервисы переводили

Распределенная БД (УРИБ, УРБД) v8 1cv8.cf Россия Бесплатно (free)

Решение проблем обмена РИБ с 10+ баз с помощью веб-сервисов и базы обмена.

13.05.2020    4563    RSConsulting    22    

Интеграция Camunda BPM и 1С

WEB Интеграция v8 Бесплатно (free)

Быстрый старт. Только практические примеры. Установка, запуск и публикация бизнес-процесса на сервере Camunda BPM. Управление бизнес-процессами из 1С при помощи Camunda REST API.

12.05.2020    4526    zhichkin    30    

Повышаем эффективность разработки правил обмена Промо

Практика программирования Перенос данных из 1C8 в 1C8 v8 КД Бесплатно (free)

Как повысить скорость и качество разработки правил обмена? Как вести групповую разработку правил обмена? Как облегчить сопровождение правил обмена после передачи в эксплуатацию? Об этом и многом другом вы можете узнать из этой статьи.

25.06.2018    29077    olegtymko    48    

Механизм XDTO

Перенос данных из 1C8 в 1C8 v8 1cv8.cf Бесплатно (free)

Попытка понять механизм XDTO и его неочевидные аспекты. Научиться выполнять обмены между различными конфигурациями без оглядки на реализацию в типовых.

12.05.2020    6118    totchaz    4    

Как мы загружаем данные в "Центр управления кассами Магнита"

Внешние источники данных Интеграция v8 1cv8.cf Бесплатно (free)

Статья о том, как мы делали механизм загрузки больших объемов данных в "Центр управления кассами Магнита"

08.05.2020    5376    chernenko_vv    25    

Синхронизация БИТ:СКУД 8 с Parsec.Net 2.5

Интеграция Внешние источники данных v8 1cv8.cf Бесплатно (free)

Настройка синхронизации БИТ:СКУД 8 с Parsec.Net.2.5, выгрузка данных из внешней системы контроля доступа.

04.05.2020    4322    RPGrigorev    0    

Универсальный обмен между идентичными конфигурациями через REST интерфейс OData. Часть І: Справочники Промо

Перенос данных из 1C8 в 1C8 v8 Бесплатно (free)

Сейчас все чаще интеграции различных конфигураций проектируются через HTTP-сервисы - они и работают быстрее, и "войти" в режим отладки гораздо проще, тем самым обойдя "черный ящик" универсального обмена через xml, например. Более года назад я начал работать в компании, в которой разработчики работали с конфигурациями 1С в режиме совместимости еще 8.2.16 (менять режим совместимости в типичных базах мы не хотели) - а как Вы наверное знаете, если интересовались HTTP-сервисами в 1С, их использование в режиме совместимости 8.3.4 и ниже недопустимо - и здесь я уже не надеялся на разработку и использование HTTP-сервисов. Но позже меня заинтересовал такой "сервис" как REST интерфейс OData, так как его можно использовать не меняя режим совместимости конфигурации - именно он и стал для меня идеальным вариантом решения "нетривиальных" задач.

11.05.2018    23994    V.Stavinsky    11    

Измерительная лаборатория с использованием 1С+Ардуино

Периферийные устройства Интеграция v8 Россия Бесплатно (free)

1С в автоматизации "научных" и около... экспериментов.

02.05.2020    4687    maxlab    16    

Интеграция БИТ:СКУД с типовой конфигурацией

Интеграция v8 1cv8.cf Россия Бесплатно (free)

Интеграция БИТ:СКУД с типовой конфигурацией, обновление БИТ:СКУД в составе конфигурации и отдельно. Обновление системы защиты.

26.04.2020    5579    RPGrigorev    0    

Взаимодействие между базами 1С через COM Промо

Перенос данных из 1C8 в 1C8 v8 1cv8.cf Бесплатно (free)

Рассмотрено много особенностей взаимодействия между базами 1С по COM технологии

10.08.2015    160794    tormozit    68    

Как я собрал для себя высокопроизводительный и бесплатный облачный бекенд для 1С на PosgreSQL + PostgREST

Производительность и оптимизация (HighLoad) WEB Интеграция Мобильная разработка Администрирование веб-серверов v8 Бесплатно (free)

В этой статье я расскажу о проблемах бека для мобильных приложений или другого фронта, который требует производительности, быстрой реакции и отказоустойчивости, и как я решил это благодаря opensource проекту PostgREST и СУБД Postgre SQL 12. Проведу простой тест производительности для сравнения 1С с данным решением. Это может быть полезно всем, кто разрабатывает мобильные приложения либо фронтсайд-приложения для 1С на чем угодно - на мобильной платформе или на нативном языке или на Simple UI. И также обзор новых функций SimpleUI для связи с этим бекендом.

31.03.2020    14369    informa1555    35    

5 ситуаций, когда в экосистеме 1C нужны веб-сервисы

Обмен данными 1С v8 Бесплатно (free)

В 1С существует немало возможностей для обмена данными, включая файловый обмен и COM Connector. В этой статье я расскажу, когда при интеграции 1С не обойтись без веб-сервисов, а также в чем плюсы использования SOAP или, наоборот, HTTP. Кроме этого речь пойдет про рабочие инструменты и примеры использования веб-сервисов. Веб-сервисы — достаточно простая штука. Существует множество инструкций по их созданию, так что запустить свой сервис может почти каждый. Сложности возникают тогда, когда веб-сервисы начинают куда-то встраивать, например, в системы 1С.

24.03.2020    8397    Neti    4    

Механизмы проведения документов при обмене по универсальному формату

Перенос данных из 1C8 в 1C8 БСП (Библиотека стандартных подсистем) v8 Бесплатно (free)

Как проводятся документы при обмене по универсальному формату. Пример доработки типовых правил обмена с переносом состояния документа: проведен/не поведен/пометка удаления.

04.03.2020    5504    partizand    6    

Использование инструментов разработчика для отладки обменов КД 2.0 Промо

Перенос данных из 1C8 в 1C8 v8 КД Бесплатно (free)

Пара трюков, благодаря которым жить становится намного проще...

05.05.2017    28086    unichkin    6    

Интеграция "Библиотеки интеграции МДЛП 1.1.2.7" с типовой конфигурацией

Интеграция Конфигурирование 1С v8 Здравоохранение, медицина, стоматология Россия Бесплатно (free)

Инструкция для интеграции “Библиотеки интеграции МДЛП 1.1.2.7” в типовые конфигурации, на примере конфигурации “Управление нашей фирмой, редакция 1.6 (1.6.18.168)”.

02.03.2020    7670    RPGrigorev    3    

Односторонний обмен ЗУП и БП

Перенос данных из 1C8 в 1C8 v8 БП3.0 ЗУП3.x Россия Бесплатно (free)

Односторонний обмен из ЗУП в БУХ

29.02.2020    6571    VAAngelov    14    

Пример работы с Trello из 1С

WEB v8 1cv8.cf Россия УУ Абонемент ($m)

Небольшая конфигурация содержит примеры обмена с онлайн-сервисом Trello.

1 стартмани

15.02.2020    12831    47    terrorion    14    

РИБ 200 узлов. Середина пути Промо

Распределенная БД (УРИБ, УРБД) v8 Розница Россия Бесплатно (free)

Между настройкой и поддержкой РИБ на 2 узла и на 10 большой разницы нет, а вот когда число удаленных точек переваливает за сотню, приходится решать уже совсем другие вопросы

25.10.2016    40416    comol    215    

Бесшовная интеграция через обмен по правилам - миссия выполнима

Практика программирования Интеграция Перенос данных из 1C8 в 1C8 v8 ДО ERP2 Бесплатно (free)

При организации работы с договорами в ERP 2, с помощью бесшовной интеграции с Документооборотом, «типовой» методикой является создание договоров в ЕРП. После создания договора в ЕРП, пользователь «отправляет» договор в ДО по бесшовной интеграции. На практике, весьма часто пользователи хотят видеть обратную схему: вводить договоры в ДО и при этом получать их в ЕРП без «лишних телодвижений». Или даже вводить их независимо в обеих системах – так, чтобы потом «стыковать» по каким-то определенным правилам.

24.01.2020    5800    e-9    2    

Как сделать обмен данными через универсальный формат быстрее? Реализация многопоточного обмена данными

Обмен данными 1С Обмен через XML v8 1cv8.cf Бесплатно (free)

Предлагаю Вашему вниманию интересный кейс по реализации обмена данными через универсальный формат между современными типовыми конфигурациями в режиме многопоточности. Учитывая все тонкости механизмов обмена данными и сложности типовых правил конвертации, сделать это оказалось совсем не так просто.

31.12.2019    8723    ids79    17    

Заметки по Конвертации данных 3.0

Обмен данными 1С v8 1cv8.cf Бесплатно (free)

Написал небольшие заметки по конвертации данных 3.0.

18.11.2019    17428    John_d    17    

Приемы обработки больших данных в 1С Промо

Универсальные обработки Математика и алгоритмы Перенос данных из 1C8 в 1C8 v8 1cv8.cf Бесплатно (free)

Рассказ об эффективных приемах организации обработок больших объемов данных на платформе 1С

07.08.2015    68742    tormozit    27    

Обсудим планы обмена. Способы регистрации объектов к обмену

Обмен данными 1С v8 1cv8.cf Бесплатно (free)

В этой статье я предлагаю обсудить такой объект конфигурации, как "план обмена", а точнее, методы регистрации в нем. Да и вообще, посмотрим, как можно зарегистрировать объекты к обмену.

16.11.2019    29507    aximo    37    

И снова "Конфигурация узла распределенной ИБ не соответствует ожидаемой"

Распределенная БД (УРИБ, УРБД) Обмен данными 1С v8 Бесплатно (free)

Конфигурация узла распределенной ИБ не соответствует ожидаемой. Приведен очередной способ устранения этой ошибки, возникший не в результате сбоев в работе оборудования или при обмене, а в результате обновления платформы 1С.

05.11.2019    6561    Kobra_RU    11    

Обертка функций Excel на русском. Ускорение процесса разработки.

Загрузка и выгрузка в Excel Универсальные функции v8 Бесплатно (free)

Устали переключаться с русского на английский и обратно при работе с таблицами Excel из 1С? Сборка наиболее необходимых функций и методов работы с Excel, обернутых в функции 1С на русском языке.

24.10.2019    7580    DmitryKotov    6    

Загрузка из EXCEL в 1С на платформе 8.3.6/8.3.7/8.3.8/8.3.9/8.3.10 (с картинками) Промо

Практика программирования Загрузка и выгрузка в Excel v8 1cv8.cf Бесплатно (free)

Импорт содержимого из файлов в форматах XLS (Microsoft Excel 97), Microsoft Office OpenXML (Microsoft Excel 2007- 2010) и ODS (OpenDocument) в таблицу значений.

06.04.2015    251108    StepByStep    76    

EnterpriseData: простой способ защиты данных в базе получателя при одностороннем обмене

Перенос данных из 1C8 в 1C8 v8 1cv8.cf Бесплатно (free)

Очень часто бухгалтеры ругаются, когда уже отраженные документы в бухгалтерском учета меняются сотрудниками.

04.10.2019    7550    handscenter    12    

Конвертация Данных. Нюансы использования конструкции "НеЗамещатьОбъект = Истина" в обработчике события "ПриЗагрузке"

Перенос данных из 1C8 в 1C8 v8 КД Бесплатно (free)

У конвертации данных есть «особенности», которые «пьют кровь» программистов. Эта статья про очередную обнаруженную «особенность».

10.09.2019    11160    ivanek    21    

Обмен данными через Web Сервисы

Перенос данных из 1C8 в 1C8 v8 1cv8.cf Россия Бесплатно (free)

Ознакомительная статья о том, как загружать\выгружать данные с одной базы в другую, используя Web Сервисы.

02.09.2019    30141    user5300    42    

Загрузка из EXCEL в 1С. Чтение файла XLSX средствами 1С. ПостроительDOM Промо

Универсальные обработки Загрузка и выгрузка в Excel Обмен через XML v8 1cv8.cf Бесплатно (free)

ПРАКТИЧЕСКОЕ ПОСОБИЕ РАЗРАБОТЧИКА: Метод "NativeXLSX" (ПостроительDOM). Обрабатываются данные EXCEL типов: "Строка", "Число", "Дата" ("Время"), "Булево", "Процент", а также изображения.

11.09.2014    75664    StepByStep    27    

Выгрузка и загрузка документов с движениями

Перенос данных из 1C8 в 1C8 v8 КД Бесплатно (free)

Возникла задача перенести документы с движениями, но подменив организацию. Наткнулся на проблему с выгрузкой движений, опишу свой опыт.

02.09.2019    8866    human_new    12    

EnterpriseData – часть 3. Загрузка данных, идентификация объектов

Практика программирования Математика и алгоритмы Перенос данных из 1C8 в 1C8 Разработка v8 v8::УФ 1cv8.cf Бесплатно (free)

Основные этапы загрузки данных через EnterpriseData. Идентификация объектов загружаемых полностью и по ссылке. Приведены схемы процессов загрузки данных. Описание основных операций и обработчиков. Перечень процедур БСП, используемых при загрузке данных, структура «КомпонентыОбмена».

22.08.2019    16502    ids79    8    

Перенос дополнительных реквизитов в Конвертации данных 2.0

Перенос данных из 1C8 в 1C8 v8 КД Россия УУ Бесплатно (free)

Пример написания правил обмена (КД 2.0) для переноса дополнительных реквизитов справочника "Номенклатура", в том числе перенос ПВХ с разными типами значений.

13.08.2019    13359    vikulinamari    8