Ускорение медленной работы строк в 1С на примере 1С:Документооборот КОРП

Публикация № 1303356

Администрирование - Производительность и оптимизация (HighLoad)

Долго Медленно Тормозит УСКОРЕНИЕ Оптимизация Документооброт Строка HTML доработка типовых КОРП избыточное

Если у вас в 1С:Документооборот КОРП 2.1.11.5 (часть более старых и новых конфигураций): 1) Долго отправляется почта в формате HTML; 2) Медленно открывается документы внутренние / входящие / исходящие; 3) Тормозит область просмотра или открытие задач. Тогда вам сюда.

Типовые конфигурации 1С умеют показать - как делать не надо.

Что может быть опасного в выражениях работы со строками или символами, например:

Строка = Строка + Символ;
КодСимвола(Строка, Позиция);
Символ = Символ(Код);

Пусть даже это происходит в цикле, ведь одна операция выполняется 0,5-2 миллисекунды.

Допустим, в такой типовой функции, которая часто используется в различных блоках конфигурации.

Функция ЗаменитьСпецСимволыHTML(Строка, СпецСимволыСоотв = Неопределено) Экспорт
	СоответствиеСпецСимволов = РаботаС_HTMLПовтИсп.ПолучитьСоответствиеСпецСимволов();
	ЗаменитьСпецСимволHTML(Строка, 38, "amp");
	НоваяСтрока = "";
	
	Для Поз = 1 По СтрДлина(Строка) Цикл
		Код = КодСимвола(Строка, Поз);
		ИмяСимвола = СоответствиеСпецСимволов.Получить(Код);
		
		Если ИмяСимвола = Неопределено Тогда
			НоваяСтрока = НоваяСтрока + Символ(Код);
		Иначе
			НоваяСтрока = НоваяСтрока + "&" + ИмяСимвола + ";";
		КонецЕсли;
	КонецЦикла;

	Строка = НоваяСтрока;
	Возврат Строка;
КонецФункции

Но если длина строки измеряется тысячами и десятками тысячами символов, то несложно догадаться, что это займет уже секунды,  десятки секунд, а может даже и сотни, что у нас и случилось.

Кажется, надо срочно выбрать другой тип переменной, отличный от строки, или использовать другие механизмы и объекты.

Но давайте попробуем понять, что там происходит в цикле, зачем и что с этим можно сделать.

  1. Получаем "код символа".
  2. Ищем "имя символа" в соответствии.
  3. Добавить к строке символ, если "имя символа":
    1. тогда добавить "символ" по коду символа;
    2. иначе добавить "имя символа".

Вроде все логично, проверяем символы и если необходимо, производим замену.

Но вот идеи, что можно сделать:

  1. Зачем переводить символ в код и обратно пункты 1. и 3.1., надо получать символ, а от него код, тогда не надо получать символ по коду.
  2. Сделать КЭШ в котором хранились символы, по которым была выполнена проверка и результат поиска.
  3. Пункт 3.1 будет выполнять подряд несколько раз, если не было спец. символов, значит надо накапливать строку и добавлять целиком, а не по одному символу. 

Посмотрим, что у нас получилось

Функция ЗаменитьСпецСимволыHTML(Строка, СпецСимволыСоотв = Неопределено) Экспорт
	
	СоответствиеСпецСимволов = РаботаС_HTMLПовтИсп.ПолучитьСоответствиеСпецСимволов();
	ЗаменитьСпецСимволHTML(Строка, 38, "amp");
	НоваяСтрока = "";
	
	// {{ новый алгоритм
	КЭШ_Символов = Новый Соответствие;
	Последний = 0;

	Для Поз = 1 По СтрДлина(Строка) Цикл
		Символ = Сред(Строка, Поз, 1);
		ИмяСимвола = КЭШ_Символов.Получить(Символ);
		
		Если ИмяСимвола = Неопределено Тогда 
			Код = КодСимвола(Строка, Поз);
			ИмяСимвола = СоответствиеСпецСимволов.Получить(Код);
			
			Если ИмяСимвола = Неопределено Тогда
				ИмяСимвола = "Неопределено";
			КонецЕсли;
			
			КЭШ_Символов.Вставить(Символ, ИмяСимвола);
		КонецЕсли;
			
		Если ИмяСимвола <> "Неопределено" Тогда 
			Если Последний = 0 Тогда 
				ПодСтрока = "";
			Иначе 
				ПодСтрока = Сред(Строка, Последний, Поз - Последний);
				Последний = 0;
			КонецЕсли;
			
			НоваяСтрока = НоваяСтрока + ПодСтрока + "&" + ИмяСимвола + ";";
		ИначеЕсли Последний = 0 Тогда 
			Последний = Поз;
		КонецЕсли;
	КонецЦикла;
	
	Строка = НоваяСтрока + ?(Последний = 0, "", Сред(Строка, Последний, Поз - Последний + 1));
	// }} новый алгоритм
	
	Возврат Строка;
КонецФункции

Давайте посмотрим, как изменился замер производительности

О чудо стало работать почти в 100 раз быстрее.

 

PS: Часто программисты не пытаются решить проблемы логики, а пытаются решить проблему медленных механизмов.

Но как показывает практика - исправление логики приносит более значимый результат.

 

Update (2020-10-02 15:15):

Новый вариант из комментариев, пример того когда велосипед уже придуман, а ты изобретаешь колесо.

В типовом релизе 1С:Документооброт ПРОФ 2.0.14.4 используют процедуру "ЗаменитьСпецСимволHTML()", но с ней есть проблема.

Значение символа по коду "Символ(КодСимвола)" вычисляется долго.

Но кто нам мешает объединить все лучшее в одном месте.

Функция ЗаменитьСпецСимволыHTML(Строка, СпецСимволыСоотв = Неопределено) Экспорт
	СоответствиеСпецСимволов = РаботаС_HTMLПовтИсп.ПолучитьСоответствиеСпецСимволов();
	ЗаменитьСпецСимволHTML(Строка, 38, "amp");
	
	// {{ новый алгоритм (4)
	Для Каждого СпецСимвол Из СоответствиеСпецСимволов Цикл 
		Строка = СтрЗаменить(Строка, РаботаС_HTMLПовтИсп.ПолучитьСимволПоКоду(СпецСимвол.Ключ), "&" + СпецСимвол.Значение + ";");
	КонецЦикла;
	// }} новый алгоритм (4)
	
	Возврат Строка;
КонецФункции

и в общем в подходящем общем модуле, добавил функцию для повторного использования.

Функция ПолучитьСимволПоКоду(Код) Экспорт
	Возврат Символ(Код);
КонецФункции

Итого: При первом использовании время немного больше 1 сек, но при повторном использовании время падает до 0,05 сек!

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. gabrielyants 01.10.20 23:36 Сейчас в теме
Спасибо за статью, неплохой вариант решения проблемы!
Sla; pavelpribytkin96; karpik666; BuildSolution; +4 Ответить
2. Sedaiko 403 02.10.20 09:39 Сейчас в теме
Должно еще ускорится если заменить
НоваяСтрока = НоваяСтрока + ПодСтрока + "&" + ИмяСимвола + ";";
на
МассивНовыхСтрок.Добавить(ПодСтрока + "&" + ИмяСимвола + ";")
и в и после уже соединить
НоваяСтрока=СтрСоединить(МассивНовыхСтрок,"")

СтрСоединить специально для этого и ввели, чтобы ускорить конкатенацию
simonovich; cosmo2004; +2 Ответить
5. Nykyanen 341 02.10.20 14:24 Сейчас в теме
(2) Проверил данный вариант, получилось выиграть еще 1/3 времени. То есть за 0,6 сек.
Далее можно углубиться в повторное использование
	// {{ новый алгоритм (2)
	КЭШ_Символов = Новый Соответствие;
	Последний = 0;
	МассивНовыхСтрок = Новый Массив;

	Для Поз = 1 По СтрДлина(Строка) Цикл
		Символ = Сред(Строка, Поз, 1);
		ИмяСимвола = КЭШ_Символов.Получить(Символ);
		
		Если ИмяСимвола = Неопределено Тогда 
			Код = КодСимвола(Строка, Поз);
			ИмяСимвола = СоответствиеСпецСимволов.Получить(Код);
			
			Если ИмяСимвола = Неопределено Тогда
				ИмяСимвола = "Неопределено";
			КонецЕсли;
			
			КЭШ_Символов.Вставить(Символ, ИмяСимвола);
		КонецЕсли;
			
		Если ИмяСимвола <> "Неопределено" Тогда 
			Если Последний = 0 Тогда 
				ПодСтрока = "";
			Иначе 
				ПодСтрока = Сред(Строка, Последний, Поз - Последний);
				Последний = 0;
			КонецЕсли;
			
			МассивНовыхСтрок.Добавить(ПодСтрока + "&" + ИмяСимвола + ";");
		ИначеЕсли Последний = 0 Тогда 
			Последний = Поз;
		КонецЕсли;
	КонецЦикла;
	
	Если Последний <> 0 Тогда 
		МассивНовыхСтрок.Добавить(Сред(Строка, Последний, Поз - Последний + 1) + "&" + ИмяСимвола + ";");
	КонецЕсли;
	
	Строка = СтрСоединить(МассивНовыхСтрок, "");
	// }} новый алгоритм (2)
Показать
Mechanist; +1 Ответить
6. Nykyanen 341 02.10.20 14:53 Сейчас в теме
(5) добавил повторное использование, перенес
КодСимвола(Строка, Поз)
в модуль
РаботаС_HTMLПовтИсп


Получилось ускорить еще в 2 раза, до 0,35 сек.
3. Yashazz 3740 02.10.20 11:38 Сейчас в теме
Вещи-то в целом очевидные, но за эти две фразы
Часто программисты не пытаются решить проблемы логики, а пытаются решить проблему медленных механизмов

Типовые конфигурации 1С умеют показать - как делать не надо

респект однозначно.
zabaluev; Nykyanen; +2 Ответить
4. Nykyanen 341 02.10.20 13:55 Сейчас в теме
Коллеги подсказали, что в 1С:Документооброт ПРОФ 2.0.14.4 используется
Процедура ЗаменитьСпецСимволHTML(Строка, КодСимвола, ИмяСимвола)
	
	Строка = СтрЗаменить(Строка, Символ(КодСимвола), "&" + ИмяСимвола + ";");
	
КонецПроцедуры

организовал, через неё
	Для Каждого СпецСимвол Из СоответствиеСпецСимволов Цикл 
		ЗаменитьСпецСимволHTML(Строка, СпецСимвол.Ключ, СпецСимвол.Значение);
	КонецЦикла;

Время выросло на 10%, до 1 сек
8. Nykyanen 341 02.10.20 15:08 Сейчас в теме
(4) Добавление повторного использования
Символ(КодСимвола)

Добавила скорости до космических 0,05 сек.
Надо добавить в статью.
Mechanist; +1 Ответить
9. Nykyanen 341 02.10.20 15:30 Сейчас в теме
(4) Ждем этот вариант в типовой конфигурации :-)
7. protexprotex 129 02.10.20 14:56 Сейчас в теме
Да. Правильно. Проблема зачастую лежит в плоскости кривизны рук, а не в проблеме "железо не тянет" :-)
10. BobNN 02.10.20 22:42 Сейчас в теме
(7)
Любые курсы программирования должны предваряться курсами программирования на программируемом калькуляторе.
(С) идея чур моя!!
11. nomad_irk 55 02.10.20 23:13 Сейчас в теме
(10) ....с замером производительности и мониторингом утилизации аппаратной части :)
12. FatPanzer 13 02.10.20 23:35 Сейчас в теме
(10) Да я как раз и начинал с МК-52...
13. protexprotex 129 03.10.20 08:59 Сейчас в теме
(10) Точно! Наш препод говорил - учу Вас программировать на ассемблере потому, что он развивает логическое мышление и главное развивает привычку оптимизировать код еще в момент его написания, а не потом когда код уже написан и работает медленно и чтобы его оптимизировать нужно все переписать.
14. SlavaKron 05.10.20 08:27 Сейчас в теме
(13) А еще есть мнение, что Преждевременная оптимизация — корень всех (или большинства) проблем в программировании.
athena; Tyler Durden; +2 Ответить
15. protexprotex 129 05.10.20 10:13 Сейчас в теме
(14) Это да. Согласен. Но и ваять а кагбы вышло - лишь бы работало - тоже не айс. Потом чтобы переделать структуру программы - лучше заново все переписать. в 1С это не так критично. А вот, например программа на c++ (или еще хуже на ассемблере) - там нет априори заданных объектов типа ТаблицаЗначений, СписокЗначений (STL - компоненты не в счет - они все же более узкоспециализированные) - там структуру не ту выбереш - и потом чтобы все это оптимизировать, то легче заново переписать. Все должно быть в меру.
16. ICeZm 15 12.10.20 14:20 Сейчас в теме
Оставьте свое сообщение

См. также

Исследование технологического журнала 1С при помощи регулярных выражений в блокноте Промо

Производительность и оптимизация (HighLoad) v8 Бесплатно (free)

Все из тех, кто пробовали сдать на сертификат "Эксперт по технологическим вопросам 1С", сталкивались с методикой ЦКТП - разбор файлов технологического журнала при помощи консоли bash. Я, в свою очередь,внёс изменения в данную методику. Мне хотелось достичь более понятного вида и сфокусироваться на Perl, в качестве предпочтительного средства обработки файлов ТЖ. Вот что из этого вышло:

30.10.2017    31263    MrWonder    42    

Решение нестандартных проблем производительности на реальных примерах

Производительность и оптимизация (HighLoad) v8 Бесплатно (free)

На екатеринбургском Infostart Meetup выступил с докладом архитектор ИС центра разработки ФТО Александр Криулин. Он поделился с коллегами кейсами нестандартных проблем производительности и рассказал о способах их решения.

24.03.2021    2835    AlexKriulin    36    

Долгое воспроизведение звука по RDP с удаленной машины

Производительность и оптимизация (HighLoad) v8 Бесплатно (free)

При воспроизведении короткого звука в 38 Кб, сигнализирующего об успешном сканировании, порою происходило подвисание примерно в 5 секунд.

09.02.2021    550    pashamak    2    

Highload-оптимизация 1С: теория и практика на примере консолидированной отчетности группы "Магнит" и розничной аптечной сети "Магнит"

Производительность и оптимизация (HighLoad) v8 Бесплатно (free)

Тема оптимизации 1С на больших данных бесконечная и всеобъемлющая, поскольку на производительность влияет целый ряд факторов – количество пользователей, данных, транзакций, неоптимальные запросы и т.д. Об инструментах для локализации проблем производительности и практических кейсах оптимизации рассказал Алексей Олейник, руководитель сектора автоматизации отчетности МСФО компании «Информационные технологии Магнит».

11.01.2021    15458    user662404_itlexusss    14    

Долго открывается конфигуратор Промо

Производительность и оптимизация (HighLoad) v8 1cv8.cf Бесплатно (free)

В ОС Windows Server 2012 бывает полезно выключать службу Dynamic Fair Share Scheduling (DFSS позволяет балансировать и распределять ресурсы между пользователями), чтобы повысить производительность 1С:Предприятие 8 в ряде случаев.

22.04.2015    42331    Gilev.Vyacheslav    1    

Анализ блокировок СУБД: таблица изменений плана обмена 1С

Производительность и оптимизация (HighLoad) v8 Бесплатно (free)

Практический пример анализа типичной проблемы ожидания на блокировках СУБД, возникающих при использовании планов обмена 1С. Сервер СУБД: Microsoft SQL Server.

18.12.2020    2107    zhichkin    5    

Анализ проблем производительности по динамике мониторинга RAS 1C

Производительность и оптимизация (HighLoad) v8 1cv8.cf Бесплатно (free)

В статье приведем список наиболее чувствительных параметров к изменением производительности системы, также расскажем и покажем, как они изменяются, на что влияют, и дадим советы, что делать.

07.10.2020    3998    ivanov660    12    

Тест скорости работы мобильной платформы 1С

Мобильная разработка Производительность и оптимизация (HighLoad) v8 1cv8.cf Бесплатно (free)

С помощью этого приложения вы можете измерить производительность своего устройства, используя для этого мобильную платформу 1С:Предприятие. Набор действий теста полностью повторяет аналогичный тест для стационарных ПК, поэтому результаты сравнимы.

14.09.2020    1546    capitan    25    

Как можно "положить" SQL сервер с помощью обычной консоли запросов 1С Промо

Производительность и оптимизация (HighLoad) v8 1cv8.cf Бесплатно (free)

Описано как из 1С, с помощью безобидной на первый взгляд обработки, можно сделать неработоспособным SQL сервер. Предложены меры, позволяющие избежать этого.

22.01.2014    68287    yuraos    112    

Описание почти всех событий технологического журнала

Технологический журнал v8 Бесплатно (free)

Краткое описание событий технологического журнала с примерами. Все для быстрого старта.

19.08.2020    16490    YPermitin    30    

Адаптация автоматической классификации ошибок технологического журнала при появлении новых текстов и типов

Технологический журнал v8 1cv8.cf Бесплатно (free)

Корректируем классификацию ошибок ТЖ в процессе работы для конфигурации мониторинг производительности

17.08.2020    689    ivanov660    0    

SQL для 1С: пишем правильно, красиво, сложно

Производительность и оптимизация (HighLoad) v8 1cv8.cf Бесплатно (free)

Многие программисты боятся работать с Null, считая, что от этих данных в запросах нужно избавляться. О том, как с помощью Null-полей в запросе решать востребованные в учете задачи по выборке данных, на конференции Infostart Event 2019 Inception рассказал ведущий разработчик ГК WiseAdvice Дмитрий Дудин.

14.08.2020    12345    dmurk    31    

Ускоряем списание партий УПП 1.2 / 1.3 / УТ 10.3 Промо

Производительность и оптимизация (HighLoad) v8 УТ10 УПП1 Бесплатно (free)

Не секрет, что многие пользователи, использующие партионный учет (а таких очень много, даже среди огромных холдингов, несмотря на пропаганду РАУЗ) при больших нагрузках сталкиваются с резким замедлением списания партий.

21.06.2013    58281    Антон Ширяев    117    

Нестандартные блокировки при работе с OLAP-нагрузкой

Производительность и оптимизация (HighLoad) v8 Бесплатно (free)

Если выполнение отчета мешает работе других пользователей и провоцирует блокировки, даже с учетом «грязного чтения» – ситуация кажется парадоксальной. О том, как расследовать такие проблемы, на конференции Infostart Event 2019 Inception рассказали ведущий программист торгового дома «Петрович» Станислав Щербаков и специалист по производительности компании «СофтПоинт» Александр Денисов.

20.07.2020    2351    Филин    7    

Автоматическая классификация ошибок технологического журнала

Технологический журнал v8 1cv8.cf Бесплатно (free)

В статье обсудим пример практической настройки конфигурации «Мониторинг производительности» для автоматической классификации ошибок по группам/кластерам на данных текстов описания ошибок. Используем механизм векторной модели текстов и косинусное сходство между ними.

25.06.2020    3343    ivanov660    13    

Выявляем и оптимизируем ресурсоемкие запросы 1С:Предприятия

Производительность и оптимизация (HighLoad) Администрирование СУБД Технологический журнал Структура метаданных v8::Запросы Бесплатно (free)

Обычно предметом оптимизации являются заранее определенные ключевые операции, т.е. действия, время выполнения которых значимо для пользователей. Причиной недостаточно быстрого выполнения ключевых операций может быть неоптимальный код, неоптимальные запросы либо же проблемы параллельности. Если выясняется, что основная доля времени выполнения ключевой операции приходится на запросы, то осуществляется оптимизация этих запросов. При высоких нагрузках на сервер СУБД в оптимизации нуждаются и те запросы, которые потребляют наибольшие ресурсы. Такие запросы не обязательно связаны с ключевыми операциями и заранее неизвестны. Но их также легко выявить и определить контекст их выполнения, чтобы оптимизировать стандартными методами.

24.05.2020    9282    DataReducer    22    

Сравнение скорости работы 1C+MSSQL и файлового варианта Промо

Производительность и оптимизация (HighLoad) v8 1cv8.cf Россия Бесплатно (free)

На форумах постоянно задается один и тот же вопрос: почему 1C+MSSQL медленнее обрабатывает запросы чем файловая? Затем обычно идет «флуд» на несколько десятков страниц. Есть два популярных «течения» в таких форумах — одни говорят что для клиент-серверного варианта это нормально, файловый вариант всегда должен работать быстрее, другие говорят что 1С плохо работает с субд. В результате «баталий и выяснения отношений» на форумах люди расходятся при своих мнения.

19.02.2013    57383    Gilev.Vyacheslav    46    

[SQL Server] Использование trace flag 9592 для сжатия траффика в кластере AlwaysOn

Производительность и оптимизация (HighLoad) v8 Бесплатно (free)

Недавно мы столкнулись с проблемой производительности, при которой дополнительная нагрузка, связанная с записью большого массива данных, приводила к существенным задержкам в операциях записи основного траффика. Найденное решение позволило не только уменьшить влияние нового процесса на основной пользовательский трафик, но и существенно снизить сетевой траффик между синхронными репликами кластера.

18.05.2020    2435    Aleksey.Bochkov    4    

Эти занимательные временные таблицы

Производительность и оптимизация (HighLoad) Администрирование СУБД v8 Бесплатно (free)

Кое-что интересное о временных таблицах и работе платформы 1С с ними.

06.04.2020    13807    YPermitin    0    

Оптимизация запросов 1С посредством индексации временных таблиц. Миф? Тестируем, смотрим, считаем

Производительность и оптимизация (HighLoad) Практика программирования v8 Бесплатно (free)

Появилось свободное время, решил проверить на работе индексацию таблиц. Решил поделиться с Вами результатами исследования. Давайте порассуждаем на эту тему? Часто ли вы пользуетесь индексацией в запросах? Платформа 8.3.16.1224

03.04.2020    6321    feva    15    

Параллельные вычисления в 1С 8 Промо

Производительность и оптимизация (HighLoad) v8 1cv8.cf Бесплатно (free)

Решение позволяет ускорять выполнение запросов в 1С 8 в отчетах путем их параллельного выполнения в разных потоках.

11.02.2013    32337    gallam99    19    

Как я собрал для себя высокопроизводительный и бесплатный облачный бекенд для 1С на PosgreSQL + PostgREST

Производительность и оптимизация (HighLoad) WEB Интеграция Мобильная разработка Администрирование веб-серверов v8 Бесплатно (free)

В этой статье я расскажу о проблемах бека для мобильных приложений или другого фронта, который требует производительности, быстрой реакции и отказоустойчивости, и как я решил это благодаря opensource проекту PostgREST и СУБД Postgre SQL 12. Проведу простой тест производительности для сравнения 1С с данным решением. Это может быть полезно всем, кто разрабатывает мобильные приложения либо фронтсайд-приложения для 1С на чем угодно - на мобильной платформе или на нативном языке или на Simple UI. И также обзор новых функций SimpleUI для связи с этим бекендом.

31.03.2020    14712    informa1555    35    

Многострочный контекст событий

Производительность и оптимизация (HighLoad) Технологический журнал v8 Бесплатно (free)

Разбор технологического журнала с группировкой событий по первой или последней строке многострочного контекста.

31.03.2020    3477    vasilev2015    10    

Анализ взаимоблокировок

Производительность и оптимизация (HighLoad) Технологический журнал v8 v8::blocking Бесплатно (free)

Скрипт Bash, который выводит полную информацию взаимоблокировок по технологическому журналу. Не имеет аналогов в отечественных публикациях.

20.03.2020    6007    vasilev2015    27    

Ubuntu vs CentOS vs Win2k8 vs Debian: производительность PostgreSQL Промо

Статистика базы данных Производительность и оптимизация (HighLoad) v8 Бесплатно (free)

Хотя интернет уже переполнен статьями о "правильной" настройке связки PostgreSQL и 1C 8.2, для подводных камней всегда остается место. При сравнении производительности СУБД PostgreSQL на разных ОС, показатели различаются в разы. Самую большую обиду принесла любимая Ubuntu (человечность). После долгих дней и ночей проведенных за консолью этой ОС, она разочаровала окончательно. Тормоза PostgreSQL в Ubuntu Server. Что с ними делать? Сколько раз можно наступать на грабли?

03.11.2012    44958    madmpro    32    

Многопоточность

Практика программирования Производительность и оптимизация (HighLoad) v8 Бесплатно (free)

Увеличиваем скорость загрузки данных в 20 раз. Как следует использовать многопоточность и готовый модуль для внедрения.

18.03.2020    7983    kaliuzhnyi    44    

Планы запросов - это просто! Разбор оптимизаций запросов PostgreSQL на живых примерах

Производительность и оптимизация (HighLoad) v8::Запросы Бесплатно (free)

Проблема быстродействия 1С напрямую зависит от производительности запросов. Но как понять механику работы СУБД с помощью плана запроса? Андрей Овсянкин и Никита Грызлов на конференции Infostart Event 2019 Inception подробно рассмотрели алгоритм работы с планом запроса СУБД PostgreSQL, полученным из технологического журнала, и рассказали, на что обратить внимание, чтобы оптимизировать работу системы.

17.02.2020    12055    Evil Beaver    13    

Оптимизатор запросов. Вторая часть

Производительность и оптимизация (HighLoad) v8 Бесплатно (free)

Продолжение статьи об оптимизаторе запросов. Во второй части мы попробуем создать свой оптимизатор и попутно разберемся с такими вопросами, как: хранение файлов; индексы; статистика.

23.01.2020    6982    darkdan77    59    

Улучшаем производительность 1С. Рекомендации

Производительность и оптимизация (HighLoad) v8 1cv8.cf Россия Бесплатно (free)

Каждый уважаемый разработчик 1С сталкивался или столкнется с вопросом производительности высоконагруженных систем. В статье агрегирован основной набор рекомендаций, который позволит повысить производительность системы. Эти рекомендации должны быть просто must have по определению.

23.01.2020    9134    Kaval88    26    

Мониторим производительность с помощью 1С RAS

Инструментарий разработчика Производительность и оптимизация (HighLoad) v8 1cv8.cf Бесплатно (free)

Подключаемся и анализируем данные через 1С RAS. Необходимо выполнить 5 пунктов и серьезный инструмент мониторинга будет у вас в руках.

19.12.2019    13614    ivanov660    20    

Весёлые картинки о работе Performance Monitor на Windows Server 2016 Std по мотивам расследования потери производительности на базе 1С

Производительность и оптимизация (HighLoad) v8 Бесплатно (free)

Данная публикация посвящена одной особенности Performance Monitor на Windows Server 2016 Std. Как понимать графики Performance Monitor на Windows Server 2016 Std при расследовании проблем в работе 1С.

22.10.2019    8255    EugeneSemyonov    11    

Обслуживание баз данных. Не так просто, как кажется

Производительность и оптимизация (HighLoad) Администрирование СУБД v8 1cv8.cf Бесплатно (free)

Считаете, что обслуживание индексов и статистик дело простое? Что ж, это не всегда так.

14.10.2019    19836    YPermitin    31    

Мониторинг высоконагруженной системы

Производительность и оптимизация (HighLoad) v8 Бесплатно (free)

Высоконагруженной системе (более 8000 клиентских сессий) мониторинг необходим. Про опыт использования инструментов для мониторинга – самописной системы информирования, написанной на C#, и конфигурации «Центр контроля качества» в связке с системой отображения данных Grafana, на конференции Infostart Event 2018 Education рассказал Олег Репников.

13.09.2019    9658    Repich    5    

Использование Zabbix для сбора информации о серверных вызовах и управляемых блокировках с сервера 1С Предприятия, работающего на платформе GNU/Linux

Администрирование данных 1С Zabbix v8 Бесплатно (free)

Описанные в данном опусе механизмы ни в коей мере не противопоставляются тому, что реализует КИП от 1С или какие-либо другие инструменты (решения)! Это всего лишь еще один взгляд на "проблему", который может быть полезен в некоторых ситуациях.

10.09.2019    20389    Sloth    30    

Хранение файлов - как уменьшить размер базы данных

Чистка базы Производительность и оптимизация (HighLoad) Практика программирования Разработка v8 Россия Бесплатно (free)

Хранение файлов в базе 1С можно оптимизировать для уменьшения размера хранимых данных.

09.09.2019    9400    2tvad    17    

Неочевидные проблемы производительности: важность системного подхода при анализе

Производительность и оптимизация (HighLoad) v8 Россия Бесплатно (free)

Часто программисты и 1С-ники сталкиваются с совершенно необъяснимыми на первый взгляд проблемами. Но это потому, что их внимание направлено только на один сегмент системы, а не на всю систему полностью. О том, почему нужно стараться смотреть на ситуацию комплексно, рассказал специалист по производительности компании SOFTPOINT Александр Денисов.

19.07.2019    9373    Филин    12    

Ловля блокировок на связке "Microsoft SQL server - 1С"

Производительность и оптимизация (HighLoad) v8 v8::blocking Бесплатно (free)

Материал относится к базам данных на связке «1С - MS SQL Server». Один из способов отлова блокировок в бд 1С . Переход к управляемым блокировкам через режим "Автоматический и управляемый".

16.07.2019    11231    fhqhelp    0    

Анти-оптимизация: как мы ускорили запрос в 4 раза, сделав его неоптимальным

Производительность и оптимизация (HighLoad) Практика программирования Решение задач на 1С:Специалист Разработка v8 Бесплатно (free)

В этой статье приведен пример неочевидной "оптимизации" запроса, которая противоречит всем правилам, описанным в книгах для подготовки к сертификации "1С:Эксперт по технологическим вопросам", а также преподаваемым на курсах подготовки экспертов.

02.07.2019    12001    igordynets    120    

Ускорение чтения правил обмена в УПП 1.3 в 20 раз!

Производительность и оптимизация (HighLoad) v8 1cv8.cf Бесплатно (free)

Способ оптимизации чтения правил обмена конвертации данных. Может понадобиться при большом размере правил и высокой периодичности обмена.

27.06.2019    10358    YPermitin    17    

Хотите снизить нагрузку на процессор сервера в 2 раза?

Производительность и оптимизация (HighLoad) v8 Бесплатно (free)

В статье рассмотрено влияние частого запуска регламентных заданий на процессор сервера 1С.

27.06.2019    10840    Дмитрий74Чел    6    

Непридуманные истории по оптимизации. История 1

Производительность и оптимизация (HighLoad) v8 1cv8.cf Россия Бесплатно (free)

Первая статья из планируемого цикла об оптимизации приложений на базе 1С. Без теории. Одна практика.

13.06.2019    13184    Repich    117    

Оптимизация: неэффективные запросы

Производительность и оптимизация (HighLoad) Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

В большинстве случаев основной причиной медленной работы системы при многопользовательском режиме работы является блокировка данных СУБД (говорим про клиент-серверную версию). Блокировка - это не есть хорошо или плохо, это жизненно необходимая вещь при построении прикладной логики работы системы. Но блокировки таблиц, записей могут быть как вполне законными, так и далеко не всегда оправданными в каждой конкретной ситуации. Одной из самых распространенных причин неоптимальной блокировки ресурсов является некорректное написание запросов.

13.06.2019    6144    slayer-ekb    10    

Многопоточное ускорение однопользовательских нагрузок в 1С + Microsoft SQL Server 2017

Практика программирования Производительность и оптимизация (HighLoad) v8 v8::Запросы Бесплатно (free)

Взаимодействие с Microsoft SQL Server нередко вызывает трудности у 1С-ников, а потому интересны любые моменты, связанные с его использованием. О своем опыте работы с новым SQL Server 2017 участникам конференции Infostart-2018 рассказал директор ООО «Аналитика софт» Дмитрий Дудин.

11.06.2019    27780    dmurk    146    

За 5 шагов добавляем мониторинг счетчиков производительности серверов MS SQL и 1С

Статистика базы данных Производительность и оптимизация (HighLoad) v8 Бесплатно (free)

Мы расскажем и покажем, как добавить данные счетчиков производительности серверов 1С и MS SQL в нашу базу мониторинга за 15 минут. Приведем список наиболее важных из них, опишем основные особенности.

28.05.2019    22382    ivanov660    11    

Не думать о секундах свысока...

Производительность и оптимизация (HighLoad) v8 1cv8.cf Бесплатно (free)

Несколько примеров оптимизации типовой конфигурации УТ11. Описанные приемы подходят для многих других конфигураций.

21.05.2019    8342    vasilev2015    21