Динамическая расшифровка СКД (на примере отчета)

Публикация № 1307527 08.12.20

Разработка - Практика программирования

Универсальная расшифровка отчета динамическое заполнение параметров макета СКД унифицированная обработка расшифровки

Предлагаю Вашему неподкупному вниманию вариант более-менее унифицированной реализации динамически формирующейся расшифровки СКД на примере простейшего отчета для конфигурации УТ 11.

Особенность данной реализации состоит в том, чтобы при формировании отчета по структуре получаемых настроек компоновщика динамически добавлялись соответствующие параметры расшифровки в определенные области макета полей СКД по которым и нужна расшифровка. И уже потом, в обработчике расшифровки табличного документа без особых усилий из расшифровываемого поля вытаскиваются все необходимые данные для формирования отбора отчета расшифровки, который откроется в новом окне. Такой приёмчик особенно сгодится для расшифровки показателей детальных записей.

А теперь, немножко поподробнее. Отчет для примера был написан на платформе 8.3.16.1063 в конфигурации Управление торговлей (11.4.11.106). В схеме компоновки данных примера добавлены два набора данных: "Продажи" и "Поступления" (тексты запросов из примера, если кому вдруг станет интересно, находятся в самом конце).

На вкладке Макеты, добавлены макеты соответствующих полей, в данном случае это Количество, Сумма и КоличествоПоступления. Заполненные области для них показаны на скрине:

Далее, в процедуре ПриКомпоновкеРезультата() перед компоновкой макета эти расшифровки областей макетов полей соответствущим образом дозаполняются, и вот тут-то и происходит основное волшебство! Заполнять их можно чем Душе угодно! Но в данном случае из структуры настроек с помощью процедуры ДобавитьПолеВРасшифровку() поля группировок и выбранных полей кроме исключаемых превращаются, абра-кадабра, в параметры расшифровок областей макетов полей, и, чтобы фокус до конца удался, сим-салабим, в вычисляемые поля, благо недоступные из пользовательского режима. Таким образом, после выполнения отчета, значения выражений вычисляемых полей появляются в значениях параметров полей данных расшифровки, которые и используются в событии обработки расшифровки табличного документа для создания настроек отчета расшифровки различной сложности.

Вот и я вновь не поскупился, и для увлекательности примера добавил в отчет ещё одну СКД "Расшифровка по документам" и разместил её во вложенных схемах. На самом деле, в данном случае, это не важно где находится СКД, можно было и нативно поместить, в макеты отчета рядом с основным СКД.

Итак, дабы не прослыть жадинкой и не желая быть голословным, ниже оставлю код из модуля объекта отчета:

Процедура ПриКомпоновкеРезультата(ДокументРезультат, ДанныеРасшифровки, СтандартнаяОбработка)
	
	СтандартнаяОбработка = Ложь;
	
	Настройки = КомпоновщикНастроек.ПолучитьНастройки();
	
	// ДОБАВЛЕНИЕ ПОЛЕЙ ДЛЯ РАСШИФРОВКИ ПО ДОКУМЕНТАМ - Количество
	ИмяПоляМакета = "Количество";
	ДобавитьПолеВРасшифровку(ИмяПоляМакета, "ПараметрыДанных.ПоДокументамПродаж", "Истина", "Истина");
	ДобавитьПолеВРасшифровку(ИмяПоляМакета, "ЭтоГруппировка", , "Ложь", "Истина");
	ДобавитьИзСтруктурыНастроекПоляДляРасшифровки(ИмяПоляМакета, Настройки, "КоличествоПоступления");
	
	// ДОБАВЛЕНИЕ ПОЛЕЙ ДЛЯ РАСШИФРОВКИ ПО ДОКУМЕНТАМ - Сумма
	ИмяПоляМакета = "Сумма";
	ДобавитьПолеВРасшифровку(ИмяПоляМакета, "ПараметрыДанных.ПоДокументамПродаж", "Истина", "Истина");
	ДобавитьПолеВРасшифровку(ИмяПоляМакета, "ЭтоГруппировка", , "Ложь", "Истина");
	ДобавитьИзСтруктурыНастроекПоляДляРасшифровки(ИмяПоляМакета, Настройки, "КоличествоПоступления");
		
	// ДОБАВЛЕНИЕ ПОЛЕЙ ДЛЯ РАСШИФРОВКИ ПО ДОКУМЕНТАМ - КоличествоПоступления (есть только в варианте "Кросс-отчет")
	Если Настройки.ДополнительныеСвойства.Свойство("КлючТекущегоВарианта")
	И Настройки.ДополнительныеСвойства.КлючТекущегоВарианта = "КроссОтчет" Тогда
		ИмяПоляМакета = "КоличествоПоступления";
		ДобавитьПолеВРасшифровку(ИмяПоляМакета, "ПараметрыДанных.ПоДокументамПоступлений", "Истина", "Истина");
		ДобавитьПолеВРасшифровку(ИмяПоляМакета, "ЭтоГруппировка", , "Ложь", "Истина");
		ДобавитьИзСтруктурыНастроекПоляДляРасшифровки(ИмяПоляМакета, Настройки, "Склад, Контрагент, КоличествоПоступления");
	КонецЕсли;
	
	КомпоновщикМакета = Новый КомпоновщикМакетаКомпоновкиДанных;
	МакетКомпоновки = КомпоновщикМакета.Выполнить(СхемаКомпоновкиДанных, Настройки, ДанныеРасшифровки);
	
	// Есть в СКД такая неявная загагулинка,
	// если вдруг будет наложен отбор в приемнике связи,
	// то система делает связь "Внутренняя" (ВНУТРЕННЕЕ СОЕДИНЕНИЕ)
	//Для Каждого Связь Из МакетКомпоновки.СвязиНаборовДанных Цикл
	//	Связь.ТипСвязи = ТипСвязиНаборовДанныхКомпоновкиДанных.Внешняя;
	//КонецЦикла;
	
	ПроцессорКомпоновки = Новый ПроцессорКомпоновкиДанных;
	ПроцессорКомпоновки.Инициализировать(МакетКомпоновки, , ДанныеРасшифровки, Истина);
	
	ДокументРезультат.Очистить();
	ПроцессорВывода = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
	ПроцессорВывода.УстановитьДокумент(ДокументРезультат);
	
	ПроцессорВывода.Вывести(ПроцессорКомпоновки);
	// ++ вывод построчно
	//ПроцессорВывода.НачатьВывод();
	//ЭлементРезультата = ПроцессорКомпоновки.Следующий();
	//Пока ЭлементРезультата <> Неопределено Цикл
	//	ПроцессорВывода.ВывестиЭлемент(ЭлементРезультата);
	//	ЭлементРезультата = ПроцессорКомпоновки.Следующий();
	//КонецЦикла;
	//ПроцессорВывода.ЗакончитьВывод();	
	// -- вывод построчно
	
	// Объединяет шапку с одинаковыми заголовками рядом
	ОбработатьЗаголовки(ДокументРезультат);
	
	// Чтобы можно было в дальнейшем из формы обращаться к именно той СКД по которой был сформирован отчет
	КомпоновщикНастроек.Настройки.ДополнительныеСвойства.Вставить("АдресСКД",
		ПоместитьВоВременноеХранилище(СхемаКомпоновкиДанных, Новый УникальныйИдентификатор));
	
КонецПроцедуры

Процедура ДобавитьИзСтруктурыНастроекПоляДляРасшифровки(ИмяПоляМакета, Структура, Знач ИсключаемыПоля = "")
	
	Если ТипЗнч(ИсключаемыПоля) = Тип("Строка") Тогда
		ИсключаемыПоля = Новый Структура(ИсключаемыПоля);
	КонецЕсли;
	
	Если ТипЗнч(Структура) = Тип("НастройкиКомпоновкиДанных")
	Или ТипЗнч(Структура) = Тип("ГруппировкаКомпоновкиДанных")
	Или ТипЗнч(Структура) = Тип("ГруппировкаТаблицыКомпоновкиДанных") Тогда
		Для Каждого ВыбранноеПоле Из Структура.Выбор.Элементы Цикл
			Если ВыбранноеПоле.Использование
			И ТипЗнч(ВыбранноеПоле) <> Тип("АвтоВыбранноеПолеКомпоновкиДанных")
			И ТипЗнч(ВыбранноеПоле) <> Тип("ГруппаВыбранныхПолейКомпоновкиДанных")
			// ++ Если вдруг нужно будет ресурс добавить в отбор для расшифровки, то тут комментируем
			И СхемаКомпоновкиДанных.ПоляИтога.Найти(Строка(ВыбранноеПоле.Поле)) = Неопределено
			// -- и в ИсключаемыеПоля добавляем вручную по каждому случаю
			И Не ИсключаемыПоля.Свойство(Строка(ВыбранноеПоле.Поле)) Тогда
				ДобавитьПолеВРасшифровку(ИмяПоляМакета, Строка(ВыбранноеПоле.Поле));
			КонецЕсли;
		КонецЦикла;
		ДобавитьИзСтруктурыНастроекПоляДляРасшифровки(ИмяПоляМакета, Структура.Структура, ИсключаемыПоля);
	Иначе
		Для Каждого ЭлСтруктуры Из Структура Цикл
			Если ТипЗнч(ЭлСтруктуры) = Тип("ТаблицаКомпоновкиДанных") Тогда
				ДобавитьИзСтруктурыНастроекПоляДляРасшифровки(ИмяПоляМакета, ЭлСтруктуры.Строки, ИсключаемыПоля);
				ДобавитьИзСтруктурыНастроекПоляДляРасшифровки(ИмяПоляМакета, ЭлСтруктуры.Колонки, ИсключаемыПоля);
			Иначе
				Для Каждого ПолеГруппировки Из ЭлСтруктуры.ПоляГруппировки.Элементы Цикл
					Если ПолеГруппировки.Использование
					// ++ Если вдруг нужно будет ресурс добавить в отбор для расшифровки, то тут комментируем
					И СхемаКомпоновкиДанных.ПоляИтога.Найти(Строка(ПолеГруппировки.Поле)) = Неопределено
					// -- и в ИсключаемыеПоля добавляем вручную по каждому случаю
					И Не ИсключаемыПоля.Свойство(Строка(ПолеГруппировки.Поле)) Тогда
						ДобавитьПолеВРасшифровку(ИмяПоляМакета, Строка(ПолеГруппировки.Поле));
					КонецЕсли;
				КонецЦикла;
				ДобавитьИзСтруктурыНастроекПоляДляРасшифровки(ИмяПоляМакета, ЭлСтруктуры, ИсключаемыПоля);
			КонецЕсли;
		КонецЦикла;
	КонецЕсли;

КонецПроцедуры

Процедура ДобавитьПолеВРасшифровку(ИмяПоляМакета, ИмяПоля, ВыражениеПоляРасшифровки = "", ВыражениеПоля = "", ВыражениеИтога = "", ТипЗначенияПоля = "")
	
	МакетПоля = СхемаКомпоновкиДанных.МакетыПолей.Найти(ИмяПоляМакета);
	Если МакетПоля <> Неопределено Тогда
		Макет = СхемаКомпоновкиДанных.Макеты.Найти(МакетПоля.Макет);
		ПараметрыРасшифровки = Макет.Параметры.Найти("Расшифровка");
		Если ПараметрыРасшифровки <> Неопределено Тогда
			ИмяПоляРасшифровки = "р"+ИмяПоля;
			Если СхемаКомпоновкиДанных.ВычисляемыеПоля.Найти(ИмяПоляРасшифровки) = Неопределено Тогда
				НовоеПоле = СхемаКомпоновкиДанных.ВычисляемыеПоля.Добавить();
				НовоеПоле.ПутьКДанным = ИмяПоляРасшифровки;
				НовоеПоле.Выражение = ?(ПустаяСтрока(ВыражениеПоля), ИмяПоля, ВыражениеПоля);
				НовоеПоле.ТипЗначения = Новый ОписаниеТипов(ТипЗначенияПоля);
				НовоеПоле.ОграничениеИспользования.Группировка = Ложь;
				НовоеПоле.ОграничениеИспользования.Поле = Ложь;
				НовоеПоле.ОграничениеИспользования.Порядок = Ложь;
				НовоеПоле.ОграничениеИспользования.Условие = Ложь;
				НовоеПоле = СхемаКомпоновкиДанных.ПоляИтога.Добавить();
				НовоеПоле.ПутьКДанным = ИмяПоляРасшифровки;
				НовоеПоле.Выражение = ?(ПустаяСтрока(ВыражениеИтога), "Неопределено", ВыражениеИтога);
			КонецЕсли;
			Если ПараметрыРасшифровки.ВыраженияПолей.Найти(ИмяПоляРасшифровки) = Неопределено Тогда
				Параметр = ПараметрыРасшифровки.ВыраженияПолей.Добавить();
				Параметр.Поле = ИмяПоляРасшифровки;
				Параметр.Выражение = ?(ПустаяСтрока(ВыражениеПоляРасшифровки), ИмяПоляРасшифровки, ВыражениеПоляРасшифровки);
				// Если указано ВыражениеПоляРасшифровки, то в обработке расшифровки как в случае с Детальными записями
				// так и с Группировкой всегда будет доступно одинаковое значение этого выражения
			КонецЕсли;			
		КонецЕсли;
	КонецЕсли;
	
КонецПроцедуры

Ладушки, так уж и быть, уболтали ;) ловите заодно и код из модуля формы отчета:

#Область ОбработчикиСобытийФормы

&НаСервере
Процедура ПриЗагрузкеВариантаНаСервере(Настройки)
	
	Отчет.КомпоновщикНастроек.Настройки.ДополнительныеСвойства.Вставить("КлючТекущегоВарианта", КлючТекущегоВарианта);
	
	// Настройки по-умолчанию
	Если КлючТекущегоВарианта = "Основной" Тогда
				
	ИначеЕсли КлючТекущегоВарианта = "КроссОтчет" Тогда
				
	КонецЕсли;	
	
КонецПроцедуры

#КонецОбласти

#Область ОбработчикиСобытийЭлементовФормы

&НаКлиенте
Процедура РезультатОбработкаРасшифровки(Элемент, Расшифровка, СтандартнаяОбработка)
	
	Перем ВыбранноеДействие;
	Перем ПараметрыВыбранногоДействия;
	
	СтандартнаяОбработка = Ложь;
	
	ОбработкаРасшифровки =  Новый ОбработкаРасшифровкиКомпоновкиДанных(АдресДанныхРасшифровки, Новый ИсточникДоступныхНастроекКомпоновкиДанных(Отчет));
	
	ДоступныеДействия = Новый Массив;
	ДоступныеДействия.Добавить(ДействиеОбработкиРасшифровкиКомпоновкиДанных.ОткрытьЗначение);
	ДоступныеДействия.Добавить(ДействиеОбработкиРасшифровкиКомпоновкиДанных.Расшифровать);
	ДополнительныеПунктыМеню = Новый СписокЗначений;
	ДополнительныеПунктыМеню.Добавить("РасшифроватьПоДокументам", "Расшифровать по документам");
	
	ОписаниеОповещения = Новый ОписаниеОповещения("ОбработкаВыбораДействияРасшифровки", ЭтотОбъект, Расшифровка);
	ОбработкаРасшифровки.ПоказатьВыборДействия(ОписаниеОповещения, Расшифровка, ДоступныеДействия, ДополнительныеПунктыМеню, Истина);
	
КонецПроцедуры

&НаКлиенте
Процедура ОбработкаВыбораДействияРасшифровки(ВыбранноеДействие, ПараметрыВыбранногоДействия, Расшифровка) Экспорт
	
	Если ВыбранноеДействие <> ДействиеОбработкиРасшифровкиКомпоновкиДанных.Нет Тогда
		
		Если ВыбранноеДействие = ДействиеОбработкиРасшифровкиКомпоновкиДанных.ОткрытьЗначение Тогда
			ПоказатьЗначение(, ПараметрыВыбранногоДействия);
		ИначеЕсли ВыбранноеДействие = ДействиеОбработкиРасшифровкиКомпоновкиДанных.Расшифровать Или ВыбранноеДействие = "РасшифроватьПоДокументам" Тогда
			Если ВыбранноеДействие = "РасшифроватьПоДокументам" Тогда
				ПараметрыФормы = ОбработатьРасшифровкуПоДокументамИПолучитьПараметрыДляОткрытияФормыРасшифровки(Расшифровка);
			Иначе // аналог платформенной обработки расшифровки, как если бы СтандартнаяОбработка = Истина;
				ПараметрыФормы = ОбработатьРасшифровкуИПолучитьПараметрыДляОткрытияФормыРасшифровки(Расшифровка, ПараметрыВыбранногоДействия);
			КонецЕсли;			
			ОткрытьФорму("ВнешнийОтчет.Продажи_ПримерДинамическойРасшифровкиСКД.Форма.ФормаРасшифровки", ПараметрыФормы, ВладелецФормы, Новый УникальныйИдентификатор);
		КонецЕсли;
		
	КонецЕсли;
	
КонецПроцедуры

#КонецОбласти

#Область СлужебныеПроцедурыИФункции

&НаСервере
Функция ОбработатьРасшифровкуИПолучитьПараметрыДляОткрытияФормыРасшифровки(Расшифровка, НастройкиРасшифровки)
			
	ДанныеРасшифровки = ПолучитьИзВременногоХранилища(АдресДанныхРасшифровки);
	
	Если Отчет.КомпоновщикНастроек.Настройки.ДополнительныеСвойства.Свойство("АдресСКД") Тогда
		// СКД из ПриКомпоновкеРезультата()
		АдресСКДРасшифровки = Отчет.КомпоновщикНастроек.Настройки.ДополнительныеСвойства.АдресСКД;
	КонецЕсли;
	
	Если Не ЗначениеЗаполнено(АдресСКДРасшифровки) Тогда
		ОтчетОбъект = РеквизитФормыВЗначение("Отчет");
		СхемаКомпоновкиДанных = ОтчетОбъект.ПолучитьМакет("ОсновнаяСхемаКомпоновкиДанных");
		АдресСКДРасшифровки = ПоместитьВоВременноеХранилище(СхемаКомпоновкиДанных, УникальныйИдентификатор);
	Иначе
		СхемаКомпоновкиДанных = ПолучитьИзВременногоХранилища(АдресСКДРасшифровки);	
	КонецЕсли;
	
	НастройкиОтчета = Отчет.КомпоновщикНастроек.ПолучитьНастройки();
		
	// Вывод поля группировки
	ЭлементГруппировки = НастройкиРасшифровки.Структура[0];
	ВыбранноеПоле = ЭлементГруппировки.Выбор.Элементы.Добавить(Тип("ВыбранноеПолеКомпоновкиДанных"));
	ВыбранноеПоле.Поле = ЭлементГруппировки.ПоляГруппировки.Элементы[0].Поле;
	
	// Вывод поля показателя
	ЭлементРасшифровки = ДанныеРасшифровки.Элементы.Получить(Расшифровка);
	ВыбранноеПоле = ЭлементГруппировки.Выбор.Элементы.Добавить(Тип("ВыбранноеПолеКомпоновкиДанных"));
	ВыбранноеПоле.Поле = Новый ПолеКомпоновкиДанных(ЭлементРасшифровки.ПолучитьПоля()[0].Поле);
	
	// Параметры
	ЗаполнитьЭлементыНастроек(НастройкиРасшифровки.ПараметрыДанных, НастройкиОтчета.ПараметрыДанных);
	
	// Отбор общий
	СкопироватьЭлементыНастроек(НастройкиРасшифровки.Отбор, НастройкиОтчета.Отбор, Истина);
	
	// Отбор по группировке
	ПоляДляОтбораПоГруппировке = ПолучитьПоляДляОтбораПоГруппировке(ЭлементРасшифровки);
	Для Каждого ПолеДляОтбораПоГруппировке Из ПоляДляОтбораПоГруппировке Цикл
		ЗаполнитьЭлементОтбора(НастройкиРасшифровки.Отбор, ПолеДляОтбораПоГруппировке.Поле, ПолеДляОтбораПоГруппировке.Значение);
	КонецЦикла;
		
	ПараметрыФормы = СформироватьРезультатИПолучитьПараметрыДляОткрытияФормыРасшифровки(СхемаКомпоновкиДанных, НастройкиРасшифровки, УникальныйИдентификатор);
	ПараметрыФормы.Вставить("АдресСКД", АдресСКДРасшифровки);
	ПараметрыФормы.Вставить("Заголовок", "Расшифровка");
	
	Возврат ПараметрыФормы;
	
КонецФункции

&НаСервере
Функция ОбработатьРасшифровкуПоДокументамИПолучитьПараметрыДляОткрытияФормыРасшифровки(Расшифровка)	
	
	ДанныеРасшифровки = ПолучитьИзВременногоХранилища(АдресДанныхРасшифровки);
	
	Если Не ЗначениеЗаполнено(АдресСКДРасшифровкиПоДокументам) Тогда
		ОтчетОбъект = РеквизитФормыВЗначение("Отчет"); // СКД для расшифровки по документам находится во вложенных схемах
		СхемаКомпоновкиДанных = ОтчетОбъект.ПолучитьМакет("ОсновнаяСхемаКомпоновкиДанных").ВложенныеСхемыКомпоновкиДанных["РасшифровкаПоДокументам"].Схема;
		АдресСКДРасшифровкиПоДокументам = ПоместитьВоВременноеХранилище(СхемаКомпоновкиДанных, УникальныйИдентификатор);
	Иначе
		СхемаКомпоновкиДанных = ПолучитьИзВременногоХранилища(АдресСКДРасшифровкиПоДокументам);
	КонецЕсли;
	
	НастройкиОтчета = Отчет.КомпоновщикНастроек.ПолучитьНастройки();
	
	КомпоновщикНастроек = Новый КомпоновщикНастроекКомпоновкиДанных;
	ИсточникДоступныхНастроек = Новый ИсточникДоступныхНастроекКомпоновкиДанных(СхемаКомпоновкиДанных);
	КомпоновщикНастроек.Инициализировать(ИсточникДоступныхНастроек);
	КомпоновщикНастроек.ЗагрузитьНастройки(СхемаКомпоновкиДанных.НастройкиПоУмолчанию);
	НастройкиРасшифровки = КомпоновщикНастроек.ПолучитьНастройки();
	
	// Параметры
	ЗаполнитьЭлементыНастроек(НастройкиРасшифровки.ПараметрыДанных, НастройкиОтчета.ПараметрыДанных);
	
	// Отбор общий
	СкопироватьЭлементыНастроек(НастройкиРасшифровки.Отбор, НастройкиОтчета.Отбор, Истина);
	
	// Отбор по группировке с доп. расшифровкой
	ЭлементРасшифровки = ДанныеРасшифровки.Элементы.Получить(Расшифровка);
	ПоляДляОтбора = ЭлементРасшифровки.ПолучитьПоля();
	Для Каждого ПолеДляОтбора Из ПоляДляОтбора Цикл
		
		// Первым полем всегда должно идти поле по которому идет расшифровка (поле показателя)
		Если ПоляДляОтбора.Индекс(ПолеДляОтбора) = 0 Тогда
			Продолжить;
		КонецЕсли;
		
		Если СтрРазделить(ПолеДляОтбора.Поле,".")[0] = "рПараметрыДанных" Тогда
			ПраметрДанных = НастройкиРасшифровки.ПараметрыДанных.Элементы.Найти(СтрРазделить(ПолеДляОтбора.Поле,".")[1]);
			ПраметрДанных.Использование = Истина;
			ПраметрДанных.Значение = ПолеДляОтбора.Значение;
			Продолжить;
		КонецЕсли;
		
		Если ПолеДляОтбора.Поле = "рЭтоГруппировка" И Не ПолеДляОтбора.Значение Тогда
			Продолжить;
		ИначеЕсли ПолеДляОтбора.Поле = "рЭтоГруппировка" И ПолеДляОтбора.Значение Тогда
			ПоляДляОтбораПоГруппировке = ПолучитьПоляДляОтбораПоГруппировке(ЭлементРасшифровки);
			Для Каждого ПолеДляОтбораПоГруппировке Из ПоляДляОтбораПоГруппировке Цикл
				ЗаполнитьЭлементОтбора(НастройкиРасшифровки.Отбор, ПолеДляОтбораПоГруппировке.Поле, ПолеДляОтбораПоГруппировке.Значение);
			КонецЦикла;
			Прервать;
		КонецЕсли;
		
		ЗаполнитьЭлементОтбора(НастройкиРасшифровки.Отбор, Сред(ПолеДляОтбора.Поле, 2), ПолеДляОтбора.Значение);
		
	КонецЦикла;
	
	ПараметрыФормы = СформироватьРезультатИПолучитьПараметрыДляОткрытияФормыРасшифровки(СхемаКомпоновкиДанных, НастройкиРасшифровки, УникальныйИдентификатор);
	ПараметрыФормы.Вставить("АдресСКД", АдресСКДРасшифровкиПоДокументам);
	ПараметрыФормы.Вставить("Заголовок", "Расшифровка по документам");
	
	Возврат ПараметрыФормы;
	
КонецФункции

&НаСервереБезКонтекста
Функция СформироватьРезультатИПолучитьПараметрыДляОткрытияФормыРасшифровки(СхемаКомпоновкиДанных, НастройкиРасшифровки, УникальныйИдентификатор)
	
	ДанныеРасшифровки = Неопределено;
	
	КомпоновщикМакета = Новый КомпоновщикМакетаКомпоновкиДанных;
	МакетКомпоновки = КомпоновщикМакета.Выполнить(СхемаКомпоновкиДанных, НастройкиРасшифровки, ДанныеРасшифровки);
		
	ПроцессорКомпоновки = Новый ПроцессорКомпоновкиДанных;
	ПроцессорКомпоновки.Инициализировать(МакетКомпоновки, , ДанныеРасшифровки, Истина);
	
	Результат = Новый ТабличныйДокумент;
	ПроцессорВывода = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
	ПроцессорВывода.УстановитьДокумент(Результат);
	ПроцессорВывода.Вывести(ПроцессорКомпоновки);
	
	// ++ для отладки
	//РезультатТЗ = Новый ТаблицаЗначений;
	//ПроцессорВывода = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВКоллекциюЗначений;
	//ПроцессорВывода.УстановитьОбъект(РезультатТЗ);
	//ПроцессорВывода.Вывести(ПроцессорКомпоновки);
	// -- для отладки
	
	ПараметрыФормы = Новый Структура;
	ПараметрыФормы.Вставить("Результат", Результат);
	ПараметрыФормы.Вставить("АдресДанныхРасшифровки", ПоместитьВоВременноеХранилище(ДанныеРасшифровки, УникальныйИдентификатор));
	
	Возврат ПараметрыФормы;
	
КонецФункции

&НаСервереБезКонтекста
Функция ПолучитьПоляДляОтбораПоГруппировке(ЭлементРасшифровки, Результат = Неопределено)
	
	Если Результат = Неопределено Тогда
		Результат = Новый ("ЗначенияПолейРасшифровкиКомпоновкиДанных");
	КонецЕсли;
	
	РодителиЭлементаРасшифровки = ЭлементРасшифровки.ПолучитьРодителей();
	Если Не РодителиЭлементаРасшифровки.Количество() Тогда
		Возврат Результат;
	КонецЕсли;
	
	РодительЭлементаРасшифровки = РодителиЭлементаРасшифровки[0];
	Если ТипЗнч(РодительЭлементаРасшифровки) <> Тип("ЭлементРасшифровкиКомпоновкиДанныхГруппировка") Тогда
		Для Каждого ПолеДляОтбора Из РодительЭлементаРасшифровки.ПолучитьПоля() Цикл
			ЗаполнитьЗначенияСвойств(Результат.Добавить(), ПолеДляОтбора);
		КонецЦикла;
	КонецЕсли;
	
	Возврат ПолучитьПоляДляОтбораПоГруппировке(РодительЭлементаРасшифровки, Результат); 
	
КонецФункции

&НаСервереБезКонтекста
Процедура ЗаполнитьЭлементОтбора(Отбор, ИмяПоля, ЗначениеПоля, ДобавлятьЕслиНеНайден = Истина)
	
	ЕстьЭлементОтбора = Ложь;
	Для Каждого ЭлементОтбора Из Отбор.Элементы Цикл
		Если Строка(ЭлементОтбора.ЛевоеЗначение) = ИмяПоля Тогда
			ЭлементОтбора.Использование = ЗначениеПоля <> Неопределено; //ЗначениеЗаполнено(ЗначениеПоля);
			ЭлементОтбора.ПравоеЗначение = ЗначениеПоля;
			ЕстьЭлементОтбора = Истина;
			Прервать;
		КонецЕсли;
	КонецЦикла;
	Если Не ЕстьЭлементОтбора И ДобавлятьЕслиНеНайден Тогда
		ЭлементОтбора = Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
		ЭлементОтбора.Использование = ЗначениеПоля <> Неопределено;
		ЭлементОтбора.ЛевоеЗначение = Новый ПолеКомпоновкиДанных(ИмяПоля);
		ЭлементОтбора.ПравоеЗначение = ЗначениеПоля;
	КонецЕсли;
	
КонецПроцедуры

&НаСервере
Процедура СкопироватьЭлементыНастроек(ПриемникЗначения, ИсточникЗначения, ОчищатьПриемник = Ложь)
    
    Если ТипЗнч(ИсточникЗначения) = Тип("УсловноеОформлениеКомпоновкиДанных")
        ИЛИ ТипЗнч(ИсточникЗначения) = Тип("ВариантыПользовательскогоПоляВыборКомпоновкиДанных")
        ИЛИ ТипЗнч(ИсточникЗначения) = Тип("ОформляемыеПоляКомпоновкиДанных")
        ИЛИ ТипЗнч(ИсточникЗначения) = Тип("ЗначенияПараметровДанныхКомпоновкиДанных") Тогда
        СоздаватьПоТипу = Ложь;
    Иначе
        СоздаватьПоТипу = Истина;
    КонецЕсли;
    
    ПриемникЭлементов = ПриемникЗначения.Элементы;
    Если ОчищатьПриемник Тогда
        ПриемникЭлементов.Очистить();
    КонецЕсли;
    ИсточникЭлементов = ИсточникЗначения.Элементы;
    
    Для каждого ЭлементИсточник Из ИсточникЭлементов Цикл
        
        Если ТипЗнч(ЭлементИсточник) = Тип("ЭлементПорядкаКомпоновкиДанных") Тогда
            Индекс = ИсточникЭлементов.Индекс(ЭлементИсточник); // Элементы порядка добавляем в начало
            ЭлементПриемник = ПриемникЭлементов.Вставить(Индекс, ТипЗнч(ЭлементИсточник));
        Иначе
			Если СоздаватьПоТипу Тогда
                ЭлементПриемник = ПриемникЭлементов.Добавить(ТипЗнч(ЭлементИсточник));
            Иначе
                ЭлементПриемник = ПриемникЭлементов.Добавить();
			КонецЕсли;
			
        КонецЕсли;
        
        ЗаполнитьЗначенияСвойств(ЭлементПриемник, ЭлементИсточник);
        
        // В некоторых коллекциях необходимо заполнить другие коллекции

        Если ТипЗнч(ИсточникЭлементов) = Тип("КоллекцияЭлементовУсловногоОформленияКомпоновкиДанных") Тогда
            ЗаполнитьЭлементыНастроек(ЭлементПриемник.Поля, ЭлементИсточник.Поля);
            ЗаполнитьЭлементыНастроек(ЭлементПриемник.Отбор, ЭлементИсточник.Отбор);
            ЗаполнитьЭлементыНастроек(ЭлементПриемник.Оформление, ЭлементИсточник.Оформление); 
        ИначеЕсли ТипЗнч(ИсточникЭлементов) = Тип("КоллекцияВариантовПользовательскогоПоляВыборКомпоновкиДанных") Тогда
            ЗаполнитьЭлементыНастроек(ЭлементПриемник.Отбор, ЭлементИсточник.Отбор);
        КонецЕсли;
        
        // В некоторых элементах коллекции необходимо заполнить другие коллекции

        Если ТипЗнч(ЭлементИсточник) = Тип("ГруппаЭлементовОтбораКомпоновкиДанных") Тогда
            ЗаполнитьЭлементыНастроек(ЭлементПриемник, ЭлементИсточник);
        ИначеЕсли ТипЗнч(ЭлементИсточник) = Тип("ГруппаВыбранныхПолейКомпоновкиДанных") Тогда
            ЗаполнитьЭлементыНастроек(ЭлементПриемник, ЭлементИсточник);
        ИначеЕсли ТипЗнч(ЭлементИсточник) = Тип("ПользовательскоеПолеВыборКомпоновкиДанных") Тогда
            ЗаполнитьЭлементыНастроек(ЭлементПриемник.Варианты, ЭлементИсточник.Варианты);
        ИначеЕсли ТипЗнч(ЭлементИсточник) = Тип("ПользовательскоеПолеВыражениеКомпоновкиДанных") Тогда
            ЭлементПриемник.УстановитьВыражениеДетальныхЗаписей (ЭлементИсточник.ПолучитьВыражениеДетальныхЗаписей());
            ЭлементПриемник.УстановитьВыражениеИтоговыхЗаписей(ЭлементИсточник.ПолучитьВыражениеИтоговыхЗаписей());
            ЭлементПриемник.УстановитьПредставлениеВыраженияДетальныхЗаписей(ЭлементИсточник.ПолучитьПредставлениеВыраженияДетальныхЗаписей());
            ЭлементПриемник.УстановитьПредставлениеВыраженияИтоговыхЗаписей(ЭлементИсточник.ПолучитьПредставлениеВыраженияИтоговыхЗаписей());
        КонецЕсли;
        
    КонецЦикла;
    
КонецПроцедуры

&НаСервереБезКонтекста
Процедура ЗаполнитьЭлементыНастроек(ПриемникЗначения, ИсточникЗначения, ПервыйУровень = Неопределено) Экспорт
    
    Если ТипЗнч(ПриемникЗначения) = Тип("КоллекцияЗначенийПараметровКомпоновкиДанных") Тогда
        КоллекцияЗначений = ИсточникЗначения;
    Иначе
        КоллекцияЗначений = ИсточникЗначения.Элементы;
    КонецЕсли;
    
    Для каждого ЭлементИсточник Из КоллекцияЗначений Цикл
        Если ПервыйУровень = Неопределено Тогда
            ЭлементПриемник = ПриемникЗначения.НайтиЗначениеПараметра(ЭлементИсточник.Параметр);
        Иначе
            ЭлементПриемник = ПервыйУровень.НайтиЗначениеПараметра(ЭлементИсточник.Параметр);
        КонецЕсли;
        Если ЭлементПриемник = Неопределено Тогда
            Продолжить;
        КонецЕсли;
        ЗаполнитьЗначенияСвойств(ЭлементПриемник, ЭлементИсточник);
        Если ТипЗнч(ЭлементИсточник) = Тип("ЗначениеПараметраКомпоновкиДанных") Тогда
            Если ЭлементИсточник.ЗначенияВложенныхПараметров.Количество() <> 0 Тогда
                ЗаполнитьЭлементыНастроек(ЭлементПриемник.ЗначенияВложенныхПараметров, ЭлементИсточник.ЗначенияВложенныхПараметров, ПриемникЗначения);
            КонецЕсли;
        КонецЕсли;
    КонецЦикла;
    
КонецПроцедуры

#КонецОбласти

Даже модуль формы расшифровки для вас обнажу, я сегодня добрый:

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
	
	Если Параметры.Свойство("Заголовок") Тогда
		Заголовок = Параметры.Заголовок;
	КонецЕсли;
	
	Если Параметры.Свойство("Результат") Тогда
		Результат = Параметры.Результат;
	КонецЕсли;
	
	Если Параметры.Свойство("АдресСКД") Тогда
		АдресСКД = Параметры.АдресСКД;
	КонецЕсли;
	
	Если Параметры.Свойство("АдресДанныхРасшифровки") Тогда
		АдресДанныхРасшифровки = Параметры.АдресДанныхРасшифровки;
	КонецЕсли;
	
КонецПроцедуры

&НаКлиенте
Процедура РезультатОбработкаРасшифровки(Элемент, Расшифровка, СтандартнаяОбработка)
	
	Перем ВыбранноеДействие;
	Перем ПараметрыВыбранногоДействия;
	
	СтандартнаяОбработка = Ложь;
	
	ОбработкаРасшифровки = Новый ОбработкаРасшифровкиКомпоновкиДанных(АдресДанныхРасшифровки, Новый ИсточникДоступныхНастроекКомпоновкиДанных(АдресСКД));
	
	ДоступныеДействия = Новый Массив;
	ДоступныеДействия.Добавить(ДействиеОбработкиРасшифровкиКомпоновкиДанных.ОткрытьЗначение);
		
	ОбработкаРасшифровки.ВыбратьДействие(Расшифровка, ВыбранноеДействие, ПараметрыВыбранногоДействия, ДоступныеДействия, , Истина);
	
	Если ВыбранноеДействие = ДействиеОбработкиРасшифровкиКомпоновкиДанных.ОткрытьЗначение Тогда
		ОткрытьЗначение(ПараметрыВыбранногоДействия);
	КонецЕсли;
	
КонецПроцедуры

А в целом, внутренности формы отчета и формы расшифровки выглядят так:

Текст запроса набора данных "Продажи":

ВЫБРАТЬ
	Итоговая.Дата КАК Дата,
	Итоговая.Организация КАК Организация,
	Итоговая.Склад КАК Склад,
	Итоговая.Контрагент КАК Контрагент,
	Итоговая.Номенклатура КАК Номенклатура,
	Итоговая.Характеристика КАК Характеристика,
	СУММА(Итоговая.Количество) КАК Количество,
	СУММА(Итоговая.Сумма) КАК Сумма
ИЗ
	(ВЫБРАТЬ
		НАЧАЛОПЕРИОДА(Документы.Дата, ДЕНЬ) КАК Дата,
		Документы.Организация КАК Организация,
		Документы.Склад КАК Склад,
		Документы.Контрагент КАК Контрагент,
		ДокументыТовары.Номенклатура КАК Номенклатура,
		ДокументыТовары.Характеристика КАК Характеристика,
		СУММА(ДокументыТовары.Количество) КАК Количество,
		СУММА(ДокументыТовары.Сумма) КАК Сумма
	ИЗ
		Документ.РеализацияТоваровУслуг КАК Документы
			ВНУТРЕННЕЕ СОЕДИНЕНИЕ Документ.РеализацияТоваровУслуг.Товары КАК ДокументыТовары
			ПО Документы.Ссылка = ДокументыТовары.Ссылка
	ГДЕ
		Документы.Проведен
	{ГДЕ
		(Документы.Дата МЕЖДУ &ДатаНачала И &ДатаОкончания)}
	
	СГРУППИРОВАТЬ ПО
		НАЧАЛОПЕРИОДА(Документы.Дата, ДЕНЬ),
		Документы.Организация,
		Документы.Контрагент,
		ДокументыТовары.Номенклатура,
		ДокументыТовары.Характеристика,
		Документы.Склад
	
	ОБЪЕДИНИТЬ ВСЕ
	
	ВЫБРАТЬ
		НАЧАЛОПЕРИОДА(Документы.Дата, ДЕНЬ),
		Документы.Организация,
		Документы.Склад,
		"Розничный покупатель",
		ДокументыТовары.Номенклатура,
		ДокументыТовары.Характеристика,
		СУММА(ДокументыТовары.Количество),
		СУММА(ДокументыТовары.Сумма)
	ИЗ
		Документ.ОтчетОРозничныхПродажах КАК Документы
			ВНУТРЕННЕЕ СОЕДИНЕНИЕ Документ.ОтчетОРозничныхПродажах.Товары КАК ДокументыТовары
			ПО Документы.Ссылка = ДокументыТовары.Ссылка
	ГДЕ
		Документы.Проведен
	{ГДЕ
		(Документы.Дата МЕЖДУ &ДатаНачала И &ДатаОкончания)}
	
	СГРУППИРОВАТЬ ПО
		НАЧАЛОПЕРИОДА(Документы.Дата, ДЕНЬ),
		Документы.Организация,
		ДокументыТовары.Номенклатура,
		ДокументыТовары.Характеристика,
		Документы.Склад) КАК Итоговая

СГРУППИРОВАТЬ ПО
	Итоговая.Характеристика,
	Итоговая.Склад,
	Итоговая.Дата,
	Итоговая.Организация,
	Итоговая.Контрагент,
	Итоговая.Номенклатура

Текст запроса набора данных "Поступления":

ВЫБРАТЬ
	НАЧАЛОПЕРИОДА(Документы.Дата, ДЕНЬ) КАК Дата,
	Документы.Организация КАК Организация,
	ДокументыТовары.Номенклатура КАК Номенклатура,
	ДокументыТовары.Характеристика КАК Характеристика,
	СУММА(ДокументыТовары.Количество) КАК КоличествоПоступления
ИЗ
	Документ.ПриобретениеТоваровУслуг КАК Документы
		ВНУТРЕННЕЕ СОЕДИНЕНИЕ Документ.ПриобретениеТоваровУслуг.Товары КАК ДокументыТовары
		ПО Документы.Ссылка = ДокументыТовары.Ссылка
ГДЕ
	Документы.Проведен
{ГДЕ
	(Документы.Дата МЕЖДУ &ДатаНачала И &ДатаОкончания)}

СГРУППИРОВАТЬ ПО
	НАЧАЛОПЕРИОДА(Документы.Дата, ДЕНЬ),
	Документы.Организация,
	ДокументыТовары.Номенклатура,
	ДокументыТовары.Характеристика

Текст запроса набора данных в СКД "Расшифровка по документам":

ВЫБРАТЬ
	// ++ для отбора
	НАЧАЛОПЕРИОДА(Документы.Дата, ДЕНЬ) КАК Дата,
	Документы.Организация КАК Организация,
	Документы.Склад КАК Склад,
	Документы.Контрагент КАК Контрагент,
	ДокументыТовары.Номенклатура КАК Номенклатура,
	ДокументыТовары.Характеристика КАК Характеристика,
	// -- для отбора
	ДокументыТовары.Ссылка КАК Документ,
	ДокументыТовары.НомерСтроки КАК НомерСтроки,
	ДокументыТовары.Количество КАК Количество,
	ДокументыТовары.Сумма КАК Сумма
ИЗ
	Документ.РеализацияТоваровУслуг КАК Документы
		ВНУТРЕННЕЕ СОЕДИНЕНИЕ Документ.РеализацияТоваровУслуг.Товары КАК ДокументыТовары
		ПО Документы.Ссылка = ДокументыТовары.Ссылка
ГДЕ
	&ПоДокументамПродаж
	И Документы.Проведен
{ГДЕ
	(Документы.Дата МЕЖДУ &ДатаНачала И &ДатаОкончания)}

ОБЪЕДИНИТЬ ВСЕ

ВЫБРАТЬ
	// ++ для отбора
	НАЧАЛОПЕРИОДА(Документы.Дата, ДЕНЬ),
	Документы.Организация,
	Документы.Склад,
	"Розничный покупатель",
	ДокументыТовары.Номенклатура,
	ДокументыТовары.Характеристика,
	// -- для отбора
	ДокументыТовары.Ссылка,
	ДокументыТовары.НомерСтроки,
	ДокументыТовары.Количество,
	ДокументыТовары.Сумма
ИЗ
	Документ.ОтчетОРозничныхПродажах КАК Документы
		ВНУТРЕННЕЕ СОЕДИНЕНИЕ Документ.ОтчетОРозничныхПродажах.Товары КАК ДокументыТовары
		ПО Документы.Ссылка = ДокументыТовары.Ссылка
ГДЕ
	&ПоДокументамПродаж
	И Документы.Проведен
{ГДЕ
	(Документы.Дата МЕЖДУ &ДатаНачала И &ДатаОкончания)}

ОБЪЕДИНИТЬ ВСЕ

ВЫБРАТЬ
	// ++ для отбора
	НАЧАЛОПЕРИОДА(Документы.Дата, ДЕНЬ),
	Документы.Организация,
	null, // так отбор по складу будет игнорироваться
	null, // так отбор по контрагенту будет игнорироваться
	ДокументыТовары.Номенклатура,
	ДокументыТовары.Характеристика,
	// -- для отбора
	ДокументыТовары.Ссылка,
	ДокументыТовары.НомерСтроки,
	ДокументыТовары.Количество,
	ДокументыТовары.Сумма
ИЗ
	Документ.ПриобретениеТоваровУслуг КАК Документы
		ВНУТРЕННЕЕ СОЕДИНЕНИЕ Документ.ПриобретениеТоваровУслуг.Товары КАК ДокументыТовары
		ПО Документы.Ссылка = ДокументыТовары.Ссылка
ГДЕ
	&ПоДокументамПоступлений
	И Документы.Проведен
{ГДЕ
	(Документы.Дата МЕЖДУ &ДатаНачала И &ДатаОкончания)}

На этом пока всё! За лаконичность описания сильно не обижаемся. Надеюсь что-нибудь из представленного кому-нибудь пригодится.

Счастья, добра, любви, удачи и 1С! :)

 

Скачать файлы

Наименование Файл Версия Размер
Отчет по продажам (пример динамической расшифровки СКД)

.erf 24,29Kb
8
.erf 24,29Kb 8 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. ovasiliev 20 12.12.20 10:38 Сейчас в теме
".. код из общего модуля отчета"
казнить нельзя помиловать?
Не, я не то что вредничаю, у меня просто препроцессор сломался в этом месте при компиляции.
2. mr_sav 17 13.12.20 14:03 Сейчас в теме
(1) Благодарю за наводку. Не знаю почему я так странно ошибся в орфографии, но имелось ввиду модуль объекта)). Поправил.
Оставьте свое сообщение

См. также

Безопасная работа с транзакциями во встроенном языке Промо

Практика программирования v8 1cv8.cf Абонемент ($m)

Разбираемся с опасностями использования транзакций во встроенном языке 1С. Познаем ошибку "В данной транзакции уже происходили ошибки". Учимся защищаться от них.

1 стартмани

25.03.2019    45290    tormozit    58    

Пример создания документа с движениями в ERP 2.5.7

БСП (Библиотека стандартных подсистем) Практика программирования v8 ERP2 Россия УУ Абонемент ($m)

Пример создания документа с движениями в ERP 2.5.7, а также включение документа в основные подсистемы, а именно по управлению доступом, датам запрета изменения, контролю остатков, использованию характеристик и серий и прочее.

1 стартмани

10.08.2021    1908    maraty    10    

Работа с абстрактным массивом

Практика программирования Математика и алгоритмы v8 Россия Абонемент ($m)

Абстрактные типы данных и алгоритмы уверенно набирают популярность в языках общего назначения. Встроенный язык 1С является предметно-ориентированным и не спешит развиваться в сторону поддержки абстракций. Однако потребность в них существует, т.к. задачи, решаемые на платформе, не уступают разнообразию из других ЯП. Предлагаю рассмотреть вариант реализации абстрактного массива в 1С.

1 стартмани

07.07.2021    3687    kalyaka    56    

Семеро одного не ждут? Асинхронное исследование асинхронности

Практика программирования Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Все уже, наверное, знают о появлении в новых версиях платформы асинхронных функций и конструкций Асинх/Ждать. Многие, возможно, уже их используют. Но что будет, если создать свои асинхронные функции, запустить и не дожидаться окончания их выполнения? Неужели можно запустить несколько процессов параллельно?

1 стартмани

08.06.2021    5371    Alxby    45    

Как выполнить отчет на СКД через COM и получить данные отчета? Промо

Практика программирования v8 УПП1 Россия Абонемент ($m)

Для чего это нужно. Например, нужно в одной базе получить какой-либо показатель из другой базы. Этот показатель вычисляется в каком-либо сложном отчете, который написан на СКД. Можно, конечно, "скопипастить" текст запроса из другой базы, немного подправить его и выполнять в том же COM подключении. Но с этим теряется гибкость: если отчет изменился, то нужно помнить о том, что где-то есть его "немного модифицированная" копия. В статье будет рассмотрен пример получения данных из базы ЗУП.

2 стартмани

08.05.2018    31910    wowik    3    

СКД: все, что вы хотели знать о подмене схемы компоновки данных в отчетах и обработках

Практика программирования v8 v8::СКД 1cv8.cf Абонемент ($m)

Довольно часто на различных тематических форумах задается вопрос, можно ли использовать в отчете/обработке несколько схем компоновки данных, подменяя одну другой по мере надобности? При этом желательно, чтобы и пользовательские настройки при смене схемы менялись соответственно.

1 стартмани

07.12.2020    5051    user1502278    18    

Cбор и анализ ошибок при помощи Sentry, или как упростить жизнь себе и пользователям

Практика программирования Интеграция v8 Абонемент ($m)

Цель данной статьи - сделать процесс сбора и анализа ошибок, происходящих в базе, максимально простым, быстрым и удобным, собирать статистику по ошибкам, местам их возникновения и частоте их появления, а также в деталях разобрать все тонкости по интеграции 1С с Sentry.

1 стартмани

09.10.2020    7296    hexhoc    12    

Программная корректировка при выводе отчета СКД

Практика программирования v8 v8::СКД 1cv8.cf Абонемент ($m)

Большинство отчетов на СКД, требующих программной корректировки, реализуются с помощью программной настройки СКД или обработки табличного документа уже после вывода отчета. Но во многих случаях более оптимально будет выполнять программную корректировку в процессе вывода отчета. Для этого существуют программные объекты, о которых я расскажу в данной статье.

1 стартмани

08.10.2020    10702    dabu-dabu    16    

Как нарисовать граф на 1С Промо

Практика программирования v8 Абонемент ($m)

Описывается реализация на языке запросов 1С метода расположения вершин графа на плоскости, основанного на использовании электромеханической аналогии. При этом вершины графа представляются одноименными электрическими зарядами, дуги - пружинками. Силы взаимодействия вершин в этой системе переводят их из случайного начального в нужное конечное положение. Приведена обработка рисования графов "ГрафОграф", реализующая данный подход, показывающая также динамику процесса. Граф можно задать списком ребер вручную, выбрать из нескольких предопределенных примеров или сформировать по данным информационной базы.

1 стартмани

09.08.2013    73464    ildarovich    117    

Загрузка, скачивание, удаление файлов с помощью НачатьПомещениеФайлаНаСервер() и НачатьПолучениеФайлаССервера()

Практика программирования v8 1cv8.cf Абонемент ($m)

В платформе 8.3.15 появились новые методы НачатьПомещениеФайлаНаСервер() и НачатьПолучениеФайлаССервера(). В данной статье рассмотрено готовое решение проверенное и прекрасно работающее на тонком и веб-клиенте.

1 стартмани

25.07.2020    11529    Flashill    15    

Универсальная печатная форма Приказа/Договора с возможностью настройки макета в пользовательском режиме

Практика программирования Универсальные печатные формы v8 1cv8.cf Абонемент ($m)

В данной статье я опишу реализацию универсальной (в кавычках) печати Приказа (Договора или чего пожелаете) с возможностью настройки выводимого текста с параметрами из пользовательского режима. Обработка для скачивания написана для доработанной конфигурации клиента ЗУП версии 3.1.13.120. Перед внедрением в свою конфигурацию ее необходимо будет дорабатывать.

1 стартмани

24.06.2020    2418    BuriyLesha    3    

Методика обновления формы объекта данных при изменении объекта

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

В формах объектов данных часто встречаются элементы, косвенно связанные с объектом. Логику обновления этих элементов при изменении объекта обычно вызывают из обработчиков ПриСозданнииНаСервере и ПриОткрытии, забывая про наличие других способов изменения объекта. В статье предложена методика для обычных и управляемых форм, учитывающая все способы.

1 стартмани

09.03.2020    20078    tormozit    16    

Простой способ индексирования интервалов Промо

Практика программирования v8 Абонемент ($m)

Предлагается простой способ индексирования интервалов для решения задач выборки записей, включающих заданный момент времени, пересекающихся с заданным интервалом или множеством интервалов. Способ основан на добавлении к исходной таблице особого числового индексированного поля, рассчитываемого по специальной формуле. Приведен код функций, необходимых для расчетов поля поиска и параметров поисковых запросов. Приведены также результаты тестирования метода, доказывающие его высокую эффективность.

1 стартмани

28.09.2016    41987    ildarovich    22    

Отправка уведомлений с помощью командной строки, Оповещения с сервера на клиент с помощью командной строки

Практика программирования v8 1cv8.cf Россия Абонемент ($m)

Отправка уведомлений с помощью команды командной строки msg. Оповестить пользователей из серверного модуля или регламентного задания, с помощью командной строки msg.

1 стартмани

05.03.2020    8065    user5300    3    

Вывод сообщений в HTML поле средствами 1С

Практика программирования v8 v8::УФ Абонемент ($m)

Пример использования вывода большого количества сообщений в поле HTML. С возможностью открывать ссылочные объекты и создавать новые объекты передавая параметры прямо из HTML поля. Протестировано на релизах 8.3.12 и 8.3.15+

2 стартмани

31.01.2020    10585    burni4    16    

Краткое руководство по внесению изменений в конфигурацию

Практика программирования v8 1cv8.cf Абонемент ($m)

Кратко описаны основополагающие моменты при старте групповой разработки конфигурации несколькими программистами. Полезно для проектной документации как требование к разработчикам или сопровождающей компании.

1 стартмани

13.01.2020    22642    sapervodichka    41    

Бесплатная проверка контрагентов в ФНС (общий модуль с алгоритмом). На примере выводим статус в список справочника контрагентов Промо

Практика программирования v8 1cv8.cf Абонемент ($m)

Если вам интересно проверить контрагенте в ФНС, вам поможет данная публикация. Весь алгоритм работы строится на основе данных, полученных с сервиса http://npchk.nalog.ru совершенно бесплатно.

1 стартмани

01.02.2018    38270    rpgshnik    54    

Универсальные функции: разложение произвольной строки адреса в структуру

Практика программирования Универсальные функции v8 1cv8.cf Абонемент ($m)

Процедуры и функции раскладывают произвольную строку адрес в структуру по ключевым словам.

1 стартмани

30.12.2019    5894    vik070777    10    

"Живые" картинки со Snap.SVG

Практика программирования WEB Работа с интерфейсом v8 Абонемент ($m)

В статье рассмотрен пример использования http-сервисов для визуализации данных

1 стартмани

24.10.2019    15112    blackhole321    7    

RLS - дубли условий в запросах к СУБД

Практика программирования Роли и права v8 v8::Права 1cv8.cf Абонемент ($m)

"Подводные камни", возникающие при бездумном копировании ролей с ограничениями RLS, как это отражается на производительности, разбор примера и инструмент для анализа.

1 стартмани

07.10.2019    10031    geron4    4    

БСП: Дополнительная обработка (Регламенты), примеры от простого к сложному Промо

Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

Очень много попадается странных решений, которые можно решить через БСП:Дополнительные отчеты и обработки. Я бы вообще БСП из-за этой подсистемы переименовал в «Большое Спасибо Программистам». Поработаем с подсистемой в части написания регламентных заданий.

1 стартмани

10.05.2018    54003    dsdred    46    

Полное копирование одной формы в другую

Практика программирования Универсальные обработки Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Однажды я столкнулся с необходимостью открыть форму ЛЮБОГО документа с определенными изменениями, не зависящими от структуры объекта (например, заблокировать все кнопки). В интернете решения я не нашел. Обычно на форумах на запросы подобного рода отвечают чем-то вроде "покажи первоначальную задачу, а не спрашивай как реализовать то, что ты придумал". Тем не менее, мне стало интересно, как это можно сделать.

1 стартмани

03.10.2019    7944    nekit_rdx    25    

Многопоточная обработка данных на примере перепроведения документов

Обработка документов Практика программирования v8 ERP2 УТ11 КА2 Абонемент ($m)

Дальнейшее развитие темы фоновой обработки данных - проведение документов в потоках. Настройка параметров и запуск основного процесса (менеджера потоков). Разбивка документов для проведения на не связанные друг с другом наборы и запуск дополнительных фоновых заданий для отдельных потоков. Отслеживание выполнения каждого потока в родительском сеансе.

1 стартмани

17.09.2019    12751    ids79    46    

Отображение истории выполнения по всем задачам комплексного процесса в документообороте

Документооборот и делопроизводство Практика программирования v8 ДО УУ Абонемент ($m)

Коллеги, предлагаю вашему вниманию доработку для вывода полной истории в задачах комплексного процесса.

1 стартмани

15.09.2019    8758    pavelpribytkin96    8    

Некоторая работа с данными через COM Промо

Практика программирования v8 Абонемент ($m)

В статье приведены примеры работы с Платформой 8.X через COM (точнее, через объект COMConnector). Примеры кода были использованы при реализации прикладных задач в процессе трудовой деятельности.

2 стартмани

05.12.2012    59940    wowik    32    

Описание формата внутреннего представления данных 1С в контексте обмена данными

Практика программирования Внешние источники данных v8 v8::УФ 1cv8.cf Абонемент ($m)

Фирма 1С не рекомендует использовать внутреннее представление данных для любых целей, которые отличны от обмена с 1С:Предприятием 7.7. Но сама возможность заглянуть на "внутреннюю кухню" платформы с помощью функций ЗначениеВСтрокуВнутр(), ЗначениеВФайл(), ЗначениеИзСтрокиВнутр() и ЗначениеИзФайла(), дала возможность сообществу программистов 1С разработать новые приемы разработки и анализа. Так, именно на использовании внутреннего представления был построен алгоритм "быстрого массива", который позволяет практически мгновенно создать массив в памяти на основании строки с разделителями. С помощью разбора внутреннего представления можно "на лету" программным кодом выполнить анализ обычной формы и даже сделать редактор графической схемы. Во внутреннем формате сохраняют свои данные между сеансами различные популярные внешние обработки. А еще это возможность сделать быстрый обмен с внешними системами.

1 стартмани

06.09.2019    21738    Dementor    31    

Удобный просмотр результата запроса с большим количеством временных таблиц

Практика программирования v8 Абонемент ($m)

Если Вам часто приходится просматривать в отладчике сложные пакетные запросы с большим количеством временных таблиц, то эта статья для Вас.

1 стартмани

27.08.2019    12817    ids79    22    

Запуск фонового задания во внешней обработке. Отключение предупреждений защиты от опасных действий в фоновом задании

Практика программирования v8 1cv8.cf Абонемент ($m)

Как запустить фоновое задание из модуля внешней обработки используя БСП. Как отключить безопасный режим и сообщения защиты от опасных действий независимо от профиля безопасности пользователя в фоновом задании во внешней обработке.

2 стартмани

24.08.2019    16965    BenGunn    22    

Работа со схемой запроса Промо

Инструментарий разработчика Практика программирования v8 v8::Запросы Абонемент ($m)

Стандартом взаимодействия с реляционной базой данных стал язык SQL. Приемником SQL в 1С является язык запросов. Язык запросов, также как и SQL, является структурированным. Составляющие структуры запроса отвечают на разные вопросы о том, какие данные требуется получить и какие манипуляции с множествами данных необходимо произвести при получении. В простых случаях текст запроса можно написать вручную, однако в сложных случаях, а также при программном формировании, - лучше воспользоваться объектной моделью запроса и использовать объект "Схема запроса". В статье дается описание объектной модели и особенностей работы с ней, а также приводится решение, упрощающее взаимодействие с объектом "Схема запроса".

1 стартмани

24.04.2018    51934    kalyaka    41    

Изменяющееся контекстное меню в 1С 8.3

Практика программирования Работа с интерфейсом Разработка v8 v8::УФ Абонемент ($m)

В одной практической задаче мне пришлось разрабатывать контекстное меню таблицы управляемой формы, которое должно было меняться в зависимости от данных, находящихся в этой таблице. Ниже приведен мой способ решения этой задачи.

1 стартмани

06.08.2019    22337    signum2009    16    

Процедура ПриКомпоновкеРезультата

Практика программирования v8 1cv8.cf Абонемент ($m)

Коллекция кода

1 стартмани

26.07.2019    58491    vasilev2015    66    

10 способов получить модуль числа (а может, и больше)

Практика программирования Разработка v8 1cv8.cf Абонемент ($m)

Пишем функцию вычисления модуля числа. Сколько способов существует? Давайте посчитаем!

1 стартмани

11.07.2019    14314    sam441    33    

Многопоточность. Универсальный «Менеджер потоков» (фреймворк) с отслеживанием зависимости объектов Промо

Практика программирования Математика и алгоритмы Универсальные функции Производительность и оптимизация (HighLoad) v8 1cv8.cf Россия Абонемент ($m)

Восстановление партий, расчет зарплаты, пакетное формирование документов или отчетов - теперь все это стало доступнее. * Есть желание повысить скорость работы медленных алгоритмов! Но... * Нет времени думать о реализации многопоточности? * о запуске и остановке потоков? * о поддержании потоков в рабочем состоянии? * о передаче данных в потоки и как получить ответ из потока? * об организации последовательности? Тогда ЭТО - то что надо!!!

26.05.2017    51394    DarkAn    86    

Ловец дедлоков СУБД

Производительность и оптимизация (HighLoad) Практика программирования ЦУП v8 Россия Абонемент ($m)

Анализ простейшего дедлока СУБД в рабочей базе с использованием ЦУП (центра управления производительностью) и profiler MS SQL (Microsoft SQL Server). Эта статья будет полезна людям, изучающим вопросы оптимизации работы 1С, или тем, у кого возникают дедлоки в рабочей базе. UPD 09.07.2019 добавлено воспроизведение блокировки в случае установки управляемой блокировки перед чтением набора записей регистра сведений. UPD 10.07.2019 добавлена тестовая база с примером.

1 стартмани

08.07.2019    12635    azazana    80    

Многоуровневая нумерация в отчете СКД (программный вывод)

Практика программирования v8::СКД 1cv8.cf Абонемент ($m)

Реализация многоуровневой нумерации при программном выводе отчета СКД основываясь на его структуре.

1 стартмани

01.07.2019    7792    lmnlmn    7    

Мониторинг производительности и искусственный интеллект

Производительность и оптимизация (HighLoad) Практика программирования Искусственный интеллект (AI) v8 Абонемент ($m)

Расскажем и покажем практически, как использовать искусственный интеллект на страже мониторинга производительности. У вас появится возможность создать собственного помощника Ларису, которая возьмет на себя вопросы по контролю и диагностике состояния обслуживаемой системы.

1 стартмани

01.07.2019    10329    ivanov660    28    

Новый запрос и новая таблица значений как функции Промо

Практика программирования v8 Абонемент ($m)

Предлагается две простые функции, использование которых уменьшает объем кода в конфигурациях на платформе «1С:Предприятие 8». Эти функции можно добавлять к своему общему модулю, что сделает процесс программирования более эффективным.

1 стартмани

27.11.2012    46415    ildarovich    49    

"Убер на складе": динамический расчет маршрутов с учетом реальных расстояний

Учет ТМЦ Практика программирования Учет ТМЦ v8 УУ Абонемент ($m)

Представляю методику и инструмент для динамического расчета маршрутов отбора на высоконагруженных складах для максимального повышения эффективности склада, ускорения проходимости и, как следствие, экономии денег. Это методика и обработка для интеграции в WMS решения. Тестировалось на 1С 8.3.14.1565.

3 стартмани

24.06.2019    19517    informa1555    17    

1С:Ассемблер. Немного летнего веселья!

Практика программирования Разработка v8 1cv8.cf Абонемент ($m)

Все вы, наверное, слышали, что 1С-ники жалуются на свою систему, считая язык 1С недостаточно низкоуровневым, скучным и т.п. Все они с тоской поглядывают в сторону "настоящих" языков программирования. Так вот, господа, они неправы. В системе 1С есть места, где можно размять программерский мозг и получить удовольствие от низкоуровневой техники. Предлагаю вам погрузиться в недра виртуальной машины 1С и понять, как она работает. Там есть свой "ассемблер" и мы попробуем его в действии!

1 стартмани

21.06.2019    33966    Evil Beaver    145    

Простые примеры сложных отчетов на СКД

Практика программирования v8 v8::СКД 1cv8.cf Абонемент ($m)

Подписи в отчете. Особенности соединения наборов: как соединить несоединяемое. Остатки на дату и обороты по месяцам в одном отчете. Курс валюты на каждую дату без группировок и соединений в запросе. Отчет с произвольными колонками и с произвольной последовательностью. "Неадекватный отчет".

1 стартмани

12.06.2019    36690    Hatson    32    

Уровни, глубина, прародители, циклы и аналоги запросом Промо

Практика программирования v8 1cv8.cf Абонемент ($m)

В продолжение публикации «Транзитивное замыкание запросом» [http://infostart.ru/public/158512/] добавлены другие варианты использования того же приема. Приведены запросы для быстрого определения уровней всех элементов справочника, максимальной глубины справочника, прародителей произвольных элементов справочника, запрос для быстрого определения циклов (на примере справочника спецификаций «1С:Управление производственным предприятием») и определения множеств аналогов номенклатуры (также на примере конфигурации «1С:Управление производственным предприятием»).

1 стартмани

13.11.2012    120096    ildarovich    102    

Создание внешней печатной формы в формате документа Word

Практика программирования Разработка v8 1cv8.cf Абонемент ($m)

В статье написано, как создать внешнюю печатную форму (для конфигураций с БСП) в формате Word.

1 стартмани

17.05.2019    23976    ВикторП    22    

Поле адреса в своем справочнике на примере 1С:Бухгалтерия 3

Практика программирования Разработка v8 v8::БУ БП3.0 Россия Абонемент ($m)

В публикации описано, как добавить поле адреса в свой справочник, чтобы вводить адрес через адресный классификатор.

1 стартмани

17.05.2019    8348    vasilievil    5    

Пример настройки шаблонов и реализации печати отчетов в документ MS Word используя функциональную часть "Библиотеки Стандартных Подсистем 1С" (БСП)

Практика программирования Разработка v8 Россия Абонемент ($m)

В конфигурации выбраны и использованы только необходимые объекты библиотеки стандартных подсистем для реализации вывода отчёта, с табличными частями, в документ MS Word. Показан пример создания необходимых областей в шаблоне для вывода параметров в отчёт.

1 стартмани

23.04.2019    8822    olegpkc    11    

Неоплаченные долги при распределении оплаты по правилу ФИФО одним запросом и намного быстрее, чем Вы думали Промо

Практика программирования Дебиторская и кредиторская задолженность Дебиторская и кредиторская задолженность v8 v8::СКД КА1 УТ10 УПП1 УУ Абонемент ($m)

Предлагается метод для быстрого нахождения неоплаченных долгов при распределении оплаты по правилу ФИФО, основанный на дихотомии. Описывается реализация метода в виде достаточно простого запроса, решающего за линейное время указанную задачу, считавшуюся ранее существенно более трудоемкой. Приводятся примеры использования запроса в отчетах на СКД для конфигураций УТ, КА, УПП.

1 стартмани

28.02.2014    70998    ildarovich    131    

Ops средствами 1С:Предприятие

Практика программирования Разработка v8 1cv8.cf Абонемент ($m)

В статье описан программный пакет "Автоматизация ИТ-процессов" (АИТП), позволяющий автоматизировать задачи по администрированию, управлению и обслуживанию ИТ-инфраструктуры.

1 стартмани

23.04.2019    18639    blackhole321    28    

1C + Python + Django Rest Framework + Vue.js. Опыт несложной full-stack разработки

Практика программирования Внешние источники данных Обмен через XML WEB Разработка v8 1cv8.cf Абонемент ($m)

В этой статье мы рассмотрим путь и основные моменты создания небольшого вэб-сервиса, который мы называем "Онлайн Прайс-лист". Выгрузка из 1С, бэкенд, фронтенд, получение заказов в 1С.

1 стартмани

22.04.2019    40920    riposte    69    

Вывод вариантов СКД в таблицы на управляемой форме

Практика программирования Работа с интерфейсом v8 v8::УФ v8::СКД 1cv8.cf Абонемент ($m)

Задача стояла такая: есть 2 различных запроса, результаты которых выгружаются на форму обработки в таблицы значений (далее ТЗ) и программно "соприкасаются" между собой определенным образом (как именно- в рамках данной статьи неважно). Нюанс в том, что запросы должны иметь свой компоновщик настроек и могут интерактивно на форме изменяться пользователем. На оригинальность публикации не претендую - изначально в рамках поставленной задачи пытался найти что-то подобное (уже готовый шаблон) на инфостарте, возможно "плохо искал" ;)

05.04.2019    13201    artkor    1    

Транзитивное замыкание запросом Промо

Практика программирования v8 1cv8.cf Абонемент ($m)

В частности, показывается, как одним пакетным запросом найти ВСЕХ предков (потомков) в иерархическом справочнике. Аналогично можно определять входимость деталей в узлы и готовые изделия по их спецификациям, определять подмножества аналогичных запчастей по цепочке аналогов, решать другие подобные задачи. Приложен файл с примером отчета для замыкания иерархии произвольного справочника, позволяющий протестировать быстродействие запроса в разных условиях.

1 стартмани

29.10.2012    92272    ildarovich    121    

[EnterpriseData] Антисвертка характеристик номенклатуры при выгрузке в Бухгалтерию

Практика программирования Перенос данных из 1C8 в 1C8 Разработка v8 v8::ПВХ КД УНФ БП3.0 Россия БУ Абонемент ($m)

Рассмотрена выгрузка каждой пары значений Номенклатура - Характерстика из УНФ 1.6 в отдельную номенклатуру в Бухгалтерию 3.0 путём доработки правил обмена в формате EnterpriseData.

1 стартмани

27.03.2019    5959    nforce    6    

Интеграция 1С и SharePoint

Практика программирования Разработка v8 УНФ ДО ERP2 БП3.0 УТ11 УХ КА2 Россия Абонемент ($m)

Заказчики поставили задачу автоматизации согласования заявок на оплату в программе 1С:Бухгалтерия предприятия 3.0. Согласно ТЗ, данные должны подтягиваться из действующей электронной системы документаоборота на MS SharePoint (в дальнейшем СЭД MS SP).

1 стартмани

22.03.2019    7078    -I-    5    

Пример использования СКД и данных расшифровки на мобильной платформе

Практика программирования Разработка v8 v8::Mobile v8::СКД 1cv8.cf Россия Абонемент ($m)

СКД в мобильном приложении и меню действий на основе данных расшифровки (отчет, совместимый с мобильной платформой 8.3.13.45).

1 стартмани

12.03.2019    6205    majoram    0