Программное условное оформление динамического списка, раскраска строк списка по цветам справочника или любым другим условиям (условное оформление)

Публикация № 1335442 30.11.20

Разработка - Практика программирования

Большое количество динамических списков на форме, большое количество условий, долгое интерактивное добавление условий, оформление по значению элементов справочников - всё это не позволяет использовать интерактивный режим назначения условного оформления динамического списка. В публикации с открытым кодом детально разберем программное решение назначения условного оформления, создадим универсальную функцию для оформления списка.

В интерфейсе Такси (Управляемые формы) системы Кронос: WMS на 1С во многих местах требовалось различное оформление динамических списков, поэтому мы решили для себя создать универсальную функцию по работе с ними. 

Например, цвет раскраски строк списка заявок на хранение (входящих поставок) настраивается в каждой складской операции:

 

 

Внешний вид списка при этом выглядит следующим образом:

 

 

Итак, приступим.

Для начала придумаем имя нашей универсальной функции, её параметры 

Функция ДобавитьУсловноеОформление(ФормаОбъекта, ПараметрыОформления, Отбор) экспорт

Пример вызова функции - 

ДобавитьУсловноеОформление(ЭтаФорма, Новый Структура("ЦветФона, Поле", ЦветФонаСписка,    ИмяСписка), Новый Структура("ТЧ, Поле, Значение", ИмяСписка, "СкладскаяОперация", СкладскаяОперация));

Разберем параметры функции: 

1. ФормаОбъекта. Передаем контекст нашей формы - ЭтаФорма, для возможности установки условного оформления.

2. ПараметрыОформления. В этом параметре мы указываем необходимое оформление, которое нужно добавить в условное оформление списка - Новый Структура("ЦветФона, Поле", ЦветФонаСписка,    ИмяСписка). ЦветФонаСписка - например, цвет, который нам нужно задать на фон, ИмяСписка - это имя нашего динамического списка на форме, если требуется задать на весь список. Можно указать конкретную графу (поле) динамического списка, которое нужно оформить. 

3. Отбор. В этом параметре мы указываем необходимый отбор, при котором нужно, чтобы срабатывало условие оформления - Новый Структура("ТЧ, Поле, Значение", ИмяСписка, "СкладскаяОперация", СкладскаяОперация).  ИмяСписка(ТЧ) - это имя нашего динамического списка на форме, "СкладскаяОперация" (Поле) - на которое устанавливается отбор, СкладскаяОперация (Значение) - значение, при котором нужно, чтобы оформление работало. 

 

Еще примеры вызовов функции:

ДобавитьУсловноеОформление(ЭтаФорма, Новый Структура("ЦветТекста", WebЦвета.ЛимонноЗеленый), Новый Структура("ТЧ, Поле, Значение","Объект.Двор_СостояниеВорот", "Направление", ""))

ДобавитьУсловноеОформление(ЭтаФорма, Новый Структура("ЦветТекста", WebЦвета.ОранжевоКрасный), Новый Структура("ТЧ, Поле, Значение, ВидСравнения","СписокДокументов_Приемка_Паллеты", "Длительность", 2, ВидСравненияКомпоновкиДанных.Больше))

ДобавитьУсловноеОформление(ЭтаФорма, Новый Структура("Шрифт, Поле", Новый Шрифт(,,Истина), ИмяСписка+"Анализ"), Новый Структура("ТЧ, Поле, Значение","Объект.АнализДокумента", "ВидЗапроса", 7))

 

Как видно, параметр "ТЧ" у нас может принимать как значения "СписокДокументов_Приемка_Паллеты", так и "Объект.АнализДокумента", т.е. как быть объектом метаданных, так и быть просто списком на форме.

Добавим новый элемент оформления и его параметры:

    НовыйЭлемент = ФормаОбъекта.УсловноеОформление.Элементы.Добавить(); 

	Для Каждого Элемент Из ПараметрыОформления Цикл
		
		Если Элемент.Ключ="Поле" Тогда
			ПолеОформления = Элемент.Значение;
		Иначе
			НовыйЭлемент.Оформление.УстановитьЗначениеПараметра(Элемент.Ключ, Элемент.Значение);	
		КонецЕсли;	
		
	КонецЦикла;		

	НовыйЭлемент.Использование = Истина;

 

Отбор, как обычно, устанавливается для полей компоновки:

    ОформляемыеПоля = НовыйЭлемент.Поля.Элементы.Добавить();
	ОформляемыеПоля.Поле = Новый ПолеКомпоновкиДанных(ПолеОформления);
	
	ЭлементОтбор = НовыйЭлемент.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
	ЭлементОтбор.ЛевоеЗначение 	= Новый ПолеКомпоновкиДанных(Отбор.ТЧ+"."+Отбор.Поле);
	
	Если Отбор.Свойство("ВидСравнения") Тогда
		ЭлементОтбор.ВидСравнения  	= Отбор.ВидСравнения;
	Иначе	
		ЭлементОтбор.ВидСравнения  	= ВидСравненияКомпоновкиДанных.Равно;
	КонецЕсли;
	
	ЭлементОтбор.ПравоеЗначение = Отбор.Значение;

В окончании нашей функции сделаем возврат добавленного оформления для возможности последующей работы с ним:

Возврат Новый Структура("Элемент, Отбор", ФормаОбъекта.УсловноеОформление.Элементы.Количество()-1, НовыйЭлемент.Отбор.Элементы.Количество()-1);

 

Для удобства привожу функцию целиком:

Функция ДобавитьУсловноеОформление(ФормаОбъекта, ПараметрыОформления, Отбор) экспорт
	
	ПолеОформления = СтрЗаменить(Отбор.ТЧ,"Объект.","");
	
	НовыйЭлемент = ФормаОбъекта.УсловноеОформление.Элементы.Добавить(); 
	Для Каждого Элемент Из ПараметрыОформления Цикл
		
		Если Элемент.Ключ="Поле" Тогда
			ПолеОформления = Элемент.Значение;
		Иначе
			НовыйЭлемент.Оформление.УстановитьЗначениеПараметра(Элемент.Ключ, Элемент.Значение);	
		КонецЕсли;	
		
	КонецЦикла;		
	НовыйЭлемент.Использование = Истина;
			
	ОформляемыеПоля = НовыйЭлемент.Поля.Элементы.Добавить();
	ОформляемыеПоля.Поле = Новый ПолеКомпоновкиДанных(ПолеОформления);
	
	ЭлементОтбор = НовыйЭлемент.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
	ЭлементОтбор.ЛевоеЗначение 	= Новый ПолеКомпоновкиДанных(Отбор.ТЧ+"."+Отбор.Поле);
	
	Если Отбор.Свойство("ВидСравнения") Тогда
		ЭлементОтбор.ВидСравнения  	= Отбор.ВидСравнения;
	Иначе	
		ЭлементОтбор.ВидСравнения  	= ВидСравненияКомпоновкиДанных.Равно;
	КонецЕсли;
	
	ЭлементОтбор.ПравоеЗначение = Отбор.Значение;	
	
	Возврат Новый Структура("Элемент, Отбор", ФормаОбъекта.УсловноеОформление.Элементы.Количество()-1, НовыйЭлемент.Отбор.Элементы.Количество()-1);
	
КонецФункции

 

 

UPD. Возникает вопрос, а как хранить оформление в справочнике и как его оттуда получать.

Есть несколько вариантов, например, в виде ХранилищеЗначения или отдельными полями, или ЗначениеВСтрокуВнутр.

У ХранилищеЗначения есть существенный недостаток - нельзя в запросе проверить есть в нем, что или нет, заполнено оно или нет. Поэтому мы у себя храним в ЗначениеВСтрокуВнутр. Однако, если Вы хотите использовать для мобильного приложения, то ЗначениеВСтрокуВнутр там нет, поэтому рекомендую ХранилищеЗначения. 

 

Итак, как сохранить в справочнике установленное пользователем оформление (цвет текста, цвет фона, шрифты):

&НаСервере
Процедура ПередЗаписьюСервер(Отказ, ПараметрыЗаписи)
	
	Если НастроеноОформление Тогда
		
		СтруктураПараметров = Новый Структура();
		
		СтруктураПараметров.Вставить("Шрифт",Шрифт);
		СтруктураПараметров.Вставить("ЦветТекстаСписка",ЦветТекста);
		СтруктураПараметров.Вставить("ЦветФонаСписка",ЦветФона);
		
		Объект.НастройкаСписка = ЗначениеВСтрокуВнутр(СтруктураПараметров);
		
	Иначе
		Объект.НастройкаСписка = "";
	КонецЕсли;

КонецПроцедуры

&НаКлиенте
Процедура ПередЗаписью(Отказ, ПараметрыЗаписи)
		
	ПередЗаписьюСервер(Отказ, ПараметрыЗаписи)
	
КонецПроцедуры

Назад в справочнике восстанавливаем так:

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
		
	Если НЕ ПустаяСтрока(Объект.НастройкаСписка) Тогда
		
		СтруктураПараметров = ЗначениеИзСтрокиВнутр(Объект.НастройкаСписка);
		
		Шрифт = СтруктураПараметров.Шрифт;
		ЦветТекста	= СтруктураПараметров.ЦветТекстаСписка;
		ЦветФона	= СтруктураПараметров.ЦветФонаСписка;
		
		НастроеноОформление = Истина;
	КонецЕсли;

КонецПроцедуры

 

А там где нужно вывести, например, в функцию 

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
	
  ....
  ОформитьСпискиПоСкладскимОперациям(мУсловноеОформлениеТаблиц, мСтруктураФормы);
	
КонецПроцедуры

&НаСервере
Процедура ОформитьСпискиПоСкладскимОперациям(мУсловноеОформлениеТаблиц, мСтруктураФормы)
	
	Запрос = Новый Запрос;
	
	Запрос.Текст = "
	|ВЫБРАТЬ
	|	Спр.НастройкаСписка		КАК НастройкаСписка,
	|	Спр.Ссылка				КАК СкладскаяОперация
	|ИЗ
	|	Справочник.лгСкладскиеОперации	КАК Спр
	|ГДЕ
	|	НЕ Спр.НастройкаСписка=""""
	|";
	
	Выборка = Запрос.Выполнить().Выбрать();
	Пока Выборка.Следующий() Цикл
		
		СтруктураПараметров = ЗначениеИзСтрокиВнутр(Выборка.НастройкаСписка);
		
		Для Каждого Элемент Из мСтруктураФормы.ИменаСписков Цикл		
		
			ФормаСписка = Элемент.Значение;	
			
			Если ПустаяСтрока(ФормаСписка.Процесс) Тогда
				Продолжить;
			КонецЕсли;

			мУсловноеОформлениеТаблиц.Вставить(ФормаСписка.ИмяСписка, пакФункцииДиалогов.ДобавитьУсловноеОформление(ЭтаФорма, Новый Структура("ЦветТекста, Поле", СтруктураПараметров.ЦветТекстаСписка, 	ФормаСписка.ИмяСписка), Новый Структура("ТЧ, Поле, Значение",ФормаСписка.ИмяСписка, "СкладскаяОперация", Выборка.СкладскаяОперация)));	
			мУсловноеОформлениеТаблиц.Вставить(ФормаСписка.ИмяСписка, пакФункцииДиалогов.ДобавитьУсловноеОформление(ЭтаФорма, Новый Структура("ЦветФона, Поле", СтруктураПараметров.ЦветФонаСписка, 	ФормаСписка.ИмяСписка), Новый Структура("ТЧ, Поле, Значение",ФормаСписка.ИмяСписка, "СкладскаяОперация", Выборка.СкладскаяОперация)));	
			мУсловноеОформлениеТаблиц.Вставить(ФормаСписка.ИмяСписка, пакФункцииДиалогов.ДобавитьУсловноеОформление(ЭтаФорма, Новый Структура("Шрифт, Поле", СтруктураПараметров.Шрифт, 	ФормаСписка.ИмяСписка), Новый Структура("ТЧ, Поле, Значение",ФормаСписка.ИмяСписка, "СкладскаяОперация", Выборка.СкладскаяОперация)));	
		КонецЦикла;
		
	КонецЦикла;	
	
КонецПроцедуры	

 

 

Надеюсь, моя публикация была Вам полезна и сэкономит Ваше время, ссылка на все публикации SizovE, думаю Вам понравится Ускоряем тормозной стандартный поиск по динамическому списку, настраиваем его под себя.

 

Подписывайтесь на мой канал (наверху), будет много интересного бесплатного контента :)

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. VZhulanov 4 07.02.21 20:48 Сейчас в теме
Раскрашивать каждый элемент справочника тоже не каждый пользователь будет, даже если это удобно.

Я делал отдельный справочник оформлений, в который добавляются элементы для различных типовых ситуаций, которые необходимо как-то выделить в программе.
У каждого элемента есть Код, под которым он используется в программе, и подробное Наименование, которое видит пользователь при настройке оформлений под себя.
Настраиваются такие параметры как цвет текста/фона и шрифт.
У каждого элемента справочника есть значение настройки по умолчанию, которое применяется для всех пользователей, которые не переопределили оформление под свой вкус.

Постепенно, при обновлении программы, этот справочник наполнился уже почти сотней различных элементов. Процедура обновления до очередной версии добавляет в этот справочник свои элементы.
Так-же этим справочником пользуется не только сама конфигурация, но и внешние обработки, которые могут дописывать к ней сторонние программисты. Ведь добавить элемент в справочник очень просто - вызов одной функции, и использовать для раскраски тоже просто.

Для удобства пользователей справочник разбит на группы по темам.

Плюс у некоторых элементов есть интересное свойство - юзеры могут сами создавать свои варианты условий и для каждого варианта устанавливать свое оформление.
Упрощенный пример - справочник товаров. В документах, в прайс-листе, в форме чека, в списках подбора ячейку с товаром можно раскрасить в зависимости от свойств этого товара (плюс еще и сами свойства можно создавать через характеристики). При заведении каких-то акций менеджеры могут добавить условное оформление по вхождению товара в акцию, указать что по умолчанию все юзеры будут видеть такое-то оформление.

Пока программа была на обычных формах - все работало замечательно. Щас постепенно перевожу на управляемые - обычные типовые оформления легко добавляются, код почти один в один как в данной публикации, а вот с условными приходится возиться, так как там условия отборов вообще не зависят от данных, которые на форме показаны )) Приходится юзать событие ПриПолученииДанныхНаСервере
2. SizovE 171 08.02.21 00:37 Сейчас в теме
(1) в нашей задачке, изложенное решение, было оптимально, это больше для админа, а не пользователя
Ваш кейс интересный, плюсик )
Хотя и моё мнение, что вариантов не должно быть много, это как с фирменным стилем сайта/компании, слишком много разных цветов или похожих будет путать пользователя, 5-7 цветов, жирность вполне достаточно для реальной жизни. В тоже время в каждой компании свои "хотелки", кто-то любит радугу ))) уточним - составленную из цветов спектра видимого излучения (wiki)
3. VZhulanov 4 08.02.21 17:52 Сейчас в теме
(2)Конечно, радуга будет мешаться.
Просто в программе много различных форм с информацией разного типа, вот и получилось много элементов этого справочника.
Но некоторые менеджеры за счет возможности раскраски по своим условиям иногда делают радугу и кассиры их матерят ))
4. SizovE 171 08.02.21 20:00 Сейчас в теме
Сообщение было скрыто модератором.
...
5. imaxtr 29.07.21 11:54 Сейчас в теме
Здравствуйте!!! А как на рознице 2.3 можно покрасить документы (Акт переоценки и Поступление Товаров) после того как через них были напечатаны ценники????
Оставьте свое сообщение

См. также

Использование классов .Net в 1С для новичков Промо

Практика программирования Разработка внешних компонент Универсальные функции v7.7 v8 Бесплатно (free)

Руководство для новичков. Написав статью http://infostart.ru/public/238584/, я понял, что многие не понимают того, что написано. Поэтому в этой статье постараюсь более подробно остановиться на азах и без кода на вражеском языке (C#)

27.01.2016    83041    Serginio    113    

Полезные примеры СКД, ч.2

Практика программирования v8 v8::СКД Бесплатно (free)

Еще несколько примеров решения задач в СКД.

06.04.2021    7899    Neti    8    

Обзор полезных методов БСП 3.1.4

Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Бесплатно (free)

Библиотека стандартных подсистем (далее - БСП) является частью любой типовой конфигурации, поэтому умение применять готовые процедуры и функции повышает качество разработки и избавляет от написания лишнего кода. К сожалению, не у всех есть время и упорство овладеть всей документацией, поэтому я собрал воедино наиболее популярный функционал.

25.03.2021    28785    rayastar    49    

Звуковое управление в 1С 8.3

Практика программирования v8 1cv8.cf Бесплатно (free)

В данной статье описано создание библиотеки для звукового управления (выполнение команд голосом) для платформы 1С 8.3. Задача была поставлена так, чтобы модуль функционировал непосредственно на клиенте 1С, осуществляя управление формами, и взаимодействовал с интерфейсом.

16.03.2021    5525    velemir    31    

Использование программных перечислений, ч.1: строковые константы Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Часто ли у вас возникает необходимость в коде выполнять сравнение на строку?

10.12.2016    39871    unichkin    74    

Serverless (Faas) в 1С. Создание и вызов Yandex Cloud Functions

Универсальные функции Практика программирования v8 Бесплатно (free)

"Я не могу просто взять и скопировать код с гитхаба", "у нас 1С микросервисами окружена", "возможностей мало" - частые фразы 1С разработчиков. которым не хватает возможностей платформы в современном мире. Faas, конечно, история не новая, но нас сдерживало 152ФЗ и задержки по пингам. Для того, чтобы действительно использовать в 1С код, к примеру, на Python, надо было приложить усилия. Теперь всё намного проще - берём и используем.

28.12.2020    7213    comol    31    

Базовые вещи БСП, которые облегчат жизнь программисту 1С

Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Россия Бесплатно (free)

В данной публикации я опишу полезные процедуры и функции модуля общего назначения библиотеки стандартных подсистем, обязательные к использованию любым программистом 1С.

30.08.2020    16979    quazare    34    

Форма выбора (подбор) в управляемых формах

Практика программирования v8 v8::УФ 1cv8.cf Россия Бесплатно (free)

Разбор небольших примеров того, как правильно открывать форму выбора (подбора) в управляемых формах, не прибегая к модальным окнам.

08.05.2020    60041    user5300    18    

Вспомогательные инструкции в коде 1С Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Помогаем редактору кода 1С помогать нам писать и анализировать код.

15.10.2018    34546    tormozit    106    

Программная работа с настройками СКД

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Нюансы программной работы с настройками системы компоновки данных в отчетах и динамических списках. Обзор всех видов настроек компоновки. Что в каких случаях правильно применять. В качестве примера рассмотрена работа с отборами и группировками.

27.01.2020    55228    ids79    26    

[СКД] Программное создание схемы компоновки данных

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Сделаем отчет на СКД полностью программно, без использования макета "схема компоновки данных".

15.01.2020    38523    John_d    22    

СКД. Шаг 3. Используем макеты для оформления отчета

Работа с интерфейсом v8 v8::СКД 1cv8.cf Бесплатно (free)

В данной публикации рассмотрим базовый подход к использованию собственных макетов в СКД на примере формирования небольшого отчета.

13.01.2020    30964    aximo    16    

Оформление и рефакторинг сложных логических выражений Промо

Практика программирования v8 Россия Бесплатно (free)

В сложных логических выражениях нередко самому автору спустя какое-то время тяжело разобраться, не говоря уже о других программистах. Предлагаемая методика позволяет повысить наглядность таких выражений путем оформления в виде И-ИЛИ дерева и одновременно выполнять их рефакторинг.

20.09.2012    81445    tormozit    131    

Последовательности событий при проведении документа 1С. Шпаргалка + про формы + про расширения

Практика программирования v8 Россия Бесплатно (free)

Собрал информацию о событиях/подписках/расширениях в одном месте.

30.12.2019    30497    kuzyara    38    

Сходство Джаро - Винклера. Нечеткое сравнение строк

Универсальные функции v8 Россия Бесплатно (free)

В области информатики и статистики сходство Джаро - Винклера представляет собой меру схожести строк для измерения расстояния между двумя последовательностями символов. В публикации рассмотрены некоторые особенности алгоритма, и представлен вариант его реализации на языке 1С.

25.12.2019    8060    brooho    19    

Полезные процедуры и функции для программиста

Практика программирования Универсальные функции v8 1cv8.cf Россия Бесплатно (free)

Все мы пишем программный код и часто используем процедуры, облегчающие его написание. Ниже приведена выборка таких полезных процедур и функций.

07.10.2019    37177    HostHost    41    

Запись значения в поле ввода/формы со срабатыванием события ПриИзменении Промо

Практика программирования v8 1cv8.cf Россия Бесплатно (free)

Иногда возникает необходимость после записи значения в какое либо поле ввода/формы вызвать для него обработчик события ПриИзменении, а о вызове самого события приходится только мечтать. В этой статье приводится программный способ вызова этого события.

11.07.2007    52653    tormozit    51    

Таблица значений. Нюансы

Практика программирования v8 Бесплатно (free)

Обзор некоторых аспектов использования общеизвестного инструмента 1С.

01.10.2019    48567    Yashazz    55    

Оповещения боту из 1С за 31 минуту

Практика программирования Интеграция v8::УФ 1cv8.cf Бесплатно (free)

Поделюсь опытом, как быстро сделать бота с оповещениями в Телеграмм из 1С без лишних затрат.

18.09.2019    19447    feva    43    

[Шпаргалка] Программное создание элементов формы

Практика программирования Работа с интерфейсом v8 1cv8.cf Бесплатно (free)

Программное создание практически всех популярных элементов формы.

06.09.2019    87677    rpgshnik    71    

Как сделать из &НаКлиентеНаСервереБезКонтекста почти &НаКлиентеНаСервере Промо

Практика программирования v8 1cv8.cf Россия Бесплатно (free)

Как сделать метод формы, доступный на клиенте и на сервере одновременно, и сохранить при этом удобство разработки

10.09.2017    49279    tormozit    74    

Агрегатные функции СКД, о которых мало кто знает

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Пользуетесь ли Вы всеми возможными агрегатными функциями, которые предоставляет система компоновки данных? Если Вы используете только: СУММА, КОЛИЧЕСТВО, МИНИМУМ, МАКСИМУМ, СРЕДНЕЕ, то эта статья для Вас.

05.09.2019    69885    ids79    55    

Регистры бухгалтерии. Общая информация

Практика программирования Математика и алгоритмы v8 v8::БУ БУ Бесплатно (free)

Общая информация о внутреннем устройстве регистров бухгалтерии.

05.09.2019    41456    YPermitin    25    

Три костыля. Сказ про фокусы в коде

Практика программирования v8 Бесплатно (free)

Три интересных (или странных) костыля в коде, которые могут помочь в повседневных и не очень задачах.

03.09.2019    29012    YPermitin    81    

Выгрузка документа по условию Промо

Практика программирования Разработка v8 Бесплатно (free)

Что делать, если документы нужно выгружать не все подряд, а по какому-то фильтру: статусу, дате, набору условий... А что если он соответствовал этим условиям, а потом перестал? А если потом опять начал? Такие ситуации заставили попотеть не одного программиста.

25.04.2019    17140    m-rv    3    

Отслеживание выполнения фонового задания

Практика программирования Универсальные функции Разработка v8 1cv8.cf Бесплатно (free)

Запуск фонового задания из модуля внешней обработки. Отслеживание выполнения задания в виде прогресса, расположенного на форме.

17.08.2019    42011    ids79    19    

Функции СКД: ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Подробное описание и использование внутренних функций системы компоновки данных: Вычислить, ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив, ВычислитьВыражениеСГруппировкойТаблицаЗначений.

08.08.2019    134164    ids79    75    

Фоновое выполнение кода в 1С - это просто

Практика программирования v8 1cv8.cf Бесплатно (free)

Как легко запускать выполнение в фоне, не прибегая к долгому описанию фоновых процедур.

02.08.2019    54424    avalakh    26    

Как прикрутить ГУИД к регистру сведений Промо

Практика программирования Перенос данных из 1C8 в 1C8 Разработка v8 Бесплатно (free)

... и немного теории обмена данными. В частности, разберем боль всех, кто пишет небанальные обмены данными: как набору записей регистра сведений назначить гуид и далее использовать его в обмене для идентификации этого набора.

16.04.2019    22230    m-rv    17    

СКД - наборы данных и связи между ними, создание собственной иерархии, вложенные отчеты

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Набор данных объект. Использование в схеме компоновки нескольких наборов данных. Различные варианты связи наборов: объединение, соединение. Использование иерархии в отчетах на СКД. Создание собственной иерархии, иерархия детальных записей. Использование вложенных схем в отчетах на СКД.

26.07.2019    94706    ids79    16    

СКД - использование расширений языка запросов, секция ХАРАКТЕРИСТИКИ

Инструментарий разработчика Практика программирования v8 v8::СКД Бесплатно (free)

Автоматическое и не автоматическое заполнение полей компоновки данных. Использование расширений языка запросов для СКД «{…}», секция ВЫБРАТЬ, секция ГДЕ, параметры виртуальных таблиц. Автоматизированное использование дополнительных данных в запросе: секция ХАРАКТЕРИСТИКИ.

17.07.2019    44913    ids79    27    

Регистры сведений. За кулисами

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Небольшие заметки по внутреннему устройству регистров сведений.

09.07.2019    31853    YPermitin    14    

Как сделать запрос на изменение данных Промо

Практика программирования v8 v8::Запросы 1cv8.cf Бесплатно (free)

В статье приведены особенности внутренней архитектуры и примеры работы с расширением языка запросов 1С.

01.06.2018    35053    m-rv    22    

"Меньше копипаста!", или как Вася универсальную процедуру писал

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Программист Вася разбирает подход создания универсальных методов на примере программного вывода СКД.

04.07.2019    21573    SeiOkami    52    

Работа с настройками системы компоновки данных

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Варианты отчетов, работа с настройками вариантов: структура группировок, поля отчета, отборы, сортировка, условное оформление, другие настройки, настройки отображения диаграмм.

02.07.2019    74943    ids79    17    

Создание отчетов с помощью СКД - основные понятия и элементы

Практика программирования Математика и алгоритмы v8 v8::СКД Бесплатно (free)

Основные принципы работы СКД. Понятия схемы компоновки и макета компоновки. Описание основных элементов схемы компоновки: наборы данных, поля, вычисляемые поля, ресурсы, параметры.

25.06.2019    70196    ids79    27    

Метод формирования движений в типовых регистрах нетиповыми регистраторами Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Вариант решения задач с проведением по типовым регистрам нетиповыми регистраторами. Зачем - чтобы при сравнении конфигурации не обращать внимание на свойства регистров и исключить вероятность допущения горькой оплошности при обновлении информационных баз, заменив типы регистраторов основной конфигурации типами конфигурации поставщика. Для программных продуктов, имеющих в своем составе метаданных документ "Корректировка регистров"("Корректировка записей регистров").

05.12.2017    30042    itriot11    34    

Подсистема "Варианты отчетов". Используете ли Вы ее правильно?

Работа с интерфейсом БСП (Библиотека стандартных подсистем) v8 1cv8.cf Бесплатно (free)

Небольшая история про использование подсистемы "Варианты отчетов" из БСП. Используете ли Вы ее правильно?

04.06.2019    52698    YPermitin    55    

Регистры накопления. Структура хранения в базе данных

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Структура хранения регистров накопления в базе данных для платформы 1С:Предприятие 8.x. Первая часть в серии публикаций.

16.05.2019    58143    YPermitin    30    

О расширениях замолвите слово...

Практика программирования Разработка v8 Бесплатно (free)

О чём стоит задуматься при принятии решения о создании расширения конфигурации…

07.04.2019    40982    ellavs    131    

Автоматические и управляемые блокировки применительно к типовым конфигурациям 1С Промо

Математика и алгоритмы Практика программирования v8 v8::blocking 1cv8.cf Бесплатно (free)

Основные принципы работы с режимами автоматических и управляемых блокировок в 1С Предприятие 8. Теория и применение в типовых конфигурациях: БП, УТ, ЕРП

10.11.2018    42096    ids79    45    

Git-репозитории для 1С-кода (опыт использования при небольших проектах)

Практика программирования v8 Бесплатно (free)

Инструкции по взаимодействию с Git-репозиторием, которые писались для тех наших программистов, которые вообще никогда не работали с Git (руководства в духе "Как получить код из git-репозитория?", "Как отправить код в git-репозиторий")...

28.03.2019    30689    ellavs    90    

Трюки с внешними источниками данных

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Некоторые трюки для преодоления ограничений внешних источников данных.

14.03.2019    38704    YPermitin    53    

Добавление отчетов в типовые конфигурации 1С

Практика программирования Универсальные функции БСП (Библиотека стандартных подсистем) v8::УФ v8::СКД 1cv8.cf Бесплатно (free)

Описание различных способов добавления общих и контекстных отчетов в конфигурации 1С, построенные на базе БСП. Основные моменты и нюансы.

07.03.2019    72753    ids79    49    

Разработка и сценарное тестирование с Vanessa-ADD. Отчетность Allure. Автоматизация запуска сценариев

Практика программирования Vanessa Automation v8 Россия Бесплатно (free)

Формируем отчетность о результатах выполнения сценариев. Автоматизируем запуск.

26.02.2019    26860    Vladimir Litvinenko    28    

Функциональные опции 1С 8.3 – все возможные варианты использования

Практика программирования Разработка v8::УФ 1cv8.cf Бесплатно (free)

Примеры использования функциональных опций для управления интерфейсом и элементами управляемых форм, с различными вариантами хранения значений: константа, реквизит справочника, ресурс регистра сведений.

22.02.2019    48288    ids79    19    

Информирование пользователя. Работа с объектом «СообщениеПользователю»

Практика программирования Разработка v8::УФ 1cv8.cf Бесплатно (free)

Различные варианты и нюансы использования объекта СообщениеПользователю и другие способы информирования пользователя: без привязки к какой-либо форме и с выводом сообщения в отдельном окне.

15.02.2019    87374    ids79    63    

Возможности типовых шаблонов ограничения доступа на уровне записей (RLS)

Практика программирования БСП (Библиотека стандартных подсистем) Роли и права v8 v8::Права Бесплатно (free)

Краткий обзор применения типовых шаблонов ограничения доступа на уровне записей в конфигурациях, созданных на базе БСП: #ПоЗначениям, #ПоНаборамЗначений, #ПоЗначениямРасширенный, #ПоЗначениямИНаборамРасширенный

03.02.2019    58555    ids79    11