Пример работы с диаграммой Ганта в 1С

Публикация № 1389904

Разработка - Практика программирования

Диаграмма Ганта

Пример работы с очень нужным и важным, по моему мнению, объектом в 1С «Диаграммой Ганта».

Статей по работе с этим объектом маловато, непонятно почему. Немного подправим ситуацию.

В пример я попытался рассказать возможности и методы построения диаграммы Ганта в 1С, создание, сохранение изображения, "экспорт импорт в XML", различные украшательства. Делается все это добро следующим образом:

Сначала создаются серии,  метод «Добавить()» свойства «Серии» у объекта «ДиаграммаГанта».

	СерияПлан = Диаграмма.Серии.Добавить();
	СерияПлан.Текст = "План";
	СерияПлан.Цвет = WebЦвета.СинеФиолетовый;
	
	СерияФакт = Диаграмма.Серии.Добавить();
	СерияФакт.Текст = "Факт";
	СерияФакт.Цвет = WebЦвета.КрасноФиолетовый;

Их может быть несколько или одна.  Далее начинам строить диаграмму - добавляется точка методом «УстановитьТочку()» объекта «ДиаграммаГанта».

		Точка = Диаграмма.УстановитьТочку(СтрокаТЧЗадачи.Этап, "Демо"); // Родитель = "Демо"
		Точка.Текст = СтрокаТЧЗадачи.Этап;
		Точка.Картинка = БиблиотекаКартинок.Реквизит;

 Точка это некий список задач, например – «Разработка».

С помощью метода «ПолучитьЗначение(Точка, Серия)» объекта «ДиаграммаГанта» получаем значение, это, если так можно выразиться, некоторое значение на пересечении серии и точки (Задачи).

		Значение = Диаграмма.ПолучитьЗначение(Точка, СерияПлан);
		Значение.Редактирование = Истина;

Значение представляет собой коллекцию интервалов. Добавляем интервал «Добавить()».

		Интервал = Значение.Добавить();
		Интервал.Начало = СтрокаТЧЗадачи.ДатаНачалаПлан;
		Интервал.Конец = СтрокаТЧЗадачи.ДатаОкончанияПлан;
		Интервал.Текст = "Интервал план";

У него есть  свойства «Начало» и «Конец», тип «Дата», а так же метод «Добавить(<Конец>)» с параметром ИнтервалДиаграммыГанта, который создаст связь и вернет значение с типом «СвязьДиаграммыГанта».

		Если СтрокаТЧЗадачи.Предшественник <> 0 Тогда 
			Отбор = Новый Структура("ПредшественникНомер", СтрокаТЧЗадачи.НомерСтроки);
			НайденныеСтроки = Связи.НайтиСтроки(Отбор);
			
			Для Каждого НайденненнаяСвязь Из НайденныеСтроки Цикл 
				НайденненнаяСвязь.Интервал.Добавить(Интервал);	
			КонецЦикла;
			
		КонецЕсли;

Для построения связей используется Таблица значений. Сейчас попытаюсь объяснить, почему так. Когда создается связь от А до В, нужно уже иметь два созданных интервала, как некие объекты с типом «ИнтервалДиаграммыГанта» на диаграмме Ганта, поэтому строить связь можно только в момент появления интервала В, а для этого нужно куда то временно сохранить значение с типом «ИнтервалДиаграммыГанта», ссылку на интервал А. Поэтому и используется таблица значений, она хранит связи, что бы их построить, когда появятся все нужные объекты  в диаграмме.

В публикацию добавлена обработка, демонстрирующая пример работы. Работает в любой конфигурации даже пустой на платформе 8.3. Тестировалась на версии 8.3.16.1359 и 8.3.18.1334

Добавляйте в комментарий, если я, что то упустил.

Всем добра.

&НаСервере
Процедура ПостроитьДиаграммуГанта() 
	
	// ТЗ для связей
	Связи = Новый ТаблицаЗначений;
	Связи.Колонки.Добавить("ПредшественникНомер");
	Связи.Колонки.Добавить("Интервал");	
	
	Диаграмма.Очистить();
	
	// Будет 2 серии - план, факт
	СерияПлан = Диаграмма.Серии.Добавить();
	СерияПлан.Текст = "План";
	СерияПлан.Цвет = WebЦвета.СинеФиолетовый;
	
	СерияФакт = Диаграмма.Серии.Добавить();
	СерияФакт.Текст = "Факт";
	СерияФакт.Цвет = WebЦвета.КрасноФиолетовый;
	
	
	// Пример иерархии, создаем верхний уровень "Демо"
	ДобавитьДемоИнтервалы(СерияПлан);
	

	Для Каждого СтрокаТЧЗадачи Из ТЗЗадачи Цикл 
		
		Точка = Диаграмма.УстановитьТочку(СтрокаТЧЗадачи.Этап, "Демо"); // Родитель = "Демо"
		Точка.Текст = СтрокаТЧЗадачи.Этап;
		Точка.Картинка = БиблиотекаКартинок.Реквизит;
		
		
		// *****************************
		// Добавляем интервал серии план				
		
		Значение = Диаграмма.ПолучитьЗначение(Точка, СерияПлан);
		Значение.Редактирование = Истина;
		
		Интервал = Значение.Добавить();
		Интервал.Начало = СтрокаТЧЗадачи.ДатаНачалаПлан;
		Интервал.Конец = СтрокаТЧЗадачи.ДатаОкончанияПлан;
		Интервал.Текст = "Интервал план";
		
		УстановитьТекстЗначения(Значение.Текст, СтрокаТЧЗадачи.ДатаНачалаПлан, СтрокаТЧЗадачи.ДатаОкончанияПлан);   

		// Строить связи будем только по серии план
		
		// Создаем заранее сохраненную связь в ТЗ связи (ищем интервал предшесвенник в ТЗ)
		Если СтрокаТЧЗадачи.Предшественник <> 0 Тогда 
			Отбор = Новый Структура("ПредшественникНомер", СтрокаТЧЗадачи.НомерСтроки);
			НайденныеСтроки = Связи.НайтиСтроки(Отбор);
			
			Для Каждого НайденненнаяСвязь Из НайденныеСтроки Цикл 
				НайденненнаяСвязь.Интервал.Добавить(Интервал);	
			КонецЦикла;
			
		КонецЕсли;

		// Если текущий интервал является предшественником для добавленных в будущем в цикле интервалов
		// тогда сохраняем связь в ТЗ связи
		Отбор = Новый Структура("Предшественник", СтрокаТЧЗадачи.НомерСтроки);
		НайденныеСтроки = ТЗЗадачи.НайтиСтроки(Отбор);
		
		Если НайденныеСтроки <> 0 Тогда 
			Для Каждого НайденненнаяСвязь Из НайденныеСтроки Цикл 
				НоваяСвязь = Связи.Добавить();
				НоваяСвязь.ПредшественникНомер = НайденненнаяСвязь.НомерСтроки;
				НоваяСвязь.Интервал = Интервал;
			КонецЦикла;
		КонецЕсли;
		
		
		// *****************************
		// Добавляем интервал серии факт
				
		Значение = Диаграмма.ПолучитьЗначение(Точка, СерияФакт);	
		Интервал = Значение.Добавить();
		Интервал.Начало = СтрокаТЧЗадачи.ДатаНачалаФакт;
		Интервал.Конец = СтрокаТЧЗадачи.ДатаОкончанияФакт;
		Интервал.Текст = "Интервал факт";
		
	КонецЦикла;
	

	// Метки времени. Добавляем метку времени их можно добавлять несколько на разные шкалы времени
	
	Шкала = Диаграмма.ОбластьПостроения.ШкалаВремени.Элементы[1];
	
	МеткаВремени = Шкала.Метки.Добавить(НачалоДня(ТекущаяДата()));
	МеткаВремени.Текст = "Текущая дата " + Формат(ТекущаяДата(), "ДФ=dd.MM.yyyy");
	МеткаВремени.ЦветТекста = WebЦвета.Красный;				
	МеткаВремени.ЦветЛинии = WebЦвета.Красный;
	
	
	// Фон, выделяем выходные	
	ТекущийПериод = НачалоМесяца(Диаграмма.НачалоПолногоИнтервала - 1);
	КонечныйПериода = Диаграмма.КонецПолногоИнтервала;
	
	Пока ТекущийПериод < КонечныйПериода Цикл 
		Если КонецНедели(ТекущийПериод) = КонецДня(ТекущийПериод) Тогда 
			ИнтервалФона = Диаграмма.ИнтервалыФона.Добавить(НачалоДня(ТекущийПериод - 86400), КонецДня(ТекущийПериод));
			ИнтервалФона.Цвет = WebЦвета.БледноЛиловый;
		КонецЕсли;
		
		ТекущийПериод = КонецДня(ТекущийПериод) + 1;	
	КонецЦикла;
	
	
	
	
	// Получаем верхнюю точку "Демо" и разворачиваем иерархию
	Точка = Диаграмма.УстановитьТочку("Демо");
	Диаграмма.РазвернутьТочку(Точка, Истина);
КонецПроцедуры

&НаСервере
Процедура ДобавитьДемоИнтервалы(Серия)
		
	Точка = Диаграмма.Точки.Добавить();
	Точка.Текст = "Демо";
	Точка.Значение = "Демо";
	Точка.Картинка = БиблиотекаКартинок.СводнаяДиаграмма;
	
	
	Значение = Диаграмма.ПолучитьЗначение(Точка, Серия);
		
	ТекущийПериод = НачалоГода(ТекущаяДата());
	
	Для Итерация = 1 По 25 Цикл 
		
		ЦветИнтервала = Новый Цвет(Итерация * 10, Итерация * 10, Итерация * 10);
		
		Интервал = Значение.Добавить();
		Интервал.Цвет = ЦветИнтервала;
		Интервал.Начало = НачалоДня(ТекущийПериод);
		Интервал.Конец = КонецДня(ТекущийПериод);
			
		
		ТекущийПериод = КонецДня(ТекущийПериод) + 1;
	КонецЦикла;
	
	
	Палира = Новый Массив;
	Палира.Добавить(WebЦвета.Красный);
	Палира.Добавить(WebЦвета.Оранжевый);
	Палира.Добавить(WebЦвета.Желтый);
	Палира.Добавить(WebЦвета.Зеленый);
	Палира.Добавить(WebЦвета.Голубой);
	Палира.Добавить(WebЦвета.Синий);
	Палира.Добавить(WebЦвета.Фиолетовый);
	
	
	Для Итерация = 0 По 6 Цикл 
		
		Интервал = Значение.Добавить();
		Интервал.Цвет = Палира[Итерация];
		Интервал.Начало = НачалоДня(ТекущийПериод);
		Интервал.Конец = КонецДня(ТекущийПериод);
				
		
		ТекущийПериод = КонецДня(ТекущийПериод) + 1;
	КонецЦикла;
		
			
КонецПроцедуры

&НаКлиентеНаСервереБезКонтекста
Процедура УстановитьТекстЗначения(Текст, ДатаНачала, ДатаОкончания)
	Текст = Формат(ДатаНачала, "ДЛФ=DDT") + " - " + Формат(ДатаОкончания, "ДЛФ=DDT");	
КонецПроцедуры

 

Скачать файлы

Наименование Файл Версия Размер
Пример работы с Диаграммой Ганта в 1С:

.epf 12,16Kb
67
.epf 12,16Kb 67 Скачать бесплатно

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. Scratch_sv 03.03.21 10:42 Сейчас в теме
Вопрос уже давно гуляет по форумам, никто ничего не отвечает:
Каким образом (какой внешней компонентой) можно реализовать перетаскивание диапазонов по вертикали (между точками). В Вашем случае, между этапами.
2. Константин С. 686 07.03.21 15:52 Сейчас в теме
(1)
ожно реализовать перетаскивание диапазонов по вертикали

https://infostart.ru/1c/articles/894080/
https://infostart.ru/1c/articles/991938/
Оставьте свое сообщение

См. также

Звуковое управление в 1С 8.3 Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

В данной статье описано создание библиотеки для звукового управления (выполнение команд голосом) для платформы 1С 8.3. Задача была поставлена так, чтобы модуль функционировал непосредственно на клиенте 1С, осуществляя управление формами, и взаимодействовал с интерфейсом.

16.03.2021    2698    velemir    29    

Полезные примеры СКД, ч.2

Практика программирования v8 v8::СКД Бесплатно (free)

Еще несколько примеров решения задач в СКД.

06.04.2021    2939    Neti    7    

Обзор полезных методов БСП 3.1.4

Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Бесплатно (free)

Библиотека стандартных подсистем (далее - БСП) является частью любой типовой конфигурации, поэтому умение применять готовые процедуры и функции повышает качество разработки и избавляет от написания лишнего кода. К сожалению, не у всех есть время и упорство овладеть всей документацией, поэтому я собрал воедино наиболее популярный функционал.

25.03.2021    11374    rayastar    45    

Базовые вещи БСП, которые облегчат жизнь программисту 1С

Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Россия Бесплатно (free)

В данной публикации я опишу полезные процедуры и функции модуля общего назначения библиотеки стандартных подсистем, обязательные к использованию любым программистом 1С.

30.08.2020    12515    quazare    34    

Serverless (Faas) в 1С. Создание и вызов Yandex Cloud Functions Промо

Универсальные функции Практика программирования v8 Бесплатно (free)

"Я не могу просто взять и скопировать код с гитхаба", "у нас 1С микросервисами окружена", "возможностей мало" - частые фразы 1С разработчиков. которым не хватает возможностей платформы в современном мире. Faas, конечно, история не новая, но нас сдерживало 152ФЗ и задержки по пингам. Для того, чтобы действительно использовать в 1С код, к примеру, на Python, надо было приложить усилия. Теперь всё намного проще - берём и используем.

28.12.2020    5132    comol    31    

Форма выбора (подбор) в управляемых формах

Практика программирования v8 v8::УФ 1cv8.cf Россия Бесплатно (free)

Разбор небольших примеров того, как правильно открывать форму выбора (подбора) в управляемых формах, не прибегая к модальным окнам.

08.05.2020    41946    user5300    17    

Программная работа с настройками СКД

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Нюансы программной работы с настройками системы компоновки данных в отчетах и динамических списках. Обзор всех видов настроек компоновки. Что в каких случаях правильно применять. В качестве примера рассмотрена работа с отборами и группировками.

27.01.2020    43256    ids79    26    

[СКД] Программное создание схемы компоновки данных

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Сделаем отчет на СКД полностью программно, без использования макета "схема компоновки данных".

15.01.2020    32560    John_d    22    

Использование программных перечислений, ч.1: строковые константы Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Часто ли у вас возникает необходимость в коде выполнять сравнение на строку?

10.12.2016    38864    unichkin    74    

Последовательности событий при проведении документа 1С. Шпаргалка + про формы + про расширения

Практика программирования v8 Россия Бесплатно (free)

Собрал информацию о событиях/подписках/расширениях в одном месте.

30.12.2019    25047    kuzyara    38    

30 задач. Странных и не очень

Практика программирования v8 Бесплатно (free)

30 задач на знание языка программирования 1С и некоторого поведения платформы. Маленьких. Странных и не очень.

02.12.2019    19618    YPermitin    60    

Как передать IP адрес, который вызвал HTTP запрос в 1C (для веб-сервера Apache)

Практика программирования v8 Бесплатно (free)

Столкнулся с задачей получения IP адреса, который вызывает http сервис 1С. Итак, решение:

22.11.2019    10226    Sibars    19    

Вспомогательные инструкции в коде 1С Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Помогаем редактору кода 1С помогать нам писать и анализировать код.

15.10.2018    32626    tormozit    105    

Полезные процедуры и функции для программиста

Практика программирования Универсальные функции v8 1cv8.cf Россия Бесплатно (free)

Все мы пишем программный код и часто используем процедуры, облегчающие его написание. Ниже приведена выборка таких полезных процедур и функций.

07.10.2019    34263    HostHost    41    

Таблица значений. Нюансы

Практика программирования v8 Бесплатно (free)

Обзор некоторых аспектов использования общеизвестного инструмента 1С.

01.10.2019    42635    Yashazz    50    

О программе Postman для тестирования API и для чего она нужна 1С-нику

Практика программирования Программное обеспечение (software) v8 Бесплатно (free)

Для чего нужна программа Postman для тестирования API и какая от него польза для 1С-программиста.

24.09.2019    15457    budidich    28    

Оформление и рефакторинг сложных логических выражений Промо

Практика программирования v8 Россия Бесплатно (free)

В сложных логических выражениях нередко самому автору спустя какое-то время тяжело разобраться, не говоря уже о других программистах. Предлагаемая методика позволяет повысить наглядность таких выражений путем оформления в виде И-ИЛИ дерева и одновременно выполнять их рефакторинг.

20.09.2012    79735    tormozit    131    

[Шпаргалка] Программное создание элементов формы

Практика программирования Работа с интерфейсом v8 1cv8.cf Бесплатно (free)

Программное создание практически всех популярных элементов формы.

06.09.2019    72759    rpgshnik    70    

Агрегатные функции СКД, о которых мало кто знает

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Пользуетесь ли Вы всеми возможными агрегатными функциями, которые предоставляет система компоновки данных? Если Вы используете только: СУММА, КОЛИЧЕСТВО, МИНИМУМ, МАКСИМУМ, СРЕДНЕЕ, то эта статья для Вас.

05.09.2019    61190    ids79    55    

Регистры бухгалтерии. Общая информация

Практика программирования Математика и алгоритмы v8 v8::БУ БУ Бесплатно (free)

Общая информация о внутреннем устройстве регистров бухгалтерии.

05.09.2019    34832    YPermitin    25    

Запись значения в поле ввода/формы со срабатыванием события ПриИзменении Промо

Практика программирования v8 1cv8.cf Россия Бесплатно (free)

Иногда возникает необходимость после записи значения в какое либо поле ввода/формы вызвать для него обработчик события ПриИзменении, а о вызове самого события приходится только мечтать. В этой статье приводится программный способ вызова этого события.

11.07.2007    50639    tormozit    48    

Три костыля. Сказ про фокусы в коде

Практика программирования v8 Бесплатно (free)

Три интересных (или странных) костыля в коде, которые могут помочь в повседневных и не очень задачах.

03.09.2019    27567    YPermitin    81    

Отслеживание выполнения фонового задания

Практика программирования Универсальные функции Разработка v8 1cv8.cf Бесплатно (free)

Запуск фонового задания из модуля внешней обработки. Отслеживание выполнения задания в виде прогресса, расположенного на форме.

17.08.2019    37870    ids79    16    

Функции СКД: ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Подробное описание и использование внутренних функций системы компоновки данных: Вычислить, ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив, ВычислитьВыражениеСГруппировкойТаблицаЗначений.

08.08.2019    114681    ids79    69    

Как сделать из &НаКлиентеНаСервереБезКонтекста почти &НаКлиентеНаСервере Промо

Практика программирования v8 1cv8.cf Россия Бесплатно (free)

Как сделать метод формы, доступный на клиенте и на сервере одновременно, и сохранить при этом удобство разработки

10.09.2017    47499    tormozit    74    

Фоновое выполнение кода в 1С - это просто

Практика программирования v8 1cv8.cf Бесплатно (free)

Как легко запускать выполнение в фоне, не прибегая к долгому описанию фоновых процедур.

02.08.2019    46809    avalakh    26    

Разбираемся с параметрами редактирования СКД

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Связь по типу, Параметры выбора, Связи параметров выбора

31.07.2019    31349    json    15    

СКД - наборы данных и связи между ними, создание собственной иерархии, вложенные отчеты

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Набор данных объект. Использование в схеме компоновки нескольких наборов данных. Различные варианты связи наборов: объединение, соединение. Использование иерархии в отчетах на СКД. Создание собственной иерархии, иерархия детальных записей. Использование вложенных схем в отчетах на СКД.

26.07.2019    81367    ids79    14    

Выгрузка документа по условию Промо

Практика программирования Разработка v8 Бесплатно (free)

Что делать, если документы нужно выгружать не все подряд, а по какому-то фильтру: статусу, дате, набору условий... А что если он соответствовал этим условиям, а потом перестал? А если потом опять начал? Такие ситуации заставили попотеть не одного программиста.

25.04.2019    16615    m-rv    2    

СКД - использование расширений языка запросов, секция ХАРАКТЕРИСТИКИ

Инструментарий разработчика Практика программирования v8 v8::СКД Бесплатно (free)

Автоматическое и не автоматическое заполнение полей компоновки данных. Использование расширений языка запросов для СКД «{…}», секция ВЫБРАТЬ, секция ГДЕ, параметры виртуальных таблиц. Автоматизированное использование дополнительных данных в запросе: секция ХАРАКТЕРИСТИКИ.

17.07.2019    41330    ids79    27    

Регистры сведений. За кулисами

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Небольшие заметки по внутреннему устройству регистров сведений.

09.07.2019    29270    YPermitin    14    

"Меньше копипаста!", или как Вася универсальную процедуру писал

Практика программирования Разработка v8 v8::СКД 1cv8.cf Бесплатно (free)

Программист Вася разбирает подход создания универсальных методов на примере программного вывода СКД.

04.07.2019    20639    SeiOkami    50    

Как прикрутить ГУИД к регистру сведений Промо

Практика программирования Перенос данных из 1C8 в 1C8 Разработка v8 Бесплатно (free)

... и немного теории обмена данными. В частности, разберем боль всех, кто пишет небанальные обмены данными: как набору записей регистра сведений назначить гуид и далее использовать его в обмене для идентификации этого набора.

16.04.2019    21219    m-rv    17    

Работа с настройками системы компоновки данных

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Варианты отчетов, работа с настройками вариантов: структура группировок, поля отчета, отборы, сортировка, условное оформление, другие настройки, настройки отображения диаграмм.

02.07.2019    63636    ids79    17    

Создание отчетов с помощью СКД - основные понятия и элементы

Практика программирования Математика и алгоритмы v8 v8::СКД Бесплатно (free)

Основные принципы работы СКД. Понятия схемы компоновки и макета компоновки. Описание основных элементов схемы компоновки: наборы данных, поля, вычисляемые поля, ресурсы, параметры.

25.06.2019    62918    ids79    26    

Многопоточное ускорение однопользовательских нагрузок в 1С + Microsoft SQL Server 2017

Практика программирования Производительность и оптимизация (HighLoad) v8 v8::Запросы Бесплатно (free)

Взаимодействие с Microsoft SQL Server нередко вызывает трудности у 1С-ников, а потому интересны любые моменты, связанные с его использованием. О своем опыте работы с новым SQL Server 2017 участникам конференции Infostart-2018 рассказал директор ООО «Аналитика софт» Дмитрий Дудин.

11.06.2019    27751    dmurk    146    

Как сделать запрос на изменение данных Промо

Практика программирования v8 v8::Запросы 1cv8.cf Бесплатно (free)

В статье приведены особенности внутренней архитектуры и примеры работы с расширением языка запросов 1С.

01.06.2018    32970    m-rv    22    

Регистры накопления. Виртуальные таблицы. Часть №2: "Остатки" и "Остатки и обороты"

Практика программирования v8 1cv8.cf Бесплатно (free)

Описание работы платформы 1С:Предприятие 8.2 с виртуальными таблицами регистров накопления "Остатки" и "Остатки и обороты". Анализ SQL-запрос при работе с виртуальными таблицами

22.05.2019    34060    YPermitin    7    

Регистры накопления. Структура хранения в базе данных

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Структура хранения регистров накопления в базе данных для платформы 1С:Предприятие 8.x. Первая часть в серии публикаций.

16.05.2019    51814    YPermitin    30    

О расширениях замолвите слово...

Практика программирования Разработка v8 Бесплатно (free)

О чём стоит задуматься при принятии решения о создании расширения конфигурации…

07.04.2019    38767    ellavs    127    

Метод формирования движений в типовых регистрах нетиповыми регистраторами Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Вариант решения задач с проведением по типовым регистрам нетиповыми регистраторами. Зачем - чтобы при сравнении конфигурации не обращать внимание на свойства регистров и исключить вероятность допущения горькой оплошности при обновлении информационных баз, заменив типы регистраторов основной конфигурации типами конфигурации поставщика. Для программных продуктов, имеющих в своем составе метаданных документ "Корректировка регистров"("Корректировка записей регистров").

05.12.2017    29013    itriot11    34    

Git-репозитории для 1С-кода (опыт использования при небольших проектах)

Практика программирования v8 Бесплатно (free)

Инструкции по взаимодействию с Git-репозиторием, которые писались для тех наших программистов, которые вообще никогда не работали с Git (руководства в духе "Как получить код из git-репозитория?", "Как отправить код в git-репозиторий")...

28.03.2019    29021    ellavs    90    

Трюки с внешними источниками данных

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Некоторые трюки для преодоления ограничений внешних источников данных.

14.03.2019    35605    YPermitin    53    

Ошибки при работе с хранилищем конфигурации и способы их решения

Практика программирования v8 Бесплатно (free)

В статье собраны наиболее распространенные ошибки при работе с хранилищем конфигурации и способы их обхода и решения.

01.03.2019    51756    Смешной 1С    31    

Использование классов .Net в 1С для новичков Промо

Практика программирования Разработка внешних компонент Универсальные функции v7.7 v8 Бесплатно (free)

Руководство для новичков. Написав статью http://infostart.ru/public/238584/, я понял, что многие не понимают того, что написано. Поэтому в этой статье постараюсь более подробно остановиться на азах и без кода на вражеском языке (C#)

27.01.2016    79076    Serginio    113    

Разработка и сценарное тестирование с Vanessa-ADD. Отчетность Allure. Автоматизация запуска сценариев

Практика программирования Vanessa Automation v8 Россия Бесплатно (free)

Формируем отчетность о результатах выполнения сценариев. Автоматизируем запуск.

26.02.2019    24929    Vladimir Litvinenko    28    

Автоматические и управляемые блокировки применительно к типовым конфигурациям 1С Промо

Математика и алгоритмы Практика программирования v8 v8::blocking 1cv8.cf Бесплатно (free)

Основные принципы работы с режимами автоматических и управляемых блокировок в 1С Предприятие 8. Теория и применение в типовых конфигурациях: БП, УТ, ЕРП

10.11.2018    38605    ids79    40