Как преобразовать Unicode в 1С

Публикация № 142092

Разработка - Практика программирования

Ох уж эти вечные проблемы с кодировкой…
Долго искал в инете как преобразователь Unicod. Потом все таки сам написал функцию.

Синтаксис:
ПереобразоватьЮникод()

Параметры:
(обязательный)
Тип: Строка.
Исходная строка.

Возвращаемое значение:
Тип: Строка.
Строка обработанных символов.

Описание:
Возвращает преобразованную строку из формата Unicod.

Доступность:
Тонкий клиент, веб-клиент, сервер, толстый клиент, внешнее соединение.

 

Функция ПереобразоватьЮникод(Строка)

    
    ГотововаяСтрока = "" ;
    
    МасУкр = Новый Массив(66) ;
    
    МасУкр[0]="А";   МасУкр[1]="Б";  МасУкр[2]="В";  МасУкр[3]="Г";  МасУкр[4]="Ґ";  МасУкр[5]="Д";
    МасУкр[6]="Е";   МасУкр[7]="Є";  МасУкр[8]="Ж";  МасУкр[9]="З";  МасУкр[10]="И"; МасУкр[11]="І";
    МасУкр[12]="Ї";  МасУкр[13]="Й"; МасУкр[14]="К"; МасУкр[15]="Л"; МасУкр[16]="М"; МасУкр[17]="Н";
    МасУкр[18]="О";  МасУкр[19]="П"; МасУкр[20]="Р"; МасУкр[21]="С"; МасУкр[22]="Т"; МасУкр[23]="У";
    МасУкр[24]="Ф";  МасУкр[25]="Х"; МасУкр[26]="Ц"; МасУкр[27]="Ч"; МасУкр[28]="Ш"; МасУкр[29]="Щ";
    МасУкр[30]="Ь";  МасУкр[31]="Ю"; МасУкр[32]="Я";  

    МасУкр[33]="а";  МасУкр[34]="б"; МасУкр[35]="в"; МасУкр[36]="г"; МасУкр[37]="ґ"; МасУкр[38]="д";
    МасУкр[39]="е";  МасУкр[40]="є"; МасУкр[41]="ж"; МасУкр[42]="з"; МасУкр[43]="и"; МасУкр[44]="і";
    МасУкр[45]="ї";  МасУкр[46]="й"; МасУкр[47]="к"; МасУкр[48]="л"; МасУкр[49]="м"; МасУкр[50]="н";
    МасУкр[51]="о";  МасУкр[52]="п"; МасУкр[53]="р"; МасУкр[54]="с"; МасУкр[55]="т"; МасУкр[56]="у";
    МасУкр[57]="ф";  МасУкр[58]="х"; МасУкр[59]="ц"; МасУкр[60]="ч"; МасУкр[61]="ш"; МасУкр[62]="щ";
    МасУкр[63]="ь";  МасУкр[31]="ю"; МасУкр[65]="я";  
        
    
    МасКод = Новый Массив(66) ;
    
    МасКод[0]="0410";   МасКод[1]="0411";  МасКод[2]="0412";  МасКод[3]="0413";  МасКод[4]="0490";  МасКод[5]="0414";
    МасКод[6]="0415";   МасКод[7]="0404";  МасКод[8]="0416";  МасКод[9]="0417";  МасКод[10]="0418"; МасКод[11]="0406";
    МасКод[12]="0407";  МасКод[13]="0419"; МасКод[14]="041A"; МасКод[15]="041B"; МасКод[16]="041C"; МасКод[17]="041D";
    МасКод[18]="041E";  МасКод[19]="041F"; МасКод[20]="0420"; МасКод[21]="0421"; МасКод[22]="0422"; МасКод[23]="0423";
    МасКод[24]="0424";  МасКод[25]="0425"; МасКод[26]="0426"; МасКод[27]="0427"; МасКод[28]="0428"; МасКод[29]="0429";
    МасКод[30]="042C";  МасКод[31]="042E"; МасКод[32]="042F";  

    МасКод[33]="0430";  МасКод[34]="0431"; МасКод[35]="0432"; МасКод[36]="0413"; МасКод[37]="0491"; МасКод[38]="0434";
    МасКод[39]="0435";  МасКод[40]="0454"; МасКод[41]="0436"; МасКод[42]="0437"; МасКод[43]="0438"; МасКод[44]="0456";
    МасКод[45]="0457";  МасКод[46]="0439"; МасКод[47]="043A"; МасКод[48]="043B"; МасКод[49]="043C"; МасКод[50]="043D";
    МасКод[51]="043E";  МасКод[52]="043F"; МасКод[53]="0440"; МасКод[54]="0441"; МасКод[55]="0442"; МасКод[56]="0443";
    МасКод[57]="0444";  МасКод[58]="0445"; МасКод[59]="0446"; МасКод[60]="0447"; МасКод[61]="0448"; МасКод[62]="0449";
    МасКод[63]="044C";  МасКод[31]="044E"; МасКод[65]="044F";  
    
    
    тмпСтрока = "" ;
    Для Счетчик = 1 По СтрДлина(Строка) Цикл      
        Если Лев(Строка, 1) = "\" Тогда
            Если Лев(Строка, 2) = "\u" Тогда
                
                тмпСтрока = Прав(Лев(Строка, 6),4) ;
                Если МасКод.Найти(тмпСтрока) = Неопределено Тогда
                    СтрокаЗамены = Прав(тмпСтрока, 1) ;
                    тмпСтрока = СтрЗаменить(тмпСтрока,СтрокаЗамены,ТРег(СтрокаЗамены)); 
                    Если МасКод.Найти(тмпСтрока) = Неопределено Тогда
                        Сообщить("Код символа не найден: " + тмпСтрока) ;
                    Иначе                      
                        ГотововаяСтрока = ГотововаяСтрока + МасУкр[МасКод.Найти(тмпСтрока)] ;                                   
                    КонецЕсли;
                Иначе
                    ГотововаяСтрока = ГотововаяСтрока + МасУкр[МасКод.Найти(тмпСтрока)] ;               
                КонецЕсли;
                
                Строка = Прав(Строка, (СтрДлина(Строка)-6)) ; 
            Иначе  
                Строка = Прав(Строка, (СтрДлина(Строка)-2)) ;
            КонецЕсли;
        Иначе
            ГотововаяСтрока = ГотововаяСтрока + Лев(Строка, 1) ;
            Строка = Прав(Строка, (СтрДлина(Строка)-1)) ;     
        КонецЕсли;         
    КонецЦикла;   

    Возврат ГотововаяСтрока ;
        
КонецФункции

 

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
0. treedo 117 03.07.12 10:11 Сейчас в теме
Ох уж эти вечные проблемы с кодировкой…
Долго искал в инете как преобразователь Unicod. Потом все таки сам написал функцию.



Перейти к публикации

1. Serj1C 479 03.07.12 12:51 Сейчас в теме
А можно было так?
Записать текстовый документ в кодировке Юникод, а потом его прочитать в кодировке Анси?
2. treedo 117 03.07.12 13:49 Сейчас в теме
3. treedo 117 03.07.12 13:54 Сейчас в теме
Способ называеццо: "Против лома, нет ..."
4. alexk-is 6470 03.07.12 16:37 Сейчас в теме
Мне кажется, что следующий код будет работать побыстрее
КлючИЗначение = Соответствие.Получить(тмпСтрока);
Если КлючИЗначение = Неопределено Тогда
    ....
Иначе
    ГотововаяСтрока = ГотововаяСтрока + КлючИЗначение.Значение;               
КонецЕсли;
5. treedo 117 03.07.12 19:58 Сейчас в теме
6. alexk-is 6470 03.07.12 20:42 Сейчас в теме
(5) А здесь написано, что точно будет быстрее. :)
7. slavik27 14 27.06.13 08:23 Сейчас в теме
спасибо, хороший пример, только жалко с русскими символами нет
8. tolick 36 10.11.15 13:24 Сейчас в теме
9. 314r 16.02.16 14:40 Сейчас в теме
Вот вариант с русскими буквами. Вдруг кому-то понадобиться :)

Функция ПреобразоватьЮникод(Строка)
    
    МасКир = Новый Массив(66);
	МасКод = Новый Массив(66);
   
МасКир[0]="А";	МасКод[0]="0410";
МасКир[1]="а";	МасКод[1]="0430";
МасКир[2]="Б";	МасКод[2]="0411";
МасКир[3]="б";	МасКод[3]="0431";
МасКир[4]="В";	МасКод[4]="0412";
МасКир[5]="в";	МасКод[5]="0432";
МасКир[6]="Г";	МасКод[6]="0413";
МасКир[7]="г";	МасКод[7]="0433";
МасКир[8]="Д";	МасКод[8]="0414";
МасКир[9]="д";	МасКод[9]="0434";
МасКир[10]="Е";	МасКод[10]="0415";
МасКир[11]="е";	МасКод[11]="0435";
МасКир[12]="Ё";	МасКод[12]="0401";
МасКир[13]="ё";	МасКод[13]="0451";
МасКир[14]="Ж";	МасКод[14]="0416";
МасКир[15]="ж";	МасКод[15]="0436";
МасКир[16]="З";	МасКод[16]="0417";
МасКир[17]="з";	МасКод[17]="0437";
МасКир[18]="И";	МасКод[18]="0418";
МасКир[19]="и";	МасКод[19]="0438";
МасКир[20]="Й";	МасКод[20]="0419";
МасКир[21]="й";	МасКод[21]="0439";
МасКир[22]="К";	МасКод[22]="041a";
МасКир[23]="к";	МасКод[23]="043a";
МасКир[24]="Л";	МасКод[24]="041b";
МасКир[25]="л";	МасКод[25]="043b";
МасКир[26]="М";	МасКод[26]="041c";
МасКир[27]="м";	МасКод[27]="043c";
МасКир[28]="Н";	МасКод[28]="041d";
МасКир[29]="н";	МасКод[29]="043d";
МасКир[30]="О";	МасКод[30]="041e";
МасКир[31]="о";	МасКод[31]="043e";
МасКир[32]="П";	МасКод[32]="041f";
МасКир[33]="п";	МасКод[33]="043f";
МасКир[34]="Р";	МасКод[34]="0420";
МасКир[35]="р";	МасКод[35]="0440";
МасКир[36]="С";	МасКод[36]="0421";
МасКир[37]="с";	МасКод[37]="0441";
МасКир[38]="Т";	МасКод[38]="0422";
МасКир[39]="т";	МасКод[39]="0442";
МасКир[40]="У";	МасКод[40]="0423";
МасКир[41]="у";	МасКод[41]="0443";
МасКир[42]="Ф";	МасКод[42]="0424";
МасКир[43]="ф";	МасКод[43]="0444";
МасКир[44]="Х";	МасКод[44]="0425";
МасКир[45]="х";	МасКод[45]="0445";
МасКир[46]="Ц";	МасКод[46]="0426";
МасКир[47]="ц";	МасКод[47]="0446";
МасКир[48]="Ч";	МасКод[48]="0427";
МасКир[49]="ч";	МасКод[49]="0447";
МасКир[50]="Ш";	МасКод[50]="0428";
МасКир[51]="ш";	МасКод[51]="0448";
МасКир[52]="Щ";	МасКод[52]="0429";
МасКир[53]="щ";	МасКод[53]="0449";
МасКир[54]="Ъ";	МасКод[54]="042a";
МасКир[55]="ъ";	МасКод[55]="044a";
МасКир[56]="Ы";	МасКод[56]="042b";
МасКир[57]="ы";	МасКод[57]="044b";
МасКир[58]="Ь";	МасКод[58]="042c";
МасКир[59]="ь";	МасКод[59]="044c";
МасКир[60]="Э";	МасКод[60]="042d";
МасКир[61]="э";	МасКод[61]="044d";
МасКир[62]="Ю";	МасКод[62]="042e";
МасКир[63]="ю";	МасКод[63]="044e";
МасКир[64]="Я";	МасКод[64]="042f";
МасКир[65]="я";	МасКод[65]="044f";

	ParsedString = Строка;
	Flag = 1;
	
	Пока (Flag = 1) Цикл
		
	PositionOfUnicodeStart = Найти(ParsedString, "\u");
		
	
		Если PositionOfUnicodeStart > 0 тогда
		UnicodeSymbol = Сред(ParsedString, PositionOfUnicodeStart +2, 4);	
		
		FullUnicodeSymbol = "\u" + UnicodeSymbol;
		
		Index = МасКод.Найти(UnicodeSymbol);
			Если Index = Неопределено тогда
			ParsedString = СтрЗаменить(ParsedString, FullUnicodeSymbol, "?UNICODE?");
			Сообщить("Найден неизвестный символ - " + FullUnicodeSymbol); 
			Иначе
			ParsedString = СтрЗаменить(ParsedString, FullUnicodeSymbol, МасКир[Index]);
			КонецЕсли;
				
		Иначе 
		Flag = 0;
		
		КонецЕсли;
					
	КонецЦикла;
	
	Возврат ParsedString;	
КонецФункции
Показать
KatrinNight; AKZARD; PASAHAKA; AskezaMax; itc_Geo; +5 Ответить
12. sevenlis 68 02.03.19 09:15 Сейчас в теме
(9)
А вот то же самое, только через ТЗ и для 7.7
Функция ПреобразоватьИзЮникод(пСтрока) Экспорт
	тзСимв = СоздатьОбъект("ТаблицаЗначений");
	тзСимв.НоваяКолонка("Кир","Строка",1);
	тзСимв.НоваяКолонка("Код","Строка",4);
	
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "А"; 	тзСимв.Код = "0410";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "а"; 	тзСимв.Код = "0430";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "Б"; 	тзСимв.Код = "0411";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "б"; 	тзСимв.Код = "0431";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "В"; 	тзСимв.Код = "0412";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "в"; 	тзСимв.Код = "0432";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "Г"; 	тзСимв.Код = "0413";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "г"; 	тзСимв.Код = "0433";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "Д"; 	тзСимв.Код = "0414";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "д"; 	тзСимв.Код = "0434";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "Е"; 	тзСимв.Код = "0415";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "е"; 	тзСимв.Код = "0435";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "Ё"; 	тзСимв.Код = "0401";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "ё"; 	тзСимв.Код = "0451";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "Ж"; 	тзСимв.Код = "0416";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "ж"; 	тзСимв.Код = "0436";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "З"; 	тзСимв.Код = "0417";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "з"; 	тзСимв.Код = "0437";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "И"; 	тзСимв.Код = "0418";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "и"; 	тзСимв.Код = "0438";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "Й"; 	тзСимв.Код = "0419";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "й"; 	тзСимв.Код = "0439";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "К"; 	тзСимв.Код = "041a";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "к"; 	тзСимв.Код = "043a";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "Л"; 	тзСимв.Код = "041b";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "л"; 	тзСимв.Код = "043b";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "М"; 	тзСимв.Код = "041c";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "м"; 	тзСимв.Код = "043c";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "Н"; 	тзСимв.Код = "041d";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "н"; 	тзСимв.Код = "043d";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "О"; 	тзСимв.Код = "041e";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "о"; 	тзСимв.Код = "043e";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "П"; 	тзСимв.Код = "041f";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "п"; 	тзСимв.Код = "043f";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "Р"; 	тзСимв.Код = "0420";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "р"; 	тзСимв.Код = "0440";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "С"; 	тзСимв.Код = "0421";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "с"; 	тзСимв.Код = "0441";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "Т"; 	тзСимв.Код = "0422";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "т"; 	тзСимв.Код = "0442";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "У"; 	тзСимв.Код = "0423";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "у"; 	тзСимв.Код = "0443";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "Ф"; 	тзСимв.Код = "0424";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "ф"; 	тзСимв.Код = "0444";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "Х"; 	тзСимв.Код = "0425";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "х"; 	тзСимв.Код = "0445";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "Ц"; 	тзСимв.Код = "0426";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "ц"; 	тзСимв.Код = "0446";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "Ч"; 	тзСимв.Код = "0427";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "ч"; 	тзСимв.Код = "0447";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "Ш"; 	тзСимв.Код = "0428";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "ш"; 	тзСимв.Код = "0448";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "Щ"; 	тзСимв.Код = "0429";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "щ"; 	тзСимв.Код = "0449";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "Ъ"; 	тзСимв.Код = "042a";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "ъ"; 	тзСимв.Код = "044a";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "Ы"; 	тзСимв.Код = "042b";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "ы"; 	тзСимв.Код = "044b";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "Ь"; 	тзСимв.Код = "042c";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "ь"; 	тзСимв.Код = "044c";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "Э"; 	тзСимв.Код = "042d";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "э"; 	тзСимв.Код = "044d";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "Ю"; 	тзСимв.Код = "042e";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "ю"; 	тзСимв.Код = "044e";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "Я"; 	тзСимв.Код = "042f";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "я"; 	тзСимв.Код = "044f";
	
	ParsedString = пСтрока;
	
	PositionOfUnicodeStart = Найти(ParsedString, "\u");
	Пока PositionOfUnicodeStart > 0 Цикл
		UnicodeSymbol 			= Сред(ParsedString, PositionOfUnicodeStart + 2, 4);    
		FullUnicodeSymbol 		= "\u" + UnicodeSymbol;
		
		Index = 0; тзСимв.НайтиЗначение(UnicodeSymbol,Index,"Код");
		Если Index = 0 Тогда
			ParsedString = СтрЗаменить(ParsedString, FullUnicodeSymbol, "?");
			Сообщить("Найден неизвестный символ - " + FullUnicodeSymbol); 
		Иначе
			ParsedString = СтрЗаменить(ParsedString, FullUnicodeSymbol, тзСимв.ПолучитьЗначение(Index,"Кир"));
		КонецЕсли;
		
		PositionOfUnicodeStart 	= Найти(ParsedString, "\u");
	КонецЦикла;
	
	Возврат ParsedString;    
КонецФункции

Показать
10. Buben-128 12.09.16 11:26 Сейчас в теме
Во народ жжот ))))
Удаление зубов через противоположный проход - это круто (наверно)!

Если "напрямую", можно так:

//Пример строки с юникодом
//{"NAME":"\u0421\u043a\u0438\u0434\u043a\u0430 \u043e\u0442 \u043c\u0435\u043d\u0435\u0434\u0436\u0435\u0440\u0430 \u041f\u041f - 5%","COUPON":"SL-4IFEJ-S4LCPZB"}

	ЧтениеJSON = Новый ЧтениеJSON;
	ЧтениеJSON.УстановитьСтроку(StrJason);
	Пока ЧтениеJSON.Прочитать() Цикл
		Попытка
			Сообщить("Параметр "+ЧтениеJSON.ТекущееЗначение); 
		Исключение			
		КонецПопытки	
	КонецЦикла;
Показать
echo77; Alien_job; zadevil; +3 Ответить
11. treedo 117 12.09.16 12:01 Сейчас в теме
(10) Buben-128, Статья писалась когда в платформе не было полноценной реализации JSON. Если ваш код рабочий, он намного эффективней и проще.
14. Nikola23 511 17.06.20 09:47 Сейчас в теме
13. Alien_job 175 24.06.19 13:56 Сейчас в теме
Оставьте свое сообщение

См. также

Использование программных перечислений, ч.1: строковые константы Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Часто ли у вас возникает необходимость в коде выполнять сравнение на строку?

10.12.2016    36808    unichkin    46    

Программная работа с настройками СКД

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Нюансы программной работы с настройками системы компоновки данных в отчетах и динамических списках. Обзор всех видов настроек компоновки. Что в каких случаях правильно применять. В качестве примера рассмотрена работа с отборами и группировками.

27.01.2020    22096    ids79    26    

[СКД] Программное создание схемы компоновки данных

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Сделаем отчет на СКД полностью программно, без использования макета "схема компоновки данных".

15.01.2020    20599    John_d    22    

Последовательности событий. Шпаргалка

Практика программирования v8 Россия Бесплатно (free)

Собрал информацию о событиях/подписках/расширениях в одном месте.

30.12.2019    15382    kuzyara    33    

Вспомогательные инструкции в коде 1С Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Помогаем редактору кода 1С помогать нам писать и анализировать код.

15.10.2018    29324    tormozit    100    

30 задач. Странных и не очень

Практика программирования v8 Бесплатно (free)

30 задач на знание языка программирования 1С и некоторого поведения платформы. Маленьких. Странных и не очень.

02.12.2019    16272    YPermitin    72    

Как передать IP адрес, который вызвал HTTP запрос в 1C (для веб-сервера Apache)

Практика программирования v8 Бесплатно (free)

Столкнулся с задачей получения IP адреса, который вызывает http сервис 1С. Итак, решение:

22.11.2019    7879    Sibars    19    

Таблица значений. Нюансы

Практика программирования v8 Бесплатно (free)

Обзор некоторых аспектов использования общеизвестного инструмента 1С.

01.10.2019    30265    Yashazz    49    

Оформление и рефакторинг сложных логических выражений Промо

Практика программирования v8 Россия Бесплатно (free)

В сложных логических выражениях нередко самому автору спустя какое-то время тяжело разобраться, не говоря уже о других программистах. Предлагаемая методика позволяет повысить наглядность таких выражений путем оформления в виде И-ИЛИ дерева и одновременно выполнять их рефакторинг.

20.09.2012    77207    tormozit    131    

[Шпаргалка] Программное создание элементов формы

Практика программирования Работа с интерфейсом v8 1cv8.cf Бесплатно (free)

Программное создание практически всех популярных элементов формы.

06.09.2019    43765    rpgshnik    63    

Агрегатные функции СКД, о которых мало кто знает

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Пользуетесь ли Вы всеми возможными агрегатными функциями, которые предоставляет система компоновки данных? Если Вы используете только: СУММА, КОЛИЧЕСТВО, МИНИМУМ, МАКСИМУМ, СРЕДНЕЕ, то эта статья для Вас.

05.09.2019    45375    ids79    54    

Регистры бухгалтерии. Общая информация

Практика программирования Математика и алгоритмы v8 v8::БУ БУ Бесплатно (free)

Общая информация о внутреннем устройстве регистров бухгалтерии.

05.09.2019    26184    YPermitin    24    

Запись значения в поле ввода/формы со срабатыванием события ПриИзменении Промо

Практика программирования v8 1cv8.cf Россия Бесплатно (free)

Иногда возникает необходимость после записи значения в какое либо поле ввода/формы вызвать для него обработчик события ПриИзменении, а о вызове самого события приходится только мечтать. В этой статье приводится программный способ вызова этого события.

11.07.2007    47505    tormozit    40    

Три костыля. Сказ про фокусы в коде

Практика программирования v8 Бесплатно (free)

Три интересных (или странных) костыля в коде, которые могут помочь в повседневных и не очень задачах.

03.09.2019    24841    YPermitin    80    

Отслеживание выполнения фонового задания

Практика программирования Универсальные функции Разработка v8 1cv8.cf Бесплатно (free)

Запуск фонового задания из модуля внешней обработки. Отслеживание выполнения задания в виде прогресса, расположенного на форме.

17.08.2019    30085    ids79    16    

Функции СКД: ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Подробное описание и использование внутренних функций системы компоновки данных: Вычислить, ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив, ВычислитьВыражениеСГруппировкойТаблицаЗначений.

08.08.2019    72202    ids79    49    

Как сделать из &НаКлиентеНаСервереБезКонтекста почти &НаКлиентеНаСервере Промо

Практика программирования v8 1cv8.cf Россия Бесплатно (free)

Как сделать метод формы, доступный на клиенте и на сервере одновременно, и сохранить при этом удобство разработки

10.09.2017    43834    tormozit    74    

Фоновое выполнение кода в 1С - это просто

Практика программирования v8 1cv8.cf Бесплатно (free)

Как легко запускать выполнение в фоне, не прибегая к долгому описанию фоновых процедур.

02.08.2019    31595    avalakh    22    

Разбираемся с параметрами редактирования СКД

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Связь по типу, Параметры выбора, Связи параметров выбора

31.07.2019    21616    json    13    

СКД - наборы данных и связи между ними, создание собственной иерархии, вложенные отчеты

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Набор данных объект. Использование в схеме компоновки нескольких наборов данных. Различные варианты связи наборов: объединение, соединение. Использование иерархии в отчетах на СКД. Создание собственной иерархии, иерархия детальных записей. Использование вложенных схем в отчетах на СКД.

26.07.2019    53347    ids79    11    

Выгрузка документа по условию Промо

Практика программирования Разработка v8 Бесплатно (free)

Что делать, если документы нужно выгружать не все подряд, а по какому-то фильтру: статусу, дате, набору условий... А что если он соответствовал этим условиям, а потом перестал? А если потом опять начал? Такие ситуации заставили попотеть не одного программиста.

25.04.2019    15850    m-rv    2    

СКД - использование расширений языка запросов, секция ХАРАКТЕРИСТИКИ

Инструментарий разработчика Практика программирования v8 v8::СКД Бесплатно (free)

Автоматическое и не автоматическое заполнение полей компоновки данных. Использование расширений языка запросов для СКД «{…}», секция ВЫБРАТЬ, секция ГДЕ, параметры виртуальных таблиц. Автоматизированное использование дополнительных данных в запросе: секция ХАРАКТЕРИСТИКИ.

17.07.2019    33833    ids79    27    

Регистры сведений. За кулисами

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Небольшие заметки по внутреннему устройству регистров сведений.

09.07.2019    25139    YPermitin    14    

"Меньше копипаста!", или как Вася универсальную процедуру писал

Практика программирования Разработка v8 v8::СКД 1cv8.cf Бесплатно (free)

Программист Вася разбирает подход создания универсальных методов на примере программного вывода СКД.

04.07.2019    19297    SeiOkami    50    

Как прикрутить ГУИД к регистру сведений Промо

Практика программирования Перенос данных из 1C8 в 1C8 Разработка v8 Бесплатно (free)

... и немного теории обмена данными. В частности, разберем боль всех, кто пишет небанальные обмены данными: как набору записей регистра сведений назначить гуид и далее использовать его в обмене для идентификации этого набора.

16.04.2019    19865    m-rv    17    

Работа с настройками системы компоновки данных

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Варианты отчетов, работа с настройками вариантов: структура группировок, поля отчета, отборы, сортировка, условное оформление, другие настройки, настройки отображения диаграмм.

02.07.2019    41743    ids79    17    

Создание отчетов с помощью СКД - основные понятия и элементы

Практика программирования Математика и алгоритмы v8 v8::СКД Бесплатно (free)

Основные принципы работы СКД. Понятия схемы компоновки и макета компоновки. Описание основных элементов схемы компоновки: наборы данных, поля, вычисляемые поля, ресурсы, параметры.

25.06.2019    48924    ids79    25    

Многопоточное ускорение однопользовательских нагрузок в 1С + Microsoft SQL Server 2017

Практика программирования Производительность и оптимизация (HighLoad) v8 v8::Запросы Бесплатно (free)

Взаимодействие с Microsoft SQL Server нередко вызывает трудности у 1С-ников, а потому интересны любые моменты, связанные с его использованием. О своем опыте работы с новым SQL Server 2017 участникам конференции Infostart-2018 рассказал директор ООО «Аналитика софт» Дмитрий Дудин.

11.06.2019    23933    dmurk    144    

Как сделать запрос на изменение данных Промо

Практика программирования v8 v8::Запросы 1cv8.cf Бесплатно (free)

В статье приведены особенности внутренней архитектуры и примеры работы с расширением языка запросов 1С.

01.06.2018    29974    m-rv    21    

Регистры накопления. Виртуальные таблицы. Часть №2: "Остатки" и "Остатки и обороты"

Практика программирования v8 1cv8.cf Бесплатно (free)

Описание работы платформы 1С:Предприятие 8.2 с виртуальными таблицами регистров накопления "Остатки" и "Остатки и обороты". Анализ SQL-запрос при работе с виртуальными таблицами

22.05.2019    22043    YPermitin    7    

Регистры накопления. Структура хранения в базе данных

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Структура хранения регистров накопления в базе данных для платформы 1С:Предприятие 8.x. Первая часть в серии публикаций.

16.05.2019    40420    YPermitin    30    

Выполнение внешней обработки в фоновом задании

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Подробное описание подхода к созданию длительной операции на основе внешней обработки. Реализация протестирована на 1С 8.3.12.1714 (x64).

11.05.2019    28414    Eret1k    23    

Метод формирования движений в типовых регистрах нетиповыми регистраторами Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Вариант решения задач с проведением по типовым регистрам нетиповыми регистраторами. Зачем - чтобы при сравнении конфигурации не обращать внимание на свойства регистров и исключить вероятность допущения горькой оплошности при обновлении информационных баз, заменив типы регистраторов основной конфигурации типами конфигурации поставщика. Для программных продуктов, имеющих в своем составе метаданных документ "Корректировка регистров"("Корректировка записей регистров").

05.12.2017    27995    itriot11    34    

О расширениях замолвите слово...

Практика программирования Разработка v8 Бесплатно (free)

О чём стоит задуматься при принятии решения о создании расширения конфигурации…

07.04.2019    34247    ellavs    126    

Git-репозитории для 1С-кода (опыт использования при небольших проектах)

Практика программирования v8 Бесплатно (free)

Инструкции по взаимодействию с Git-репозиторием, которые писались для тех наших программистов, которые вообще никогда не работали с Git (руководства в духе "Как получить код из git-репозитория?", "Как отправить код в git-репозиторий")...

28.03.2019    26539    ellavs    88    

Трюки с внешними источниками данных

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Некоторые трюки для преодоления ограничений внешних источников данных.

14.03.2019    30388    YPermitin    53    

Использование классов .Net в 1С для новичков Промо

Практика программирования Разработка внешних компонент Универсальные функции v7.7 v8 Бесплатно (free)

Руководство для новичков. Написав статью http://infostart.ru/public/238584/, я понял, что многие не понимают того, что написано. Поэтому в этой статье постараюсь более подробно остановиться на азах и без кода на вражеском языке (C#)

27.01.2016    75483    Serginio    108    

Ошибки при работе с хранилищем конфигурации и способы их решения

Практика программирования v8 Бесплатно (free)

В статье собраны наиболее распространенные ошибки при работе с хранилищем конфигурации и способы их обхода и решения.

01.03.2019    36034    Смешной 1С    27    

Разработка и сценарное тестирование с Vanessa-ADD. Отчетность Allure. Автоматизация запуска сценариев

Практика программирования Vanessa Automation v8 Россия Бесплатно (free)

Формируем отчетность о результатах выполнения сценариев. Автоматизируем запуск.

26.02.2019    20963    Vladimir Litvinenko    27    

Автоматические и управляемые блокировки применительно к типовым конфигурациям 1С Промо

Математика и алгоритмы Практика программирования v8 v8::blocking 1cv8.cf Бесплатно (free)

Основные принципы работы с режимами автоматических и управляемых блокировок в 1С Предприятие 8. Теория и применение в типовых конфигурациях: БП, УТ, ЕРП

10.11.2018    33699    ids79    40    

Возможности типовых шаблонов ограничения доступа на уровне записей (RLS)

Практика программирования БСП (Библиотека стандартных подсистем) Роли и права v8 v8::Права Бесплатно (free)

Краткий обзор применения типовых шаблонов ограничения доступа на уровне записей в конфигурациях, созданных на базе БСП: #ПоЗначениям, #ПоНаборамЗначений, #ПоЗначениямРасширенный, #ПоЗначениямИНаборамРасширенный

03.02.2019    36913    ids79    9    

Тестер: частые вопросы Промо

Практика программирования v8 Бесплатно (free)

Ошибкам бой - тесты норма жизни!

25.07.2018    28882    grumagargler    28    

EnterpriseData – часть 2. Процесс выгрузки данных

Практика программирования Обмен через XML v8 v8::УФ Россия Бесплатно (free)

Основные этапы выгрузки данных через ED, обработчики событий выгрузки, правила обработки данных, правила конвертации объектов, конвертация свойств первого и второго этапов, процедуры БСП, используемые при выгрузке данных, структура «КомпонентыОбмена».

26.12.2018    25766    ids79    31    

Новый подход к обмену данными EnterpriseData

Практика программирования Обмен через XML v8 v8::УФ Россия Бесплатно (free)

Хочу предложить Вашему вниманию цикл статей, посвященных обмену данными через универсальный формат (EnterpriseData или ED).

14.12.2018    39563    ids79    72    

EnterpriseData - пример доработки правил конвертации без использования КД 3.0 в расширении конфигурации

Практика программирования Обмен через XML v8 v8::УФ БП3.0 УТ11 Россия Бесплатно (free)

В статье подробно описан реальный пример доработки обмена данными через EnterpriseData (универсальный формат обмена) между конфигурациями УТ 11.4 и Бухгалтерия 3.0

16.11.2018    35880    ids79    40    

Ускоряем 1С: модули с повторным использованием возвращаемых значений Промо

Практика программирования v8 Бесплатно (free)

По роду своей деятельности, мне часто приходится обсуждать с программистами детали реализации той или иной функциональности. Очень часто, разговаривая даже с квалифицированными специалистами я сталкиваюсь с незнанием сути платформенной функциональности Повторного использования возвращаемых значений общих модулей. В данной статье я постараюсь дать краткий обзор и основные особенности этой функциональности.

04.09.2017    51797    m-rv    61    

Программное заполнение пользовательских параметров и отборов СКД

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Публикация представляет из себя краткие примеры того, как можно заполнять параметры СКД программно так, чтобы все параметры и отборы были доступны в быстрых настройках и в обычных (типовых) настройках параметров и отборов СКД.

13.11.2018    44070    Unk92    21