СКД: скрываем нужные группы (блоки) по требованию пользователя

Публикация № 1479603 14.07.21

Разработка - Практика программирования

СКД отчёт параметры ПриКомпоновкеРезультата

Видимость блоков в определённой группе, регулируемая пользователем в отчёте СКД.

Цель: реализовать возможность скрывать блок колонок пользователем в отчёте, как показано на рисунках:

 

 

Отчёт выполнен на базе схемы компоновки данных (СКД).

Написан запрос, для выборки нужных данных. Он индивидуален, поэтому его нет смысла представлять.

Описание самого "увлекательного" процесса настройки СКД представлено ниже.

В параметры СКД вынесены необходимые параметры:

 


В данном случае, - Аналитика, ОбъектЭксплуатации и Управленческий. 

В настройках СКД отчёт состоит из двух группировок: дополнительной информации и детальных записей.
В дополнительной информации выводится заголовок отчёта, а в детальных записях - его данные.
Обратим внимание, что в настройках отчёта необходимо вывести параметры: Аналитика, Объект эксплуатации и Управленческие аналитики.

Это показана на рисунке:

 

 

 Зададим первоначальные значения этих параметров. В нашем случае, значение принимает следующий вид: "Ложь".

В детальных записях (вкладка Выбранные поля) выведены колонки отчёта и созданы группы, которые, в зависимости от выбранных пользователем параметров, будут выводиться в отчёт:

 

 

Не забываем, что эти параметры необходимо включить в пользовательские настройки:

 

 

На этом "увлекательный" процесс закончен. Перейдём к написанию кода для реализации скрытия нужных блоков (полный текст процедур можно найти после описания).

Достаточно много времени заняла отладка кода, чтобы попасть в нужный блок и установить свойство "Использование".
Все манипуляции будут проходить в модуле объекта отчёта, в процедуре "ПриКомпоновкеРезультата".


Итак, что мы делаем:

1) получаем пользовательские настройки элементов и структуры отчёта

ПараметрыОтчета_ЗначениеПараметраНастроекКомпоновкиДанных = КомпоновщикНастроек.ПользовательскиеНастройки.Элементы;
ПараметрыОтчета_ГруппировкаКомпоновкиДанных = КомпоновщикНастроек.Настройки.Структура;

2) создаём параметры видимости колонок

ПараметрАналитика = Новый ПараметрКомпоновкиДанных("Аналитика");
ПараметрОбъект = Новый ПараметрКомпоновкиДанных("ОбъектЭксплуатации");
ПараметрУправленческий = Новый ПараметрКомпоновкиДанных("Управленческий");

3) для удобства отладки вынесли названия выводимых заголовков (блоков)     

ЗаголовокВыводимойКолонкиАналитики = "Аналитика";
ЗаголовокВыводимойКолонкиОбъект = "ОбъектЭксплуатации";
ЗаголовокВыводимойКолонкиУправленческий = "УправленческиеАналитики";


    
4) перебираем параметры отчёта, получаем текущие значения видимости и обращаемся именно к нужному блоку отчёта с детальными записями. Если выбираемый блок относится к группе с заголовком "Расшифровки", а именно в этом блоке содержатся скрываемые колонки, то применяем процедуру "ОтображениеБлокаКолонок" для манипуляций с видимостью
 

   Для каждого ПараметрОтчетаКД Из ПараметрыОтчета_ЗначениеПараметраНастроекКомпоновкиДанных Цикл
        ВидимостьАналитика         =    ПараметрыОтчета_ЗначениеПараметраНастроекКомпоновкиДанных.Получить(4).Значение;
        ВидимостьОбъект         =     ПараметрыОтчета_ЗначениеПараметраНастроекКомпоновкиДанных.Получить(5).Значение;
        ВидимостьУправленческий =     ПараметрыОтчета_ЗначениеПараметраНастроекКомпоновкиДанных.Получить(6).Значение;
        Если ТипЗнч(ПараметрОтчетаКД) = Тип("ЗначениеПараметраНастроекКомпоновкиДанных") И  ПараметрОтчетаКД.Параметр = ПараметрАналитика Тогда 
            Для каждого ПараметрОтчетаГруппировка ИЗ ПараметрыОтчета_ГруппировкаКомпоновкиДанных Цикл
                Если ТипЗнч(ПараметрОтчетаГруппировка) = Тип("ГруппировкаКомпоновкиДанных") И ПараметрОтчетаГруппировка.Имя = "Данные" Тогда
                    Для Каждого ЭлементыПараметров Из ПараметрОтчетаГруппировка.Выбор.Элементы Цикл
                        Если ЭлементыПараметров.Заголовок = "Расшифровки" Тогда
                                ОтображениеБлокаКолонок(ПараметрАналитика,ЗаголовокВыводимойКолонкиАналитики,ВидимостьАналитика,ЭлементыПараметров.Элементы[0]);
                                ОтображениеБлокаКолонок(ПараметрОбъект,ЗаголовокВыводимойКолонкиОбъект,ВидимостьОбъект,ЭлементыПараметров.Элементы[1]);
                                ОтображениеБлокаКолонок(ПараметрУправленческий,ЗаголовокВыводимойКолонкиУправленческий,ВидимостьУправленческий,ЭлементыПараметров.Элементы[2]);
                            
                        КонецЕсли;
                    КонецЦикла;    
                КонецЕсли;
            КонецЦикла;
        КонецЕсли;
    КонецЦикла;


5) манипуляции с видимостью заключаются в том, что в зависимости от установленного значения параметра видимости, свойство "Использование" принимает необходимое значение.

Процедура ОтображениеБлокаКолонок(Параметр,Заголовок,ВидимостьКолонки,ЭлементыПараметров)
    //для выбранной колонки отключаем использование
    Если ЭлементыПараметров.Заголовок=Заголовок Тогда 
        ЭлементыПараметров.Использование = ВидимостьКолонки;
    Иначе
        ЭлементыПараметров.Использование = НЕ ВидимостьКолонки;
    КонецЕсли;
КонецПроцедуры

На этом всё!

 

Полный код реализации:
 

Процедура ПриКомпоновкеРезультата(ДокументРезультат, ДанныеРасшифровки, СтандартнаяОбработка)
    
    ПараметрыОтчета_ЗначениеПараметраНастроекКомпоновкиДанных = КомпоновщикНастроек.ПользовательскиеНастройки.Элементы;
    ПараметрыОтчета_ГруппировкаКомпоновкиДанных = КомпоновщикНастроек.Настройки.Структура;
    
    //параметры для видимости колонок
    ПараметрАналитика = Новый ПараметрКомпоновкиДанных("Аналитика");
    ПараметрОбъект = Новый ПараметрКомпоновкиДанных("ОбъектЭксплуатации");
    ПараметрУправленческий = Новый ПараметрКомпоновкиДанных("Управленческий");
    
    //названия выводимых колонок в отчёте
    ЗаголовокВыводимойКолонкиАналитики = "АналитикаПоСтанциям";
    ЗаголовокВыводимойКолонкиОбъект = "ОбъектЭксплуатации";
    ЗаголовокВыводимойКолонкиУправленческий = "УправленческиеАналитики";
    
    
    Для каждого ПараметрОтчетаКД Из ПараметрыОтчета_ЗначениеПараметраНастроекКомпоновкиДанных Цикл
        ВидимостьАналитика         =    ПараметрыОтчета_ЗначениеПараметраНастроекКомпоновкиДанных.Получить(4).Значение;
        ВидимостьОбъект         =     ПараметрыОтчета_ЗначениеПараметраНастроекКомпоновкиДанных.Получить(5).Значение;
        ВидимостьУправленческий =     ПараметрыОтчета_ЗначениеПараметраНастроекКомпоновкиДанных.Получить(6).Значение;
        Если ТипЗнч(ПараметрОтчетаКД) = Тип("ЗначениеПараметраНастроекКомпоновкиДанных") И  ПараметрОтчетаКД.Параметр = ПараметрАналитика Тогда 
            Для каждого ПараметрОтчетаГруппировка ИЗ ПараметрыОтчета_ГруппировкаКомпоновкиДанных Цикл
                Если ТипЗнч(ПараметрОтчетаГруппировка) = Тип("ГруппировкаКомпоновкиДанных") И ПараметрОтчетаГруппировка.Имя = "Данные" Тогда
                    Для Каждого ЭлементыПараметров Из ПараметрОтчетаГруппировка.Выбор.Элементы Цикл
                        Если ЭлементыПараметров.Заголовок = "Расшифровки" Тогда
                                ОтображениеБлокаКолонок(ПараметрАналитика,ЗаголовокВыводимойКолонкиАналитики,ВидимостьАналитика,ЭлементыПараметров.Элементы[0]);
                                ОтображениеБлокаКолонок(ПараметрОбъект,ЗаголовокВыводимойКолонкиОбъект,ВидимостьОбъект,ЭлементыПараметров.Элементы[1]);
                                ОтображениеБлокаКолонок(ПараметрУправленческий,ЗаголовокВыводимойКолонкиУправленческий,ВидимостьУправленческий,ЭлементыПараметров.Элементы[2]);
                            
                        КонецЕсли;
                    КонецЦикла;    
                КонецЕсли;
            КонецЦикла;
        КонецЕсли;
    КонецЦикла;
КонецПроцедуры

Процедура ОтображениеБлокаКолонок(Параметр,Заголовок,ВидимостьКолонки,ЭлементыПараметров)
    //для выбранной колонки отключаем использование
    Если ЭлементыПараметров.Заголовок=Заголовок Тогда 
        ЭлементыПараметров.Использование = ВидимостьКолонки;
    Иначе
        ЭлементыПараметров.Использование = НЕ ВидимостьКолонки;
    КонецЕсли;
КонецПроцедуры

 

Комментарии, пожелания приветствуются!

С уважением, Оля-ля.

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. the1 912 15.07.21 11:25 Сейчас в теме
Я по другому делаю, если нужно скрыть какие-либо группировки - добавляю в пользовательские настройки
Прикрепленные файлы:
ixijixi; DrAku1a; echo77; olja-ljaaa; +4 Ответить
3. olja-ljaaa 16 15.07.21 12:19 Сейчас в теме
(1)
Здравствуйте!

В статье описана возможность скрытия блоков, состоящих из нескольких реквизитов. Т.е нужно скрывать не один реквизит, а именно блок (набор реквизитов).
Есть ли штатная возможность скрытия именно блока реквизитов?

С уважением, Оля-ля
4. the1 912 15.07.21 12:21 Сейчас в теме
(3) Скрывается вся группировка (блок по вашему =)) со всеми реквизитами.
ixijixi; DrAku1a; echo77; yghmd; olja-ljaaa; +5 Ответить
6. DrAku1a 1451 26.07.21 07:02 Сейчас в теме
(1) В настройках отчета (в дереве группировок - корень) ставим на отборы включать в состав пользовательских настроек и быстрый доступ - в результате пользователю выводится поле со списком группировок, в котором можно их менять местами и включать/выключать отдельные.
ИМХО, удобнее такое давать, а далее- каждый под себя настраивает вариантами (но чаще всего - копируют друг у друга)...
7. ixijixi 27.08.21 09:03 Сейчас в теме
2. olja-ljaaa 16 15.07.21 12:18 Сейчас в теме
5. the1 912 15.07.21 14:31 Сейчас в теме
Оставьте свое сообщение

См. также

Аналог PIVOT в запросе 1С (как выполнить транспонирование таблицы в запросе 1С) Промо

Практика программирования v8 Бесплатно (free)

В статье показывается простой метод реализации аналога оператора PIVOT в запросе 1С без использования соединений.

12.12.2020    3515    Eugen-S    20    

Программное открытие отчета СКД с параметрами и отбором

Практика программирования v8 v8::УФ v8::СКД Бесплатно (free)

Периодически возникает задача открытия формы отчёта СКД уже со сформированным отчётом, с определёнными параметрами и отборами. В данной публикации рассматриваются способы сделать это как в обычном приложении, так и в управляемом.

07.08.2021    3487    Eugen-S    19    

Изменение расшифровки макета СКД до компоновки

Практика программирования Универсальные функции v8 v8::СКД Бесплатно (free)

Это не про работу с данными расшифровки. Это про изменение расшифровок полей ДО того, как СКД выполнилась. Быстрый способ сделать нужные расшифровки.

12.07.2021    2252    Yashazz    6    

Чтоб в СКД по таблице значений был порядок!

Инструментарий разработчика Практика программирования v8::СКД Бесплатно (free)

Сортировка СКД и источник - таблица значений. Заметка.

28.06.2021    1238    Yashazz    0    

Использование классов .Net в 1С для новичков Промо

Практика программирования Разработка внешних компонент Универсальные функции v7.7 v8 Бесплатно (free)

Руководство для новичков. Написав статью http://infostart.ru/public/238584/, я понял, что многие не понимают того, что написано. Поэтому в этой статье постараюсь более подробно остановиться на азах и без кода на вражеском языке (C#)

27.01.2016    84647    Serginio    113    

Формирование отчета СКД с расшифровкой из обработки

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Формирование отчета СКД из обработки немного отличается от формирования из отчета.

27.04.2021    4025    John_d    14    

Нестандартное использование СКД

Практика программирования v8::СКД Бесплатно (free)

Программист 1С в компании «БКС-технологии» Алексей Шиянов в ходе Infostart Meetup Novosibirsk продемонстрировал необычный способ использования СКД и сравнил результаты заполнения движений документа через СКД с классическим подходом к заполнению движений через запросы и циклы.

14.04.2021    3796    user1127305    11    

Полезные примеры СКД, ч.2

Практика программирования v8 v8::СКД Бесплатно (free)

Еще несколько примеров решения задач в СКД.

06.04.2021    9649    Neti    8    

Звуковое управление в 1С 8.3 Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

В данной статье описано создание библиотеки для звукового управления (выполнение команд голосом) для платформы 1С 8.3. Задача была поставлена так, чтобы модуль функционировал непосредственно на клиенте 1С, осуществляя управление формами, и взаимодействовал с интерфейсом.

16.03.2021    6654    velemir    31    

Пример платежного календаря. СКД. Работает на любой платформе, без привязки к данным. Подробное описание действий

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Отчет-пример, в котором на СКД рассмотрены принципы построения платежного календаря без привязки к данным и работающий на любой платформе. Подробно описаны этапы решения задачи. Тестирование проводилось на платформе 8.3.16.1814.

02.04.2021    1095    parshachello    2    

Неочевидные нюансы записи управляемой формы

Практика программирования v8 v8::УФ Платформа 1C v8.2 1cv8.cf Бесплатно (free)

Разберем несколько нюансов записи управляемой формы.

02.04.2021    11009    SeiOkami    52    

Полезные примеры СКД, ч.1

Практика программирования v8::СКД Бесплатно (free)

Подборка видео по решению различных задач в отчетах на СКД.

30.03.2021    12239    Neti    19    

Serverless (Faas) в 1С. Создание и вызов Yandex Cloud Functions Промо

Универсальные функции Практика программирования v8 Бесплатно (free)

"Я не могу просто взять и скопировать код с гитхаба", "у нас 1С микросервисами окружена", "возможностей мало" - частые фразы 1С разработчиков. которым не хватает возможностей платформы в современном мире. Faas, конечно, история не новая, но нас сдерживало 152ФЗ и задержки по пингам. Для того, чтобы действительно использовать в 1С код, к примеру, на Python, надо было приложить усилия. Теперь всё намного проще - берём и используем.

28.12.2020    8328    comol    31    

Обзор полезных методов БСП 3.1.4

Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Бесплатно (free)

Библиотека стандартных подсистем (далее - БСП) является частью любой типовой конфигурации, поэтому умение применять готовые процедуры и функции повышает качество разработки и избавляет от написания лишнего кода. К сожалению, не у всех есть время и упорство овладеть всей документацией, поэтому я собрал воедино наиболее популярный функционал.

25.03.2021    34980    rayastar    51    

Сравнение данных с февралем високосного года (проблема 29 февраля)

Практика программирования v8::СКД Бесплатно (free)

Думаю, в практике многим приходится неоднократно сталкиваться с необходимостью разработки отчёта типа LFL (like for like), сравнивающего аналогичные периоды разных лет, например, текущего выбранного периода с аналогичным периодом прошлого года. В новых конфигурациях такой отчёт есть в составе конфигурации (см. "Сравнение продаж аналогичных периодов"), а в старых обычно приходится добавлять. Если не учесть нюанс сравнения с февралём високосного года, данные в отчёте за прошлый период могут быть некорректными.

02.03.2021    408    aleksei_adamov    4    

Отбор на форму (документа, справочника, обработки) с помощью СКД

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Добавляем удобный отбор на форму документа с помощью СКД

09.02.2021    5812    John_d    15    

Использование программных перечислений, ч.1: строковые константы Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Часто ли у вас возникает необходимость в коде выполнять сравнение на строку?

10.12.2016    40672    unichkin    74    

Установка нескольких фильтров/отбора СКД в табличной форме, хранение в табличной части для отправки push/email уведомлений (ОтборКомпоновкиДанных, КомпоновщикНастроек, ДинамическийСписок)

Работа с интерфейсом Практика программирования v8 v8::УФ v8::СКД Бесплатно (free)

Рассмотрим, как организовать установку фильтров/отбора СКД (динамического списка) на push/email уведомления в подсистеме EDIbot (WebApp) для 1С в табличной части "События уведомлений".

02.11.2020    1408    SizovE    0    

Вычислить РАЗНОСТЬДАТ в рабочих днях

Практика программирования БСП (Библиотека стандартных подсистем) v8::Запросы v8::СКД ERP2 БП3.0 УТ11 ЗУП3.x Бесплатно (free)

Вычисление количества рабочих днях между двумя датами в запросе.

20.10.2020    3635    antonivan    17    

Базовые вещи БСП, которые облегчат жизнь программисту 1С

Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Россия Бесплатно (free)

В данной публикации я опишу полезные процедуры и функции модуля общего назначения библиотеки стандартных подсистем, обязательные к использованию любым программистом 1С.

30.08.2020    18904    quazare    34    

Вспомогательные инструкции в коде 1С Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Помогаем редактору кода 1С помогать нам писать и анализировать код.

15.10.2018    35538    tormozit    106    

Вывод дерева в табличный документ СКД

Практика программирования Универсальные функции v8 v8::СКД Бесплатно (free)

Вывод содержимого элемента формы "ДанныеФормыДерево" в табличный документ средствами СКД.

09.07.2020    4115    Yashazz    7    

Роль "Остатки" поля набора данных СКД в отчете и в расшифровке

Практика программирования v8::СКД 1cv8.cf Бесплатно (free)

В СКД создан набор данных "Запрос". Запрос выполняется к виртуальной таблице "Остатки и обороты", периодичность регистра "Авто", выбираются все измерения и ресурсы регистра, а так же выбирается Регистратор и ПериодСекунда. Для полей содержащих остатки устанавливается роль "Остатки". Для полей "Регистратор" и "ПериодСекунда" устанавливается роль "Период". Для поля "Регистратор" устанавливается выражение упорядочивания.

24.05.2020    6055    kasper076    17    

Макет оформления в отчете с несколькими СКД

Практика программирования v8::СКД Россия Бесплатно (free)

Как заставить работать макет оформления в отчёте с несколькими СКД.

14.05.2020    4125    vendim    2    

Оформление и рефакторинг сложных логических выражений Промо

Практика программирования v8 Россия Бесплатно (free)

В сложных логических выражениях нередко самому автору спустя какое-то время тяжело разобраться, не говоря уже о других программистах. Предлагаемая методика позволяет повысить наглядность таких выражений путем оформления в виде И-ИЛИ дерева и одновременно выполнять их рефакторинг.

20.09.2012    82379    tormozit    131    

Форма выбора (подбор) в управляемых формах

Практика программирования v8 v8::УФ 1cv8.cf Россия Бесплатно (free)

Разбор небольших примеров того, как правильно открывать форму выбора (подбора) в управляемых формах, не прибегая к модальным окнам.

08.05.2020    69660    user5300    19    

СКД. Использование Менеджера временных таблиц в системе компоновки

Практика программирования v8 v8::Запросы v8::СКД 1cv8.cf Бесплатно (free)

С выпуском платформы 8.3.17 фирма 1С анонсировала возможность передачи в механизм системы компоновки данных менеджера временных таблиц. Платформа вышла из беты, самое время разобраться с новым механизмом, тем более в комментариях я встретил непонимание принципов работы этого нововведения. Постараюсь кратко.

29.04.2020    11397    the1    44    

Ограничения полей, или как обмануть СКД?

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Каждое из ограничений полей можно обойти. Рассмотрим варианты обхода и способы обезопасить свой отчет.

15.04.2020    15030    SeiOkami    41    

Запись значения в поле ввода/формы со срабатыванием события ПриИзменении Промо

Практика программирования v8 1cv8.cf Россия Бесплатно (free)

Иногда возникает необходимость после записи значения в какое либо поле ввода/формы вызвать для него обработчик события ПриИзменении, а о вызове самого события приходится только мечтать. В этой статье приводится программный способ вызова этого события.

11.07.2007    53712    tormozit    51    

Работа с запросами в 1С СКД. Отладка СКД

Практика программирования v8::Запросы v8::СКД Россия Бесплатно (free)

В предыдущем разделе мы изучали с вами особенности работы с запросами в СКД. Для изучения (отладки) работы различных схем компоновки данных я использовал консоль компоновки данных.

15.04.2020    4614    ProfessionStore    3    

Работа с запросами в 1С СКД. Особенности работы запросов в СКД. Часть 3

Практика программирования v8::Запросы v8::СКД Россия Бесплатно (free)

Почему при отборе по контрагенту наш отчет работает неправильно. Посмотрим на примере другого отчета, в котором нам нужно выбрать данные из расходных накладных и связанные с номенклатурой данные по ВСЕМ заявкам.

13.04.2020    8174    ProfessionStore    4    

СКД: Прозрачная обработка результата

Практика программирования v8::СКД 1cv8.cf Бесплатно (free)

В статье дан ответ на вопрос о том, как "прозрачно" обработать результат компоновки (да хотя бы картинки вставить после того, как отчет сформирован).

13.04.2020    5450    starik-2005    16    

Как сделать из &НаКлиентеНаСервереБезКонтекста почти &НаКлиентеНаСервере Промо

Практика программирования v8 1cv8.cf Россия Бесплатно (free)

Как сделать метод формы, доступный на клиенте и на сервере одновременно, и сохранить при этом удобство разработки

10.09.2017    50468    tormozit    74    

Работа с запросами в 1С СКД. Особенности работы запросов в СКД. Часть 2

Практика программирования v8::Запросы v8::СКД Россия Бесплатно (free)

Все примеры разобраны с помощью консолей компоновки данных, речь о которых пойдет в предпоследнем разделе статьи.

12.04.2020    6724    ProfessionStore    11    

Работа с запросами в 1С СКД. Особенности работы запросов в СКД. Часть 1

Практика программирования v8::Запросы v8::СКД 1cv8.cf Россия Бесплатно (free)

Все примеры разобраны с помощью консолей компоновки данных, речь о которых пойдет в предпоследнем разделе статьи.

11.04.2020    10832    ProfessionStore    9    

Работа с запросами в 1С СКД. Язык выражений СКД и подмена запросов

Практика программирования v8::Запросы v8::СКД Россия Бесплатно (free)

Хотя эта статья называется «Работа с запросами в 1С СКД», нельзя не упомянуть про язык выражений СКД. Да – у системы компоновки данных есть свой язык! Это не язык платформы 1С, это не язык запросов. Это еще один язык, который используется 1С в СКД для обработки полученного набора (ов) данных.

11.04.2020    9502    ProfessionStore    25    

Выгрузка документа по условию Промо

Практика программирования Разработка v8 Бесплатно (free)

Что делать, если документы нужно выгружать не все подряд, а по какому-то фильтру: статусу, дате, набору условий... А что если он соответствовал этим условиям, а потом перестал? А если потом опять начал? Такие ситуации заставили попотеть не одного программиста.

25.04.2019    17751    m-rv    3    

Работа с запросами в 1С СКД. Примеры использования расширения языка запросов СКД

Практика программирования v8::Запросы v8::СКД Россия Бесплатно (free)

Все тонкости использования расширения языка запросов 1С для СКД вы можете изучить по ссылкам, которые приведены в предыдущей статье. Здесь мы рассмотрим конкретные кейсы применения данного расширения.

10.04.2020    9394    ProfessionStore    4    

Запросы 1С СКД. Возможности и ограничения

Практика программирования v8::Запросы v8::СКД Россия Бесплатно (free)

В этом цикле статей мы рассмотрим особенности работы системы компоновки данных с запросами в 1С.

10.04.2020    11795    ProfessionStore    14    

Вложенные СКД

Практика программирования Конфигурирование 1С v8 v8::СКД Бесплатно (free)

Возможности, нюансы, заметки.

26.03.2020    9131    Yashazz    19    

Как прикрутить ГУИД к регистру сведений Промо

Практика программирования Перенос данных из 1C8 в 1C8 Разработка v8 Бесплатно (free)

... и немного теории обмена данными. В частности, разберем боль всех, кто пишет небанальные обмены данными: как набору записей регистра сведений назначить гуид и далее использовать его в обмене для идентификации этого набора.

16.04.2019    22980    m-rv    18    

СКД - одна из проблем связи Наборов данных

Практика программирования v8::СКД 1cv8.cf Россия Бесплатно (free)

Официальная информация: 1. В схеме компоновки данных нет указания типа связи. Все связи считаются ЛЕВЫМИ внешними соединениями. 2. Если для вложенного набора данных указано условие фильтра, тогда связь вложенного набора данных с родительским набором данных считается ВНУТРЕННЕЙ. Или как получить все результаты основного набора при отборе в зависимом.

03.03.2020    7705    BelikovSA    10    

Получение значений всех полей в иерархии структуры отчета

Практика программирования Математика и алгоритмы v8::СКД Россия Бесплатно (free)

При обработке расшифровки данных в отчете (да и не только отчете), основанном на СКД, может потребоваться получить значения всех полей, находящихся в текущей группировке и её родителях. Представляю вашему вниманию алгоритм, выполняющий эту задачу. Как говорится, "просто оставлю это здесь".

28.02.2020    2489    real_MaxA    1    

Для чего нужен флаг "Автозаполнение" в СКД и каких проблем без него можно избежать

Практика программирования v8 v8::СКД Бесплатно (free)

Речь пойдет о флаге «Автозаполнение» в наборе данных Запрос Системы компоновки данных (СКД). Сразу хочу отметить, что флаг «Автозаполнение» доступен только в наборе данных - Запрос.

26.02.2020    9532    Neti    41    

Как сделать запрос на изменение данных Промо

Практика программирования v8 v8::Запросы 1cv8.cf Бесплатно (free)

В статье приведены особенности внутренней архитектуры и примеры работы с расширением языка запросов 1С.

01.06.2018    36184    m-rv    23    

Программная работа с настройками СКД

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Нюансы программной работы с настройками системы компоновки данных в отчетах и динамических списках. Обзор всех видов настроек компоновки. Что в каких случаях правильно применять. В качестве примера рассмотрена работа с отборами и группировками.

27.01.2020    61309    ids79    26    

[СКД] Программное создание схемы компоновки данных

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Сделаем отчет на СКД полностью программно, без использования макета "схема компоновки данных".

15.01.2020    41500    John_d    22    

Последовательности событий при проведении документа 1С. Шпаргалка + про формы + про расширения

Практика программирования v8 Россия Бесплатно (free)

Собрал информацию о событиях/подписках/расширениях в одном месте.

30.12.2019    33165    kuzyara    38    

Метод формирования движений в типовых регистрах нетиповыми регистраторами Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Вариант решения задач с проведением по типовым регистрам нетиповыми регистраторами. Зачем - чтобы при сравнении конфигурации не обращать внимание на свойства регистров и исключить вероятность допущения горькой оплошности при обновлении информационных баз, заменив типы регистраторов основной конфигурации типами конфигурации поставщика. Для программных продуктов, имеющих в своем составе метаданных документ "Корректировка регистров"("Корректировка записей регистров").

05.12.2017    30568    itriot11    34    

30 задач. Странных и не очень

Практика программирования v8 Бесплатно (free)

30 задач на знание языка программирования 1С и некоторого поведения платформы. Маленьких. Странных и не очень.

02.12.2019    23252    YPermitin    62