Ошибка формата потока

21.11.12

Задачи пользователя - Корректировка данных

Указанное сообщение было обнаружено при обновлении.

При обновлении конфигурации "Бухгалтерия гос. учреждения" Появилось сообщение "Ошибка формата потока" и два варианта, не самых приятных, "Завершить" и "Перезапустить".

Попытки тестирования БД, как и chdbfl не дали никакого результата.

Проверка конфигурации, с галочкой "Поиск некорректных ссылок" привела к такому же сообщению (Ошибка формата...).

Вывод - БД ни при чем. Проблема в конфигурации.

При сравнении с заведомо-рабочей конфигурацией, той же версии, найдены различия в типах числовых реквизитов, хотя и там и там стоит тип Число(15,2).

Из всей кучи советов, найденых "на просторах" подошел 1: перенести данные в другую БД.

Как это сделать:

1. На основе рабочей конфигурации создаем новую базу. (Хоть с шаблона, хоть создать новую - загрузить конфигурацию).

2. Запускаем в режиме предприятие. Наверняка пойдет обновление, до требуемой версии.

3.Запускаем обработку MD82Exp (на просторах свободно). У кого 8.1 тем MD81Exp. Там есть настройки, позволяющие не выгружать регистры, я выгрузил все, кроме регистров расчета. У меня их нет. Сохраняем файл описания конфигурации.

4. Повторяем последнее, для "битой" конфигурации.

5. С помощью конфигурации "Конвертация данных" на основе этих двух файлов описания, создаем правила переноса.

6. Возможно, Ваши бухи добавляли счета или субконто к ним. Если их не будет добавлено в новой базе, то перенос вылетит на ошибку, да и бухам потеря данных не понравится. Чтобы найти эти добавленные использунем простейшую обработку:

Процедура КнопкаВыполнитьНажатие(Кнопка)

  План=ПланыСчетов.ЕПСБУ.Выбрать();
  Пока План.Следующий() Цикл

     Если План.ЭлементГруппа Тогда              //Внимание! Это реквизит счета в бюджете! Если у вас другая конфигурация проверьте 
        Продолжить;                                          //признак группы иначе.
     КонецЕсли;


    Для каждого ВС Из План.ВидыСубконто Цикл
       Если ВС.Предопределенное ИЛИ  Тогда
          Продолжить;
      КонецЕсли;
      Сообщить("Счет "+План.Код+" Вид субконто "+ВС.ВидСубконто.Наименование);
    КонецЦикла;
  КонецЦикла;
КонецПроцедуры

Кто хочет может выбрать запросом, не думаю, что будет быстрее. Просматриваем весь план счетов.

Получаем 2 списка непредопределенных счетов и субконто. Сравниваем, добавляем, каких нет в новой базе.

7. Запускаем "битую" базу в режиме предприятие и переносим данные Универсальным обменом... 

У меня оборотки получились как близнецы. Бухи счастливы.

См. также

Тестирование и исправление ключей аналитики ERP, УТ11, КА

Корректировка данных Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Платные (руб)

Незаменимая обработка для сопровождения конфигураций: ERP, УТ, КА. Позволяет вычистить многие ошибки в ключах аналитики, в ключевых справочниках конфигурации.

3600 руб.

10.02.2017    103939    616    167    

654

QR -кодирование документов БЕЗ изменения печатных форм, с произв. алгоритмами создания QR -кода и обработки (в т.ч прикрепление сканов к документам) для УТ 11 (все), ERP 2, КА 2, Розница 2, УНФ 1.6/3.0, БП 3, ЗУП 3

Корректировка данных Платформа 1С v8.3 1С:Управление торговлей 10 1С:Розница 2 1С:Управление производственным предприятием 1С:Управление нашей фирмой 1.6 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Управленческий учет Платные (руб)

Представьте, что есть система, которая НЕ ТРЕБУЕТ изменения конфигурации, НЕ ТРЕБУЕТ изменения ни одной печатной формы для добавления QR-кода, включая внешние, НЕ ХРАНИТ данные штрихкодов и их связь, от чего база не "пухнет", ИМЕЕТ возможность закодировать в QR-коде произвольные данные параметров для последующей обработки полученных данных, УМЕЕТ прикреплять сканы, УМЕЕТ обработать считанный QR-код как ВЫ захотите. А также ХРАНИТ историю операций в обход базы для каждого пользователя в отдельности и УМЕЕТ работать с 2D - сканерами. А также автоматически распознавать отсканированные печатные формы (картинки или pdf-файлы) и выполнять заданные произвольные алгоритмы, в том числе прикрепление их к документам! Обновление 3.1 от 09.11.2023!

8400 руб.

26.08.2018    49615    12    60    

53

Заполнение документа "Корректировка регистров" произвольными данными

Закрытие периода Корректировка данных Платформа 1С v8.3 Система компоновки данных 1С:Управление нашей фирмой 1.6 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 Управленческий учет Платные (руб)

Внешняя обработка, позволяющая произвольным образом заполнять документ "Корректировка регистров" Предназначена для использования в конфигурациях "Управление торговлей 11", "Управление небольшой фирмой", "ERP Управление предприятием", а также в других конфигурациях, в состав которых входит библиотека стандартных подсистем (БСП) версии 2.2+ и указанный выше документ.

2400 руб.

13.07.2015    49333    165    29    

116

Исправление ошибки закрытия месяца "Обнаружены ненулевые остатки по суммам при нулевом остатке по количеству в регистре себестоимости по организации". УТ 11.4,УТ 11.5, КА 2.4,КА 2.5, ERP 2.4, ERP 2.5, КА 2 Казахстан, Управление торговлей 3 для Казахстана

Закрытие периода Корректировка данных Платформа 1С v8.3 Оперативный учет 1С:Управление торговлей 11 Управленческий учет Платные (руб)

Закрытие месяца - важный процесс в современных конфигурациях, таких как УТ 11.4, УТ 11.5, КА 2.4, КА 2.5 ERP 2.4,ERP 2.5, КА 2 Казахстан, УТ 3 Казахстан регламентные операции влияют на расчет себестоимости, и ошибки в данном расчете не дают картины деятельности организации.

2400 руб.

27.10.2021    21164    295    35    

65

Помощник исправления порядка расчетов

Взаиморасчеты Корректировка данных Платформа 1С v8.3 Конфигурации 1cv8 Бухгалтерский учет Управленческий учет Платные (руб)

Вы наконец разобрались с закрытием месяцев и пора начать контролировать сроки оплаты поставщикам и задолженности клиентов, но в базе расчеты не идут из-за развернутого сальдо? Не беда, есть решение!

7200 руб.

02.11.2020    6517    4    0    

7

Исправление в 1С:ЗУП/ЗКГУ ошибок по НДФЛ и взаиморасчетам с сотрудниками на начало расчетного года.

Корректировка данных Зарплата Платформа 1С v8.3 Сложные периодические расчеты 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и Управление Персоналом 3.x Россия Бухгалтерский учет НДФЛ Платные (руб)

Обработка исправляет технические ошибки по НДФЛ, взаиморасчетам с сотрудниками в 1С:ЗУП (1С:ЗКГУ) на начало года. Фактически все ошибки, которые проявляются в ведомостях на выплату, расчетных листках, при заполнении ведомостей на выплату и отчетах 6-НДФЛ и т.д. нужно начинать исправлять с начала расчетного года. Это позволит быть уверенными, что после завершения расчетов предыдущего года, начали работать с «чистого листа» без ошибочных остатков.

4320 руб.

06.10.2023    857    3    5    

5

Групповое изменение реквизитов номенклатуры для УТ 11/КА 2

Загрузка и выгрузка в Excel Корректировка данных Платформа 1С v8.3 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Управленческий учет Платные (руб)

Обработка для группового редактирования реквизитов номенклатуры. Позволяет редактировать реквизиты (как основные, так и дополнительные реквизиты и сведения) непосредственно в таблице, устанавливать новые значения реквизитов на выбранную номенклатуру, а также загружать новые значения из Excel. Предусмотрена возможность добавления фото к товарам перетаскиванием файла из проводника на строку с товаром (drag'n'drop)

4200 руб.

16.11.2020    16932    11    5    

10

Автоматическая корректировка НДФЛ в ЗКГУ

Корректировка данных Платформа 1С v8.3 1С:Зарплата и кадры государственного учреждения 3 Государственные, бюджетные структуры Россия Бухгалтерский учет Налоговый учет НДФЛ Платные (руб)

На этот раз действительно автоматическая корректировка НДФЛ! С помощью данной обработки можно автоматически скорректировать НДФЛ, не тратя целые часы на его ручную корректировку. Можно в считанные минуты изменить НДФЛ по всем сотрудникам в организации. Что бережет деньги на оплату специалиста и время! Обновлена и адаптирована к новым правилам исчисления и удержания НДФЛ с 01.01.2023 г.

4500 руб.

23.06.2022    11104    77    32    

40
Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. serega_sun 28.11.12 04:06 Сейчас в теме
А не пробовали полностью загрузить заведомо рабочую конфигурацию в базу с ошибкой?
2. Nordgreen 08.02.13 13:29 Сейчас в теме
(1) Была такая же ситуация, увы, не помогло. Пришлось так же переносить в чистую базу конвертацией данных.
3. kdv 05.09.13 09:54 Сейчас в теме
В аналогичной ситуации помогло удаление из списка баз битой базы и создание новой строки в списке баз
4. sknarid 09.07.14 15:28 Сейчас в теме
Подтверждаю. Помогло простое удаление из списка ИБ, и занесение базы в список заново.
5. Star_SU 9 10.10.15 08:05 Сейчас в теме
Столкнулся с "Ошибка формата потока" при обновлении конфигурации.
Решил найти обновление без ошибок, оказалось что все конфигурации выдают эту ошибку при ее проверке, но на разных процентах - то на каком либо документе, то на справочнике.
Например ЗУП:
2.5.46.2 - Неразрешимые ссылки на картинки
2.5.48.2 - ВозвратНаРаботуВОрганизацию
2.5.55.3 - Физлица

Что это за странность такая?

6. Star_SU 9 10.10.15 08:06 Сейчас в теме
Весь интернет перелазил - ничего подобного не нашел
7. Borisych 503 10.10.15 10:55 Сейчас в теме
(6) Star_SU, платформа актуальна для используемой версии конфигурации? дальше как обычно - кеш, перенос базы на другой комп, ТиИ и др.
8. Cooler 22 10.10.15 11:35 Сейчас в теме
+(7) Если база файловая, то еще chdbfl.exe в качестве "и др.". И лучше пораньше, перед переносом базы.
Оставьте свое сообщение