Несколько слов о вложенных схемах компоновки данных

12.02.13

Разработка - СКД

За 2 года работы предприятия с конфигурацией «Управление торговлей 11» у нас накопилось немалое число внешних отчетов пользователей (около 30). Соответственно пользователям стало трудно ориентироваться в таком количестве отчетов, поэтому было принято решение сгруппировать отчеты по смыслу и перенести часть отчетов во вложенные схемы компоновки данных. Статья будет полезна тем, кто только начинает знакомиться с компоновкой данных. Примеры из статьи работают как УТ 11 так и в УТ 3.0 (для Украины).

Скачать файл

ВНИМАНИЕ: Файлы из Базы знаний - это исходный код разработки. Это примеры решения задач, шаблоны, заготовки, "строительные материалы" для учетной системы. Файлы ориентированы на специалистов 1С, которые могут разобраться в коде и оптимизировать программу для запуска в базе данных. Гарантии работоспособности нет. Возврата нет. Технической поддержки нет.

Наименование SM По подписке [?] Купить один файл
Файлы.zip
.zip 16,13Kb
60
60
1 SM
Скачать Купить за 1 850 руб.

ПРИМЕР БЕЗ ПРОГРАММИРОВАНИЯ

Для начала давайте рассмотрим способ вывода отчета из вложенной схемы без программирования. У нас есть два отчета:

  • Остатки товаров;
  • Цены номенклатуры;

На основании двух отчетов необходимо составить один отчет, где отчет «Цены номенклатуры» будут вызываться как вариант отчета «Остатки товаров» (пример не совсем по смыслу, но демонстрирует возможности платформы).
Итак, сначала откроем отчет «Цены номенклатуры» в конфигураторе и сохраним схему отчета в файл.

Сохранение схемы компоновки данных в файл

Теперь перейдем в отчет «Остатки номенклатуры», откроем основную схему компоновки данных на вкладке «Вложенные схемы». После добавления новой вложенной схемы, загрузим сохраненную схему. Хочу обратить внимание на то, что нельзя изменять имя и заголовок отчета.

Вложенная схема компоновки данных

Создадим новый вариант отчета, дадим ему имя «Цены номенклатуры», подключим вложенный отчет. Должно выйти примерно так, как на картинке.

Настройки варианта отчета СКД

Запустим отчет в режиме «1С Предприятия» и убедимся, что нам доступны 2 варианта отчета.

Отчет в режиме «1С Пердприятия»

ПРОГРАММНЫЙ ВЫВОД ОТЧЕТА С ВЛОЖЕННЫМИ СХЕМАМИ

Хорошо, теперь заделаем то же, но для программного вывода отчета. Задача та же, но отчет будем формировать программно. Такая ситуация может возникнуть например при вызове отчета из обработки.

Программный вызов отчет из обработки

Следующий код выводит отчет из макета обработки:

&НаКлиенте
Процедура ОстаткиНоменклатуры(Команда)
  СформироватьОтчетОстаткиНоменклатуры();
КонецПроцедуры
&НаСервере
Процедура СформироватьОтчетОстаткиНоменклатуры()
  ОбработкаОбъект   = РеквизитФормыВЗначение("Объект");
  СхемаКомпоновкиДанных  = ОбработкаОбъект.ПолучитьМакет("Макет");
  ЗначениеВРеквизитФормы(ОбработкаОбъект, "Объект");

  Настройки = СхемаКомпоновкиДанных.НастройкиПоУмолчанию;

  КомпоновщикМакета    = Новый КомпоновщикМакетаКомпоновкиДанных;
  ДанныеРасшифровкиКД   = Новый ДанныеРасшифровкиКомпоновкиДанных;
  МакетКомпоновки    = КомпоновщикМакета.Выполнить(СхемаКомпоновкиДанных, Настройки);

  ПроцессорКомпоновкиДанны    = Новый ПроцессорКомпоновкиДанных;
  ПроцессорКомпоновкиДанны.Инициализировать(МакетКомпоновки);

  ПроцессорВывода    = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;

  ПроцессорВывода.УстановитьДокумент(Результат);
  ПроцессорВывода.Вывести(ПроцессорКомпоновкиДанны);
КонецПроцедуры

Перейдем к выводу вложенной схемы. Давайте посмотрим отладчиком, где ее искать.

Вложенная схема компоновки данных в отладчике

Вот она, во вложенных схемах компоновки данных. Дело за малым, осталось программно вывести результат работы процессора компоновки в форму.

&НаКлиенте
Процедура ЦеныНоменклатуры(Команда)
  СформироватьОтчетЦеныНоменклатуры();
КонецПроцедуры
 
&НаСервере
Процедура СформироватьОтчетЦеныНоменклатуры()
  ОбработкаОбъект 	= РеквизитФормыВЗначение("Объект");
  СхемаКомпоновкиДанных 	= ОбработкаОбъект.ПолучитьМакет("Макет");
  ЗначениеВРеквизитФормы(ОбработкаОбъект, "Объект");
	
  ВложеннаяСКД = СхемаКомпоновкиДанных.ВложенныеСхемыКомпоновкиДанных.Найти("Отчет1");
	
  Если ВложеннаяСКД = Неопределено Тогда
    ВызватьИсключение НСтр("ru=""Не удалось получить вложенную схему компоновки данных.""");
    Возврат;
  КонецЕсли;
	
  Настройки = ВложеннаяСКД.Схема.НастройкиПоУмолчанию;
	
  КомпоновщикМакета 			= Новый КомпоновщикМакетаКомпоновкиДанных;
  ДанныеРасшифровкиКД			= Новый ДанныеРасшифровкиКомпоновкиДанных;
  МакетКомпоновки				= КомпоновщикМакета.Выполнить(ВложеннаяСКД.Схема, Настройки);
	
  ПроцессорКомпоновкиДанны = Новый ПроцессорКомпоновкиДанных;
  ПроцессорКомпоновкиДанны.Инициализировать(МакетКомпоновки);
	
  ПроцессорВывода	= Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
	
  ПроцессорВывода.УстановитьДокумент(Результат);
  ПроцессорВывода.Вывести(ПроцессорКомпоновкиДанны);
КонецПроцедуры

В заключение скажу, вложенные схемы – прекрасный механизм, который позволяет гибко использовать функционал схемы компоновки данных.

Статья написана по материалам сайта avtomat.biz

См. также

Инструментарий разработчика Роли и права Запросы СКД Программист Платформа 1С v8.3 Управляемые формы Запросы Система компоновки данных Конфигурации 1cv8 Платные (руб)

Набор инструментов программиста и специалиста 1С для всех конфигураций на управляемых формах. В состав входят инструменты: Консоль запросов, Консоль СКД, Консоль кода, Редактор объекта, Анализ прав доступа, Метаданные, Поиск ссылок, Сравнение объектов, Все функции, Подписки на события и др. Редактор запросов и кода с раскраской и контекстной подсказкой. Доработанный конструктор запросов тонкого клиента. Продукт хорошо оптимизирован и обладает самым широким функционалом среди всех инструментов, представленных на рынке.

10000 руб.

02.09.2020    140680    772    391    

803

Запросы СКД Программист Стажер Система компоновки данных Россия Бесплатно (free)

Часто при разработке отчетов в СКД возникает ситуация, когда не совсем понятно, почему отчет выводит не те данные, которые нужны, либо не выводит вовсе. Возникает потребность увидеть конечный запрос, который формирует СКД. Как это сделать, рассмотрим в этой статье.

15.05.2024    5224    implecs_team    6    

43

Инструментарий разработчика СКД Программист Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

По выбранной схеме компоновки данных генерирует программный код, который генерирует СКД, аналогичную исходной схеме. Есть дополнительные инструменты для просмотра дерева схемы, сравнение исходной схемы и полученной по коду, а также сравнение изменений в сгенерированном коде для исходной схемы и для измененной.

3 стартмани

05.02.2024    5581    43    obmailok    21    

78

Запросы СКД Программист Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Абонемент ($m)

Есть список полей в виде текста, или запрос - закидываем в набор СКД.

1 стартмани

31.01.2024    2580    2    Yashazz    0    

33

СКД WEB-интеграция Программист Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Долгое время поддерживаю web-портал, в котором появилась необходимость создавать отчеты. Просмотрев различные фреймворки на js, я решил сделать свое решение, которое позволяло бы быстро разрабатывать и добавлять новые отчеты на web-портал.

2 стартмани

11.12.2023    9468    21    John_d    25    

124

СКД Программист Платформа 1С v8.3 Система компоновки данных Конфигурации 1cv8 Бесплатно (free)

Рассмотрим еще не получивший широкого распространения способ работы с внешними данным в СКД. В процессе обсуждения работы с СКД выяснилось, что многие не знакомы со способом помещения туда временной таблицы, полученной предварительно. Статья будет полезна разработчикам, знакомым с программным созданием СКД.

05.12.2023    6208    PROSTO-1C    13    

67
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. GreenFox 13.02.13 00:41 Сейчас в теме
Идея конечно хороша, но если посмотреть в типовую конфигурацию то там есть справочник который называется "Дополнительные внешние обработки" - он иерархический - группируйте по смыслу сколько хотите даже переделывать не прийдется ни одного отчета. И отчеты остануться проще в сопровождении. Я например когда б пришел на проект и мне поставили задачу что-нибудь изменить в таком громоздком отчете пришел бы вначале в ужас. Не понимаю зачем все так усложнять?
Михаська; +1 Ответить
2. akomar 457 13.02.13 00:58 Сейчас в теме
(1) Здравствуйте, спасибо за отзыв. Мне конечно известно о иерархичности справочника «Внешние обработки и отчеты». Но увы, пользователи клиента хотели, чтобы, например, несколько разработанных доп. отчетов были по рукой и чтобы их запустить без переключатся между окнами (у менеджеров очень мало времени :)). Вот и пришлось идти на извращения разного рода. Кто платит тот и прав, главное чтобы клиент был доволен.
3. Ibrogim 1319 13.02.13 07:26 Сейчас в теме
(2) Раз уж пишите статью про вложенные схемы, то неплохо было бы раскрыть тему передачи параметров в них ( том числе и программное).
VVi3ard; StAsya_1C; HystriX; +3 Ответить
8. akomar 457 13.02.13 12:43 Сейчас в теме
(3) Наверно это будет тема следующей статьи.
4. vec435 15 13.02.13 08:32 Сейчас в теме
(2) в таком случае создать доп форму избранное и пусть добавляют ссылки в нее на любые отчеты
Михаська; KindLion; AlX0id; akomar; +4 Ответить
9. akomar 457 13.02.13 12:43 Сейчас в теме
5. zqzq 25 13.02.13 08:53 Сейчас в теме
Автор извратился и решил задачу, которая:
1) по-нормальному решается 2-мя независимыми источниками данных и 2-мя вариантами, вложенные схемы не для того предназначены (а для формирования отчета с вложенными подотчетами (с) кэп)
2) задача надуманная (как писали выше) и рождённая от буквального понимания безумных хотелок пользователей (ну да... некогда думать, прыгать (грести деньги) надо).

PS Может погорячился... Впринципе достаточно малотрудозатратный способ продемонстрирован, хотя и не совсем "правильный".
Irwin; KindLion; sheff161; AlX0id; +4 Ответить
10. akomar 457 13.02.13 12:44 Сейчас в теме
(5)Спасибо за критику. Способ не совсем правильный, но зато работает :)
6. yuraos 1001 13.02.13 10:30 Сейчас в теме

Теперь перейдем в отчет «Остатки номенклатуры», откроем основную схему компоновки данных на вкладке «Вложенные схемы». После добавления новой вложенной схемы, загрузим сохраненную схему. Хочу обратить внимание на то, что нельзя изменять имя и заголовок отчета.

А почему собственно нельзя менять, можно по-подробнее ?
Чтобы не менять их в примере кода ниже по тексту статьи ???
7. akomar 457 13.02.13 12:42 Сейчас в теме
(6)Нельзя менять - потому что не сможете добавить вложенную схему в вариант отчета (по моему инфа есть в бесплатных уроках по СКД на сайте spec8.ru)
13. yuraos 1001 13.02.13 14:46 Сейчас в теме
(7)
СКД также неисчерпаема, как 1С.
а 1С также неисчепаема, как электрон.
а электрон также неисчерпаем, как атом.
---
Нуралиев - верный марксист-ленинец,
творчески развивает идеи классиков!
:)
Михаська; ЧерныйКот; sa1m0nn; +3 Ответить
16. StepanZaytsev 03.10.13 14:27 Сейчас в теме
(7)название можно менять
DmitrySinichnikov; +1 Ответить
11. Новенький_2209 13.02.13 13:46 Сейчас в теме
Хорошая статья. Очень бы хотелось посмотреть как в шаблоне типового отчета (который на обычных формах) можно:
1. разрешить использование вложенных схем
2. заставить работать интерфейсные элементы, с этими вложенными схемами.

П.1 я победил. По п.2 - копал глубоко, но расковырять так и не смог. Если бы автор как то просветил этот момент - цветы к его прижизненному памятнику обещаю носить ежегодно :)
18. trumanl 12 18.11.14 11:27 Сейчас в теме
(11) Новенький_2209, Вы не подскажите как вы "победили" в шаблоне типового отчета использование вложенных схем ??
19. akomar 457 18.11.14 11:52 Сейчас в теме
(18) Хм, как нибуть конкретизируйте вопрос :)
14. DoctorRoza 13.02.13 19:08 Сейчас в теме
Неплохо, может и пригодится!
15. masik85 21 14.02.13 08:55 Сейчас в теме
спасибо за статью, у нас такие же пользователи-извращенцы соответственно и программистам приходится извращаться, как я вас понимаю
17. Ele1234567 21.05.14 12:47 Сейчас в теме
Подскажите а как в таком варианте реализации отчета программно установить параметры для вложенной схемы?
22. 20tanush 30.03.16 10:40 Сейчас в теме
(17) Ele1234567, попробую помочь:
ПараметрыВложСхемы = КомпоновщикНастроек.Настройки.Структура[1].Настройки.ПараметрыДанных.Элементы; // индекс в структуре у вас может быть другой, посмотрите в отладчике
ВложПараметр = ПараметрыВложСхемы.Найти("ИмяВашегоПараметра");
	ВложПараметр.Использование = Истина;
	ВложПараметр.Значение  = ЗначениеВашегоПараметра;

У меня это работает. Спасибо вот этой статье: http://www.forum.mista.ru/topic.php?id=492695
20. Kuklachel 10.06.15 17:22 Сейчас в теме
Добрый день. Я все делаю как у вас указано, Создаю схему отчета во вложенных схемах, загружаю туда xml, на вкладке "настройки" добавляю вариант отчета и добавляю в него вложенный отчет. В режиме предприятия видны два варианта, но формируется только основной. Подскажите, пожалуйста, почему так?
21. user_2010 943 22.03.16 11:52 Сейчас в теме
(20) Kuklachel, так и должно быть: формируя отчет - вы выбираете вариант, который хотите сформировать. Ваш вариант содержит только один отчет - он и формируется.
Автор реализовал возможность открыв один отчет - выбирать разные варианты отчета и формировать их.
А вам нужно, видимо, в одном отчете сформировать два разных отчета. Тоже сейчас над этим думаю...
23. quares 21 23.11.17 13:23 Сейчас в теме
Спасибо, пригодилось!
Изначально изобретал велосипед и создавал две отдельные схемы с мудрёным переключением между ними.
Оставьте свое сообщение