Программное добавление колонки в дерево значений на управляемой форме в расширении

02.04.23

Разработка - Работа с интерфейсом

Программно создаём колонку дерева значений при необходимости и заполняем её значениями.

В данном примере добавим колонку "Водитель" на форме обработки, которая управляет доставкой.

Сначала создаём колонку в процедуре "ПриСозданииНаСервере".

&НаСервере
Процедура расш_ПриСозданииНаСервереПосле(Отказ, СтандартнаяОбработка)
	
	расш_СоздатьКолонкуВодитель();
	расш_ЗаполнитьКолонкуВодитель();
	
КонецПроцедуры

Но создать колонку только в процедуре "ПриСозданииНаСервере" недостаточно.
Необходимо создавать её при каждом выполнении процедуры "СохранитьЗаданияОбновитьСписки", потому что дерево будет формироваться каждый раз заново.

&НаСервере
&После("СохранитьЗаданияОбновитьСписки")
Процедура расш_СохранитьЗаданияОбновитьСписки()
	
	расш_СоздатьКолонкуВодитель();
	расш_ЗаполнитьКолонкуВодитель();
	
КонецПроцедуры

Проверяем, существует ли уже колонка, и создаём, если она ещё не создана.
Внимательно смотрим, в какую группу вставить свой элемент. На форме могут быть колонки, объединённые в группы.

&НаСервере
Процедура расш_СоздатьКолонкуВодитель()
	
	расш_Дерево = РеквизитФормыВЗначение("ЗаданияНаПеревозкуПланируемые");      
	Если расш_Дерево.Колонки.Найти("расш_Водитель") = Неопределено Тогда
		МассивДобавляемыхРеквизитов = Новый Массив;  
		ТипРеквизитаСтрока = Новый ОписаниеТипов("Строка");
		МассивДобавляемыхРеквизитов.Добавить(Новый РеквизитФормы("расш_Водитель", ТипРеквизитаСтрока, "ЗаданияНаПеревозкуПланируемые"));
		ИзменитьРеквизиты(МассивДобавляемыхРеквизитов);	
		
		расш_ВодительЭлемент = Элементы.Вставить("расш_ВодительЭлемент", Тип("ПолеФормы"), ЭтаФорма.Элементы.ЗаданияНаПеревозкуПланируемыеГруппаТранспорт, ЭтаФорма.Элементы.ЗаданияНаПеревозкуПланируемыеТранспорт);
		расш_ВодительЭлемент.Вид = ВидПоляФормы.ПолеВвода;
		расш_ВодительЭлемент.ПутьКДанным = "ЗаданияНаПеревозкуПланируемые.расш_Водитель";
		расш_ВодительЭлемент.Заголовок = "Водитель";  
	КонецЕсли;
	
КонецПроцедуры

Заполняем нашу колонку значениями.
Напрямую взаимодействовать с деревом значений не получится.
Нужно использовать метод РеквизитФормыВЗначение("ЗаданияНаПеревозкуПланируемые").

&НаСервере
Процедура расш_ЗаполнитьКолонкуВодитель()

	расш_Дерево = РеквизитФормыВЗначение("ЗаданияНаПеревозкуПланируемые");  
	Для каждого СтрокаДЗ Из расш_Дерево.Строки Цикл 
		СтрокаДЗ.расш_Водитель = ""+СтрокаДЗ.Ссылка.Водитель; 
	КонецЦикла;	
	ЗначениеВРеквизитФормы(расш_Дерево,"ЗаданияНаПеревозкуПланируемые");	
	
КонецПроцедуры

 

дерево значений

См. также.

Работа с интерфейсом Программист Платформа 1С v8.3 Конфигурации 1cv8 Платные (руб)

Обработка предназначена для создания и управления дашбордами.

2400 руб.

29.06.2020    17351    23    4    

37

Работа с интерфейсом Платформа 1С v8.3 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Зарплата и Управление Персоналом 3.x 1С:Управление нашей фирмой 3.0 Бесплатно (free)

Добавьте новогоднего настроения! Расширение создает декорацию в виде гирлянды на некоторых формах объектов.

27.12.2023    11951    781    elcoan    47    

109

Инструментарий разработчика Работа с интерфейсом Программист Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Подходит для создания web-страниц для замены управляемых форм 1С, красивых отчетов, интерфейса мобильного приложения на платформе 1С и для простых страниц веб-сайтов.

2 стартмани

10.04.2023    10406    158    acces969    31    

120

Работа с интерфейсом Программист Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

"MVC плохо применима в 1С" - познакомьтесь с моделью состояния и, возможно, ваше мнение поменяется! Представленное решение является эволюционным развитием идеи реализации MVC для 1С. В новой версии добавлены DSL для описания модели состояния, а также параметризация свойств параметров и элементов формы.

1 стартмани

05.07.2022    4376    kalyaka    4    

31

Работа с интерфейсом Платформа 1С v8.3 Платные (руб)

Подсистема условного оформления элементов форм (далее подсистема) предназначена для настройки оформления элементов форм (видимость, доступность, цвет фона, цвет текста и прочее) в пользовательском режиме 1С. Также подсистему возможно использовать для ограничения доступа к реквизитам формы для определенных пользователей (или групп пользователей).

6000 руб.

18.01.2022    9205    1    2    

6

Работа с интерфейсом Программист Платформа 1С v8.3 Конфигурации 1cv8 Бесплатно (free)

Реализовал простой способ программного создания новых элементов, команд и реквизитов на форме.

25.11.2021    10254    AtamanovYS    19    

143
Оставьте свое сообщение