Создание обмена между двумя конфигурациями на БСП с помощью Конвертации Данных 2.0

23.08.23

Интеграция - Обмен между базами 1C

Я кратко описал пару простых шагов, чтобы запустить обмен между двумя конфигурациями на БСП. Это просто и легко, но, к сожалению, материала и достойной статьи я не нашел. Пришлось "разбить лоб" самому. Чтобы у вас не было такой проблемы, я написал эту статью.

1. Задача сделать обмен между двумя конфигурациями на БСП.

Получил задачу и сразу вопрос "Как это сделать?", спросил у Гугла, спросил у ИТС ... ответа толкового нет. Ведь все же просто, но где нужно поставить волшебную галочку, а где поставить немного кода? Чтобы вы не "Разбили" свою голову, я хочу с вами поделиться небольшим кодом и пошаговым описанием, что нужно сделать. 

2. Добавить обмен с одинаковым именем в обе базы.

Условное наименование  ОбменСДругойБазой

Добавляем план обмена, чтобы он был виден среди всех планов обменов. (Через расширение)

ОбменДаннымиПовтИсп.СписокПлановОбменаБСП

&ИзменениеИКонтроль("СписокПлановОбменаБСП") 
Функция Расш_СписокПлановОбменаБСП() Экспорт    
    // Возвращаемое значение функции.
    СписокПлановОбмена = Новый СписокЗначений;
    ПланыОбменаПодсистемы = Новый Массив;
    ОбменДаннымиПереопределяемый.ПолучитьПланыОбмена(ПланыОбменаПодсистемы);
    Для Каждого ПланОбмена Из ПланыОбменаПодсистемы Цикл
        СписокПлановОбмена.Добавить(ПланОбмена.Имя, ПланОбмена.Синоним);
    КонецЦикла;
    #Вставка
        //Добавим свой план обмена    
        ПОБП = Метаданные.ПланыОбмена.ОбменСДругойБазой;
        СписокПлановОбмена.Добавить(ПОБП.Имя, ПОБП.Синоним);
    #КонецВставки
    Возврат СписокПлановОбмена;
КонецФункции

 

К Плану обмена надо добавить следующие макеты (зеркально надо добавлять в базу приемник).

  • ПравилаОбмена (Текстовый документ)
  • ПравилаОбменаКорреспондента (Текстовый документ)
  • ПравилаРегистрации (Текстовый документ)
  • ПодробнаяИнформация (HTML документ)

 

 

В модуль менеджера плана обмена (основной конфигурации, или в расширении) добавляем код

Процедура ПриПолученииНастроек(Настройки) Экспорт
    Настройки.ИмяКонфигурацииИсточника = "";
    Настройки.НаличиеПравилКонвертацииОбязательно = Истина;  
КонецПроцедуры

 

Добавить форму узла.

 

 

В форме добавить запись


&НаСервере
Процедура ПриЗаписиНаСервере(Отказ, ТекущийОбъект, ПараметрыЗаписи)
	// запишем в регистр "Общие настройки узлов информационных баз" информацию о данной базе
	Если текущийОбъект.ЭтотУзел = Ложь тогда
	ЗаписьИнф = РегистрыСведений.ОбщиеНастройкиУзловИнформационныхБаз.СоздатьМенеджерЗаписи();
	ЗаписьИнф.УзелИнформационнойБазы = текущийОбъект.ссылка;
	ЗаписьИнф.НастройкаЗавершена = истина;
	ЗаписьИнф.Префикс = "БП"; //// ОБЯЗАТЕЛЬНО ЗАПОЛНИТЬ
	ЗаписьИнф.ПрефиксКорреспондента = "УТ";   // ОБЯЗАТЕЛЬНО ЗАПОЛНИТЬ
	ЗаписьИнф.Записать(Истина);
	КонецЕсли;
КонецПроцедуры

 

В ней надо разместить следующие команды

  • ЗагрузитьПравила  (Что бы загрузить подготовленные правила, без обновления конфигурации)
&НаКлиенте
Процедура ЗагрузитьПравила(Команда)
	ОбменДаннымиКлиент.ЗагрузитьПравилаСинхронизацииДанных("ОбменСДругойБазой");
КонецПроцедуры
  • НастройкиПодключения   (Открыть настройки подключения связанные с этим планом обмена)
&НаКлиенте
Процедура НастройкиПодключения(Команда)	
	Корреспондент = объект.Ссылка;
	ИдентификаторНастройки = "";

	Отбор              = Новый Структура("Корреспондент", Корреспондент);
	ЗначенияЗаполнения = Новый Структура("Корреспондент", Корреспондент);
		
	ОбменДаннымиКлиент.ОткрытьФормуЗаписиРегистраСведенийПоОтбору(Отбор,
	ЗначенияЗаполнения, "НастройкиТранспортаОбменаДанными", Этаформа);
КонецПроцедуры

  • ОбновитьСведенияОПравилах (Обновляет сведения и правила зашитые в конфигурации в макетах)
&НаСервере
Процедура ОбновитьСведенияОПравилахНаСервере()
	// запишем правила
	ЗаписьПравилаОбмена = регистрыСведений.ПравилаДляОбменаДанными.СоздатьМенеджерЗаписи();
	ЗаписьПравилаОбмена.ИмяПланаОбмена = "ОбменСДругойБазой";
	ЗаписьПравилаОбмена.ВидПравил = Перечисления.ВидыПравилДляОбменаДанными.ПравилаКонвертацииОбъектов;
	
	ЗаписьПравилаОбмена.ИмяМакетаПравил	= "ПравилаОбмена";
	ЗаписьПравилаОбмена.ИмяМакетаПравилКорреспондента = "ПравилаОбменаКорреспондента";
	ЗаписьПравилаОбмена.ИмяПланаОбменаИзПравил = "";  
	ЗаписьПравилаОбмена.ИмяФайлаОбработкиДляОтладкиВыгрузки = "";
	ЗаписьПравилаОбмена.ИмяФайлаОбработкиДляОтладкиЗагрузки = ""; 
	ЗаписьПравилаОбмена.ИмяФайлаПравил = "";
	ЗаписьПравилаОбмена.ИмяФайлаПротоколаОбмена = "";
	ЗаписьПравилаОбмена.ИнформацияОПравилах = "";
	ЗаписьПравилаОбмена.ИсточникПравил = перечисления.ИсточникиПравилДляОбменаДанными.МакетКонфигурации;
	ЗаписьПравилаОбмена.НеОстанавливатьПоОшибке = "";
	ЗаписьПравилаОбмена.ПравилаXML = "";
	ЗаписьПравилаОбмена.ПравилаXMLКорреспондента = "";
	ЗаписьПравилаОбмена.ПравилаЗачитанные = "";
	ЗаписьПравилаОбмена.ПравилаЗачитанныеКорреспондента = "";
	ЗаписьПравилаОбмена.РежимОтладки	 = Ложь;
	ЗаписьПравилаОбмена.РежимОтладкиВыгрузки = Ложь;
	ЗаписьПравилаОбмена.РежимОтладкиЗагрузки = Ложь;
	ЗаписьПравилаОбмена.РежимПротоколированияОбменаДанными = "";
	ЗаписьПравилаОбмена.ИмяМенеджераРегистрации	 = "";
	
	//ЗаписьПравилаОбмена.ПравилаЗагружены
	ЗаписьПравилаОбмена.Записать(Истина);

	ЗаписьПравилаОбмена = регистрыСведений.ПравилаДляОбменаДанными.СоздатьМенеджерЗаписи();
	ЗаписьПравилаОбмена.ИмяПланаОбмена = "ОбменСДругойБазой";
	ЗаписьПравилаОбмена.ВидПравил = Перечисления.ВидыПравилДляОбменаДанными.ПравилаРегистрацииОбъектов;
	
	ЗаписьПравилаОбмена.ИмяМакетаПравил	= "ПравилаРегистрации";
	ЗаписьПравилаОбмена.ИмяМакетаПравилКорреспондента = "";
	ЗаписьПравилаОбмена.ИмяПланаОбменаИзПравил = "";  
	ЗаписьПравилаОбмена.ИмяФайлаОбработкиДляОтладкиВыгрузки = "";
	ЗаписьПравилаОбмена.ИмяФайлаОбработкиДляОтладкиЗагрузки = ""; 
	ЗаписьПравилаОбмена.ИмяФайлаПравил = "";
	ЗаписьПравилаОбмена.ИмяФайлаПротоколаОбмена = "";
	ЗаписьПравилаОбмена.ИнформацияОПравилах = "";
	ЗаписьПравилаОбмена.ИсточникПравил = перечисления.ИсточникиПравилДляОбменаДанными.МакетКонфигурации;
	ЗаписьПравилаОбмена.НеОстанавливатьПоОшибке = "";
	ЗаписьПравилаОбмена.ПравилаXML = "";
	ЗаписьПравилаОбмена.ПравилаXMLКорреспондента = "";
	ЗаписьПравилаОбмена.ПравилаЗачитанные = "";
	ЗаписьПравилаОбмена.ПравилаЗачитанныеКорреспондента = "";
	ЗаписьПравилаОбмена.РежимОтладки	 = Ложь;
	ЗаписьПравилаОбмена.РежимОтладкиВыгрузки = Ложь;
	ЗаписьПравилаОбмена.РежимОтладкиЗагрузки = Ложь;
	ЗаписьПравилаОбмена.РежимПротоколированияОбменаДанными = "";
	ЗаписьПравилаОбмена.ИмяМенеджераРегистрации	 = "";
	
	//ЗаписьПравилаОбмена.ПравилаЗагружены
	ЗаписьПравилаОбмена.Записать(Истина);
	
	////// теперь обработаем правила.
	ИсточникПравилКомплекта = Перечисления.ИсточникиПравилДляОбменаДанными.МакетКонфигурации;
	
	ЗаписьПравилКонвертации                               = РегистрыСведений.ПравилаДляОбменаДанными.СоздатьМенеджерЗаписи();
	ЗаписьПравилКонвертации.ВидПравил                     = Перечисления.ВидыПравилДляОбменаДанными.ПравилаКонвертацииОбъектов;
	ЗаписьПравилКонвертации.ИмяМакетаПравил               = "ПравилаОбмена";
	ЗаписьПравилКонвертации.ИмяМакетаПравилКорреспондента = "ПравилаОбменаКорреспондента";
	ЗаписьПравилКонвертации.ИнформацияОПравилах           = "";
	
	//ЗаполнитьЗначенияСвойств(ЗаписьПравилКонвертации, ЭтотОбъект);
	ЗаписьПравилКонвертации.ИмяПланаОбмена = "ОбменБухгалтерияПредприятияУИ";
	ЗаписьПравилКонвертации.ИсточникПравил = Перечисления.ИсточникиПравилДляОбменаДанными.МакетКонфигурации;
	
	ЗаписьПравилРегистрации                     = РегистрыСведений.ПравилаДляОбменаДанными.СоздатьМенеджерЗаписи();
	ЗаписьПравилРегистрации.ВидПравил           = Перечисления.ВидыПравилДляОбменаДанными.ПравилаРегистрацииОбъектов;
	ЗаписьПравилРегистрации.ИмяМакетаПравил     = "ПравилаРегистрации";
	ЗаписьПравилРегистрации.ИнформацияОПравилах = "ПравилаРегистрации";
	ЗаписьПравилРегистрации.ИмяФайлаПравил      = "";
	ЗаписьПравилРегистрации.ИмяПланаОбмена      = "ОбменСДругойБазой";
	ЗаписьПравилРегистрации.ИсточникПравил      =  Перечисления.ИсточникиПравилДляОбменаДанными.МакетКонфигурации;
	ЗаписьПравилРегистрации.ИмяПланаОбмена = "ОбменСДругойБазой";

	СтруктураЗаписейРегистра = Новый Структура();
	СтруктураЗаписейРегистра.Вставить("ЗаписьПравилКонвертации", ЗаписьПравилКонвертации);
	СтруктураЗаписейРегистра.Вставить("ЗаписьПравилРегистрации", ЗаписьПравилРегистрации);
	
	Отказ = ложь;     
	ОписаниеОшибки = "";                        
	АдресВременногоХранилища = "";                    
	ИмяФайлаПравил = "";
	РегистрыСведений.ПравилаДляОбменаДанными.ЗагрузитьКомплектПравил(Отказ, СтруктураЗаписейРегистра,
		ОписаниеОшибки, АдресВременногоХранилища, ИмяФайлаПравил);
	
	Если Не Отказ Тогда
		ЗаписьПравилКонвертации.Записать();
		ЗаписьПравилРегистрации.Записать();
	КонецЕсли;
			
КонецПроцедуры

&НаКлиенте
Процедура ОбновитьСведенияОПравилах(Команда)
	ОбновитьСведенияОПравилахНаСервере();
КонецПроцедуры

3. Доработать расширение

В расширении захватить план обмена, и документы которые надо регистрировать к обмену. 

В плане обмена указать состав объектов к обмену.

Обязательно добавить в обмен регистрСведений.СоответствияОбъектовИнформационныхБаз и в расширение.

 

 

4. Убрать процедуру удаления файлов при каждом обмене (так как 1сцы считают что больше никто не пользуется правилами обмена 2.0, то при каждом обновлении правила обмена удаляются) (взял у https://forum.infostart.ru/forum29/topic221697/)

В основной конфигурации в модуле "ОбменДаннымиСервер" в процедуре "УдалитьНеактуальныеЗаписиВРегистреПравилДляОбменаДанными" 

закомментировал код

//  НаборЗаписей.Записать();


 

Все, можно настраивать папку и делать первый обмен. Все стандартные инструменты уже будут доступны в этом обмене.

 

UPD:

Далее нам понадобилось настроить работу правил регистрации. Как это сделать описано тут //infostart.ru/1c/articles/1922737/

конвертация20 конвертация ОБМЕН ОБМЕН БСП

См. также

SALE! 10%

Перенос данных из УПП 1.3 в ERP 2 / УТ 11 / КА 2

Обмен между базами 1C Платформа 1С v8.3 1С:Управление производственным предприятием Россия Платные (руб)

Продано более 270 раз! Обработка позволяет перенести из УПП в ERP / 1С:УТ 11 / КА 2 всю возможную информацию. Переносятся документы, а также начальные остатки и справочная информация. Типовая обработка от фирмы 1С не позволяет сохранить документы за период работы. Кроме того, наши алгоритмы выгрузки начальных остатков тоже имеют больше функционала и тщательно проверялись на реальных проектах перехода с УПП на ERP. Наша разработка будет полезна как фирмам-франчайзи, которые периодически выполняют перенос данных для заказчиков, так и организациям, самостоятельно выполняющим проект по переходу. При приобретении обработки вы будете четыре месяца получать ее обновления, далее можно приобрести подписку на обновления. Конфигурации 1С постоянно меняются, выходят новые релизы. Имея подписку на обновления, вы всегда можете быть уверены, что правила конвертации данных будут работать на ваших базах 1С.

50722 45650 руб.

04.08.2015    155970    289    263    

331

SALE! 10%

Перенос данных из УПП 1.3 / КА 1.1 в БП 3.0 (переносятся документы, начальные остатки, справочники)

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Управление производственным предприятием Россия Бухгалтерский учет Платные (руб)

Предлагаем перенос данных из УПП 1.3 в БП 3.0 (или из КА 1.1 в БП 3.0). Переносятся документы, начальные остатки и вся справочная информация. Есть фильтр по организации и множество других параметров выгрузки. Поддерживается несколько сценариев работы: как первичный полный перенос, так и перенос только новых документов. Перенос данных возможен в 1С: Бухгалтерию 3.0 версии ПРОФ, КОРП или базовую. Переход с "1С: Управление производственным предприятием 1.3" / "1С:Комплексная автоматизация 1.1" на "1С:Бухгалтерия предприятия 3.0" с помощью наших правил конвертации будет максимально комфортным! Обработка входит в ТОП продаж Инфостарта!

43889 39500 руб.

25.02.2015    167012    284    236    

367

SALE! 15%

[ED3] Обмен для ERP 2.5, КА 2.5, УТ 11.5 БП 3.0, Розница, УНФ и других с EnterpriseData (универсальный формат обмена), правила обмена

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 1С:Розница 2 1С:Управление нашей фирмой 1.6 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Управление нашей фирмой 3.0 1С:Розница 3.0 Россия Платные (руб)

Правила в универсальном формате обмена для ERP 2.5, КА 2.5, УТ 11.5, БП 3.0, Розница, УНФ, для последних версий конфигураций. Ссылки на другие конфигурации в описании публикации. Правила совместимы со всеми другими версиями конфигураций новыми и старыми, поддерживающими обмен в формате EnterpriseData. Не требуется синхронного обновления правил после обновления другой конфигурации, участвующей в обмене. Типовой обмен через планы обмена кнопкой Синхронизация вручную или автоматически по расписанию, или вручную обработкой.

25080 руб.

12.06.2017    131810    687    290    

379

SALE! 10%

Перенос данных из УПП 1.3 в БП 3.0. Переносятся документы (обороты за период), справочная информация и остатки

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 1С:Управление производственным предприятием 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Управленческий учет Платные (руб)

Перенос данных из 1С:Управление производственным предприятием 1.3 в 1С: Бухгалтерия предприятия 3.0 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная информация. Правила тестировались на конфигурациях УПП 1.3 (1.3.215.x) и БП 3.0 (3.0.144.x). Правила подходят для версии ПРОФ и КОРП.

28000 25200 руб.

15.12.2021    18286    114    36    

69

SALE! 10%

Перенос данных из ERP 2 / КА 2 в ЗУП 3

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Комплексная автоматизация 2.х Россия Бухгалтерский учет Управленческий учет Платные (руб)

Наша обработка позволяет не только перенести все документы, справочную информацию и начальные остатки из ERP 2 или КА 2 в ЗУП 3, но и организовать регулярный перенос данных между программами 1С:ERP 2 / КА 2 и 1С:ЗУП 3. Вы можете выбрать период отбора данных и установить фильтр по организациям, чтобы выгружать только необходимую информацию. Более того, перенос оперативно обновляется при выходе новых релизов программы 1С, так что вы всегда будете иметь самую актуальную версию обработки.

48278 43450 руб.

03.12.2020    32734    69    56    

71

SALE! 10%

Перенос данных из УТ 10.3 в УТ 11 / КА 2 / ERP 2 (ЕРП 2)

Обмен между базами 1C Взаиморасчеты Оптовая торговля Логистика, склад и ТМЦ Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 1С:Управление торговлей 10 Россия Управленческий учет Платные (руб)

Предлагаем вам качественное и проверенное временем решение для перехода с УТ 10.3 на УТ 11 / КА 2 / ERP 2. Перенос данных находится в продаже с 2015 года, постоянно развивается, им воспользовались уже более 240 компаний. Можно перенести начальные остатки, нормативно-справочную информацию и все возможные документы. При выгрузке можно установить отбор по периоду, организациям и складам. При выходе новых релизов конфигураций 1C оперативно выпускаем обновление переноса данных.

50722 45650 руб.

24.04.2015    188285    264    235    

267

SALE! 10%

Перенос данных из БП 2.0 в БП 3.0

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 2.0 Россия Бухгалтерский учет Налоговый учет Платные (руб)

С помощью настоящих правил обмена можно выполнить переход с программы 1С:БП 2.0 на 1С:БП 3.0, если типовой способ (переход при помощи обновления релиза программы) от фирмы 1С вам по каким-то причинам не подходит. Переносится вся справочная информация, документы за выбранный период, а также начальные остатки на выбранную дату. Кроме того, мы оперативно обновляем правила конвертации при выходе новых версий программы 1С, чтобы ваши данные всегда были актуальными. Если у вас возникнут вопросы, не стесняйтесь обращаться к нам за технической поддержкой через тикеты на Инфостарте. Мы готовы помочь вам разобраться в любых вопросах, связанных с использованием нашего программного обеспечения.

44222 39800 руб.

21.05.2019    48557    69    100    

64

SALE! 10%

Перенос данных из ERP 2 / КА 2 / УТ 11 в БП 3.0

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Платные (руб)

Перенос позволяет настроить собственный обмен данными между указанными программами, альтернативный предлагаемому фирмой 1С. Перенос данных осуществляется из 1С:ERP 2 / 1С:КА 2 / 1С:УТ 11 в 1С:БП 3.0. Правила обмена оперативно обновляются при выходе новых релизов программы 1С, так что вы всегда будете иметь самую актуальную версию обработки.

38500 34650 руб.

15.04.2019    66183    164    131    

97
Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. sapervodichka 6602 05.07.23 14:33 Сейчас в теме
Нехватает упоминания о включении плана обмена в общие команды (НастройкиПодключения, СобытияОтправки, СоставОтправляемыхДанных, СценарииСинхронизации и т.д.) для работы с ним, о ролях для пользователей (чтобы ошибки не возникало при регистрации изменений), режимом совместимости расширения от 8.3.14 должен быть по-моему (на более ранний план обмена не добавить). +1
7. uribur 115 05.07.23 20:11 Сейчас в теме
(1) в этом случае надо снимать с поддержки, и обновление превратится в мучение. Добавили нужные команды на форме, и их нам достаточно. Обновить правила - больше ничего не надо.
8. sapervodichka 6602 05.07.23 21:47 Сейчас в теме
(7) понял, без меня тут будет лучше ))
9. uribur 115 06.07.23 12:24 Сейчас в теме
(8) нет что вы ) Наоборот, может кому то хочется извращений с обновлением конфигурации ))
10. maksa2005 472 06.07.23 13:46 Сейчас в теме
(9)Не знаю за какие трудности вы говорите) правила написал с тот же скд. доработал план обмена
учел (НастройкиПодключения, СобытияОтправки, СоставОтправляемыхДанных, СценарииСинхронизации и т.д)
и работает уже больше года. Обновление все проходят, да они вообще не мешают
11. uribur 115 06.07.23 14:24 Сейчас в теме
(10) если вам не мешают, то прекрасно ) Мне вообще не нравится вариант открытия конфы разработчика, поэтому я всегда за обход.
ivprovotorov; +1 Ответить
12. sapervodichka 6602 06.07.23 16:35 Сейчас в теме
(9) я об изменениях конфигурации не писал ни слова, данные команды надо использовать как и план обмена в расширении, команды роли, режим совместимости...

P.S. Представляешь я тоже раньше критику и советы людей, которые например обмен сотни раз уже делали не воспринимал, знаешь с возрастом это проходит.
13. uribur 115 06.07.23 16:41 Сейчас в теме
(12) странно я даже не воспринял Ваши слова за критику, а наоборот принял за дельный совет и вариант реализации. Если я дал ответ, значит просто сказал что есть вариант ''just different' не более.

P.S. facepalm Когда ведешь диалог с человеком, а он почему то обиделся... :(
Больше вам не отвечаю )
2. Samarin 96 05.07.23 15:37 Сейчас в теме
В функции "ОбменДаннымиПовтИсп.СписокПлановОбменаБСП" вызов ОбменДаннымиПереопределяемый.ПолучитьПланыОбмена был добавлен именно для дополнительных планов обмена.


Процедура ПолучитьПланыОбмена(ПланыОбменаПодсистемы) Экспорт

ПланыОбменаПодсистемы.Добавить(Метаданные.ПланыОбмена.ОбменСДругойБазой);

КонецПроцедуры
6. uribur 115 05.07.23 20:11 Сейчас в теме
(2) Можно и там. В любом случае это делалось через расширение, основные модули не снимались с поддержки.
3. Tangram 158 05.07.23 15:43 Сейчас в теме
Материалы на ИТС в разделе внедрения подсистемы ОбменДанными. Все четко описано, какие макеты, какие команды и т.д.
5. uribur 115 05.07.23 20:10 Сейчас в теме
(3) если можно пришлите ссылочку, в процессе внедрения детальной информации там совсем не было.
4. quazare 3491 05.07.23 16:48 Сейчас в теме
Не у всех есть доступ к ИТС. ИТС написан сложным языком, мелочи «не разжеваны»
cheshirshik; nightowl5; maksa2005; gamletspb; +4 Ответить
14. cheshirshik 58 07.07.23 08:47 Сейчас в теме
(4) тут соглашусь. Такое впечатление, что справка итс написана для вида. Просто чтобы было. БЕЗ слёз на нее смотреть нельзя.
16. webester 26 09.07.23 07:47 Сейчас в теме
(4)
Не у всех есть доступ к ИТС

Можно юзать dropmail, регать туда пробник и юзать ИТС неделю, через неделю если нужен ИТС, повторить цикл. Говорят, что раньше работало. Проверять я это конечно не буду. Делов 10 минут. Муторно но не так, чтобы недоступно.
15. webester 26 09.07.23 07:42 Сейчас в теме
(0)
но, к сожалению, материала и достойной статьи я не нашел

Исправляем :)
Начнем с оф документации к БСП. Да сложно, но надо научиться читать документацию от 1С, там очень часто бывают описаны неочевидные моменты. Ну и в данном конкретном случае это вообще максимально полное описание https://its.1c.ru/db/bsp319doc#content:4:1:issogl1_обмен_данными
Ну и статьи на ИС
https://infostart.ru/1c/articles/1316278/
https://infostart.ru/1c/articles/1187782/
https://infostart.ru/1c/articles/544413/
Не совсем то конечно, но что-то там было нужное, не помню, что :) https://infostart.ru/1c/articles/697808/
Тем кто любит видосы плейлист по работе с БСП там и про обмены индекс оставил именно на видосе про планы обмена https://www.youtube.com/watch?v=GJisV536NPk&list=PL8TlceaQF_l_CMirNFV1rgUfXUM_w_JMD&index=­49 сам я больше люблю текст, поэтому насколько там полная и актуальная инфа, сказать не могу, сорян.
Krotov_Valery; legenda-nsh; KirillZ44; gamletspb; TokarevV; dooD1iez; kser87; NeLenin; sapervodichka; +9 Ответить
17. kser87 2403 10.07.23 13:01 Сейчас в теме
Однозначно пригодиться
18. user673778_karavaykov 1 11.07.23 10:09 Сейчас в теме
Норм. Жаль что статьи не было в марте месяце, когда я делал такой обмен для своих задач. Затер до дыр глазами документацию с ИТС и код модуля менеджера плана обмена в тестовом дистрибутиве БСП 3.1. Когда всё худо бедно заработало, столкнулся с необходимостью создания правил регистрации. Чтобы из сотни моих контор обмен в базе проходил только для десяти. Потом столкнулся с проблемой, что в обработке УнивкерсальныйОбменДаннымиВФорматеXML и с использованием плана обмена работают иначе. Но, в общем и целом, задача интересная
19. Tarlich 115 12.07.23 23:42 Сейчас в теме
Статью в закладочку ....
сейчас стоит задача обмена двухстороннего УТ 10,3 и УНФ - может есть какая ссылка на материал ?
20. user1152948 05.09.23 14:04 Сейчас в теме
А как обошли ошибку в регистре сведений "НастройкиТранспортаОбменаДанными" при настройке обмена? Измерение регистра "Корреспондент" не видит план обмена добавленный в расширении, а в режиме совместимости 8.3.17 нет возможности изменять состав в измерениях регистра в расширении.
Оставьте свое сообщение