Функция СведенияОВнешнейОбработке() в 1С

01.09.23

Разработка - Универсальные функции

Из этой статьи вы узнаете, для чего нужна Функция СведенияОВнешнейОбработке() и как ее составить. Информация в первую очередь будет полезна начинающим программистам 1С 8.3 (управляемые формы).

Функция СведенияОВнешнейОбработке() нужна:

1) чтобы сделать внешнюю обработку (или отчет)  внутренней;

2) разместить свою доработку во фреш;

3) разместить публикацию на Инфостарт.

 

Зайдите в меню 1С "Администрирование \ Печатные формы, отчеты и обработки \

Подключение внешних компонент сторонних поставщиков к программе

[v]Дополнительные отчеты и обработки":

рядом Дополнительные отчеты и обработки

[Добавить из файла] \ [Продолжить]

выбрать файл с обработкой

Можно поместить в меню 1С, нажав

Размещение Не определено

[Выполнить] и [Записать и закрыть]

 

Иногда внешние обработки могут не запускаться. Чтобы пользователь мог их использовать, необходимо войти через 1С Конфигуратор и "Пользователь \ [v]Интерактивное открытие внешних отчетов и обработок".

Потом "=" \ Файл \ Открыть.

Если у внешней обработке войти в "Подсистемы" (или ПКМ \ Дополнительно), то можно включить ее в меню 1С.

 

Пример функции СведенияОВнешнейОбработке() для внешней обработки взят из

"Упрощенное меню для программы 1С:Бухгалтерия..."

//infostart.ru/1c/tools/1879112/

 

Внизу формы обработки: Действия \ Открыть модуль объекта, поместить туда

Функция СведенияОВнешнейОбработке() Экспорт   

//Изменить на свои
ВерсияВО = "01";
КраткоВО = "Тренажер для изучения 1С: БП 3.0 (УСН)";
ИнформацияВО     = "Упрощенное меню для программы 1С:Бухгалтерия (версия 1) = тренажер для изучения 1С: БП 3.0 (УСН)";
ИдентификаторВО = "КонтрагентыПоискДублей";

     //Остальное не трогать
     ПараметрыРегистрации = ДополнительныеОтчетыИОбработки.СведенияОВнешнейОбработке();
     ПараметрыРегистрации.Вид = ДополнительныеОтчетыИОбработкиКлиентСервер.ВидОбработкиДополнительнаяОбработка();
     ПараметрыРегистрации.Информация = НСтр("ru = '" + ИнформацияВО + "'");
     ПараметрыРегистрации.Версия = ВерсияВО;

     НоваяКоманда = ПараметрыРегистрации.Команды.Добавить();
     НоваяКоманда.Представление = КраткоВО;
     НоваяКоманда.Идентификатор = ИдентификаторВО;
     НоваяКоманда.Использование = ДополнительныеОтчетыИОбработкиКлиентСервер.ТипКомандыОткрытиеФормы();
     НоваяКоманда.ПоказыватьОповещение = Ложь;

     Возврат ПараметрыРегистрации;

КонецФункции

 

1) Чтобы сделать внешнюю обработку (или отчет) внутренней:

1.1) Можно через конфигуратор выделить ветку «Обработки» дерева метаданных конфигурации, вызвать контекстное меню и выполнить в нем команду «Вставить внешнюю обработку, отчет…»

 

2) Требования к дополнительным отчетам и обработкам для фреш

см.: 1cfresh.com

 

3) Внешние обработки на Инфостарт перед размещением проходят автоматическую проверку

Нажимаем свою аватарку \ "=" \ Личный кабинет \ Моя страница \ Кабинет автора \

Мои публикации \ Название статьи \ Статистика Маркетплейса

Нажимаем на красные прямоугольники с "х", появится сообщение: "Тестирование не пройдено, обнаружены ошибки ..."

 

Информация актуальна на 2023-08-31. Проверено на 1С:Предприятие 8.3 (8.3.23.1688) Бухгалтерия предприятия (базовая), редакция 3.0 (3.0.140.20).

 

PS: Более подробно можно ознакомиться здесь:

1. Обработки 1С

2. Шпаргалка infostart.ru

 

PS2: для внешнего отчета она немного отличается (в одной строке).

СведенияОВнешнейОбработке()

См. также

Печать любых непроведенных документов для УТ, КА, ERP. Настройка печати по пользователям, документам и печатным формам

Пакетная печать Печатные формы Адаптация типовых решений Универсальные функции Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Платные (руб)

Расширение для программ 1С:Управление торговлей, 1С:Комплексная автоматизация, 1С:ERP, которое позволяет распечатывать любые печатные формы для непроведенных документов. Можно настроить, каким пользователям, какие конкретные формы документов разрешено печатать без проведения документа.

3480 руб.

22.08.2023    1243    1    4    

3

Переоткрытие внешних обработок

Универсальные функции Платформа 1С v8.3 Бесплатно (free)

На заключительных этапах, когда идет отладка или доработка интерфейса, необходимо много раз переоткрыть внешний объект. Вот один из способов автоматизации этого.

30.11.2023    2419    ke.92@mail.ru    14    

47

Валидация JSON через XDTO (включая массивы)

WEB-интеграция Универсальные функции Механизмы платформы 1С Платформа 1С v8.3 Конфигурации 1cv8 Бесплатно (free)

При работе с интеграциями рано или поздно придется столкнуться с получением JSON файлов. И, конечно же, жизнь заставит проверять файлы перед тем, как записывать данные в БД.

28.08.2023    5584    YA_418728146    6    

119

Расширение: Быстрые отборы через буфер [Alt+C] Копировать список, [Alt+V] Вставить список, [Ctrl+C] Копировать из файлов

Инструментарий разработчика Универсальные функции Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Копирует в буфер значения из списков, из ячеек отчетов, таблиц, настроек списков, других отборов и вставляет в выбранную настройку отбора. Работает с Объект не найден. Работает как в одной так и между разными базами 1С. Использует комбинации [Alt+C] Копировать список, [Alt+V] Вставить список. Также для копирования данных используется стандартная [Ctrl+C] (например из открытого xls, mxl, doc и т.п. файла скопировать список наименований)

1 стартмани

13.10.2022    14502    113    sapervodichka    106    

124

Система контроля ведения учета [БСП]

Универсальные функции Механизмы типовых конфигураций БСП (Библиотека стандартных подсистем) Платформа 1С v8.3 Конфигурации 1cv8 Бесплатно (free)

В данном материале рассмотрим типовой алгоритм подсистемы контроля учета БСП в конфигурациях на примерах.

18.07.2022    6694    quazare    8    

108

Хитрости СКД. Часть 3

СКД Универсальные функции Платформа 1С v8.3 Система компоновки данных Конфигурации 1cv8 Бесплатно (free)

Столкнулся с тем, что мне приходится писать гору отчетов. Во многих приходится использовать повторяющиеся приемы. Решил написать шпаргалку, которая, надеюсь пригодится не только мне. В этой статье: Объединение ячеек в отчете только на определенном уровне иерархии, Постобработка итогов в табличном документе, Скрытие колонок в зависимости от количества месяцев в периоде.

28.05.2022    8318    milkers    11    

91
Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. KOTzilla 15 01.09.23 12:28 Сейчас в теме
Думаю, стоит отметить, что код функции СведенияОВнешнейОбработке () может отличаться в зависимости от версии БСП.
Лично для меня, это было целым открытием, в интернете полно обработок-примеров, под любые версии БСП, возможно такие примеры есть и на 1С:Фреш, но это не точно=)
3. AlOkt 66 01.09.23 13:32 Сейчас в теме
(1) Вот именно, поэтому я и пытаюсь внести ясность (по минимуму инфы), что актуально на данный момент для внешних обработок (на примере популярных 1с БП 8.3 (упр.формы) , фрешь и Инфостарт.
У всех какие то "микро"требования, которые они и сами не могут объяснить. Причем вчера все было нормально и вроде работает, по крайней мере локально у меня на ПК. Т.е. нет жестких требований (инструкций), а универсальные они громоздки и запутанные.
2. AlOkt 66 01.09.23 13:24 Сейчас в теме
Система тестирования решений https://infostart.ru/about/help/58737/1454052/#_Toc1
4. AlOkt 66 01.09.23 14:12 Сейчас в теме
Функция СведенияОВнешнейОбработке() Экспорт	
  ПараметрыРегистрации = ДополнительныеОтчетыИОбработки.СведенияОВнешнейОбработке();
  ПараметрыРегистрации.Вид = ДополнительныеОтчетыИОбработкиКлиентСервер.ВидОбработкиДополнительнаяОбработка();
  ПараметрыРегистрации.Информация = НСтр("ru = 'Обработка предназначена одинаковых контрагентов (дубль)'");
  ПараметрыРегистрации.Версия = "00";

  НоваяКоманда = ПараметрыРегистрации.Команды.Добавить();
  НоваяКоманда.Представление = "Контрагенты поиск дублей";
  НоваяКоманда.Идентификатор = "КонтрагентыПоискДублей";
  НоваяКоманда.Использование = ДополнительныеОтчетыИОбработкиКлиентСервер.ТипКомандыОткрытиеФормы();
  НоваяКоманда.ПоказыватьОповещение = Ложь;

     Возврат ПараметрыРегистрации;

КонецФункции
Показать
5. AlOkt 66 01.09.23 16:19 Сейчас в теме
Вот раньше пользовался, тут по минимуму, и работала. Решил не много поменять, либо "перемудрил" либо требования изменились, у Инфостарта модерацию не проходит. Пишет: нет функции СведенияОВнешнейОбработке(), хотя она есть! А логов Автопроверки они не сообщают. Придется методом "тыка" разбираться ...
6. AlOkt 66 29.09.23 12:09 Сейчас в теме
Функция СведенияОВнешнейОбработке() Экспорт

ВерсияВО = "1.4";
СинонимВО = "Тренажер для изучения 1С: БП 3.0 (УСН)";
ИмяВО = "ТренажерДляИзученияБПнаУСН";
  
  ПараметрыРегистрации = ДополнительныеОтчетыИОбработки.СведенияОВнешнейОбработке();
  ПараметрыРегистрации.Вид = ДополнительныеОтчетыИОбработкиКлиентСервер.ВидОбработкиДополнительнаяОбработка();
  ПараметрыРегистрации.Информация = НСтр("ru = 'Упрощенное меню для программы 1С:Бухгалтерия (версия 1.4) = тренажер для изучения 1С: БП 3.0 (УСН)'");
  ПараметрыРегистрации.Версия = ВерсияВО;

  НоваяКоманда = ПараметрыРегистрации.Команды.Добавить();
  НоваяКоманда.Представление = СинонимВО;
  НоваяКоманда.Идентификатор = ИмяВО;
  НоваяКоманда.Использование = ДополнительныеОтчетыИОбработкиКлиентСервер.ТипКомандыОткрытиеФормы();
  НоваяКоманда.ПоказыватьОповещение = Ложь;

     Возврат ПараметрыРегистрации;

КонецФункции
Показать
7. AlOkt 66 29.09.23 12:12 Сейчас в теме
На 2023-09-29 по сведению infostart.ru :
Бухгалтерия предприятия, редакция 3.0, версия 3.0.141.39
Тестирование пройдено, ошибок не обнаружено
Оставьте свое сообщение