Последовательный выпуск полуфабрикатов

Публикация № 364074

Администрирование - Администрирование данных 1С - Обработка документов

ПУБ производство полуфабрикаты

Автоматический выпуск вложенных полуфабрикатов любой степени вложенности для ПУБ.

Предлагаю вашему вниманию свой вариант выпуска промежуточных полуфабрикатов, призванный облегчить сам выпуск продукции.

В документ Выпуск продукции добавляем кнопку и к ней в модуле формы прилагается процедура (см.ниже).

Рассмотрим абстрактный пример 3-х уровневой спецификации.

Порядок работы такой:

1)      Сначала вводим выпуск продукции за день, один или несколько документов. Не проводим – все равно не проведется. Если надо, можно ввести выпуск нескольких полуфабрикатов. Помеченные на удаление документы не участвуют в расчете.

2)    Вводим новый документ выпуска за эту же дату, и теперь нажимаем нашу кнопочку – и заполняется первый уровень полуфабрикатов. Не проводим, если есть еще уровни вложенности.

3)    Вводим следующие документы и опять нажимаем кнопочку – пока документ не перестанет заполняться, значит, все.

Обращаем внимание, что каждый последующий документ встает раньше предыдущего.

Теперь можно провести все подряд, и все проведется. Полуфабрикаты спишутся по нулям (см.последнюю картинку).

 

Теперь сама процедура:

 

 

Процедура ЗаполнитьПолуфабрикаты()
    Перем ТЗ_Полуфабрикаты;
    Перем ТабЗатрат;
    Перем Ч,М,С;

    Если КоличествоСтрок() > 0  Тогда
        Если Вопрос("Очистить табличную часть и заполнить заново?",4) = 7 Тогда
            Возврат;
        КонецЕсли;
    КонецЕсли;

    УдалитьСтроки();

    ТЗ_Полуфабрикаты = СоздатьОбъект("ТаблицаЗначений");
    ТЗ_Полуфабрикаты.ВставитьКолонку("Полуфабрикат",,"Справочник.Номенклатура");
    ТЗ_Полуфабрикаты.ВставитьКолонку("Количество",,"Число",10,3);

    //ставим выпуск полуфабрикатов перед всеми выпусками
    Выпуск = СоздатьОбъект("Документ.ВыпускПродукцииПоНормам");
    Выпуск.ВыбратьДокументы(ДатаДок,ДатаДок);
    Пока Выпуск.ПолучитьДокумент() = 1 Цикл
        Если Выпуск.ПометкаУдаления() = 1 Тогда
            Продолжить;
        КонецЕсли;
        Если Выпуск.НомерДок = НомерДок Тогда
            Продолжить;
        КонецЕсли;
        Прервать;
    КонецЦикла;
    Выпуск.ПолучитьВремя(Ч,М,С);
    С = С - 10;
    Попытка
        УстановитьВремя(Ч,М,С);
    Исключение
        //Сообщить("Чтобы время выпуска полуфабрикатов автоматически установилось ранее
        //выпуска основной продууции, нужно заполнять новый, не записанный документ!");
    КонецПопытки;


    //перебираем все выпуски за дату документа на нужность выпуска полуфабрикатов
    Выпуск.ВыбратьДокументы(ДатаДок,ДатаДок);
    Пока Выпуск.ПолучитьДокумент() = 1 Цикл

        Если Выпуск.ПометкаУдаления() = 1 Тогда
            Продолжить;
        КонецЕсли;
        Если Выпуск.НомерДок = НомерДок Тогда
            Продолжить;
        КонецЕсли;

        Выпуск.ВыбратьСтроки();
        Пока Выпуск.ПолучитьСтроку() = 1 Цикл

            Если НЕ ((Выпуск.Продукция.ТипНоменклатуры = Перечисление.ТипыНоменклатуры.Продукция) или
            (Выпуск.Продукция.ТипНоменклатуры = Перечисление.ТипыНоменклатуры.Полуфабрикат)) Тогда
                Продолжить;
            КонецЕсли;

            глЗатратыПоПродукции(Выпуск.Продукция, Выпуск.Спецификация, 1, Выпуск.ДатаДок, ТабЗатрат);

            // Добавим входящие в выпущенные изделия полуфабрикаты в таблицу
            ТабЗатрат.ВыбратьСтроки();
            Пока ТабЗатрат.ПолучитьСтроку() = 1 Цикл

                Если (ТабЗатрат.ВидЭлемента = Перечисление.ВидыЭлементовНормРасходов.Полуфабрикат) или
                     (ТабЗатрат.ВидЭлемента = Перечисление.ВидыЭлементовНормРасходов.Продукция) Тогда

                    НоваяСтрока = ТЗ_Полуфабрикаты.НоваяСтрока();
                    ТЗ_Полуфабрикаты.Полуфабрикат     = ТабЗатрат.Элемент;
                    ТЗ_Полуфабрикаты.Количество       = ТабЗатрат.Количество*Выпуск.Количество;

                КонецЕсли;

            КонецЦикла;

        КонецЦикла;
    КонецЦикла;

    ТЗ_Полуфабрикаты.Свернуть("Полуфабрикат","Количество");

    ///удалим из списка уже выпущенные сегодня полуфабрикаты
    Выпуск = СоздатьОбъект("Документ.ВыпускПродукцииПоНормам");
    Выпуск.ВыбратьДокументы(ДатаДок,ДатаДок);
    Пока Выпуск.ПолучитьДокумент() = 1 Цикл
        Если Выпуск.ПометкаУдаления() = 1 Тогда
            Продолжить;
        КонецЕсли;
        Если Выпуск.НомерДок = НомерДок Тогда
            Продолжить;
        КонецЕсли;

        Выпуск.ВыбратьСтроки();
        Пока Выпуск.ПолучитьСтроку() = 1 Цикл
            Для а = 1 По ТЗ_Полуфабрикаты.КоличествоСтрок() Цикл
                ТЗ_Полуфабрикаты.ПолучитьСтрокуПоНомеру(а);
                Если ТЗ_Полуфабрикаты.Полуфабрикат = Выпуск.Продукция Тогда
                    ТЗ_Полуфабрикаты.Количество = ТЗ_Полуфабрикаты.Количество - Выпуск.Количество;
                КонецЕсли;
            КонецЦикла;

        КонецЦикла;
    КонецЦикла;

    колУд = 0;
    Для а = 1 По ТЗ_Полуфабрикаты.КоличествоСтрок() Цикл
        ТЗ_Полуфабрикаты.ПолучитьСтрокуПоНомеру(а-колУд);
        Если ТЗ_Полуфабрикаты.Количество <= 0 Тогда
            ТЗ_Полуфабрикаты.УдалитьСтроку(а-колУд);
            колУд = колУд + 1;
        КонецЕсли;
    КонецЦикла;

    //////////////////////////////////////
    Для а = 1 По ТЗ_Полуфабрикаты.КоличествоСтрок() Цикл
        НоваяСтрока();
        ТЗ_Полуфабрикаты.ПолучитьСтрокуПоНомеру(а);
        Продукция        = ТЗ_Полуфабрикаты.Полуфабрикат;
        Количество       = ТЗ_Полуфабрикаты.Количество;
        ЕдиницаИзмерения = ТЗ_Полуфабрикаты.Полуфабрикат.ОсновнаяЕдиницаИзмерения;
        НазначитьТип("Спецификация", ТипЗначенияСтр(ТЗ_Полуфабрикаты.Полуфабрикат.ОсновнаяСпецификация));
        Спецификация     = ТЗ_Полуфабрикаты.Полуфабрикат.ОсновнаяСпецификация;
    КонецЦикла;


КонецПроцедуры  // ЗаполнитьПолуфабрикаты




И небольшое дополнение. Нужно в процедурах формы ВводНового и ВводНаОсновании добавить строчку:

АвтоВремяОтключить();

Чтобы программно можно было менять время документа.

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. @Sonya 27 28.07.15 10:43 Сейчас в теме
Замечание! Данный расчет производится без учета имеющихся на складе остатков полуфабрикатов! Если кому-то будет нужно - выложу полный вариант.
2. vasyak319 139 28.07.15 10:54 Сейчас в теме
Почему бы не сделать обработку, которая сама спустится до материалов и создаст нужное количество документов? Тем более, что при вашем подходе не будут свёрнуты в одну строку одинаковые полуфабрикаты в том случае, когда они на разных уровнях. Типа:
Продукция1
ПФ1
ПФ2

Продукция2
ПФ2

ПФ2 в этом случае придётся произвести дважды.
Оставьте свое сообщение

См. также

Использование классов .Net в 1С для новичков Промо

Практика программирования Разработка внешних компонент Универсальные функции v7.7 v8 Бесплатно (free)

Руководство для новичков. Написав статью http://infostart.ru/public/238584/, я понял, что многие не понимают того, что написано. Поэтому в этой статье постараюсь более подробно остановиться на азах и без кода на вражеском языке (C#)

27.01.2016    76153    Serginio    108    

Маркировка лекарств - как передать код маркировки при продаже через ККТ Штрих-М

Практика программирования ККМ v7.7 Здравоохранение, медицина, стоматология Фармацевтика, аптеки Россия Бесплатно (free)

Пример программного кода для вывода чеков на ККМ Штрих-М с передачей информации о маркированных товарах (лекарства).

10.02.2020    6518    vovaapril    20    

Как в торговле 7.7 печатать код ТНВЭД в счет-фактуре

Практика программирования Внешнеэкономическая деятельность (ВЭД) Внешнеэкономическая деятельность (ВЭД) v77::ОУ 1С7:ТиС Россия БУ НДС Бесплатно (free)

В данной статье хотел поделиться опытом, как в Торговле 7.7 ( релиз 994) сделать возможность выводить код ТНВЭД в печатную форму счета-фактуры. Сразу скажу, что нужно это только тем, кто осуществляет экспорт в страны таможенного союза. Остальные могут не волноваться.

15.11.2017    10622    AndKovalchuk    0    

Проверка часового пояса

Практика программирования v7.7 Бесплатно (free)

При использовании терминалок для удаленных баз, иногда при входе в базу данных необходимо исключить возможность входа пользователей с компьютеров с другим часовым поясом. Например, работают в Новосибирской базе с временем UTC +6 и пытаются зайти в базу с UTC +3.

16.05.2016    10965    kudenzov    3    

.Net в 1С. На примере использования HTTPClient, AngleSharp. Удобный парсинг сайтов с помощью библиотеки AngleSharp, в том числе с авторизацией аля JQuery с использованием CSS селекторов. Динамическая компиляция Промо

Практика программирования WEB v7.7 v8 Бесплатно (free)

Часто приходится парсить сайты, в том числе с авторизацией, перескакивая со страницы на страницу по ссылкам. Тот, кто занимался вэб программированием, знает, как удобно использовать JQuery и CSS селекторы. На .Net написана очень удобная библиотека AngleSharp. Я покажу, как с её помощью можно значительно облегчить себе труд.

10.03.2016    55712    Serginio    33    

[ПОЛЕЗНЯШКА, 7.7] Как посчитать итоги по документам черным запросом с изподвывертом?

Практика программирования v7.7 1cv7.md Бесплатно (free)

Мелкая полезняшка, считает запросом итоговую сумму документов и количество документов.

12.03.2016    18967    CheBurator    18    

.Net в 1С. Асинхронные HTTP запросы, отправка Post нескольких файлов multipart/form-data, сжатие трафика с использованием gzip, deflate, удобный парсинг сайтов и т.д.

Разработка внешних компонент Практика программирования WEB v7.7 v8 Бесплатно (free)

Очень часто нужно при работе с HTTP сервисами или сайтами использовать Асинхронные HTTP запросы, отправку на сервер нескольких файлов, использование сжатия трафика. Эта статья про то, как этого легко добиться.

09.03.2016    31637    Serginio    22    

Пример HTTP запроса к УТМ ЕГАИС на платформе 1С 7.7

Внешние источники данных Практика программирования Оптовая торговля Розничная торговля Оптовая торговля Розничная торговля v7.7 1cv7.md Россия Бесплатно (free)

Запрос реализован на объекте ServerXMLHTTP из встроенной в Windows библиотеки MSXML, результатом запроса является XML объект DOMDocument из той же библиотеки MSXML со встроенным интерфейсом его обработки

16.12.2015    25007    Palmer1976    3    

1С:Предприятие 7.7. Оптимизация. Промо

Практика программирования v7.7 1cv7.md Россия Бесплатно (free)

Разгоняем 1С:Предприятие 7.7. Выжимаем последние соки.

31.01.2009    46581    alexk-is    110    

Экспорт нескольких MXL таблиц в один XLS файл, на отдельные листы. Простой алгоритм

Загрузка и выгрузка в Excel Практика программирования v7.7 v8 Бесплатно (free)

Статья посвящена распространённому вопросу - как сохранить несколько таблиц (отчетов) в формате MXL, с которым работает 1С, на отдельные листы одного Excel файла. Освещается простой алгоритм решения проблемы штатными средствами, без использования внешних модулей и библиотек (не относящихся к 1С и Excel).

23.11.2015    17355    etmarket    14    

Процедура расшифровки ячейки таблицы в отчетах 1С 7.7

Практика программирования Универсальные функции v7.7 1cv7.md Бесплатно (free)

Хочу поделиться с вами универсальной процедурой для расшифровки ячеек печатной формы отчетов в 1С 7.7.

24.09.2015    17521    Anzhey    14    

Универсальный способ сравнения таблиц

Практика программирования v7.7 v8 Бесплатно (free)

На эту тему уже есть статьи, но этот способ нигде не описан. Хотя я его использую с тех пор, как занимаюсь программированием. Его преимущество в простоте и универсальности: можно применять на 1С, SQL, а также в любом другом языке программирования.

05.07.2015    19125    json    1    

Как уменьшить количество заблокированных объектов Промо

Практика программирования v7.7 1cv7.md Россия Бесплатно (free)

История о том как я решил пересобрать форму справочника клиентов и чем это все закончилось...

12.01.2012    15577    ShEvOvIcH    18    

Числа прописью в родительном падеже в 7.7? Легко!

Практика программирования v7.7 1cv7.md Бесплатно (free)

Вывод числительных прописью в родительном падеже штатными средствами в три строчки кода.

20.06.2015    12743    gimalaj    3    

Хитрости сохранения табличного документа в Excel для дальнейшей работы с ним

Загрузка и выгрузка в Excel Практика программирования v7.7 v8 1cv8.cf 1cv7.md Бесплатно (free)

Все пользователи 1С всех версий (начиная с 7-й) сталкиваются с проблемой нормальной работы с данными, сохраненными в Excel файл. Есть некоторые хитрости, которые позволяют облегчить работу с сохраненными данными из 1С в формат Excel.

16.01.2015    89128    shmellevich    38    

ЗаполнитьЗначенияСвойств - заставляем работать в 7.7

Практика программирования v7.7 1cv7.md Бесплатно (free)

Если вы используете в работе 1С:Предприятие 8.х, то наверняка знакомы и с замечательной системной процедурой, как ЗаполнитьЗначенияСвойств(). Ее использование помогает значительно упростить написание программного кода в ряде случае, делает его (код) более наглядным и простым. Но что же делать тем, кто до сих пор использует (постоянно или иногда) 1С:Предприятие 7.7?

24.07.2014    22059    tomvlad    5    

Технология обновления нетиповых конфигураций 1С:Предприятия 7.7 Промо

Практика программирования Администрирование данных 1С v7.7 1cv7.md Россия Бесплатно (free)

Данная статья рассчитана на уже подготовленного пользователя, владеющего некоторыми навыками программирования и работы в конфигураторе. Статью можно использовать как поэтапное руководство к действию. Статья была написана для повышения качества работ выполняемых сотрудниками компании Информ Сервис при обновлении нетиповых конфигураций. Я надеюсь, что эта информация окажется полезной и для вас.

12.12.2008    62742    alexk-is    25    

Чтение строк файла CSV в список значений с помощью метода ИзСтрокиСРазделителями

Практика программирования Внешние источники данных v7.7 Бесплатно (free)

Чтение строк файла CSV в список значений с помощью метода ИзСтрокиСРазделителями

04.04.2013    19298    ivisor_fil    11    

Конвертация данных 2.1 (2.1.3.1) 1С 7.7 - 1С 8.Х передача параметра ПКО

Практика программирования Перенос данных из 1С7.7 в 1C8.X v7.7 v8 КД Бесплатно (free)

Передача параметров по умолчанию доступна только для баз 1С 8.х -1С 8.х. Показан пример, как передать параметры из 1С 7.7 - 1С 8.х

10.12.2012    25383    serg_gres    6    

Скрытие помеченных на удаление в справочнике

Практика программирования v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Бесплатно (free)

Корректно скрываем помеченных на удаление в справочнике, с иерархией и без. Вроде простая и нужная вещь, но почему-то нигде не встречалась

08.08.2012    13817    mikukrnet    7    

Динамическая фильтрация в справочнике при вводе наименования

Практика программирования v7.7 1cv7.md Россия Бесплатно (free)

Позволяет в открытой форме списка, выбора или подбора справочника производить динамическую фильтрацию по набранному наименованию.

02.07.2012    16279    maxpiter    62    

Продажа собственной фирме (интеркомпани) - заполнение отрицательными остатками

Практика программирования Учет ТМЦ Учет ТМЦ v77::ОУ 1С7:Комплекс 1С7:ТиС Россия Бесплатно (free)

В документе "Продажа собственной фирме" приходится добавлять номенклатуру вручную через подбор. А ведь можно сэкономить время и заполнить спецификацию документа на основании отрицательных остатков фирмы. Все просто...

06.05.2012    13390    2sw    4    

Ввод остатков по 76.ВА в 1С ПУБ

Практика программирования v77::ОУ v77::БУ 1С7:ПУБ Россия БУ Бесплатно (free)

Статья посвящена найденному мной недостатку в конфигурации 1С 7.7 "Производство-услуги-бухгалтерия", связанному с вводом начальных остатков по 76.ВА.

29.04.2012    10028    Пользователь 1С    0    

Обновление базы 1с 7.7. с помощью движка 1с 8.х

Практика программирования Администрирование данных 1С v7.7 1cv7.md Россия Бесплатно (free)

Если Вас угораздило в стандартную типовую конфу внести правки, причем в самый большой модуль, а именно глобальный. Если к тому же Вы внесли изменение в какую-то стандартную функцию, в которой 1с сама регулярно чего-то меняет, то любое обновление начинает доставать. Используя возможности движка платформы 1с 8.х можно существенно сэкономить себе время и нервы.

28.04.2012    18620    Valerich    31    

Ошибка при формировании отчета Авансы по налогу на имущество. В 1С:Предприятие 7.7. Регламентированная отчетность за I квартал 2012 года Обновление 12q1009 от 18.04.2012 г.

Практика программирования v77::ОУ v77::БУ 1cv7.md Россия Бесплатно (free)

При формировании отчета NIMAVP1.ERT Авансы по налогу на имущество (версия 5.03) в разделе № 1-3 не сохраняет номера Страниц при выборе, что ведет к не сохранению и выводу печати двухмерного кода.

24.04.2012    9354    leo072    7    

Запуск внешней обработки по расписанию v7.7

Практика программирования Администрирование данных 1С v7.7 1cv7.md Россия Бесплатно (free)

Неоднократно возникали задачи организовать, например ежедневную выгрузку и отправку отчетов по эл.почте, и вот…

20.03.2012    44049    Yury1001    17    

Быстрый отбор в журнале на конкретную дату

Практика программирования v77::ОУ 1cv7.md Россия Бесплатно (free)

Лень - двигатель прогресса. Полезная фича для быстрого отбора документов в любом журнале на конкретную дату.

27.02.2012    11239    avers007    16    

ЗиК 321, в отчетах пропадает проводка по ПФР_страховая

Практика программирования v77::ОУ v77::Расчет 1С7:ЗиК Россия ФОМС, ПФ, ФСС Бесплатно (free)

При формировании отчета "Свод проводок" с галкой "Учет начисления налогов с ФОТ, включаемых в состав расходов" в отчет не выходит ПФР_страх

10.02.2012    6843    filh    19    

Ошибка в 1С:Бух77 ред.533 Начисление ФФОМС при ЕНВД

Практика программирования Зарплата Зарплата v77::БУ 1С7:Бух Россия Бесплатно (free)

При начислении налогов с ФОТ (док.ЗакрытиеМесяца) не расчитываются налоги ФФОМС, если начисление зарплаты проводится как "облагаемые ЕНВД".

22.01.2012    10274    lelbraun    3    

Прямые запросы: ускорение получения цен для типовой ТиС 7.7

Практика программирования Разработка внешних компонент v77::ОУ 1С7:Комплекс 1С7:ТиС Россия Бесплатно (free)

Первая статья из цикла статей "Прямые запросы:...". Рассказывается о применении класса ПрямойЗапрос и компоненты 1С++ для ускорения функции глВернутьЦену() в типовой конфигурации Торговля и склад. Платформа 7.7.

15.11.2011    15597    leshik    21    

1С:Торговля и Склад - ошибка во всех релизах, При использовании нескольких фирм и префиксов номеров документов.

Практика программирования v77::ОУ 1С7:ТиС Россия Бесплатно (free)

Собственно сегодня обнаружил ошибку, которая присутствует во всех релизах конфигурации Торговля и Склад 7.7 вплоть до текущего 7.70.969, при использовании нескольких фирм и префиксов документов для некоторых из них.

04.11.2011    15581    twilight5023    8    

Функция проверки валидности e-mail с использованием регулярных выражений RegExp (7.7)

Практика программирования openconf v77::БУ 1cv7.md Россия Бесплатно (free)

Функция проверки валидности e-mail с использованием регулярных выражений RegExp (7.7). Данную функцию можно вставить в Глобальный модуль и пользоваться, например, при вводе или сохранении e-mail.

30.10.2011    11078    zaursoft    11    

ЗиК: Заполнение данных о заработке у предыдущих работодателей в больничном

Практика программирования Зарплата Зарплата v77::Расчет 1С7:ЗиК Россия БУ Бесплатно (free)

Доработка ЗиК 314. Заполнение данных в больничном за 2 предыдущих года у другого работодателя. Для работы необходимо добавить в конфигурацию новый справочник.

04.10.2011    11876    allexe    13    

Компенсация отпуска, оплата дней доноров и оплата льготных дней родителей в ЗиК

Практика программирования Зарплата Зарплата v77::Расчет 1cv7.md 1С7:ЗиК Россия Бесплатно (free)

"Компенсация отпуска"," Оплата дней доноров" и "Оплата льготных дней родителей" - эти виды расчетов должны облагаться страховыми взносами с 01.01.2011 года.

04.10.2011    9267    maxim305    18    

7.7.: Готовим md-файл для публикации. В картинках.

Практика программирования v7.7 1cv7.md Россия Бесплатно (free)

Вы доработали типовую конфигурацию: скажем, добавили новый Документ, и хотите им поделиться с обществом ИС. Но нельзя же выложить МД-шник целиком, это будет нарушением правил. И как тут быть?

14.09.2011    17394    Арчибальд    21    

Расшифровка внутренних расчетов 1С:Зарплата

Практика программирования Зарплата Зарплата v77::Расчет 1С7:ЗиК Россия Бесплатно (free)

Трассировка (расшифровка) промежуточных расчетов документов в 1С:Зарплата

20.07.2011    10794    buhinfo    5    

Дата запрета редактирования

Практика программирования v77::БУ 1cv7.md Россия Бесплатно (free)

Очень часто необходимо постоянно закрывать период для редактирования документов. Вот как я вышла из этой ситуации.

15.07.2011    10729    natalika1601    14    

Кнопка обновления версии внешнего отчета

Практика программирования v77::ОУ v77::БУ v77::Расчет Россия Бесплатно (free)

После исправления внешнего отчета вместо рекомендации пользователю: "Закрой отчет и открой его заново", говорим: "Нажми на кнопку".

18.06.2011    13862    Shaman100M    8    

Методика расчета резервов отпусков (счет 96) в 1С Зарплата и Кадры 7.7 с 2011 года (вариант)

Практика программирования Зарплата Зарплата v77::Расчет 1С7:Бух 1С7:ЗиК Россия БУ Бесплатно (free)

В статье рассмотрен один из возможных вариантов расчета резервов отпусков (счет 96) в 1С Зарплата и Кадры 7.7 с 2011 года.

14.06.2011    22028    vkr    48    

Бюджетка ББУ 7.7 "Новый план счетов" без обновления на 645 :)

Практика программирования v77::БУ 1С7:ББУ Россия БУ Бесплатно (free)

Дешевый и сердитый вариант привыкания к новому плану счетов в 7-ке ББУ (за 2-3 минуты) (конфигурация 644 и менее ). 1. Оставляем план счетов как есть, пусть пока бухгалеры работают по-прежнему, а программист вдумчиво готовится к Настоящему Переводу. 2. Для отчетности на печать во всех стандартных отчетах (оборотки, карточки, анализы и пр.) выводим "новый план счетов". Подменой один к одному. Главное - идея. Реализацию можете подправить самостоятельно, кому нужно. Печатные формы подшиваются, бухгалтеры привыкают к новым счетам. Скажете: временный вариант. Конечно, зато какой простой!

05.06.2011    6151    alexolder    12