Последовательный выпуск полуфабрикатов

Публикация № 364074

Администрирование - Администрирование данных 1С - Обработка документов

ПУБ производство полуфабрикаты

4
Автоматический выпуск вложенных полуфабрикатов любой степени вложенности для ПУБ.

Предлагаю вашему вниманию свой вариант выпуска промежуточных полуфабрикатов, призванный облегчить сам выпуск продукции.

В документ Выпуск продукции добавляем кнопку и к ней в модуле формы прилагается процедура (см.ниже).

Рассмотрим абстрактный пример 3-х уровневой спецификации.

Порядок работы такой:

1)      Сначала вводим выпуск продукции за день, один или несколько документов. Не проводим – все равно не проведется. Если надо, можно ввести выпуск нескольких полуфабрикатов. Помеченные на удаление документы не участвуют в расчете.

2)    Вводим новый документ выпуска за эту же дату, и теперь нажимаем нашу кнопочку – и заполняется первый уровень полуфабрикатов. Не проводим, если есть еще уровни вложенности.

3)    Вводим следующие документы и опять нажимаем кнопочку – пока документ не перестанет заполняться, значит, все.

Обращаем внимание, что каждый последующий документ встает раньше предыдущего.

Теперь можно провести все подряд, и все проведется. Полуфабрикаты спишутся по нулям (см.последнюю картинку).

 

Теперь сама процедура:

 

 

Процедура ЗаполнитьПолуфабрикаты()
    Перем ТЗ_Полуфабрикаты;
    Перем ТабЗатрат;
    Перем Ч,М,С;

    Если КоличествоСтрок() > 0  Тогда
        Если Вопрос("Очистить табличную часть и заполнить заново?",4) = 7 Тогда
            Возврат;
        КонецЕсли;
    КонецЕсли;

    УдалитьСтроки();

    ТЗ_Полуфабрикаты = СоздатьОбъект("ТаблицаЗначений");
    ТЗ_Полуфабрикаты.ВставитьКолонку("Полуфабрикат",,"Справочник.Номенклатура");
    ТЗ_Полуфабрикаты.ВставитьКолонку("Количество",,"Число",10,3);

    //ставим выпуск полуфабрикатов перед всеми выпусками
    Выпуск = СоздатьОбъект("Документ.ВыпускПродукцииПоНормам");
    Выпуск.ВыбратьДокументы(ДатаДок,ДатаДок);
    Пока Выпуск.ПолучитьДокумент() = 1 Цикл
        Если Выпуск.ПометкаУдаления() = 1 Тогда
            Продолжить;
        КонецЕсли;
        Если Выпуск.НомерДок = НомерДок Тогда
            Продолжить;
        КонецЕсли;
        Прервать;
    КонецЦикла;
    Выпуск.ПолучитьВремя(Ч,М,С);
    С = С - 10;
    Попытка
        УстановитьВремя(Ч,М,С);
    Исключение
        //Сообщить("Чтобы время выпуска полуфабрикатов автоматически установилось ранее
        //выпуска основной продууции, нужно заполнять новый, не записанный документ!");
    КонецПопытки;


    //перебираем все выпуски за дату документа на нужность выпуска полуфабрикатов
    Выпуск.ВыбратьДокументы(ДатаДок,ДатаДок);
    Пока Выпуск.ПолучитьДокумент() = 1 Цикл

        Если Выпуск.ПометкаУдаления() = 1 Тогда
            Продолжить;
        КонецЕсли;
        Если Выпуск.НомерДок = НомерДок Тогда
            Продолжить;
        КонецЕсли;

        Выпуск.ВыбратьСтроки();
        Пока Выпуск.ПолучитьСтроку() = 1 Цикл

            Если НЕ ((Выпуск.Продукция.ТипНоменклатуры = Перечисление.ТипыНоменклатуры.Продукция) или
            (Выпуск.Продукция.ТипНоменклатуры = Перечисление.ТипыНоменклатуры.Полуфабрикат)) Тогда
                Продолжить;
            КонецЕсли;

            глЗатратыПоПродукции(Выпуск.Продукция, Выпуск.Спецификация, 1, Выпуск.ДатаДок, ТабЗатрат);

            // Добавим входящие в выпущенные изделия полуфабрикаты в таблицу
            ТабЗатрат.ВыбратьСтроки();
            Пока ТабЗатрат.ПолучитьСтроку() = 1 Цикл

                Если (ТабЗатрат.ВидЭлемента = Перечисление.ВидыЭлементовНормРасходов.Полуфабрикат) или
                     (ТабЗатрат.ВидЭлемента = Перечисление.ВидыЭлементовНормРасходов.Продукция) Тогда

                    НоваяСтрока = ТЗ_Полуфабрикаты.НоваяСтрока();
                    ТЗ_Полуфабрикаты.Полуфабрикат     = ТабЗатрат.Элемент;
                    ТЗ_Полуфабрикаты.Количество       = ТабЗатрат.Количество*Выпуск.Количество;

                КонецЕсли;

            КонецЦикла;

        КонецЦикла;
    КонецЦикла;

    ТЗ_Полуфабрикаты.Свернуть("Полуфабрикат","Количество");

    ///удалим из списка уже выпущенные сегодня полуфабрикаты
    Выпуск = СоздатьОбъект("Документ.ВыпускПродукцииПоНормам");
    Выпуск.ВыбратьДокументы(ДатаДок,ДатаДок);
    Пока Выпуск.ПолучитьДокумент() = 1 Цикл
        Если Выпуск.ПометкаУдаления() = 1 Тогда
            Продолжить;
        КонецЕсли;
        Если Выпуск.НомерДок = НомерДок Тогда
            Продолжить;
        КонецЕсли;

        Выпуск.ВыбратьСтроки();
        Пока Выпуск.ПолучитьСтроку() = 1 Цикл
            Для а = 1 По ТЗ_Полуфабрикаты.КоличествоСтрок() Цикл
                ТЗ_Полуфабрикаты.ПолучитьСтрокуПоНомеру(а);
                Если ТЗ_Полуфабрикаты.Полуфабрикат = Выпуск.Продукция Тогда
                    ТЗ_Полуфабрикаты.Количество = ТЗ_Полуфабрикаты.Количество - Выпуск.Количество;
                КонецЕсли;
            КонецЦикла;

        КонецЦикла;
    КонецЦикла;

    колУд = 0;
    Для а = 1 По ТЗ_Полуфабрикаты.КоличествоСтрок() Цикл
        ТЗ_Полуфабрикаты.ПолучитьСтрокуПоНомеру(а-колУд);
        Если ТЗ_Полуфабрикаты.Количество <= 0 Тогда
            ТЗ_Полуфабрикаты.УдалитьСтроку(а-колУд);
            колУд = колУд + 1;
        КонецЕсли;
    КонецЦикла;

    //////////////////////////////////////
    Для а = 1 По ТЗ_Полуфабрикаты.КоличествоСтрок() Цикл
        НоваяСтрока();
        ТЗ_Полуфабрикаты.ПолучитьСтрокуПоНомеру(а);
        Продукция        = ТЗ_Полуфабрикаты.Полуфабрикат;
        Количество       = ТЗ_Полуфабрикаты.Количество;
        ЕдиницаИзмерения = ТЗ_Полуфабрикаты.Полуфабрикат.ОсновнаяЕдиницаИзмерения;
        НазначитьТип("Спецификация", ТипЗначенияСтр(ТЗ_Полуфабрикаты.Полуфабрикат.ОсновнаяСпецификация));
        Спецификация     = ТЗ_Полуфабрикаты.Полуфабрикат.ОсновнаяСпецификация;
    КонецЦикла;


КонецПроцедуры  // ЗаполнитьПолуфабрикаты




И небольшое дополнение. Нужно в процедурах формы ВводНового и ВводНаОсновании добавить строчку:

АвтоВремяОтключить();

Чтобы программно можно было менять время документа.

4

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. @Sonya 25 28.07.15 10:43 Сейчас в теме
Замечание! Данный расчет производится без учета имеющихся на складе остатков полуфабрикатов! Если кому-то будет нужно - выложу полный вариант.
2. vasyak319 132 28.07.15 10:54 Сейчас в теме
Почему бы не сделать обработку, которая сама спустится до материалов и создаст нужное количество документов? Тем более, что при вашем подходе не будут свёрнуты в одну строку одинаковые полуфабрикаты в том случае, когда они на разных уровнях. Типа:
Продукция1
ПФ1
ПФ2

Продукция2
ПФ2

ПФ2 в этом случае придётся произвести дважды.
Оставьте свое сообщение

См. также

Как в торговле 7.7 печатать код ТНВЭД в счет-фактуре 0

Статья Программист Нет файла v77::ОУ 1С7:ТиС Россия БУ Внешнеэкономическая деятельность (ВЭД) НДС Бесплатно (free) Практика программирования

В данной статье хотел поделиться опытом, как в Торговле 7.7 ( релиз 994) сделать возможность выводить код ТНВЭД в печатную форму счета-фактуры. Сразу скажу, что нужно это только тем, кто осуществляет экспорт в страны таможенного союза. Остальные могут не волноваться.

15.11.2017    8381    AndKovalchuk    0       

.Net в 1С. На примере использования HTTPClient, AngleSharp. Удобный парсинг сайтов с помощью библиотеки AngleSharp, в том числе с авторизацией аля JQuery с использованием CSS селекторов. Динамическая компиляция 110

Статья Программист Нет файла v7.7 v8 Windows Бесплатно (free) Практика программирования WEB

Часто приходится парсить сайты, в том числе с авторизацией, перескакивая со страницы на страницу по ссылкам. Тот, кто занимался вэб программированием, знает, как удобно использовать JQuery и CSS селекторы. На .Net написана очень удобная библиотека AngleSharp. Я покажу, как с её помощью можно значительно облегчить себе труд.

10.03.2016    48195    Serginio    33       

Использование классов .Net в 1С для новичков 147

Статья Программист Нет файла v7.7 v8 Windows Бесплатно (free) Практика программирования Разработка внешних компонент Универсальные функции

Руководство для новичков. Написав статью http://infostart.ru/public/238584/, я понял, что многие не понимают того, что написано. Поэтому в этой статье постараюсь более подробно остановиться на азах и без кода на вражеском языке (C#)

27.01.2016    62541    Serginio    104       

Скрытие помеченных на удаление в справочнике 5

Статья Программист Нет файла v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Бесплатно (free) Практика программирования

Корректно скрываем помеченных на удаление в справочнике, с иерархией и без. Вроде простая и нужная вещь, но почему-то нигде не встречалась

08.08.2012    11034    mikukrnet    7       

Продажа собственной фирме (интеркомпани) - заполнение отрицательными остатками 9

Статья Программист Нет файла v77::ОУ 1С7:Комплекс 1С7:ТиС Россия Учет ТМЦ Бесплатно (free) Практика программирования

В документе "Продажа собственной фирме" приходится добавлять номенклатуру вручную через подбор. А ведь можно сэкономить время и заполнить спецификацию документа на основании отрицательных остатков фирмы. Все просто...

06.05.2012    11070    2sw    4       

Ввод остатков по 76.ВА в 1С ПУБ 2

Статья Программист Нет файла v77::ОУ v77::БУ 1С7:ПУБ Россия БУ Бесплатно (free) Практика программирования

Статья посвящена найденному мной недостатку в конфигурации 1С 7.7 "Производство-услуги-бухгалтерия", связанному с вводом начальных остатков по 76.ВА.

29.04.2012    7871    Пользователь 1С    0       

Ошибка при формировании отчета Авансы по налогу на имущество. В 1С:Предприятие 7.7. Регламентированная отчетность за I квартал 2012 года Обновление 12q1009 от 18.04.2012 г. 18

Статья Программист Нет файла v77::ОУ v77::БУ 1cv7.md Россия Бесплатно (free) Практика программирования

При формировании отчета NIMAVP1.ERT Авансы по налогу на имущество (версия 5.03) в разделе № 1-3 не сохраняет номера Страниц при выборе, что ведет к не сохранению и выводу печати двухмерного кода.

24.04.2012    7192    leo072    7       

Быстрый отбор в журнале на конкретную дату 7

Статья Программист Нет файла v77::ОУ 1cv7.md Россия Бесплатно (free) Практика программирования

Лень - двигатель прогресса. Полезная фича для быстрого отбора документов в любом журнале на конкретную дату.

27.02.2012    9041    avers007    16       

ЗиК 321, в отчетах пропадает проводка по ПФР_страховая 25

Статья Программист Нет файла v77::ОУ v77::Расчет 1С7:ЗиК Россия ФОМС, ПФ, ФСС Бесплатно (free) Практика программирования

При формировании отчета "Свод проводок" с галкой "Учет начисления налогов с ФОТ, включаемых в состав расходов" в отчет не выходит ПФР_страх

10.02.2012    4542    filh    19       

Как уменьшить количество заблокированных объектов 26

Статья Программист Нет файла v7.7 1cv7.md Россия Бесплатно (free) Практика программирования

История о том как я решил пересобрать форму справочника клиентов и чем это все закончилось...

12.01.2012    13139    ShEvOvIcH    18       

Прямые запросы: ускорение получения цен для типовой ТиС 7.7 21

Статья Программист Нет файла v77::ОУ 1С7:Комплекс 1С7:ТиС Россия Бесплатно (free) Практика программирования Разработка внешних компонент

Первая статья из цикла статей "Прямые запросы:...". Рассказывается о применении класса ПрямойЗапрос и компоненты 1С++ для ускорения функции глВернутьЦену() в типовой конфигурации Торговля и склад. Платформа 7.7.

15.11.2011    13098    leshik    21       

1С:Торговля и Склад - ошибка во всех релизах, При использовании нескольких фирм и префиксов номеров документов. 14

Статья Программист Нет файла v77::ОУ 1С7:ТиС Россия Бесплатно (free) Практика программирования

Собственно сегодня обнаружил ошибку, которая присутствует во всех релизах конфигурации Торговля и Склад 7.7 вплоть до текущего 7.70.969, при использовании нескольких фирм и префиксов документов для некоторых из них.

04.11.2011    13326    twilight5023    8       

Конфигурация для автоматизации учета бланков строгой отчетности и анализа деятельности государственных ветеринарных служб (демо база) 5

Отчеты и формы no Конфигурация (md, cf) v77::ОУ Государственные, бюджетные структуры Россия Производство готовой продукции (работ, услуг) Бесплатно (free) Управленческий учет (прочее)

Конфигурация для автоматизации учета бланков строгой отчетности и анализа деятельности государственных ветеринарных служб (демо база). Данная разработка опубликована с целью изучения интереса со стороны сообщества к программным решениям в области государственных ветеринарных служб.

05.08.2011    13720    40    delta    3       

Кнопка обновления версии внешнего отчета 18

Статья Программист Нет файла v77::ОУ v77::БУ v77::Расчет Россия Бесплатно (free) Практика программирования

После исправления внешнего отчета вместо рекомендации пользователю: "Закрой отчет и открой его заново", говорим: "Нажми на кнопку".

18.06.2011    11663    Shaman100M    8       

Особенности сортировки в 1С:Предприятие 7.7 22

Инструменты и обработки Программист Внешняя обработка (ert,epf) v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Windows Бесплатно (free) Практика программирования

Подобная "разработка" использовалась для анализа/сравнения порядка индексов таблиц БД в различных СУБД: "родные" DBF, MS SQL, CodeBase 6.5, Advantage 7.x/8.x/9.x. Тогда было выяснено, что в этих СУБД разный порядок сортировки индекса.

29.05.2011    15174    68    hogik    4       

Учет переплаты за прошлый период (персонифицированный учет в ПФР) 9

Статья Программист Нет файла v77::ОУ 1С7:ЗиК Россия БУ Зарплата ФОМС, ПФ, ФСС Бесплатно (free) Практика программирования

Для того, чтобы в отчетности за текущий период учитывалась переплата по страховой/накопительной части, произведенная в прошлых отчетных периодах.

06.05.2011    3753    pavel_vrn    8       

Конвертация прериодических реквизитов справочников 6

Статья Программист Нет файла v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Бесплатно (free) Практика программирования

Активно работаю с конфигурацией "Конвертация" версии 2.0, но возникают ситуации, когда необходимо написать правила обмена между базами данных 1С:Предприятие. Когда и источник и приемник имеют версию 7.7. И камень преткновения - выгрузка периодических реквизитов справочников.

29.04.2011    12889    lvictor58    2       

Некоторые ошибки и «проблемные» особенности реализации встроенного языка платформы 1С:Предприятие 7.7 96

Статья Программист Нет файла v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Бесплатно (free) Практика программирования

Описание некоторых ошибок и особенностей реализации встроенного языка, которые создают «подводные камни» при программировании, а также возможных способов обхода этих проблем из собственного опыта работы на платформе 1С:Предприятие 7.7.

08.04.2011    41912    AleksR    102       

Вариант реализации динамического табло в 1С 7.7 12

Статья Программист Нет файла v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Бесплатно (free) Практика программирования

Позволяет отображать на экране (монитора или большого телевизора) результат работы требуемого отчета при изменении определенных данных без необходимости интерактивного участия пользователя

14.03.2011    7095    1с2с    19       

Тюнинг Бух 7.7.: Микрографики в ТЧ документа. 49

Статья Программист Нет файла v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Бесплатно (free) Практика программирования

Как вставить в документ что-то вроде диаграммы распределения сумм…

25.01.2011    18129    Арчибальд    18       

Граната для обезьянки или редактор движений регистра (7.7) 123

Инструменты и обработки Системный администратор Программист Бухгалтер Внешняя обработка (ert,epf) v7.7 1cv7.md Россия УУ Бесплатно (free) Обработка документов Администрирование данных 1С

Правим движения регистра не отходя от кассы! Универсальная поделка для редактирования движений любого документа, даже если он не проведен или помечен на удаление.

17.12.2010    32606    1218    Ёпрст    180       

Подбор свободного кода справочника "Номенклатура" без захвата одного и того же кода несколькими операторами. 1

Статья Программист Нет файла v77::ОУ 1С7:ТиС Россия Windows Бесплатно (free) Практика программирования

При использовании в справочнике Номенклатура конструкции подбора не занятых кодов менее максимального, при работе нескольких операторов возникла проблема захвата одного и того же кода, если не использовать Записать() при создании нового элемента.

05.11.2010    8457    Rusk51    10       

Быстрый подсчет элементов справочника 17

Статья Программист Нет файла v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Бесплатно (free) Практика программирования

Частенько бывает нужно подсчитать количество элементов в справочнике, чтобы показать пользователю прогресс выполнения обработки. Быстро это сделать позволяет следующая функция.

18.10.2010    21197    brr    11       

[ОБУЧАЛОВКА] Прямые запросы: практические примеры разработки 29

Статья Программист Нет файла v77::ОУ 1С7:Комплекс 1С7:ТиС Россия Бесплатно (free) Практика программирования

Пример прямого запроса для типовой 1С 7.7. ТиС для извлечения цен номенклатуры... тест

30.09.2010    116376    CheBurator    37       

Изменяем вид кнопок на форме 1С 7.7 25

Статья Программист Нет файла v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Windows Бесплатно (free) Практика программирования

Изменяем вид кнопок на форме 1С 7.7. Статья для разработчиков ВК (Delphi) Реализовано в http://infostart.ru/public/59436/?PAGEN_1=22#comm

20.08.2010    20683    Abadonna    12       

Максимум изменений в стандартной конфигурации при их минимуме с использованием formex.dll 34

Статья Программист Нет файла v77::ОУ v77::БУ v77::Расчет 1cv7.md Windows Бесплатно (free) Практика программирования Разработка внешних компонент

Восстанавливаю ранее опубликованную статью. Может кому пригодится... Иногда очень хочется что-нибудь добавить в стандартную конфигурацию, но потом возникают проблемы, связанные с "затиранием" кода при обновлении. Каждый раз помнить где и что - напряжно. При данном подходе в Глобальный Модуль добавляется всего одна (!) строчка

15.08.2010    16390    Abadonna    33       

Универсальная обработка табличной части документа 21

Инструменты и обработки no Внешняя обработка (ert,epf) v77::ОУ v77::БУ v77::Расчет 1cv7.md Windows Бесплатно (free) Обработка документов

Обработка предназначена для группового изменения реквизитов табличной части документа. Например, изменить реквизит документа на процент и т.п.

02.08.2010    12406    392    vovk_v    17       

Организация быстрого подбора 3

Инструменты и обработки Программист Внешняя обработка (ert,epf) openconf v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Бесплатно (free) Практика программирования

Организация быстрого подбора, что бы отфильтрованные позиции справочника "вылетали" по нажатии символов, причём не важно, в каком позиции начинается слово в названии элемента.

15.06.2010    6081    118    DeAmon2K    13       

Разбор строки CSV при помощи RegExp 12

Статья Программист Нет файла v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Бесплатно (free) Практика программирования

Вроде бы все просто, пока не встретилось что-то наподобие "111;111""";111

27.05.2010    12372    Berrimor    16       

АЦРК: Реестр документов универсальный 48

Инструменты и обработки no Внешняя обработка (ert,epf) v77::ОУ v77::БУ v77::Расчет 1cv7.md Windows Бесплатно (free) Обработка документов

Печатает реестр документов любого вида. Можно управлять составом и порядком печатаемых реквизитов (в том числе и табличных частей) и подсчетом итогов по реестру. Можно задавать условия отбора документов для реестра.

21.05.2010    16918    840    acrk    32       

Фильтрация иерархического справочника по какому-либо условию в форме списка 13

Статья Программист Нет файла v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Бесплатно (free) Практика программирования

Перед 1С программистами порой встаёт задача реализовать фильтрацию справочника по какому-нибудь условию прямо в форме списка (Например "ФормаСписка" или "ДляПодбора"). Вот и передо мной, недавно, поставили такую задачу. Она оказалась не такой уж и тривиальной, особенно для иерархического справочника...

19.05.2010    10601    Antoska    19       

Как получить GUID без v7plus.dll в Предприятии 7.7 10

Статья Программист Нет файла v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Бесплатно (free) Практика программирования Универсальные функции

Часто в терминальных сессиях у пользователю Windows не хватает прав на регистрацию v7plus.dll. Соответственно нельзя воспользоваться, например методом СоздатьGUID() класса V7SysInfo.

12.05.2010    12208    prolancer    5       

Групповая обработка документов для 1С: Предприятия 7.7 6

Инструменты и обработки no Внешняя обработка (ert,epf) v77::ОУ 1С7:ТиС Windows Бесплатно (free) Сервисные утилиты Обработка документов

Переделанная типовая обработка из конфигурации "Торговля и склад". Может быть легко адаптирована для любой конфигурации. Обработка умеет снимать / устанавливать пометку удаления, делать не проведенными и проводить документы за выбранный период. Программа распространяется в надежде, что может быть полезена, но БЕЗ КАКОГО-ЛИБО ВИДА ГАРАНТИЙ, ВЫРАЖЕННЫХ ЯВНО ИЛИ ПОДРАЗУМЕВАЕМЫХ, ВКЛЮЧАЯ, НО НЕ ОГРАНИЧИВАЯСЬ ПОДРАЗУМЕВАЕМЫМИ ГАРАНТИЯМИ КОММЕРЧЕСКОЙ ЦЕННОСТИ И ПРИГОДНОСТИ ДЛЯ КОНКРЕТНОЙ ЦЕЛИ.

28.04.2010    21970    1383    vovk_v    21       

1c v 7.7. Установка владельца для справочника, имеющего записи. 9

Статья Программист Нет файла v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Бесплатно (free) Практика программирования Работа с интерфейсом

Итак, в конфигурацию я должен был добавить новый справочник, и, самое странное, должен был поставить ему в подчинение уже существующий справочник, причем активно использующийся. Если делать это штатными средствами, 1с при сохранении конфигурации выдает сообщение, что справочник такой-то имеет записи и не может быть подчинен.

28.04.2010    7423    Майкопчанин    12       

Выгонялка. 14

Статья Программист Нет файла openconf v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Бесплатно (free) Практика программирования

Часто сталкиваюсь с проблемой: просишь пользователей выйти из базы, а они не слушаются! Для этого написала такую вот выгонялку.

21.04.2010    10445    Cvetic    38       

Упаковщик двоичных файлов os7764 30

Инструменты и обработки Программист Внешняя обработка (ert,epf) v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Бесплатно (free) Практика программирования

Помещает любые файлы (драйвера, внешние компоненты, видеоролики) в конфигурацию или внешнюю обработку и обеспечивает их распаковку.

18.04.2010    12665    205    nafa    27       

Перехват некоторых клавиш клавиатуры 8

Инструменты и обработки Программист Внешняя обработка (ert,epf) v77::ОУ v77::БУ 1cv7.md Россия Бесплатно (free) Практика программирования

Представлена небольшая коллекция кнопок, позволяющая перехватывать нажатие некоторых клавиш клавиатуры. ВК не используется. Ничего нового, давно уже используется в нашем сообществе. Технология - GComp.

07.03.2010    11017    380    G_Re    23       

Загрузка данных (справочник, документ) через буфер обмена 21

Статья Программист Нет файла v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Бесплатно (free) Практика программирования Загрузка и выгрузка в Excel

Первая в мире однокнопочная обработка, мечта юзера! Расскажу, как я кардинально упростил загрузку разнообразных данных из Экселя...

01.03.2010    10723    mikukrnet    12       

Дерево документов ТиС 1с++ 0

Инструменты и обработки no Внешняя обработка (ert,epf) v77::ОУ 1С7:Комплекс 1С7:ТиС Россия Бесплатно (free) Обработка документов

Ввиду проблем с mssql2005 пришлось переделать показ структуры подчиненности документов. (Штатная внутренняя обработка ДеревоДокументов) использован материал: http://www.forum.mista.ru/topic.php?id=400197 Если автор где-то здесь (на инфостарте), пусть напишет.

10.02.2010    7459    89    dav405    1       

Оптимизация штатных запросов 7.7 43

Статья Программист Нет файла v77::ОУ 1С7:Комплекс 1С7:ТиС 1С7:ПУБ Россия Бесплатно (free) Практика программирования

1С 7.7 выполняет запросы просто и бездумно - все что сказали, все и сделает. Никаких попыток оптимизации. Если в запросе есть переменная, например "СвойствоПоставщика=Регистр.ПартииНаличие.Партия.Поставщик.ОсновноеСвойство;" произойдет обращение к справочникам контрагентов и значений свойств, даже если переменная СвойствоПоставщика не используется ни в условиях, ни в группировках. Что оборачивается потерей быстродействия.

26.01.2010    15029    vcv    22