Конструктор дерева/таблицы значений в режиме предприятия

Публикация № 536031

Разработка - Практика программирования

Генерация строки кода создания таблицы/дерева значений, удобно использовать с конструктором коллекции ИР

Когда-то пользовался скриптом для openconf - конструктор таблицы значений: в формочке указывается структура ТЗ, на выходе код. Работая с ИР, вдруг подумал, что было бы удобно сделать нечто похожее: в консоли кода ИР описываем структуру ТЗ, и генерим код для ее создания с помощью языка 1С. Что получилось - выкладываю сюда, наглядно на видео:

Сам код:

	тз = ИсходнаяТЗ.СкопироватьКолонки();
	
	#Область Описание_соответствий_имен_типов
	
	СтруктураСоответствиеИменТипов = Новый Структура;
	
	//Простые
	СтруктураСоответствиеИменТипов.Вставить("boolean", "Булево");
	СтруктураСоответствиеИменТипов.Вставить("decimal", "Число");
	СтруктураСоответствиеИменТипов.Вставить("string", "Строка");
	СтруктураСоответствиеИменТипов.Вставить("dateTime", "Дата");
	
	// Ссылочные
	СтруктураСоответствиеИменТипов.Вставить("CatalogRef", "СправочникСсылка");
	СтруктураСоответствиеИменТипов.Вставить("DocumentRef", "ДокументСсылка");	
	СтруктураСоответствиеИменТипов.Вставить("BusinessProcessRoutePointRef", "ТочкаМаршрутаБизнесПроцессаСсылка");
	СтруктураСоответствиеИменТипов.Вставить("ChartOfCalculationTypesRef", "ПланВидовРасчетаСсылка");
	СтруктураСоответствиеИменТипов.Вставить("BusinessProcessRef", "БизнесПроцессСсылка");
	СтруктураСоответствиеИменТипов.Вставить("ChartOfAccountsRef", "ПланСчетовСсылка");
	СтруктураСоответствиеИменТипов.Вставить("EnumRef", "ПеречислениеСсылка");
	СтруктураСоответствиеИменТипов.Вставить("ChartOfCharacteristicTypesRef", "ПланВидовХарактеристикСсылка");
	СтруктураСоответствиеИменТипов.Вставить("TaskRef", "ЗадачаСсылка");	
	СтруктураСоответствиеИменТипов.Вставить("ExchangePlanRef", "ПланОбменаСсылка");	
	
	// Коллекции
	СтруктураСоответствиеИменТипов.Вставить("ValueTree", "ДеревоЗначений");
	СтруктураСоответствиеИменТипов.Вставить("ValueTable", "ТаблицаЗначений");
	СтруктураСоответствиеИменТипов.Вставить("ValueListType", "СписокЗначений");
	СтруктураСоответствиеИменТипов.Вставить("Array", "Массив");  
	
	// Прочие
	СтруктураСоответствиеИменТипов.Вставить("StandardBeginningDate", "СтандартнаяДатаНачала");
	СтруктураСоответствиеИменТипов.Вставить("UUID", "УникальныйИдентификатор");
	СтруктураСоответствиеИменТипов.Вставить("StandardPeriod", "СтандартныйПериод");
	СтруктураСоответствиеИменТипов.Вставить("PointOfTime", "МоментВремени");
	СтруктураСоответствиеИменТипов.Вставить("Null", "Null");	
	СтруктураСоответствиеИменТипов.Вставить("Type", "Тип");
	СтруктураСоответствиеИменТипов.Вставить("Bound", "Граница");
	СтруктураСоответствиеИменТипов.Вставить("Field", "ПолеКомпоновкиДанных");	
	СтруктураСоответствиеИменТипов.Вставить("TypeDescription", "ОписаниеТипов");
	
	// Системные перечисления	
	СтруктураСоответствиеИменТипов.Вставить("AccumulationRecordType", "ВидДвиженияНакопления");
	СтруктураСоответствиеИменТипов.Вставить("AccountingRecordType", "ВидДвиженияБухгалтерии");
	СтруктураСоответствиеИменТипов.Вставить("AccountType", "ВидСчета");
	
	#КонецОбласти 	
	
	СтрокаКода = ИмяПеременной + " = Новый ТаблицаЗначений;";
	Для Каждого Колонка Из тз.Колонки Цикл
		
		//скк - строка кода конструктора
		скк_ОписанияТипов = "";
	    скк_МассивТипов = "";
		
#Область Генерация_строки_описания_типов
		
		МассивТипов = Колонка.ТипЗначения.Типы();
		
		// Если колонка несоставного типа, то воспользуюсь быстрым конструктором 
		// описания типов, иначе - через массив		
		Счетчик = 0; ВсегоТипов = МассивТипов.Количество();
		ЕстьОписание = ВсегоТипов > 0;
		
		Если ЕстьОписание Тогда
			ЭтоПростоеОписаниеТипов = ВсегоТипов = 1;
			
			скк_МассивТипов = "";
			
	#Область Генерация_строки_массива_типов
			Для каждого Тип Из МассивТипов Цикл	
				
				Счетчик = Счетчик + 1;
				
				ТипXML = СериализаторXDTO.XMLТип(Тип);	
				
				поз = Найти(ТипXML.ИмяТипа, ".");
				Если поз > 0 Тогда
					ТипМетаданногоАнгл = Лев(ТипXML.ИмяТипа, поз - 1);	
					ИмяМетаданного = Сред(ТипXML.ИмяТипа, поз + 1);
					ТипМетаданногоРус = СтруктураСоответствиеИменТипов[ТипМетаданногоАнгл];
					скк_ТекущийТип = ТипМетаданногоРус + "." + ИмяМетаданного;
				Иначе
					скк_ТекущийТип = СтруктураСоответствиеИменТипов[ТипXML.ИмяТипа];
				КонецЕсли; 				
				
				Если ЭтоПростоеОписаниеТипов Тогда
					скк_ПараметрОписания = """" + скк_ТекущийТип + """";	
				Иначе	
					скк_ПараметрОписания = "МассивТипов";
					Если Счетчик = 1 Тогда
						скк_МассивТипов = "МассивТипов = Новый Массив();"					
					КонецЕсли; 
					скк_МассивТипов = скк_МассивТипов + Символы.ПС + "МассивТипов.Добавить(Тип(""" + скк_ТекущийТип+ """));";
				КонецЕсли; 
				
			КонецЦикла;
	#КонецОбласти 		
			
		
	#Область Генерация_строки_квалификаторов
			скк_Квалификаторы = ",КвЧисла,КвСтроки,КвДаты";
			скк_квДаты = ""; скк_квЧисла = ""; скк_квСтроки = "";
			Если Колонка.ТипЗначения.СодержитТип(Тип("Дата")) Тогда
				
				Если Колонка.ТипЗначения.КвалификаторыДаты.ЧастиДаты = ЧастиДаты.Время Тогда
					скк_ЧастиДаты = "Время";
					
				ИначеЕсли Колонка.ТипЗначения.КвалификаторыДаты.ЧастиДаты = ЧастиДаты.Дата Тогда
					скк_ЧастиДаты = "Дата";
					
				ИначеЕсли Колонка.ТипЗначения.КвалификаторыДаты.ЧастиДаты = ЧастиДаты.ДатаВремя Тогда
					скк_ЧастиДаты = "ДатаВремя";				
					
				КонецЕсли; 
				
				скк_квДаты = " Новый КвалификаторыДаты(ЧастиДаты."+ скк_ЧастиДаты +")"; 	
			КонецЕсли; 
			
			Если Колонка.ТипЗначения.СодержитТип(Тип("Строка")) Тогда
				скк_ДлинаСтроки = Колонка.ТипЗначения.КвалификаторыСтроки.Длина;
				скк_ДопустимаяДлина = "" + Колонка.ТипЗначения.КвалификаторыСтроки.ДопустимаяДлина;
				
				скк_квСтроки = " Новый КвалификаторыСтроки("+ скк_ДлинаСтроки +", " +
				"ДопустимаяДлина." + скк_ДопустимаяДлина +")";
			КонецЕсли; 
			
			Если Колонка.ТипЗначения.СодержитТип(Тип("Число")) Тогда
				скк_ЧислоРазрядов = "" + Колонка.ТипЗначения.КвалификаторыЧисла.Разрядность;
				скк_ЧислоРазрядовДробнойЧасти = "" + Колонка.ТипЗначения.КвалификаторыЧисла.РазрядностьДробнойЧасти; 
				скк_ДопустимыйЗнак = "" + Колонка.ТипЗначения.КвалификаторыЧисла.ДопустимыйЗнак;
				
				скк_квЧисла = " Новый КвалификаторыЧисла("+ скк_ЧислоРазрядов + ", " +
				скк_ЧислоРазрядовДробнойЧасти + 
				", ДопустимыйЗнак." + скк_ДопустимыйЗнак +")";
			КонецЕсли; 
			
			скк_Квалификаторы = СтрЗаменить(скк_Квалификаторы, "КвДаты", скк_квДаты);	
			скк_Квалификаторы = СтрЗаменить(скк_Квалификаторы, "КвСтроки", скк_квСтроки);
			скк_Квалификаторы = СтрЗаменить(скк_Квалификаторы, "КвЧисла", скк_квЧисла);
			
			//Удалю запятые с конца
			Пока Прав(скк_Квалификаторы, 1) = "," Цикл
				скк_Квалификаторы = Лев(скк_Квалификаторы, СтрДлина(скк_Квалификаторы) - 1);				
			КонецЦикла; 
	#КонецОбласти 

			скк_ОписанияТипов = "Новый ОписаниеТипов("+ скк_ПараметрОписания + скк_Квалификаторы +")";
		Иначе
			скк_ОписанияТипов = "";			
		КонецЕсли; 
		
#КонецОбласти 		
		
		скк_ПараметрыКолонки = 
		"""" + Колонка.Имя + """," +  // ИмяКолонки
		?(ПустаяСтрока(скк_ОписанияТипов), "", " " + скк_ОписанияТипов) + "," + // Описание типов
		?(ПустаяСтрока(Колонка.Заголовок), "", " """ + Колонка.Заголовок + """") + "," + // Заголовок
		?(Колонка.Ширина = 0, "", " "+ Колонка.Ширина); // Ширина
		
		//Удалю запятые с конца
		Пока Прав(скк_ПараметрыКолонки, 1) = "," Цикл
			скк_ПараметрыКолонки = Лев(скк_ПараметрыКолонки, СтрДлина(скк_ПараметрыКолонки) - 1);				
		КонецЦикла; 
				
		//Генерация кода создания колонки:
		СтрокаКода = СтрокаКода + Символы.ПС +
		скк_МассивТипов + ?(ПустаяСтрока(скк_МассивТипов), "", Символы.ПС) +
		ИмяПеременной + ".Колонки.Добавить("+ скк_ПараметрыКолонки +");" 
		+ ?(ПустаяСтрока(скк_МассивТипов), "", Символы.ПС);
		
	КонецЦикла;
	
	Сообщить(СтрокаКода);

 

 

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. tormozit 6179 10.07.16 13:17 Сейчас в теме
На будущее. При записи ролика лучше запускать приложение без проверки модальности. Будет красивее.
German_Tagil; +1 Ответить
2. unichkin 1332 10.07.16 15:58 Сейчас в теме
(1) tormozit, это да. Для тестов взял что под рукой было - БП 3.0, показалось что долго коряжить - а на деле еще с видео провозился полчаса почти))
3. Yashazz 3612 11.07.16 12:21 Сейчас в теме
Товарисч, ну ты что. Работаешь с XDTO, а для соответствия русских и английских имён такой ужас нагородил. Это ж проще можно, вроде СокрЛП(СериализаторXDTO.XMLСтрока(рЗначение)) где Значение, например, системного типа, на выходе будет англоязычным. Или фабрики самой 1С почитай.
4. unichkin 1332 11.07.16 12:56 Сейчас в теме
(3) Yashazz, копался час с этим не нашел другого способа. В т. ч. и СериализаторXDTO.XMLСтрока("CatalogRef.Контрагенты") пробовал - возвращает "CatalogRef.Контрагенты". Может чего-то недопонимаю.
Оставьте свое сообщение

См. также

Serverless (Faas) в 1С. Создание и вызов Yandex Cloud Functions Промо

Универсальные функции Практика программирования v8 Бесплатно (free)

"Я не могу просто взять и скопировать код с гитхаба", "у нас 1С микросервисами окружена", "возможностей мало" - частые фразы 1С разработчиков. которым не хватает возможностей платформы в современном мире. Faas, конечно, история не новая, но нас сдерживало 152ФЗ и задержки по пингам. Для того, чтобы действительно использовать в 1С код, к примеру, на Python, надо было приложить усилия. Теперь всё намного проще - берём и используем.

28.12.2020    3504    comol    20    

«Варп-двигатель» для «среза последних»

Практика программирования Бесплатно (free)

Решение, позволяющее получить данные, аналогичные "срезу последних" на два порядка быстрее.

10.08.2020    3110    hobi    45    

Не спеша, эффективно и правильно – путь разработки. Часть 3. Практика

Практика программирования Бесплатно (free)

Черновой вариант книги Никиты Зайцева, a.k.a.WildHare. Разработкой на платформе 1С автор занимается с 1996-го года, специализация — большие и по-хорошему страшные системы. Квалификация “Эксперт”, несколько успешных проектов класса “сверхтяжелая”. Успешные проекты ЦКТП. Четыре года работал в самой “1С”, из них два с половиной архитектором и ведущим разработчиком облачной Технологии 1cFresh. Ну — и так далее. Не хвастовства ради, а понимания для. Текст написан не фантазером-теоретиком, а экспертом, у которого за плечами почти двадцать три года инженерной практики на больших проектах.

29.06.2020    10341    WildHare    33    

Не спеша, эффективно и правильно – путь разработки. Часть 2. Теория

Практика программирования Бесплатно (free)

Черновой вариант книги Никиты Зайцева, a.k.a.WildHare. Разработкой на платформе 1С автор занимается с 1996-го года, специализация — большие и по-хорошему страшные системы. Квалификация “Эксперт”, несколько успешных проектов класса “сверхтяжелая”. Успешные проекты ЦКТП. Четыре года работал в самой “1С”, из них два с половиной архитектором и ведущим разработчиком облачной Технологии 1cFresh. Ну — и так далее. Не хвастовства ради, а понимания для. Текст написан не фантазером-теоретиком, а экспертом, у которого за плечами почти двадцать три года инженерной практики на больших проектах.

22.06.2020    10933    WildHare    23    

Использование программных перечислений, ч.1: строковые константы Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Часто ли у вас возникает необходимость в коде выполнять сравнение на строку?

10.12.2016    38191    unichkin    74    

Не спеша, эффективно и правильно – путь разработки. Часть 1. Парадигма

Практика программирования Бесплатно (free)

Черновой вариант книги Никиты Зайцева, a.k.a.WildHare. Разработкой на платформе 1С автор занимается с 1996-го года, специализация — большие и по-хорошему страшные системы. Квалификация “Эксперт”, несколько успешных проектов класса “сверхтяжелая”. Успешные проекты ЦКТП. Четыре года работал в самой “1С”, из них два с половиной архитектором и ведущим разработчиком облачной Технологии 1cFresh. Ну — и так далее. Не хвастовства ради, а понимания для. Текст написан не фантазером-теоретиком, а экспертом, у которого за плечами почти двадцать три года инженерной практики на больших проектах.

15.06.2020    16305    WildHare    34    

JSON в запросах DaJet QL

Практика программирования Бесплатно (free)

Практические примеры работы с JSON непосредственно в языке запросов. Перенос курсов валют между УТ и БП. Требуется SQL Server 2016 и выше.

24.04.2020    4013    zhichkin    6    

Визионное программирование

Практика программирования Бесплатно (free)

Новый способ программирования и его практическая демонстрация.

22.04.2020    4710    mkalimulin    111    

Вспомогательные инструкции в коде 1С Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Помогаем редактору кода 1С помогать нам писать и анализировать код.

15.10.2018    31606    tormozit    104    

Использование машинного обучения для решения инцидентов. Практическое применение

Практика программирования Бесплатно (free)

Продолжаю (и заканчиваю) тему с автоматическим решением инцидентов. Перейдем от теории к практике.

25.02.2020    4433    Repich    9    

Использование машинного обучения для решения инцидентов

Практика программирования Бесплатно (free)

История о том, как я с помощью машинного обучения сокращал затраты на техподдержку.

18.02.2020    7161    Repich    17    

Часовой на страже логов

Практика программирования Инструментарий разработчика Бесплатно (free)

При поддержке решений, которые установлены у большого количества пользователей на различных системах, очень важно вовремя получать подробную информацию о возникших проблемах. О том, как собирать логи и анализировать полученные данные в трекере ошибок Sentry на конференции Infostart Event 2019 Inception рассказал Андрей Крапивин.

13.01.2020    7493    Scorpion4eg    8    

Оформление и рефакторинг сложных логических выражений Промо

Практика программирования v8 Россия Бесплатно (free)

В сложных логических выражениях нередко самому автору спустя какое-то время тяжело разобраться, не говоря уже о других программистах. Предлагаемая методика позволяет повысить наглядность таких выражений путем оформления в виде И-ИЛИ дерева и одновременно выполнять их рефакторинг.

20.09.2012    78941    tormozit    131    

Приватный блокчейн и 1С популярно

Практика программирования Блокчейн Бесплатно (free)

Две предыдущие публикации на эту тему были сфокусированы преимущественно на технической стороне вопроса. Кроме того, их содержание оказалось понятным не каждому специалисту. В этой статье я постараюсь обяснить для всех и, что говорится, «на пальцах»: что такое приватный блокчейн, когда и зачем его следует применять и на что обратить внимание при использовании этой технологии в 1С.

02.09.2019    6336    mkalimulin    140    

Кодогенерация и метагенерация в 1С

Практика программирования Инструментарий разработчика Бесплатно (free)

В своем докладе на конференции INFOSTART EVENT 2018 EDUCATION Дмитрий Белозеров рассказал о разработке инструмента, позволяющего программно работать с метаданными 1С и писать скрипты для выполнения тех же действий, которые выполняет разработчик в конфигураторе –  с какими сложностями и нюансами пришлось столкнуться, и что получилось в итоге.

26.08.2019    9198    kirovsbis    28    

Интеграция сценарного тестирования в процесс разработки

Практика программирования Инструментарий разработчика Бесплатно (free)

Разработчик системы «Тестер» Дмитрий Решитко в своем докладе на конференции INFOSTART EVENT 2018 EDUCATION показывает, что процесс тестирования можно очень плотно интегрировать в процесс разработки, что внедрение тестирования – это возможность развития программиста как такового, позволяющая ему упорядочивать ход мыслей и оставаться «в фокусе». Навыки построения процесса кодирования на стыке с тестированием сокращают время на концентрацию, освобождают от страха перед изменениями и улучшают память разработчика.

08.07.2019    9555    grumagargler    7    

Запись значения в поле ввода/формы со срабатыванием события ПриИзменении Промо

Практика программирования v8 1cv8.cf Россия Бесплатно (free)

Иногда возникает необходимость после записи значения в какое либо поле ввода/формы вызвать для него обработчик события ПриИзменении, а о вызове самого события приходится только мечтать. В этой статье приводится программный способ вызова этого события.

11.07.2007    49599    tormozit    48    

Управляй качеством кода 1С с помощью SonarQube

Практика программирования Россия Бесплатно (free)

Управляй техническом долгом проектов 1С с помощью SonarQube. В статье рассматривается пример применения SonarQube при разработке.

07.07.2019    44609    olegtymko    234    

Выгрузка документа по условию

Практика программирования Разработка v8 Бесплатно (free)

Что делать, если документы нужно выгружать не все подряд, а по какому-то фильтру: статусу, дате, набору условий... А что если он соответствовал этим условиям, а потом перестал? А если потом опять начал? Такие ситуации заставили попотеть не одного программиста.

25.04.2019    16329    m-rv    2    

Как прикрутить ГУИД к регистру сведений

Практика программирования Перенос данных из 1C8 в 1C8 Разработка v8 Бесплатно (free)

... и немного теории обмена данными. В частности, разберем боль всех, кто пишет небанальные обмены данными: как набору записей регистра сведений назначить гуид и далее использовать его в обмене для идентификации этого набора.

16.04.2019    20810    m-rv    17    

Как сделать из &НаКлиентеНаСервереБезКонтекста почти &НаКлиентеНаСервере Промо

Практика программирования v8 1cv8.cf Россия Бесплатно (free)

Как сделать метод формы, доступный на клиенте и на сервере одновременно, и сохранить при этом удобство разработки

10.09.2017    46158    tormozit    74    

О времени и 1С

Практика программирования Разработка Бесплатно (free)

Основы и особенности работы со временем в 1С. Как избавиться от боли при работе в разных часовых поясах. Что такое момент времени. И другое.

01.04.2019    39553    YPermitin    61    

Пример создания bridge (http api - tcp) для ККТ "Касса №1" ("К1-Ф")

Практика программирования ККМ Кассовые операции Кассовые операции Разработка Россия Бесплатно (free)

Пример создания bridge (http api - tcp) для ККТ "Касса №1" ("К1-Ф"). Данная статья будет полезна интеграторам, программистам, тем кто работает (интегрирует, разрабатывает) различное ТО либо железки. Версия и релиз технологической платформы не имеет значения.

17.03.2019    6770    dmarenin    1    

Развитие 1С программиста Промо

Практика программирования Личная эффективность Бесплатно (free)

Делюсь своим опытом и видением развития 1С программиста.

17.10.2018    22168    pashamak    63    

Быстрее чем INSERT! BULK-операции и примеры использования

Производительность и оптимизация (HighLoad) Практика программирования Внешние источники данных Перенос данных из 1C8 в 1C8 Разработка Бесплатно (free)

Microsoft SQL Server поддерживает так называемые BULK-операции, используемые для быстрого изменения больших объемов данных в базе. В статье пойдет речь о практических примерах их использования. Все примеры сделаны в контексте платформы 1С (а как иначе).

09.03.2019    27066    YPermitin    40    

Как писать понятные коммиты

Практика программирования Разработка Россия Бесплатно (free)

Как писать сообщения коммитов так, чтобы потом не было мучительно больно.

06.03.2019    13166    Scorpion4eg    35    

Как сделать запрос на изменение данных Промо

Практика программирования v8 v8::Запросы 1cv8.cf Бесплатно (free)

В статье приведены особенности внутренней архитектуры и примеры работы с расширением языка запросов 1С.

01.06.2018    31789    m-rv    21    

Подготовка ребёнка к ЕГЭ по информатике. Часть шестнадцатая

Практика программирования Разработка Бесплатно (free)

Поиск выигрышной стратегии, завершающая статья.

22.02.2019    5870    vasilev2015    0    

Метод формирования движений в типовых регистрах нетиповыми регистраторами Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Вариант решения задач с проведением по типовым регистрам нетиповыми регистраторами. Зачем - чтобы при сравнении конфигурации не обращать внимание на свойства регистров и исключить вероятность допущения горькой оплошности при обновлении информационных баз, заменив типы регистраторов основной конфигурации типами конфигурации поставщика. Для программных продуктов, имеющих в своем составе метаданных документ "Корректировка регистров"("Корректировка записей регистров").

05.12.2017    28704    itriot11    34    

Подготовка ребёнка к ЕГЭ по информатике. Часть тринадцатая

Практика программирования Разработка Бесплатно (free)

Исправление ошибок в программе, часть вторая.

20.02.2019    5906    vasilev2015    3    

Использование классов .Net в 1С для новичков Промо

Практика программирования Разработка внешних компонент Универсальные функции v7.7 v8 Бесплатно (free)

Руководство для новичков. Написав статью http://infostart.ru/public/238584/, я понял, что многие не понимают того, что написано. Поэтому в этой статье постараюсь более подробно остановиться на азах и без кода на вражеском языке (C#)

27.01.2016    77870    Serginio    110    

Подготовка ребёнка к ЕГЭ по информатике. Часть восьмая

Практика программирования Разработка Бесплатно (free)

Шифрование и дешифрование информации. Закон Фано

05.02.2019    5686    vasilev2015    1    

Автоматические и управляемые блокировки применительно к типовым конфигурациям 1С Промо

Математика и алгоритмы Практика программирования v8 v8::blocking 1cv8.cf Бесплатно (free)

Основные принципы работы с режимами автоматических и управляемых блокировок в 1С Предприятие 8. Теория и применение в типовых конфигурациях: БП, УТ, ЕРП

10.11.2018    36654    ids79    40    

Расширяем свой багаж

Практика программирования Разработка Бесплатно (free)

Алгоритм решения возможной нетиповой задачи на собеседовании.

29.01.2019    6455    scientes    15    

Подготовка ребёнка* к ЕГЭ по информатике. Часть четвертая

Практика программирования Разработка Бесплатно (free)

Решение систем логических уравнений повышенного уровня сложности.

25.01.2019    6430    vasilev2015    0    

Подготовка ребенка* к ЕГЭ по информатике. Часть третья

Практика программирования Разработка Бесплатно (free)

Алгоритмы рекурсии, логические задачи. Подготовка к ЕГЭ.

22.01.2019    7637    vasilev2015    0    

Разработка и сценарное тестирование с Vanessa-ADD. Установка инструментов. Запись действий пользователя и выполнение сценариев

Практика программирования Vanessa Automation Бесплатно (free)

Вторая часть цикла публикаций, посвященных Vanessa-ADD и автоматизации тестирования.

21.01.2019    39476    Vladimir Litvinenko    96    

Подготовка ребенка* к ЕГЭ по информатике. Часть вторая

Практика программирования Бесплатно (free)

Примеры на Паскале. Если сам родитель* - поддержи ! Если сам водила - посигналь !

19.01.2019    5958    vasilev2015    0    

Подготовка к ЕГЭ сына - школьника (по информатике)

Практика программирования Бесплатно (free)

Примеры на Паскале. Если сам отец - поддержи ! Если сам водила - посигналь !

17.01.2019    6712    vasilev2015    50