Добавление собственных "Автоподстановок" в 1С: Документооборот

27.10.16

Разработка - Универсальные функции

При внедрении 1С: Документооборот КОРП, столкнулся с необходимостью добавить свою автоподстановку. Автоподстановок давольно-таки много, но иногда нужно что то не типовое. Так получилось и в данном случае.

Добрый день!

При согласовании внутренного документа (Вид внутренного документа "Договор с контрагентом") возникла необходимость добавить "Руководителя ответственной службы". Т.к. структура предприятия очень большая, и нет возможности в конкретике определиться кто же все таки руководитель ответственной службы, то:

1) Для данного вида внутренного документа добавил обяхательный доп реквизит с типом "Пользователь".

Заполнение данного реквизита обязательно.

2) Изменил немного код, буквально 10 строк:

- Основная конфигурация ОбщийМодуль.ШаблоныБизнесПроцессов.Модуль

Функция ПолучитьСписокДоступныхФункций(ИменаПредметовДляФункций = Неопределено, ВключатьНедоступные = Истина) Экспорт

добавлено:

ДоступныеФункции.Добавить("ШаблоныБизнесПроцессов.РуководительОтветственнойСлужбы(Объект, ИмяПредмета)",
	СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(НСтр("ru = '%1.Руководитель ответственной службы'"),Строка(ИмяПредмета)));

и в этом же модуле создал экспортную процедуру:

Функция РуководительОтветственнойСлужбы (БизнесПроцессОбъект,ИмяПредмета) Экспорт
...............
	Возврат ДопРеквизит.Значение;
...............
КонецФункции

Вот, в общем-то, и все. Новая автоподстановка появилась и отлично работает.

Документооборот

См. также

Загрузка табличного документа в таблицу значений. Пять строк кода, которые изменили мир

Универсальные функции Программист Платформа 1С v8.3 Конфигурации 1cv8 Бесплатно (free)

Благодаря этим пяти строчкам можно больше не заморачиваться с загрузкой из внешних файлов. Пользуюсь везде, всегда и постоянно.

21.05.2024    3712    dimanich70    77    

75

Вставляем картинку из буфера обмена (платформа 1С 8.3.24)

Универсальные функции Программист Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Задача: вставить картинку из буфера обмена на форму средствами платформы 1С.

1 стартмани

18.03.2024    3114    3    John_d    11    

57

GUID в 1С 8.3 - как с ними быть

Универсальные функции Программист Стажер Платформа 1С v8.3 Конфигурации 1cv8 Бесплатно (free)

Пришлось помучиться с GUID-ами немного, решил поделиться опытом, мало ли кому пригодится.

12.02.2024    6132    atdonya    22    

53

Переоткрытие внешних обработок

Универсальные функции Программист Платформа 1С v8.3 Бесплатно (free)

На заключительных этапах, когда идет отладка или доработка интерфейса, необходимо много раз переоткрыть внешний объект. Вот один из способов автоматизации этого.

30.11.2023    4428    ke.92@mail.ru    16    

64

Валидация JSON через XDTO (включая массивы)

WEB-интеграция Универсальные функции Механизмы платформы 1С Программист Платформа 1С v8.3 Конфигурации 1cv8 Бесплатно (free)

При работе с интеграциями рано или поздно придется столкнуться с получением JSON файлов. И, конечно же, жизнь заставит проверять файлы перед тем, как записывать данные в БД.

28.08.2023    10233    YA_418728146    7    

147

Печать непроведенных документов для УТ, КА, ERP. Настройка печати по пользователям, документам и печатным формам

Пакетная печать Печатные формы Адаптация типовых решений Универсальные функции Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Абонемент ($m)

Расширение для программ 1С:Управление торговлей, 1С:Комплексная автоматизация, 1С:ERP, которое позволяет распечатывать печатные формы для непроведенных документов. Можно настроить, каким пользователям, какие конкретные формы документов разрешено печатать без проведения документа.

2 стартмани

22.08.2023    2491    34    progmaster    8    

4

Расширение: Быстрые отборы через буфер [Alt+C] Копировать список, [Alt+V] Вставить список, [Ctrl+C] Копировать из файлов

Инструментарий разработчика Универсальные функции Платформа 1С v8.3 Конфигурации 1cv8 1С:Розница 2 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Зарплата и Управление Персоналом 3.x Абонемент ($m)

Копирует в буфер значения из списков, из ячеек отчетов, таблиц, настроек списков, других отборов и вставляет в выбранную настройку отбора. Работает с Объект не найден. Работает как в одной так и между разными базами 1С. Использует комбинации [Alt+C] Копировать список, [Alt+V] Вставить список. Также для копирования данных используется стандартная [Ctrl+C] (например из открытого xls, mxl, doc и т.п. файла скопировать список наименований)

1 стартмани

13.10.2022    16703    148    sapervodichka    112    

132
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. Skromnyi 13 27.10.16 16:36 Сейчас в теме
Правильнее это делать в общем модуле "ШаблоныБизнесПроцессовПереопределяемый".
fvr2000; chebser; babys; nixel; +4 Ответить
2. iolko 320 27.10.16 16:47 Сейчас в теме
(1) Skromnyi, можно слегка больше деталей?
3. Skromnyi 13 27.10.16 17:17 Сейчас в теме
(2) в этом модуле есть такая-же функция, в нее и надо писать свой код. Там и пример есть создания собственной Автоподстановки.
Akuji; iolko; +2 Ответить
4. iolko 320 27.10.16 21:02 Сейчас в теме
(3) Skromnyi, странно, что отладчиком в нее не залетал(видимо недоглядел), спасибо большое.
20. eksdak 20.08.19 15:28 Сейчас в теме
(4)у меня туда не заходит отладчик
5. zabaluev 462 12.12.16 19:05 Сейчас в теме
А статью надо переделать, как заметил Skromnyi, используя предназначенные для переопределения модули.
Много полезного здесь в ИТС:
"1С:Документооборот" для разработчика
http://its.1c.ru/db/metod8dev#browse:13:-1:1989:2531

6. Eskimos 26 17.01.17 18:59 Сейчас в теме
Сделал всё как вы пишете. Не появляется моя функция в списке автоподстановок.

Попробовал раскоментировать демопример в модуле: ШаблоныБизнесПроцессовПереопределяемый

Всё равно не отображается. Куда копать?
7. Eskimos 26 17.01.17 19:10 Сейчас в теме
Я так понял, что нужно каким-то макаром создать ещё элемент справочника АдреснаяКнига с реквизитом ТипДаннызОбъекта = Автоподстановка процессовjav * ascript:void(0);
8. SkrAn 1 18.01.17 07:22 Сейчас в теме
Просто обнови адресную книгу и все. Правой кнопкой по списку -> обновить данные адресной книги.
Только довольно долго считает. У меня в районе 2х часов.
10. fastovenko 28.04.17 14:14 Сейчас в теме
(8) Что нужно сделать чтобы обновить адресную книгу? По какому списку кликать?
9. Eskimos 26 18.01.17 11:54 Сейчас в теме
Спасибо. Помогло. Вообще за такую реализацию гвоздь в голову вбить разработчику хочется.
11. iolko 320 28.04.17 19:21 Сейчас в теме
в адресной книге ПКМ... обновить данные адресной книге. Затем согласиться на то, что это будет долгою и ждать.
12. logos 211 19.07.17 10:54 Сейчас в теме
В некоторых случаях обновлять адресную книгу может быть смерти подобно. Можно обновить только автоподстановки.
Для этого, в окошке подбора исполнителей шаблона БП, где автоподстановки видны, можно нажать правую кнопку мыши на автоподстановках и выбрать пункт меню "Обновить автоподстановки". Это будет намного быстрее, чем обновлять всю адресную книгу.
Alexandr73Rus; user1492823; Akuji; +3 Ответить
13. Akuji 22 19.10.17 13:38 Сейчас в теме
А если доп реквизитов несколько...
и нужно в зависимости от вида документа разные подставлять тут как лучше сделать?
14. iolko 320 20.10.17 07:53 Сейчас в теме
(13)

//Добавление руководителя инициирующей службы
Функция РуководительИнициирующейСлужбы (БизнесПроцессОбъект) Экспорт
	Для Каждого ПредметПроцесса Из БизнесПроцессОбъект.Предметы Цикл
		Если (ПредметПроцесса.Предмет.ВидДокумента.Родитель = Справочники.ВидыВнутреннихДокументов.НайтиПоНаименованию("Договора")) ИЛИ
			(ПредметПроцесса.Предмет.ВидДокумента.Родитель = Справочники.ВидыВнутреннихДокументов.НайтиПоНаименованию("Заказы")) ИЛИ
			(ПредметПроцесса.Предмет.ВидДокумента.Родитель = Справочники.ВидыВнутреннихДокументов.НайтиПоНаименованию("Изменения условий договора (заказа)"))
			Тогда
			Для Каждого ДопРеквизит из ПредметПроцесса.Предмет.ДополнительныеРеквизиты Цикл
				Если Найти(НРЕГ(ДопРеквизит.Свойство),НРЕГ("Руководитель инициирующей службы"))>0 Тогда
					Возврат ДопРеквизит.Значение;
				КонецЕсли;
			КонецЦикла;				
		КонецЕсли;
	КонецЦикла;
КонецФункции
Показать
user1492823; user1302444; +2 Ответить
15. Akuji 22 20.10.17 12:14 Сейчас в теме
(14)
Тут получается в шаблоне в группе автоподстановки будет одна функция:
РуководительИнициирующейСлужбы

а в процесс попаду все пользователи.
Я правильно понимаю?

А как сделать что бы уже в автоподстановках была группа ДопРеквизиты, а в ней доступные доп.реквизиты и далее выбирать нужных пользователей?


Аввтоподстановки:
доп.реквизиты:
-рук1
-рук2
-рук3


а в процесс уже шли значения из этих доп.реквизитов...
16. iolko 320 23.10.17 10:44 Сейчас в теме
(15) А можно пример, что то не совсем могу уловить, что конкретно нужно.
17. Akuji 22 23.10.17 16:54 Сейчас в теме
(16)
Пример был:

Аввтоподстановки:
доп.реквизиты:
-рук1
-рук2
-рук3

я так понимаю что для каждого реквизита добавлять отдельную функцию...
18. iolko 320 24.10.17 05:01 Сейчас в теме
(17)
онимаю что для каждого реквизита добавлять отдельную функцию...


Да, других вариантов я не вижу.
19. AlekSo 15 05.07.19 11:40 Сейчас в теме
А кто-нибудь пробовал делать это в расширении?
22. sinops 03.10.20 12:34 Сейчас в теме
(19) Я пробовал. Все отлично работает.
user1492823; +1 Ответить
21. bpirate999 25 11.02.20 15:11 Сейчас в теме
Нужно после добавления своей автоподстановки из контекстного меню выполнить обновить автоподстановки
Оставьте свое сообщение