Пишем игру Минер. Обработка событий ActiveX в 1С

Публикация № 627941

Разработка - Практика программирования

Поправил

Пример демонстрирует обработку событий генерируемых компонентой ActiveX в 1С.

Открываем  и создаем проект аналогично описаном в предыдущей статье  //infostart.ru/public/625457/.

Для хранения изображений колоды карт будем использовать компонент TImage. Кидаем его на форму и подгружаем изображения. Свойство Visible = false

Открываем Type Library и добавляем 3 метода:

AddCell  - добавляем ячейку

ChangeImage - поменять ячейку

ClearResource - Очищаем ресурсы с формы

Добавляем СОБЫТИЕ

Кодим:

Создаем класс

TCell = class
  Public
    Image : TImage;
    Row: Integer;
    Column: Integer;
    Par : Tw0rmMine;
    NameClass : string;
    Procedure OnRightClickImage(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: Integer);
  Constructor Create(x, y, iRow, iCol : Integer; iName: string);
  End;
procedure Tw0rmMine.MyEvent(Row, Column: Integer; Button, Name: string);
begin
  if FEvents <> nil then FEvents.OnClickCell(Row, Column, Button, Name);
end;

{ TCell }


constructor TCell.Create(x, y, iRow, iCol: Integer; iName: string);
begin
  x := x;
  y := y;
  Row := iRow;
  Column := iCol;
  NameClass := iName

end;


procedure TCell.OnRightClickImage(Sender: TObject; Button: TMouseButton;
  Shift: TShiftState; X, Y: Integer);
var
  Butt : String;

begin

  if Button = controls.mbRight then
    begin
      Butt := 'btRight';
    end;
  if Button = controls.mbLeft then
    begin
      Butt := 'btLeft';
    end;

    Par.MyEvent(Row, Column, Butt, NameClass); //!!!-ГЕНЕРИРУЕМ СОБЫТИЕ ДЛЯ 1С

end;


//Прорисовываем ячейку
procedure Tw0rmMine.AddCell(x, y, Row, Column: Integer;
  const Name: WideString);
var
  Cell : TCell;
const
  h=30; //Высота изображения
begin
  Cell := TCell.Create(x,y,Row,Column, Name);
  cell.Image := TImage.Create(Self);
  cell.Image.Parent:= Self;
  cell.Image.Left:=x;
  cell.Image.Top:=y;
  cell.Image.Width:=h;
  cell.Image.Height:=h;
  cell.Image.Name := Name;
  cell.Image.Canvas.CopyRect(Rect(0, 0, h, h), Image1.Canvas, Rect(column*h ,row*h, (column*h)+h, (row*h)+h));
  cell.Image.OnMouseDown := cell.OnRightClickImage;
  cell.Par := Self;
end;


//Меняем изображение в ячейке
procedure Tw0rmMine.ChangeImage(const Name: WideString; Row,
  Column: Integer);
Var
  img : TImage;
const
  h=30; //Высота изображения
begin
  img:=(FindComponent(Name)) as Timage;
  img.Canvas.CopyRect(Rect(0, 0, h, h), Image1.Canvas, Rect(column*h ,row*h, (column*h)+h, (row*h)+h));
end;

//Очищаем ресурсы 
procedure Tw0rmMine.ClearResource;
var i : integer;
begin
for i:= ComponentCount-1 downto 0 do
 begin
  If Components[i].Name <> 'Image1' then  Components[i].Free;
 end;
end;

Регистрируем компоненту.

Открываем 1С создаем обработку. Накидываем контролы. Видим, что появилось наше событие:

Кодим:

Перем МассивЯчеек;
Перем МассивИменЯчеек;
Перем МассивСостояниеЯчейки;
Перем МассивСостоянияФлагаЯчейки;
Перем ИдМины;

Процедура КнопкаВыполнитьНажатие(Кнопка)
	ЭлементыФормы.ЭлементУправления1.AddCell(0,0,1,2, "s1");
	ЭлементыФормы.ЭлементУправления1.AddCell(0,30,0,0, "s2");
КонецПроцедуры

Процедура ЭлементУправления1OnClickCell(Элемент, Row, Column, Button, Name)
	
	СпецификацияЯчейки = СтрЗаменить(Name, "_", Символы.ПС);
	Строк = Число(СтрПолучитьСтроку (СпецификацияЯчейки, 2)) - 1;
	Колонка = Число(СтрПолучитьСтроку (СпецификацияЯчейки, 3))-1;
	
	Если МассивСостояниеЯчейки[Строк][Колонка] =1 Тогда 
		Возврат;
	КонецЕсли;	
	
	Если Button = "btLeft" Тогда 
		
		ОбработатьГрафическийВыводЛеваяКнопка(Строк, Колонка, Name);
		
		Если МассивЯчеек[Строк][Колонка] = 0 Тогда
			ОбработатьПустуюЯчейку(Строк, Колонка);
			
			Выход = Ложь;
			
			Пока Выход = Ложь Цикл 
				Выход = Истина;
				
				Для а = 0 по КоличествоСтрок-1 Цикл 
					Для б = 0 по КоличествоКолонок-1 Цикл 
						Если МассивСостояниеЯчейки[а][б] = 99 Тогда 
							ОбработатьПустуюЯчейку(а, б);
							МассивСостояниеЯчейки[а][б] = 1;
							Выход = Ложь;
						КонецЕсли;	
						
					КонецЦикла;	
				КонецЦикла;
			КонецЦикла;	
			
		КонецЕсли;
		
		МассивСостояниеЯчейки[Строк][Колонка] = 1;
				
	КонецЕсли;	
	
	
	Если Button = "btRight" Тогда
		
		МассивСостоянияФлагаЯчейки[Строк][Колонка] = МассивСостоянияФлагаЯчейки[Строк][Колонка] + 1;
		Если МассивСостоянияФлагаЯчейки[Строк][Колонка] > 2 Тогда 
			МассивСостоянияФлагаЯчейки[Строк][Колонка] = 0;	
		КонецЕсли;	
		
		ОбработатьГрафическийВыводПраваяКнопка(Строк, Колонка, Name);
	
	КонецЕсли;	
	
	ПроверитьИгру();
	
КонецПроцедуры

Процедура ПриОткрытии()
	КоличествоКолонок = 10;
	КоличествоСтрок   = 10;
	КоличествоМин     = 10;
КонецПроцедуры

Процедура СтартНажатие(Элемент)	
	ЭлементыФормы.КомпонентПоле.ClearResource();
	ИнициализироватьПоле();
	ПрорисоватьПоле();
	ИдБомбы = 999;
	
КонецПроцедуры

Процедура ИнициализироватьПоле()
	
	МассивЯчеек = Новый	Массив(КоличествоСтрок, КоличествоКолонок);
	МассивСостояниеЯчейки = Новый	Массив(КоличествоСтрок, КоличествоКолонок);
	МассивСостоянияФлагаЯчейки = Новый	Массив(КоличествоСтрок, КоличествоКолонок);
	
	//Инициализируем массив
	Для а = 0 по КоличествоСтрок-1 Цикл 
		Для б = 0 по КоличествоКолонок-1 Цикл 
			МассивЯчеек[а][б] = 0;
			МассивСостояниеЯчейки[а][б] = 0;
			МассивСостоянияФлагаЯчейки[а][б] =0;
		КонецЦикла;	
	КонецЦикла;	
	
	//Расставляем мины
	
	Для ии = 1 По КоличествоМин Цикл  
		
		МинаРасставлена = Ложь;
		
		Пока МинаРасставлена = Ложь Цикл 
			Колонка = ПолучитьСлучайноеЧисло(0, КоличествоСтрок-1);
			Ряд = ПолучитьСлучайноеЧисло(0, КоличествоКолонок-1);	

			Если МассивЯчеек[Ряд][Колонка] = 0 Тогда 
				МассивЯчеек[Ряд][Колонка] = ИдМины; //Ид мины в маасиве
				МинаРасставлена = Истина;
			КонецЕсли;	
		КонецЦикла;	
			
	КонецЦикла;	
	
	//Обрабатываем поле
	
	Для а = 0 по КоличествоСтрок-1 Цикл 
		Для б = 0 по КоличествоКолонок-1 Цикл 
			Если МассивЯчеек[а][б] = 0 Тогда 
				МассивЯчеек[а][б] = ПроверитьЯчейку(а,б);
			КонецЕсли;
		КонецЦикла;	
	КонецЦикла;	



КонецПроцедуры	

Процедура ПрорисоватьПоле()
	
	игрек = 0;
	МассивИменЯчеек = Новый	Массив(КоличествоСтрок, КоличествоКолонок);
	
	Для а = 0 по КоличествоСтрок-1 Цикл 
		икс = 0;
		Для б = 0 по КоличествоКолонок-1 Цикл 			
			имя = "Cell_" + СокрЛП(Формат(Число(а+1),"ЧГ=")) + "_" + СокрЛП(Формат(Число(б+1),"ЧГ="));
			МассивИменЯчеек[а][б] = имя;
			ЭлементыФормы.КомпонентПоле.AddCell(икс, игрек, 0, 0, имя);
			икс = икс + 30;
		КонецЦикла;
		игрек = игрек +30;
	КонецЦикла;	
	
КонецПроцедуры	

Функция ПолучитьСлучайноеЧисло(Мин,Макс) 

	//вместо Randomize 
	Для н = 1 По 100 Цикл 
		Уник = Новый УникальныйИдентификатор; 
	КонецЦикла; 

	//генерируем GUID 
	Уник = СокрЛП(Новый УникальныйИдентификатор); 

	//оставляем только цифры 
	Уник = СтрЗаменить(Уник,"-",""); 
	Уник = СтрЗаменить(Уник,"a",""); 
	Уник = СтрЗаменить(Уник,"b",""); 
	Уник = СтрЗаменить(Уник,"c",""); 
	Уник = СтрЗаменить(Уник,"d",""); 
	Уник = СтрЗаменить(Уник,"e",""); 
	Уник = СтрЗаменить(Уник,"f",""); 

//знаменатель должен иметь такое же количество нулей + 1 
	Знаменатель = 10; 
	Для н = 2 По (СтрДлина(СтрЗаменить(Уник,Символы.НПП,""))) Цикл 
		Знаменатель = Знаменатель * 10; 
	КонецЦикла; 

	Случ = Число(Уник) / Знаменатель; //здесь получается дробное случайное число от 0 до 1 

	//преобразуем его в случайное число из заданного интервала, округляем до целого 
	ЧислоИзИнтервала = Мин(Макс(Окр(Мин + (Макс-Мин)*Случ),Мин),Макс); 

	Возврат ЧислоИзИнтервала; 

КонецФункции

Функция ПроверитьЯчейку(Строк, Колонка)
	
	счетчик = 0;
	
	Если Строк-1 >= 0 и Колонка-1 >=0 Тогда 
		Если МассивЯчеек[Строк-1][Колонка-1] = ИдМины Тогда 
			счетчик = счетчик + 1;	
		КонецЕсли;	
	КонецЕсли;	
	
	Если Колонка-1 >=0 Тогда
		Если МассивЯчеек[Строк][Колонка-1] = ИдМины Тогда 
			счетчик = счетчик + 1; 
		КонецЕсли;	
	КонецЕсли;	
	
	Если Строк+1 < КоличествоСтрок и Колонка-1 >=0 Тогда 
		Если МассивЯчеек[Строк+1][Колонка-1] = ИдМины Тогда 
			счетчик = счетчик + 1;	
		КонецЕсли;
	КонецЕсли;	

	Если Строк-1 >=0 Тогда 
		Если МассивЯчеек[Строк-1][Колонка] = ИдМины Тогда 
			счетчик = счетчик + 1;	
		КонецЕсли;
	КонецЕсли;	
	
	Если Строк+1 <КоличествоСтрок Тогда 
		Если МассивЯчеек[Строк+1][Колонка] = ИдМины Тогда 
			счетчик = счетчик + 1;	
		КонецЕсли;
	КонецЕсли;	
	
	
	Если Строк-1 >=0 и Колонка+1 < КоличествоКолонок Тогда 
		Если МассивЯчеек[Строк-1][Колонка+1] = ИдМины Тогда 
			счетчик = счетчик + 1;
		КонецЕсли;		
	КонецЕсли;
	
	Если Колонка+1 < КоличествоКолонок Тогда 
		Если МассивЯчеек[Строк][Колонка+1]= ИдМины Тогда 
			счетчик = счетчик + 1;
		КонецЕсли;	
	КонецЕсли;	
	
	Если Строк+1 < КоличествоСтрок и Колонка+1 < КоличествоКолонок Тогда 
		Если МассивЯчеек[Строк+1][Колонка+1] = ИдМины Тогда 
			счетчик = счетчик + 1;
		КонецЕсли;	
	КонецЕсли;
	
	Возврат(счетчик);
КонецФункции	

Процедура ОбработатьПустуюЯчейку(Строк, Колонка)
	
		МассивСостояниеЯчейки[Строк][Колонка] = 1;
	
		Если Строк-1 >= 0 и Колонка-1 >=0 Тогда  
			ОбработатьГрафическийВыводЛеваяКнопка(Строк-1, Колонка-1, МассивИменЯчеек[Строк-1][Колонка-1]);
			Если МассивЯчеек[Строк-1][Колонка-1] = 0 и МассивСостояниеЯчейки[Строк-1][Колонка-1] <> 1 Тогда
				МассивСостояниеЯчейки[Строк-1][Колонка-1] = 99;
			Иначе
				МассивСостояниеЯчейки[Строк-1][Колонка-1] = 1;	
			КонецЕсли;	
		КонецЕсли;	

		
		Если Колонка-1 >=0 Тогда 
			ОбработатьГрафическийВыводЛеваяКнопка(Строк, Колонка-1, МассивИменЯчеек[Строк][Колонка-1]);
			Если МассивЯчеек[Строк][Колонка-1] = 0 и МассивСостояниеЯчейки[Строк][Колонка-1] <> 1 Тогда	
				МассивСостояниеЯчейки[Строк][Колонка-1] = 99;
			Иначе
				МассивСостояниеЯчейки[Строк][Колонка-1] = 1;	
			КонецЕсли;	
		КонецЕсли;	
		
		Если Строк+1 < КоличествоСтрок и Колонка-1 >=0 Тогда 
			ОбработатьГрафическийВыводЛеваяКнопка(Строк+1, Колонка-1, МассивИменЯчеек[Строк+1][Колонка-1]);	
			Если МассивЯчеек[Строк+1][Колонка-1] = 0 и МассивСостояниеЯчейки[Строк+1][Колонка-1] <> 1 Тогда
				МассивСостояниеЯчейки[Строк+1][Колонка-1] = 99;
			Иначе
				МассивСостояниеЯчейки[Строк+1][Колонка-1] = 1;	
			КонецЕсли;
		КонецЕсли;	

		Если Строк-1 >=0 Тогда 
			ОбработатьГрафическийВыводЛеваяКнопка(Строк-1, Колонка, МассивИменЯчеек[Строк-1][Колонка]);	
			Если МассивЯчеек[Строк-1][Колонка] = 0 и МассивСостояниеЯчейки[Строк-1][Колонка] <> 1 Тогда 
				МассивСостояниеЯчейки[Строк-1][Колонка] = 99;
			Иначе
				МассивСостояниеЯчейки[Строк-1][Колонка] = 1;	
			КонецЕсли;
		КонецЕсли;	
		
		Если Строк+1 <КоличествоСтрок Тогда  
			ОбработатьГрафическийВыводЛеваяКнопка(Строк+1, Колонка, МассивИменЯчеек[Строк+1][Колонка]);	
			Если МассивЯчеек[Строк+1][Колонка] = 0 и МассивСостояниеЯчейки[Строк+1][Колонка] <> 1 Тогда	
				МассивСостояниеЯчейки[Строк+1][Колонка] = 99;
			Иначе
				МассивСостояниеЯчейки[Строк+1][Колонка] = 1;	
			КонецЕсли;
		КонецЕсли;	
		
		
		Если Строк-1 >=0 и Колонка+1 < КоличествоКолонок Тогда  
			ОбработатьГрафическийВыводЛеваяКнопка(Строк-1, Колонка+1, МассивИменЯчеек[Строк-1][Колонка+1]);	
			Если МассивЯчеек[Строк-1][Колонка+1] = 0 и МассивСостояниеЯчейки[Строк-1][Колонка+1] <> 1 Тогда	
				МассивСостояниеЯчейки[Строк-1][Колонка+1] = 99;
			Иначе
				МассивСостояниеЯчейки[Строк-1][Колонка+1] = 1;	
			КонецЕсли;		
		КонецЕсли;
		
		Если Колонка+1 < КоличествоКолонок Тогда  
			ОбработатьГрафическийВыводЛеваяКнопка(Строк, Колонка+1, МассивИменЯчеек[Строк][Колонка+1]);
			Если МассивЯчеек[Строк][Колонка+1]= 0 и МассивСостояниеЯчейки[Строк][Колонка+1] <> 1 Тогда	
				МассивСостояниеЯчейки[Строк][Колонка+1] = 99;
			Иначе 	
				МассивСостояниеЯчейки[Строк][Колонка+1] = 1;
			КонецЕсли;	
		КонецЕсли;	
		
		Если Строк+1 < КоличествоСтрок и Колонка+1 < КоличествоКолонок Тогда  
			ОбработатьГрафическийВыводЛеваяКнопка(Строк+1, Колонка+1, МассивИменЯчеек[Строк+1][Колонка+1]);	
			Если МассивЯчеек[Строк+1][Колонка+1] = 0 и МассивСостояниеЯчейки[Строк+1][Колонка+1] <> 1 Тогда	
				МассивСостояниеЯчейки[Строк+1][Колонка+1] = 99;
			Иначе
				МассивСостояниеЯчейки[Строк+1][Колонка+1] = 1;	
			КонецЕсли;	
		КонецЕсли;	

КонецПроцедуры

Процедура ОбработатьГрафическийВыводЛеваяКнопка(Строк, Колонка, Name)
	
		Если МассивЯчеек[Строк][Колонка] = ИдМины Тогда 
			ЭлементыФормы.КомпонентПоле.ChangeImage(Name, 4, 0);
			Предупреждение("Вы проиграли!");
		КонецЕсли;	
		
		Если МассивЯчеек[Строк][Колонка] = 0 Тогда
			ЭлементыФормы.КомпонентПоле.ChangeImage(Name, 4, 1);
		КонецЕсли;  		
		
		Если МассивЯчеек[Строк][Колонка] = 1 Тогда
			ЭлементыФормы.КомпонентПоле.ChangeImage(Name, 1, 0);
		КонецЕсли;
		
		Если МассивЯчеек[Строк][Колонка] = 2 Тогда
			ЭлементыФормы.КомпонентПоле.ChangeImage(Name, 1, 1);
		КонецЕсли;
		
		Если МассивЯчеек[Строк][Колонка] = 3 Тогда
			ЭлементыФормы.КомпонентПоле.ChangeImage(Name, 1, 2);
		КонецЕсли;
		
		Если МассивЯчеек[Строк][Колонка] = 4 Тогда
			ЭлементыФормы.КомпонентПоле.ChangeImage(Name, 2, 0);
		КонецЕсли;
		
		Если МассивЯчеек[Строк][Колонка] = 5 Тогда
			ЭлементыФормы.КомпонентПоле.ChangeImage(Name, 2, 1);
		КонецЕсли;
		
		Если МассивЯчеек[Строк][Колонка] = 6 Тогда
			ЭлементыФормы.КомпонентПоле.ChangeImage(Name, 2, 2);
		КонецЕсли;
		
		Если МассивЯчеек[Строк][Колонка] = 7 Тогда
			ЭлементыФормы.КомпонентПоле.ChangeImage(Name, 3, 0);
		КонецЕсли;
		
		Если МассивЯчеек[Строк][Колонка] = 8 Тогда
			ЭлементыФормы.КомпонентПоле.ChangeImage(Name, 3, 1);
		КонецЕсли;
		
		МассивСостоянияФлагаЯчейки[Строк][Колонка] =0;
	
КонецПроцедуры	

Процедура ОбработатьГрафическийВыводПраваяКнопка(Строк, Колонка, Name)
	
		Если МассивСостоянияФлагаЯчейки[Строк][Колонка] = 0 Тогда
			ЭлементыФормы.КомпонентПоле.ChangeImage(Name, 0, 0);
		КонецЕсли;  		
		
		Если МассивСостоянияФлагаЯчейки[Строк][Колонка] = 1 Тогда
			ЭлементыФормы.КомпонентПоле.ChangeImage(Name, 0, 1);
		КонецЕсли;
		
		Если МассивСостоянияФлагаЯчейки[Строк][Колонка] = 2 Тогда
			ЭлементыФормы.КомпонентПоле.ChangeImage(Name, 0, 2);
		КонецЕсли;
	
КонецПроцедуры	
	
Процедура ПроверитьИгру()
	
	сч = 0;
		
	Для а = 0 по КоличествоСтрок-1 Цикл 
		Для б = 0 по КоличествоКолонок-1 Цикл 
			Если МассивЯчеек[а][б] = ИдМины и МассивСостоянияФлагаЯчейки[а][б] =1 Тогда 
				
				сч = сч + 1;
			
			КонецЕсли;
		КонецЦикла;	
	КонецЦикла;	
	
	Если сч = КоличествоМин Тогда 
		Предупреждение("Вы победили");
	КонецЕсли;	
		
КонецПроцедуры		
		
		

 

 

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. user621724_Dimav1979 300 29.05.17 10:55 Сейчас в теме
Исходники
Прикрепленные файлы:
miner.zip
andrey7617; sasha777666; monsterZE; gzharkoj; netesoff; smirnov.es; +6 Ответить
2. rpgshnik 2331 29.05.17 11:09 Сейчас в теме
Картинки графики красивые, сам делал?
Прикрепленные файлы:
smirnov.es; +1 Ответить
3. user621724_Dimav1979 300 29.05.17 11:37 Сейчас в теме
(2) Картинки друг мой сделал - ДИМКА КОТ
корум; rpgshnik; +2 Ответить
4. Brawler 471 29.05.17 18:52 Сейчас в теме
ActiveX загибается загибается, да никак не загнется, как и мерзопакостный Delphi)))
5. user621724_Dimav1979 300 30.05.17 02:40 Сейчас в теме
(4) слова недалёкого человека...учите матчасть и не пишите больше чепухи
smirnov.es; Deslime; CyberCerber; rpgshnik; gzharkoj; +5 Ответить
8. Brawler 471 30.05.17 07:06 Сейчас в теме
(5) Давайте без оскорблений! Технология ActiveX в моём понимании ещё жива только из-за большой тяги Microsoft к обратной совместимости. Да в некоторых случаях удобно её использовать, но вот в проведенном вами решении есть проблема. Без танцев с бубном не заставить работать под тем же линуксом. А по поводу Delphi, свой путь в профессию начинал с него когда-то, но потом быстро переметнулся на С# и не жалею. Сдаётся мне у вас предвзятое отношение к пользователям сего ресурса. Ошибочное я бы сказал, тут многие освоили не только программирование на 1С.
sasha777666; rpgshnik; +2 1 Ответить
9. user621724_Dimav1979 300 30.05.17 08:46 Сейчас в теме
(8) Учитесь выбирать, конкретный инструментарий под конкретную задачу! Неважно дельфи это 7 версии или XE последней версии...да это тяжело, но приходит с опытом. Если человек не в состоянии применить навыки - это не значит, что невозможно это сделать.
11. Brawler 471 30.05.17 10:47 Сейчас в теме
(9) Учитесь не учить людей уму разуму
sasha777666; rpgshnik; +2 1 Ответить
6. &rew 23 30.05.17 05:33 Сейчас в теме
Я, конечно, дико извиняюсь, но мне кажется что все-таки Сапёр!
rpgshnik; +1 Ответить
7. rpgshnik 2331 30.05.17 06:47 Сейчас в теме
(6) Я вас дико поддерживаю!
10. ipoloskov 122 30.05.17 09:05 Сейчас в теме
Мне кажется, УникальныйИдентификатор - это не вполне случайное число, распределение будет совсем не равномерное.
Генератор случайных чисел
DrAku1a; Brawler; VitaliyCeban; +3 Ответить
12. Brawler 471 06.10.19 22:58 Сейчас в теме
Случайно снова наткнулся на эту статью и вспомнил, что месяц назад рылся в своих поделках древних на C# и находил клон Сапера))
Картинку прикладываю так чисто по трещать))
Прикрепленные файлы:
Оставьте свое сообщение

См. также

Использование программных перечислений, ч.1: строковые константы Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Часто ли у вас возникает необходимость в коде выполнять сравнение на строку?

10.12.2016    37235    unichkin    74    

Программная работа с настройками СКД

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Нюансы программной работы с настройками системы компоновки данных в отчетах и динамических списках. Обзор всех видов настроек компоновки. Что в каких случаях правильно применять. В качестве примера рассмотрена работа с отборами и группировками.

27.01.2020    25554    ids79    26    

[СКД] Программное создание схемы компоновки данных

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Сделаем отчет на СКД полностью программно, без использования макета "схема компоновки данных".

15.01.2020    23033    John_d    22    

Последовательности событий. Шпаргалка

Практика программирования v8 Россия Бесплатно (free)

Собрал информацию о событиях/подписках/расширениях в одном месте.

30.12.2019    17591    kuzyara    33    

Вспомогательные инструкции в коде 1С Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Помогаем редактору кода 1С помогать нам писать и анализировать код.

15.10.2018    30094    tormozit    100    

30 задач. Странных и не очень

Практика программирования v8 Бесплатно (free)

30 задач на знание языка программирования 1С и некоторого поведения платформы. Маленьких. Странных и не очень.

02.12.2019    16875    YPermitin    72    

Как передать IP адрес, который вызвал HTTP запрос в 1C (для веб-сервера Apache)

Практика программирования v8 Бесплатно (free)

Столкнулся с задачей получения IP адреса, который вызывает http сервис 1С. Итак, решение:

22.11.2019    8271    Sibars    19    

Таблица значений. Нюансы

Практика программирования v8 Бесплатно (free)

Обзор некоторых аспектов использования общеизвестного инструмента 1С.

01.10.2019    32520    Yashazz    50    

Оформление и рефакторинг сложных логических выражений Промо

Практика программирования v8 Россия Бесплатно (free)

В сложных логических выражениях нередко самому автору спустя какое-то время тяжело разобраться, не говоря уже о других программистах. Предлагаемая методика позволяет повысить наглядность таких выражений путем оформления в виде И-ИЛИ дерева и одновременно выполнять их рефакторинг.

20.09.2012    77848    tormozit    131    

[Шпаргалка] Программное создание элементов формы

Практика программирования Работа с интерфейсом v8 1cv8.cf Бесплатно (free)

Программное создание практически всех популярных элементов формы.

06.09.2019    48509    rpgshnik    63    

Агрегатные функции СКД, о которых мало кто знает

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Пользуетесь ли Вы всеми возможными агрегатными функциями, которые предоставляет система компоновки данных? Если Вы используете только: СУММА, КОЛИЧЕСТВО, МИНИМУМ, МАКСИМУМ, СРЕДНЕЕ, то эта статья для Вас.

05.09.2019    48447    ids79    54    

Регистры бухгалтерии. Общая информация

Практика программирования Математика и алгоритмы v8 v8::БУ БУ Бесплатно (free)

Общая информация о внутреннем устройстве регистров бухгалтерии.

05.09.2019    27920    YPermitin    24    

Запись значения в поле ввода/формы со срабатыванием события ПриИзменении Промо

Практика программирования v8 1cv8.cf Россия Бесплатно (free)

Иногда возникает необходимость после записи значения в какое либо поле ввода/формы вызвать для него обработчик события ПриИзменении, а о вызове самого события приходится только мечтать. В этой статье приводится программный способ вызова этого события.

11.07.2007    48196    tormozit    41    

Три костыля. Сказ про фокусы в коде

Практика программирования v8 Бесплатно (free)

Три интересных (или странных) костыля в коде, которые могут помочь в повседневных и не очень задачах.

03.09.2019    25336    YPermitin    80    

Иерархия без "В ИЕРАРХИИ"

Математика и алгоритмы v8 Бесплатно (free)

Говорится о том, как эффективно представлять иерархию в СУБД, как получать и использовать эти представления при решении задач в запросной технике. Уточняются и дополняются запросы из статьи "Уровни, глубина, прародители, циклы и аналоги запросом" [https://infostart.ru/public/160707/].

22.08.2019    12302    ildarovich    19    

Отслеживание выполнения фонового задания

Практика программирования Универсальные функции Разработка v8 1cv8.cf Бесплатно (free)

Запуск фонового задания из модуля внешней обработки. Отслеживание выполнения задания в виде прогресса, расположенного на форме.

17.08.2019    31165    ids79    16    

Как сделать из &НаКлиентеНаСервереБезКонтекста почти &НаКлиентеНаСервере Промо

Практика программирования v8 1cv8.cf Россия Бесплатно (free)

Как сделать метод формы, доступный на клиенте и на сервере одновременно, и сохранить при этом удобство разработки

10.09.2017    44635    tormozit    74    

Функции СКД: ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Подробное описание и использование внутренних функций системы компоновки данных: Вычислить, ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив, ВычислитьВыражениеСГруппировкойТаблицаЗначений.

08.08.2019    79742    ids79    49    

Фоновое выполнение кода в 1С - это просто

Практика программирования v8 1cv8.cf Бесплатно (free)

Как легко запускать выполнение в фоне, не прибегая к долгому описанию фоновых процедур.

02.08.2019    34453    avalakh    22    

СКД - наборы данных и связи между ними, создание собственной иерархии, вложенные отчеты

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Набор данных объект. Использование в схеме компоновки нескольких наборов данных. Различные варианты связи наборов: объединение, соединение. Использование иерархии в отчетах на СКД. Создание собственной иерархии, иерархия детальных записей. Использование вложенных схем в отчетах на СКД.

26.07.2019    58262    ids79    11    

Выгрузка документа по условию Промо

Практика программирования Разработка v8 Бесплатно (free)

Что делать, если документы нужно выгружать не все подряд, а по какому-то фильтру: статусу, дате, набору условий... А что если он соответствовал этим условиям, а потом перестал? А если потом опять начал? Такие ситуации заставили попотеть не одного программиста.

25.04.2019    16012    m-rv    2    

Обработчики событий при записи объектов. Зачем и что за чем?

Математика и алгоритмы v8 Бесплатно (free)

Программисту, имеющему немного опыта на платформе 1С 8.3, бывает сложно разобраться: ПередЗаписью, ПриЗаписи, ПослеЗаписи, на сервере, на клиенте, в модуле формы, в модуле объекта.... Эта шпаргалка была создана в процессе обучения и реального опыта с целью разложить всё по полочкам, чтобы было четкое понимание в каком случае какой обработчик нужно использовать и в какой последовательности они запускаются при записи и проведении документов. Данная статья будет полезна в большей степени начинающим разработчикам. Но и опытным позволит освежить информацию, упорядочить её.

25.07.2019    48984    AlbinaAAA    28    

Управление качеством кода

Математика и алгоритмы Рефакторинг и качество кода v8 Бесплатно (free)

О SonarQube, АПК, EDT. Какие преимущества дает их использование. Для каких команд подходит.

22.07.2019    16343    Stepa86    33    

СКД - использование расширений языка запросов, секция ХАРАКТЕРИСТИКИ

Инструментарий разработчика Практика программирования v8 v8::СКД Бесплатно (free)

Автоматическое и не автоматическое заполнение полей компоновки данных. Использование расширений языка запросов для СКД «{…}», секция ВЫБРАТЬ, секция ГДЕ, параметры виртуальных таблиц. Автоматизированное использование дополнительных данных в запросе: секция ХАРАКТЕРИСТИКИ.

17.07.2019    35426    ids79    27    

Как прикрутить ГУИД к регистру сведений Промо

Практика программирования Перенос данных из 1C8 в 1C8 Разработка v8 Бесплатно (free)

... и немного теории обмена данными. В частности, разберем боль всех, кто пишет небанальные обмены данными: как набору записей регистра сведений назначить гуид и далее использовать его в обмене для идентификации этого набора.

16.04.2019    20140    m-rv    17    

Регистры сведений. За кулисами

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Небольшие заметки по внутреннему устройству регистров сведений.

09.07.2019    25863    YPermitin    14    

"Меньше копипаста!", или как Вася универсальную процедуру писал

Практика программирования Разработка v8 v8::СКД 1cv8.cf Бесплатно (free)

Программист Вася разбирает подход создания универсальных методов на примере программного вывода СКД.

04.07.2019    19553    SeiOkami    50    

Создание отчетов с помощью СКД - основные понятия и элементы

Практика программирования Математика и алгоритмы v8 v8::СКД Бесплатно (free)

Основные принципы работы СКД. Понятия схемы компоновки и макета компоновки. Описание основных элементов схемы компоновки: наборы данных, поля, вычисляемые поля, ресурсы, параметры.

25.06.2019    51745    ids79    25    

Как сделать запрос на изменение данных Промо

Практика программирования v8 v8::Запросы 1cv8.cf Бесплатно (free)

В статье приведены особенности внутренней архитектуры и примеры работы с расширением языка запросов 1С.

01.06.2018    30479    m-rv    21    

Многопоточное ускорение однопользовательских нагрузок в 1С + Microsoft SQL Server 2017

Практика программирования Производительность и оптимизация (HighLoad) v8 v8::Запросы Бесплатно (free)

Взаимодействие с Microsoft SQL Server нередко вызывает трудности у 1С-ников, а потому интересны любые моменты, связанные с его использованием. О своем опыте работы с новым SQL Server 2017 участникам конференции Infostart-2018 рассказал директор ООО «Аналитика софт» Дмитрий Дудин.

11.06.2019    24837    dmurk    145    

Регистры накопления. Структура хранения в базе данных

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Структура хранения регистров накопления в базе данных для платформы 1С:Предприятие 8.x. Первая часть в серии публикаций.

16.05.2019    42464    YPermitin    30    

О расширениях замолвите слово...

Практика программирования Разработка v8 Бесплатно (free)

О чём стоит задуматься при принятии решения о создании расширения конфигурации…

07.04.2019    35147    ellavs    126    

Метод формирования движений в типовых регистрах нетиповыми регистраторами Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Вариант решения задач с проведением по типовым регистрам нетиповыми регистраторами. Зачем - чтобы при сравнении конфигурации не обращать внимание на свойства регистров и исключить вероятность допущения горькой оплошности при обновлении информационных баз, заменив типы регистраторов основной конфигурации типами конфигурации поставщика. Для программных продуктов, имеющих в своем составе метаданных документ "Корректировка регистров"("Корректировка записей регистров").

05.12.2017    28203    itriot11    34    

Git-репозитории для 1С-кода (опыт использования при небольших проектах)

Практика программирования v8 Бесплатно (free)

Инструкции по взаимодействию с Git-репозиторием, которые писались для тех наших программистов, которые вообще никогда не работали с Git (руководства в духе "Как получить код из git-репозитория?", "Как отправить код в git-репозиторий")...

28.03.2019    27296    ellavs    89    

Трюки с внешними источниками данных

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Некоторые трюки для преодоления ограничений внешних источников данных.

14.03.2019    31155    YPermitin    53    

Разработка и сценарное тестирование с Vanessa-ADD. Отчетность Allure. Автоматизация запуска сценариев

Практика программирования Vanessa Automation v8 Россия Бесплатно (free)

Формируем отчетность о результатах выполнения сценариев. Автоматизируем запуск.

26.02.2019    21781    Vladimir Litvinenko    27    

Использование классов .Net в 1С для новичков Промо

Практика программирования Разработка внешних компонент Универсальные функции v7.7 v8 Бесплатно (free)

Руководство для новичков. Написав статью http://infostart.ru/public/238584/, я понял, что многие не понимают того, что написано. Поэтому в этой статье постараюсь более подробно остановиться на азах и без кода на вражеском языке (C#)

27.01.2016    76203    Serginio    108    

Возможности типовых шаблонов ограничения доступа на уровне записей (RLS)

Практика программирования БСП (Библиотека стандартных подсистем) Роли и права v8 v8::Права Бесплатно (free)

Краткий обзор применения типовых шаблонов ограничения доступа на уровне записей в конфигурациях, созданных на базе БСП: #ПоЗначениям, #ПоНаборамЗначений, #ПоЗначениямРасширенный, #ПоЗначениямИНаборамРасширенный

03.02.2019    38913    ids79    9    

EnterpriseData – часть 2. Процесс выгрузки данных

Практика программирования Обмен через XML v8 v8::УФ Россия Бесплатно (free)

Основные этапы выгрузки данных через ED, обработчики событий выгрузки, правила обработки данных, правила конвертации объектов, конвертация свойств первого и второго этапов, процедуры БСП, используемые при выгрузке данных, структура «КомпонентыОбмена».

26.12.2018    26610    ids79    31    

Автоматические и управляемые блокировки применительно к типовым конфигурациям 1С Промо

Математика и алгоритмы Практика программирования v8 v8::blocking 1cv8.cf Бесплатно (free)

Основные принципы работы с режимами автоматических и управляемых блокировок в 1С Предприятие 8. Теория и применение в типовых конфигурациях: БП, УТ, ЕРП

10.11.2018    34528    ids79    40    

Новый подход к обмену данными EnterpriseData

Практика программирования Обмен через XML v8 v8::УФ Россия Бесплатно (free)

Хочу предложить Вашему вниманию цикл статей, посвященных обмену данными через универсальный формат (EnterpriseData или ED).

14.12.2018    41084    ids79    72    

EnterpriseData - пример доработки правил конвертации без использования КД 3.0 в расширении конфигурации

Практика программирования Обмен через XML v8 v8::УФ БП3.0 УТ11 Россия Бесплатно (free)

В статье подробно описан реальный пример доработки обмена данными через EnterpriseData (универсальный формат обмена) между конфигурациями УТ 11.4 и Бухгалтерия 3.0

16.11.2018    36755    ids79    42    

Программное заполнение пользовательских параметров и отборов СКД

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Публикация представляет из себя краткие примеры того, как можно заполнять параметры СКД программно так, чтобы все параметры и отборы были доступны в быстрых настройках и в обычных (типовых) настройках параметров и отборов СКД.

13.11.2018    46883    Unk92    25    

Тестер: частые вопросы Промо

Практика программирования v8 Бесплатно (free)

Ошибкам бой - тесты норма жизни!

25.07.2018    29173    grumagargler    28    

Произвольный код в фоновом режиме

Практика программирования v8 1cv8.cf Бесплатно (free)

Задача: реализовать выполнение произвольного кода в фоновом режиме без изменения конфигурации, т.е. во внешней обработке.

03.09.2018    27806    zarankony    42    

Основные понятия и механизмы оптимизации клиент-серверного взаимодействия в 1C

Математика и алгоритмы Практика программирования v8 Россия Бесплатно (free)

У многих начинающих 1С программистов часто возникают вопросы про клиент-серверное взаимодействие в 1С и чтобы разобраться в непростых механизмах платформы, необходимо понять, что же такое контекст, для чего предназначены директивы компиляции, что представляют собой контекстные/внеконтекстные вызовы и как наиболее оптимально описывать прикладные задачи в модулях управляемых форм.

23.08.2018    38278    Rain88    46    

Ускоряем 1С: модули с повторным использованием возвращаемых значений Промо

Практика программирования v8 Бесплатно (free)

По роду своей деятельности, мне часто приходится обсуждать с программистами детали реализации той или иной функциональности. Очень часто, разговаривая даже с квалифицированными специалистами я сталкиваюсь с незнанием сути платформенной функциональности Повторного использования возвращаемых значений общих модулей. В данной статье я постараюсь дать краткий обзор и основные особенности этой функциональности.

04.09.2017    52490    m-rv    61