Замена штатной функции "Создать на основании"

Публикация № 636444

Разработка - Практика программирования

основание основании создать на основании

Модернизация операции "Создать на основании" в документе

Всем доброго времени суток!

Хочу поделиться некоторыми соображениями по замене штатной функции "Создать на основании". Возникло несколько нюансов при использовании данной опции:

1. Необходимо чтобы в форме документа отражался созданный на его основании документ;

2. Если документ на основании уже создан, чтобы открывался текущий, а не создавался новый.

Вкратце опишу задачу.

На данный момент занимаюсь разработкой системы "Водосбыт". Есть карточка лицевого счета, в которой отражаются все данные об абоненте и объекте водоснабжения. На основании данных из этой карточки заключаются договора на водоснабжение (на первом скриншоте указано стрелкой). Необходимо после создания договора его отображение в карточке. Жмем создать договор (скрин №2). Далее проводим новый договор (скрин №3). После чего, данный договор отобразится в карточке (скрин №4). И теперь после нажатия кнопки "Создать открыть договор" вместо создания нового, откроется текущий.

Теперь перейдем к технической части.

Во-первых, чтобы штатные кнопки не отображались, уберем галочки в закладке "Командный интерфейс" (скрин №5). После этого, создаем действие для команды "СоздатьОткрытьДВСн" (скрин №6)

Ну и далее сам код модуля формы:

#Область ОткрытиеСозданиеДокументов

&НаКлиенте
Процедура СоздатьОткрытьДВСн(Команда)
	Если Модифицированность Тогда
		Предупреждение("Необходимо сохранить документ!");		
		Возврат;
	КонецЕсли;
	
	Если Объект.ДоговорВодоснабжения.Пустая() Тогда
		ОткрытьФорму("Документ.ДоговорВодоснабжения.ФормаОбъекта", 
				Новый Структура("Основание, РежимВыбора", Объект.Ссылка, Истина), ЭтаФорма);
	Иначе
		ОткрытьЗначение(Объект.ДоговорВодоснабжения);
	КонецЕсли;
КонецПроцедуры

&НаКлиенте
Процедура СоздатьОткрытьДЖБО(Команда)
	Если Модифицированность Тогда
		Предупреждение("Необходимо сохранить документ!");
		Возврат;
	КонецЕсли;
	
	Если Объект.ДоговорНаВывозЖБО.Пустая() Тогда
		ОткрытьФорму("Документ.ДоговорНаВывозЖБО.ФормаОбъекта", 
				Новый Структура("Основание, РежимВыбора", Объект.Ссылка, Истина), ЭтаФорма);
	Иначе
		ОткрытьЗначение(Объект.ДоговорНаВывозЖБО);
	КонецЕсли;
КонецПроцедуры

&НаКлиенте
Процедура ОбработкаВыбора(ВыбранноеЗначение, ИсточникВыбора)
	Если Тип("ДокументСсылка.ДоговорНаВывозЖБО") = ТипЗнч(ВыбранноеЗначение) Тогда
		Объект.ДоговорНаВывозЖБО = ВыбранноеЗначение;
	Иначе
		Объект.ДоговорВодоснабжения = ВыбранноеЗначение;
	КонецЕсли;
	
	СохранитьИзменения(Объект.Ссылка);
	
КонецПроцедуры

&НаСервере
Процедура СохранитьИзменения(Знач Ссылка)
	ТекущийДокумент = Ссылка.ПолучитьОбъект();
	ЗаполнитьЗначенияСвойств(ТекущийДокумент, Объект);
	Если Объект.Проведен Тогда
		ТекущийДокумент.Записать(РежимЗаписиДокумента.Проведение);
	Иначе
		ТекущийДокумент.Записать(РежимЗаписиДокумента.Запись);
	КонецЕсли;
КонецПроцедуры

#КонецОбласти

#Область УдалениеДоговоров

&НаКлиенте
Процедура УдалитьДВСн(Команда)
	
	Если Модифицированность Тогда
		Предупреждение("Необходимо сохранить документ!");
		Возврат;
	КонецЕсли;
		
	ДиалогСВопросом("Удалить договор водоснабжения?", "Удаление данных", РежимДиалогаВопрос.ДаНет);
		
КонецПроцедуры

&НаКлиенте
Процедура ПослеВопросаУдаленияДоговораВСн(Результат, Параметры) Экспорт		
    Если Результат = КодВозвратаДиалога.Да Тогда
        УдалитьДВСнНаСервере(Объект.ДоговорВодоснабжения);
		Объект.ДоговорВодоснабжения = ПолучитьПустуюСсылку("ДоговорВодоснабжения");
		СохранитьИзменения(Объект.Ссылка);
    КонецЕсли;	
КонецПроцедуры

&НаСервереБезКонтекста
Функция ПолучитьПустуюСсылку(НаименованиеДокумента);	
	Возврат Документы[НаименованиеДокумента].ПустаяСсылка();
КонецФункции

&НаСервереБезКонтекста
Процедура УдалитьДВСнНаСервере(Знач Ссылка)			
	УдаляемыйДВСн = Ссылка.ПолучитьОбъект();	
	УдаляемыйДВСн.УстановитьПометкуУдаления(Истина);	
КонецПроцедуры

&НаКлиенте
Процедура УдалитьДЖБО(Команда)
	
	Если Модифицированность Тогда
		Предупреждение("Необходимо сохранить документ!");
		Возврат;
	КонецЕсли;
		
	ДиалогСВопросом("Удалить договор на вывоз ЖБО?", "Удаление данных", РежимДиалогаВопрос.ДаНет);
КонецПроцедуры

&НаКлиенте
Процедура ПослеВопросаУдаленияДоговораЖБО(Результат, Параметры) Экспорт		
    Если Результат = КодВозвратаДиалога.Да Тогда
        УдалитьДЖБОНаСервере(Объект.ДоговорНаВывозЖБО);
		Объект.ДоговорНаВывозЖБО = ПолучитьПустуюСсылку("ДоговорНаВывозЖБО");
		СохранитьИзменения(Объект.Ссылка);
    КонецЕсли;	
КонецПроцедуры

&НаСервереБезКонтекста
Процедура УдалитьДЖБОНаСервере(Знач Ссылка)	
	УдаляемыйДВСн = Ссылка.ПолучитьОбъект();	
	УдаляемыйДВСн.УстановитьПометкуУдаления(Истина);	
КонецПроцедуры

#КонецОбласти

&НаКлиенте
Процедура ДиалогСВопросом(ТекстВопроса, ЗаголовокВопроса, РежимДиалога)
	
	Если ТекстВопроса = "Удалить договор водоснабжения?" Тогда
		Оповещение = Новый ОписаниеОповещения("ПослеВопросаУдаленияДоговораВСн", ЭтотОбъект);
	Иначе
		Оповещение = Новый ОписаниеОповещения("ПослеВопросаУдаленияДоговораЖБО", ЭтотОбъект);
	КонецЕсли;
 
    ПоказатьВопрос(Оповещение,
        ТекстВопроса,
        РежимДиалога,
        0,
        КодВозвратаДиалога.Да,
        ЗаголовокВопроса
		
    );
КонецПроцедуры

&НаКлиенте
Процедура ОбновитьДанные(Команда)
	Элементы.АбонентКонтактныеДанные.Обновить();
КонецПроцедуры

Так - же реализовал вопрос при удалении договора. 

И для того, чтобы ссылка созданного на основании договора передалась в форму карточки лицевого счета, в форме договора необходимо оповестить о выборе. Данную функцию я вставил в процедуру "ПослеЗаписи":

&НаКлиенте
Процедура ПослеЗаписи(ПараметрыЗаписи)
	Если Не Объект.Основание.Пустая() Тогда
		ОповеститьОВыборе(Объект.Ссылка);
	КонецЕсли;
КонецПроцедуры

Надеюсь данный функционал кому либо поможет. Если возникнут какие либо вопросы или предложения, буду рад выслушать...

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. premierex 22.06.17 18:16 Сейчас в теме
2. premierex 22.06.17 18:22 Сейчас в теме
(0) Ничего личного. Просто не не понравилось оформление кода. Не было желания оскорбить, обидеть, задеть за живое и т.д .
3. premierex 22.06.17 18:24 Сейчас в теме
(2) не-не=НЕ! Бывают опечатки :)))
4. cheiser1982 92 23.06.17 03:42 Сейчас в теме
(3) Ну возможно ты и прав, можно было по другому эту процедуру обозвать. Просто в наших терминах такое название более понятно... Ну а на критику я всегда адекватно реагирую, так что все нормально... :))
5. Артано 673 23.06.17 03:54 Сейчас в теме
Если на первом скрине данные реального абонента, то рекомендую закрасить, иначе нарушение 152-ФЗ

Насчет кода, то глаз резанули только лишние отступы внутри структур, передача на сервер ссылочных типов по ссылке, а не по значению и заремаренный старый код. В остальном всё норм.
6. cheiser1982 92 23.06.17 04:39 Сейчас в теме
(5) Насчет абонента - все вымышленное, в том числе и адрес. По поводу ссылочных типов - немного не понял... По ссылке передаю документ, после чего ставлю пометку. Подскажи как по значению передать и выполнить то-же действие...
Насчет отступов - ну у каждого свои нюансы в написании. Мне просто так удобнее. А старый код сейчас уберу. Когда писал - искал команды по подсказке...
7. Артано 673 23.06.17 04:50 Сейчас в теме
(6)
По ссылке передаю документ, после чего ставлю пометку. Подскажи как по значению передать и выполнить то-же действие...


Пометку же не в СправочникСсылка ставите, а в СправочникОбъект, который является отдельным объектом другого типа связанным с со ссылкой лишь общим родителем и ID.
Когда ссылочный тип передается на сервер, происходит его сериализация (поэтому мутабельные типы не передаются), если передавать не по значению, то при завершении работы серверного метода, будет произведена обратная операция для возврата объекта на клиент. Т.е. двойная работа никому не нужная.
8. cheiser1982 92 23.06.17 04:55 Сейчас в теме
(7)
Т.е. двойная работа никому не нужная.

Я это уже понял при отладке, что не все правильно делаю. Можешь привести пример, как грамотно все организовать? Возможно у меня немного опыта не хватает...
9. Артано 673 23.06.17 05:01 Сейчас в теме
(8) Передавай данные на сервер только по значению. Если нужно намеренно "испортить" передаваемый параметр, то передавай по ссылке. По неизвестной мне причине для 1С стандартом по умолчанию является передача по ссылке, что и приводит к таким казусам. Бывает и сам забудешь поставить заветную "Знач", но в целом это дело привычки и такие ошибки случаются редко.
cheiser1982; +1 Ответить
10. cheiser1982 92 23.06.17 05:22 Сейчас в теме
(9) Исправил - так правильно?
11. Артано 673 23.06.17 05:53 Сейчас в теме
(10) Похоже. Но всё же почитай на ИТС про передачу по ссылке и по значению
12. Alexey-Alyosha 24.06.17 11:03 Сейчас в теме
Спасибо, очень помогло... Сэкономил кучу времени, опираясь на Вашу статью...
13. Altair777 640 11.07.17 10:20 Сейчас в теме
(0)
На данный момент занимаюсь разработкой системы "Водосбыт"

А что это за конфигурация такая, совсем с нуля?
14. stepan_s 24.07.20 08:12 Сейчас в теме
Если не секрет что заставляет такие сокращения делать? Как жить людям с этим, которые придут потом? Почему принцип самокоментируемости так не вкатывает?
Оставьте свое сообщение

См. также

Использование программных перечислений, ч.1: строковые константы Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Часто ли у вас возникает необходимость в коде выполнять сравнение на строку?

10.12.2016    37264    unichkin    74    

Программная работа с настройками СКД

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Нюансы программной работы с настройками системы компоновки данных в отчетах и динамических списках. Обзор всех видов настроек компоновки. Что в каких случаях правильно применять. В качестве примера рассмотрена работа с отборами и группировками.

27.01.2020    25726    ids79    26    

[СКД] Программное создание схемы компоновки данных

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Сделаем отчет на СКД полностью программно, без использования макета "схема компоновки данных".

15.01.2020    23145    John_d    22    

СКД. Шаг 3. Используем макеты для оформления отчета

Работа с интерфейсом v8 v8::СКД 1cv8.cf Бесплатно (free)

В данной публикации рассмотрим базовый подход к использованию собственных макетов в СКД на примере формирования небольшого отчета.

13.01.2020    14322    aximo    14    

Вспомогательные инструкции в коде 1С Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Помогаем редактору кода 1С помогать нам писать и анализировать код.

15.10.2018    30130    tormozit    100    

Последовательности событий. Шпаргалка

Практика программирования v8 Россия Бесплатно (free)

Собрал информацию о событиях/подписках/расширениях в одном месте.

30.12.2019    17699    kuzyara    33    

30 задач. Странных и не очень

Практика программирования v8 Бесплатно (free)

30 задач на знание языка программирования 1С и некоторого поведения платформы. Маленьких. Странных и не очень.

02.12.2019    16897    YPermitin    72    

Как передать IP адрес, который вызвал HTTP запрос в 1C (для веб-сервера Apache)

Практика программирования v8 Бесплатно (free)

Столкнулся с задачей получения IP адреса, который вызывает http сервис 1С. Итак, решение:

22.11.2019    8285    Sibars    19    

Оформление и рефакторинг сложных логических выражений Промо

Практика программирования v8 Россия Бесплатно (free)

В сложных логических выражениях нередко самому автору спустя какое-то время тяжело разобраться, не говоря уже о других программистах. Предлагаемая методика позволяет повысить наглядность таких выражений путем оформления в виде И-ИЛИ дерева и одновременно выполнять их рефакторинг.

20.09.2012    77891    tormozit    131    

Создание асинхронных виджетов

Работа с интерфейсом v8 1cv8.cf Бесплатно (free)

Описание нескольких способов создания асинхронных виджетов для 1С:Предприятия. Рассматриваются способы с использованием HTTP-сервисов и фоновых заданий.

16.10.2019    12901    YPermitin    19    

Таблица значений. Нюансы

Практика программирования v8 Бесплатно (free)

Обзор некоторых аспектов использования общеизвестного инструмента 1С.

01.10.2019    32659    Yashazz    50    

[Шпаргалка] Программное создание элементов формы

Практика программирования Работа с интерфейсом v8 1cv8.cf Бесплатно (free)

Программное создание практически всех популярных элементов формы.

06.09.2019    48782    rpgshnik    63    

Запись значения в поле ввода/формы со срабатыванием события ПриИзменении Промо

Практика программирования v8 1cv8.cf Россия Бесплатно (free)

Иногда возникает необходимость после записи значения в какое либо поле ввода/формы вызвать для него обработчик события ПриИзменении, а о вызове самого события приходится только мечтать. В этой статье приводится программный способ вызова этого события.

11.07.2007    48256    tormozit    41    

Агрегатные функции СКД, о которых мало кто знает

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Пользуетесь ли Вы всеми возможными агрегатными функциями, которые предоставляет система компоновки данных? Если Вы используете только: СУММА, КОЛИЧЕСТВО, МИНИМУМ, МАКСИМУМ, СРЕДНЕЕ, то эта статья для Вас.

05.09.2019    48614    ids79    54    

Регистры бухгалтерии. Общая информация

Практика программирования Математика и алгоритмы v8 v8::БУ БУ Бесплатно (free)

Общая информация о внутреннем устройстве регистров бухгалтерии.

05.09.2019    27979    YPermitin    24    

Три костыля. Сказ про фокусы в коде

Практика программирования v8 Бесплатно (free)

Три интересных (или странных) костыля в коде, которые могут помочь в повседневных и не очень задачах.

03.09.2019    25344    YPermitin    80    

Как сделать из &НаКлиентеНаСервереБезКонтекста почти &НаКлиентеНаСервере Промо

Практика программирования v8 1cv8.cf Россия Бесплатно (free)

Как сделать метод формы, доступный на клиенте и на сервере одновременно, и сохранить при этом удобство разработки

10.09.2017    44668    tormozit    74    

Отслеживание выполнения фонового задания

Практика программирования Универсальные функции Разработка v8 1cv8.cf Бесплатно (free)

Запуск фонового задания из модуля внешней обработки. Отслеживание выполнения задания в виде прогресса, расположенного на форме.

17.08.2019    31224    ids79    16    

Функции СКД: ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Подробное описание и использование внутренних функций системы компоновки данных: Вычислить, ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив, ВычислитьВыражениеСГруппировкойТаблицаЗначений.

08.08.2019    80207    ids79    49    

Фоновое выполнение кода в 1С - это просто

Практика программирования v8 1cv8.cf Бесплатно (free)

Как легко запускать выполнение в фоне, не прибегая к долгому описанию фоновых процедур.

02.08.2019    34591    avalakh    22    

Выгрузка документа по условию Промо

Практика программирования Разработка v8 Бесплатно (free)

Что делать, если документы нужно выгружать не все подряд, а по какому-то фильтру: статусу, дате, набору условий... А что если он соответствовал этим условиям, а потом перестал? А если потом опять начал? Такие ситуации заставили попотеть не одного программиста.

25.04.2019    16022    m-rv    2    

Разбираемся с параметрами редактирования СКД

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Связь по типу, Параметры выбора, Связи параметров выбора

31.07.2019    23408    json    13    

СКД - наборы данных и связи между ними, создание собственной иерархии, вложенные отчеты

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Набор данных объект. Использование в схеме компоновки нескольких наборов данных. Различные варианты связи наборов: объединение, соединение. Использование иерархии в отчетах на СКД. Создание собственной иерархии, иерархия детальных записей. Использование вложенных схем в отчетах на СКД.

26.07.2019    58482    ids79    11    

СКД - использование расширений языка запросов, секция ХАРАКТЕРИСТИКИ

Инструментарий разработчика Практика программирования v8 v8::СКД Бесплатно (free)

Автоматическое и не автоматическое заполнение полей компоновки данных. Использование расширений языка запросов для СКД «{…}», секция ВЫБРАТЬ, секция ГДЕ, параметры виртуальных таблиц. Автоматизированное использование дополнительных данных в запросе: секция ХАРАКТЕРИСТИКИ.

17.07.2019    35492    ids79    27    

Как прикрутить ГУИД к регистру сведений Промо

Практика программирования Перенос данных из 1C8 в 1C8 Разработка v8 Бесплатно (free)

... и немного теории обмена данными. В частности, разберем боль всех, кто пишет небанальные обмены данными: как набору записей регистра сведений назначить гуид и далее использовать его в обмене для идентификации этого набора.

16.04.2019    20154    m-rv    17    

Регистры сведений. За кулисами

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Небольшие заметки по внутреннему устройству регистров сведений.

09.07.2019    25894    YPermitin    14    

"Меньше копипаста!", или как Вася универсальную процедуру писал

Практика программирования Разработка v8 v8::СКД 1cv8.cf Бесплатно (free)

Программист Вася разбирает подход создания универсальных методов на примере программного вывода СКД.

04.07.2019    19573    SeiOkami    50    

Создание отчетов с помощью СКД - основные понятия и элементы

Практика программирования Математика и алгоритмы v8 v8::СКД Бесплатно (free)

Основные принципы работы СКД. Понятия схемы компоновки и макета компоновки. Описание основных элементов схемы компоновки: наборы данных, поля, вычисляемые поля, ресурсы, параметры.

25.06.2019    51875    ids79    25    

Как сделать запрос на изменение данных Промо

Практика программирования v8 v8::Запросы 1cv8.cf Бесплатно (free)

В статье приведены особенности внутренней архитектуры и примеры работы с расширением языка запросов 1С.

01.06.2018    30508    m-rv    21    

Многопоточное ускорение однопользовательских нагрузок в 1С + Microsoft SQL Server 2017

Практика программирования Производительность и оптимизация (HighLoad) v8 v8::Запросы Бесплатно (free)

Взаимодействие с Microsoft SQL Server нередко вызывает трудности у 1С-ников, а потому интересны любые моменты, связанные с его использованием. О своем опыте работы с новым SQL Server 2017 участникам конференции Infostart-2018 рассказал директор ООО «Аналитика софт» Дмитрий Дудин.

11.06.2019    24874    dmurk    145    

Подсистема "Варианты отчетов". Используете ли Вы ее правильно?

Работа с интерфейсом БСП (Библиотека стандартных подсистем) v8 1cv8.cf Бесплатно (free)

Небольшая история про использование подсистемы "Варианты отчетов" из БСП. Используете ли Вы ее правильно?

04.06.2019    41044    YPermitin    52    

Регистры накопления. Структура хранения в базе данных

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Структура хранения регистров накопления в базе данных для платформы 1С:Предприятие 8.x. Первая часть в серии публикаций.

16.05.2019    42548    YPermitin    30    

Метод формирования движений в типовых регистрах нетиповыми регистраторами Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Вариант решения задач с проведением по типовым регистрам нетиповыми регистраторами. Зачем - чтобы при сравнении конфигурации не обращать внимание на свойства регистров и исключить вероятность допущения горькой оплошности при обновлении информационных баз, заменив типы регистраторов основной конфигурации типами конфигурации поставщика. Для программных продуктов, имеющих в своем составе метаданных документ "Корректировка регистров"("Корректировка записей регистров").

05.12.2017    28212    itriot11    34    

О расширениях замолвите слово...

Практика программирования Разработка v8 Бесплатно (free)

О чём стоит задуматься при принятии решения о создании расширения конфигурации…

07.04.2019    35186    ellavs    126    

Git-репозитории для 1С-кода (опыт использования при небольших проектах)

Практика программирования v8 Бесплатно (free)

Инструкции по взаимодействию с Git-репозиторием, которые писались для тех наших программистов, которые вообще никогда не работали с Git (руководства в духе "Как получить код из git-репозитория?", "Как отправить код в git-репозиторий")...

28.03.2019    27308    ellavs    89    

Трюки с внешними источниками данных

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Некоторые трюки для преодоления ограничений внешних источников данных.

14.03.2019    31191    YPermitin    53    

Использование классов .Net в 1С для новичков Промо

Практика программирования Разработка внешних компонент Универсальные функции v7.7 v8 Бесплатно (free)

Руководство для новичков. Написав статью http://infostart.ru/public/238584/, я понял, что многие не понимают того, что написано. Поэтому в этой статье постараюсь более подробно остановиться на азах и без кода на вражеском языке (C#)

27.01.2016    76235    Serginio    108    

Разработка и сценарное тестирование с Vanessa-ADD. Отчетность Allure. Автоматизация запуска сценариев

Практика программирования Vanessa Automation v8 Россия Бесплатно (free)

Формируем отчетность о результатах выполнения сценариев. Автоматизируем запуск.

26.02.2019    21801    Vladimir Litvinenko    27    

Возможности типовых шаблонов ограничения доступа на уровне записей (RLS)

Практика программирования БСП (Библиотека стандартных подсистем) Роли и права v8 v8::Права Бесплатно (free)

Краткий обзор применения типовых шаблонов ограничения доступа на уровне записей в конфигурациях, созданных на базе БСП: #ПоЗначениям, #ПоНаборамЗначений, #ПоЗначениямРасширенный, #ПоЗначениямИНаборамРасширенный

03.02.2019    39050    ids79    9    

Автоматические и управляемые блокировки применительно к типовым конфигурациям 1С Промо

Математика и алгоритмы Практика программирования v8 v8::blocking 1cv8.cf Бесплатно (free)

Основные принципы работы с режимами автоматических и управляемых блокировок в 1С Предприятие 8. Теория и применение в типовых конфигурациях: БП, УТ, ЕРП

10.11.2018    34566    ids79    40    

EnterpriseData – часть 2. Процесс выгрузки данных

Практика программирования Обмен через XML v8 v8::УФ Россия Бесплатно (free)

Основные этапы выгрузки данных через ED, обработчики событий выгрузки, правила обработки данных, правила конвертации объектов, конвертация свойств первого и второго этапов, процедуры БСП, используемые при выгрузке данных, структура «КомпонентыОбмена».

26.12.2018    26671    ids79    31    

Новый подход к обмену данными EnterpriseData

Практика программирования Обмен через XML v8 v8::УФ Россия Бесплатно (free)

Хочу предложить Вашему вниманию цикл статей, посвященных обмену данными через универсальный формат (EnterpriseData или ED).

14.12.2018    41162    ids79    72    

EnterpriseData - пример доработки правил конвертации без использования КД 3.0 в расширении конфигурации

Практика программирования Обмен через XML v8 v8::УФ БП3.0 УТ11 Россия Бесплатно (free)

В статье подробно описан реальный пример доработки обмена данными через EnterpriseData (универсальный формат обмена) между конфигурациями УТ 11.4 и Бухгалтерия 3.0

16.11.2018    36818    ids79    42    

Тестер: частые вопросы Промо

Практика программирования v8 Бесплатно (free)

Ошибкам бой - тесты норма жизни!

25.07.2018    29185    grumagargler    28    

Программное заполнение пользовательских параметров и отборов СКД

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Публикация представляет из себя краткие примеры того, как можно заполнять параметры СКД программно так, чтобы все параметры и отборы были доступны в быстрых настройках и в обычных (типовых) настройках параметров и отборов СКД.

13.11.2018    47024    Unk92    25    

Произвольный код в фоновом режиме

Практика программирования v8 1cv8.cf Бесплатно (free)

Задача: реализовать выполнение произвольного кода в фоновом режиме без изменения конфигурации, т.е. во внешней обработке.

03.09.2018    27848    zarankony    42    

Основные понятия и механизмы оптимизации клиент-серверного взаимодействия в 1C

Математика и алгоритмы Практика программирования v8 Россия Бесплатно (free)

У многих начинающих 1С программистов часто возникают вопросы про клиент-серверное взаимодействие в 1С и чтобы разобраться в непростых механизмах платформы, необходимо понять, что же такое контекст, для чего предназначены директивы компиляции, что представляют собой контекстные/внеконтекстные вызовы и как наиболее оптимально описывать прикладные задачи в модулях управляемых форм.

23.08.2018    38332    Rain88    46    

Ускоряем 1С: модули с повторным использованием возвращаемых значений Промо

Практика программирования v8 Бесплатно (free)

По роду своей деятельности, мне часто приходится обсуждать с программистами детали реализации той или иной функциональности. Очень часто, разговаривая даже с квалифицированными специалистами я сталкиваюсь с незнанием сути платформенной функциональности Повторного использования возвращаемых значений общих модулей. В данной статье я постараюсь дать краткий обзор и основные особенности этой функциональности.

04.09.2017    52524    m-rv    61