Знакомство с 1С:Документооборот. История автоматизации и доработок. Печатная форма Лист согласования

Публикация № 637276

Разработка - Практика программирования

Копирование вставка и перенос файлов Документооборот Лист согласования Визы загрузка данных из другой базы по com соединению webinst

Документооборот 2.1.10.2 ПРОФ, КОРП. История автоматизации и доработок. Ввод на основании внутреннего документа из задачи согласование с переносом прикрепленных файлов(копировать и вставить файлы). ПФ Лист согласования для процесса Согласование и для справочника Внутренние документы(печатается с историей). Автоматическая загрузка справочника по com-соединению из другой базы. Печатные формы работают и на последнем релизе 2.1.20.5.

А) введение

Б) публикация на IIS, исправление ошибок, настройка браузера

В) Автоматизация процесса согласования и доработка:

 в1) Этапы согласования

 в2) Скопировать\вставить файлы, “ввод на основании” Внутреннего документа из Задачи с переносом прикрепленных файлов

 в3) Другие доработки

P.S. Изначально я хотел написать только про пункт в2, но статья получилась очень маленькой и пришло в голову такое решение.


1. Начало


Есть на работе база ДО, в которой работают несколько человек и заносят договоры и прикрепляют к ним файлы. Реестр договоров в общем. Появилась задача автоматизировать процесс согласования договоров по всем отделам.

Знакомство с ДО началось с обновления 1.2.4.3 до 2.1.10.2 - Начало!

В итоге обновление пошло по следующей схеме:

1.2.4.3 > 1.2.8.1 (21.02.2013)  > 1.4.8.3 (19.02.2015)  > 1.4.13.1 (09.09.2015)  > 2.1.10.2 (30.03.2017)

После перехода на другую редакцию, визуально конечно кардинально все поменялось в плане интерфейса и функционала, а также приятно менялась заставка запуска:

1.2.4.3

1.4.8.3

2.1.10.2

Далее тестирование и исправление, после чего больше ошибок не было и получилась нормальная рабочая база последнего релиза (видимо повезло). Сделал это для того чтобы приходили различные уведомления из 1с на почту сотрудникам. Ибо в версии 1.2.4.3 по каким-то причинам это не получилось настроить. Не хотело работать и все тут.

Далее нужно было сделать возможность работать в web интерфейсе из любого места.


2. Публикация 1с на web-сервере IIS


2.1 Публикация


Настроить как в публикации //infostart.ru/public/275820/?ID=275820 и похожим способом у меня по каким то причинам не вышло и решение было следующим. Публикуем на веб-сервере IIS с использованием компоненты webinst от 1с.

Справка по webinst:

Для публикации на удаленном компьютере можно также использовать утилиту webinst. Данная утилита должна запускаться из каталога двоичных файлов платформы (для ее запуска требуется наличие динамических библиотек, входящих в состав платформы):

Публикация:

webinst [-publish] websrv -wsdir VirtualDir -dir Dir -connstr connStr [-confPath confPath] [-osauth]

Удаление публикации:

webinst -delete websrv -wsdir VirtualDir [-dir Dir] [-connstr connStr] [-confPath confPath]

-publish – опубликовать (ключ по умолчанию);

-delete – удалить публикацию;

websrv – тип веб-сервера. Может принимать следующие значения:

• iis – публикация веб-клиента для IIS;

• apache2 – публикация веб-клиента для Apache 2.0;

• apache22 – публикация веб-клиента для Apache 2.2;

-wsdir VirtualDir – виртуальный каталог;

-dir Dir – физический каталог, в который будет отображен виртуальный каталог;

-connstr connStr – строка соединения информационной базы;

-confPath confPath – полный путь к конфигурационному файлу Apache (только для публикации на Apache);

-osauth – использование Windows авторизации (только для IIS);

–descriptor <путь к vrd файлу> – указывает новый файл-дескриптор публикации. При публикации существующий vrd файл полностью переписывается указанным. Если в вызове утилиты указаны также ключи –wsdir и/или –connstr, их значения перекрывают значения полей vrd-файла base и ib соответственно. Если указан ключ –delete, ключ –descriptor используется для получения имени публикации (поле base vrd-файла) и проверки строки соединения (проверка, что по этому имени опубликована требуемая база). Должен использоваться именно файл-дескриптор публикации. 

Через командную строку необходимо перейти в каталог с файлом webinst:

cd C:\Program Files (x86)\1cv8\8.3.9.2170\bin

Далее вводим команду:

webinst -publish -iis -wsdir Base1C -dir c:\inetpub\wwwroot\Base1C\ -connstr "Srvr=192.168.2.3;Ref=Base1C;"

Почти все готово. Но кое-что нужно сделать еще.


2.2 Появляются ошибки в web-клиенте «Обнаружено потенциально опасное значение Request.Path, полученное от клиента» и «Runtime Error»


Решение изложено вот тут http://forum.infostart.ru/forum9/topic72212/ , а именно

Алгоритм решения проблемы следующий:

1. Открываем Диспетчер служб IIS.

2. Открываем наш «сайт»

3. Идем в сопоставления обработчиков

4. Ищем ISAPI-dll, выделяем строку.

5. Справа нажимаем «Изменить»

6. Меняем путь запроса с «*.dll» на «*», Исполняемый файл (у Вас может быть другая версия 1С) — «C:\Program Files (x86)\1cv8\8.3.5.1248\bin\wsisapi.dll» :

7. Ок

8. Все работает.


2.3 Настройка браузера


- В браузере нужно отключить блокировку всплывающих окон что бы не возникало ошибок при уведомлениях 1с.

- так же можно установить “Расширение для работы с 1с” для Яндекс браузера и Google Chrome https://chrome.google.com/webstore/detail/extension-for-working-wit/pbhelknnhilelbnhfpcjlcabhmfangik?hl=ru&gl=RU

Вот теперь все заработало как надо.


3. Автоматизация процесса согласования и доработка


Тут я опишу этапы согласования и доработки по ходу рассказа.

В итоге, утвержденный руководством регламент выглядит следующим образом:

                        

В общем поехали.

1 – Инициатор(сотрудник отдела) в программе создает процесс согласования по настроенному шаблону:

Непосредственный руководитель автора процесса и Начальник юридического отдела по очереди. И прикрепляет перечень учредительных документов к процессу.

Это первый этап согласования договора. Инициатор согласовывает заявку на договор с Руководителем отдела. После подтверждения Руководителем, согласование автоматически передается Начальнику юридического отдела для дальнейших действий.

2 – Начальник юр. отдела в моем случае либо одобряет и создает внутренний документ, либо перенаправляет задачу своему подчиненному (ответственный юр. отдела).

Тут встала задача автоматизировать этот этап, потому что много времени уходит на ручной перенос прикрепленных файлов из задачи в договор.

Понадобилось реализовать следующую идею: из задачи согласование нужно создать внутренний документ(договор) и перенести прикрепленные файлы задачи. Что то вроде "ввода на основании" с переносом прикрепленных файлов.

Были добавлены кнопки Создать договор, Скопировать и Вставить файлы в форму ФормаЗадачиИсполнителя (Бизнес-процессы > Согласование). А так же соответствующие им команды.

Далее в модуле формы пишем следующий код для кнопок:

// РАБОТА С ФАЙЛАМИ И СОЗДАНИЕ ДОГОВОРА С ВЛОЖЕНИЯМИ ИЗ ЗАДАЧИ

// ЭТО КНОПКА СОЗДАТЬ ДОГОВОР
&НаКлиенте
Процедура СоздатьДоговор(Команда)	
// Нажмем на кнопку "Согласовано" и напишем комментарий в задаче
Если  Объект.РезультатВыполнения = "" Тогда
    Объект.РезультатВыполнения = "Предварительный договор рассмотрен.";
КонецЕсли;
	ОписаниеОповещения = Новый ОписаниеОповещения(
		"ПродолжениеВыполненияЗадачиСогласованоПослеВыбораФактическогоИсполнителя", ЭтаФорма);	
	РаботаСБизнесПроцессамиКлиент.ВыбратьИсполнителяЗадачи(
		ЭтаФорма,
		Объект.Исполнитель,
		ТекущийПользователь,
		ФактическийИсполнительЗадачи,
		ОписаниеОповещения);		
//-------------------------------------------	
	НовыйВнутреннийДокумент = ПереносФайловНаСервере();
	ПараметрыФормы = Новый Структура("Ключ", НовыйВнутреннийДокумент);
	ФормаНовогоВнутреннегоДокумента = ОткрытьФорму("Справочник.ВнутренниеДокументы.ФормаОбъекта",ПараметрыФормы);
	ФормаНовогоВнутреннегоДокумента.Открыть();
	ЭтаФорма.ОбновитьОтображениеДанных();	
КонецПроцедуры

&НаСервере
Функция СоздатьДоговорНаСервере()

// Создаем новый договор
	НовыйВнутреннийДокумент = Справочники.ВнутренниеДокументы.СоздатьЭлемент();
	НовыйВнутреннийДокумент.Заголовок     = "Договор: " + ЭтаФорма.Объект.Наименование;
	НовыйВнутреннийДокумент.Наименование  = НовыйВнутреннийДокумент.Заголовок;
	НовыйВнутреннийДокумент.Ответственный = ЭтаФорма.Объект.Автор;
	НовыйВнутреннийДокумент.Подготовил = ТекущийПользователь;
	Если Справочники.ПапкиВнутреннихДокументов.НайтиПоНаименованию("Договоры") <> Неопределено И
	     Справочники.ВидыВнутреннихДокументов.НайтиПоНаименованию("Договор") <> Неопределено Тогда
	  НовыйВнутреннийДокумент.Папка = Справочники.ПапкиВнутреннихДокументов.НайтиПоНаименованию("Договоры");
	  НовыйВнутреннийДокумент.ВидДокумента = Справочники.ВидыВнутреннихДокументов.НайтиПоНаименованию("Договор");
    КонецЕсли;
    НовыйВнутреннийДокумент.Состояние = Перечисления.СостоянияДокументов.НаСогласовании;
	НовыйВнутреннийДокумент.ДатаРегистрации = ТекущаяДата();
	НовыйВнутреннийДокумент.Записать();	
	Для Каждого ИдентификаторСтроки Из Элементы.ДеревоПриложений.ВыделенныеСтроки Цикл
		КопируемаяСтрока = ДеревоПриложений.НайтиПоИдентификатору(ИдентификаторСтроки);
		СсылкаНаФайл = КопируемаяСтрока.Ссылка.ПолучитьОбъект();
		СсылкаНаФайл.ВладелецФайла = НовыйВнутреннийДокумент.Ссылка;
		СсылкаНаФайл.Записать();
	КонецЦикла;	
	Возврат НовыйВнутреннийДокумент.Ссылка;
КонецФункции // ПереносФайловНаСервере()

// ЭТО КНОПКА СКОПИРОВАТЬ ФАЙЛЫ
&НаКлиенте
Процедура СкопироватьСтроки(Команда)
	
	ЧислоФайлов = 0;
	СкопироватьСтрокиНаСервере(ЧислоФайлов);
	
	Если ЧислоФайлов <> 0 Тогда
		
		ПолноеОписание = СтрШаблон(
			НСтр("ru = 'Файлы (%1 шт) скопированы в буфер обмена.'"), ЧислоФайлов);
		
		ПоказатьОповещениеПользователя(
			НСтр("ru = 'Копирование в буфер'"),
			,
			ПолноеОписание,
			БиблиотекаКартинок.Информация32);			
	КонецЕсли;	
КонецПроцедуры

&НаСервере
Процедура СкопироватьСтрокиНаСервере(ЧислоФайлов)	
	ЧислоФайлов = Элементы.ДеревоПриложений.ВыделенныеСтроки.Количество();	
	ОбщегоНазначения.СкопироватьФайлыВБуферОбменаИзТаблицыФайлы(ДеревоПриложений, Элементы.ДеревоПриложений.ВыделенныеСтроки);
	Элементы.ВставитьСтроки.Доступность = Истина;	
КонецПроцедуры

// ЭТО КНОПКА ВСТАВИТЬ ФАЙЛЫ
&НаКлиенте
Процедура ВставитьСтроки(Команда)
	
	Если Модифицированность Тогда
		Если НЕ Записать() Тогда
			Возврат;
		КонецЕсли;
	КонецЕсли;
	
	ЧислоФайлов = 0;
	ВставитьСтрокиНаСервере(ЧислоФайлов);
	
	Если ЧислоФайлов <> 0 Тогда
		
		ПолноеОписание = СтрШаблон(
			НСтр("ru = 'Файлы (%1 шт) вставлены из буфера обмена.'"), ЧислоФайлов);
		
		ПоказатьОповещениеПользователя(
			НСтр("ru = 'Вставка из буфера'"),
			,
			ПолноеОписание,
			БиблиотекаКартинок.Информация32);			
	КонецЕсли;	
КонецПроцедуры

&НаСервере
Процедура ВставитьСтрокиНаСервере(ЧислоФайлов)	
	Если ОбщегоНазначения.ПустойБуферОбмена() Тогда
		Возврат;
	КонецЕсли;	
	ДанныеИзБуфераОбмена = ОбщегоНазначения.СтрокиИзБуфераОбмена();
	МассивФайлов = ДанныеИзБуфераОбмена.Данные;	
	ЧислоФайлов = МассивФайлов.Количество();	
	РаботаСФайламиВызовСервера.СкопироватьФайлВПриложенных(МассивФайлов, Объект.Ссылка);	
	ЗаполнитьСписокФайлов();
	Модифицированность = Ложь;	
КонецПроцедуры

// Заполняет список файлов в карточке документа
//
//	Параметры
//		ЗаполнитьПризнакОригинал - Булево - если Истина, то будет заполнен признак оригинала
//
&НаСервере
Процедура ЗаполнитьСписокФайлов(ЗаполнитьПризнакОригинал = Ложь)	
	Делопроизводство.ЗаполнитьСписокФайловДокумента(ЭтаФорма, ЗаполнитьПризнакОригинал);	
КонецПроцедуры

3 – Дальнейшие действия: заполнить договор необходимой информацией (контрагент, сумма и т.д.).

Так как Инициатор договора должен контролировать процесс изменения договора и процесса согласования, то в карточке Ответственный заполняется из задачи автоматически. Нужно только его подписать на договор.

Тут сделал просто, на форму вынес кнопку Подписать, по нажатию на которую происходит следующее:

Автоматически подставляется Инициатор из договора(ответственный), а так же проставляются необходимые события для контроля(в моем примере "Изменился внутренний документ"):

Процедура Подписаться(Команда)	
	Если ЗначениеЗаполнено(Объект.Ссылка) Тогда
		ПараметрыФормы = Новый Структура("ОбъектПодписки", Объект.Ссылка);
		ФормаПодписки = ОткрытьФорму("ОбщаяФорма.ПодпискаНаУведомленияПоОбъекту", ПараметрыФормы);
	// Ponomarev -->
	Если ЗначениеЗаполнено(ЭтаФорма.Объект.Ответственный) Тогда  			
		ФормаПодписки.Заголовок = "Инициатор для контроля договора: " + ЭтотОбъект.Объект.Ответственный;
		ФормаПодписки.Элементы.Пользователь.Родитель.Родитель.Пользователь = ЭтаФорма.Объект.Ответственный;
	   Для Каждого Строка из ФормаПодписки.ПодпискиУведомлений Цикл
		Если Строка.Представление = "Изменился внутренний документ" Тогда
 	    	 // значения(1-да, 2-нет). Тип - число
                 Строка.ПоПочте = 1;
                 Строка.Окном   = 1;
                 // надпись (Да или Нет). Тип - строка
                 Строка.ПоПочтеСтрокой = Истина;
                 Строка.ОкномСтрокой   = Истина;
		КонецЕсли;
	   КонецЦикла;
	Иначе
	//  ФормаПодписки.Закрыть();
	//  Сообщить("Обязательно укажите Инициатора в карточке договора для подписки на уведомления.");	  
       КонецЕсли;
      // <-- Ponomarev		
	КонецЕсли;	
КонецПроцедуры

4 – Ответственный юр. отдела начинает процесс согласования нового договора по шаблону и при необходимости добавляет\удаляет участников.

В процессе Согласование добавил кнопку Подписать и реквизит Ответственный(Инициатор), который должен заполниться автоматически, но пока не сделал!

Код кнопки такой же как выше, только отмечаем все события:

&НаКлиенте
Процедура Подписаться(Команда)	
// Ponomarev	
	//Если ЗначениеЗаполнено(Объект.Ссылка) Тогда
	//	ПараметрыФормы = Новый Структура("ОбъектПодписки", Объект.Ссылка);
	//	ОткрытьФорму("ОбщаяФорма.ПодпискаНаУведомленияПоОбъекту", ПараметрыФормы);
	//КонецЕсли;
	Если ЗначениеЗаполнено(Объект.Ссылка) Тогда
		ПараметрыФормы = Новый Структура("ОбъектПодписки", Объект.Ссылка);
		ФормаПодписки = ОткрытьФорму("ОбщаяФорма.ПодпискаНаУведомленияПоОбъекту", ПараметрыФормы);			
	 Если ЗначениеЗаполнено(ЭтаФорма.Объект.Ответственный) Тогда  			
		ФормаПодписки.Заголовок = "Инициатор для контроля договора: " + ЭтотОбъект.Объект.Ответственный;
		ФормаПодписки.Элементы.Пользователь.Родитель.Родитель.Пользователь = ЭтаФорма.Объект.Ответственный;
		Для Каждого Строка из ФормаПодписки.ПодпискиУведомлений Цикл
		 // значения(1-да, 2-нет). Тип - число
                 Строка.ПоПочте = 1;
                 Строка.Окном   = 1;
                 // надпись (Да или Нет). Тип - строка
                 Строка.ПоПочтеСтрокой = "Да"; 
                 Строка.ОкномСтрокой   = "Да";
		КонецЦикла;
         КонецЕсли;  
        КонецЕсли;	
КонецПроцедуры

5 – После завершения процесса согласования Ответственный юр. отдела передает распечатанный договор и Лист согласования(печатает его из Процесса или из карточки договора, в прикрепленных файлах есть внешние ПФ(печатается с историей если есть)) офис менеджеру. Измененный Лист согласования выглядит так:

Офис менеджер меняет статус договора(На утверждении) и передает Генеральному директору на подпись.

Потом меняет статус(Утвержден) и указывает кем подписан договор.

Если договор не подписан со стороны Контрагента ставиться статус(Отправлен контрагенту), а если обе стороны подписали, то статус(Отправлен в архив).

Тут пришлось добавить эти статусы в перечисления СостоянияДокументов и изменить код модуля формы элемента внутреннего документа:

	// Список состояний
	СписокСостояний.Добавить(Перечисления.СостоянияДокументов.Проект);
	СписокСостояний.Добавить(Перечисления.СостоянияДокументов.НаСогласовании);
	СписокСостояний.Добавить(Перечисления.СостоянияДокументов.Согласован);
	СписокСостояний.Добавить(Перечисления.СостоянияДокументов.НеСогласован);
	СписокСостояний.Добавить(Перечисления.СостоянияДокументов.НаУтверждении);
	СписокСостояний.Добавить(Перечисления.СостоянияДокументов.Утвержден);
	СписокСостояний.Добавить(Перечисления.СостоянияДокументов.НеУтвержден);
	СписокСостояний.Добавить(Перечисления.СостоянияДокументов.НаРегистрации); 	
	// Ponomarev -->
СписокСостояний.Добавить(Перечисления.СостоянияДокументов.ОтправленКонтрагенту);
СписокСостояний.Добавить(Перечисления.СостоянияДокументов.ОтправленВАрхив);  
	// <-- Ponomarev

На этом процесс согласования завершен.


4. Другие доработки


1) Захотелось добавить больше информационных данных во внутренний документ. Решено было добавить реквизит Код затрат, таблицу Коды проекта, которую вынес в список внутренних документов. Данные берутся из добавленных справочников КодЗатрат и КодПроекта, причем последний должен синхронизироваться со справочником из бухгалтерской базы(БП). Теперь обо всем поподробнее:

КодПроекта:

Реквизиты: КодИзБП(Строка,9); GUID(Строка,50); Комментарий(Строка,100)

Формы: ФормаЭлемента, ФормаСписка, ФормаВыбора

Добавил общий модуль ПодргузкаИзБП, а в нем Процедуру ПодгрузитьКодПроекта, с помощью которой происходит подсоединение к базе по COM и сравнивнение GUID в базе-приемнике с GUID в базе-источнике и если такого нет, то создается новый элемент. В моем случае нужно было синхронизовать справочник КодПроекта и ПодразделенияОрганизации из БП 2.0:

Процедура ПодгрузитьКодПроекта()Экспорт	
	 cntr = Новый COMObject("V83.COMConnector");	 
	 КаталогБазыДанных = "\\---\Buh2014";
	 Пользователь = "Админ";
         Пароль = "----";
     TheConnectionString = "file='" + КаталогБазыДанных + "'; usr='" + Пользователь + "'; pwd='" + Пароль + "'";
	 
	 connection = cntr.Connect(TheConnectionString);
	 
	 Запрос = connection.NewObject("Запрос");
	 Запрос.Текст = "ВЫБРАТЬ
	 |	ПодразделенияОрганизаций.Ссылка,
	 |	ПодразделенияОрганизаций.Наименование,
	 |	ПодразделенияОрганизаций.Код,
	 |	ПодразделенияОрганизаций.Родитель 
	 |ИЗ
	 |	Справочник.ПодразделенияОрганизаций КАК ПодразделенияОрганизаций
	 |ГДЕ
	 |	НЕ ПодразделенияОрганизаций.ПометкаУдаления";
	 
	 РезультатЗапроса = Запрос.Выполнить();
	 
	 СпрОбъект = РезультатЗапроса.Выбрать(); 
	 ТабЗн = Новый ТаблицаЗначений;
	 ТабЗн.Колонки.Добавить("Ссылка");
	 ТабЗн.Колонки.Добавить("Код",Новый ОписаниеТипов("Строка",, Новый КвалификаторыСтроки(9)));
	 ТабЗн.Колонки.Добавить("Наименование",Новый ОписаниеТипов("Строка",, Новый КвалификаторыСтроки(100)));
	 ТабЗн.Колонки.Добавить("GUID",Новый ОписаниеТипов("Строка",, Новый КвалификаторыСтроки(50)));
	 ТабЗн.Колонки.Добавить("Родитель",Новый ОписаниеТипов("Строка",, Новый КвалификаторыСтроки(100))); 	 
	 
	 Пока СпрОбъект.Следующий() Цикл 		 
		 НоваяСтрока = ТабЗн.Добавить();
		 НоваяСтрока.Ссылка       = СпрОбъект.ref;
		 НоваяСтрока.Код          = СпрОбъект.code;
		// НоваяСтрока.Родитель = Connection.String(СпрОбъект.ref.Parent);
		 НоваяСтрока.Родитель     = СпрОбъект.Parent.Description;
		 НоваяСтрока.Наименование = СпрОбъект.description;
		 НоваяСтрока.GUID         = Connection.String(СпрОбъект.ref.UUID());
	 КонецЦикла;
	 connection = Неопределено;
	 ТабДог.Сортировать("Родитель Возр");
	 Запрос2 = новый Запрос;
	 Запрос2.Текст = "ВЫБРАТЬ
	                 |	Таб.Код КАК Код,
	                 |	Таб.Родитель КАК Родитель,
	                 |	Таб.Наименование КАК Наименование,
	                 |	Таб.GUID КАК GUID
	                 |ПОМЕСТИТЬ ВТДанные
	                 |ИЗ
	                 |	&Данные КАК Таб
	                 |;
	                 |
	                 |//////////////////////////////////////////////////////////////////////
	                 |ВЫБРАТЬ
	                 |	КодПроекта.GUID,
	                 |	КодПроекта.Родитель
	                 |ПОМЕСТИТЬ ВТ_КП
	                 |ИЗ
	                 |	Справочник.КодПроекта КАК КодПроекта
	                 |;
	                 |
	                 |//////////////////////////////////////////////////////////////////////
	                 |ВЫБРАТЬ
	                 |	ВТ_КП.GUID,
	                 |	ВТДанные.Код КАК Код,
	                 |	ВТДанные.Наименование КАК Наименование,
	                 |	ВТДанные.GUID КАК GUID1,
	                 |	ВТДанные.Родитель КАК Родитель
	                 |ИЗ
	                 |	ВТДанные КАК ВТДанные
	                 |		ЛЕВОЕ СОЕДИНЕНИЕ ВТ_КП КАК ВТ_КП
	                 |		ПО ВТДанные.GUID = ВТ_Дог.GUID";
	 
	 Запрос2.УстановитьПараметр("Данные",ТабЗн);
	 Результат = Запрос2.Выполнить();
	 
	 Выборка = Результат.Выбрать();
	 
	 кол = 0;
	 Пока Выборка.Следующий() Цикл		 
		 Если Выборка.GUID = Null Тогда
			 Спр = Справочники.КодПроекта.СоздатьЭлемент();
			 Спр.КодИзБП      = Выборка.Код;
			 Спр.Наименование = Выборка.Наименование;
			 Спр.GUID         = Выборка.GUID1;
			 Спр.Родитель     = Выборка.Родитель; 
                         Спр.Комментарий  = Выборка.Родитель; 
			 Спр.Записать();
			 Сообщить(Спр.Наименование);
			 кол = кол + 1;
		 КонецЕсли;	 
	 КонецЦикла;
	 Сообщить("Всего загружено: " + кол + " элементов");	 
КонецПроцедуры

Код кнопки:

&НаСервере
Процедура ЗагрузкаКодовПроектаНаСервере()	
	ПодгрузкаИзБП.ПодгрузитьКодПроекта();	
КонецПроцедуры

&НаКлиенте
Процедура ЗагрузкаКодовПроекта(Команда)	
	ЗагрузкаКодовПроектаНаСервере();	
КонецПроцедуры

Далее я сделал Решламентное задание ПодгрузкаНовыхКодовПроектаИзБП, указав Имя метода ПодгрузкаИзБП.ПодгрузитьКодПроекта и установил галочку Предопределенное, что бы мое задание появилось в списке заданий в базе. Справочник выглядит вот так:

Для того, чтобы показать таблицу Коды проекта в списке внутренних документов(ВнутренниеДокументы > ФормаСпискаСПапками), нужно изменить запрос:

В итоге получим вид:

2) Далее начальству пришла в голову мысль, чтобы у руководителей отделов на кнопке вместо согласовано было написано рассмотрено. Ок. Добавил роль ЗаменаСогласованоНаРассмотрено и изменил код двух модулей и заодно создал еще одну роль СогласоватьИСоздатьДоговор, которую прицепил к сотрудникам юр. отдела что бы только они видели кнопку Создать договор(об этом речь шла выше):

  • Бизнес-Процессы --> Согласование --> форма  ФормаЗадачиИсполнителя --> Модуль
// Ponomarev -->
&НаСервере
Процедура ПриОткрытииНаСервере()
     Если РольДоступна("ЗаменаСогласованоНаРассмотрено") Тогда 		 
	  ЭтотОбъект.Элементы.СогласованоСЗамечаниями.Заголовок = "Рассмотрено с замечаниями";
	  ЭтотОбъект.Элементы.Согласовано.Заголовок             = "Рассмотрено";
	  ЭтотОбъект.Элементы.НеСогласовано.Заголовок           = "Не рассмотрено";	 
     КонецЕсли;   
     Если РольДоступна("СогласоватьИСоздатьДоговор") Тогда 
	  ЭтаФорма.Элементы.ВРаботу.Видимость = Истина;
	  ЭтаФорма.Элементы.ГруппаРаботаСФайлами.Доступность = Истина;
	  ЭтаФорма.Элементы.Help.Видимость = Истина;
     Иначе
	  ЭтаФорма.Элементы.ВРаботу.Видимость = Ложь;
	  ЭтаФорма.Элементы.ГруппаРаботаСФайлами.Доступность = Ложь;
	  ЭтаФорма.Элементы.Help.Видимость = Ложь;
     КонецЕсли;		 
КонецПроцедуры // <-- Ponomarev

&НаКлиенте
Процедура ПриОткрытии(Отказ)	
	Оповестить("ОбновитьСписокПоследних");	
	 Если ЭтотОбъект.Элементы.ОтменитьВыполнение.Видимость = Истина Тогда 
	      ЭтотОбъект.Элементы.ВРаботу.Видимость = Ложь;
		  ЭтотОбъект.Элементы.Help.Видимость    = Ложь;
	 КонецЕсли;

	ПриОткрытииНаСервере(); // Ponomarev

КонецПроцедуры
  • Задачи -->  форма ЗадачиМне --> Модуль (тут делаем по аналогии)
// Ponomarev -->
&НаСервере
Процедура ПриОткрытииНаСервере()	
     Если РольДоступна("ЗаменаСогласованоНаРассмотрено") Тогда		 
	 ЭтотОбъект.Элементы.СогласованоСЗамечаниями.Заголовок = "Рассмотрено с замечаниями";
	 ЭтотОбъект.Элементы.Согласовано.Заголовок             = "Рассмотрено";
	 ЭтотОбъект.Элементы.НеСогласовано.Заголовок           = "Не рассмотрено"; 	 
     КонецЕсли;	
КонецПроцедуры // <-- Ponomarev

&НаКлиенте
Процедура ПриОткрытии(Отказ)	
	УстановитьТекущееЗначениеГруппировкиЗадачМне();	
	#Если Не ВебКлиент Тогда
		УстановитьАвтообновлениеФормы();
	#КонецЕсли	
	ЗаполнитьПараметрыСохраненияКомментарияЗадачи(ЭтаФорма);	
	ПриОткрытииНаСервере(); // Ponomarev	
КонецПроцедуры

3) Изменена форма Задачи мне – для удобства добавлена кнопка Ход согласования.

Кнопка:

&НаКлиенте
Процедура История(Команда)	
Если ЭтаФорма.ТекущийЭлемент.ТекущиеДанные = НЕОПРЕДЕЛЕНО
	ИЛИ ЭтотОбъект.ТекущийЭлемент.ТекущаяСтрока = 0 Тогда
 Сообщить("Выберите в списке задачу. Бизнес процесс задачи не определен.");	
Иначе
 ЗадачаСсылка        = ЭтаФорма.ТекущийЭлемент.ТекущаяСтрока;
 БизнесПроцессСсылка = ЭтаФорма.ТекущийЭлемент.ТекущиеДанные.БизнесПроцесс;
 ПараметрыФормы = Новый Структура;
 ПараметрыФормы.Вставить("ЗадачаСсылка",  ЭтаФорма.ТекущийЭлемент.ТекущаяСтрока);
 ЭтаФорма.ТолькоПросмотр = Истина;
 ПараметрыФормы.Вставить("ТолькоПросмотр", ЭтаФорма.ТолькоПросмотр);	
	
  Если ТипЗнч(БизнесПроцессСсылка) = Тип("БизнесПроцессСсылка.Согласование") Тогда 
    ФРМ = ПолучитьФорму("БизнесПроцесс.Согласование.Форма.ФормаИсторияСогласования", ПараметрыФормы);
    ДанныеФормы = ФРМ.ЭтотОбъект;      
    ФРМ.Открыть();
  Иначе
    Сообщить("это не Согласование, а " + ТипЗнч(БизнесПроцессСсылка));
  КонецЕсли;
КонецЕсли;
КонецПроцедуры

4) Изменена форма Все задачи – добавлена информация о договоре и кнопка ход согласования(Код такой же как выше).

Для возможности добавить информацию о договоре, нужно изменить запрос(Задачи > ФормаСписка). После этого нужно добавить необходимые поля на форму. Я не стал здесь показывать что и где нужно изменить, можете скачать конфигурацию и посмотреть все изменения.


После всего этого в базе стало работать много сотрудников что отразилось на производительности. Спас web-интерфейс, благодаря которому не наблюдается тормозов 1с.

В итоге получилась вроде бы нормальная автоматизация, отвечающая утвержденному регламенту. На этом все.

Надеюсь данная статья и доработки будут кому нибудь интересны и полезны.


P.S.S. В прикрепленных файлах если кому пригодится – руководство по согласованию для новичков(потому что пришлось детально все описать для пользователей, которые 1с никогда не видели), конфигурация и  две ВПФ Лист согласования(работают в ПРОФ и КОРП 2.1).

Для справки, сервер из себя представляет следующую конфигурацию:

- Intel® Core™ 2 Quad CPU Q8200 2.33 GHz; 4 Gb RAM

- Windows Server 2008 R2 Standard

- MS SQL Server 2008 + 1с 8.3.9.2170 + одна база ДО (~ 15 ГГ)


Спасибо за внимание!


Обновление 26.04.2018:

  • Добавлены еще 2 печатные формы в архив для процесса(1 - заголовок берется из процесса; 2 - с колонкой срок выполнения и просрочка)
  • У печатных форм добавил Размещение при регистрации и изменил имена файлов в архиве что бы не путаться.

P.S. Печатные формы на последних релизах тоже работают.

Скачать файлы

Наименование Файл Версия Размер
Четыре ПФ Лист согласования: для справочника ВнутренниеДокументы и для Процесса(3 шт.) с историей

.zip 63,40Kb
22.05.20
23
.zip 63,40Kb 23 Скачать
Конфигурация с описанными изменениями и Руководство по работе с программой и процесс согласования договора

.7z 53,65Mb
04.07.17
12
.7z 53,65Mb 12 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. botokash 258 04.07.17 13:49 Сейчас в теме
то пришлось поискать на просторах интернета обновления

На сайте партнера 1С звучит не комильфо)
5. SPonomareff 84 05.07.17 10:28 Сейчас в теме
(1) За это извиняюсь. Но не оказалось подписки, а делать что то нужно было.
2. ilya.rudziak 33 04.07.17 14:05 Сейчас в теме
Скрины из 1.3 а какая версия БД в
"Конфигурация с описанными изменениями и Руководство по работе с программой и процесс согласования договора" ?
4. SPonomareff 84 05.07.17 10:25 Сейчас в теме
(2) Я делал все изменения на версии 2.1.10.2 ПРОФ и руководство по ней писал. Может случайно скришоты не те вставил.
6. SPonomareff 84 05.07.17 15:07 Сейчас в теме
(2) Совсем забыл написать - у конфигурации включен режим совместимости интерфейса с 8.2
7. user766040 14.11.17 13:27 Сейчас в теме
Приветствую! Ваша разработка будет работать в ДО 2.1.10.2 КОРП?
9. SPonomareff 84 15.11.17 12:26 Сейчас в теме
(7) Добрый день!

Разработки и печатные формы будут работать и на ПРОФ и на КОРП. На данный момент у меня работает на КОРП 2.1.11.5.
Если будут какие то вопросы, то пишите. С радостью помогу.
8. CyberBob 4 15.11.17 11:59 Сейчас в теме
Особенно понравилась кнопка "Не рассмотрено".)
10. rti30 25.04.18 11:55 Сейчас в теме
SPonomareff,
Платформа 8.3.10.2580, редакция 2.1.11.5, режим совместимости 8.3.8 на поддержке. Будут внешние ПФ формы листа согласования открываться? ФормуЗадачиИсполнителя и изменения в Общем модуле вы через "расширение" реализовали?
13. SPonomareff 84 26.04.18 10:23 Сейчас в теме
(10) Добрый день!

Только что все перепроверил. В типовой конфигурации печатные формы работают.

Думаю над расширением.
11. SPonomareff 84 25.04.18 21:48 Сейчас в теме
Добрый вечер!

Все было реализовано именно изменением типовой конфигурации и до сих пор продолжает работать.

Печатные формы протестирую с Вашей конфигурацией и если что подкорректирую и завтра сообщю. Вообще должно все работать если убрать вывод в ПФ табличную часть Код проекта.

Я давно хотел сделать именно расширение. Если подождете, то я в майские праздники( или до них) попробую сделать расширение.
12. SPonomareff 84 25.04.18 21:56 Сейчас в теме
Хотя нет. Должно все работать и так! Я не выкладывал ПФ с учетом изменений. Но все равно завтра проверю.
14. user636714_elizarov.aleksey 25.05.18 18:07 Сейчас в теме
у меня начальство подобный "ход согласования" требует. и найти не могу кто бы взялся. пример того что нужно сделать




или может у кого есть готовый вариант. куплю!)))

код как по мне так слишком замудреный в ДО
15. SPonomareff 84 25.05.18 21:17 Сейчас в теме
Доброго времени суток!
Через час смогу посмотреть и сразу отвечу.
16. Gorislav 21.05.20 19:36 Сейчас в теме
Добрый вечер. В последнем релизе ДО печатные формы также работают?
17. SPonomareff 84 21.05.20 23:05 Сейчас в теме
(16) Добрый вечер!
Завтра поставлю последний релиз ДО и посмотрю. Если что не работает, то переделаю.
18. SPonomareff 84 22.05.20 09:46 Сейчас в теме
(16)
Доброе утро!
На релизе 2.1.20.5 все работает, проверил.
19. yurikmellon 5 07.07.20 11:16 Сейчас в теме
(18) Добрый день.
Скачал Ваши печатные формы и столкнулся с проблемой. В web-интерфейсе они не заработали. Формы, которые печатаются из процесса намертво вешают приложение. А форма для справочника Внутренние документы просто не формируется с сообщением "Печатная форма недоступна". Есть какие то особенности с работой этих внешних печатных форм через браузер?
З.Ы. Платформа 8.3.16.1063 Документооборот КОРП 2.1.14.4
20. SPonomareff 84 23.07.20 21:43 Сейчас в теме
(19) Добрый день!
Прошу прощения за долгий ответ.
Проблем не было с веб-интерфейсом точно, но платформа была при тестировании в веб-интерфейсе намного ниже 8.3.16. Возможно дело в этом. Проверю в выходные и отпишусь Вам.
Оставьте свое сообщение

См. также

Безопасная работа с транзакциями во встроенном языке Промо

Практика программирования v8 1cv8.cf Абонемент ($m)

Разбираемся с опасностями использования транзакций во встроенном языке 1С. Познаем ошибку "В данной транзакции уже происходили ошибки". Учимся защищаться от них.

1 стартмани

25.03.2019    36063    tormozit    54    

Cбор и анализ ошибок при помощи Sentry, или как упростить жизнь себе и пользователям

Практика программирования Интеграция v8 Абонемент ($m)

Цель данной статьи - сделать процесс сбора и анализа ошибок, происходящих в базе, максимально простым, быстрым и удобным, собирать статистику по ошибкам, местам их возникновения и частоте их появления, а также в деталях разобрать все тонкости по интеграции 1С с Sentry.

1 стартмани

09.10.2020    2771    hexhoc    12    

Программная корректировка при выводе отчета СКД

Практика программирования v8 v8::СКД 1cv8.cf Абонемент ($m)

Большинство отчетов на СКД, требующих программной корректировки, реализуются с помощью программной настройки СКД или обработки табличного документа уже после вывода отчета. Но во многих случаях более оптимально будет выполнять программную корректировку в процессе вывода отчета. Для этого существуют программные объекты, о которых я расскажу в данной статье.

1 стартмани

08.10.2020    3377    dabu-dabu    8    

Загрузка, скачивание, удаление файлов с помощью НачатьПомещениеФайлаНаСервер() и НачатьПолучениеФайлаССервера()

Практика программирования v8 1cv8.cf Абонемент ($m)

В платформе 8.3.15 появились новые методы НачатьПомещениеФайлаНаСервер() и НачатьПолучениеФайлаССервера(). В данной статье рассмотрено готовое решение проверенное и прекрасно работающее на тонком и веб-клиенте.

1 стартмани

25.07.2020    3813    Flashill    10    

Как выполнить отчет на СКД через COM и получить данные отчета? Промо

Практика программирования v8 УПП1 Россия Абонемент ($m)

Для чего это нужно. Например, нужно в одной базе получить какой-либо показатель из другой базы. Этот показатель вычисляется в каком-либо сложном отчете, который написан на СКД. Можно, конечно, "скопипастить" текст запроса из другой базы, немного подправить его и выполнять в том же COM подключении. Но с этим теряется гибкость: если отчет изменился, то нужно помнить о том, что где-то есть его "немного модифицированная" копия. В статье будет рассмотрен пример получения данных из базы ЗУП.

2 стартмани

08.05.2018    27221    wowik    3    

Параллельные вычисления расчета факториала числа N

Практика программирования v8 1cv8.cf Абонемент ($m)

Распараллеливание алгоритма с помощью фоновых заданий (асинхронные вычисления)

1 стартмани

29.06.2020    2855    Rustig    17    

Универсальная печатная форма Приказа/Договора с возможностью настройки макета в пользовательском режиме

Практика программирования Универсальные печатные формы v8 1cv8.cf Абонемент ($m)

В данной статье я опишу реализацию универсальной (в кавычках) печати Приказа (Договора или чего пожелаете) с возможностью настройки выводимого текста с параметрами из пользовательского режима

1 стартмани

24.06.2020    1404    BuriyLesha    0    

Методика обновления формы объекта данных при изменении объекта

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

В формах объектов данных часто встречаются элементы, косвенно связанные с объектом. Логику обновления этих элементов при изменении объекта обычно вызывают из обработчиков ПриСозданнииНаСервере и ПриОткрытии, забывая про наличие других способов изменения объекта. В статье предложена методика для обычных и управляемых форм, учитывающая все способы.

1 стартмани

09.03.2020    8893    tormozit    13    

Как нарисовать граф на 1С Промо

Практика программирования v8 Абонемент ($m)

Описывается реализация на языке запросов 1С метода расположения вершин графа на плоскости, основанного на использовании электромеханической аналогии. При этом вершины графа представляются одноименными электрическими зарядами, дуги - пружинками. Силы взаимодействия вершин в этой системе переводят их из случайного начального в нужное конечное положение. Приведена обработка рисования графов "ГрафОграф", реализующая данный подход, показывающая также динамику процесса. Граф можно задать списком ребер вручную, выбрать из нескольких предопределенных примеров или сформировать по данным информационной базы.

1 стартмани

09.08.2013    70710    ildarovich    117    

Отправка уведомлений с помощью командной строки, Оповещения с сервера на клиент с помощью командной строки

Практика программирования v8 1cv8.cf Россия Абонемент ($m)

Отправка уведомлений с помощью команды командной строки msg. Оповестить пользователей из серверного модуля или регламентного задания, с помощью командной строки msg.

1 стартмани

05.03.2020    5920    user5300    3    

Вывод сообщений в HTML поле средствами 1С

Практика программирования v8 v8::УФ Абонемент ($m)

Пример использования вывода большого количества сообщений в поле HTML. С возможностью открывать ссылочные объекты и создавать новые объекты передавая параметры прямо из HTML поля. Протестировано на релизах 8.3.12 и 8.3.15+

2 стартмани

31.01.2020    6059    burni4    16    

Краткое руководство по внесению изменений в конфигурацию

Практика программирования v8 1cv8.cf Абонемент ($m)

Кратко описаны основополагающие моменты при старте групповой разработки конфигурации несколькими программистами. Полезно для проектной документации как требование к разработчикам или сопровождающей компании.

1 стартмани

13.01.2020    17698    sapervodichka    41    

Простой способ индексирования интервалов Промо

Практика программирования v8 Абонемент ($m)

Предлагается простой способ индексирования интервалов для решения задач выборки записей, включающих заданный момент времени, пересекающихся с заданным интервалом или множеством интервалов. Способ основан на добавлении к исходной таблице особого числового индексированного поля, рассчитываемого по специальной формуле. Приведен код функций, необходимых для расчетов поля поиска и параметров поисковых запросов. Приведены также результаты тестирования метода, доказывающие его высокую эффективность.

1 стартмани

28.09.2016    39848    ildarovich    22    

Универсальные функции: разложение произвольной строки адреса в структуру

Практика программирования Универсальные функции v8 1cv8.cf Абонемент ($m)

Процедуры и функции раскладывают произвольную строку адрес в структуру по ключевым словам.

1 стартмани

30.12.2019    3927    vik070777    10    

"Живые" картинки со Snap.SVG

Практика программирования WEB Работа с интерфейсом v8 Абонемент ($m)

В статье рассмотрен пример использования http-сервисов для визуализации данных

1 стартмани

24.10.2019    13729    blackhole321    7    

RLS - дубли условий в запросах к СУБД

Практика программирования Роли и права v8 v8::Права 1cv8.cf Абонемент ($m)

"Подводные камни", возникающие при бездумном копировании ролей с ограничениями RLS, как это отражается на производительности, разбор примера и инструмент для анализа.

1 стартмани

07.10.2019    8555    geron4    4    

Бесплатная проверка контрагентов в ФНС (общий модуль с алгоритмом). На примере выводим статус в список справочника контрагентов Промо

Практика программирования v8 1cv8.cf Абонемент ($m)

Если вам интересно проверить контрагенте в ФНС, вам поможет данная публикация. Весь алгоритм работы строится на основе данных, полученных с сервиса http://npchk.nalog.ru совершенно бесплатно.

1 стартмани

01.02.2018    35288    rpgshnik    49    

Полное копирование одной формы в другую

Практика программирования Универсальные обработки Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Однажды я столкнулся с необходимостью открыть форму ЛЮБОГО документа с определенными изменениями, не зависящими от структуры объекта (например, заблокировать все кнопки). В интернете решения я не нашел. Обычно на форумах на запросы подобного рода отвечают чем-то вроде "покажи первоначальную задачу, а не спрашивай как реализовать то, что ты придумал". Тем не менее, мне стало интересно, как это можно сделать.

1 стартмани

03.10.2019    5341    nekit_rdx    23    

Многопоточная обработка данных на примере перепроведения документов

Обработка документов Практика программирования v8 ERP2 УТ11 КА2 Абонемент ($m)

Дальнейшее развитие темы фоновой обработки данных - проведение документов в потоках. Настройка параметров и запуск основного процесса (менеджера потоков). Разбивка документов для проведения на не связанные друг с другом наборы и запуск дополнительных фоновых заданий для отдельных потоков. Отслеживание выполнения каждого потока в родительском сеансе.

1 стартмани

17.09.2019    9476    ids79    46    

Отображение истории выполнения по всем задачам комплексного процесса в документообороте

Документооборот и делопроизводство Практика программирования v8 ДО Абонемент ($m)

Коллеги, предлагаю вашему вниманию доработку для вывода полной истории в задачах комплексного процесса.

1 стартмани

15.09.2019    7025    pavelpribytkin96    8    

БСП: Дополнительная обработка (Регламенты), примеры от простого к сложному Промо

Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

Очень много попадается странных решений, которые можно решить через БСП:Дополнительные отчеты и обработки. Я бы вообще БСП из-за этой подсистемы переименовал в «Большое Спасибо Программистам». Поработаем с подсистемой в части написания регламентных заданий.

1 стартмани

10.05.2018    45588    dsdred    43    

Описание формата внутреннего представления данных 1С в контексте обмена данными

Практика программирования Внешние источники данных v8 v8::УФ 1cv8.cf Абонемент ($m)

Фирма 1С не рекомендует использовать внутреннее представление данных для любых целей, которые отличны от обмена с 1С:Предприятием 7.7. Но сама возможность заглянуть на "внутреннюю кухню" платформы с помощью функций ЗначениеВСтрокуВнутр(), ЗначениеВФайл(), ЗначениеИзСтрокиВнутр() и ЗначениеИзФайла(), дала возможность сообществу программистов 1С разработать новые приемы разработки и анализа. Так, именно на использовании внутреннего представления был построен алгоритм "быстрого массива", который позволяет практически мгновенно создать массив в памяти на основании строки с разделителями. С помощью разбора внутреннего представления можно "на лету" программным кодом выполнить анализ обычной формы и даже сделать редактор графической схемы. Во внутреннем формате сохраняют свои данные между сеансами различные популярные внешние обработки. А еще это возможность сделать быстрый обмен с внешними системами.

1 стартмани

06.09.2019    19708    Dementor    30    

Удобный просмотр результата запроса с большим количеством временных таблиц

Практика программирования v8 Абонемент ($m)

Если Вам часто приходится просматривать в отладчике сложные пакетные запросы с большим количеством временных таблиц, то эта статья для Вас.

1 стартмани

27.08.2019    11032    ids79    21    

Запуск фонового задания во внешней обработке. Отключение предупреждений защиты от опасных действий в фоновом задании

Практика программирования v8 1cv8.cf Абонемент ($m)

Как запустить фоновое задание из модуля внешней обработки используя БСП. Как отключить безопасный режим и сообщения защиты от опасных действий независимо от профиля безопасности пользователя в фоновом задании во внешней обработке.

2 стартмани

24.08.2019    11369    BenGunn    22    

Некоторая работа с данными через COM Промо

Практика программирования v8 Абонемент ($m)

В статье приведены примеры работы с Платформой 8.X через COM (точнее, через объект COMConnector). Примеры кода были использованы при реализации прикладных задач в процессе трудовой деятельности.

2 стартмани

05.12.2012    57779    wowik    32    

Изменяющееся контекстное меню в 1С 8.3

Практика программирования Работа с интерфейсом Разработка v8 v8::УФ Абонемент ($m)

В одной практической задаче мне пришлось разрабатывать контекстное меню таблицы управляемой формы, которое должно было меняться в зависимости от данных, находящихся в этой таблице. Ниже приведен мой способ решения этой задачи.

1 стартмани

06.08.2019    16402    signum2009    16    

Процедура ПриКомпоновкеРезультата

Практика программирования v8 1cv8.cf Абонемент ($m)

Коллекция кода

1 стартмани

26.07.2019    40827    vasilev2015    64    

10 способов получить модуль числа (а может, и больше)

Практика программирования Разработка v8 1cv8.cf Абонемент ($m)

Пишем функцию вычисления модуля числа. Сколько способов существует? Давайте посчитаем!

1 стартмани

11.07.2019    8787    sam441    29    

Работа со схемой запроса Промо

Инструментарий разработчика Практика программирования v8 v8::Запросы Абонемент ($m)

Стандартом взаимодействия с реляционной базой данных стал язык SQL. Приемником SQL в 1С является язык запросов. Язык запросов, также как и SQL, является структурированным. Составляющие структуры запроса отвечают на разные вопросы о том, какие данные требуется получить и какие манипуляции с множествами данных необходимо произвести при получении. В простых случаях текст запроса можно написать вручную, однако в сложных случаях, а также при программном формировании, - лучше воспользоваться объектной моделью запроса и использовать объект "Схема запроса". В статье дается описание объектной модели и особенностей работы с ней, а также приводится решение, упрощающее взаимодействие с объектом "Схема запроса".

1 стартмани

24.04.2018    44744    kalyaka    35    

Ловец дедлоков СУБД

Производительность и оптимизация (HighLoad) Практика программирования Разработка v8 Россия Абонемент ($m)

Анализ простейшего дедлока СУБД в рабочей базе с использованием ЦУП (центра управления производительностью) и profiler MS SQL (Microsoft SQL Server). Эта статья будет полезна людям, изучающим вопросы оптимизации работы 1С, или тем, у кого возникают дедлоки в рабочей базе. UPD 09.07.2019 добавлено воспроизведение блокировки в случае установки управляемой блокировки перед чтением набора записей регистра сведений. UPD 10.07.2019 добавлена тестовая база с примером.

1 стартмани

08.07.2019    11281    azazana    79    

Мониторинг производительности и искусственный интеллект

Производительность и оптимизация (HighLoad) Практика программирования Разработка v8 Абонемент ($m)

Расскажем и покажем практически, как использовать искусственный интеллект на страже мониторинга производительности. У вас появится возможность создать собственного помощника Ларису, которая возьмет на себя вопросы по контролю и диагностике состояния обслуживаемой системы.

1 стартмани

01.07.2019    9408    ivanov660    28    

"Убер на складе": динамический расчет маршрутов с учетом реальных расстояний

Учет ТМЦ Практика программирования Учет ТМЦ v8 УУ Абонемент ($m)

Представляю методику и инструмент для динамического расчета маршрутов отбора на высоконагруженных складах для максимального повышения эффективности склада, ускорения проходимости и, как следствие, экономии денег. Это методика и обработка для интеграции в WMS решения. Тестировалось на 1С 8.3.14.1565.

3 стартмани

24.06.2019    16332    informa1555    17    

Многопоточность. Универсальный «Менеджер потоков» (фреймворк) с отслеживанием зависимости объектов Промо

Практика программирования Математика и алгоритмы Универсальные функции Производительность и оптимизация (HighLoad) v8 1cv8.cf Россия Абонемент ($m)

Восстановление партий, расчет зарплаты, пакетное формирование документов или отчетов - теперь все это стало доступнее. * Есть желание повысить скорость работы медленных алгоритмов! Но... * Нет времени думать о реализации многопоточности? * о запуске и остановке потоков? * о поддержании потоков в рабочем состоянии? * о передаче данных в потоки и как получить ответ из потока? * об организации последовательности? Тогда ЭТО - то что надо!!!

26.05.2017    49342    DarkAn    86    

1С:Ассемблер. Немного летнего веселья!

Практика программирования Разработка v8 1cv8.cf Абонемент ($m)

Все вы, наверное, слышали, что 1С-ники жалуются на свою систему, считая язык 1С недостаточно низкоуровневым, скучным и т.п. Все они с тоской поглядывают в сторону "настоящих" языков программирования. Так вот, господа, они неправы. В системе 1С есть места, где можно размять программерский мозг и получить удовольствие от низкоуровневой техники. Предлагаю вам погрузиться в недра виртуальной машины 1С и понять, как она работает. Там есть свой "ассемблер" и мы попробуем его в действии!

1 стартмани

21.06.2019    29632    Evil Beaver    129    

Совместное использование 1С:Сервер взаимодействия и Документооборот 8 КОРП, редакция 2.1.13 - Уведомления для рабочего стола

Пользователю системы Работа с интерфейсом Интеграция Документооборот и делопроизводство Документооборот и делопроизводство v8 ДО УУ Абонемент ($m)

С версии ДО 2.1.13 в программу встроена подсистема Обсуждения. Данная подсистема позволяет производить уведомление пользователей без необходимости открытия программы.

1 стартмани

18.06.2019    13684    ilya.rudziak    10    

Простые примеры сложных отчетов на СКД

Практика программирования v8 v8::СКД 1cv8.cf Абонемент ($m)

Подписи в отчете. Особенности соединения наборов: как соединить несоединяемое. Остатки на дату и обороты по месяцам в одном отчете. Курс валюты на каждую дату без группировок и соединений в запросе. Отчет с произвольными колонками и с произвольной последовательностью. "Неадекватный отчет".

1 стартмани

12.06.2019    30454    Hatson    31    

Новый запрос и новая таблица значений как функции Промо

Практика программирования v8 Абонемент ($m)

Предлагается две простые функции, использование которых уменьшает объем кода в конфигурациях на платформе «1С:Предприятие 8». Эти функции можно добавлять к своему общему модулю, что сделает процесс программирования более эффективным.

1 стартмани

27.11.2012    45362    ildarovich    46    

Графики работы из БСП

Практика программирования Разработка v8 1cv8.cf Россия Абонемент ($m)

Не очень давно на канале 1С:БСП была опубликована заметка по использованию Графиков работы и Календарных графиков.

1 стартмани

23.05.2019    3360    fenixnow    0    

Создание внешней печатной формы в формате документа Word

Практика программирования Разработка v8 1cv8.cf Абонемент ($m)

В статье написано, как создать внешнюю печатную форму (для конфигураций с БСП) в формате Word.

1 стартмани

17.05.2019    14573    ВикторП    21    

Пример настройки шаблонов и реализации печати отчетов в документ MS Word используя функциональную часть "Библиотеки Стандартных Подсистем 1С" (БСП)

Практика программирования Разработка v8 Россия Абонемент ($m)

В конфигурации выбраны и использованы только необходимые объекты библиотеки стандартных подсистем для реализации вывода отчёта, с табличными частями, в документ MS Word. Показан пример создания необходимых областей в шаблоне для вывода параметров в отчёт.

1 стартмани

23.04.2019    6463    olegpkc    11    

Уровни, глубина, прародители, циклы и аналоги запросом Промо

Практика программирования v8 1cv8.cf Абонемент ($m)

В продолжение публикации «Транзитивное замыкание запросом» [http://infostart.ru/public/158512/] добавлены другие варианты использования того же приема. Приведены запросы для быстрого определения уровней всех элементов справочника, максимальной глубины справочника, прародителей произвольных элементов справочника, запрос для быстрого определения циклов (на примере справочника спецификаций «1С:Управление производственным предприятием») и определения множеств аналогов номенклатуры (также на примере конфигурации «1С:Управление производственным предприятием»).

1 стартмани

13.11.2012    112872    ildarovich    98    

Ops средствами 1С:Предприятие

Практика программирования Разработка v8 1cv8.cf Абонемент ($m)

В статье описан программный пакет "Автоматизация ИТ-процессов" (АИТП), позволяющий автоматизировать задачи по администрированию, управлению и обслуживанию ИТ-инфраструктуры.

1 стартмани

23.04.2019    17514    blackhole321    28    

1C + Python + Django Rest Framework + Vue.js. Опыт несложной full-stack разработки

Практика программирования Внешние источники данных Обмен через XML WEB Разработка v8 1cv8.cf Абонемент ($m)

В этой статье мы рассмотрим путь и основные моменты создания небольшого вэб-сервиса, который мы называем "Онлайн Прайс-лист". Выгрузка из 1С, бэкенд, фронтенд, получение заказов в 1С.

1 стартмани

22.04.2019    33918    riposte    65    

Вывод вариантов СКД в таблицы на управляемой форме

Практика программирования Работа с интерфейсом v8 v8::УФ v8::СКД 1cv8.cf Абонемент ($m)

Задача стояла такая: есть 2 различных запроса, результаты которых выгружаются на форму обработки в таблицы значений (далее ТЗ) и программно "соприкасаются" между собой определенным образом (как именно- в рамках данной статьи неважно). Нюанс в том, что запросы должны иметь свой компоновщик настроек и могут интерактивно на форме изменяться пользователем. На оригинальность публикации не претендую - изначально в рамках поставленной задачи пытался найти что-то подобное (уже готовый шаблон) на инфостарте, возможно "плохо искал" ;)

05.04.2019    11472    artkor    1    

Неоплаченные долги при распределении оплаты по правилу ФИФО одним запросом и намного быстрее, чем Вы думали Промо

Практика программирования Дебиторская и кредиторская задолженность Дебиторская и кредиторская задолженность v8 v8::СКД КА1 УТ10 УПП1 УУ Абонемент ($m)

Предлагается метод для быстрого нахождения неоплаченных долгов при распределении оплаты по правилу ФИФО, основанный на дихотомии. Описывается реализация метода в виде достаточно простого запроса, решающего за линейное время указанную задачу, считавшуюся ранее существенно более трудоемкой. Приводятся примеры использования запроса в отчетах на СКД для конфигураций УТ, КА, УПП.

1 стартмани

28.02.2014    68598    ildarovich    125    

Функциональное программирование в 1С

Практика программирования Математика и алгоритмы Разработка v8 1cv8.cf Абонемент ($m)

Статья о функциональном программировании в 1С. Добавляем новые возможности. Пример передачи функций в качестве аргумента.

1 стартмани

28.03.2019    8475    alexey.kutya    26    

[EnterpriseData] Антисвертка характеристик номенклатуры при выгрузке в Бухгалтерию

Практика программирования Перенос данных из 1C8 в 1C8 Разработка v8 v8::ПВХ КД УНФ БП3.0 Россия БУ Абонемент ($m)

Рассмотрена выгрузка каждой пары значений Номенклатура - Характерстика из УНФ 1.6 в отдельную номенклатуру в Бухгалтерию 3.0 путём доработки правил обмена в формате EnterpriseData.

1 стартмани

27.03.2019    4753    nforce    6    

Интеграция 1С и SharePoint

Практика программирования Разработка v8 УНФ ДО ERP2 БП3.0 УТ11 УХ КА2 Россия Абонемент ($m)

Заказчики поставили задачу автоматизации согласования заявок на оплату в программе 1С:Бухгалтерия предприятия 3.0. Согласно ТЗ, данные должны подтягиваться из действующей электронной системы документаоборота на MS SharePoint (в дальнейшем СЭД MS SP).

1 стартмани

22.03.2019    5564    -I-    4    

Транзитивное замыкание запросом Промо

Практика программирования v8 1cv8.cf Абонемент ($m)

В частности, показывается, как одним пакетным запросом найти ВСЕХ предков (потомков) в иерархическом справочнике. Аналогично можно определять входимость деталей в узлы и готовые изделия по их спецификациям, определять подмножества аналогичных запчастей по цепочке аналогов, решать другие подобные задачи. Приложен файл с примером отчета для замыкания иерархии произвольного справочника, позволяющий протестировать быстродействие запроса в разных условиях.

1 стартмани

29.10.2012    86245    ildarovich    118    

Легкий "тюнинг" УТ 10.3

Практика программирования Разработка v8 v8::ОУ УТ10 Россия УУ Абонемент ($m)

Вариант программной реализации изменения форм типовых объектов для конфигурации Управление торговлей 10.3.

1 стартмани

15.03.2019    4484    pm74    6    

Пример использования СКД и данных расшифровки на мобильной платформе

Практика программирования Разработка v8 v8::Mobile v8::СКД 1cv8.cf Россия Абонемент ($m)

СКД в мобильном приложении и меню действий на основе данных расшифровки (отчет, совместимый с мобильной платформой 8.3.13.45).

1 стартмани

12.03.2019    5604    majoram    0    

Программное создание реквизита управляемой формы с помощью механизма расширений

Практика программирования Разработка v8 v8::УФ 1cv8.cf Абонемент ($m)

В ЗУП 3 возникла задача добавить реквизит в справочник не внося изменений в конфигурацию. БСП с механизмом дополнительных реквизитов использовать было нежелательно, поэтому был использован механизм расширений. Для вывода данного реквизита на форму добавлять саму форму в расширение не хотелось по ряду причин, описанных ниже. Создание реквизита и элемента формы, соответствующего данному реквизиту было решено сделать программно в самом расширении, следуя принципу минимального воздействия на конфигурацию.

1 стартмани

12.03.2019    37861    ni_cola    31