Знакомство с 1С:Документооборот. История автоматизации и доработок. Печатная форма Лист согласования

Публикация № 637276

Разработка - Практика программирования

Копирование вставка и перенос файлов Документооборот Лист согласования Визы загрузка данных из другой базы по com соединению webinst

23
Документооборот 2.1.10.2 ПРОФ. История автоматизации и доработок. Ввод на основании внутреннего документа из задачи согласование с переносом прикрепленных файлов(копировать и вставить файлы). ПФ Лист согласования для процесса Согласование и для справочника Внутренние документы(печатается с историей). Автоматическая загрузка справочника по com-соединению из другой базы.

А) введение

Б) публикация на IIS, исправление ошибок, настройка браузера

В) Автоматизация процесса согласования и доработка:

 в1) Этапы согласования

 в2) Скопировать\вставить файлы, “ввод на основании” Внутреннего документа из Задачи с переносом прикрепленных файлов

 в3) Другие доработки

P.S. Изначально я хотел написать только про пункт в2, но статья получилась очень маленькой и пришло в голову такое решение.


1. Начало


Есть на работе база ДО, в которой работают несколько человек и заносят договоры и прикрепляют к ним файлы. Реестр договоров в общем. Появилась задача автоматизировать процесс согласования договоров по всем отделам.

Знакомство с ДО началось с обновления 1.2.4.3 до 2.1.10.2 - Начало!

В итоге обновление пошло по следующей схеме:

1.2.4.3 > 1.2.8.1 (21.02.2013)  > 1.4.8.3 (19.02.2015)  > 1.4.13.1 (09.09.2015)  > 2.1.10.2 (30.03.2017)

После перехода на другую редакцию, визуально конечно кардинально все поменялось в плане интерфейса и функционала, а также приятно менялась заставка запуска:

1.2.4.3

1.4.8.3

2.1.10.2

Далее тестирование и исправление, после чего больше ошибок не было и получилась нормальная рабочая база последнего релиза (видимо повезло). Сделал это для того чтобы приходили различные уведомления из 1с на почту сотрудникам. Ибо в версии 1.2.4.3 по каким-то причинам это не получилось настроить. Не хотело работать и все тут.

Далее нужно было сделать возможность работать в web интерфейсе из любого места.


2. Публикация 1с на web-сервере IIS


2.1 Публикация


Настроить как в публикации //infostart.ru/public/275820/?ID=275820 и похожим способом у меня по каким то причинам не вышло и решение было следующим. Публикуем на веб-сервере IIS с использованием компоненты webinst от 1с.

Справка по webinst:

Для публикации на удаленном компьютере можно также использовать утилиту webinst. Данная утилита должна запускаться из каталога двоичных файлов платформы (для ее запуска требуется наличие динамических библиотек, входящих в состав платформы):

Публикация:

webinst [-publish] websrv -wsdir VirtualDir -dir Dir -connstr connStr [-confPath confPath] [-osauth]

Удаление публикации:

webinst -delete websrv -wsdir VirtualDir [-dir Dir] [-connstr connStr] [-confPath confPath]

-publish – опубликовать (ключ по умолчанию);

-delete – удалить публикацию;

websrv – тип веб-сервера. Может принимать следующие значения:

• iis – публикация веб-клиента для IIS;

• apache2 – публикация веб-клиента для Apache 2.0;

• apache22 – публикация веб-клиента для Apache 2.2;

-wsdir VirtualDir – виртуальный каталог;

-dir Dir – физический каталог, в который будет отображен виртуальный каталог;

-connstr connStr – строка соединения информационной базы;

-confPath confPath – полный путь к конфигурационному файлу Apache (только для публикации на Apache);

-osauth – использование Windows авторизации (только для IIS);

–descriptor <путь к vrd файлу> – указывает новый файл-дескриптор публикации. При публикации существующий vrd файл полностью переписывается указанным. Если в вызове утилиты указаны также ключи –wsdir и/или –connstr, их значения перекрывают значения полей vrd-файла base и ib соответственно. Если указан ключ –delete, ключ –descriptor используется для получения имени публикации (поле base vrd-файла) и проверки строки соединения (проверка, что по этому имени опубликована требуемая база). Должен использоваться именно файл-дескриптор публикации. 

Через командную строку необходимо перейти в каталог с файлом webinst:

cd C:\Program Files (x86)\1cv8\8.3.9.2170\bin

Далее вводим команду:

webinst -publish -iis -wsdir Base1C -dir c:\inetpub\wwwroot\Base1C\ -connstr "Srvr=192.168.2.3;Ref=Base1C;"

Почти все готово. Но кое-что нужно сделать еще.


2.2 Появляются ошибки в web-клиенте «Обнаружено потенциально опасное значение Request.Path, полученное от клиента» и «Runtime Error»


Решение изложено вот тут http://forum.infostart.ru/forum9/topic72212/ , а именно

Алгоритм решения проблемы следующий:

1. Открываем Диспетчер служб IIS.

2. Открываем наш «сайт»

3. Идем в сопоставления обработчиков

4. Ищем ISAPI-dll, выделяем строку.

5. Справа нажимаем «Изменить»

6. Меняем путь запроса с «*.dll» на «*», Исполняемый файл (у Вас может быть другая версия 1С) — «C:\Program Files (x86)\1cv8\8.3.5.1248\bin\wsisapi.dll» :

7. Ок

8. Все работает.


2.3 Настройка браузера


- В браузере нужно отключить блокировку всплывающих окон что бы не возникало ошибок при уведомлениях 1с.

- так же можно установить “Расширение для работы с 1с” для Яндекс браузера и Google Chrome https://chrome.google.com/webstore/detail/extension-for-working-wit/pbhelknnhilelbnhfpcjlcabhmfangik?hl=ru&gl=RU

Вот теперь все заработало как надо.


3. Автоматизация процесса согласования и доработка


Тут я опишу этапы согласования и доработки по ходу рассказа.

В итоге, утвержденный руководством регламент выглядит следующим образом:

                        

В общем поехали.

1 – Инициатор(сотрудник отдела) в программе создает процесс согласования по настроенному шаблону:

Непосредственный руководитель автора процесса и Начальник юридического отдела по очереди. И прикрепляет перечень учредительных документов к процессу.

Это первый этап согласования договора. Инициатор согласовывает заявку на договор с Руководителем отдела. После подтверждения Руководителем, согласование автоматически передается Начальнику юридического отдела для дальнейших действий.

2 – Начальник юр. отдела в моем случае либо одобряет и создает внутренний документ, либо перенаправляет задачу своему подчиненному (ответственный юр. отдела).

Тут встала задача автоматизировать этот этап, потому что много времени уходит на ручной перенос прикрепленных файлов из задачи в договор.

Понадобилось реализовать следующую идею: из задачи согласование нужно создать внутренний документ(договор) и перенести прикрепленные файлы задачи. Что то вроде "ввода на основании" с переносом прикрепленных файлов.

Были добавлены кнопки Создать договор, Скопировать и Вставить файлы в форму ФормаЗадачиИсполнителя (Бизнес-процессы > Согласование). А так же соответствующие им команды.

Далее в модуле формы пишем следующий код для кнопок:

// РАБОТА С ФАЙЛАМИ И СОЗДАНИЕ ДОГОВОРА С ВЛОЖЕНИЯМИ ИЗ ЗАДАЧИ

// ЭТО КНОПКА СОЗДАТЬ ДОГОВОР
&НаКлиенте
Процедура СоздатьДоговор(Команда)	
// Нажмем на кнопку "Согласовано" и напишем комментарий в задаче
Если  Объект.РезультатВыполнения = "" Тогда
    Объект.РезультатВыполнения = "Предварительный договор рассмотрен.";
КонецЕсли;
	ОписаниеОповещения = Новый ОписаниеОповещения(
		"ПродолжениеВыполненияЗадачиСогласованоПослеВыбораФактическогоИсполнителя", ЭтаФорма);	
	РаботаСБизнесПроцессамиКлиент.ВыбратьИсполнителяЗадачи(
		ЭтаФорма,
		Объект.Исполнитель,
		ТекущийПользователь,
		ФактическийИсполнительЗадачи,
		ОписаниеОповещения);		
//-------------------------------------------	
	НовыйВнутреннийДокумент = ПереносФайловНаСервере();
	ПараметрыФормы = Новый Структура("Ключ", НовыйВнутреннийДокумент);
	ФормаНовогоВнутреннегоДокумента = ОткрытьФорму("Справочник.ВнутренниеДокументы.ФормаОбъекта",ПараметрыФормы);
	ФормаНовогоВнутреннегоДокумента.Открыть();
	ЭтаФорма.ОбновитьОтображениеДанных();	
КонецПроцедуры

&НаСервере
Функция СоздатьДоговорНаСервере()

// Создаем новый договор
	НовыйВнутреннийДокумент = Справочники.ВнутренниеДокументы.СоздатьЭлемент();
	НовыйВнутреннийДокумент.Заголовок     = "Договор: " + ЭтаФорма.Объект.Наименование;
	НовыйВнутреннийДокумент.Наименование  = НовыйВнутреннийДокумент.Заголовок;
	НовыйВнутреннийДокумент.Ответственный = ЭтаФорма.Объект.Автор;
	НовыйВнутреннийДокумент.Подготовил = ТекущийПользователь;
	Если Справочники.ПапкиВнутреннихДокументов.НайтиПоНаименованию("Договоры") <> Неопределено И
	     Справочники.ВидыВнутреннихДокументов.НайтиПоНаименованию("Договор") <> Неопределено Тогда
	  НовыйВнутреннийДокумент.Папка = Справочники.ПапкиВнутреннихДокументов.НайтиПоНаименованию("Договоры");
	  НовыйВнутреннийДокумент.ВидДокумента = Справочники.ВидыВнутреннихДокументов.НайтиПоНаименованию("Договор");
    КонецЕсли;
    НовыйВнутреннийДокумент.Состояние = Перечисления.СостоянияДокументов.НаСогласовании;
	НовыйВнутреннийДокумент.ДатаРегистрации = ТекущаяДата();
	НовыйВнутреннийДокумент.Записать();	
	Для Каждого ИдентификаторСтроки Из Элементы.ДеревоПриложений.ВыделенныеСтроки Цикл
		КопируемаяСтрока = ДеревоПриложений.НайтиПоИдентификатору(ИдентификаторСтроки);
		СсылкаНаФайл = КопируемаяСтрока.Ссылка.ПолучитьОбъект();
		СсылкаНаФайл.ВладелецФайла = НовыйВнутреннийДокумент.Ссылка;
		СсылкаНаФайл.Записать();
	КонецЦикла;	
	Возврат НовыйВнутреннийДокумент.Ссылка;
КонецФункции // ПереносФайловНаСервере()

// ЭТО КНОПКА СКОПИРОВАТЬ ФАЙЛЫ
&НаКлиенте
Процедура СкопироватьСтроки(Команда)
	
	ЧислоФайлов = 0;
	СкопироватьСтрокиНаСервере(ЧислоФайлов);
	
	Если ЧислоФайлов <> 0 Тогда
		
		ПолноеОписание = СтрШаблон(
			НСтр("ru = 'Файлы (%1 шт) скопированы в буфер обмена.'"), ЧислоФайлов);
		
		ПоказатьОповещениеПользователя(
			НСтр("ru = 'Копирование в буфер'"),
			,
			ПолноеОписание,
			БиблиотекаКартинок.Информация32);			
	КонецЕсли;	
КонецПроцедуры

&НаСервере
Процедура СкопироватьСтрокиНаСервере(ЧислоФайлов)	
	ЧислоФайлов = Элементы.ДеревоПриложений.ВыделенныеСтроки.Количество();	
	ОбщегоНазначения.СкопироватьФайлыВБуферОбменаИзТаблицыФайлы(ДеревоПриложений, Элементы.ДеревоПриложений.ВыделенныеСтроки);
	Элементы.ВставитьСтроки.Доступность = Истина;	
КонецПроцедуры

// ЭТО КНОПКА ВСТАВИТЬ ФАЙЛЫ
&НаКлиенте
Процедура ВставитьСтроки(Команда)
	
	Если Модифицированность Тогда
		Если НЕ Записать() Тогда
			Возврат;
		КонецЕсли;
	КонецЕсли;
	
	ЧислоФайлов = 0;
	ВставитьСтрокиНаСервере(ЧислоФайлов);
	
	Если ЧислоФайлов <> 0 Тогда
		
		ПолноеОписание = СтрШаблон(
			НСтр("ru = 'Файлы (%1 шт) вставлены из буфера обмена.'"), ЧислоФайлов);
		
		ПоказатьОповещениеПользователя(
			НСтр("ru = 'Вставка из буфера'"),
			,
			ПолноеОписание,
			БиблиотекаКартинок.Информация32);			
	КонецЕсли;	
КонецПроцедуры

&НаСервере
Процедура ВставитьСтрокиНаСервере(ЧислоФайлов)	
	Если ОбщегоНазначения.ПустойБуферОбмена() Тогда
		Возврат;
	КонецЕсли;	
	ДанныеИзБуфераОбмена = ОбщегоНазначения.СтрокиИзБуфераОбмена();
	МассивФайлов = ДанныеИзБуфераОбмена.Данные;	
	ЧислоФайлов = МассивФайлов.Количество();	
	РаботаСФайламиВызовСервера.СкопироватьФайлВПриложенных(МассивФайлов, Объект.Ссылка);	
	ЗаполнитьСписокФайлов();
	Модифицированность = Ложь;	
КонецПроцедуры

// Заполняет список файлов в карточке документа
//
//	Параметры
//		ЗаполнитьПризнакОригинал - Булево - если Истина, то будет заполнен признак оригинала
//
&НаСервере
Процедура ЗаполнитьСписокФайлов(ЗаполнитьПризнакОригинал = Ложь)	
	Делопроизводство.ЗаполнитьСписокФайловДокумента(ЭтаФорма, ЗаполнитьПризнакОригинал);	
КонецПроцедуры

3 – Дальнейшие действия: заполнить договор необходимой информацией (контрагент, сумма и т.д.).

Так как Инициатор договора должен контролировать процесс изменения договора и процесса согласования, то в карточке Ответственный заполняется из задачи автоматически. Нужно только его подписать на договор.

Тут сделал просто, на форму вынес кнопку Подписать, по нажатию на которую происходит следующее:

Автоматически подставляется Инициатор из договора(ответственный), а так же проставляются необходимые события для контроля(в моем примере "Изменился внутренний документ"):

Процедура Подписаться(Команда)	
	Если ЗначениеЗаполнено(Объект.Ссылка) Тогда
		ПараметрыФормы = Новый Структура("ОбъектПодписки", Объект.Ссылка);
		ФормаПодписки = ОткрытьФорму("ОбщаяФорма.ПодпискаНаУведомленияПоОбъекту", ПараметрыФормы);
	// Ponomarev -->
	Если ЗначениеЗаполнено(ЭтаФорма.Объект.Ответственный) Тогда  			
		ФормаПодписки.Заголовок = "Инициатор для контроля договора: " + ЭтотОбъект.Объект.Ответственный;
		ФормаПодписки.Элементы.Пользователь.Родитель.Родитель.Пользователь = ЭтаФорма.Объект.Ответственный;
	   Для Каждого Строка из ФормаПодписки.ПодпискиУведомлений Цикл
		Если Строка.Представление = "Изменился внутренний документ" Тогда
 	    	 // значения(1-да, 2-нет). Тип - число
                 Строка.ПоПочте = 1;
                 Строка.Окном   = 1;
                 // надпись (Да или Нет). Тип - строка
                 Строка.ПоПочтеСтрокой = Истина;
                 Строка.ОкномСтрокой   = Истина;
		КонецЕсли;
	   КонецЦикла;
	Иначе
	//  ФормаПодписки.Закрыть();
	//  Сообщить("Обязательно укажите Инициатора в карточке договора для подписки на уведомления.");	  
       КонецЕсли;
      // <-- Ponomarev		
	КонецЕсли;	
КонецПроцедуры

4 – Ответственный юр. отдела начинает процесс согласования нового договора по шаблону и при необходимости добавляет\удаляет участников.

В процессе Согласование добавил кнопку Подписать и реквизит Ответственный(Инициатор), который должен заполниться автоматически, но пока не сделал!

Код кнопки такой же как выше, только отмечаем все события:

&НаКлиенте
Процедура Подписаться(Команда)	
// Ponomarev	
	//Если ЗначениеЗаполнено(Объект.Ссылка) Тогда
	//	ПараметрыФормы = Новый Структура("ОбъектПодписки", Объект.Ссылка);
	//	ОткрытьФорму("ОбщаяФорма.ПодпискаНаУведомленияПоОбъекту", ПараметрыФормы);
	//КонецЕсли;
	Если ЗначениеЗаполнено(Объект.Ссылка) Тогда
		ПараметрыФормы = Новый Структура("ОбъектПодписки", Объект.Ссылка);
		ФормаПодписки = ОткрытьФорму("ОбщаяФорма.ПодпискаНаУведомленияПоОбъекту", ПараметрыФормы);			
	 Если ЗначениеЗаполнено(ЭтаФорма.Объект.Ответственный) Тогда  			
		ФормаПодписки.Заголовок = "Инициатор для контроля договора: " + ЭтотОбъект.Объект.Ответственный;
		ФормаПодписки.Элементы.Пользователь.Родитель.Родитель.Пользователь = ЭтаФорма.Объект.Ответственный;
		Для Каждого Строка из ФормаПодписки.ПодпискиУведомлений Цикл
		 // значения(1-да, 2-нет). Тип - число
                 Строка.ПоПочте = 1;
                 Строка.Окном   = 1;
                 // надпись (Да или Нет). Тип - строка
                 Строка.ПоПочтеСтрокой = "Да"; 
                 Строка.ОкномСтрокой   = "Да";
		КонецЦикла;
         КонецЕсли;  
        КонецЕсли;	
КонецПроцедуры

5 – После завершения процесса согласования Ответственный юр. отдела передает распечатанный договор и Лист согласования(печатает его из Процесса или из карточки договора, в прикрепленных файлах есть внешние ПФ(печатается с историей если есть)) офис менеджеру. Измененный Лист согласования выглядит так:

Офис менеджер меняет статус договора(На утверждении) и передает Генеральному директору на подпись.

Потом меняет статус(Утвержден) и указывает кем подписан договор.

Если договор не подписан со стороны Контрагента ставиться статус(Отправлен контрагенту), а если обе стороны подписали, то статус(Отправлен в архив).

Тут пришлось добавить эти статусы в перечисления СостоянияДокументов и изменить код модуля формы элемента внутреннего документа:

	// Список состояний
	СписокСостояний.Добавить(Перечисления.СостоянияДокументов.Проект);
	СписокСостояний.Добавить(Перечисления.СостоянияДокументов.НаСогласовании);
	СписокСостояний.Добавить(Перечисления.СостоянияДокументов.Согласован);
	СписокСостояний.Добавить(Перечисления.СостоянияДокументов.НеСогласован);
	СписокСостояний.Добавить(Перечисления.СостоянияДокументов.НаУтверждении);
	СписокСостояний.Добавить(Перечисления.СостоянияДокументов.Утвержден);
	СписокСостояний.Добавить(Перечисления.СостоянияДокументов.НеУтвержден);
	СписокСостояний.Добавить(Перечисления.СостоянияДокументов.НаРегистрации); 	
	// Ponomarev -->
СписокСостояний.Добавить(Перечисления.СостоянияДокументов.ОтправленКонтрагенту);
СписокСостояний.Добавить(Перечисления.СостоянияДокументов.ОтправленВАрхив);  
	// <-- Ponomarev

На этом процесс согласования завершен.


4. Другие доработки


1) Захотелось добавить больше информационных данных во внутренний документ. Решено было добавить реквизит Код затрат, таблицу Коды проекта, которую вынес в список внутренних документов. Данные берутся из добавленных справочников КодЗатрат и КодПроекта, причем последний должен синхронизироваться со справочником из бухгалтерской базы(БП). Теперь обо всем поподробнее:

КодПроекта:

Реквизиты: КодИзБП(Строка,9); GUID(Строка,50); Комментарий(Строка,100)

Формы: ФормаЭлемента, ФормаСписка, ФормаВыбора

Добавил общий модуль ПодргузкаИзБП, а в нем Процедуру ПодгрузитьКодПроекта, с помощью которой происходит подсоединение к базе по COM и сравнивнение GUID в базе-приемнике с GUID в базе-источнике и если такого нет, то создается новый элемент. В моем случае нужно было синхронизовать справочник КодПроекта и ПодразделенияОрганизации из БП 2.0:

Процедура ПодгрузитьКодПроекта()Экспорт	
	 cntr = Новый COMObject("V83.COMConnector");	 
	 КаталогБазыДанных = "\\---\Buh2014";
	 Пользователь = "Админ";
         Пароль = "----";
     TheConnectionString = "file='" + КаталогБазыДанных + "'; usr='" + Пользователь + "'; pwd='" + Пароль + "'";
	 
	 connection = cntr.Connect(TheConnectionString);
	 
	 Запрос = connection.NewObject("Запрос");
	 Запрос.Текст = "ВЫБРАТЬ
	 |	ПодразделенияОрганизаций.Ссылка,
	 |	ПодразделенияОрганизаций.Наименование,
	 |	ПодразделенияОрганизаций.Код,
	 |	ПодразделенияОрганизаций.Родитель 
	 |ИЗ
	 |	Справочник.ПодразделенияОрганизаций КАК ПодразделенияОрганизаций
	 |ГДЕ
	 |	НЕ ПодразделенияОрганизаций.ПометкаУдаления";
	 
	 РезультатЗапроса = Запрос.Выполнить();
	 
	 СпрОбъект = РезультатЗапроса.Выбрать(); 
	 ТабЗн = Новый ТаблицаЗначений;
	 ТабЗн.Колонки.Добавить("Ссылка");
	 ТабЗн.Колонки.Добавить("Код",Новый ОписаниеТипов("Строка",, Новый КвалификаторыСтроки(9)));
	 ТабЗн.Колонки.Добавить("Наименование",Новый ОписаниеТипов("Строка",, Новый КвалификаторыСтроки(100)));
	 ТабЗн.Колонки.Добавить("GUID",Новый ОписаниеТипов("Строка",, Новый КвалификаторыСтроки(50)));
	 ТабЗн.Колонки.Добавить("Родитель",Новый ОписаниеТипов("Строка",, Новый КвалификаторыСтроки(100))); 	 
	 
	 Пока СпрОбъект.Следующий() Цикл 		 
		 НоваяСтрока = ТабЗн.Добавить();
		 НоваяСтрока.Ссылка       = СпрОбъект.ref;
		 НоваяСтрока.Код          = СпрОбъект.code;
		// НоваяСтрока.Родитель = Connection.String(СпрОбъект.ref.Parent);
		 НоваяСтрока.Родитель     = СпрОбъект.Parent.Description;
		 НоваяСтрока.Наименование = СпрОбъект.description;
		 НоваяСтрока.GUID         = Connection.String(СпрОбъект.ref.UUID());
	 КонецЦикла;
	 connection = Неопределено;
	 ТабДог.Сортировать("Родитель Возр");
	 Запрос2 = новый Запрос;
	 Запрос2.Текст = "ВЫБРАТЬ
	                 |	Таб.Код КАК Код,
	                 |	Таб.Родитель КАК Родитель,
	                 |	Таб.Наименование КАК Наименование,
	                 |	Таб.GUID КАК GUID
	                 |ПОМЕСТИТЬ ВТДанные
	                 |ИЗ
	                 |	&Данные КАК Таб
	                 |;
	                 |
	                 |//////////////////////////////////////////////////////////////////////
	                 |ВЫБРАТЬ
	                 |	КодПроекта.GUID,
	                 |	КодПроекта.Родитель
	                 |ПОМЕСТИТЬ ВТ_КП
	                 |ИЗ
	                 |	Справочник.КодПроекта КАК КодПроекта
	                 |;
	                 |
	                 |//////////////////////////////////////////////////////////////////////
	                 |ВЫБРАТЬ
	                 |	ВТ_КП.GUID,
	                 |	ВТДанные.Код КАК Код,
	                 |	ВТДанные.Наименование КАК Наименование,
	                 |	ВТДанные.GUID КАК GUID1,
	                 |	ВТДанные.Родитель КАК Родитель
	                 |ИЗ
	                 |	ВТДанные КАК ВТДанные
	                 |		ЛЕВОЕ СОЕДИНЕНИЕ ВТ_КП КАК ВТ_КП
	                 |		ПО ВТДанные.GUID = ВТ_Дог.GUID";
	 
	 Запрос2.УстановитьПараметр("Данные",ТабЗн);
	 Результат = Запрос2.Выполнить();
	 
	 Выборка = Результат.Выбрать();
	 
	 кол = 0;
	 Пока Выборка.Следующий() Цикл		 
		 Если Выборка.GUID = Null Тогда
			 Спр = Справочники.КодПроекта.СоздатьЭлемент();
			 Спр.КодИзБП      = Выборка.Код;
			 Спр.Наименование = Выборка.Наименование;
			 Спр.GUID         = Выборка.GUID1;
			 Спр.Родитель     = Выборка.Родитель; 
                         Спр.Комментарий  = Выборка.Родитель; 
			 Спр.Записать();
			 Сообщить(Спр.Наименование);
			 кол = кол + 1;
		 КонецЕсли;	 
	 КонецЦикла;
	 Сообщить("Всего загружено: " + кол + " элементов");	 
КонецПроцедуры

Код кнопки:

&НаСервере
Процедура ЗагрузкаКодовПроектаНаСервере()	
	ПодгрузкаИзБП.ПодгрузитьКодПроекта();	
КонецПроцедуры

&НаКлиенте
Процедура ЗагрузкаКодовПроекта(Команда)	
	ЗагрузкаКодовПроектаНаСервере();	
КонецПроцедуры

Далее я сделал Решламентное задание ПодгрузкаНовыхКодовПроектаИзБП, указав Имя метода ПодгрузкаИзБП.ПодгрузитьКодПроекта и установил галочку Предопределенное, что бы мое задание появилось в списке заданий в базе. Справочник выглядит вот так:

Для того, чтобы показать таблицу Коды проекта в списке внутренних документов(ВнутренниеДокументы > ФормаСпискаСПапками), нужно изменить запрос:

В итоге получим вид:

2) Далее начальству пришла в голову мысль, чтобы у руководителей отделов на кнопке вместо согласовано было написано рассмотрено. Ок. Добавил роль ЗаменаСогласованоНаРассмотрено и изменил код двух модулей и заодно создал еще одну роль СогласоватьИСоздатьДоговор, которую прицепил к сотрудникам юр. отдела что бы только они видели кнопку Создать договор(об этом речь шла выше):

  • Бизнес-Процессы --> Согласование --> форма  ФормаЗадачиИсполнителя --> Модуль
// Ponomarev -->
&НаСервере
Процедура ПриОткрытииНаСервере()
     Если РольДоступна("ЗаменаСогласованоНаРассмотрено") Тогда 		 
	  ЭтотОбъект.Элементы.СогласованоСЗамечаниями.Заголовок = "Рассмотрено с замечаниями";
	  ЭтотОбъект.Элементы.Согласовано.Заголовок             = "Рассмотрено";
	  ЭтотОбъект.Элементы.НеСогласовано.Заголовок           = "Не рассмотрено";	 
     КонецЕсли;   
     Если РольДоступна("СогласоватьИСоздатьДоговор") Тогда 
	  ЭтаФорма.Элементы.ВРаботу.Видимость = Истина;
	  ЭтаФорма.Элементы.ГруппаРаботаСФайлами.Доступность = Истина;
	  ЭтаФорма.Элементы.Help.Видимость = Истина;
     Иначе
	  ЭтаФорма.Элементы.ВРаботу.Видимость = Ложь;
	  ЭтаФорма.Элементы.ГруппаРаботаСФайлами.Доступность = Ложь;
	  ЭтаФорма.Элементы.Help.Видимость = Ложь;
     КонецЕсли;		 
КонецПроцедуры // <-- Ponomarev

&НаКлиенте
Процедура ПриОткрытии(Отказ)	
	Оповестить("ОбновитьСписокПоследних");	
	 Если ЭтотОбъект.Элементы.ОтменитьВыполнение.Видимость = Истина Тогда 
	      ЭтотОбъект.Элементы.ВРаботу.Видимость = Ложь;
		  ЭтотОбъект.Элементы.Help.Видимость    = Ложь;
	 КонецЕсли;

	ПриОткрытииНаСервере(); // Ponomarev

КонецПроцедуры
  • Задачи -->  форма ЗадачиМне --> Модуль (тут делаем по аналогии)
// Ponomarev -->
&НаСервере
Процедура ПриОткрытииНаСервере()	
     Если РольДоступна("ЗаменаСогласованоНаРассмотрено") Тогда		 
	 ЭтотОбъект.Элементы.СогласованоСЗамечаниями.Заголовок = "Рассмотрено с замечаниями";
	 ЭтотОбъект.Элементы.Согласовано.Заголовок             = "Рассмотрено";
	 ЭтотОбъект.Элементы.НеСогласовано.Заголовок           = "Не рассмотрено"; 	 
     КонецЕсли;	
КонецПроцедуры // <-- Ponomarev

&НаКлиенте
Процедура ПриОткрытии(Отказ)	
	УстановитьТекущееЗначениеГруппировкиЗадачМне();	
	#Если Не ВебКлиент Тогда
		УстановитьАвтообновлениеФормы();
	#КонецЕсли	
	ЗаполнитьПараметрыСохраненияКомментарияЗадачи(ЭтаФорма);	
	ПриОткрытииНаСервере(); // Ponomarev	
КонецПроцедуры

3) Изменена форма Задачи мне – для удобства добавлена кнопка Ход согласования.

Кнопка:

&НаКлиенте
Процедура История(Команда)	
Если ЭтаФорма.ТекущийЭлемент.ТекущиеДанные = НЕОПРЕДЕЛЕНО
	ИЛИ ЭтотОбъект.ТекущийЭлемент.ТекущаяСтрока = 0 Тогда
 Сообщить("Выберите в списке задачу. Бизнес процесс задачи не определен.");	
Иначе
 ЗадачаСсылка        = ЭтаФорма.ТекущийЭлемент.ТекущаяСтрока;
 БизнесПроцессСсылка = ЭтаФорма.ТекущийЭлемент.ТекущиеДанные.БизнесПроцесс;
 ПараметрыФормы = Новый Структура;
 ПараметрыФормы.Вставить("ЗадачаСсылка",  ЭтаФорма.ТекущийЭлемент.ТекущаяСтрока);
 ЭтаФорма.ТолькоПросмотр = Истина;
 ПараметрыФормы.Вставить("ТолькоПросмотр", ЭтаФорма.ТолькоПросмотр);	
	
  Если ТипЗнч(БизнесПроцессСсылка) = Тип("БизнесПроцессСсылка.Согласование") Тогда 
    ФРМ = ПолучитьФорму("БизнесПроцесс.Согласование.Форма.ФормаИсторияСогласования", ПараметрыФормы);
    ДанныеФормы = ФРМ.ЭтотОбъект;      
    ФРМ.Открыть();
  Иначе
    Сообщить("это не Согласование, а " + ТипЗнч(БизнесПроцессСсылка));
  КонецЕсли;
КонецЕсли;
КонецПроцедуры

4) Изменена форма Все задачи – добавлена информация о договоре и кнопка ход согласования(Код такой же как выше).

Для возможности добавить информацию о договоре, нужно изменить запрос(Задачи > ФормаСписка). После этого нужно добавить необходимые поля на форму. Я не стал здесь показывать что и где нужно изменить, можете скачать конфигурацию и посмотреть все изменения.


После всего этого в базе стало работать много сотрудников что отразилось на производительности. Спас web-интерфейс, благодаря которому не наблюдается тормозов 1с.

В итоге получилась вроде бы нормальная автоматизация, отвечающая утвержденному регламенту. На этом все.

Надеюсь данная статья и доработки будут кому нибудь интересны и полезны.


P.S.S. В прикрепленных файлах если кому пригодится – руководство по согласованию для новичков(потому что пришлось детально все описать для пользователей, которые 1с никогда не видели), конфигурация и  две ВПФ Лист согласования(работают в ПРОФ и КОРП 2.1).

Для справки, сервер из себя представляет следующую конфигурацию:

- Intel® Core™ 2 Quad CPU Q8200 2.33 GHz; 4 Gb RAM

- Windows Server 2008 R2 Standard

- MS SQL Server 2008 + 1с 8.3.9.2170 + одна база ДО (~ 15 ГГ)


Спасибо за внимание!


Обновление 26.04.2018:

  • Добавлены еще 2 печатные формы в архив для процесса(1 - заголовок берется из процесса; 2 - с колонкой срок выполнения и просрочка)
  • У печатных форм добавил Размещение при регистрации и изменил имена файлов в архиве что бы не путаться.
23

Скачать файлы

Наименование Файл Версия Размер
Четыре ПФ Лист согласования: для справочника ВнутренниеДокументы и для Процесса(3 шт.) с историей
.zip 63,40Kb
26.04.18
16
.zip 63,40Kb 16 Скачать
Конфигурация с описанными изменениями и Руководство по работе с программой и процесс согласования договора
.7z 53,65Mb
04.07.17
9
.7z 53,65Mb 9 Скачать

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. botokash 76 04.07.17 13:49 Сейчас в теме
то пришлось поискать на просторах интернета обновления

На сайте партнера 1С звучит не комильфо)
5. SPonomareff 69 05.07.17 10:28 Сейчас в теме
(1) За это извиняюсь. Но не оказалось подписки, а делать что то нужно было.
2. ilya.rudziak 29 04.07.17 14:05 Сейчас в теме
Скрины из 1.3 а какая версия БД в
"Конфигурация с описанными изменениями и Руководство по работе с программой и процесс согласования договора" ?
4. SPonomareff 69 05.07.17 10:25 Сейчас в теме
(2) Я делал все изменения на версии 2.1.10.2 ПРОФ и руководство по ней писал. Может случайно скришоты не те вставил.
6. SPonomareff 69 05.07.17 15:07 Сейчас в теме
(2) Совсем забыл написать - у конфигурации включен режим совместимости интерфейса с 8.2
7. user766040 14.11.17 13:27 Сейчас в теме
Приветствую! Ваша разработка будет работать в ДО 2.1.10.2 КОРП?
9. SPonomareff 69 15.11.17 12:26 Сейчас в теме
(7) Добрый день!

Разработки и печатные формы будут работать и на ПРОФ и на КОРП. На данный момент у меня работает на КОРП 2.1.11.5.
Если будут какие то вопросы, то пишите. С радостью помогу.
8. CyberBob 3 15.11.17 11:59 Сейчас в теме
Особенно понравилась кнопка "Не рассмотрено".)
10. rti30 25.04.18 11:55 Сейчас в теме
SPonomareff,
Платформа 8.3.10.2580, редакция 2.1.11.5, режим совместимости 8.3.8 на поддержке. Будут внешние ПФ формы листа согласования открываться? ФормуЗадачиИсполнителя и изменения в Общем модуле вы через "расширение" реализовали?
13. SPonomareff 69 26.04.18 10:23 Сейчас в теме
(10) Добрый день!

Только что все перепроверил. В типовой конфигурации печатные формы работают.

Думаю над расширением.
11. SPonomareff 69 25.04.18 21:48 Сейчас в теме
Добрый вечер!

Все было реализовано именно изменением типовой конфигурации и до сих пор продолжает работать.

Печатные формы протестирую с Вашей конфигурацией и если что подкорректирую и завтра сообщю. Вообще должно все работать если убрать вывод в ПФ табличную часть Код проекта.

Я давно хотел сделать именно расширение. Если подождете, то я в майские праздники( или до них) попробую сделать расширение.
12. SPonomareff 69 25.04.18 21:56 Сейчас в теме
Хотя нет. Должно все работать и так! Я не выкладывал ПФ с учетом изменений. Но все равно завтра проверю.
14. user636714_elizarov.aleksey 25.05.18 18:07 Сейчас в теме
у меня начальство подобный "ход согласования" требует. и найти не могу кто бы взялся. пример того что нужно сделать




или может у кого есть готовый вариант. куплю!)))

код как по мне так слишком замудреный в ДО
15. SPonomareff 69 25.05.18 21:17 Сейчас в теме
Доброго времени суток!
Через час смогу посмотреть и сразу отвечу.
Оставьте свое сообщение

См. также

Вам нравятся запросы в 1С? 12

Инструменты и обработки Программист Конфигурация (md, cf) v8 v8::Запросы 1cv8.cf Абонемент ($m) Практика программирования Разработка

Речь не только о том, что простейший запрос с "легальным" оформлением растянется на пол-экрана, речь еще обо всем, что нужно написать "в нагрузку" к тексту запроса. Все эти "Новый Запрос", "УстановитьПараметр" и последующие пляски с обработкой результата... Пора с этим заканчивать!

1 стартмани

03.07.2019    8848    1    m-rv    70       

1С:Ассемблер. Немного летнего веселья! 282

Статья Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Практика программирования Разработка

Все вы, наверное, слышали, что 1С-ники жалуются на свою систему, считая язык 1С недостаточно низкоуровневым, скучным и т.п. Все они с тоской поглядывают в сторону "настоящих" языков программирования. Так вот, господа, они неправы. В системе 1С есть места, где можно размять программерский мозг и получить удовольствие от низкоуровневой техники. Предлагаю вам погрузиться в недра виртуальной машины 1С и понять, как она работает. Там есть свой "ассемблер" и мы попробуем его в действии!

1 стартмани

21.06.2019    12099    37    Evil Beaver    108       

Простые примеры сложных отчетов на СКД 230

Статья Программист Архив с данными v8 v8::СКД 1cv8.cf Абонемент ($m) Практика программирования Разработка

Подписи в отчете. Особенности соединения наборов: как соединить несоединяемое. Остатки на дату и обороты по месяцам в одном отчете. Курс валюты на каждую дату без группировок и соединений в запросе. Отчет с произвольными колонками и с произвольной последовательностью. "Неадекватный отчет".

1 стартмани

12.06.2019    10752    9    Hatson    21       

Безопасная работа с транзакциями во встроенном языке 183

Статья Программист Конфигурация (md, cf) v8 1cv8.cf Абонемент ($m) Практика программирования Разработка

Разбираемся с опасностями использования транзакций во встроенном языке 1С. Познаем ошибку "В данной транзакции уже происходили ошибки". Учимся защищаться от них.

1 стартмани

25.03.2019    13054    7    tormozit    35       

Коннектор: удобный HTTP-клиент для 1С:Предприятие 8 507

Инструменты и обработки Программист Конфигурация (md, cf) v8 1cv8.cf Абонемент ($m) Практика программирования Внешние источники данных WEB Универсальные функции Инструментарий разработчика Универсальные обработки

Коннектор - библиотека для работы с HTTP запросами. Библиотека берет на себя всю рутину работы с HTTP запросами. Буквально в одну строку можно получать данные, отправлять, не заботясь о необходимости конструирования URL, кодирования данных и т.п.

1 стартмани

31.01.2019    24572    242    bonv    100       

Работа с публикациями "Инфостарт" 13

Инструменты и обработки Программист Архив с данными v8 УУ Абонемент ($m) Практика программирования О сообществе WEB

Работа с рублевыми публикациями на сайте "Инфостарт": ведение клиентов, заказов, обновление файлов публикации, рассылка обновлений.

1 стартмани

13.09.2018    8051    10    RocKeR_13    12       

Позиционирование в помещении с помощью нейросети по сигналу Wi-Fi. Интерактивная карта склада в 1С с показом позиции 62

Инструменты и обработки Программист Бизнес-аналитик Приложение (apk) v8 Windows Абонемент ($m) Инструментарий разработчика Практика программирования

Данная публикация содержит в себе редактор и интерактивную карту склада или иного помещения, на которой в реальном времени отображается позиция устройства, координаты которого вычисляются по уровням сигнала нескольких роутеров Wi-Fi. В статье и приложенным к ней разработкам предлагаются инструменты и методика для реализации вычисления точной геопозиции внутри помещений с помощью нейронной сети. Конфигурация написана на релизе 1С:Предприятие 8.3.12.1412, клиентское приложение имеет минимальный уровень совместимости SDK -16.

5 стартмани

09.08.2018    14591    23    informa1555    26       

Работа с данными выбора 38

Инструменты и обработки Программист Архив с данными v8 Россия Абонемент ($m) Практика программирования Работа с интерфейсом

В управляемом интерфейсе заложена мощная возможность описывать связи реквизитов формы через параметры. Установка параметров связей позволяет ограничить выбор данных так, чтобы целостность данных была обеспечена на этапе ввода. Однако без дополнительного программирования задать можно только самые простые связи. Такие условия связи, как зависимость от реквизита через точку или зависимость через дополнительное отношение, заданное в регистре сведений - уже задать без программирования не получится.

1 стартмани

17.07.2018    19383    13    kalyaka    15       

HTTP Сервисы: Путь к своему сервису. Часть 1 257

Статья Системный администратор Программист Расширение (cfe) v8 1cv8.cf Абонемент ($m) Практика программирования WEB

Уже много было написано про http-сервисы, но то и дело всплывают «Новые» статьи по обмену между базами V8 по COM, что «Немножко» удивляет. Решил внести свои 5 копеек, поработаем с http-сервисом.

1 стартмани

15.07.2018    34492    15    dsdred    22       

ВСТАВИТЬ В Справочник.Номенклатура (Код, Наименование) ЗНАЧЕНИЯ ("001", "Новый товар") 105

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::Запросы 1cv8.cf Абонемент ($m) Практика программирования

Вас не обманывают ваши глаза, это запрос на изменение данных! И это работает без прямого доступа к БД, регистрации и смс.

1 стартмани

01.06.2018    18867    86    m-rv    57       

БСП: Дополнительная обработка (Регламенты), примеры от простого к сложному 236

Статья Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Практика программирования БСП (Библиотека стандартных подсистем)

Очень много попадается странных решений, которые можно решить через БСП:Дополнительные отчеты и обработки. Я бы вообще БСП из-за этой подсистемы переименовал в «Большое Спасибо Программистам». Поработаем с подсистемой в части написания регламентных заданий.

1 стартмани

10.05.2018    25923    24    dsdred    34       

Как выполнить отчет на СКД через COM и получить данные отчета? 85

Статья Программист Архив с данными v8 УПП1 Россия Windows Абонемент ($m) Практика программирования

Для чего это нужно. Например, нужно в одной базе получить какой-либо показатель из другой базы. Этот показатель вычисляется в каком-либо сложном отчете, который написан на СКД. Можно, конечно, "скопипастить" текст запроса из другой базы, немного подправить его и выполнять в том же COM подключении. Но с этим теряется гибкость: если отчет изменился, то нужно помнить о том, что где-то есть его "немного модифицированная" копия. В статье будет рассмотрен пример получения данных из базы ЗУП.

2 стартмани

08.05.2018    17098    10    wowik    3       

Работа со схемой запроса 169

Статья Программист Конфигурация (md, cf) v8 v8::Запросы Абонемент ($m) Инструментарий разработчика Практика программирования

Стандартом взаимодействия с реляционной базой данных стал язык SQL. Приемником SQL в 1С является язык запросов. Язык запросов, также как и SQL, является структурированным. Составляющие структуры запроса отвечают на разные вопросы о том, какие данные требуется получить и какие манипуляции с множествами данных необходимо произвести при получении. В простых случаях текст запроса можно написать вручную, однако в сложных случаях, а также при программном формировании, - лучше воспользоваться объектной моделью запроса и использовать объект "Схема запроса". В статье дается описание объектной модели и особенностей работы с ней, а также приводится решение, упрощающее взаимодействие с объектом "Схема запроса".

1 стартмани

24.04.2018    26947    70    kalyaka    34       

Заполняем по шаблону (по умолчанию) 68

Инструменты и обработки Программист Архив с данными v8 v8::УФ 1cv8.cf Абонемент ($m) Практика программирования

Простой в подключении, универсальный и достаточно удобный механизм заполнения реквизитов произвольных документов/справочников значениями по умолчанию. Реализован в расширении, но может быть и непосредственно включен практически в любую конфигурацию на управляемых формах простым копированием одной формы и двух команд. Весь код в статье.

1 стартмани

08.02.2018    17299    20    mvxyz    17       

Бесплатная проверка контрагентов в ФНС (общий модуль с алгоритмом). На примере выводим статус в список справочника контрагентов 122

Статья Программист Конфигурация (md, cf) v8 1cv8.cf Абонемент ($m) Практика программирования

Если вам интересно проверить контрагенте в ФНС, вам поможет данная публикация. Весь алгоритм работы строится на основе данных, полученных с сервиса http://npchk.nalog.ru совершенно бесплатно.

1 стартмани

01.02.2018    24170    61    rpgshnik    46       

Расширение возможностей печати: Вывод произвольного нижнего и верхнего колонтитула 8

Отчеты и формы Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Печатные формы документов Практика программирования Универсальные функции

Расширяем функционал вывода нижнего / верхнего колонтитула. Стандартно 1С имеет достаточно ограничений по выводу и наполнению колонтитулов содержимым, взять хотя бы такие, как вывод только текста и отсутствие ограничения на номер конечной страницы. А при разработке кода сталкиваешься с тем, что свой блок с нижним колонтитулом нужно прижимать к низу страницы. Казалось бы быстро решаемый вопрос, но и в нем есть нюансы. Сейчас я расскажу о том, как решалась эта задача. UPD 15.02.2018. Добавлен вывод верхнего колонтитула; Вывод колонтитулов на первой и последней странице управляется параметрами; Научился считать страницы: Добавлено заполнение переменных аналогичных стандартным из колонтитулов; Задаются форматы даты и времени. Ограничения прежние: 1. Повторно сформировать табличный документ после смены параметров страницы интерактивно.; 2. Передавать данные для более плотной печати как можно более мелко нарезанными кусками.

1 стартмани

29.12.2017    21227    21    agent00mouse    0       

Практика доступа в базу 1С через протокол oData. Чтение данных 274

Статья Системный администратор Программист Бизнес-аналитик Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Сервисные утилиты Практика программирования Администрирование данных 1С

Для чего нужен доступ в базу 1С через REST-интерфейс по протокол oData? Как его организовать? Как не будучи гуру в JavaScript и .NET получить быстрый визуальный доступ к данным базы 1С? Попробую дать ответ на эти вопросы и прокомментирую некоторые нюансы, с которыми я столкнулся.

1 стартмани

11.12.2017    54472    231    Dementor    42       

Печатная форма, сделанная как расширение конфигурации для БП 3.0. Новые возможности БСП 26

Инструменты и обработки Программист Расширение (cfe) v8 БП3.0 Абонемент ($m) Практика программирования Универсальные печатные формы

Печатные формы на внешних обработках скоро канут в лету. На смену им приходят ПФ, реализованные в виде расширений конфигурации. Не нашел на сайте примеров таких расширений. Привожу пример подобного расширения для БП 3.0.

1 стартмани

06.12.2017    17715    52    kwazi    6       

Простой бесплатный DashBoard с помощью http сервиса 256

Статья Программист Конфигурация (md, cf) v8 Абонемент ($m) Практика программирования

Как создать свой DashBoard без дополнительных затрат и сложных технических доработок.

1 стартмани

25.11.2017    43284    58    dewersia    32       

Макеты СКД 282

Статья Программист Внешний отчет (ert,erf) v8 v8::СКД 1cv8.cf Абонемент ($m) Практика программирования

Рассмотрены некоторые типовые задачи, которые решаются с помощью предопределенных макетов, а также перечислены несколько случаев, для которых макеты не подходят

1 стартмани

25.07.2017    67611    106    json    24       

Расширения конфигураций 1С: учимся перехватывать методы 110

Инструменты и обработки Программист Расширение (cfe) v8 v8::УФ 1cv8.cf Абонемент ($m) Практика программирования

В этой статье я на примерах разберу некоторые механизмы расширений конфигураций 1С. А именно «перехваты» методов модуля объекта и «перехваты» событий формы и элементов формы. Данная статья написана с учебными целями, чтобы показать, как при помощи расширений конфигурации можно делать такие доработки, ради которых раньше приходилось снимать конфигурацию с поддержки.

1 стартмани

30.05.2017    81254    14    signum2009    45       

Многопоточность. Универсальный «Менеджер потоков» (фреймворк) с отслеживанием зависимости объектов 175

Статья Программист Архив с данными v8 1cv8.cf Россия Абонемент ($m) Практика программирования Математика и алгоритмы Универсальные функции Производительность и оптимизация (HighLoad)

Восстановление партий, расчет зарплаты, пакетное формирование документов или отчетов - теперь все это стало доступнее. * Есть желание повысить скорость работы медленных алгоритмов! Но... * Нет времени думать о реализации многопоточности? * о запуске и остановке потоков? * о поддержании потоков в рабочем состоянии? * о передаче данных в потоки и как получить ответ из потока? * об организации последовательности? Тогда ЭТО - то что надо!!!

26.05.2017    38203    166    DarkAn    86       

Регулярные выражения – это просто. Построитель и отладчик регулярных выражений 181

Инструменты и обработки Программист Архив с данными v8 1cv8.cf Абонемент ($m) Инструментарий разработчика Практика программирования

Предлагается к использованию построитель регулярных выражений. Выполненный в виде внешней обработки, он позволит строить сложно-структурированные выражения на основе параметрического описания, тестировать их, и в результате получить программный код 1С.

1 стартмани

13.03.2017    22174    112    romasna    47       

Простой способ индексирования интервалов 180

Статья Программист Конфигурация (md, cf) v8 Абонемент ($m) Практика программирования

Предлагается простой способ индексирования интервалов для решения задач выборки записей, включающих заданный момент времени, пересекающихся с заданным интервалом или множеством интервалов. Способ основан на добавлении к исходной таблице особого числового индексированного поля, рассчитываемого по специальной формуле. Приведен код функций, необходимых для расчетов поля поиска и параметров поисковых запросов. Приведены также результаты тестирования метода, доказывающие его высокую эффективность.

1 стартмани

28.09.2016    31510    39    ildarovich    22       

1С: Предприятие + корпоративный чат, как наладить оперативные уведомления за 10 минут 61

Инструменты и обработки Системный администратор Программист Компонента, плагин (dll, vbs,..) v8 Windows Абонемент ($m) Практика программирования

Как сделать автоматические уведомления о разных событиях из 1С в корпоративный чат MyChat для сотрудников компании

1 стартмани

14.08.2016    37944    35    Demanoidos    60       

Хранение файлов в томах на диске (для УПП 1.3) 76

Инструменты и обработки Программист Архив с данными v8 УПП1 Windows Абонемент ($m) Практика программирования

Доработка типовой УПП 1.3 в плане хранения присоединенных файлов вне базы данных

2 стартмани

05.06.2016    43306    4    wowik    27       

БСП 2.3 и БСП 3.0: Просто про выполнение внешней обработки в фоне (c индикацией прогресса выполнения) 185

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) Инструментарий разработчика Практика программирования БСП (Библиотека стандартных подсистем)

Простое пояснение о том, как сделать внешнюю обработку с фоновым выполнением и индикацией процесса для любой конфигурации на основе БСП 2.3.2. UPDATE 20/09/19: добавлен вариант обработки с индикацией процента выполнения и статусом выполнения для БСП 3.0.

1 стартмани

18.05.2016    45379    136    rozer    52       

Остатки на каждый день в запросе 33

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf УУ Windows Учет ТМЦ Абонемент ($m) Практика программирования

Запрос формирует остатки товаров на каждый день в пределах выбранного периода.

1 стартмани

26.04.2016    33636    19    arakelyan    16       

Выполнение JavaScript кода из 1С в объекте Поле HTML Документа (HTML 5) и вызов события в 1С ПриНажатии 149

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Россия Windows Абонемент ($m) Практика программирования

Пример выполнения JS кода из 1С в Поле HTML Документа под управляемыми формами, с удобным получением результата в 1С(С помощью вызова привязанного события ПриНажатии к элементу ПолеHTMLДокумента)

1 стартмани

22.03.2016    59713    132    igo1    49       

Количество дней недели (понедельников/вторников/...) в заданном диапазоне одним запросом 28

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 Абонемент ($m) Практика программирования

При реализации периодического авто-заполнения маршрутных листов по графику (недельному) необходимо было просчитать стоимость всего периода, с условием выездов только по определенным дням. Заморачиваться с обходом результата не хотелось. Пришлось написать "Небольшой" запрос.

1 стартмани

03.03.2016    11866    1    Alexander.Shvets    5       

Простые радости жизни программиста 1С: выбор типа значения 51

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Практика программирования Работа с интерфейсом

Предлагаемая в работе обработка включает обычную и управляемую формы, которые максимально точно реализуют функциональность системного диалога выбора типа в толстом клиенте обычное приложение (включая оформление диалога). Эти формы имеют дополнительные интерфейсные удобства и могут быть использованы в качестве альтернативных диалогов выбора типа.

1 стартмани

17.02.2016    38424    45    yuraos    17       

Яндекс.Деньги "Благотворительность" 17

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) Инструментарий разработчика Практика программирования

Яндекс.Деньги теперь в 1С. Форма для приема благотворительных взносов. Форму легко сделать и вставить на любую страницу сайта или блога. Платежи будут приходить на ваш кошелек. На форме есть три способа платежа: из кошелька, с банковской карты, с баланса мобильного.

1 стартмани

16.02.2016    16932    9    Tatitutu    5       

Мастер рассылки e-mail 2.2 для управляемых форм 9

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::УФ ERP2 БП3.0 УТ11 Абонемент ($m) Практика программирования Email

Для пользователей: переделанный из старый разработки под 8.2 с использованием библиотеки Мастер рассылки e-mail 2.2 (ERP, УТ, БП) (Только управляемые формы), который теперь может запускаться под любой версией платформы с разрешенными или запрещенными модальными/синхронными вызовами в конфигурации. Также удобный выбор e-mail и их владельцев с помощью отбора динамического списка по любым критериям и галочки исключения.

1 стартмани

29.12.2015    30297    20    milkers    4       

Нечеткий поиск одним запросом 37

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Практика программирования

Использование механизма полнотекстового поиска в 1С не всегда оправдано, т.к. построение индекса и поддержание его в актуальном состоянии может значительно нагружать систему. Предлагаемая реализация нечеткого поиска методом N-грамм выполняется одним запросом, что позволяет производить поиск в любой таблице и не требует предварительного построения индекса.

1 стартмани

28.12.2015    18932    57    vasvl123    9       

Передача больших пакетов через веб-сервисы 136

Инструменты и обработки Системный администратор Программист Конфигурация (md, cf) v8 Абонемент ($m) Практика программирования Администрирование данных 1С Внешние источники данных

Реализация механизма передачи больших пакетов через веб-сервисы. С его помощью передать файл размером в несколько гигабайт не составит проблем.

1 стартмани

06.12.2015    40516    44    YPermitin    19       

Пример связи 1С и мессенджера Telegram. Получение данных из 1С запросом из Telegram 242

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Практика программирования Внешние источники данных

В результате чтения публикации Вы получите готовую внешнюю обработку, позволяющую получать из 1С данные, запрашиваемые через Telegram. В данной статье рассмотрим следующее: Использование HTTPСоединение; Чтение JSON для версии 1С 8.3.6 и выше, а также аналог JSON для версии 1С ниже 8.3.6; Подключение обработчика ожидания; Некоторые основные возможности API Telegram; Как создать бота для Telegram; Программное создание колонок дерева на управляемой форме;

1 стартмани

19.11.2015    69122    417    Luchik    199       

Быстрое определение интервалов в запросе 177

Инструменты и обработки Программист Внешний отчет (ert,erf) v8 Абонемент ($m) Практика программирования

В статье описывается новый метод определения интервалов между данными различных записей в запросе. В отличие от общеизвестного метода, время работы предлагаемого метода зависит от объема данных ЛИНЕЙНО. Это обеспечивает ему значительный выигрыш по быстродействию на больших объемах данных. В качестве иллюстрации возможностей метода приведен отчет, показывающий гистограмму распределения времени между продажами.

1 стартмани

01.10.2015    41600    32    ildarovich    41       

Полезные приемы при работе с Excel из 1С (Версия 3.1) 486

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) Практика программирования Разработка внешних компонент Загрузка и выгрузка в Excel

Программисту 1С часто приходится работать с таблицами Excel из 1С. Я постарался собрать небольшой FAQ и набор функций для работы с файлами Excel. Надеюсь, кому-то будет полезна данная статья.

1 стартмани

22.09.2015    133342    444    Zerocl    60       

Javascript и 1С. Кросс-платформенное взаимодействие 268

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Практика программирования

Что делать, если необходим богатый интерфейс, а управляемые формы нам его не могут обеспечить? Использовать HTML и JavaScript. В статье рассмотрено взаимодействие кода 1С и JavaScript, работающее на любой платформе: толстый, тонкий и веб-клиент, под Windows и Linux.

1 стартмани

14.09.2015    49747    186    VitaliyCeban    45       

Code First и Linq to EF на примере 1С версии 7.7 и 8.3 часть I 10

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 Windows Абонемент ($m) Практика программирования

Данный проект является чисто исследовательским примером использования Code First и Linq to EF на примере 1С версии 7.7. Так как сам я программист 1С, то мне всегда было интересно, как можно перенести модель объектов 1С на компилируемые языки, и использовать мощь Linq to EF. С появлением Code First давно хотел прикрутить, но все как-то руки не доходили, и вот, наконец ..

1 стартмани

28.08.2015    17824    4    Serginio    2       

Универсальная учетная система с конструктором документов и справочников в режиме 1С: Предприятие 95

Инструменты и обработки Программист Конфигурация (md, cf) v8 1cv8.cf УУ Windows Абонемент ($m) Инструментарий разработчика Практика программирования

Заголовок статьи звучит фантастично, но это не шутка. Занимаясь внедрениями, я часто сталкивался с ситуацией, когда надо было к типовой конфе приделать простенький модуль учета чего-нибудь, не специфичного для самой конфы. Например в УТ учет материалов в эксплуатации. Модуль обычно состоял из пары справочников (2-3), 3-х документов и регистра или пары регистров. Однажды подобные пристройки понадобились одновременно на 3 проектах. Скучно делать одинаковую работу, и я подумал, а что, если сделать универсальный инструмент, в котором пользователь сам сможет нарисовать себе справочники, реквизиты к ним, документы и движения. Т.е. конструктор полноценных документов в пользовательском режиме. Это оказалось не так сложно - все дело в подходящей архитектуре данных.

1 стартмани

29.07.2015    25950    141    informa1555    39       

Методы для группировки данных по полю,полям в Таблице Значений на примере универсального метода списания по партиям, а также отбора строк в ТЗ по произвольному условию. Для 8.x и 7.7 4

Инструменты и обработки Программист Внешняя обработка (ert,epf) v7.7 v8 1cv8.cf 1cv7.md Windows Абонемент ($m) Практика программирования Универсальные функции

Я очень часто использую группировку данных по полю и полям, как в восьмерке, так и в семерке. Это аналог запроса Итоги, но там строится дерево, а в большинстве случаев нужны "плоские данные". Да и делать запрос в большинстве случаев более накладный процесс, чем работа с ТЗ. Все достоинства такого подхода приведены на примере метода универсального списания по париям, а так же отбора строк в ТЗ по произвольному условию. Для 7.7 еще отчеты сравнения двух ТЗ. Работая с различными базами для упрощения сравнения номенклатуры, или как аналог джойнов(join), сделал сравнение двух таблиц значений по нескольким полям. Пока группировки полей должны быть уникальны. Часто приходится искать дубли, для универсального поиска есть ДублиВТзПоПолю и пример в Тест.ert.

1 стартмани

25.06.2015    20951    4    Serginio    1       

И снова "Как сжать картинки для экспорта в EXCEL?" или Умная картинка 8.2 14

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) Практика программирования Загрузка и выгрузка в Excel

Прошла уже эпоха , когда экономили на трафике интернета. Но все же...повторюсь. Я предлагаю совершенно новый способ сжатия картинки - эффект в 20 раз !!!

1 стартмани

17.06.2015    22425    54    Tatitutu    10       

Регистрация и согласование договоров, редакция 2.0 6

Отчеты и формы Пользователь Архив с данными v8 УУ Windows Документооборот и делопроизводство Абонемент ($m) Управленческий учет (прочее)

Конфигурация "Регистрация и согласование договоров" является готовым решением для управления и учета договоров на предприятии. Позволяет организовать единую информационную систему регистрации и согласования. Включает CRM подсистему.

1000 руб.

26.05.2015    13694    18    5       

Приемная руководителя, редакция 1.1 23

Инструменты и обработки Пользователь Конфигурация (md, cf) v8 Windows Документооборот и делопроизводство Абонемент ($m) Управленческий учет (прочее)

Приемная руководителя, редакция 1.1. Конфигурация на управляемых формах (интерфейс - Такси) с открытым кодом, создана для секретарей.

1500 руб.

19.05.2015    22709    21    6       

УПД за поставщика c подписями и факсимиле для БП 3.0 39

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v8 v8::БУ БП3.0 Россия БУ Windows Документооборот и делопроизводство Оптовая торговля Абонемент ($m) Печатные формы документов

Внешняя печатная форма для печати - "Универсальный передаточный документ" за поставщика. ВПФ (с формой и без) в форме заполняются должности и фамилии и происходит заполнение полей 10,13, 15,18.Так же есть возможность хранить и выводить на печать подписи руководителя и глав.бухгалтера поставщика. Внесены изменения под требования конфигураций выше 3.0.67.38 (НДС20%). Версия 0.2 без формы выбора подписантов(будет полезна тем у кого ответственные лица неизменные).

5 стартмани

19.03.2015    68492    953    kn    96       

Подсистема "Планировщик" (версия 1.1) 138

Отчеты и формы no Конфигурация (md, cf) v8 1cv8.cf Россия Абонемент ($m) Практика программирования WEB Работа с интерфейсом

Конфигурация с подсистемой "Планировщик" (календарь). Бесплатная открытая версия для свободного использования не включает двустороннюю интеграцию с сервисом Google и Outlook.com.

5 стартмани

02.03.2015    55582    463    vandalsvq    62       

Регулярные выражения без COM объектов и внешних компонент 27

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Практика программирования Универсальные функции

Платформа до сих пор не поддерживает регулярные выражения, хотя они уже стали довольно востребованной возможностью в разных языках программирования. Использование COM объектов и внешних компонент имеет ограничения, поэтому предлагается вариант реализации ограниченного функционала на встроенном языке 1С.

1 стартмани

09.02.2015    20472    18    boogie    35       

Асинхронные вызовы 83

Инструменты и обработки Программист Конфигурация (md, cf) v8 1cv8.cf Абонемент ($m) Практика программирования

В этой статье я покажу свою реализацию асинхронных вызовов серверных функций и процедур

1 стартмани

02.02.2015    33785    141    rtnm    25