Решение проблемы ПроверитьВывод() для огромных документов

Публикация № 696547

Разработка - Печать - Печатные формы документов

Пример того, как я ускорил вывод большого табличного документа(100+ страниц)

Каких результатов удалось достичь

Изначально, печатная форма, содержащая ~200 страниц выводилась(речь идет об именно выводе в табличный документ) > 15 минут. В результате оптимизации удалось сократить время до 1-2 минут.

Последовательность действий:

  1. Объявляем ТабличныйДокумент как ранее, настраиваем его свойства(Масштаб, ориентация страницы, поля);
  2. Объявляем еще один табличный документ, назовем его ИтоговыйТабличныйДокумент, копируем в него все свойства ранее созданного;
  3. Выполняем вывод одной страницы в ТабличныйДокумент, проверяем, умещается ли он или нет с помощью метода ПроверитьВывод()
  4. Когда вывод не умещается на странице ТабличныйДокумент, то:
    1. Выполняем его вывод в ИтоговыйТабличныйДокумент методом Вывести(ТабличныйДокумент)
    2. Очищаем ТабличныйДокумент
    3. Выводим шапку(если требуется) в Табличный документ
  5. Пункты 3-4 повторяются в цикле, как и при обычном формировании печатных форм
  6. В конце формирования выводим подвал в ИтоговыйТабличныйДокумент

Как это выглядит в программе

    ТабДокумент = Новый ТабличныйДокумент;
    ТабДокумент.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_ИнвентаризационнаяОписьВРазрезеГоловныхИзделий";
    ТабДокумент.ОриентацияСтраницы  = ОриентацияСтраницы.Портрет;
    ТабДокумент.МасштабПечати = 90;
    Макет   = ПолучитьМакет("ИнвентаризационнаяОпись");
    
    // Документ используется для вывода по страницам
    ИтоговыйТабДок = Новый ТабличныйДокумент;
    ЗаполнитьЗначенияСвойств(ИтоговыйТабДок, ТабДокумент); 
    
    НомерСтрокиНачало = ТабДокумент.ВысотаТаблицы + 1;
    Запрос = Новый Запрос;
    Запрос.Текст=
    "ВЫБРАТЬ
    |    ИнвентаризацияНЗП.Организация,
    |    ИнвентаризацияНЗП.Подразделение,
    |    ИнвентаризацияНЗП.Ссылка,
    |    ИнвентаризацияНЗП.Номер,
    |    ИнвентаризацияНЗП.Дата,
    |    ИнвентаризацияНЗП.Заказ,
    |    ИнвентаризацияНЗП.ВводитьЗаказыПоСтрокам,
    |    ИнвентаризацияНЗП.Заказ.Представление КАК ЗаказПредставление,
    |    ИнвентаризацияНЗП.Организация.Представление КАК ОрганизацияПредставление,
    |    ИнвентаризацияНЗП.Подразделение.Представление КАК ПодразделениеПредставление
    |ИЗ
    |    Документ.ИнвентаризацияНЗП КАК ИнвентаризацияНЗП
    |ГДЕ
    |    ИнвентаризацияНЗП.Ссылка = &ТекДок";
    Запрос.УстановитьПараметр("ТекДок", СсылкаНаОбъект);
    
    Шапка = Запрос.Выполнить().Выбрать();
    Шапка.Следующий();
    
    ИнфоОрг = УправлениеКонтактнойИнформацией.СведенияОЮрФизЛице(Шапка.Организация, СсылкаНаОбъект.Дата);
    
    Область = Макет.ПолучитьОбласть("Шапка");
    Область.Параметры.ПечНомерДок      = Шапка.Номер;
    Область.Параметры.ПечДатаДок       = Шапка.Дата;
    Область.Параметры.ПечОрганизация   = ИнфоОрг.ПолноеНаименование;
    Область.Параметры.ПечПодразделение = Шапка.ПодразделениеПредставление;
    
    Область.Параметры.КодОКПО          = ИнфоОрг.КодПоОКПО;
    Область.Параметры.Организация      = Шапка.Организация;
    Область.Параметры.Подразделение    = Шапка.Подразделение;
    
    ТабДокумент.Вывести(Область);
    ОбластьТабШапка = Макет.ПолучитьОбласть("ТабШапка");
    ТабДокумент.Вывести(ОбластьТабШапка);
    
    Индекс       = 0;
    ВсегоТМЦ     = 0;
    ВсегоКолФакт = 0;
    ВсегоКолОПУ  = 0;
    ВсегоКолОтк  = 0;
    КолФактСтр   = 0;
    СтрокНаЛисте = 5;// Изменим, подбирается опытным путем
    НПП = 0;
    ВсегоСтраниц = 0;    
    
    
    ВсегоИзделий = ДанныеДляПечати.Строки.Количество();
    
    ОбластьПодвал = Макет.ПолучитьОбласть("ПодвалСтраницы");
    
    Для Каждого СтрокаДЗ1 Из ДанныеДляПечати.Строки Цикл
        
        Состояние("Производится вывод печатной формы (изделие "+ (ДанныеДляПечати.Строки.Индекс(СтрокаДЗ1) + 1) + "/" + ВсегоИзделий + "). Стр. " + ВсегоСтраниц);
        
        Область  = Макет.ПолучитьОбласть("СтрокаПродукция");
        Область.Параметры.ПечНоменклатура = СтрокаДЗ1.НоменклатураПредставление;
        Область.Параметры.Номенклатура    = СтрокаДЗ1.Номенклатура;
        Область.Параметры.ПечКолБух          = Формат(СтрокаДЗ1.Количество, "ЧЦ=15; ЧДЦ=3");
        Область.Параметры.ПереченьЗаказов = СтрокаДЗ1.ПереченьЗаказов;
        ТабДокумент.Вывести(Область);
        
        Для Каждого СтрокаДЗ2 Из СтрокаДЗ1.Строки Цикл
            
            // Делаем через проверить вывод
            Индекс   = Индекс + 1;
            ВсегоТМЦ = ВсегоТМЦ + 1;
            НПП      = НПП + 1;
            Область  = Макет.ПолучитьОбласть("Строка");
            Область.Параметры.ПечНомер        = Формат( НПП, "ЧЦ=6; ЧН=");
            Область.Параметры.ПечНоменклатура = СтрокаДЗ2.НоменклатураПредставление;
            Область.Параметры.Номенклатура    = СтрокаДЗ2.Номенклатура;
              
            
            //Область.Параметры.ПечШифрИВЦ      = Шифр;
            Область.Параметры.ПечКодТМЦ       = СокрЛП(СтрокаДЗ2.НоменклатураКод);
            Область.Параметры.ПечКодЕИ        = СтрокаДЗ2.ЕдиницаИзмеренияКод;
            Область.Параметры.ПечЕИ           = СтрокаДЗ2.ЕдиницаИзмерения;
            
            Область.Параметры.ПечКолБух       = Формат(СтрокаДЗ2.Количество, "ЧЦ=15; ЧДЦ=3");
            
            // Если с подвалом не умещается - выводим подвал, начинаем новую страницу
            МассивДляПроверки = Новый Массив;
            МассивДляПроверки.Добавить(Область);
            //МассивДляПроверки.Добавить(ОбластьПодвал);
            Если ТабДокумент.ПроверитьВывод(МассивДляПроверки) = ЛОЖЬ Тогда
                
                // Подвал страницы просили не выводить
                //ОбластьПодвал.Параметры.КолНомСтр  = Индекс;
                //ОбластьПодвал.Параметры.ИтогКолСтр = КолФактСтр;
                //ТабДокумент.Вывести( ОбластьПодвал);
                Индекс     = 0;
                КолФактСтр = 0;
                ТабДокумент.ВывестиГоризонтальныйРазделительСтраниц();
                СтрокНаЛисте = 10; // Изменено - подбирается опытным путем  Это было раньше (На первом листе 9 строк, на остальных 30)
                
                ВсегоСтраниц = ВсегоСтраниц + 1;
                
                // Переносим изменения в итоговый документ, очищаем оригинал, выводим шапку на след.странице
                ИтоговыйТабДок.Вывести(ТабДокумент);
                
                ТабДокумент.Очистить();
                ТабДокумент.Вывести(ОбластьТабШапка);
                
            КонецЕсли;

            ОбработкаПрерыванияПользователя();// На всякий случай
            
            ТабДокумент.Вывести(Область);
            
            КолФактСтр   = КолФактСтр   + СтрокаДЗ2.Количество;
            ВсегоКолФакт = ВсегоКолФакт + СтрокаДЗ2.Количество;

        КонецЦикла;
        
    КонецЦикла;
    
    Область = Макет.ПолучитьОбласть("Итого");
    Область.Параметры.ПечКолФактИтого = Формат( ВсегоКолФакт, "ЧЦ=15; ЧДЦ=3");
    
    // Подвал страницы просили не выводить
    //ТабДокумент.Вывести( Область);
    //Если Индекс > 0 Тогда
    //    ОбластьПодвал = Макет.ПолучитьОбласть("ПодвалСтраницы");
    //    ОбластьПодвал.Параметры.КолНомСтр  = Индекс;
    //    ОбластьПодвал.Параметры.ИтогКолСтр = КолФактСтр;
    //    ТабДокумент.Вывести( ОбластьПодвал);
    //КонецЕсли;
    
    Область = Макет.ПолучитьОбласть("Подвал");
    Область.Параметры.ВсегоТМЦ      = ВсегоТМЦ;
    Область.Параметры.ИтогоКолОпись = ВсегоКолФакт;
    ТабДокумент.ВывестиГоризонтальныйРазделительСтраниц();
    ТабДокумент.Вывести( Область);
    //УправлениеПечатью.ЗадатьОбластьПечатиДокумента(ТабДокумент, НомерСтрокиНачало, Новый СписокЗначений, СсылкаНаОбъект);
    
    // Выведем всяческие подвалы
    ИтоговыйТабДок.Вывести(ТабДокумент);

Бонусом идет печатная форма для УПП 1.3, в которой присутствует этот кусок кода

Скачать файлы

Наименование Файл Версия Размер
Инвентаризационная опись в разрезе головных изделий

.epf 33,91Kb
06.11.17
2
.epf 33,91Kb 2 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. Armando 1393 06.11.17 22:43 Сейчас в теме
На 8.3.11 не проверяли? Там что-то оптимизировали на эту тему:

Оптимизирована работа метода табличного документа ПроверитьВывод().
Источник: http://downloads.v8.1c.ru/content//Platform/8_3_11_2700/V8Update.htm#0bacf61e-057e-11e7-a3f7-0050569f678a
SITR-utyos; +1 Ответить
2. SITR-utyos 1294 07.11.17 07:08 Сейчас в теме
(1) Нет, на 8.3.11 не проверял. Последняя платформа, что у меня стоит 8.3.10.2639 - там такая же проблема.
Спасибо, за заметку
3. mifka186 8 07.11.17 09:41 Сейчас в теме
Что-то подобное в расчетном листке организации ЗУП 2.5 используется.

Если ВыводитьПоСтраницам Тогда
			
	ОбластьПриемник = ТабличныйДокументДляПроверки.Область(ТабличныйДокументДляПроверки.ВысотаТаблицы + 1, ,ТабличныйДокументДляПроверки.ВысотаТаблицы + (НомерСтрокиКонцаРЛ - НомерСтрокиНачалаРЛ) + 1, );
	ТабличныйДокументДляПроверки.ВставитьОбласть(ОбластьРЛ, ОбластьПриемник, , истина);
		
	КоличествоСтраниц = 0;
	Попытка
		КоличествоСтраниц = ТабличныйДокументДляПроверки.КоличествоСтраниц();
	Исключение
	КонецПопытки;
			
	Если КоличествоСтраниц > 1 тогда
				
		ТабличныйДокумент.Область(НомерСтрокиНачалаРЛ, , НомерСтрокиНачалаРЛ,).НачалоСтраницы = истина;
				
		ТабличныйДокументДляПроверки.Очистить();
			
		Для сч = 0 по НастройкаШириныКолонокРасчетногоЛистка.ВГраница() Цикл
			ОбластьКолонкиРЛ                  = ТабличныйДокументДляПроверки.Область(, сч+1, , сч+1);
			ОбластьКолонкиРЛ.ШиринаКолонки    = НастройкаШириныКолонокРасчетногоЛистка[сч];
			ОбластьКолонкиРЛ.РазмещениеТекста = ПолучитьТипРазмещенияТекста(НастройкаРазмТекстаКолонокРасчетногоЛистка[сч]);
		КонецЦикла;
				
		ОбластьПриемник = ТабличныйДокументДляПроверки.Область(ТабличныйДокументДляПроверки.ВысотаТаблицы + 1, ,ТабличныйДокументДляПроверки.ВысотаТаблицы + (НомерСтрокиКонцаРЛ - НомерСтрокиНачалаРЛ) + 1, );
		ТабличныйДокументДляПроверки.ВставитьОбласть(ОбластьРЛ, ОбластьПриемник, , истина);
				
	КонецЕсли;
			
КонецЕсли;
Показать
4. madonov 155 07.11.17 09:49 Сейчас в теме
Плюс за идею. Взял на вооружение.
5. nvv1970 07.11.17 11:14 Сейчас в теме
Работа с табличным документом, текстовым документом деградирует пропорционально росту его объема. Поэтому можно применять не только указанный метод, но и использовать для организации печати страниц двумерный массив табличных документов. Так можно определить последовательность вывода по строкам, столбам, чёт/нечет и т.д. на сколько хватит фантазии.
sm.artem; +1 Ответить
6. BigB 181 07.11.17 12:09 Сейчас в теме
Каждый месяц генерирую примерно > 600 тысяч квитанций пачками по 1000 листов в пачке.
На каждой странице (внизу) есть адрес доставки и кому.
Квитанция должна занимать не более одной страницы.
Я поступаю так: если адрес доставки больше 150 тогда делаю проверку на количество страниц и если произошел перенос адреса на другую страницу - уменьшаю шрифт, пока не влезет в одну страницу.
Вот такой кусок кода у меня:
//Автоматическое изменение размера шрифта адреса доставки
Если СтрДлина(Выборка.АдресДоставки)>150 И ТДП.КоличествоСтраниц()>ХХ Тогда
	Y=Формат(ТДП.Области.Подвал.Низ,"ЧГ=0");
	ОбластьДоставки=ТДП.Область("R"+Y+"C2:R"+Y+"C10");
	Пока Истина Цикл
		ОбластьДоставки.Шрифт=Новый Шрифт(ОбластьДоставки.Шрифт,ОбластьДоставки.Шрифт.Имя,ОбластьДоставки.Шрифт.Размер-1);
		Если ТДП.КоличествоСтраниц()=ХХ Тогда
			Прервать
		ИначеЕсли ОбластьДоставки.Шрифт.Размер<7 Тогда
			Сообщить("Л/С "+Выборка.НомерЛС+" Не удалось разместить на одной странице адрес доставки:"+Символы.ПС+Выборка.АдресДоставки);
			Прервать
		КонецЕсли;
	КонецЦикла;
КонецЕсли;
Показать
cargobird; jaroslav.h; sm.artem; AlexGroovy; Danil.Potapov; +5 Ответить
7. vis_tmp 30 08.11.17 06:33 Сейчас в теме
Спасибо, интересный метод ускорения печати больших отчётов!
8. AlexGroovy 08.11.17 11:11 Сейчас в теме
А где именно в коде оптимизация ? Я понял,если бы вы избежали ПроверитьВывод(),но у он у вас остался и находится в цикле.Смысл в том,что всё выводится в итоговый табличный документ?
9. корум 284 08.11.17 11:52 Сейчас в теме
(8)
А где именно в коде оптимизация ? Я понял,если бы вы избежали ПроверитьВывод(),но у он у вас остался и находится в цикле.Смысл в том,что всё выводится в итоговый табличный документ?

нет, не понял.
Смысл в том, что не тормозит.
ПроверитьВывод() 3 страниц 0,01 сек, ПроверитьВывод() 300 страниц не 1 сек, а 100.
ПроверитьВывод() для 3 страниц 100 раз - 1 сек.
11. AlexGroovy 08.11.17 14:13 Сейчас в теме
А как у вас получается область на 300 страниц сразу,если вы в цикле как и в типовом механизме добавляете по области строчке и сразу переносите другие на новую страницу?
13. madonov 155 09.11.17 02:36 Сейчас в теме
(11) да не область на 300 страниц. А сам табличный документ на 300 страниц.

БольшойТабличныйДокумент.ПроверитьВывод(Область)
работает гозадо медленнее чем
МалыйТабличныйДокумент.ПроверитьВывод(Область)

Автор предлагает не вызывать ПроверитьВывод() для большого документа на 300 страниц, а вызывать эту функцию только для малого табличного документа, который равен последней странице большого.

Ускорение происходит не за счет того, что уменьшается количество вызовов функции ПроверитьВывод(), а за счет того, что каждый вызов занимает в разы меньше времени.
starik-2005; echo77; klinval; корум; AlexGroovy; +5 Ответить
14. AlexGroovy 09.11.17 09:54 Сейчас в теме
(13)Спасибо большое за ответ =)
10. BigB 181 08.11.17 12:35 Сейчас в теме
(0) Уберите из названия "для огромных документов".
Поверьте мне - 200 страниц это мизерный документ.
Не используйте ПроверитьВывод().
Вместо этого используйте КоличествоСтраниц() в разумных пределах и отчет будет формироваться очень быстро.
12. madonov 155 09.11.17 02:28 Сейчас в теме
(10) предположим, что выводим область и при помощи КоличествоСтраниц() видим, что количество страниц увеличилось.
И как без ПроверитьВывод() определить целиком ли новая новая область на новой странице или её "разорвало" на разные и требуется вставка разрыва страницы?
15. apostal86 233 09.11.17 09:59 Сейчас в теме
Идея интересная. Надо запомнить
16. androgin 10.11.17 00:55 Сейчас в теме
Простите, а если длина наименования постоянно разная и может занимать 1,2,3 строки, то как вы это обойдете?
На одном листе может быть 40 строк, а следующем 50, а третьем ваще 35.
Тут уже параметр СтрокНаЛисте не имеет смысла
17. echo77 1161 10.11.17 05:59 Сейчас в теме
(16) В примере переменная СтрокНаЛисте нигде не используется, если посмотреть циклы внимательное. Это наследие типовой формы инвентаризации - там сделано именно так
Оставьте свое сообщение

См. также

Безопасная работа с транзакциями во встроенном языке Промо

Практика программирования v8 1cv8.cf Абонемент ($m)

Разбираемся с опасностями использования транзакций во встроенном языке 1С. Познаем ошибку "В данной транзакции уже происходили ошибки". Учимся защищаться от них.

1 стартмани

25.03.2019    33182    tormozit    44    

Загрузка, скачивание, удаление файлов с помощью НачатьПомещениеФайлаНаСервер() и НачатьПолучениеФайлаССервера()

Практика программирования v8 1cv8.cf Абонемент ($m)

В платформе 8.3.15 появились новые методы НачатьПомещениеФайлаНаСервер() и НачатьПолучениеФайлаССервера(). В данной статье рассмотрено готовое решение проверенное и прекрасно работающее на тонком и веб-клиенте.

1 стартмани

25.07.2020    1619    Flashill    9    

Параллельные вычисления расчета факториала числа N

Практика программирования v8 1cv8.cf Абонемент ($m)

Распараллеливание алгоритма с помощью фоновых заданий (асинхронные вычисления)

1 стартмани

29.06.2020    2154    Rustig    17    

Методика обновления формы объекта данных при изменении объекта

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

В формах объектов данных часто встречаются элементы, косвенно связанные с объектом. Логику обновления этих элементов при изменении объекта обычно вызывают из обработчиков ПриСозданнииНаСервере и ПриОткрытии, забывая про наличие других способов изменения объекта. В статье предложена методика для обычных и управляемых форм, учитывающая все способы.

1 стартмани

09.03.2020    6905    tormozit    13    

Как выполнить отчет на СКД через COM и получить данные отчета? Промо

Практика программирования v8 УПП1 Россия Абонемент ($m)

Для чего это нужно. Например, нужно в одной базе получить какой-либо показатель из другой базы. Этот показатель вычисляется в каком-либо сложном отчете, который написан на СКД. Можно, конечно, "скопипастить" текст запроса из другой базы, немного подправить его и выполнять в том же COM подключении. Но с этим теряется гибкость: если отчет изменился, то нужно помнить о том, что где-то есть его "немного модифицированная" копия. В статье будет рассмотрен пример получения данных из базы ЗУП.

2 стартмани

08.05.2018    26657    wowik    3    

Отправка уведомлений с помощью командной строки, Оповещения с сервера на клиент с помощью командной строки

Практика программирования v8 1cv8.cf Россия Абонемент ($m)

Отправка уведомлений с помощью команды командной строки msg. Оповестить пользователей из серверного модуля или регламентного задания, с помощью командной строки msg.

1 стартмани

05.03.2020    5073    user5300    3    

Вывод сообщений в HTML поле средствами 1С

Практика программирования v8 v8::УФ Абонемент ($m)

Пример использования вывода большого количества сообщений в поле HTML. С возможностью открывать ссылочные объекты и создавать новые объекты передавая параметры прямо из HTML поля. Протестировано на релизах 8.3.12 и 8.3.15+

2 стартмани

31.01.2020    5224    burni4    16    

Краткое руководство по внесению изменений в конфигурацию

Практика программирования v8 1cv8.cf Абонемент ($m)

Кратко описаны основополагающие моменты при старте групповой разработки конфигурации несколькими программистами. Полезно для проектной документации как требование к разработчикам или сопровождающей компании.

1 стартмани

13.01.2020    15962    sapervodichka    41    

Как нарисовать граф на 1С Промо

Практика программирования v8 Абонемент ($m)

Описывается реализация на языке запросов 1С метода расположения вершин графа на плоскости, основанного на использовании электромеханической аналогии. При этом вершины графа представляются одноименными электрическими зарядами, дуги - пружинками. Силы взаимодействия вершин в этой системе переводят их из случайного начального в нужное конечное положение. Приведена обработка рисования графов "ГрафОграф", реализующая данный подход, показывающая также динамику процесса. Граф можно задать списком ребер вручную, выбрать из нескольких предопределенных примеров или сформировать по данным информационной базы.

1 стартмани

09.08.2013    69854    ildarovich    117    

Универсальные функции: разложение произвольной строки адреса в структуру

Практика программирования Универсальные функции v8 1cv8.cf Абонемент ($m)

Процедуры и функции раскладывают произвольную строку адрес в структуру по ключевым словам.

1 стартмани

30.12.2019    3277    vik070777    10    

"Живые" картинки со Snap.SVG

Практика программирования WEB Работа с интерфейсом v8 Абонемент ($m)

В статье рассмотрен пример использования http-сервисов для визуализации данных

1 стартмани

24.10.2019    12968    blackhole321    7    

RLS - дубли условий в запросах к СУБД

Практика программирования Роли и права v8 v8::Права 1cv8.cf Абонемент ($m)

"Подводные камни", возникающие при бездумном копировании ролей с ограничениями RLS, как это отражается на производительности, разбор примера и инструмент для анализа.

1 стартмани

07.10.2019    8136    geron4    4    

Простой способ индексирования интервалов Промо

Практика программирования v8 Абонемент ($m)

Предлагается простой способ индексирования интервалов для решения задач выборки записей, включающих заданный момент времени, пересекающихся с заданным интервалом или множеством интервалов. Способ основан на добавлении к исходной таблице особого числового индексированного поля, рассчитываемого по специальной формуле. Приведен код функций, необходимых для расчетов поля поиска и параметров поисковых запросов. Приведены также результаты тестирования метода, доказывающие его высокую эффективность.

1 стартмани

28.09.2016    39082    ildarovich    22    

Полезные процедуры и функции для программиста

Практика программирования Универсальные функции v8 1cv8.cf Россия Абонемент ($m)

Все мы пишем программный код и часто используем процедуры, облегчающие его написание. Ниже приведена выборка таких полезных процедур и функций.

1 стартмани

07.10.2019    28236    HostHost    40    

Полное копирование одной формы в другую

Практика программирования Универсальные обработки Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Однажды я столкнулся с необходимостью открыть форму ЛЮБОГО документа с определенными изменениями, не зависящими от структуры объекта (например, заблокировать все кнопки). В интернете решения я не нашел. Обычно на форумах на запросы подобного рода отвечают чем-то вроде "покажи первоначальную задачу, а не спрашивай как реализовать то, что ты придумал". Тем не менее, мне стало интересно, как это можно сделать.

1 стартмани

03.10.2019    4567    nekit_rdx    23    

Многопоточная обработка данных на примере перепроведения документов

Обработка документов Практика программирования v8 ERP2 УТ11 КА2 Абонемент ($m)

Дальнейшее развитие темы фоновой обработки данных - проведение документов в потоках. Настройка параметров и запуск основного процесса (менеджера потоков). Разбивка документов для проведения на не связанные друг с другом наборы и запуск дополнительных фоновых заданий для отдельных потоков. Отслеживание выполнения каждого потока в родительском сеансе.

1 стартмани

17.09.2019    8670    ids79    46    

Бесплатная проверка контрагентов в ФНС (общий модуль с алгоритмом). На примере выводим статус в список справочника контрагентов Промо

Практика программирования v8 1cv8.cf Абонемент ($m)

Если вам интересно проверить контрагенте в ФНС, вам поможет данная публикация. Весь алгоритм работы строится на основе данных, полученных с сервиса http://npchk.nalog.ru совершенно бесплатно.

1 стартмани

01.02.2018    34620    rpgshnik    49    

Отображение истории выполнения по всем задачам комплексного процесса в документообороте

Документооборот и делопроизводство Практика программирования v8 ДО Абонемент ($m)

Коллеги, предлагаю вашему вниманию доработку для вывода полной истории в задачах комплексного процесса.

1 стартмани

15.09.2019    6433    pavelpribytkin96    8    

Описание формата внутреннего представления данных 1С в контексте обмена данными

Практика программирования Внешние источники данных v8 v8::УФ 1cv8.cf Абонемент ($m)

Фирма 1С не рекомендует использовать внутреннее представление данных для любых целей, которые отличны от обмена с 1С:Предприятием 7.7. Но сама возможность заглянуть на "внутреннюю кухню" платформы с помощью функций ЗначениеВСтрокуВнутр(), ЗначениеВФайл(), ЗначениеИзСтрокиВнутр() и ЗначениеИзФайла(), дала возможность сообществу программистов 1С разработать новые приемы разработки и анализа. Так, именно на использовании внутреннего представления был построен алгоритм "быстрого массива", который позволяет практически мгновенно создать массив в памяти на основании строки с разделителями. С помощью разбора внутреннего представления можно "на лету" программным кодом выполнить анализ обычной формы и даже сделать редактор графической схемы. Во внутреннем формате сохраняют свои данные между сеансами различные популярные внешние обработки. А еще это возможность сделать быстрый обмен с внешними системами.

1 стартмани

06.09.2019    18708    Dementor    30    

Удобный просмотр результата запроса с большим количеством временных таблиц

Практика программирования v8 Абонемент ($m)

Если Вам часто приходится просматривать в отладчике сложные пакетные запросы с большим количеством временных таблиц, то эта статья для Вас.

1 стартмани

27.08.2019    10567    ids79    21    

БСП: Дополнительная обработка (Регламенты), примеры от простого к сложному Промо

Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

Очень много попадается странных решений, которые можно решить через БСП:Дополнительные отчеты и обработки. Я бы вообще БСП из-за этой подсистемы переименовал в «Большое Спасибо Программистам». Поработаем с подсистемой в части написания регламентных заданий.

1 стартмани

10.05.2018    43290    dsdred    36    

Запуск фонового задания во внешней обработке. Отключение предупреждений защиты от опасных действий в фоновом задании

Практика программирования v8 1cv8.cf Абонемент ($m)

Как запустить фоновое задание из модуля внешней обработки используя БСП. Как отключить безопасный режим и сообщения защиты от опасных действий независимо от профиля безопасности пользователя в фоновом задании во внешней обработке.

2 стартмани

24.08.2019    9791    BenGunn    22    

Изменяющееся контекстное меню в 1С 8.3

Практика программирования Работа с интерфейсом Разработка v8 v8::УФ Абонемент ($m)

В одной практической задаче мне пришлось разрабатывать контекстное меню таблицы управляемой формы, которое должно было меняться в зависимости от данных, находящихся в этой таблице. Ниже приведен мой способ решения этой задачи.

1 стартмани

06.08.2019    14779    signum2009    16    

Процедура ПриКомпоновкеРезультата

Практика программирования v8 1cv8.cf Абонемент ($m)

Коллекция кода

1 стартмани

26.07.2019    34827    vasilev2015    63    

Некоторая работа с данными через COM Промо

Практика программирования v8 Абонемент ($m)

В статье приведены примеры работы с Платформой 8.X через COM (точнее, через объект COMConnector). Примеры кода были использованы при реализации прикладных задач в процессе трудовой деятельности.

2 стартмани

05.12.2012    56934    wowik    32    

10 способов получить модуль числа (а может, и больше)

Практика программирования Разработка v8 1cv8.cf Абонемент ($m)

Пишем функцию вычисления модуля числа. Сколько способов существует? Давайте посчитаем!

1 стартмани

11.07.2019    7274    sam441    29    

Ловец дедлоков СУБД

Производительность и оптимизация (HighLoad) Практика программирования Разработка v8 Россия Абонемент ($m)

Анализ простейшего дедлока СУБД в рабочей базе с использованием ЦУП (центра управления производительностью) и profiler MS SQL (Microsoft SQL Server). Эта статья будет полезна людям, изучающим вопросы оптимизации работы 1С, или тем, у кого возникают дедлоки в рабочей базе. UPD 09.07.2019 добавлено воспроизведение блокировки в случае установки управляемой блокировки перед чтением набора записей регистра сведений. UPD 10.07.2019 добавлена тестовая база с примером.

1 стартмани

08.07.2019    10731    azazana    79    

Мониторинг производительности и искусственный интеллект

Производительность и оптимизация (HighLoad) Практика программирования Разработка v8 Абонемент ($m)

Расскажем и покажем практически, как использовать искусственный интеллект на страже мониторинга производительности. У вас появится возможность создать собственного помощника Ларису, которая возьмет на себя вопросы по контролю и диагностике состояния обслуживаемой системы.

1 стартмани

01.07.2019    8968    ivanov660    28    

Работа со схемой запроса Промо

Инструментарий разработчика Практика программирования v8 v8::Запросы Абонемент ($m)

Стандартом взаимодействия с реляционной базой данных стал язык SQL. Приемником SQL в 1С является язык запросов. Язык запросов, также как и SQL, является структурированным. Составляющие структуры запроса отвечают на разные вопросы о том, какие данные требуется получить и какие манипуляции с множествами данных необходимо произвести при получении. В простых случаях текст запроса можно написать вручную, однако в сложных случаях, а также при программном формировании, - лучше воспользоваться объектной моделью запроса и использовать объект "Схема запроса". В статье дается описание объектной модели и особенностей работы с ней, а также приводится решение, упрощающее взаимодействие с объектом "Схема запроса".

1 стартмани

24.04.2018    42608    kalyaka    34    

"Убер на складе": динамический расчет маршрутов с учетом реальных расстояний

Учет ТМЦ Практика программирования Учет ТМЦ v8 УУ Абонемент ($m)

Представляю методику и инструмент для динамического расчета маршрутов отбора на высоконагруженных складах для максимального повышения эффективности склада, ускорения проходимости и, как следствие, экономии денег. Это методика и обработка для интеграции в WMS решения. Тестировалось на 1С 8.3.14.1565.

3 стартмани

24.06.2019    14334    informa1555    17    

1С:Ассемблер. Немного летнего веселья!

Практика программирования Разработка v8 1cv8.cf Абонемент ($m)

Все вы, наверное, слышали, что 1С-ники жалуются на свою систему, считая язык 1С недостаточно низкоуровневым, скучным и т.п. Все они с тоской поглядывают в сторону "настоящих" языков программирования. Так вот, господа, они неправы. В системе 1С есть места, где можно размять программерский мозг и получить удовольствие от низкоуровневой техники. Предлагаю вам погрузиться в недра виртуальной машины 1С и понять, как она работает. Там есть свой "ассемблер" и мы попробуем его в действии!

1 стартмани

21.06.2019    27647    Evil Beaver    122    

Простые примеры сложных отчетов на СКД

Практика программирования v8 v8::СКД 1cv8.cf Абонемент ($m)

Подписи в отчете. Особенности соединения наборов: как соединить несоединяемое. Остатки на дату и обороты по месяцам в одном отчете. Курс валюты на каждую дату без группировок и соединений в запросе. Отчет с произвольными колонками и с произвольной последовательностью. "Неадекватный отчет".

1 стартмани

12.06.2019    28428    Hatson    22    

Многопоточность. Универсальный «Менеджер потоков» (фреймворк) с отслеживанием зависимости объектов Промо

Практика программирования Математика и алгоритмы Универсальные функции Производительность и оптимизация (HighLoad) v8 1cv8.cf Россия Абонемент ($m)

Восстановление партий, расчет зарплаты, пакетное формирование документов или отчетов - теперь все это стало доступнее. * Есть желание повысить скорость работы медленных алгоритмов! Но... * Нет времени думать о реализации многопоточности? * о запуске и остановке потоков? * о поддержании потоков в рабочем состоянии? * о передаче данных в потоки и как получить ответ из потока? * об организации последовательности? Тогда ЭТО - то что надо!!!

26.05.2017    48538    DarkAn    86    

Графики работы из БСП

Практика программирования Разработка v8 1cv8.cf Россия Абонемент ($m)

Не очень давно на канале 1С:БСП была опубликована заметка по использованию Графиков работы и Календарных графиков.

1 стартмани

23.05.2019    3040    fenixnow    0    

Создание внешней печатной формы в формате документа Word

Практика программирования Разработка v8 1cv8.cf Абонемент ($m)

В статье написано, как создать внешнюю печатную форму (для конфигураций с БСП) в формате Word.

1 стартмани

17.05.2019    11889    ВикторП    20    

Пример настройки шаблонов и реализации печати отчетов в документ MS Word используя функциональную часть "Библиотеки Стандартных Подсистем 1С" (БСП)

Практика программирования Разработка v8 Россия Абонемент ($m)

В конфигурации выбраны и использованы только необходимые объекты библиотеки стандартных подсистем для реализации вывода отчёта, с табличными частями, в документ MS Word. Показан пример создания необходимых областей в шаблоне для вывода параметров в отчёт.

1 стартмани

23.04.2019    5747    olegpkc    11    

Новый запрос и новая таблица значений как функции Промо

Практика программирования v8 Абонемент ($m)

Предлагается две простые функции, использование которых уменьшает объем кода в конфигурациях на платформе «1С:Предприятие 8». Эти функции можно добавлять к своему общему модулю, что сделает процесс программирования более эффективным.

1 стартмани

27.11.2012    44912    ildarovich    46    

Ops средствами 1С:Предприятие

Практика программирования Разработка v8 1cv8.cf Абонемент ($m)

В статье описан программный пакет "Автоматизация ИТ-процессов" (АИТП), позволяющий автоматизировать задачи по администрированию, управлению и обслуживанию ИТ-инфраструктуры.

1 стартмани

23.04.2019    17057    blackhole321    28    

1C + Python + Django Rest Framework + Vue.js. Опыт несложной full-stack разработки

Практика программирования Внешние источники данных Обмен через XML WEB Разработка v8 1cv8.cf Абонемент ($m)

В этой статье мы рассмотрим путь и основные моменты создания небольшого вэб-сервиса, который мы называем "Онлайн Прайс-лист". Выгрузка из 1С, бэкенд, фронтенд, получение заказов в 1С.

1 стартмани

22.04.2019    31469    riposte    63    

Вывод вариантов СКД в таблицы на управляемой форме

Практика программирования Работа с интерфейсом v8 v8::УФ v8::СКД 1cv8.cf Абонемент ($m)

Задача стояла такая: есть 2 различных запроса, результаты которых выгружаются на форму обработки в таблицы значений (далее ТЗ) и программно "соприкасаются" между собой определенным образом (как именно- в рамках данной статьи неважно). Нюанс в том, что запросы должны иметь свой компоновщик настроек и могут интерактивно на форме изменяться пользователем. На оригинальность публикации не претендую - изначально в рамках поставленной задачи пытался найти что-то подобное (уже готовый шаблон) на инфостарте, возможно "плохо искал" ;)

05.04.2019    10573    artkor    1    

Уровни, глубина, прародители, циклы и аналоги запросом Промо

Практика программирования v8 1cv8.cf Абонемент ($m)

В продолжение публикации «Транзитивное замыкание запросом» [http://infostart.ru/public/158512/] добавлены другие варианты использования того же приема. Приведены запросы для быстрого определения уровней всех элементов справочника, максимальной глубины справочника, прародителей произвольных элементов справочника, запрос для быстрого определения циклов (на примере справочника спецификаций «1С:Управление производственным предприятием») и определения множеств аналогов номенклатуры (также на примере конфигурации «1С:Управление производственным предприятием»).

1 стартмани

13.11.2012    110576    ildarovich    98    

Функциональное программирование в 1С

Практика программирования Математика и алгоритмы Разработка v8 1cv8.cf Абонемент ($m)

Статья о функциональном программировании в 1С. Добавляем новые возможности. Пример передачи функций в качестве аргумента.

1 стартмани

28.03.2019    8171    alexey.kutya    26    

[EnterpriseData] Антисвертка характеристик номенклатуры при выгрузке в Бухгалтерию

Практика программирования Перенос данных из 1C8 в 1C8 Разработка v8 v8::ПВХ КД УНФ БП3.0 Россия БУ Абонемент ($m)

Рассмотрена выгрузка каждой пары значений Номенклатура - Характерстика из УНФ 1.6 в отдельную номенклатуру в Бухгалтерию 3.0 путём доработки правил обмена в формате EnterpriseData.

1 стартмани

27.03.2019    4354    nforce    4    

Интеграция 1С и SharePoint

Практика программирования Разработка v8 УНФ ДО ERP2 БП3.0 УТ11 УХ КА2 Россия Абонемент ($m)

Заказчики поставили задачу автоматизации согласования заявок на оплату в программе 1С:Бухгалтерия предприятия 3.0. Согласно ТЗ, данные должны подтягиваться из действующей электронной системы документаоборота на MS SharePoint (в дальнейшем СЭД MS SP).

1 стартмани

22.03.2019    5189    -I-    4    

Неоплаченные долги при распределении оплаты по правилу ФИФО одним запросом и намного быстрее, чем Вы думали Промо

Практика программирования Дебиторская и кредиторская задолженность Дебиторская и кредиторская задолженность v8 v8::СКД КА1 УТ10 УПП1 УУ Абонемент ($m)

Предлагается метод для быстрого нахождения неоплаченных долгов при распределении оплаты по правилу ФИФО, основанный на дихотомии. Описывается реализация метода в виде достаточно простого запроса, решающего за линейное время указанную задачу, считавшуюся ранее существенно более трудоемкой. Приводятся примеры использования запроса в отчетах на СКД для конфигураций УТ, КА, УПП.

1 стартмани

28.02.2014    67696    ildarovich    123    

Легкий "тюнинг" УТ 10.3

Практика программирования Разработка v8 v8::ОУ УТ10 Россия УУ Абонемент ($m)

Вариант программной реализации изменения форм типовых объектов для конфигурации Управление торговлей 10.3.

1 стартмани

15.03.2019    4247    pm74    6    

Пример использования СКД и данных расшифровки на мобильной платформе

Практика программирования Разработка v8 v8::Mobile v8::СКД 1cv8.cf Россия Абонемент ($m)

СКД в мобильном приложении и меню действий на основе данных расшифровки (отчет, совместимый с мобильной платформой 8.3.13.45).

1 стартмани

12.03.2019    5359    majoram    0    

Программное создание реквизита управляемой формы с помощью механизма расширений

Практика программирования Разработка v8 v8::УФ 1cv8.cf Абонемент ($m)

В ЗУП 3 возникла задача добавить реквизит в справочник не внося изменений в конфигурацию. БСП с механизмом дополнительных реквизитов использовать было нежелательно, поэтому был использован механизм расширений. Для вывода данного реквизита на форму добавлять саму форму в расширение не хотелось по ряду причин, описанных ниже. Создание реквизита и элемента формы, соответствующего данному реквизиту было решено сделать программно в самом расширении, следуя принципу минимального воздействия на конфигурацию.

1 стартмани

12.03.2019    32378    ni_cola    29    

Транзитивное замыкание запросом Промо

Практика программирования v8 1cv8.cf Абонемент ($m)

В частности, показывается, как одним пакетным запросом найти ВСЕХ предков (потомков) в иерархическом справочнике. Аналогично можно определять входимость деталей в узлы и готовые изделия по их спецификациям, определять подмножества аналогичных запчастей по цепочке аналогов, решать другие подобные задачи. Приложен файл с примером отчета для замыкания иерархии произвольного справочника, позволяющий протестировать быстродействие запроса в разных условиях.

1 стартмани

29.10.2012    83627    ildarovich    118    

Иерархия библиотек. Автоматическое обновление или как отказаться от переопределяемых модулей

Практика программирования Математика и алгоритмы Разработка v8 Абонемент ($m)

В статье рассмотрен один из вариантов библиотечного подхода к разработке, позволяющий организовать иерархический вызов библиотечных процедур и упростить автоматическую сборку готового продукта из нескольких библиотек. Предлагаемый подход может служить одним из элементов CI/CD при разработке ПО на платформе 1С.

1 стартмани

04.03.2019    5625    Alxby    4    

Асинхронная работа с текстовыми файлами в 1С 8.3

Практика программирования Разработка v8 1cv8.cf Абонемент ($m)

В этой статье я рассмотрю основные моменты работы с текстовым файлом в 1С 8.3. (загрузка - выгрузка) в режиме отключенной модальности (асинхронно).

1 стартмани

28.02.2019    7014    signum2009    6    

Баг или фича? Неожиданное поведение платформы

Практика программирования Тестирование и исправление Разработка v8 1cv8.cf Абонемент ($m)

Рассмотрим несколько случаев неожиданного поведения платформы 1С, а также что с этим можно cделать.

18.02.2019    22598    YPermitin    89