Функция сохранения картинок из книги Excel в каталог с определением координат на листе

Публикация № 699042

Разработка - Обмен данными 1С - Загрузка и выгрузка в Excel

Разбор файла *.xlsx как Web-архива, выгрузка изображений без потери качества, с определением положения изображений.

Возникла необходимость написать парсер для чтения прайс-листов поставщиков, с чтением картинок. Среди публикаций нашел вот эту Сохранение картинки из MS Excel в файл без использования внешних компонент - в ней описано, как скопировать изображение во временный  лист Excel, на котором создается  диаграмма, в которую заливается  картинка с последующим экспортом диаграммы в файл. Работает отлично, за исключением того, что диаграмма сохраняется с двумя разрешениями - для  печати  и как на экране, а очень хотелось получить изображение с исходным  разрешением именно таким, в котором картинка  была  помещена в  книгу (для файла, в котором не было сжатия изображений). 

Способа работы через коллекцию Shapes я не нашел, зато есть способ сохранить файл как Web-архив, открыть его архиватором и получить нужные изображения в виде набора файлов с именами "Image1", "Image2" и так далее. Правда не совсем ясно, какое изображение в какой ячейке находится и в каком конкретно порядке они выгружены.

Нужные данные для случая, когда книга состоит из одного листа содержатся в файлах "drawing1.xml" и "drawing1.xml.rels" внутри web-архива. Картинки лежат в папке "xl/media/" архива.

Приведенная ниже функция сохраняет все данные в каталог временных файлов 1с, но можно указать любое другое нужное место.

 

Функция ВыгрузитьКартинки(Путь) Экспорт // Путь к исходному файлу Excel
        
    АрхивныеДанные = Новый ТаблицаЗначений;
    АрхивныеДанные.Колонки.Добавить("ИД"); // rId - внутренний идентификатор
    АрхивныеДанные.Колонки.Добавить("НомерСтроки",Новый ОписаниеТипов("Число"));
    АрхивныеДанные.Колонки.Добавить("НомерКолонки",Новый ОписаниеТипов("Число"));
    АрхивныеДанные.Колонки.Добавить("ИмяФайла");
    АрхивныеДанные.Колонки.Добавить("КороткоеИмяФайла"); //  Image1 ...
        
    ИмяФайлаПутей = "";
    ИмяФайлаКоординат = "";
    
    Читалка = Новый ЧтениеZipФайла(Путь);
    ВотВамКаталог = ПолучитьИмяВременногоФайла();
    Для Каждого Эл Из Читалка.Элементы Цикл
        Если Эл.Путь = "xl/media/" Тогда  //  это  папка  с  картинками -  элемент  - картинка
            Читалка.Извлечь(Эл,ВотВамКаталог,РежимВосстановленияПутейФайловZIP.НеВосстанавливать);
            НС = АрхивныеДанные.Добавить();
            НС.КороткоеИмяФайла = Эл.Имя;
            НС.ИмяФайла = ВотВамКаталог + "\" + Эл.Имя;
        ИначеЕсли Эл.ПолноеИмя = "xl/drawings/drawing1.xml" Тогда  
            Читалка.Извлечь(Эл,ВотВамКаталог,РежимВосстановленияПутейФайловZIP.НеВосстанавливать);
            ИмяФайлаКоординат = ВотВамКаталог + "\" + Эл.Имя;
        ИначеЕсли Эл.ПолноеИмя = "xl/drawings/_rels/drawing1.xml.rels" Тогда
            Читалка.Извлечь(Эл,ВотВамКаталог,РежимВосстановленияПутейФайловZIP.НеВосстанавливать);
            ИмяФайлаПутей = ВотВамКаталог + "\" + Эл.Имя;
        КонецЕсли;    
    КонецЦикла;          
    
    //ИмяФайлаПутей
    ЧтениеФайлаXML = Новый ЧтениеXML;
    ЧтениеФайлаXML.ОткрытьФайл(ИмяФайлаПутей);
    Пока ЧтениеФайлаXML.Прочитать() Цикл
        
        Если ЧтениеФайлаXML.Имя = "Relationship" Тогда
            ИД = "";
            КороткоеИмя = "";
            Пока ЧтениеФайлаXML.СледующийАтрибут()  Цикл
                Если ЧтениеФайлаXML.Имя = "Id" Тогда
                    Ид = ЧтениеФайлаXML.Значение;
                ИначеЕсли ЧтениеФайлаXML.Имя = "Target"    Тогда
                    КороткоеИмя = ЧтениеФайлаXML.Значение;            // ../media/image3.jpeg    
                    ПозНачала = Найти(КороткоеИмя,"/image");
                    Если ПозНачала > 0 Тогда
                        КороткоеИмя = Сред(КороткоеИмя,ПозНачала + 1,СтрДлина(КороткоеИмя) - ПозНачала);
                    КонецЕсли;
                КонецЕсли;    
            КонецЦикла;    
            Если ЗначениеЗаполнено(КороткоеИмя) И ЗначениеЗаполнено(ИД) Тогда
                СтрокаДанных = АрхивныеДанные.Найти(КороткоеИмя,"КороткоеИмяФайла");
                Если СтрокаДанных <> Неопределено Тогда
                    СтрокаДанных.ИД = ИД;
                КонецЕсли;    
            КонецЕсли;    
        КонецЕсли;    
                    
    КонецЦикла;
    
    //ИмяФайлаКоординат
    ЗаголовокНачалоУзла = "xdr:twoCellAnchor";
    ЗаголовокНачалоУзла1 = "xdr:oneCellAnchor";
    ЗаголовокНачалоКоординат = "xdr:from";
    ЗаголовокНачалаКоординатКолонка = "xdr:col";
    ЗаголовокНачалаКоординатСтрока = "xdr:row";
    ЗаголовокНачалаИдентификатора  = "a:blip";
    ИмяАтрибутаИдентификатора  = "r:embed";
    //Заголовок
    
    ЧтениеФайлаXML = Новый ЧтениеXML;
    ЧтениеФайлаXML.ОткрытьФайл(ИмяФайлаКоординат);
    
    ПутьЧтения = "";
    
    Пока ЧтениеФайлаXML.Прочитать() Цикл
        
        Если ЧтениеФайлаXML.ТипУзла = ТипУзлаXML.НачалоЭлемента И (ЧтениеФайлаXML.Имя = ЗаголовокНачалоУзла Или ЧтениеФайлаXML.Имя = ЗаголовокНачалоУзла1) Тогда
            ПутьЧтения = "Узел";
            Данные = Новый Структура("Столбец,Строчка,Ид");
        ИначеЕсли ЧтениеФайлаXML.ТипУзла = ТипУзлаXML.КонецЭлемента И (ЧтениеФайлаXML.Имя = ЗаголовокНачалоУзла Или ЧтениеФайлаXML.Имя = ЗаголовокНачалоУзла1) Тогда
            СтрокиДанных = АрхивныеДанные.НайтиСтроки(Новый Структура("Ид",Данные.Ид));
            
            СтрокаДляЗаполнения = Неопределено;
            Для Каждого Стр Из СтрокиДанных Цикл
                Если Не ЗначениеЗаполнено(Стр.НомерСтроки) Тогда
                    СтрокаДляЗаполнения = Стр;
                    Прервать;
                КонецЕсли;    
            КонецЦикла;    
            
            Если СтрокаДляЗаполнения = Неопределено Тогда
                СтрокаДляЗаполнения = АрхивныеДанные.Добавить();
                ЗаполнитьЗначенияСвойств(СтрокаДляЗаполнения,СтрокиДанных[0],,"НомерСтроки,НомерКолонки");
            КонецЕсли;    
                
            СтрокаДляЗаполнения.НомерСтроки = Данные.Строчка;
            СтрокаДляЗаполнения.НомерКолонки = Данные.Столбец;
            ПутьЧтения = "";
        КонецЕсли;    
        
        Если ЧтениеФайлаXML.ТипУзла = ТипУзлаXML.НачалоЭлемента И ЧтениеФайлаXML.Имя = ЗаголовокНачалоКоординат И Найти(ПутьЧтения,"Узел") > 0 Тогда
            ПутьЧтения = ПутьЧтения + "Координаты";
        ИначеЕсли ЧтениеФайлаXML.ТипУзла = ТипУзлаXML.КонецЭлемента И ЧтениеФайлаXML.Имя = ЗаголовокНачалоКоординат Тогда
            ПутьЧтения = СтрЗаменить(ПутьЧтения,"Координаты","");    
        КонецЕсли;    
        
        Если ЧтениеФайлаXML.ТипУзла = ТипУзлаXML.НачалоЭлемента И ЧтениеФайлаXML.Имя = ЗаголовокНачалаКоординатСтрока И Найти(ПутьЧтения,"Координаты") > 0 Тогда
            ЧтениеФайлаXML.Прочитать();
            Данные.Вставить("Строчка",Число(ЧтениеФайлаXML.Значение));
        КонецЕсли;    
        
        Если ЧтениеФайлаXML.ТипУзла = ТипУзлаXML.НачалоЭлемента И ЧтениеФайлаXML.Имя = ЗаголовокНачалаКоординатКолонка И Найти(ПутьЧтения,"Координаты") > 0 Тогда
            ЧтениеФайлаXML.Прочитать();
            Данные.Вставить("Столбец",Число(ЧтениеФайлаXML.Значение));
        КонецЕсли;    
            
        Если ЧтениеФайлаXML.ТипУзла = ТипУзлаXML.НачалоЭлемента И ЧтениеФайлаXML.Имя = ЗаголовокНачалаИдентификатора И Найти(ПутьЧтения,"Узел") > 0 Тогда
            Данные.Вставить("Ид",ЧтениеФайлаXML.ПолучитьАтрибут(ИмяАтрибутаИдентификатора));        
        КонецЕсли;    
        
    КонецЦикла;
    
    Возврат АрхивныеДанные;
    
КонецФункции   

 

Специальные предложения

Оставьте свое сообщение

См. также

Копирование числовых ячеек из 1С в Excel Промо

Загрузка и выгрузка в Excel Администрирование данных 1С v8 1cv8.cf Бесплатно (free)

Решение проблемы, когда значения скопированных ячеек из табличных документов 1С в Excel воспринимаются последним как текст, т.е. без дополнительного форматирования значений невозможно применить арифметические операции. Поводом для публикации послужило понимание того, что целое предприятие с более сотней активных пользователей уже на протяжении года мучилось с такой, казалось бы на первый взгляд, тривиальной проблемой. Варианты решения, предложенные специалистами helpdesk, обслуживающими данное предприятие, а так же многочисленные обсуждения на форумах, только подтвердили убеждение в необходимости описания способа, который позволил мне качественно и быстро справиться с ситуацией.

15.01.2019    25404    itriot11    26    

Отпускной период (период основного отпуска) - как его узнать

Зарплата Универсальные функции v8 v8::СПР v8::УФ ЗУП3.x Россия БУ Бесплатно (free)

Пришла мне задача где нужно получить отпускной период, на просторах сети решения я не нашел. Решил поделиться с вами своим решением.

26.10.2020    227    Danila7Zz    2    

Произвольные колонтитулы и повтор шапки таблицы в табличном документе (функция)

Универсальные функции v8 Бесплатно (free)

Пример рекурсивной функции, при помощи которой в табличный документ можно выводить верхний или нижний колонтитулы с произвольным содержимым, а также делать повтор шапки таблицы (или таблиц, если их несколько).

07.10.2020    961    ellavs    1    

Печать в word, pdf через html

Печать Практика программирования Универсальные функции v8 Россия Бесплатно (free)

При работе с клиентами возникла задача: использовать форматированный документ. Итак, существует справочник, в нем табличная часть. Для каждой строки требуется ввести описание, причем описание имеет тип форматированный документ. Потребовалось организовать печать табличной части справочника с описанием для каждой строки. Тип данных "Форматированный документ" не может выводится в табличный документ, поэтому пришлось организовывать печать через Microsoft Word.

11.09.2020    793    arr    4    

Excel vs 1С: битва с неожиданным исходом Промо

Анализ учета Универсальные обработки Загрузка и выгрузка в Excel Финансовые Управленческие v8 1cv8.cf Россия Бесплатно (free)

Что лучше 1С или Excel? Разберемся, в казалось бы, очевидном, чтобы получить невероятное!

11.04.2019    36718    bolefirenko    117    

Самый простой парсинг и обработка веб-страниц в 1С

WEB Универсальные функции v8 1cv8.cf Бесплатно (free)

Рассмотрим самый простой парсинг веб-страниц средствами платформы 1С и еще некоторые полезные приемы работы с веб-страницами.

07.08.2020    4791    YPermitin    18    

Выполнение внешней обработки по расписанию для управляемого и обычного приложения

БСП (Библиотека стандартных подсистем) Универсальные функции v8 1cv8.cf Россия Бесплатно (free)

Использование БСП для выполнения внешних обработок в управляемом и обычном приложении

06.08.2020    1438    RPGrigorev    0    

Пользовательское поле СКД одной процедурой

Практика программирования Универсальные функции v8 Бесплатно (free)

Быстрое создание пользовательского поля "выражение" одной процедурой

05.08.2020    1591    Yashazz    0    

Использование классов .Net в 1С для новичков Промо

Практика программирования Разработка внешних компонент Универсальные функции v7.7 v8 Бесплатно (free)

Руководство для новичков. Написав статью http://infostart.ru/public/238584/, я понял, что многие не понимают того, что написано. Поэтому в этой статье постараюсь более подробно остановиться на азах и без кода на вражеском языке (C#)

27.01.2016    76777    Serginio    108    

Полезные встроенные функции для работы с печатными формами и не только на УТ 11.4 и БП 3.0 (сравнение)

Универсальные функции v8 БП3.0 УТ11 Россия Бесплатно (free)

В данном обзоре приведу примеры встроенных используемых функций для работы с печатными формами на примерах конфигураций Управление торговлей 11.4 и Бухгалтерия 3.0.

10.07.2020    3031    quazare    5    

Вывод дерева в табличный документ СКД

Практика программирования Универсальные функции v8 v8::СКД Бесплатно (free)

Вывод содержимого элемента формы "ДанныеФормыДерево" в табличный документ средствами СКД.

09.07.2020    2653    Yashazz    6    

Ещё немного функционального стиля в 1С или Как нам отфильтровать таблицу значений

Универсальные функции v8 Россия Бесплатно (free)

Потребовалось накладывать хитрые отборы на таблицу значений в сотни строк и десятки колонок, однако Скопировать со структурой отбора мне не подошло. Пришлось немного покреативить, подсмотрев, как это делается в других языках - возможно, получилось несколько топорно, но тем не менее - работает.

16.05.2020    2849    GlebHappy    34    

Из Excel в 1С запросом Промо

Загрузка и выгрузка в Excel v8 1cv8.cf Бесплатно (free)

... ну, конечно, не прям так типовым языком запросов, а расширенным языком запросов. Речь пойдет о том, как "залить" данные в таблицы 1С и не пилить при этом бесконечного количества наколеночных обработок.

14.08.2018    20146    m-rv    5    

Удаление из файла эксель ненужных страниц средствами 1С без COM и через COM

Загрузка и выгрузка в Excel v8 1cv8.cf Бесплатно (free)

Как средствами 1С из файла эксель удалить ненужные листы без COM и с ним. Я разрабатывал на платформе 1С:Предприятие 8.3 (8.3.14.1694)

28.01.2020    2731    pavel_pss    12    

Сходство Джаро - Винклера. Нечеткое сравнение строк

Универсальные функции v8 Россия Бесплатно (free)

В области информатики и статистики сходство Джаро - Винклера представляет собой меру схожести строк для измерения расстояния между двумя последовательностями символов. В публикации рассмотрены некоторые особенности алгоритма, и представлен вариант его реализации на языке 1С.

25.12.2019    7089    brooho    17    

Функция - Формат государственного номера автомобиля

Универсальные функции v8 Автомобили, автосервисы Россия Бесплатно (free)

Возникла необходимость в приведении к единому формату хранящихся, и вводимых вновь, автомобильных Регистрационных знаков - Гос.номер.

23.12.2019    3796    brooho    4    

Универсальные функции с примерами использования Промо

Универсальные функции v8 Бесплатно (free)

14 универсальных функций, с примерами использования - для обычного и управляемого интерфейса

26.02.2016    41323    unichkin    46    

Полезности | Дерево значений | Обычные формы |

Практика программирования Универсальные функции v8 Бесплатно (free)

Полезные функции при работе с деревом значений.

04.12.2019    5711    Mellow    7    

Использование XML-схемы из макета внешней обработки

Обмен через XML Универсальные функции v8 1cv8.cf Бесплатно (free)

Простой способ использования XML-схем из макета внешней обработки.

28.10.2019    10981    Olesia_Matusevich    10    

Быстрое создание наполненных коллекций

Практика программирования Универсальные функции v8 1cv8.cf Бесплатно (free)

Разберем самые частые способы создания коллекции, значения которой известны заранее. И сравним скорость их выполнения.

28.10.2019    7226    SeiOkami    66    

Минимализмы 3 Промо

Практика программирования Универсальные функции v8 Бесплатно (free)

Очередная серия "минимализмов" [http://infostart.ru/public/306536/, https://infostart.ru/public/460935/]. Также, как и в предыдущих статьях, здесь приведена подборка коротких оригинальных авторских решений некоторых задач. Ранее эти решения были разбросаны по моим комментариям к чужим публикациям.

19.02.2018    46811    ildarovich    45    

Преобразование XML в таблицу значений или иной объект 1С методом XSL преобразования

Универсальные функции Обмен через XML v8 1cv8.cf Бесплатно (free)

Сразу открою интригу, напрямую прочитать XML, не содержащий объект 1С, не удастся. Статья раскрывает способы привести XML к формату, который возможно прочитать средствами платформы.

24.10.2019    11525    kraspila    30    

Обертка функций Excel на русском. Ускорение процесса разработки.

Загрузка и выгрузка в Excel Универсальные функции v8 Бесплатно (free)

Устали переключаться с русского на английский и обратно при работе с таблицами Excel из 1С? Сборка наиболее необходимых функций и методов работы с Excel, обернутых в функции 1С на русском языке.

24.10.2019    7284    DmitryKotov    6    

Функция СтрШаблон с именованными маркерами

Универсальные функции v8 1cv8.cf Бесплатно (free)

Функция позволяет задавать именованные маркеры формата [Имя], в отличии от типовых нумерованных формата %n

1 стартмани

21.10.2019    4520    kirinalex    27    

Универсальная функция для программного выполнения СКД Промо

Инструментарий разработчика Универсальные функции v8::СКД 1cv8.cf Бесплатно (free)

Часто встречаются вопросы на форумах о программном формировании СКД. Вроде и информации много по этому поводу, но... Все как всегда :) Собственно, в описании без лишних слов выложен текст общей функции, в которую, для выполнения отчета, нужно передать (минимум 2 параметра): СКД и ТабличныйДокумент.

20.05.2015    30653    dj_serega    18    

Полезняшки по СКД и построителям. Просто код

Практика программирования Универсальные функции v8 v8::СКД Бесплатно (free)

Полезные процедуры и функции для работы с построителями и СКД. Просто исходник.

10.10.2019    10082    Yashazz    45    

Выгрузка из 1С номенклатуры со штрихкодами без программирования

Загрузка и выгрузка в Excel Внешние источники данных v8 УТ11 Россия Бесплатно (free)

Я так и не смог найти простой инструкции или обработки, чтобы выгрузить из 1С: Управление торговлей 11 номенклатуру вместе со штрихкодами, поэтому решил написать собственную инструкцию.

28.08.2019    12551    user1114182    4    

Отслеживание выполнения фонового задания

Практика программирования Универсальные функции Разработка v8 1cv8.cf Бесплатно (free)

Запуск фонового задания из модуля внешней обработки. Отслеживание выполнения задания в виде прогресса, расположенного на форме.

17.08.2019    32047    ids79    16    

Выполнение произвольного кода в фоновых заданиях Промо

Универсальные функции v8 Бесплатно (free)

Если надо быстро провести 100`000 документов...

13.01.2016    24694    unichkin    13    

Загрузка картинок в справочники (Универсальная загрузка из табличного документа)

Обработка справочников Загрузка и выгрузка в Excel v8 1cv8.cf Бесплатно (free)

Пример загрузки картинок в справочник Номенклатура (с помощью обработки универсальная загрузка данных из табличного документа). Проверялось на конфигурации УТ 11.4.7.

28.05.2019    8006    rasdag    5    

Сохранение запроса со всеми параметрами и временными таблицами

Универсальные функции v8 v8::УФ Россия Бесплатно (free)

Функция сохранения запроса со всеми параметрами и временными таблицами в формате *.q1c для открытия в консоли запросов с диска ИТС.

13.05.2019    6523    Serge R    5    

Загрузка из EXCEL в 1С на платформе 8.3.6/8.3.7/8.3.8/8.3.9/8.3.10 (с картинками) Промо

Практика программирования Загрузка и выгрузка в Excel v8 1cv8.cf Бесплатно (free)

Импорт содержимого из файлов в форматах XLS (Microsoft Excel 97), Microsoft Office OpenXML (Microsoft Excel 2007- 2010) и ODS (OpenDocument) в таблицу значений.

06.04.2015    240263    StepByStep    75    

Иерархия справочника Сверху Вниз. Получаем произвольное количество родителей "верхнего" уровня

Практика программирования Универсальные функции Разработка v8 1cv8.cf Бесплатно (free)

Иерархия справочника Сверху Вниз. Функция для получения произвольного количества родителей "верхнего" уровня. На примере справочника "Номенклатура".

28.03.2019    6163    obsfromekb    11    

Доработка проведения типовых документов в УТ 11.4, КА 2.4, ЕРП 2.4

Практика программирования Универсальные функции Разработка v8 v8::УФ ERP2 УТ11 КА2 Россия УУ Бесплатно (free)

Различные варианты корректировки типовых механизмов проведения документов, без корректировки основной конфигурации. Использование расширений, подписок на событие и механизма локализации типовых документов.

22.03.2019    18069    ids79    16    

Повторение строк заголовка на каждой странице при обработке файлов Excel средствами платформы 1С:Предприятие

Практика программирования Загрузка и выгрузка в Excel Разработка v8 Россия Бесплатно (free)

Вопросы повторения строк на каждой странице при работе с файлом Excel из программы, работающей в системе 1С.

23.01.2019    6597    senshkr    3    

Распределение оплаты по товарам Промо

Практика программирования Универсальные функции v8 1cv8.cf Бесплатно (free)

Учебная задача. Оплата приходит по заказу. Требуется запросом распределить её по товарам. Практическая задача была сложнее. Упростил специально для иллюстрации. Сначала собираем в одну таблицу заказы и товары. Затем ОБЪЕДИНТЬ ВСЕ с оплатами. Потом намазываем оплату на товар.

04.08.2014    19176    Трактор    5    

Работа со строками: от простого к сложному

Практика программирования Универсальные функции v8 Бесплатно (free)

Простые примеры работы со строками, в конце более читаемый разбор сложных текстов.

14.01.2019    31678    Evg-Lylyk    17    

Запись одной книги Excel на нескольких листах средствами 1С (без внешних компонент)

Загрузка и выгрузка в Excel v8 1cv8.cf Бесплатно (free)

Пользователи часто просят сохранить им стопиццот отчетов в один файл Excel, чтобы отчеты были в одном файле. Ну или клиент хочет счет, накладную и счет-фактуру получить в одном документе. 1С умеет это делать без всяких там COM-объектов. Давайте разберемся, куда нажимать и что крутить.

14.01.2019    22498    starik-2005    27    

Нумерация колонок субконто при выгрузке набора записей регистра бухгалтерии в таблицу значений

Универсальные функции v8 Бесплатно (free)

Решение проблемы несовпадения номеров колонок с номерами субконто на счете при выгрузке в таблицу значений.

14.01.2019    5663    The Ded    6    

Загрузка из EXCEL в 1С. Чтение файла XLSX средствами 1С. ПостроительDOM Промо

Универсальные обработки Загрузка и выгрузка в Excel Обмен через XML v8 1cv8.cf Бесплатно (free)

ПРАКТИЧЕСКОЕ ПОСОБИЕ РАЗРАБОТЧИКА: Метод "NativeXLSX" (ПостроительDOM). Обрабатываются данные EXCEL типов: "Строка", "Число", "Дата" ("Время"), "Булево", "Процент", а также изображения.

11.09.2014    73523    StepByStep    27    

Как легко загружать данные из электронных таблиц (Excel, OpenOffice и т.д)

Загрузка и выгрузка в Excel v8 1cv8.cf Бесплатно (free)

Как легко загружать данные из электронных таблиц (Excel, OpenOffice и т.д). На примере загрузки в табличную часть документа Поступление товаров и услуг в УТ 11.4.

09.01.2019    13186    rasdag    14    

Многопоточное восстановление последовательностей

Производительность и оптимизация (HighLoad) Практика программирования Математика и алгоритмы Универсальные функции v8 Бесплатно (free)

Универсальный алгоритм многопоточного фонового восстановления любой последовательности.

05.12.2018    13385    _ASZ_    33    

Универсальные функции ЗУП 3.1 / ЗКГУ 3.1, которые помогут в разработке

Универсальные функции Зарплата Управление персоналом (HRM) Зарплата v8 v8::СПР ЗКГУ3.0 ЗУП3.x БУ Бесплатно (free)

В статье размещен список стандартных процедур и функций с примерами, которые могут помочь при разработке (доработке) конфигураций Зарплата и управление персоналом ред. 3.1 и Зарплата и кадры государственного учреждения 3.1. Иногда бывает довольно сложно правильно получить данные или долго, поэтому лучшим вариантом будет использование стандартных процедур. Буду очень признателен, если Вы поделитесь своим опытом и предложите свои варианты стандартных процедур которые помогают в работе. Или предложите, как дополнить имеющиеся процедуры.

14.11.2018    91314    GeterX    121    

Загрузка из EXCEL в 1С. MS ADODB.Connection Промо

Практика программирования Универсальные обработки Загрузка и выгрузка в Excel v8 1cv8.cf Бесплатно (free)

ПРАКТИЧЕСКОЕ ПОСОБИЕ РАЗРАБОТЧИКА: Метод "MS ADODB" (ADODB.Connection). Поддерживаемые типы: *.xls,*.xlsx.

30.11.2012    150185    StepByStep    89    

Кадровые данные сотрудников в ЗУП 3.1 в отчетах

Универсальные функции Управление персоналом (HRM) Управление персоналом (HRM) v8 v8::СПР ЗУП3.x Россия Бесплатно (free)

Параметры используемые для получения данных сотрудников в ЗУП 3.1. Пригодится для разработки отчетов как напоминалка.

07.11.2018    34418    fromlion    23    

Работа с Excel через COM

Загрузка и выгрузка в Excel v8 1cv8.cf Бесплатно (free)

Несколько примеров работы с excel (ms office 2010, в моем случае) через COM.

01.10.2018    10539    jaroslav.h    0    

Выгрузка в Excel с использованием формата OpenXML, разбор файла sheet1.xml

Загрузка и выгрузка в Excel v8 1cv8.cf Бесплатно (free)

Судя по количеству просмотров темы https://infostart.ru/public/900022/ решил описать структуру файла Листа excel. На полноту не претендую, опишу то, что знаю.

21.09.2018    7893    user1045404    2    

Сканируем без сканера или MXL to JPG Промо

Внешние источники данных Универсальные функции Печатные формы документов v8 1cv8.cf Бесплатно (free)

Хотите конвертировать документы в формат изображения менее чем за минуту, не имея сканера? Тогда эта статья для вас.

24.05.2012    34157    shakmaev    47    

Функция НайтиФайлы() в каталоге netshare на Linux - обход ошибки работы

Практика программирования Универсальные функции v8 Бесплатно (free)

Решение проблемы применения функции НайтиФайлы() в каталоге с netshare на Linux-сервере - не работает поиск файлов по указанной маске (шаблону)

19.09.2018    6342    drmaxart    3    

Excel: создание в формате xlsx без COM технологии

Загрузка и выгрузка в Excel v8 1cv8.cf Бесплатно (free)

По работе приходится часто выгружать данные в Excel формате. При большом количестве строк и формул этот процесс достаточно длительный. Решил написать для своих целей небольшую библиотечку для выгрузки данных. Используется технология open-xml. Никаких библиотек не надо, пишу напрямую в xml файлики. На данном этапе сделано форматирование, формулы.

10.09.2018    11528    user1045404    16