Вывод отладочных сообщений HTTP Сервиса с помощью ChromeLogger

Публикация № 705818

Разработка - Практика программирования

ChromeLogger отладка http сервис base64

Разработка для 1C для вывода отладочной информации с помощью ChromeLogger. Есть вопросы к знатокам.

Существует ряд средств для отладки веб-приложений, которые выводят сообщения сформированные на стороне сервера в консоль браузера. 

Рассмотрим как работает одно из таких средств - ChromeLogger (https://craig.is/writing/chrome-logger/techspecs).

На стороне сервера в процессе формирования ответа добавляется заголовок X-ChromeLogger-Data. Значение заголовка формируется так:

1. Формируем json строку вида:

data = {
    "version": "0.2", // версия модуля, который формирует отладочную информацию
    "request_uri": "/", // ресурс
    "columns": ["label", "log", "backtrace", "type"], // перечень колонок
    "rows": [ // массив строк, соответствующих колонкам
        [
            'метка',
            'сообщение/описание/представление объекта',
            'стек вызова',
            'тип отладочного сообщения'
        ]
    ]
}

2. Кодируем строку в UTF8

3. Кодируем строку в Base64

На стороне клиента в браузере Google Chrome установленное расширение Chrome Logger разбирает данный заголовок и выводит информацию в консоль.

 

А теперь реализуем это для 1С

Разработка производится на 8.3.10.2505, УНФ 1.6.12.4. Модули входят в состав расширения. Конфигурация с поддержки не снята.

Нам необходимо где-то хранить информацию, я выбрал ХранилищеОбщихНастроек. Может быть есть лучше вариант?

функция Отладка(Данные, Метка="", Трассировка="", Тип="") экспорт
	ТекущиеДанные = ОбщегоНазначения.ХранилищеОбщихНастроекЗагрузить("ChromeLogger", "ChromeLogger");
	
	если НЕ ЗначениеЗаполнено(ТекущиеДанные) тогда
		ТекущиеДанные = новый ТаблицаЗначений();
		ТекущиеДанные.Колонки.Добавить("log");
		ТекущиеДанные.Колонки.Добавить("label");
		ТекущиеДанные.Колонки.Добавить("backtrace");
		ТекущиеДанные.Колонки.Добавить("type");
	конецесли;

	Запись = ТекущиеДанные.Добавить();	
	Запись.log = Данные;
	Запись.label = Метка;
	Запись.backtrace = Трассировка;
	Запись.type = Тип;
	
	ОбщегоНазначения.ХранилищеОбщихНастроекСохранить("ChromeLogger", "ChromeLogger", ТекущиеДанные);
конецфункции

Теперь сформируем заголовок.

Формируем json строку.

функция СформироватьChromeLoggerJson()
	Таблица = ОбщегоНазначения.ХранилищеОбщихНастроекЗагрузить("ChromeLogger", "ChromeLogger");	
	
	если НЕ ЗначениеЗаполнено(Таблица) ИЛИ Таблица.Количество() = 0 тогда
		возврат неопределено;
	конецесли;
	
	Запись = новый ЗаписьJSON();
	Запись.УстановитьСтроку();
	
	Структура = Новый Структура();
	Структура.Вставить("version", "4.0");
	
	Колонки = Новый Массив();
	Колонки.Добавить("label");
	Колонки.Добавить("log");
	Колонки.Добавить("backtrace");
	Колонки.Добавить("type");	
	
	Структура.Вставить("columns", Колонки);	
	
	Строки = новый Массив();	
	для каждого строка из Таблица цикл
		Значения = Новый Массив();
		Значения.Добавить(КодироватьВUnicodeEscape(строка.label));
		
		//Значения.Добавить(строка.log);				
		Значения.Добавить(КодироватьВUnicodeEscape(строка.log));
		
		Значения.Добавить(КодироватьВUnicodeEscape(строка.backtrace));
		Значения.Добавить(КодироватьВUnicodeEscape(строка.type));
		
		Строки.Добавить(Значения);
	конеццикла;	
	
	Структура.Вставить("rows", Строки);	
	Структура.Вставить("request_uri", "/");
	
	ЗаписатьJSON(Запись, Структура);
	
	Таблица.Очистить();
	
	возврат Запись.Закрыть();		
конецфункции

Все национальные символы должны быть кодированы с помощью escape-последовательностей \uhhhh, где hhhh — шестнадцатеричное число из четырех цифр. Для этого была написана, как быстрое решение, функция КодироватьВUnicodeEscape. Можно ли это сделать "красивее", и желательно по максимум штатными средствами?

функция КодироватьВUnicodeEscape(Строка) 
	Уникод = новый Массив();
	Уникод.Добавить("\u0410");
	Уникод.Добавить("\u0430");
	Уникод.Добавить("\u0411");
	Уникод.Добавить("\u0431");
	Уникод.Добавить("\u0412");
	Уникод.Добавить("\u0432");
	Уникод.Добавить("\u0413");
	Уникод.Добавить("\u0433");
	Уникод.Добавить("\u0414");
	Уникод.Добавить("\u0434");
	Уникод.Добавить("\u0415");
	Уникод.Добавить("\u0435");
	Уникод.Добавить("\u0401");
	Уникод.Добавить("\u0451");
	Уникод.Добавить("\u0416");
	Уникод.Добавить("\u0436");
	Уникод.Добавить("\u0417");
	Уникод.Добавить("\u0437");
	Уникод.Добавить("\u0418");
	Уникод.Добавить("\u0438");
	Уникод.Добавить("\u0419");
	Уникод.Добавить("\u0439");
	Уникод.Добавить("\u041a");
	Уникод.Добавить("\u043a");
	Уникод.Добавить("\u041b");
	Уникод.Добавить("\u043b");
	Уникод.Добавить("\u041c");
	Уникод.Добавить("\u043c");
	Уникод.Добавить("\u041d");
	Уникод.Добавить("\u043d");
	Уникод.Добавить("\u041e");
	Уникод.Добавить("\u043e");
	Уникод.Добавить("\u041f");
	Уникод.Добавить("\u043f");
	Уникод.Добавить("\u0420");
	Уникод.Добавить("\u0440");
	Уникод.Добавить("\u0421");
	Уникод.Добавить("\u0441");
	Уникод.Добавить("\u0422");
	Уникод.Добавить("\u0442");
	Уникод.Добавить("\u0423");
	Уникод.Добавить("\u0443");
	Уникод.Добавить("\u0424");
	Уникод.Добавить("\u0444");
	Уникод.Добавить("\u0425");
	Уникод.Добавить("\u0445");
	Уникод.Добавить("\u0426");
	Уникод.Добавить("\u0446");
	Уникод.Добавить("\u0427");
	Уникод.Добавить("\u0447");
	Уникод.Добавить("\u0428");
	Уникод.Добавить("\u0448");
	Уникод.Добавить("\u0429");
	Уникод.Добавить("\u0449");
	Уникод.Добавить("\u042a");
	Уникод.Добавить("\u044a");
	Уникод.Добавить("\u042b");
	Уникод.Добавить("\u044b");
	Уникод.Добавить("\u042c");
	Уникод.Добавить("\u044c");
	Уникод.Добавить("\u042d");
	Уникод.Добавить("\u044d");
	Уникод.Добавить("\u042e");
	Уникод.Добавить("\u044e");
	Уникод.Добавить("\u042f");
	Уникод.Добавить("\u044f");	
	
	РусскиеБуквы = Новый Массив();
	РусскиеБуквы.Добавить("А");
	РусскиеБуквы.Добавить("а");
	РусскиеБуквы.Добавить("Б");
	РусскиеБуквы.Добавить("б");
	РусскиеБуквы.Добавить("В");
	РусскиеБуквы.Добавить("в");
	РусскиеБуквы.Добавить("Г");
	РусскиеБуквы.Добавить("г");
	РусскиеБуквы.Добавить("Д");
	РусскиеБуквы.Добавить("д");
	РусскиеБуквы.Добавить("Е");
	РусскиеБуквы.Добавить("е");
	РусскиеБуквы.Добавить("Ё");
	РусскиеБуквы.Добавить("ё");
	РусскиеБуквы.Добавить("Ж");
	РусскиеБуквы.Добавить("ж");
	РусскиеБуквы.Добавить("З");
	РусскиеБуквы.Добавить("з");
	РусскиеБуквы.Добавить("И");
	РусскиеБуквы.Добавить("и");
	РусскиеБуквы.Добавить("Й");
	РусскиеБуквы.Добавить("й");
	РусскиеБуквы.Добавить("К");
	РусскиеБуквы.Добавить("к");
	РусскиеБуквы.Добавить("Л");
	РусскиеБуквы.Добавить("л");
	РусскиеБуквы.Добавить("М");
	РусскиеБуквы.Добавить("м");
	РусскиеБуквы.Добавить("Н");
	РусскиеБуквы.Добавить("н");
	РусскиеБуквы.Добавить("О");
	РусскиеБуквы.Добавить("о");
	РусскиеБуквы.Добавить("П");
	РусскиеБуквы.Добавить("п");
	РусскиеБуквы.Добавить("Р");
	РусскиеБуквы.Добавить("р");
	РусскиеБуквы.Добавить("С");
	РусскиеБуквы.Добавить("с");
	РусскиеБуквы.Добавить("Т");
	РусскиеБуквы.Добавить("т");
	РусскиеБуквы.Добавить("У");
	РусскиеБуквы.Добавить("у");
	РусскиеБуквы.Добавить("Ф");
	РусскиеБуквы.Добавить("ф");
	РусскиеБуквы.Добавить("Х");
	РусскиеБуквы.Добавить("х");
	РусскиеБуквы.Добавить("Ц");
	РусскиеБуквы.Добавить("ц");
	РусскиеБуквы.Добавить("Ч");
	РусскиеБуквы.Добавить("ч");
	РусскиеБуквы.Добавить("Ш");
	РусскиеБуквы.Добавить("ш");
	РусскиеБуквы.Добавить("Щ");
	РусскиеБуквы.Добавить("щ");
	РусскиеБуквы.Добавить("Ъ");
	РусскиеБуквы.Добавить("ъ");
	РусскиеБуквы.Добавить("Ы");
	РусскиеБуквы.Добавить("ы");
	РусскиеБуквы.Добавить("Ь");
	РусскиеБуквы.Добавить("ь");
	РусскиеБуквы.Добавить("Э");
	РусскиеБуквы.Добавить("э");
	РусскиеБуквы.Добавить("Ю");
	РусскиеБуквы.Добавить("ю");
	РусскиеБуквы.Добавить("Я");
	РусскиеБуквы.Добавить("я");	
	
	для индекс = 0 по РусскиеБуквы.Количество()-1 цикл
		Строка = СтрЗаменить(Строка, РусскиеБуквы.Получить(индекс), Уникод.Получить(индекс));
	конеццикла;	
	
	возврат Строка;
конецфункции

Далее необходимо кодировать получившееся в utf8, после в base64. Можно ли это сделать без всяких временных файлов?

функция КодироватьВUTF8ИBase64(Строка)
    ВременныйФайл = ПолучитьИмяВременногоФайла();

    Запись = Новый ЗаписьТекста(ВременныйФайл, КодировкаТекста.UTF8);
    Запись.Записать(Строка);
    Запись.Закрыть();
    
    ДвоичныеДанные = Новый ДвоичныеДанные(ВременныйФайл);
    Результат = Base64Строка(ДвоичныеДанные);    
    УдалитьФайлы(ВременныйФайл);
	
	возврат Результат;
конецфункции

Собираем все вместе

функция СформироватьЗаголовокДляChromeLogger()
	json = СформироватьChromeLoggerJson();
	
	если НЕ ЗначениеЗаполнено(json) тогда
		возврат неопределено;
	конецесли;	

	json = СтрЗаменить(json, "\\u", "\u");
	Результат = КодироватьВUTF8ИBase64(json);	
	Результат = СтрЗаменить(СтрЗаменить(СтрЗаменить(СтрЗаменить(Результат, " ", ""), Символы.ПС, ""), Символ(20), ""), Символ(13), "");	
	Результат = Прав(Результат, СтрДлина(Результат)-4);
	
	возврат Результат;
конецфункции

На последнем шаге добавляем заголовок к ответу

функция Ответ(ДанныеJSON) экспорт		
	Ответ = Новый HTTPСервисОтвет(200);
	Ответ.Заголовки.Вставить("Content-Type", "application/json; charset=UTF-8");
	
	ЗаголовокДляChromeLogger = СформироватьЗаголовокДляChromeLogger();
	если ЗначениеЗаполнено(ЗаголовокДляChromeLogger) тогда
		Ответ.Заголовки.Вставить("X-ChromeLogger-Data", ЗаголовокДляChromeLogger);				
	конецесли;
	
	ОбщегоНазначения.ХранилищеОбщихНастроекСохранить("ChromeLogger", "ChromeLogger", неопределено);
	
	Ответ.УстановитьТелоИзСтроки(ДанныеJSON, КодировкаТекста.UTF8, ИспользованиеByteOrderMark.НеИспользовать);	
	Возврат Ответ;	
конецфункции

Таким образом, при вызове в коде функции <ОбщийМодуль>.Отладка("Привет infostart.ru!"); в консоли браузера увидим наше сообщение.

 

В процессе реализации у меня возникли следующие вопросы:

1. Где лучше хранить отладочную информацию (функция Отладка), в случае использования расширений конфигурации?

2. Как "красиво" и правильно закодировать строку в unicode escape-последовательности (функция КодироватьВUnicodeEscape) штатными средствами?

3. Можно ли кодировать строку в base64 штатными средствами без временных файлов?

 

Спасибо. Надеюсь, кому-нибудь мой опыт будет полезен.

 

Обновление №1

Спасибо всем за ответы. 

Переписаны функции 
- КодироватьВUTF8ИBase64 
- КодироватьВUnicodeEscape 
- СформироватьChromeLoggerJson 

// Наименование модуля
// ХромЛогер

// Получить данные отладки
//
// Возвращаемое значение:
// Массив
//
функция ПолучитьДанныеОтладки()
	возврат ОбщегоНазначения.ХранилищеОбщихНастроекЗагрузить("ChromeLogger", "ChromeLogger");
конецфункции

// Установить данные отладки
//
// Параметры:
// Значение - Массив
//
процедура УстановитьДанныеОтладки(Значение)
	ОбщегоНазначения.ХранилищеОбщихНастроекСохранить("ChromeLogger", "ChromeLogger", Значение);
конецпроцедуры	

// Удалить все данные отладки
//
процедура УдалитьДанныеОтладки()
	ОбщегоНазначения.ХранилищеОбщихНастроекСохранить("ChromeLogger", "ChromeLogger", неопределено);
конецпроцедуры	

////////////////////////////////////////////////////////
////////////////////////////////////////////////////////

// Добавляет отладочное сообщение
//
// Параметры:
// Данные - Строка, или Объект
// Метка - Строка
// Трассировка - Строка
// Тип - Строка - возможные значения: log, warn, error, info, group, groupEnd, groupCollapsed, table
//
процедура Отладка(Данные, Метка="", Трассировка="", Тип="") экспорт
	ТекущиеДанные = ПолучитьДанныеОтладки();
	
	если НЕ ЗначениеЗаполнено(ТекущиеДанные) тогда
		ТекущиеДанные = новый Массив();
	конецесли;
	
	СтрокаДанные = новый Массив();
	СтрокаДанные.Вставить(0, Данные);
	СтрокаДанные.Вставить(1, Метка);
	СтрокаДанные.Вставить(2, Трассировка);
	СтрокаДанные.Вставить(3, Тип);
	
	ТекущиеДанные.Добавить(СтрокаДанные);
	
	УстановитьДанныеОтладки(ТекущиеДанные);
конецпроцедуры

// Кодирует строку в UTF8, затем в BASE64
//
// Параметры:
// Строка - Строка, которую необходимо закодировать
//
// Возвращаемое значение:
// Строка - строка в BASE64
//
функция КодироватьВUTF8ИBase64(Строка)
	// Совет http://forum.infostart.ru/forum9/topic181969/message1888978/#message1888978
	Поток = Новый ПотокВПамяти;
	
	ЗаписьДанных = Новый ЗаписьДанных(Поток, КодировкаТекста.UTF8,,,,ложь);
	ЗаписьДанных.ЗаписатьСимволы(Строка);
	ЗаписьДанных.Закрыть();
	
	ДвоичныеДанные = Поток.ЗакрытьИПолучитьДвоичныеДанные();
	Результат = Base64Строка(ДвоичныеДанные);
	
	возврат Результат;
конецфункции	

// Преобразовывает число в шестнадцатеричное представление
//
// Параметры:
// Значение - Число
//
// Возвращаемое значение:
// Строка - шестнадцатеричное представление
//
функция ЧислоВHex(Значение)
	Результат = "";
	
	Пока Значение > 0 Цикл
		Результат = Сред("0123456789ABCDEFGHIJKLMNOPQRSTUVWXYZ", Значение%16 + 1, 1) + Результат;
		Значение = Цел(Значение/16) ;
	КонецЦикла;
	
	Возврат Результат;
конецфункции

// Кодирует строку с использованием escape-последовательностей
//
// Параметры:
// Строка - Строка, которую необходимо преобразовать
//
// Возвращаемое значение:
// Строка - преобразованная строка
//
функция КодироватьВUnicodeEscape(Строка) 
	Результат = "";
	для индекс = 1 по СтрДлина(Строка) цикл		
		Символ = Сред(Строка, индекс, 1);
		КодСимвола = КодСимвола(Символ);
		если КодСимвола > 127 тогда
			Символ = "\u" + Прав("0000" + ЧислоВHex(КодСимвола), 4);
		конецесли;
		
		Результат = Результат + Символ;
	конеццикла;	
	
	возврат Результат;
конецфункции	

// Вспомогательная фукнция для ЗаписатьJSON() в СформироватьChromeLoggerJson()
//
Функция ПреобразованиеJSON(Знач Свойство, Значение, ДопПараметры, Отказ) Экспорт
	// Совет http://forum.infostart.ru/forum9/topic181969/message1888986/#message1888986
	ТипЗначения = ТипЗнч(Значение);
	
	Если ТипЗначения = Тип("ТаблицаЗначений") Тогда
		
		мКолонки = Новый Массив;
		
		Для Каждого Колонка ИЗ Значение.Колонки Цикл
			мКолонки.Добавить(Колонка.Имя);
		КонецЦикла;
		
		СтрКолонки = СтрСоединить(мКолонки, ",");
		
		Массив = Новый Массив;
		
		Для Каждого СтрокаТЗ ИЗ Значение Цикл
			Структура = Новый Структура(СтрКолонки);
			ЗаполнитьЗначенияСвойств(Структура, СтрокаТЗ, СтрКолонки);
			Массив.Добавить(Структура);
		КонецЦикла;
		
		Возврат ПерекодироватьВсеСтрокиВМассивеВUnicodeEscape(Массив);
		
	ИначеЕсли ТипЗначения = Тип("Дата") Тогда
		
		Если НачалоДня(Значение) = '00010101' Тогда
			Возврат Формат(Значение, "ДФ=HH:mm:ss");
		Иначе
			Возврат Формат(Значение, "ДФ='dd.MM.yyyy HH:mm:ss'"); //Игнорим настройки системы
		КонецЕсли;
		
	Иначе
		
		возврат КодироватьВUnicodeEscape(Строка(Значение)); // рискнем и преобразуем в строку
		
	КонецЕсли;
	
КонецФункции

// Перекодирует все строки в массиве (рекурсивно)
//
// Параметры:
// МассивЗначений - Массив
//
// Возвращаемое значение:
// Массив - с перекодированными строками
//
функция ПерекодироватьВсеСтрокиВМассивеВUnicodeEscape(МассивЗначений)
	если ЗначениеЗаполнено(МассивЗначений) И МассивЗначений.Количество() > 0  тогда
		для индекс = 0 по МассивЗначений.Количество()-1 цикл
			Элемент = МассивЗначений.Получить(индекс);
			если ТипЗнч(Элемент) = Тип("Строка") тогда
				МассивЗначений.Установить(индекс, КодироватьВUnicodeEscape(элемент));
			иначеесли ТипЗнч(Элемент) = Тип("Массив") тогда
				МассивЗначений.Установить(индекс, ПерекодироватьВсеСтрокиВМассивеВUnicodeEscape(элемент));
			конецесли;
		конеццикла;	
	конецесли;
	
	возврат МассивЗначений;
конецфункции	

// Сформировать json строку для заголовка ChromeLogger'а
// 
// Возвращаемое значение:
// Строка - JSON
//
функция СформироватьChromeLoggerJson()
	ТекущиеДанные = ПолучитьДанныеОтладки();
	
	если НЕ ЗначениеЗаполнено(ТекущиеДанные) ИЛИ ТекущиеДанные.Количество() = 0 тогда
		возврат неопределено;
	конецесли;
	
	Запись = новый ЗаписьJSON();
	Запись.УстановитьСтроку();
	
	Структура = Новый Структура();
	Структура.Вставить("version", "1.0");
	
	Колонки = Новый Массив();
	Колонки.Добавить("label");
	Колонки.Добавить("log");
	Колонки.Добавить("backtrace");
	Колонки.Добавить("type");	
	
	Структура.Вставить("columns", Колонки);		
	Структура.Вставить("rows", ПерекодироватьВсеСтрокиВМассивеВUnicodeEscape(ТекущиеДанные));	
	Структура.Вставить("request_uri", "/");
	
	ЗаписатьJSON(Запись, Структура,,"ПреобразованиеJSON", ХромЛогер);
	
	УдалитьДанныеОтладки();
	
	возврат Запись.Закрыть();		
конецфункции

// Сформировать заголовок X-ChromeLogger-Data
//
// Возвращаемое значение:
// Строка - BASE64
//
функция СформироватьЗаголовокДляChromeLogger() Экспорт
	json = СформироватьChromeLoggerJson();
	
	если НЕ ЗначениеЗаполнено(json) тогда
		возврат неопределено;
	конецесли;	
	
	json = СтрЗаменить(json, "\\u", "\u");
	Результат = КодироватьВUTF8ИBase64(json);	
	Результат = СтрЗаменить(СтрЗаменить(СтрЗаменить(СтрЗаменить(Результат, " ", ""), Символы.ПС, ""), Символ(20), ""), Символ(13), "");	
	
	возврат Результат;
конецфункции

Пример использования

функция Ответ(ДанныеJSON) экспорт		
	Ответ = Новый HTTPСервисОтвет(200);
	Ответ.Заголовки.Вставить("Content-Type", "application/json; charset=UTF-8");
	
	ЗаголовокДляChromeLogger = ХромЛогер.СформироватьЗаголовокДляChromeLogger();
	если ЗначениеЗаполнено(ЗаголовокДляChromeLogger) тогда
		Ответ.Заголовки.Вставить("X-ChromeLogger-Data", ЗаголовокДляChromeLogger);
	конецесли;
	
	Ответ.УстановитьТелоИзСтроки(ДанныеJSON, КодировкаТекста.UTF8, ИспользованиеByteOrderMark.НеИспользовать);	
	Возврат Ответ;	
конецфункции

 

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. Bassgood 1049 27.11.17 18:30 Сейчас в теме
Можно ли это сделать "красивее", и желательно по максимум штатными средствами?

РусскиеБуквыСтрокой = "А,Б,В,Г,Д";
РусскиеБуквы = СтроковыеФункцииКлиентСервер.РазложитьСтрокуВМассивПодстрок(РусскиеБуквыСтрокой, ",");

Процедуру разложения строки в массив можете выдернуть из БСП и прописать в ней добавление еще букв нижнего регистра, либо дополнить массив букв уже после его формирования, как то так ;)
3. PerlAmutor 107 27.11.17 18:54 Сейчас в теме
(1) Это можно сделать тоже штатными средствами:
РусскиеБуквыСтрокой = "А,Б,В,Г,Д";
РусскиеБуквы = СтрРазделить(РусскиеБуквыСтрокой,",", Ложь));
4. Bassgood 1049 27.11.17 19:16 Сейчас в теме
(3) Можно и так, но на ранних версих 8.3 и ниже не взлетит - этот метод в платформе еще не был реализован.
6. ArchLord42 71 27.11.17 19:34 Сейчас в теме
(1) у автора 8.3.10 там и СтрРазделить можно юзать уже давно
7. ArchLord42 71 27.11.17 19:35 Сейчас в теме
(6) Пока писал уже написали за меня)
2. PerlAmutor 107 27.11.17 18:52 Сейчас в теме
3. Можно ли кодировать строку в base64 штатными средствами без временных файлов?

Сам не пробовал, но связка из этих двух функций глобального контекста в 8.3.11, вероятно может это сделать:
ПолучитьБуферДвоичныхДанныхИзСтроки
ПолучитьBase64СтрокуИзБуфераДвоичныхДанных
5. PerlAmutor 107 27.11.17 19:21 Сейчас в теме
Для функции "КодироватьВUnicodeEscape" данные я бы поместил либо в текстовый макет, либо в двоичный макет, в формате JSON. Соответственно перед вызовом функции хорошо бы эти данные вытащить и подготовить, а не делать этого на лету. Макет хранить в обработке расширения можно.
В 8.3.11 расширения позволяют перехватить УстановкуПараметровСеанса (на выбор, до или после родного обработчика) и создавать прямо в расширении свои Регистры сведений.
8. ArchLord42 71 27.11.17 19:36 Сейчас в теме
получение base64 строки без временных файлов

ТестоваяСтрока = "<<JSON>>>";
	
Поток = Новый ПотокВПамяти;

ЗаписьДанных = Новый ЗаписьДанных(Поток, КодировкаТекста.UTF8,,,,Ложь);
ЗаписьДанных.ЗаписатьСимволы(ТестоваяСтрока);
ЗаписьДанных.Закрыть();

ДД = Поток.ЗакрытьИПолучитьДвоичныеДанные();
Base64Строка = Base64Строка(ДД);
Показать


Странно, у меня на платформе 8.3.10.2466 вылетает ошибка:
Некорректные символы в заголовке HTTP: [X-ChromeLogger-Data: e31zYWRhc2Rhc2Rhc2Rhc2RzZGZnLC5kZnNiZmRuYmxrbmRzZmxrYm5zc3Nzc3Nz c3Nzc3Nzcw==]

чет не кушает base64
9. ArchLord42 71 27.11.17 19:55 Сейчас в теме
Сколько публикаций не видел по HTTP сервисами, ни разу не видел, чтобы юзали 3,4,5 параметры у функции "ПреобразоватьJSON", а их использование может сэкономить приличное количество строк кода и инкапсулировать все преобразования данных, которая 1Ска не может сделать автоматом, достаточно накидать функцию наподобие этой:

Функция ПреобразованияJSON(Свойство, Значение, ДопПараметры, Отказ) Экспорт
	ТипЗначения = ТипЗнч(Значение);
	
	Если ТипЗначения = Тип("ТаблицаЗначений") Тогда
		
		мКолонки = Новый Массив;
		
		Для Каждого Колонка ИЗ Значение.Колонки Цикл
			мКолонки.Добавить(Колонка.Имя);
		КонецЦикла;
		
		СтрКолонки = СтрСоединить(мКолонки, ",");
		
		Массив = Новый Массив;
		
		Для Каждого СтрокаТЗ ИЗ Значение Цикл
			Структура = Новый Структура(СтрКолонки);
			ЗаполнитьЗначенияСвойств(Структура, СтрКолонки);
			Массив.Добавить(Структура);
		КонецЦикла;
		
		Возврат Массив;
		
	ИначеЕсли ЭтоСсылка(Значение) Тогда
		
		Возврат XMLСтрока(Значение);
		
	ИначеЕсли ТипЗначения = Тип("Дата") Тогда
		
		Если НачалоДня(Значение) = '00010101' Тогда
			Возврат Формат(Значение, "ДФ=HH:mm:ss");
		Иначе
			Возврат Формат(Значение, "ДФ='dd.MM.yyyy HH:mm:ss'"; //Игнорим настройки системы
		КонецЕсли;
		
	Иначе
		
		Отказ = Истина;
		
	КонецЕсли;
	
КонецФункции
Показать


и подставить нужные параметры в функцию ЗаписатьJSON
10. MOPC 23 28.11.17 07:38 Сейчас в теме
Большое спасибо всем за советы.

Добавил обновление!
11. Dementor 719 29.11.17 20:38 Сейчас в теме
А можете привести пример использования такой доработки?

Если нужна отладка в процессе разработки, то включаем в конфигураторе автоподключение отладки веб/http-сервисов и наслаждаемся просмотром значений всех переменных и стеком вызовов.
Если нужно решать какую-то проблему связанную с рабочим использованием, то мне кажется более простым способом делать в ключевых точках записи в журнал регистрации с нужным тегом, а потом анализировать накопленные логи.

В вашем решении много кода и установка стороннего расширения в браузере. В чем же преимущества? Да и многопользовательская одновременная работа не очень продумана - под одним пользователем с долгой операцией логи накопятся, а другой клиент с быстрым запросом их прочитает и обнулит для первого пользователя.
12. MOPC 23 30.11.17 02:28 Сейчас в теме
(11) Да, совершенно верно. Можно использовать штатную отладку.
Это все лишь еще один из способов...

А пример использования - только на этапе разработки и если вы работаете в паре с веб-разработчиком, который знает, допустим только javascript/angular, и ему (разработчику) нужна какая то доп.информация.
Dementor; +1 Ответить
13. Dementor 719 30.11.17 12:35 Сейчас в теме
(12) О, про работу в паре с веб-мастером, у которого нет доступа к серверу 1С, я как-то не подумал.
Оставьте свое сообщение

См. также

Использование программных перечислений, ч.1: строковые константы Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Часто ли у вас возникает необходимость в коде выполнять сравнение на строку?

10.12.2016    37241    unichkin    74    

Программная работа с настройками СКД

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Нюансы программной работы с настройками системы компоновки данных в отчетах и динамических списках. Обзор всех видов настроек компоновки. Что в каких случаях правильно применять. В качестве примера рассмотрена работа с отборами и группировками.

27.01.2020    25578    ids79    26    

[СКД] Программное создание схемы компоновки данных

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Сделаем отчет на СКД полностью программно, без использования макета "схема компоновки данных".

15.01.2020    23046    John_d    22    

Последовательности событий. Шпаргалка

Практика программирования v8 Россия Бесплатно (free)

Собрал информацию о событиях/подписках/расширениях в одном месте.

30.12.2019    17605    kuzyara    33    

Вспомогательные инструкции в коде 1С Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Помогаем редактору кода 1С помогать нам писать и анализировать код.

15.10.2018    30100    tormozit    100    

30 задач. Странных и не очень

Практика программирования v8 Бесплатно (free)

30 задач на знание языка программирования 1С и некоторого поведения платформы. Маленьких. Странных и не очень.

02.12.2019    16877    YPermitin    72    

Как передать IP адрес, который вызвал HTTP запрос в 1C (для веб-сервера Apache)

Практика программирования v8 Бесплатно (free)

Столкнулся с задачей получения IP адреса, который вызывает http сервис 1С. Итак, решение:

22.11.2019    8274    Sibars    19    

Таблица значений. Нюансы

Практика программирования v8 Бесплатно (free)

Обзор некоторых аспектов использования общеизвестного инструмента 1С.

01.10.2019    32550    Yashazz    50    

Оформление и рефакторинг сложных логических выражений Промо

Практика программирования v8 Россия Бесплатно (free)

В сложных логических выражениях нередко самому автору спустя какое-то время тяжело разобраться, не говоря уже о других программистах. Предлагаемая методика позволяет повысить наглядность таких выражений путем оформления в виде И-ИЛИ дерева и одновременно выполнять их рефакторинг.

20.09.2012    77861    tormozit    131    

О программе Postman для тестирования API и для чего она нужна 1С-нику

Практика программирования Программное обеспечение (software) v8 Бесплатно (free)

Для чего нужна программа Postman для тестирования API и какая от него польза для 1С-программиста.

24.09.2019    11615    budidich    28    

[Шпаргалка] Программное создание элементов формы

Практика программирования Работа с интерфейсом v8 1cv8.cf Бесплатно (free)

Программное создание практически всех популярных элементов формы.

06.09.2019    48568    rpgshnik    63    

Агрегатные функции СКД, о которых мало кто знает

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Пользуетесь ли Вы всеми возможными агрегатными функциями, которые предоставляет система компоновки данных? Если Вы используете только: СУММА, КОЛИЧЕСТВО, МИНИМУМ, МАКСИМУМ, СРЕДНЕЕ, то эта статья для Вас.

05.09.2019    48485    ids79    54    

Запись значения в поле ввода/формы со срабатыванием события ПриИзменении Промо

Практика программирования v8 1cv8.cf Россия Бесплатно (free)

Иногда возникает необходимость после записи значения в какое либо поле ввода/формы вызвать для него обработчик события ПриИзменении, а о вызове самого события приходится только мечтать. В этой статье приводится программный способ вызова этого события.

11.07.2007    48205    tormozit    41    

Регистры бухгалтерии. Общая информация

Практика программирования Математика и алгоритмы v8 v8::БУ БУ Бесплатно (free)

Общая информация о внутреннем устройстве регистров бухгалтерии.

05.09.2019    27930    YPermitin    24    

Три костыля. Сказ про фокусы в коде

Практика программирования v8 Бесплатно (free)

Три интересных (или странных) костыля в коде, которые могут помочь в повседневных и не очень задачах.

03.09.2019    25336    YPermitin    80    

Отслеживание выполнения фонового задания

Практика программирования Универсальные функции Разработка v8 1cv8.cf Бесплатно (free)

Запуск фонового задания из модуля внешней обработки. Отслеживание выполнения задания в виде прогресса, расположенного на форме.

17.08.2019    31175    ids79    16    

Как сделать из &НаКлиентеНаСервереБезКонтекста почти &НаКлиентеНаСервере Промо

Практика программирования v8 1cv8.cf Россия Бесплатно (free)

Как сделать метод формы, доступный на клиенте и на сервере одновременно, и сохранить при этом удобство разработки

10.09.2017    44640    tormozit    74    

Функции СКД: ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Подробное описание и использование внутренних функций системы компоновки данных: Вычислить, ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив, ВычислитьВыражениеСГруппировкойТаблицаЗначений.

08.08.2019    79853    ids79    49    

Фоновое выполнение кода в 1С - это просто

Практика программирования v8 1cv8.cf Бесплатно (free)

Как легко запускать выполнение в фоне, не прибегая к долгому описанию фоновых процедур.

02.08.2019    34479    avalakh    22    

Разбираемся с параметрами редактирования СКД

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Связь по типу, Параметры выбора, Связи параметров выбора

31.07.2019    23315    json    13    

Выгрузка документа по условию Промо

Практика программирования Разработка v8 Бесплатно (free)

Что делать, если документы нужно выгружать не все подряд, а по какому-то фильтру: статусу, дате, набору условий... А что если он соответствовал этим условиям, а потом перестал? А если потом опять начал? Такие ситуации заставили попотеть не одного программиста.

25.04.2019    16013    m-rv    2    

СКД - наборы данных и связи между ними, создание собственной иерархии, вложенные отчеты

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Набор данных объект. Использование в схеме компоновки нескольких наборов данных. Различные варианты связи наборов: объединение, соединение. Использование иерархии в отчетах на СКД. Создание собственной иерархии, иерархия детальных записей. Использование вложенных схем в отчетах на СКД.

26.07.2019    58322    ids79    11    

СКД - использование расширений языка запросов, секция ХАРАКТЕРИСТИКИ

Инструментарий разработчика Практика программирования v8 v8::СКД Бесплатно (free)

Автоматическое и не автоматическое заполнение полей компоновки данных. Использование расширений языка запросов для СКД «{…}», секция ВЫБРАТЬ, секция ГДЕ, параметры виртуальных таблиц. Автоматизированное использование дополнительных данных в запросе: секция ХАРАКТЕРИСТИКИ.

17.07.2019    35436    ids79    27    

Регистры сведений. За кулисами

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Небольшие заметки по внутреннему устройству регистров сведений.

09.07.2019    25867    YPermitin    14    

Как прикрутить ГУИД к регистру сведений Промо

Практика программирования Перенос данных из 1C8 в 1C8 Разработка v8 Бесплатно (free)

... и немного теории обмена данными. В частности, разберем боль всех, кто пишет небанальные обмены данными: как набору записей регистра сведений назначить гуид и далее использовать его в обмене для идентификации этого набора.

16.04.2019    20143    m-rv    17    

"Меньше копипаста!", или как Вася универсальную процедуру писал

Практика программирования Разработка v8 v8::СКД 1cv8.cf Бесплатно (free)

Программист Вася разбирает подход создания универсальных методов на примере программного вывода СКД.

04.07.2019    19554    SeiOkami    50    

Работа с настройками системы компоновки данных

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Варианты отчетов, работа с настройками вариантов: структура группировок, поля отчета, отборы, сортировка, условное оформление, другие настройки, настройки отображения диаграмм.

02.07.2019    45564    ids79    17    

Создание отчетов с помощью СКД - основные понятия и элементы

Практика программирования Математика и алгоритмы v8 v8::СКД Бесплатно (free)

Основные принципы работы СКД. Понятия схемы компоновки и макета компоновки. Описание основных элементов схемы компоновки: наборы данных, поля, вычисляемые поля, ресурсы, параметры.

25.06.2019    51764    ids79    25    

Как сделать запрос на изменение данных Промо

Практика программирования v8 v8::Запросы 1cv8.cf Бесплатно (free)

В статье приведены особенности внутренней архитектуры и примеры работы с расширением языка запросов 1С.

01.06.2018    30488    m-rv    21    

Многопоточное ускорение однопользовательских нагрузок в 1С + Microsoft SQL Server 2017

Практика программирования Производительность и оптимизация (HighLoad) v8 v8::Запросы Бесплатно (free)

Взаимодействие с Microsoft SQL Server нередко вызывает трудности у 1С-ников, а потому интересны любые моменты, связанные с его использованием. О своем опыте работы с новым SQL Server 2017 участникам конференции Infostart-2018 рассказал директор ООО «Аналитика софт» Дмитрий Дудин.

11.06.2019    24840    dmurk    145    

Регистры накопления. Виртуальные таблицы. Часть №2: "Остатки" и "Остатки и обороты"

Практика программирования v8 1cv8.cf Бесплатно (free)

Описание работы платформы 1С:Предприятие 8.2 с виртуальными таблицами регистров накопления "Остатки" и "Остатки и обороты". Анализ SQL-запрос при работе с виртуальными таблицами

22.05.2019    24324    YPermitin    7    

Регистры накопления. Структура хранения в базе данных

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Структура хранения регистров накопления в базе данных для платформы 1С:Предприятие 8.x. Первая часть в серии публикаций.

16.05.2019    42476    YPermitin    30    

Метод формирования движений в типовых регистрах нетиповыми регистраторами Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Вариант решения задач с проведением по типовым регистрам нетиповыми регистраторами. Зачем - чтобы при сравнении конфигурации не обращать внимание на свойства регистров и исключить вероятность допущения горькой оплошности при обновлении информационных баз, заменив типы регистраторов основной конфигурации типами конфигурации поставщика. Для программных продуктов, имеющих в своем составе метаданных документ "Корректировка регистров"("Корректировка записей регистров").

05.12.2017    28206    itriot11    34    

О расширениях замолвите слово...

Практика программирования Разработка v8 Бесплатно (free)

О чём стоит задуматься при принятии решения о создании расширения конфигурации…

07.04.2019    35152    ellavs    126    

Git-репозитории для 1С-кода (опыт использования при небольших проектах)

Практика программирования v8 Бесплатно (free)

Инструкции по взаимодействию с Git-репозиторием, которые писались для тех наших программистов, которые вообще никогда не работали с Git (руководства в духе "Как получить код из git-репозитория?", "Как отправить код в git-репозиторий")...

28.03.2019    27299    ellavs    89    

Трюки с внешними источниками данных

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Некоторые трюки для преодоления ограничений внешних источников данных.

14.03.2019    31157    YPermitin    53    

Использование классов .Net в 1С для новичков Промо

Практика программирования Разработка внешних компонент Универсальные функции v7.7 v8 Бесплатно (free)

Руководство для новичков. Написав статью http://infostart.ru/public/238584/, я понял, что многие не понимают того, что написано. Поэтому в этой статье постараюсь более подробно остановиться на азах и без кода на вражеском языке (C#)

27.01.2016    76210    Serginio    108    

Ошибки при работе с хранилищем конфигурации и способы их решения

Практика программирования v8 Бесплатно (free)

В статье собраны наиболее распространенные ошибки при работе с хранилищем конфигурации и способы их обхода и решения.

01.03.2019    38674    Смешной 1С    28    

Разработка и сценарное тестирование с Vanessa-ADD. Отчетность Allure. Автоматизация запуска сценариев

Практика программирования Vanessa Automation v8 Россия Бесплатно (free)

Формируем отчетность о результатах выполнения сценариев. Автоматизируем запуск.

26.02.2019    21788    Vladimir Litvinenko    27    

Автоматические и управляемые блокировки применительно к типовым конфигурациям 1С Промо

Математика и алгоритмы Практика программирования v8 v8::blocking 1cv8.cf Бесплатно (free)

Основные принципы работы с режимами автоматических и управляемых блокировок в 1С Предприятие 8. Теория и применение в типовых конфигурациях: БП, УТ, ЕРП

10.11.2018    34532    ids79    40    

Возможности типовых шаблонов ограничения доступа на уровне записей (RLS)

Практика программирования БСП (Библиотека стандартных подсистем) Роли и права v8 v8::Права Бесплатно (free)

Краткий обзор применения типовых шаблонов ограничения доступа на уровне записей в конфигурациях, созданных на базе БСП: #ПоЗначениям, #ПоНаборамЗначений, #ПоЗначениямРасширенный, #ПоЗначениямИНаборамРасширенный

03.02.2019    38942    ids79    9    

Тестер: частые вопросы Промо

Практика программирования v8 Бесплатно (free)

Ошибкам бой - тесты норма жизни!

25.07.2018    29176    grumagargler    28    

EnterpriseData – часть 2. Процесс выгрузки данных

Практика программирования Обмен через XML v8 v8::УФ Россия Бесплатно (free)

Основные этапы выгрузки данных через ED, обработчики событий выгрузки, правила обработки данных, правила конвертации объектов, конвертация свойств первого и второго этапов, процедуры БСП, используемые при выгрузке данных, структура «КомпонентыОбмена».

26.12.2018    26617    ids79    31    

Новый подход к обмену данными EnterpriseData

Практика программирования Обмен через XML v8 v8::УФ Россия Бесплатно (free)

Хочу предложить Вашему вниманию цикл статей, посвященных обмену данными через универсальный формат (EnterpriseData или ED).

14.12.2018    41102    ids79    72    

EnterpriseData - пример доработки правил конвертации без использования КД 3.0 в расширении конфигурации

Практика программирования Обмен через XML v8 v8::УФ БП3.0 УТ11 Россия Бесплатно (free)

В статье подробно описан реальный пример доработки обмена данными через EnterpriseData (универсальный формат обмена) между конфигурациями УТ 11.4 и Бухгалтерия 3.0

16.11.2018    36768    ids79    42    

Ускоряем 1С: модули с повторным использованием возвращаемых значений Промо

Практика программирования v8 Бесплатно (free)

По роду своей деятельности, мне часто приходится обсуждать с программистами детали реализации той или иной функциональности. Очень часто, разговаривая даже с квалифицированными специалистами я сталкиваюсь с незнанием сути платформенной функциональности Повторного использования возвращаемых значений общих модулей. В данной статье я постараюсь дать краткий обзор и основные особенности этой функциональности.

04.09.2017    52498    m-rv    61    

Программное заполнение пользовательских параметров и отборов СКД

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Публикация представляет из себя краткие примеры того, как можно заполнять параметры СКД программно так, чтобы все параметры и отборы были доступны в быстрых настройках и в обычных (типовых) настройках параметров и отборов СКД.

13.11.2018    46904    Unk92    25