Вывод горизонтальных разделителей в отчете на СКД

29.05.10

Разработка - СКД

Многие сталкивались с проблемой  возможности вывода в отчете на СКД горизонтальных разделителей страниц.  В этой статье будет изложено одно из возможных решений для платформы 8.2 для управляемой формы отчета.

Итак, имеем отчет на СКД.


В СКД создаем вычисляемое поле «Горизонтальный разделитель страниц».



На форме отчета создаем команду для вывода отчета с разделителями:


Код команды:

&НаКлиенте
Процедура КомандаСформироватьСРазделителями(Команда)
КомандаСформироватьСРазделителямиСервер();
КонецПроцедуры

&НаСервере
Процедура КомандаСформироватьСРазделителямиСервер()
ДанныеРасшифровкиВ =Новый ДанныеРасшифровкиКомпоновкиДанных;
КомпоновщикМакета =Новый КомпоновщикМакетаКомпоновкиДанных;
МакетКомпоновки =КомпоновщикМакета.Выполнить(Отчеты.Отчет.ПолучитьМакет("ОсновнаяСхемаКомпоновкиДанных"),Отчет.КомпоновщикНастроек.ПолучитьНастройки(),ДанныеРасшифровкиВ);
ПроцессорКомпоновки =Новый ПроцессорКомпоновкиДанных;
ПроцессорКомпоновки.Инициализировать(МакетКомпоновки,,ДанныеРасшифровкиВ);
ПроцессорВывода =Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
Результат.Очистить();
ПроцессорВывода.УстановитьДокумент(Результат);
ПроцессорВывода.НачатьВывод();
ПервыйПропущен =Ложь;
Пока Истина Цикл
ЭлементРезультата =ПроцессорКомпоновки.Следующий();
Если
ЭлементРезультата =Неопределено Тогда
Прервать;
Иначе
Для Каждого
Параметр Из ЭлементРезультата.ЗначенияПараметров Цикл
Если
Параметр.Значение="Горизонтальный разделитель страниц" Тогда
Если
ПервыйПропущен Тогда
Результат.ВывестиГоризонтальныйРазделительСтраниц();
Иначе
ПервыйПропущен=Истина;
КонецЕсли;
Прервать;
КонецЕсли;
КонецЦикла;
ПроцессорВывода.ВывестиЭлемент(ЭлементРезультата);
КонецЕсли;
КонецЦикла;
//Зачистим поля с горизонтальным разделителем страниц
НайденнаяОбласть =Результат.НайтиТекст("Горизонтальный разделитель страниц");
Пока
НайденнаяОбласть<>Неопределено Цикл
НайденнаяОбласть.Текст="";
НайденнаяОбласть =Результат.НайтиТекст("Горизонтальный разделитель страниц");
КонецЦикла;
ПроцессорВывода.ЗакончитьВывод();
ДанныеРасшифровки =ПоместитьВоВременноеХранилище(ДанныеРасшифровкиВ,Новый УникальныйИдентификатор);
КонецПроцедуры



В результате этой команды будет сформирован табличный документ ,  где перед каждым выводом группировки, в которой будет участвовать поле «Горизонтальный разделитель страниц» ,будет выведен горизонтальный разделитель страницы, само поле, как и его заголовок будут выведены пустыми.
Недостатком предложенного способа является образование лишней незаполненной колонки таблицы отчета.

См. также

Инструментарий разработчика Роли и права Запросы СКД Программист Платформа 1С v8.3 Управляемые формы Запросы Система компоновки данных Конфигурации 1cv8 Платные (руб)

Набор инструментов программиста и специалиста 1С для всех конфигураций на управляемых формах. В состав входят инструменты: Консоль запросов, Консоль СКД, Консоль кода, Редактор объекта, Анализ прав доступа, Метаданные, Поиск ссылок, Сравнение объектов, Все функции, Подписки на события и др. Редактор запросов и кода с раскраской и контекстной подсказкой. Доработанный конструктор запросов тонкого клиента. Продукт хорошо оптимизирован и обладает самым широким функционалом среди всех инструментов, представленных на рынке.

10000 руб.

02.09.2020    141084    774    391    

803

Запросы СКД Программист Стажер Система компоновки данных Россия Бесплатно (free)

Часто при разработке отчетов в СКД возникает ситуация, когда не совсем понятно, почему отчет выводит не те данные, которые нужны, либо не выводит вовсе. Возникает потребность увидеть конечный запрос, который формирует СКД. Как это сделать, рассмотрим в этой статье.

15.05.2024    5298    implecs_team    6    

44

Инструментарий разработчика СКД Программист Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

По выбранной схеме компоновки данных генерирует программный код, который генерирует СКД, аналогичную исходной схеме. Есть дополнительные инструменты для просмотра дерева схемы, сравнение исходной схемы и полученной по коду, а также сравнение изменений в сгенерированном коде для исходной схемы и для измененной.

3 стартмани

05.02.2024    5631    43    obmailok    21    

78

Запросы СКД Программист Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Абонемент ($m)

Есть список полей в виде текста, или запрос - закидываем в набор СКД.

1 стартмани

31.01.2024    2607    2    Yashazz    0    

33

СКД WEB-интеграция Программист Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Долгое время поддерживаю web-портал, в котором появилась необходимость создавать отчеты. Просмотрев различные фреймворки на js, я решил сделать свое решение, которое позволяло бы быстро разрабатывать и добавлять новые отчеты на web-портал.

2 стартмани

11.12.2023    9511    21    John_d    25    

124

СКД Программист Платформа 1С v8.3 Система компоновки данных Конфигурации 1cv8 Бесплатно (free)

Рассмотрим еще не получивший широкого распространения способ работы с внешними данным в СКД. В процессе обсуждения работы с СКД выяснилось, что многие не знакомы со способом помещения туда временной таблицы, полученной предварительно. Статья будет полезна разработчикам, знакомым с программным созданием СКД.

05.12.2023    6268    PROSTO-1C    13    

67
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. IronDemon 767 29.05.10 10:51 Сейчас в теме
Опять танцы с бубном :cry:
Когда уже 1С нормальную реализацию сделает.
user712426; chebser; +2 Ответить
2. kravchuk 141 29.05.10 11:58 Сейчас в теме
Да, могли бы в дополнительные свойства группировки ввести свойство "выводить на новой странице" было бы проще.
3. detec 136 10.06.10 14:56 Сейчас в теме
А можно сделать картинку выполненного отчёта, чтобы можно было визуально оценить работу процедуры?
Merkalov; FesenkoA; RailMen; +3 Ответить
4. kravchuk 141 10.06.10 19:03 Сейчас в теме
Тут не так много операций, в любом отчете можешь попробовать сделать.
5. it-kostya 14.06.11 11:16 Сейчас в теме
6. asdPerepel 12 03.09.17 22:42 Сейчас в теме
Здравствуйте !
Скажите, как это сделать на управляемой форме. В частности в БП 3.0. Чёта там сплошные вызовы фоновых заданий ничё не пойму.
&НаКлиенте
Процедура Сформировать()
	ПередФормированиемНаКлиенте();
	ТребуетсяОбработчик = ФоновоеЗаданиеЗапустить(ПеременныеКлиента.ФормированиеПриОткрытии, НастройкиОтчета.Внешний Или НастройкиОтчета.Безопасный);
	Если ТребуетсяОбработчик Тогда
		ДлительныеОперацииКлиент.ИнициализироватьПараметрыОбработчикаОжидания(ПараметрыОбработчика);
		ПодключитьОбработчикОжидания("ФоновоеЗаданиеПроверитьНаКлиенте", 1, Истина);
	Иначе
		ПослеФормированияНаКлиенте();
	КонецЕсли;
КонецПроцедуры
Показать
Оставьте свое сообщение