ЛайфХак: окно с результатами поиска и динамическим позиционированием в найденном

Публикация № 805108

Разработка - Работа с интерфейсом

УФ Управляемые формы Поиск ОтркытьФорму

Вот есть на форме дерево (или макет) с кучей данных. Нажимаем Ctrl+F и находим искомое. А потом еще раз, потом еще, потом еще... Ну и так далее. Есть мысль, как это все улучшить и углубить, ну и решить одну интересную проблему с "модальностью".

Добрый день, господа из Парижу и товарищи из Пекина!

Наш сегодняшний репортаж я веду из стольного города Нерезиновска.

СУТЬ

Суть рассматриваемой проблемы в том, чтобы организовать две формы, в одной из которых мы сможем кликнуть на найденный элемент (или на иной какой), а в другой форме при этом будет произведено позиционирование на нужный элемент (вот прям как на картинке в заголовке).

ДА ДЕЛО

Итак, для организации такой казалось бы простой и элементарной операции нам потребуется внешняя, например, обработка, с парочкой форм: на первой форме мы нарисуем красочное дерево с реквизитами "СтрокаПоиска" и "ОписаниеДанных", добавим туда команду "Найти" и прибиндим обработчики. Во второй форме у нас будет таблица результата, к которой мы прибиндим обработчик активации строки, а в нем уже спозиционируем "курсор" на выбранную строку в вызвавшей поиск форме.

КОД

Код нашей первой формы достаточно прост:


&НаКлиенте
Функция НайтиРекурсивно(Узел, СтрокаПоиска, Массив = Неопределено)
	Если Массив = Неопределено Тогда 
		Массив = Новый Массив;
	КонецЕсли;
	
	Для Каждого Ст ИЗ Узел.ПолучитьЭлементы() Цикл 
		Если Ст.Данные = СтрокаПоиска ИЛИ Ст.ОписаниеДанных = СтрокаПоиска Тогда 
			Массив.Добавить(Новый Структура("НайденнаяСтрока,СтрокаДерева", Ст.Данные + " (" + Ст.ОписаниеДанных + ")", Ст.ПолучитьИдентификатор()));
		КонецЕсли;
		НайтиРекурсивно(Ст, СтрокаПоиска, Массив);
	КонецЦикла;
	Возврат Массив;
КонецФункции

&НаКлиенте
Функция ПоучитьИмяФормы(Имя)
	Возврат СтрЗаменить(ЭтаФорма.ИмяФормы, "ОсновнаяФорма", Имя);
КонецФункции

&НаКлиенте
Процедура НайтиДанные(Команда)
	ПоказатьВводСтроки(Новый ОписаниеОповещения("ПослеВводаСтроки", ЭтаФорма, ), , "Введите строку поиска");
КонецПроцедуры

&НаКлиенте
Процедура ПослеВводаСтроки(Рез, Доп) Экспорт 
	Если НЕ рез = Неопределено Тогда 
		Массив = НайтиРекурсивно(Дерево, Рез);
		Если Массив.Количество() > 0 Тогда 
			ВладелецФормы.ВремВладелецФормы = ЭтаФорма;
			ОткрытьФорму(ПоучитьИмяФормы("ФормаНайдено"), Новый Структура("Данные", Массив), ВладелецФормы, Истина, , , , РежимОткрытияОкнаФормы.БлокироватьОкноВладельца);
		КонецЕсли;
	КонецЕсли;
КонецПроцедуры

Все процедуры и функции - клиентские. Процедура "НайтиДанные" открывает диалог ввода строки, результат которого попадает в процедуру "ПослеВводаСтроки", в которой вызывается рекурсивная функция поиска "НайтиРекурсивно", результатом выполнения которой является массив структур, содержащих имя найденной строки и ее идентификатор.

Дальше, если строку мы нашли, то наша задача открыть форму отображения результатов поиска. И вот тут появляется проблема...

ПРОБЛЕМА

Если мы откроем новую форму в режиме без блокировки, то она отобразится на новой закладке интерфейса такси, и вытащить ее можно будет только через ПКМ с выбором размещения двух форм на одной закладке. Не все пользователи об этом знаю, а я, например, не знаю, как это сделать программно. Да и не устраивает меня статика = хочется управлять размером и положением формы.

Если мы откроем форму в режиме блокировки вызывающей формы, то мы не сможем одновременно работать в этих двух формах, что в некоторых случаях является печалькой (например, если мы нашли сто ошибок, спозиционировались на первой, чтобы ее исправить закрыли форму поиска, исправили, снова вызвали форму поиска и снова закрыли, чтобы исправить вторую ошибку из ста). 

Остается вопрос, а как открыть форму без блокировки владельца, но при этом отдельно от интерфейса такси, чтобы видеть обе формы без бубна и танцев?

РЕШЕНИЕ

Мое решение такое: блокировать третью форму обоими открытыми формами. Это решает все проблемы и позволяет одновременно работать в обоих окнах. Для этого я в обработку добавил еще одну форму  "ГлавнаяФорма", функция которой просто открытие окна и хранение информации о форме-владельце для формы поиска. Вот ее код:

&НаКлиенте
Перем ВремВладелецФормы Экспорт;

&НаКлиенте
Функция ПоучитьИмяФормы(Имя)
	Возврат СтрЗаменить(ЭтаФорма.ИмяФормы, "ГлавнаяФорма", Имя);
КонецФункции

&НаКлиенте
Процедура ПриОткрытии(Отказ)
	ПодключитьОбработчикОжидания("ОткрытьФ", 1, Истина);
КонецПроцедуры

&НаКлиенте
Процедура ОткрытьФ()
	ОткрытьФорму(ПоучитьИмяФормы("ОсновнаяФорма"), , ЭтаФорма, , , , , РежимОткрытияОкнаФормы.БлокироватьОкноВладельца);
КонецПроцедуры

Здесь я в начале формы определяю переменную, в которую помещу открытую форму. Дальше в процедуре "ПриОткрытии" мне пришлось подключить обработчик ожидания, который открыл бы мне вторую форму с деревом. Ну и сама процедура открытия формы, которая вызывается уже после открытия формы (т.к. при открытии формы из процедуры "ПриОткрытии" форма не открывается, что заставило вот так выходить из ситуации).

Ну и код третьей формы со строками поиска, кликание на которые производит позиционирование на элемент дерева второй формы:


&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
	Для Каждого Ст ИЗ Параметры.Данные Цикл 
		ЗаполнитьЗначенияСвойств(Таблица.Добавить(), Ст);
	КонецЦикла;
КонецПроцедуры

&НаКлиенте
Процедура ТаблицаПриАктивизацииСтроки(Элемент)
	ВладелецФормы.ВремВладелецФормы.Элементы.Дерево.ТекущаяСтрока = Элементы.Таблица.ТекущиеДанные.СтрокаДерева
КонецПроцедуры

Все. Цели достигнуты. Всем спасибо за внимание.

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. Daniayr 28.03.18 14:19 Сейчас в теме
у меня сейчас проблема с поиском, обойти все объекты конфигурации и всего их модулю где вставить в запросы РАЗРЕШЕННЫЕ, делаю сижу руками.
может кто подскажет быстрее решение
2. antz 28.03.18 15:05 Сейчас в теме
(1) выгрузить конфигурацию в файлы, написать скрипт
3. Daniayr 28.03.18 16:23 Сейчас в теме
(2) а чуть подробнее пожалуйста?
4. antz 28.03.18 17:30 Сейчас в теме
(3) ну вот вы, грубо говоря, выгружаете конфигурацию в файлы. У вас, мягко выражаясь, получается куча папок с типами метаданных, в которых лежат подпапки с объектами метаданных. В папках с метаданными лежат собственно папки с формами, которые включают в себя файлы форм (с расширением xml) и файлы модулей (с расширением bsl), которые, по сути, обычные текстовые файлы. И вот вы берете эти файлы и парсите - можно средствами той же 1С - на предмет текста запроса и после слова "выбрать" вставляете слово "разрешенные". Потом загружаете конфигурацию из файлов назад.
5. Daniayr 28.03.18 20:03 Сейчас в теме
(4) не подойдет так, ведь просто искать слово "Выбрать". забыл написать Ут 10.3

нужны проверки, это могу быть результат выборки (РезультатЗапроса.Выбрать()), это может быть параметр виртуальной таблици или пакет запросов объединение или вложенные запрос и тд
6. antz 29.03.18 10:12 Сейчас в теме
(5) подойдет, все зависит от вас ведь) От того, какие вы проверки напишете при разборе кода.
7. starik-2005 2325 29.03.18 12:35 Сейчас в теме
Регулярные выражения спасут всех!
Оставьте свое сообщение

См. также

Подбор в управляемой форме - что может быть проще? Промо

Работа с интерфейсом v8::УФ 1cv8.cf Бесплатно (free)

Технологии модальности сейчас меняются на технологии асинхронности, многопоточности и прочие дивные вещи, что, в свою очередь, заставляет людей еще чаще спрашивать о том, что да как в этой новой нелегкой жизни. Разбираемся!

19.09.2017    50254    starik-2005    67    

Предотвращение многократного вызова "ПриПолученииДанных" во время поиска в табличном поле в обычных формах

Работа с интерфейсом Практика программирования v8 Бесплатно (free)

Долго искал решение: как при выводе строк заполнить значениями колонки, которые созданы программно, чтобы, не было тормозов при стандартном поиске. И с минимальными изменениями (легко контролируемыми, при обновлении).

07.04.2021    1664    Vlad_CK    9    

Динамический список и поиск... неприятностей

Работа с интерфейсом Конфигурирование 1С v8 Бесплатно (free)

Страх и ненависть в поиске по динамическому списку, или "Кое-что о неоптимальном отборе".

17.03.2021    2547    Yashazz    37    

Мобильный HTML-интерфейс, взгляд изнутри

Работа с интерфейсом Мобильная разработка v8::Mobile Бесплатно (free)

Для реализации красивого интерфейса в мобильном приложении 1С удобно использовать возможности стека HTML / CSS / JavaScript. О том, как построить отзывчивый HTML-интерфейс с перехватом событий и выполнением JavaScript-кода в поле HTML-документа на форме 1С, рассказал сотрудник отдела мобильной разработки в компании «1С-Рарус» Роман Сухоруков.

28.12.2020    3030    ingeneerz@gmail.com    10    

Недокументированное использование стандартных обработок из меню "Все функции". Промо

Практика программирования Работа с интерфейсом v8 1cv8.cf Бесплатно (free)

Рассмотрены возможности произвольного использования стандартных функций, вызываемых из меню платформы "Все функции" - "Стандартные" (Активные пользователи, Журнал регистрации, Поиск ссылок на объект, Проведение документов ...).

19.06.2015    116813    ekaruk    133    

Программное условное оформление динамического списка, раскраска строк списка по цветам справочника или любым другим условиям (условное оформление)

Практика программирования Универсальные функции Работа с интерфейсом v8 v8::УФ 1cv8.cf Бесплатно (free)

Большое количество динамических списков на форме, большое количество условий, долгое интерактивное добавление условий, оформление по значению элементов справочников - всё это не позволяет использовать интерактивный режим назначения условного оформления динамического списка. В публикации с открытым кодом детально разберем программное решение назначения условного оформления, создадим универсальную функцию для оформления списка.

30.11.2020    4169    SizovE    3    

Установка нескольких фильтров/отбора СКД в табличной форме, хранение в табличной части для отправки push/email уведомлений (ОтборКомпоновкиДанных, КомпоновщикНастроек, ДинамическийСписок)

Работа с интерфейсом Практика программирования v8 v8::УФ v8::СКД Бесплатно (free)

Рассмотрим, как организовать установку фильтров/отбора СКД (динамического списка) на push/email уведомления в подсистеме EDIbot (WebApp) для 1С в табличной части "События уведомлений".

02.11.2020    1262    SizovE    0    

[mobile] Переносим HTML интерфейс на 1С

Работа с интерфейсом Мобильная разработка v8 v8::Mobile 1cv8.cf Бесплатно (free)

Разберем методы переноса HTML интерфейса на 1С на примере реализации нижнего меню для мобильного приложения. Сравним методы между собой. Данные методы можно применять не только для мобильной разработки, но и для веб-клиента и т.д

02.11.2020    7068    leobrn    66    

Полезности применения СКД Промо

Практика программирования Работа с интерфейсом v8::УФ v8::СКД УТ10 Россия Бесплатно (free)

Нюансы при работе из СКД на программном уровне.

11.04.2012    52608    logarifm    42    

Процедура генерации отдельных элементов формы для даты и времени

Работа с интерфейсом v8::УФ 1cv8.cf Бесплатно (free)

Развиваю тему статьи "Раздельный вывод частей даты на форму без программирования" - на этот раз реализовал процедуру для общего модуля, которая из элемента формы реквизита с типом "Дата" генерирует отдельный элемент для времени и выполняет все шаги, указанные в исходной публикации

03.10.2020    757    drmaxart    0    

Рендеринг элементов управляемого интерфейса

Работа с интерфейсом v8 v8::УФ Россия Бесплатно (free)

Реализация отображения всего состояния формы проще, чем работа по изменениям. Однако использование идеи разделения алгоритмов на программные слои MVC и построения реактивных систем позволяет получить не только простые и масштабируемые решения, но и производительные интерфейсы. Рассмотрим примеры таких реализаций на основе использования фреймворка «Управление состоянием»: Информационная надпись, Заголовок формы, Свертываемая группа, Отключаемые панели.

22.09.2020    3614    kalyaka    5    

Переопределение представления ссылочного значения

Практика программирования Работа с интерфейсом v8 Бесплатно (free)

Переопределение представления ссылочного значения

17.09.2020    3966    sam441    15    

Идея или как сохранить ЦВЕТ, ШРИФТ, ОФОРМЛЕНИЕ пользователя Промо

Работа с интерфейсом v8 1cv8.cf Бесплатно (free)

Простой и оригинальный способ сохранять ЦВЕТОВУЮ СХЕМУ и ОФОРМЛЕНИЕ пользователей. Как сохранить ЦВЕТ

22.06.2015    24790    Tatitutu    12    

Дружелюбный интерфейс пометки и отмены пометки в диалоге табличных полей, для управляемых форм.

Работа с интерфейсом v8::УФ Бесплатно (free)

Пример кода пометки и отмены пометки в диалоге табличный полей. Позволяет выставить флажки или какое либо другое значение в табличной части формы, у которой применен отбор.

14.08.2020    3817    DrZombi    15    

Использование флажков в динамических списках

Практика программирования Работа с интерфейсом v8::УФ Бесплатно (free)

В статье расскажу как в динамических списках можно использовать поле флажка для отметки строк. Используемый прием можно использовать не только для галочек, но и для любого поля ввода. Несмотря на то, что редактирование динамических списков напрямую невозможно, есть способ обойти платформу. Подробности в публикации.

04.08.2020    7927    nekit_rdx    28    

Видеодемонстрация применения Теста-центра для нагрузочного тестирования конфигураций Промо

Практика программирования Работа с интерфейсом v8 1cv8.cf Бесплатно (free)

Тест-центр – инструмент автоматизации многопользовательских нагрузочных испытаний информационных систем на платформе 1С:Предприятие 8. С его помощью можно моделировать работу предприятия без участия реальных пользователей, что позволяет оценивать применимость, производительность и масштабируемость информационной системы в реальных условиях. В видео показан пример с внедрением конфигурации Тест-центра в произвольную информационную базу и создание простого сценария нагрузочного теста.

16.09.2012    36118    Aleksey.Bochkov    29    

Обработка нажатия клавиши

Работа с интерфейсом v8::УФ Бесплатно (free)

Один из способов обработки события нажатия клавиши.

10.06.2020    4422    RotaninV    7    

Английский интерфейс для 1С: Управление торговлей. Перенос перевода из 1С: ERP

Работа с интерфейсом v8::ОУ УТ11 Россия УУ Бесплатно (free)

Полноценный англоязычный интерфейс для 1С: Управление торговлей. Я передаю идею, а пользоваться или нет, решайте сами. Надеюсь, эта статья ускорит появление продукта 1C:Trade Management 11.

05.05.2020    2919    _Ramzes    7    

Перенос инструкций из word во встроенную справку 1С с сохранением картинок и форматирования

Практика программирования Работа с интерфейсом v8 Бесплатно (free)

Делюсь простым и удобным способом переноса справки/инструкций из ворда (и не только) во встроенную справку 1С с сохранением картинок и форматирования.

22.04.2020    5215    77dream77    21    

Хранение и редактирование дополнительных параметров в регламентированном отчете. Для начинающих. Промо

Работа с интерфейсом v8 БП2.0 УПП1 БУ Бесплатно (free)

Для начинающих. Как редактировать дополнительные параметры регламентированного отчета, изменив только модуль формы и модуль объекта. Как сохранить дополнительные параметры в данных отчета.

22.01.2014    20904    KapasMordorov    4    

Форма выбора для реквизита с составным типом данных

Работа с интерфейсом v8 Бесплатно (free)

Возник вопрос: как открыть форму выбора для реквизита, имеющего составной тип данных, да еще и отображаемый в виде надписи?

11.03.2020    4467    rule_2    3    

Treemapping — способ визуализации данных древовидной структуры. Карта-схема дерева

Математика и алгоритмы Работа с интерфейсом v8 1cv8.cf Бесплатно (free)

Предлагается ознакомиться с редким способом графического представления иерархических данных. Приводится алгоритм формирования и пример реализации.

18.02.2020    5996    randomus    20    

[Шпаргалка] Свой диалог выбора типа значения (элемента)

Практика программирования Работа с интерфейсом v8 1cv8.cf Бесплатно (free)

Для реквизита составного типа необходимо ограничить список выбора типов.

18.02.2020    4738    rpgshnik    6    

Программное генерирование кнопочек для удобного управления уровнями группировки в отчетах (версия 2a). Промо

Работа с интерфейсом v8 1cv8.cf Россия Бесплатно (free)

В табличных документах 1С 8 имеется отличная возможность использования группировок, но управление уровнями группировок через контекстное меню не очень удобное. В своих отчетах для управления уровнями группировок я использую маленькие кнопочки на поле табличного документа - это намного удобнее и быстрее, чем через контекстное меню.

09.04.2011    46961    mtv:)    74    

Простой и красивый интерфейс

Работа с интерфейсом Мобильная разработка v8::Mobile Бесплатно (free)

Разработчики мобильных приложений на платформе 1С сталкиваются с проблемой адаптации сгенерированного платформой интерфейса под удобство использования. О том, какие приемы помогут сделать интерфейс красивым и удобным, на конференции Infostart Event 2019 Inception рассказал руководитель отдела мобильной разработки компании «1С-Рарус» Никита Бакшеев.

30.01.2020    15160    Baksheev-Nikita    33    

СКД. Шаг 3. Используем макеты для оформления отчета

Работа с интерфейсом v8 v8::СКД 1cv8.cf Бесплатно (free)

В данной публикации рассмотрим базовый подход к использованию собственных макетов в СКД на примере формирования небольшого отчета.

13.01.2020    28069    aximo    16    

Добавление собственного поля и состояния в настройки доступности по состоянию в 1С:Документооборот

Практика программирования Работа с интерфейсом v8 ДО Бесплатно (free)

В данной публикации я хочу описать процесс добавления собственного поля и состояния в функционал настройки доступности по состоянию в 1С:Документооборот.

30.12.2019    5911    pavelpribytkin96    2    

Хитрости компоновки данных: программное формирование заголовков отчета и колонок без использования макетов. Промо

Работа с интерфейсом v8 1cv8.cf Россия Бесплатно (free)

Хитрости компоновки данных: программное формирование заголовков отчета и колонок без использования макетов. Очень часто необходимо программно сформировать заголовок отчета, например добавить туда наименование валюты, в которой формируется отчет. Можно использовать макеты, но во многих случаях это не оправданно.

27.07.2012    32545    milkers    10    

[СКД] Вывод картинки в результат любого отчета на СКД

Работа с интерфейсом v8 v8::СКД 1cv8.cf Бесплатно (free)

Если у вас в справочнике Номенклатура (или другом справочнике) заполнена картинка, то ее можно легко вывести для наглядности отчета.

09.12.2019    11093    John_d    16    

Лайфхаки 1С. Настройка списков (Часть 3)

Работа с интерфейсом v8 Бесплатно (free)

Новая порция лайфхаков по работе с интерфейсом 1С. На этот раз разбираем работу со списками - учимся их упорядочивать, сортировать, создавать новые и перемещать старые. Это очень полезное дополнение к уже имеющимся знаниям по интерфейсу 1С.

03.12.2019    19145    VachKirp    14    

В новой платформе пропала кнопка "Печать". Имитируем БСП

Работа с интерфейсом v8 Россия Бесплатно (free)

"Приятным" сюрпризом для многих пользователей 1С стало то, что при обновлении платформы (начиная с 8.3.15) полностью поменялся интерфейс. Можно долго спорить о целесообразности этого новшества, но самым главным минусом стало то, что пропали стандартные кнопки на панели инструментов. Разработчики предполагают повсеместное использование БСП, но что делать тем, кто давно и успешно использует самописные конфигурации, в которых формирование печатной формы происходит по ТабДок.Показать(), и не желает их "утяжелять"? Добавим общую форму с нужными нам кнопками.

03.12.2019    9988    Vlan    44    

Рабочее место кассира для touch-screen и программируемой клавиатуры продавца в «1С: Розница» Промо

Работа с интерфейсом v8 Розница Бесплатно (free)

Вашему вниманию предлагается текст одного из технических проектов «1С: Розница 8», он описывает процесс разработки интерфейса РМК, с которым, нынче, работают кассиры очень многих магазинов.

29.11.2012    47878    aavolkoff    50    

Управляемые формы. Изменение формы списка или формы объекта без внесения изменений в типовые формы (без использования расширений)

Работа с интерфейсом v8 1cv8.cf Бесплатно (free)

Вносим изменения в типовые формы объектов (документы, справочники, журналы, обработки, общие формы). Не снимая с поддержки эти формы. Создаем программно элементы из общего модуля. Для примера рассмотрю добавление колонки "Скрепка" в форму списка документа. Если к документу привязан файл, то в списке в новой колонке должна отображаться "скрепка".

12.11.2019    14232    John_d    25    

Локализация интерфейсов конфигураций. Практика и инструментарий 1Ci

Работа с интерфейсом Локализация решений v8 Бесплатно (free)

В последнее время компания 1С International все увереннее заявляет о себе на международном рынке. Но для успешного продвижения в этом направлении необходима локализация интерфейсов конфигураций 1С. О том, как выглядит процесс перевода, какие инструменты для этого есть, где брать переводчиков и как проверять их работу, на конференции Infostart Event 2018 Education рассказал руководитель группы локализации компании 1Ci Сергей Поликарпов.

05.11.2019    5828    user1069006    1    

ELK. Время изумительных историй!

Журнал регистрации Работа с интерфейсом v8 1cv8.cf Бесплатно (free)

Всем привет! Сегодня хочу рассказать вам несколько полезных историй про то как нам помог Elastic search в связке с Kibana. Про сам Elastic рассказывать не буду, уже все давным давно описали и до меня. Все обычно говорят что это полезно, это классно. В то же время, очень мало кто рассказывает про практические ситуации: когда и как помог Elastic. Итак, начнем.

31.10.2019    9526    slozhenikin_com    28    

Бухгалтерия предприятия 3.0 интерфейс, аналогичный 1С:Бухгалтерии 7.7; Промо

Работа с интерфейсом v8 БП2.0 Россия Бесплатно (free)

Бухгалтерия предприятия, редакция 3.0, версия 3.0.14. Добавлена возможность использовать интерфейс, аналогичный 1С:Бухгалтерии 7.7;

20.09.2012    37738    dour-dead    18    

Лайфхаки 1С (часть 2) Настройка работы интерфейса такси. Настройка и советы по работе

Работа с интерфейсом v8 1cv8.cf Россия Бесплатно (free)

Советы по настройке интерфейса Такси и особенности работы в этой среде.

24.10.2019    13831    VachKirp    10    

Изменение макета в карточке номенклатуры(УТ 11, КА 2)

Практика программирования Работа с интерфейсом v8::УФ ERP2 УТ11 КА2 Бесплатно (free)

Краткая памятка по выведению добавленного реквизита в справочнике Номенклатура в стандартную карточку номенклатуры в УТ 11, КА 2, ERP 2.

24.10.2019    5296    darkultro37    5    

Создание асинхронных виджетов

Работа с интерфейсом v8 1cv8.cf Бесплатно (free)

Описание нескольких способов создания асинхронных виджетов для 1С:Предприятия. Рассматриваются способы с использованием HTTP-сервисов и фоновых заданий.

16.10.2019    13891    YPermitin    19    

Выбор вариантов отчета в "Управление торговлей" ред. 11 Промо

Работа с интерфейсом Учет ТМЦ Учет ТМЦ v8 УТ10 Россия БУ Бесплатно (free)

В УТ 11 в свойствах конфигурации задано хранилище вариантов отчетов. Исходя из этого, все отчеты будут использовать для своих вариантов именно это хранилище (если, конечно, в свойствах самого отчета не задано другое хранилище). По сути, все варианты для отчетов находятся в справочнике "Варианты отчетов", который заполняется при первом запуске системы. Вполне очевидно, что если Вы создаете свой отчет (внешний или внутренний) с несколькими вариантами, у Вас не будет возможности выбирать нужный вариант (переключаться между вариантами), т.к. в выше указанном справочнике нет никакой информации о вариантах созданного Вами отчета. В этой небольшой статье я покажу один из способов решения данной проблемы.

27.05.2012    48004    1cUserAndrew    25    

Формы. Трудности программной работы

Работа с интерфейсом v8 v8::УФ 1cv8.cf Бесплатно (free)

Рассматриваем основные подводные камни, с которыми приходится сталкиваться при программной работе с формами, а также способы обхода самых частых проблем.

06.10.2019    12745    YPermitin    31    

Лайфхаки 1С (часть 1). Настройки отчетов и печатных форм 1С

Работа с интерфейсом v8 1cv8.cf Россия Бесплатно (free)

Статья рассчитана на пользователей или программистов, которые только начинают работать с 1С, для максимально быстрого ознакомления с интерфейсом программы. В статье приведены лайфхаки, которые позволят вам быстро и эффективно научиться настраивать отчёты и печатные в среде программных продуктов 1С. Полученные знания значительно упростят взаимодействие с интерфейсом 1С и повысят продуктивность работы оператора.

02.10.2019    14820    VachKirp    10    

СКД. Отчеты с картинками

Практика программирования Работа с интерфейсом v8::СКД 1cv8.cf Бесплатно (free)

Решение популярных кейсов с картинками в отчетах на СКД.

25.09.2019    28524    YPermitin    50    

Создаем отчет с заданной периодичностью на СКД Промо

Практика программирования Работа с интерфейсом v8::СКД 1cv8.cf Россия Бесплатно (free)

Учимся создавать отчет с заданной периодичностью с использованием СКД.

16.04.2012    76411    Lyns_owner    36    

Добавляем виджет "Задачи от меня" в Документооборот 2.1

Практика программирования Работа с интерфейсом v8 v8::Бизнес-процессы ДО Россия Бесплатно (free)

Небольшая доработка Документооборота 2.1 для возможности добавления виджета "Задачи от меня" в обработку Текущие дела.

25.09.2019    8879    Sergey_Borisovi4    3    

[Шпаргалка] Программное создание элементов формы

Практика программирования Работа с интерфейсом v8 1cv8.cf Бесплатно (free)

Программное создание практически всех популярных элементов формы.

06.09.2019    81625    rpgshnik    70    

[Механизм интерфейса] Часы

Работа с интерфейсом Практика программирования v8 1cv8.cf Бесплатно (free)

Добавляем цифровые часы на форму, как бонус рассмотрим вариант и с аналоговыми.

26.08.2019    10711    rpgshnik    36    

Практика регулярных выражений в 1С или "парсим неудобные форматы" Промо

Практика программирования Работа с интерфейсом v8 1cv8.cf Россия Бесплатно (free)

В продолжение статьи Использование регулярных выражений (RegExp) в 1С8.х. Углубляемся в практику использования регулярных выражений в 1С. Основы работы с регулярными выражениями хорошо описаны в указанной публикации. А я попробую ответить на вопрос "почему именно регулярные выражения?" на примере конкретной рабочей задачи.

26.10.2011    30345    1cspecialist    33    

Произвольная начальная страница через расширение (программно)

Работа с интерфейсом v8 1cv8.cf Бесплатно (free)

Установка своей формы произвольному пользователю на начальную страницу.

14.08.2019    16963    nagaitseff    15    

Подходы, методы и инструменты UX/UI для разработки эффективных интерфейсов на 1С

Работа с интерфейсом Инструментарий разработчика v8 Бесплатно (free)

Интерфейсам в 1С обычно уделяют мало внимания. Это в итоге снижает востребованность платформы, делает ее неконкурентной, лишает большой доли рынка. Как не потерять старых клиентов и привлекать новых с помощью интерфейсов, а главное – как сделать «правильный» интерфейс, рассказал участникам конференции Infostart Event 2018 Education управляющий партнер и основатель консалтинговой группы WiseAdvice Иван Тягунов.

07.08.2019    12847    IvanAT1981    18    

Форма отчета СКД

Работа с интерфейсом v8::СКД 1cv8.cf Бесплатно (free)

Описание объекта ОбщиеФормы – ФормаОтчета.

01.08.2019    14766    vasilev2015    5    

БСП: Дополнительные отчеты и обработки - одна обработка, несколько форм

Практика программирования Работа с интерфейсом БСП (Библиотека стандартных подсистем) v8 Бесплатно (free)

Как в одной дополнительной обработке разместить несколько форм с типом команды "ОткрытиеФормы"?

29.07.2019    12287    dsdred    10