Больничный лист по беременности и родам

18.02.11

Учетные задачи - Зарплата

По новому законодательству можно теперь начислять пособия по беременности и родам, как по старым правилам, так и по новым, на усмотрение сотрудника. В ЗиК 306 и выше  это не предусмотрено.

В модуле документа "Больничный лист"  в конце процедуры СформироватьСлои() добавить следующие строки:

Если ТипБолезни = Перечисление.ТипБолезни.ПоБеременностиИРодам Тогда
	Форма.Закладки.УдалитьВсе();
	Форма.Закладки.ДобавитьЗначение("Постоянный,Основной","Основная");
	Форма.Закладки.ДобавитьЗначение("Постоянный,Средний2011","Расчет за период после 01.01.2011"); 
	ЕстьЗакладкаПереходногоПериода = 1;
	Форма.Закладки.ДобавитьЗначение("Постоянный,Средний","Средний заработок");
	Форма.Закладки.ДобавитьЗначение("Постоянный,Комментарий","Комментарий");
КонецЕсли;

И в процедуре  Печать(ПараметрПечати = "") строки 6730 добавить:

Если ТипБолезни = Перечисление.ТипБолезни.ПоБеременностиИРодам Тогда
	Печать2010(ПараметрПечати);  
КонецЕсли;

Реализация  расчета

в модуле формы в районе 1318 после строки:

Форма.РасчетВпереходномПериодеПоПравилам2011.Видимость(0);

добавить:

Если (ДатаНачалаСобытия >= ДатаНачалаРеформыСоцСтрахования) И (ТипБолезни = Перечисление.ТипБолезни.ПоБеременностиИРодам) Тогда 
	Форма.РасчетВпереходномПериодеПоПравилам2011.Видимость(1); 
КонецЕсли;

в ГМ в районе 50563 перед строкой: 

НетПереходногоПериода=0;

вместо строки:

Если (ДатаНачалаБолезни < ДатаНачалаРеформыСоцСтрахования) Тогда

пробить (заменить на) строку:

Если (ДатаНачалаБолезни < ДатаНачалаРеформыСоцСтрахования) ИЛИ (ТипБолезни = Перечисление.ТипБолезни.ПоБеременностиИРодам) Тогда

Отпуск по уходу за ребенком. Расчет по-новому и по-старому. Реализация на  //infostart.ru/public/82554/.

См. также

Обмен данными ЗУП 3.1 - Бухгалтерия 7.7

Зарплата Перенос данных 1C Бухгалтерский учет 7.7 Сложные периодические расчеты 1С:Бухгалтерия 7.7 1С:Зарплата и Управление Персоналом 3.x Россия Бухгалтерский учет Платные (руб)

Как известно, Бухгалтерия 7.7 не имеет штатной возможности для обмена с ЗУП 3.1. Данная разработка пригодится тем, кто перешел с ЗиК 2.3 на ЗУП 3.1, но вынужден по каким-то своим причинам оставаться на Бухгалтерии 7.7.

18000 руб.

29.09.2020    13623    2    0    

5

7.7 : Ставки налогов и отчислений. БУХ учет Украина 2014

Зарплата Бухгалтерский учет 7.7 1С:Бухгалтерия 7.7 Украина Бухгалтерский учет НДФЛ Абонемент ($m)

Просто запустим обработку. Файл "СтавкиНалоговЗарплата2014.ert" - выполнить.

1 стартмани

22.01.2014    28515    2    kompas-dm    1    

1

Справка по форме 182Н для 1С:Бухгалтерии 7.7

Зарплата Бухгалтерский учет 7.7 1С:Бухгалтерия 7.7 1С:Производство+Услуги+Бухгалтерия 1С:Упрощенное налогообложение 7.7 Россия Бухгалтерский учет ФОМС, ЕФС Платные (руб)

Новая справка для расчета пособий по временной нетрудоспособности в соответствии с приказом Министерства труда и социальной защиты № 182Н от 30.04.2013 года (учитывая изменения вплоть до 2017 года). Справку необходимо выдавать на руки при увольнении сотрудника. Может помочь при расчете среднего заработка при нетрудоспособности сотрудников. Будет незаменимым помощником для бухгалтеров, осуществляющих расчеты по заработной плате, при отсутствии специализированной программы.

2000 руб.

03.08.2013    81344    31    21    

39

Подготовка сведений в ПФР за 2013 год с распределением суммы уплаченных взносов, превышающих начисленные

Регламентированный учет и отчетность Зарплата Расчет 7.7 1С:Зарплата и кадры 7.7 Россия Бухгалтерский учет ФОМС, ЕФС Абонемент ($m)

При подготовке к сдаче отчета в ПФР столкнулся с тем, что программа не учитывает переплату - не распределяет сумму уплаченных взносов, превышающую начисленную, даже если это оплата проходит в январе 2013 за декабрь 2012. В случае, когда есть долг по оплате на начало периода (например, за декабрь 2012 платят в январе 2013) сумма уплаченных взносов может быть больше суммы начисленных. Программа же ставит сумму уплаченных взносов равную сумме начисленных. В этой обработке распределяются суммы уплаченных взносов, превышающих начисленные, а так же внесены исправления, связанные с возможными ошибками при формировании штатной обработки из 335 релиза (в пачки попадали ненужные уволенные, неправильно распределялись уплаты взносов, при выгрузке в файл возникали ошибки).

1 стартмани

20.04.2013    30960    425    mirrr    65    

41

Расчетная ведомость для 1С:Бухгалтерии 7.7

Зарплата Бухгалтерский учет 7.7 1С:Бухгалтерия 7.7 Россия Бухгалтерский учет Абонемент ($m)

Для бухгалтера : удобный отчет по начислениям-выплатам-удержаниям И повод задуматься о переходе на ЗУП Для программиста : удобный инструмент сверки данных при переходе с 1С:Бухгалтерии 7.7 на 1С:ЗУП 2.5

4 стартмани

01.03.2013    37395    87    Designer1C    7    

10
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. Boroda 90 18.02.11 17:38 Сейчас в теме
Что-т я не допонял: это для конфигурации 1С:Бухгалтерский учёт или для ЗиК 306?
2. lel4ik 60 18.02.11 20:23 Сейчас в теме
3. Гена 18.02.11 22:18 Сейчас в теме
Вы дали поправку не в модуле дока, а в модуле формы...
поэтому вкладка то появилась... и две печатные формы... а вот сам расчёт идёт только по-новому...

добавьте:
1. крыжик или переключатель выбора варианта расчёта
2. ну и по п.1 само ветвление расчёта в ГМ(?)
konyavka; lookindenis; +2 Ответить
4. Гена 18.02.11 23:21 Сейчас в теме
для реализации (3) предлагаю:
1. в модуле формы в районе 1318 после строки
Форма.РасчетВпереходномПериодеПоПравилам2011.Видимость(0);

добавить:
Если (ДатаНачалаСобытия >= ДатаНачалаРеформыСоцСтрахования) И (ТипБолезни = Перечисление.ТипБолезни.ПоБеременностиИРодам) Тогда
Форма.РасчетВпереходномПериодеПоПравилам2011.Видимость(1);
КонецЕсли;


2. в ГМ в районе 50563 перед строкой:
НетПереходногоПериода=0;

вместо строки
Если (ДатаНачалаБолезни < ДатаНачалаРеформыСоцСтрахования) Тогда

пробить (заменить на) строку
Если (ДатаНачалаБолезни < ДатаНачалаРеформыСоцСтрахования) ИЛИ (ТипБолезни = Перечисление.ТипБолезни.ПоБеременностиИРодам) Тогда
Nicholas; artbear; MANEK; lel4ik; +4 Ответить
18. Anatolka 2 16.03.11 11:58 Сейчас в теме
и всетаки как выбрать метод расчета? из (3) поправка 1 так тут и не добавили?
5. lel4ik 60 19.02.11 12:04 Сейчас в теме
6. Гена 20.02.11 09:22 Сейчас в теме
(5) надо всё доделывать до конца... поправки касаются не только б/л по декрету, но и отпуска по уходу...

сделайте аналогичные изменения и в доке ОУ - две вкладки среднего и выбор расчёта по новому или по старому...
7. lel4ik 60 20.02.11 11:03 Сейчас в теме
Я начинающий программист, так что сильно не ругайтесь. А вообще большое спасибо за поправки. Учить меня некому, учусь сама.
8. ZolotareffOY 25.02.11 11:14 Сейчас в теме
Здравствуйте !!!
Я не програмист. Как редактировать модули не знаю.
А больничный по беремености и родам уже нужно расчитывать. Какие есть еще варианты расчета больничного.
У меня девочка работает 8 месяцев, а программа даже в расчет январь 2011 года месяца не берет.
9. Гена 25.02.11 13:02 Сейчас в теме
так, господа... сейчас ДАМ подписал поправки... с БиР здесь разобрались... надо делать и ОУ (отпуск по уходу за ребёнком)... хватит лодырничать...
13. Nicholas 893 10.03.11 14:28 Сейчас в теме
(9) Форма документа ОтпускПоУходуЗаРебенком:

1. Добавляем новый реквизит на форму:
//Nicholas modified ОАО "Рога и копыта" 05.03.2011
//Comments: О внесении изменений в Федеральный закон «Об обязательном социальном страховании на случай временной нетрудоспособности и в связи с материнством...
//Диалог: изменен
// Новый реквизит NРасчетС2011
//Модуль: изменен
//Таблицы: без изменений


2. В процедуре РассчитатьСреднийЗаработок():
//Nicholas [<>] ОАО "Рога и копыта" 05.03.2011 17:57:28
//Comments: О внесении изменений в Федеральный закон «Об обязательном социальном страховании на случай временной нетрудоспособности и в связи с материнством...
//Been:
//Если ТипРасчетаБольничного=Перечисление.ТипРасчетаБольничного.С2011года Тогда
//Turn:

Если (ТипРасчетаБольничного = Перечисление.ТипРасчетаБольничного.С2011года)
И (
NРасчетС2011 = 1) Тогда
//EndNicholas [<>]


3. В Процедуре Печать():
//Nicholas [<>] ОАО "Рога и копыта" 05.03.2011 17:58:40
//Comments: О внесении изменений в Федеральный закон «Об обязательном социальном страховании на случай временной нетрудоспособности и в связи с материнством...
//Been:
//Если ТипРасчетаБольничного=Перечисление.ТипРасчетаБольничного.С2011года Тогда
//Turn:

Если (ТипРасчетаБольничного = Перечисление.ТипРасчетаБольничного.С2011года)
И (
NРасчетС2011 = 1) Тогда
//EndNicholas [<>]

4. В Процедуре СформироватьСлои() после Форма.Закладки.ДобавитьЗначение("Постоянный,Средний2011", "Средний заработок"):
//Nicholas [+] ОАО "Рога и копыта" 04.03.2011 18:39:02
//Comments: О внесении изменений в Федеральный закон «Об обязательном социальном страховании на случай временной нетрудоспособности и в связи с материнством...

Форма.Закладки.ДобавитьЗначение("Постоянный,Средний", "Расчет за период до 01.01.2011");
//EndNicholas [+]
10. Ulfhedhinn 249 01.03.11 02:49 Сейчас в теме
Очень хорошо, но плюсовать пока не буду. Оформите пост с учетом предложенных Геной поправок и не забудьте про отпуск по уходу. А еще желательно переоформите это для 307 релиза. Щас снова возникнет ситуация, что каждый будет постить свои маленькие поправочки и собирать урожай плюсов. Давайте уж лучше пусть урожай соберет один человек, зато пост действительно будет стоить урожая ;)
11. lushka 6 10.03.11 08:56 Сейчас в теме
Такой еще косяк вылез - в глобальнике
глСобратьДанныеДляБЛ2010
было
//ПредельнаяВеличинаБазы = Константа.ПредельнаяВеличинаБазыСтраховыхВзносов.Получить(КонГода(ДатаОграничения));
стало
ПредельнаяВеличинаБазы = Окр((Константа.ОграничениеРазмераБЛ.Получить(КонГода(ДатаОграничения))) * 12,2);


ссылается на предельную величину базы страховых взносов, которая до 01.01.2011 была равна 415000, а теперь 463000 в итоге неправильно ограничивает размер пособия
Nicholas; +1 Ответить
12. Nicholas 893 10.03.11 11:40 Сейчас в теме
(11) ОграничениеРазмераБЛ = 18720.00, умножаем на 12, получаем - 224640.00.

Предлагаю сделать так:
//ОдноЦе [<>] ОАО "Рога и копыта" 10.03.2011 16:00:51
//Comments: Используем предельную величину базы страховых взносов 2010-го года
//Been:
//ДатаОграничения = Макс(ДатаПереходаНаСтраховыеВзносы,ДатаНачалаБолезни);
//Turn:

ДатаОграничения = Мин(Макс(ДатаПереходаНаСтраховыеВзносы, ДатаНачалаБолезни), '31.12.2010');
//EndОдноЦе [<>]

И, видимо, нужно еще внести изменения в глСобратьДанныеДляБЛ2011:
//ОдноЦе [<>] ОАО "Рога и копыта" 10.03.2011 16:30:56
//Comments: Используем предельную величину базы страховых взносов 2010-го года
//Been:
//ПредельнаяВеличинаБазы2010 = Константа.ПредельнаяВеличинаБазыСтраховыхВзносов.Получить(КонГода(ДатаНачалаБолезни));
//Turn:

ПредельнаяВеличинаБазы2010 = Константа.ПредельнаяВеличинаБазыСтраховыхВзносов.Получить(КонГода(Мин(ДатаНачалаБолезни, '31.12.2010')));
//EndОдноЦе [<>]
14. lushka 6 11.03.11 05:01 Сейчас в теме
Nicholas пишет:
(11) ОграничениеРазмераБЛ = 18720.00, умножаем на 12, получаем - 224640.00.

ну это смотря в каком регионе :) у нас например - 34583,34
а вобще, да, не совсем правильно, поторопилась
16. yugraman 14.03.11 07:57 Сейчас в теме
lushka пишет:
[IS-QUOTE]Nicholas пишет:
(11) ОграничениеРазмераБЛ = 18720.00, умножаем на 12, получаем - 224640.00.

ну это смотря в каком регионе у нас например - 34583,34[/IS-QUOTE]

От региона ж не зависит, везде 415000/12=34583,33. А предел 18720.00 не используется с 2010 года.
15. yugraman 14.03.11 07:47 Сейчас в теме
lushka пишет:

Такой еще косяк вылез - в глобальнике
глСобратьДанныеДляБЛ2010
было
//ПредельнаяВеличинаБазы = Константа.ПредельнаяВеличинаБазыСтраховыхВзносов.Получить(КонГода(ДатаОграничения));
стало
ПредельнаяВеличинаБазы = Окр((Константа.ОграничениеРазмераБЛ.Получить(КонГода(ДатаОграничения))) * 12,2);


ссылается на предельную величину базы страховых взносов, которая до 01.01.2011 была равна 415000, а теперь 463000 в итоге неправильно ограничивает размер пособия

А где сказано, что должен использоваться предел 415000? В п.19.1 Постановления 375 сказано "Средний дневной заработок, из которого исчисляются пособия по временной нетрудоспособности, по беременности и родам застрахованным лицам, не может превышать средний дневной заработок, определяемый путем деления предельной величины базы .... на день наступления страхового случая, на 365". Это изменение внесено до закона 21-ФЗ и его не отменяли. Так что для отпуска по беременности и родам в 2011 г. вроде как надо использовать текущее значение предела - 463000р.
17. SotnikovEO 16.03.11 08:40 Сейчас в теме
Не учтено что больничный может быть продолжение, при печати не учтено что больничный может рассчитываться по правилам 2011 года.
Вот мои дополнения к поправкам больничного (смотреть метки SEO):
//------> Процедура СформироватьСлои()
Процедура СформироватьСлои()

Форма.Закладки.УдалитьВсе();
Форма.Закладки.ДобавитьЗначение("Постоянный,Основной","Основная");
ЕстьЗакладкаПереходногоПериода = 0;
Если (ТипРасчетаБольничного=Перечисление.ТипРасчетаБольничного.С2011года) Тогда

Если (ДатаНачалаСобытия < ДатаНачалаРеформыСоцСтрахования) и (Окончание >= ДатаНачалаРеформыСоцСтрахования) Тогда

Если ПервичныйБольничный.Выбран() = 0 Тогда
Форма.Закладки.ДобавитьЗначение("Постоянный,Средний2011","Расчет за период после 01.01.2011");
ЕстьЗакладкаПереходногоПериода = 1;
Форма.Закладки.ДобавитьЗначение("Постоянный,Средний","Средний заработок");
Иначе
// проверим есть ли в первичном БЛ данные заработка
ПредыдущийПервичный = ПервичныйБольничный;
Пока ПредыдущийПервичный.ПервичныйБольничный.Выбран() = 1 Цикл
ПредыдущийПервичный = ПредыдущийПервичный.ПервичныйБольничный;
КонецЦикла;
ПервичныйДокумент = ПредыдущийПервичный;

Если (ПервичныйДокумент.ЗаработокЗаПервыйГод+ПервичныйДокумент.ЗаработокЗаВторойГод
+ПервичныйДокумент.ЗаработокЗаПервыйГодДругиеСтрахователи
+ПервичныйДокумент.ЗаработокЗаВторойГодДругиеСтрахователи) = 0 Тогда
Форма.Закладки.ДобавитьЗначение("Постоянный,Средний2011","Расчет за период после 01.01.2011");
КонецЕсли;
КонецЕсли;
ИначеЕсли (ПустоеЗначение(Окончание) = 0) и (Окончание < ДатаНачалаРеформыСоцСтрахования) Тогда
Форма.Закладки.ДобавитьЗначение("Постоянный,Средний","Средний заработок");
ИначеЕсли ПервичныйБольничный.Выбран() = 0 Тогда
//{seo
//Форма.Закладки.ДобавитьЗначение("Постоянный,Средний2011","Средний заработок");
Если ТипБолезни = Перечисление.ТипБолезни.ПоБеременностиИРодам Тогда
ЕстьЗакладкаПереходногоПериода = 1;
Форма.Закладки.ДобавитьЗначение("Постоянный,Средний","Средний заработок");
Форма.Закладки.ДобавитьЗначение("Постоянный,Средний2011","Расчет за период после 01.01.2011");
Иначе
Форма.Закладки.ДобавитьЗначение("Постоянный,Средний2011","Средний заработок");
КонецЕсли;
//seo}
КонецЕсли;
//------> Процедура Печать()
Процедура Печать(ПараметрПечати = "")

Если ((Проведен()=0)или(Модифицированность()=1)) Тогда
Если Вопрос("Распечатать можно только записанный документ."+РазделительСтрок+" Записать и распечатать документ?","Да+Нет")="Нет" Тогда
Возврат
КонецЕсли;
Если ПередЗаписью()=0 Тогда
глОткрытьОбработчик(ОбработчикСообщений, Вид()+НомерДок);
Возврат
Иначе
Записать();
КонецЕсли;
КонецЕсли;

Если ПустоеЗначение(ДатаНачалаСобытия)=1 Тогда
//ПолучитьДатуНачалаСобытия();
ДатаНачалаСобытия = глПолучитьДатуНачалаСобытияБЛ(Контекст)
КонецЕсли;

Если ДатаНачалаСобытия < '01.01.2005' Тогда
Печать2004(ПараметрПечати)
ИначеЕсли ДатаНачалаСобытия < '01.01.2006' Тогда
Печать2005(ПараметрПечати);
ИначеЕсли ТипРасчетаБольничного=Перечисление.ТипРасчетаБольничного.С2011года Тогда
//{seo
//Печать2011(ПараметрПечати);
Если ТипБолезни=Перечисление.ТипБолезни.ПоБеременностиИРодам Тогда
Если (ЗаработокЗаВторойГод+ЗаработокЗаПервыйГод+ЗаработокЗаВторойГ­одДругиеСтрахователи+ЗаработокЗаПервыйГодДругиеСтрахователи)>0 Тогда
Печать2011(ПараметрПечати);
Иначе
Печать2010(ПараметрПечати);
КонецЕсли;
Иначе
Печать2011(ПараметрПечати);
КонецЕсли;
//seo}
ИначеЕсли ТипРасчетаБольничного=Перечисление.ТипРасчетаБольничного.С2010года Тогда
Anatolka; +1 Ответить
19. lefthander 01.04.11 17:38 Сейчас в теме
Anatolka пишет:
всетаки как выбрать метод расчета?

Только дополнив шапку реквизитом и выводом его на форму в виде флажка.
Я другого способа не вижу.
Останавливает пока то, что через 1-2 релиза 1С введет свой реквизит и все созданные документы придется править.
Как всегда. Но расчетчики прижали... видимо с 4 апреля буду вводить у себя, ждать 1с уже трудно.
20. корум 288 05.04.11 18:41 Сейчас в теме
Если в тему заглядывают несчастные, кому приходится бороться с Комплексной - кроме вышеописанных танцев с бубном не забудьте поправить отчет РасходыПредприятияЗаСчетФСС.
Строка 1682, меняем
		Если Документ.ТипРасчетаБольничного=Перечисление.ТипРасчетаБольничного.С2010года Тогда

на
		Если (Документ.ТипРасчетаБольничного=Перечисление.ТипРасчетаБольничного.С2010года) ИЛИ ((Документ.типБолезни = Перечисление.ТипБолезни.ПоБеременностиИРодам) и (Документ.флРасчетс2011=0))  Тогда


Иначе при печати оборотного листа вместо нужных цифр увидим нули.

Глобальный модуль, процедура глСобратьДанныеДляБЛВыбор

//Если Документ.ТипРасчетаБольничного = Перечисление.ТипРасчетаБольничного.С2010года Тогда
Если (Документ.ТипРасчетаБольничного = Перечисление.ТипРасчетаБольничного.С2010года)
или ((Документ.флрасчетс2011 = 0) и (документ.ТипБолезни = перечисление.ТипБолезни.ПоБеременностиИРодам))
21. safia-med 03.09.14 12:13 Сейчас в теме
как выбрать метод расчета?
Оставьте свое сообщение